Collect SentinelOne Attivo (formerly Attivo Networks) logs
Parser Version: 9.0
This document explains how to ingest SentinelOne Attivo (formerly known as Attivo Networks) logs to Google Security Operations using Bindplane.
SentinelOne Attivo is a deception technology platform that detects in-network threats, lateral movement, and credential-based attacks. It deploys decoys and lures across the environment to detect attackers who have bypassed perimeter defenses. Attivo forwards detection events and alerts via syslog.
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance.
- A Windows 2016 or later or Linux host with systemd.
- If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements.
- Privileged access to the SentinelOne Attivo BOTsink management console.
Get Google SecOps credentials for the Bindplane agent
To authenticate the Bindplane agent to Google SecOps, choose one of the following methods:
- New deployments: Use the Chronicle API (Option 1).
- Legacy deployments: Continue using the ingestion authentication file (Option 2) until the Ingestion API is discontinued on July 20, 2027.
Option 1: Create a service account for the Chronicle API (recommended)
- Sign in to the Google Cloud console and select the Google Cloud project that is linked to your Google SecOps instance.
- Go to IAM & Admin > Service Accounts.
- Click Create service account.
- Provide the following configuration details:
- Service account name: Enter a name for the account (for example,
bindplane-ingest). - Service account description: Enter a description (for example,
Bindplane agent log ingestion).
- Service account name: Enter a name for the account (for example,
- Click Create and continue.
- In the Grant this service account access to project section, click Select a role and select Chronicle Editor.
- Click Continue, and then click Done.
- Click the service account you created, and then go to the Keys tab.
- Click Add key > Create new key.
- Select JSON and click Create. The key file is downloaded to your computer.
- Save the key file as
ingestion-auth.jsonin the Bindplane collector directory (/opt/observiq-otel-collector/ingestion-auth.jsonon Linux orC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.jsonon Windows), or updatecreds_file_pathinconfig.yamlto match the path where you save it. - Go to IAM & Admin > Settings and copy the Project number. You'll need it for the exporter configuration.
Option 2: Download the ingestion authentication file (legacy)
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agents.
- Download the ingestion authentication file.
- Save the file securely on the system where the Bindplane agent will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
- Copy and save the Customer ID from the Organization Details section.
Install the Bindplane agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows installation
- Open the Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
Additional installation resources
For additional installation options, consult this installation guide.
Configure the Bindplane agent to ingest syslog and send to Google SecOps
Access the Configuration File:
- Locate the
config.yamlfile. Typically, it's in the/observiq-otel-collector/directory on Linux or in the installation directory on Windows. - Open the file using a text editor (for example,
nano,vi, or Notepad).
- Locate the
Edit the
config.yamlfile as follows:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <your_customer_id> endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'ATTIVO' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- Replace the port and IP address as required in your infrastructure.
- Replace
<LOCATION>with the region of your Google SecOps instance (for example,us,europe, orasia-southeast1). The exporter prefixeschronicle.googleapis.comwith this value. - Replace
<PROJECT_NUMBER>with the project number from IAM & Admin > Settings. - Replace
<your_customer_id>with the actual Customer ID. - Update
/path/to/ingestion-authentication-file.jsonto the file path where the service account key file (Option 1) was saved in Step 1.
Legacy ingestion API exporter
If you use the ingestion authentication file from Option 2, replace the
exportersblock with the following. Setcreds_file_pathto the path to the ingestion authentication file, and if your instance is outside the US, replacemalachiteingestion-pa.googleapis.comwith your regional endpoint (for example,europe-malachiteingestion-pa.googleapis.com).exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <your_customer_id> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'ATTIVO' raw_log_field: body ingestion_labels:
Restart the Bindplane agent to apply the changes
To restart the Bindplane agent in Linux:
Run the following command:
sudo systemctl restart observiq-otel-collectorVerify the service is running:
sudo systemctl status observiq-otel-collectorCheck logs for errors:
sudo journalctl -u observiq-otel-collector -f
To restart the Bindplane agent in Windows:
Choose one of the following options:
- Command Prompt or PowerShell as administrator:
net stop observiq-otel-collector && net start observiq-otel-collector- Services console:
- Press
Win+R, typeservices.msc, and press Enter. - Locate observIQ OpenTelemetry Collector.
- Right-click and select Restart.
- Press
Verify the service is running:
sc query observiq-otel-collectorCheck logs for errors:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Configure SentinelOne Attivo syslog forwarding
Create a CEF syslog profile
- Sign in to the Attivo BOTsink management console.
- Go to Administration > Management > Syslog.
- Click Add to create a new syslog profile.
- Enter a descriptive name for the profile (for example,
SecOps-CEF). - Set Event Forwarding to Enabled.
- Select CEF as the Message Format.
- Configure the severity mapping for events:
- Very High: Select Emergency.
- High: Select Critical.
- Medium: Select Alert.
- Low: Select Warning.
- Very Low: Select Informational.
- Click Save to save the syslog profile.
Add a syslog server connection
- In the syslog profile you created, click Add New Connection.
- Provide the following connection details:
- Server Name: Enter a descriptive name for the connection (for example,
Bindplane-Agent). - Profile Name: Select the CEF syslog profile created in the previous section.
- IP Address: Enter the IP address of the Bindplane agent host (for example,
192.168.1.100). - Port: Enter
514(or your configured Bindplane agent port). - Protocol: Select TCP.
- Server Name: Enter a descriptive name for the connection (for example,
- Click Test Connection to verify that BOTsink can reach the Bindplane agent.
- Click Save.
Verify syslog delivery
- After configuring syslog forwarding, trigger a test alert or wait for a detection event.
On the Bindplane agent host, verify that logs are being received:
sudo journalctl -u observiq-otel-collector -f
For more information, see the SentinelOne Attivo documentation.
UDM mapping table
| Log Field | UDM Mapping | Logic |
|---|---|---|
src |
principal.ip |
Value taken from src field. |
dst |
target.ip |
Value taken from dst field. |
spt |
principal.port |
Value taken from spt and converted to integer. |
dpt |
target.port |
Value taken from dpt and converted to integer. |
shost |
principal.hostname |
Value taken from shost field. |
dhost |
target.hostname |
Value taken from dhost field. |
suser |
principal.user.userid |
Value taken from suser field. |
duser |
target.user.userid |
Value taken from duser field. |
msg |
metadata.description |
Value taken from msg field. |
cat |
security_result.category_details |
Value taken from cat (CEF category) field. |
act |
security_result.action_details |
Value taken from act (action) field. |
severity |
security_result.severity |
Mapped from CEF severity: 1-3 -> LOW, 4-6 -> MEDIUM, 7-8 -> HIGH, 9-10 -> CRITICAL. |
deviceEventClassId |
metadata.product_event_type |
Value taken from deviceEventClassId field. |
name |
security_result.summary |
Value taken from CEF name field (event name). |
deviceVendor |
metadata.vendor_name |
Value taken from deviceVendor field. Typically set to "Attivo Networks". |
deviceProduct |
metadata.product_name |
Value taken from deviceProduct field. Typically set to "BOTsink". |
deviceVersion |
metadata.product_version |
Value taken from deviceVersion field. |
metadata.event_type |
Set to "GENERIC_EVENT" by default. Set to "NETWORK_CONNECTION" if source and destination IPs are present. Set to "STATUS_UPDATE" if only principal information is available. | |
metadata.log_type |
Set to "ATTIVO". | |
VLANID |
event.idm.read_only_udm.additional.fields |
Mapped from changelog |
Forwarder_IP |
event.idm.read_only_udm.additional.fields |
Mapped from changelog |
VTSummaryResult |
event.idm.read_only_udm.additional.fields |
Mapped from changelog |
WebRootReputation |
event.idm.read_only_udm.additional.fields |
Mapped from changelog |
Forwarder |
event.idm.read_only_udm.additional.fields |
Mapped from changelog |
Target_IP_Ports |
event.idm.read_only_udm.additional.fields |
Mapped from changelog |
TargetIP_List |
event.idm.read_only_udm.additional.fields |
Mapped from changelog |
Dest_UserName |
event.idm.read_only_udm.target.user.userid |
Mapped from changelog |
Attacker_IP_Domain |
event.idm.read_only_udm.principal.administrative_domain |
Mapped from changelog |
attacker_ip |
event.idm.read_only_udm.principal.ip and event.idm.read_only_udm.principal.asset.ip |
Mapped from changelog |
detail_target_ip |
event.idm.read_only_udm.principal.ip and event.idm.read_only_udm.principal.asset.ip |
Mapped from changelog |
target_host |
event.idm.read_only_udm.target.hostname |
Mapped from changelog |
target_ip |
event.idm.read_only_udm.target.ip and event.idm.read_only_udm.target.asset.ip |
Mapped from changelog |
target_os |
event.idm.read_only_udm.target.platform_version |
Mapped from changelog |
description |
event.idm.read_only_udm.metadata.description |
Mapped from changelog |
detail_source_ip |
event.idm.read_only_udm.observer.ip |
Mapped from changelog |
phase |
event.idm.read_only_udm.security_result.category_details |
Mapped from changelog |
Attacker_HostName |
event.idm.read_only_udm.principal.hostname |
Mapped from changelog |
Attacker_MAC |
event.idm.read_only_udm.principal.mac |
Mapped from changelog |
Attacker_UserNames |
event.idm.read_only_udm.principal.user.user_display_name |
Mapped from changelog |
Source_Device_Name |
event.idm.read_only_udm.observer.hostname |
Mapped from changelog |
Attivo_AlertID |
event.idm.read_only_udm.metadata.product_log_id |
Mapped from changelog |
MITRE_Technique_Name |
event.idm.read_only_udm.security_result.detection_fields |
Mapped from changelog |
MITRE_Tactic_Name |
event.idm.read_only_udm.security_result.rule_name |
Mapped from changelog |
severity |
event.idm.read_only_udm.security_result.severity |
Mapped from changelog |
Target_Ports |
event.idm.read_only_udm.target.port |
Mapped from changelog |
Target_IP_Domain |
event.idm.read_only_udm.target.administrative_domain |
Mapped from changelog |
Alert.subject |
metadata.description |
Mapped from changelog |
Alert.body |
metadata.description |
Mapped from changelog |
Alert.app |
principal.application |
Mapped from changelog |
Alert.dest_ip |
target.ip |
Mapped from changelog |
Alert.dest_host |
target.hostname |
Mapped from changelog |
Alert.src_hostname |
principal.hostname |
Mapped from changelog |
Alert.src_ip_domain |
principal.domain.name |
Mapped from changelog |
Alert.dest_ip_domain |
target.domain.name |
Mapped from changelog |
Alert.id |
metadata.product_log_id |
Mapped from changelog |
Alert.des_os |
target.asset.platform_software.platform_version |
Mapped from changelog |
Alert.src_ip |
principal.ip |
Mapped from changelog |
Alert.src_mac |
prinicipal.mac |
Mapped from changelog |
Alert.bootsink_ip |
intermediary.ip |
Mapped from changelog |
Alert.forwarder" and "Alert.service |
additional.fields |
Mapped from changelog |
techinque_id |
security_result.attack_details.tactics.id |
Mapped from changelog |
techinque_name |
security_result.attack_details.tactics.name |
Mapped from changelog |
Alert.severity |
security_result.severity |
Mapped from changelog |
Alert.src_category |
security_result.threat_name |
Mapped from changelog |
Change Log
View the Change Log for this parser
Need more help? Get answers from Community members and Google SecOps professionals.