Appian Cloud ログを収集する

パーサーのバージョン: 4.0

以下でサポートされています。

このドキュメントでは、Bindplane エージェントを使用して Appian Cloud ログを Google Security Operations に取り込む方法について説明します。

Appian Cloud は、組織がエンタープライズ アプリケーションとワークフローを構築できるようにするローコード自動化プラットフォームです。ログ ストリーミングは、IPsec VPN 接続を介して Appian Cloud 環境から監査ログとセキュリティ イベントログを提供します。

始める前に

次の前提条件を満たしていることを確認してください。

  • Google SecOps インスタンス
  • Windows Server 2016 以降、または systemd を使用する Linux ホスト
  • プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認します。
  • Appian Cloud の Professional または Signature ライセンス
  • Appian 環境の URL の記録
  • Appian Cloud と、Bindplane エージェントがデプロイされる環境との間の IPsec VPN

Bindplane エージェントの Google SecOps 認証情報を取得する

Bindplane エージェントを Google SecOps に対して認証するには、次のいずれかの方法を選択します。

  • 新規デプロイ: Chronicle API を使用します(オプション 1)。
  • 以前のデプロイ: 2027 年 7 月 20 日に Ingestion API が廃止されるまで、取り込み認証ファイル(オプション 2)を引き続き使用します。
  1. Google Cloud コンソールにログインし、Google SecOps インスタンスにリンクされている Google Cloud プロジェクトを選択します。
  2. [IAM と管理] > [サービス アカウント] に移動します。
  3. [サービス アカウントを作成] をクリックします。
  4. 次の構成情報を指定します。
    • サービス アカウント名: アカウントの名前を入力します(例: bindplane-ingest)。
    • サービス アカウントの説明: 説明を入力します(例: Bindplane agent log ingestion)。
  5. [作成して続行] をクリックします。
  6. [このサービス アカウントにプロジェクトへのアクセスを許可する] セクションで、[ロールを選択] をクリックし、[Chronicle 編集者] を選択します。
  7. [続行] をクリックして [完了] をクリックします。
  8. 作成したサービス アカウントをクリックし、[キー] タブに移動します。
  9. [鍵を追加] > [新しい鍵を作成] の順にクリックします。
  10. [JSON] を選択し、[作成] をクリックします。キーファイルがパソコンにダウンロードされます。
  11. 鍵ファイルを ingestion-auth.json として Bindplane コレクタ ディレクトリ(Linux の場合は /opt/observiq-otel-collector/ingestion-auth.json、Windows の場合は C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)に保存するか、config.yaml の creds_file_path を更新して、保存先のパスと一致させます。
  12. [IAM と管理] > [設定] に移動し、[プロジェクト番号] をコピーします。これはエクスポータの構成に必要です。

オプション 2: 取り込み認証ファイルをダウンロードする(レガシー)

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [収集エージェント] に移動します。
  3. 取り込み認証ファイルをダウンロードします。
  4. Bindplane エージェントがインストールされるシステムにファイルを安全に保存します。

Google SecOps のお客様 ID を取得する

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [プロファイル] に移動します。
  3. [組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。

Bindplane エージェントをインストールする

次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。

Windows へのインストール

  1. 管理者として コマンド プロンプトまたは PowerShell を開きます。
  2. 次のコマンドを実行します。

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sc query observiq-otel-collector
    

    サービスが RUNNING と表示されます。

Linux のインストール

  1. root 権限または sudo 権限でターミナルを開きます。
  2. 次のコマンドを実行します。

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sudo systemctl status observiq-otel-collector
    

    サービスは active (running) と表示されます。

その他のインストール リソース

その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。

Syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する

構成ファイルを探す

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

構成ファイルを編集します。

  • config.yaml の内容全体を次の構成に置き換えます。

    receivers:
      tcplog:
        listen_address: "0.0.0.0:6514"
    
    exporters:
      chronicle/appian_cloud:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: APPIAN_CLOUD
        raw_log_field: body
    
    service:
      pipelines:
        logs/appian_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/appian_cloud
    

構成パラメータ

各プレースホルダを次のように置き換えます。

  • レシーバーの構成:

    • listen_address: リッスンする IP アドレスとポート。
      • 0.0.0.0: すべてのインターフェースでリッスンします(推奨)。
      • ポート 6514 は、Appian Cloud ログ ストリーミングに推奨されるポートです。
  • エクスポータの構成:

    • creds_file_path: サービス アカウントの JSON キーファイルのフルパス(オプション 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps コンソールからコピーしたお客様 ID
    • location: <LOCATION> は、Google SecOps インスタンスのリージョン(us、europe、asia-southeast1 など)に置き換えます。エクスポーターは、chronicle.googleapis.com の先頭にこの値を付加します。完全なリストについては、リージョン エンドポイントをご覧ください。
    • project: <PROJECT_NUMBER> を [IAM と管理] > [設定] のプロジェクト番号に置き換えます。
    • endpoint: chronicle.googleapis.com に設定したままにします。

以前の取り込み API エクスポータ

  • オプション 2 の取り込み認証ファイルを使用する場合は、exporters ブロックを次のように置き換えます。creds_file_path を取り込み認証ファイルのパスに設定します。インスタンスが米国以外にある場合は、malachiteingestion-pa.googleapis.com をリージョン エンドポイント(例: europe-malachiteingestion-pa.googleapis.com)に置き換えます。

    exporters:
      chronicle/appian_cloud:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: APPIAN_CLOUD
        raw_log_field: body
    

構成ファイルを保存する

  • 編集後、ファイルを保存します。
    • Linux: Ctrl+O、Enter、Ctrl+X の順に押します。
    • Windows の場合: [ファイル] > [保存] をクリックします。

Bindplane エージェントを再起動して変更を適用する

  • Linux で Bindplane エージェントを再起動するには、次のコマンドを実行します。

    sudo systemctl restart observiq-otel-collector
    
    1. サービスが実行されていることを確認します。

      sudo systemctl status observiq-otel-collector
      
    2. ログでエラーを確認します。

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows で Bindplane エージェントを再起動するには、次のいずれかのオプションを選択します。

    • 管理者としてコマンド プロンプトまたは PowerShell を開きます。

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • サービス コンソール:

      1. Win+R を押し、「services.msc」と入力して Enter キーを押します。
      2. observIQ OpenTelemetry Collector を見つけます。
      3. 右クリックして [再起動] を選択します。
      4. サービスが実行されていることを確認します。

        sc query observiq-otel-collector
        
      5. ログでエラーを確認します。

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Appian Cloud のログ ストリーミングを有効にする

  1. 件名を「Enable Log Streaming」として Appian でサポートケースを開き、次の詳細を含めます。
    • 環境 URL
    • 目的のネットワーク パス(IPsec VPN)
    • Bindplane エージェントの IP アドレス
    • Bindplane エージェントの TCP ポート番号(例: 6514)
  2. Appian サポートがメンテナンスの時間枠をスケジュールし、構成をデプロイします。

UDM マッピング テーブル

ログフィールド UDM マッピング ロジック
available_heap_space_label additional.fields 統合済み
cpu_core_count_label additional.fields 統合済み
daemon_thread_count_label additional.fields 統合済み
data_store_label additional.fields 統合済み
devicetimestamp_label additional.fields 統合済み
entity_label additional.fields 統合済み
execute_time_label additional.fields 統合済み
load_average_label additional.fields 統合済み
operation_name_label additional.fields 統合済み
operation_type_label additional.fields 統合済み
permanent_generation_available_label additional.fields 統合済み
permanent_generation_used_label additional.fields 統合済み
prepare_time_label additional.fields 統合済み
retcode_label additional.fields 統合済み
session_count_label additional.fields 統合済み
tenured_collection_count_label additional.fields 統合済み
tenured_collection_time_label additional.fields 統合済み
tenured_generation_available_label additional.fields 統合済み
tenured_generation_usage_after_collection_label additional.fields 統合済み
tenured_generation_used_label additional.fields 統合済み
thread_label additional.fields 統合済み
total_swap_space_label additional.fields 統合済み
total_system_memory_label additional.fields 統合済み
total_thread_count_label additional.fields 統合済み
transform_time_label additional.fields 統合済み
used_heap_space_label additional.fields 統合済み
used_swap_space_label additional.fields 統合済み
used_system_memory_label additional.fields 統合済み
young_cllection_time_label additional.fields 統合済み
young_collection_count_label additional.fields 統合済み
has_principal_user extensions.auth.type マッピング: true → AUTHTYPE_UNSPECIFIED
src_host intermediary.hostname 直接マッピングされます。
src_ip intermediary.ip 統合済み
time metadata.event_timestamp yyyy-MM-dd HH:mm:ss として解析済み
event_type metadata.event_type 直接マッピングされます。
device metadata.product_event_type 直接マッピングされます。
product_type metadata.product_event_type 直接マッピングされます。
http_method network.http.method 直接マッピングされます。
useragent network.http.parsed_user_agent 名前変更済み/マッピング済み
useragent network.http.user_agent 直接マッピングされます。
connectionid network.session_id 直接マッピングされます。
sessionID network.session_id 直接マッピングされます。
session_id network.session_id 直接マッピングされます。
domain principal.administrative_domain 直接マッピングされます。
application principal.application 直接マッピングされます。
host principal.asset.hostname 直接マッピングされます。
hostname principal.asset.hostname 直接マッピングされます。
IpAddress principal.asset.ip 統合済み
host principal.hostname 直接マッピングされます。
hostname principal.hostname 直接マッピングされます。
IpAddress principal.ip 統合済み
src_port principal.port 直接マッピングされます。
process_id principal.process.pid 直接マッピングされます。
url principal.url 直接マッピングされます。
roles principal.user.attribute.roles 統合済み
companyname principal.user.company_name 直接マッピングされます。
email principal.user.email_addresses 統合済み
user_id principal.user.email_addresses マッピング: N/A → user_id
modified_by_uuid principal.user.product_object_id 直接マッピングされます。
user principal.user.product_object_id 直接マッピングされます。
modified_by_username principal.user.userid 直接マッピングされます。
userId principal.user.userid 直接マッピングされます。
user_id principal.user.userid 直接マッピングされます。
username2 principal.user.userid 直接マッピングされます。
versionDetails security_result.about.platform_version 直接マッピングされます。
outcome_result security_result.action 統合済み
security_result_action security_result.action 統合済み
act security_result.action_details 直接マッピングされます。
status security_result.action_details 直接マッピングされます。
sec_result_category security_result.category 統合済み
category security_result.category_details 統合済み
desc security_result.description 直接マッピングされます。
details security_result.description 直接マッピングされます。
details_label security_result.detection_fields 統合済み
endpoint_label security_result.detection_fields 統合済み
execution_count_label security_result.detection_fields 統合済み
maximum_execution_time_label security_result.detection_fields 統合済み
maximum_response_size_label security_result.detection_fields 統合済み
maximum_response_time_label security_result.detection_fields 統合済み
mean_execution_time_label security_result.detection_fields 統合済み
mean_response_size_label security_result.detection_fields 統合済み
minimum_execution_time_label security_result.detection_fields 統合済み
minimum_response_size_label security_result.detection_fields 統合済み
model_label security_result.detection_fields 統合済み
rolesAllow_label security_result.detection_fields 統合済み
sqlcmd_label security_result.detection_fields 統合済み
status_code_1xx_count_label security_result.detection_fields 統合済み
status_code_2xx_count_label security_result.detection_fields 統合済み
status_code_3xx_count_label security_result.detection_fields 統合済み
status_code_4xx_count_label security_result.detection_fields 統合済み
status_code_5xx_count_label security_result.detection_fields 統合済み
type_label security_result.detection_fields 統合済み
uuid_label security_result.detection_fields 統合済み
severity security_result.severity マッピング: "INFORMATIONAL","INFORMATION","INFO" → INFORMATIONAL、"WARNING", "MEDIUM" → `M...
detail security_result.severity_details 直接マッピングされます。
action1 security_result.summary 直接マッピングされます。
msg security_result.summary 直接マッピングされます。
object security_result.summary 直接マッピングされます。
operation_detail security_result.summary 直接マッピングされます。
reason security_result.summary 直接マッピングされます。
summary security_result.summary 直接マッピングされます。
server_host target.asset.hostname 直接マッピングされます。
tar_host target.asset.hostname 直接マッピングされます。
src_ip1 target.asset.ip 統合済み
hash target.file.md5 直接マッピングされます。
document_name target.file.names 統合済み
server_host target.hostname 直接マッピングされます。
tar_host target.hostname 直接マッピングされます。
src_ip1 target.ip 統合済み
commandline target.process.command_line 直接マッピングされます。
action_label target.resource.attribute.labels 統合済み
environment_label target.resource.attribute.labels 統合済み
filters_label target.resource.attribute.labels 統合済み
new_value_label target.resource.attribute.labels 統合済み
original_value_label target.resource.attribute.labels 統合済み
page_group_invoved_label target.resource.attribute.labels 統合済み
page_involved_label target.resource.attribute.labels 統合済み
record_identifier_label target.resource.attribute.labels 統合済み
record_type_name_label target.resource.attribute.labels 統合済み
record_type_url_stub_label target.resource.attribute.labels 統合済み
setting_new_value_label target.resource.attribute.labels 統合済み
setting_old_value_label target.resource.attribute.labels 統合済み
site_involved_label target.resource.attribute.labels 統合済み
site_url_stub_label target.resource.attribute.labels 統合済み
view_label target.resource.attribute.labels 統合済み
database target.resource.name 直接マッピングされます。
property target.resource.name 直接マッピングされます。
record_type_name target.resource.name 直接マッピングされます。
resourcename target.resource.name 直接マッピングされます。
site_involved target.resource.name 直接マッピングされます。
id target.resource.product_object_id 直接マッピングされます。
oid target.resource.product_object_id 直接マッピングされます。
queryid target.resource.product_object_id 直接マッピングされます。
sessionID target.resource.product_object_id 直接マッピングされます。
transactionId target.resource.product_object_id 直接マッピングされます。
action target.resource.resource_subtype 直接マッピングされます。
name target.resource.resource_subtype 直接マッピングされます。
user_uuid target.user.product_object_id 直接マッピングされます。
username1 target.user.userid 直接マッピングされます。
なし extensions.auth.type 定数: AUTHTYPE_UNSPECIFIED
なし metadata.event_type 定数: GENERIC_EVENT
なし metadata.log_type 定数: APPIAN_CLOUD
なし metadata.product_name 定数: Cloud Platform
なし metadata.vendor_name 定数: Appian
なし security_result.severity 定数: INFORMATIONAL
sessionID event.idm.read_only_udm.network.session_id 変更履歴からマッピング
transactionId event.idm.read_only_udm.target.resource.product_object_id 変更履歴からマッピング
versionDetails event.idm.read_only_udm.security_result.about.platform_version 変更履歴からマッピング
application event.idm.read_only_udm.principal.application 変更履歴からマッピング
IpAddress event.idm.read_only_udm.principal.ip 変更履歴からマッピング
IpAddress event.idm.read_only_udm.principal.asset.ip 変更履歴からマッピング
userId event.idm.read_only_udm.principal.user.userid 変更履歴からマッピング
rolesAllow event.idm.read_only_udm.additional.fields 変更履歴からマッピング
userRole event.idm.read_only_udm.additional.fields 変更履歴からマッピング
status event.idm.read_only_udm.section_result.action_details 変更履歴からマッピング
resourcename event.idm.read_only_udm.target.resource.name 変更履歴からマッピング
commandline event.idm.read_only_udm.target.process.command_line 変更履歴からマッピング
devicetimestamp event.idm.read_only_udm.additional.fields 変更履歴からマッピング
email event.idm.read_only_udm.principal.user.email_addresses 変更履歴からマッピング
document_name target.files.names 変更履歴からマッピング
msg" and "reason security_result.summary 変更履歴からマッピング
original_value", "setting_new_value", "setting_old_value", and "new_value target.resource.attribute.labels 変更履歴からマッピング
page_involved", "site_involved", and "page_group_involved target.resource.attribute.labels 変更履歴からマッピング
total_thread_count", "daemon_thread_count", used_heap_space", "available_heap_space", "tenured_generation_usage_after_collection", "tenured_generation_used", "tenured_generation_available", "permanent_generation_used", and "permanent_generation_available additional.fields 変更履歴からマッピング
young_collection_count", "young_cllection_time", "tenured_collection_count", "tenured_collection_time", "cpu_core_count", "total_system_memory", "used_system_memory", "total_swap_space", "used_swap_space", "load_average", and "session_count additional.fields 変更履歴からマッピング
record_identifier", "record_type_url_stub", "view", "filters", "environment", and "site_url_stub target.resource.attribute.labels 変更履歴からマッピング
data_store", "entity", and "operation_type additional.fields 変更履歴からマッピング
operation_name", "prepare_time", "transform_time", and "execute_time additional.fields 変更履歴からマッピング
connectionid network.session.id 変更履歴からマッピング
minimum_execution_time", "execution_count", "status_code_1xx_count", "status_code_2xx_count", "status_code_3xx_count", "status_code_4xx_count", "status_code_5xx_count", "minimum_response_size", "maximum_response_time", "maximum_response_size", "mean_execution_time", and "maximum_response_size security_result.detection_fields 変更履歴からマッピング

変更ログ

このパーサーの変更ログを表示する

さらにサポートが必要な場合 コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。