收集 AIDE(高级入侵检测环境)日志
解析器版本:1.0
本文档介绍了如何使用 Bindplane 将 AIDE(高级入侵检测环境)日志注入 Google Security Operations。AIDE 是一种文件完整性监控工具,可检测 Linux/Unix 系统上的文件更改。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- 运行 AIDE 0.18 或更高版本(支持 JSON 格式)且具有 systemd 的 Linux 主机
- 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
- 对 AIDE 配置文件的特权访问权限
获取 Bindplane 代理的 Google SecOps 凭证
如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:
- 新部署:使用 Chronicle API(选项 1)。
- 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
方法 1:为 Chronicle API 创建服务账号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续。
- 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
- 点击继续,然后点击完成。
- 点击您创建的服务账号,然后前往密钥标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录(Linux 上的
/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的ingestion-auth.json,或更新config.yaml中的creds_file_path以匹配您保存它的路径。 - 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。
方法 2:下载数据注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往设置 > 数据管理 > 收集代理。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 收集代理。
- 下载数据注入身份验证文件。
- 将该文件安全地保存在将要安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往设置 > 管理 > 个人资料。如果您使用的是仅限 SIEM 的平台,请依次前往设置 > 个人资料。
- 复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Linux 操作系统上安装 Bindplane 代理。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安装资源
如需了解其他安装选项,请参阅此安装指南。
配置 Bindplane 代理以注入 Syslog 并发送到 Google SecOps
访问配置文件:
- 找到
config.yaml文件。在 Linux 上,它通常位于/opt/observiq-otel-collector/目录中。 - 使用文本编辑器(例如
nano或vi)打开该文件。
- 找到
按如下方式修改
config.yaml文件:receivers: udplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <CUSTOMER_ID> endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'AIDE' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labels- 根据基础架构的要求替换端口和 IP 地址。
- 将
<LOCATION>替换为 Google SecOps 实例所在的区域(例如us、europe或asia-southeast1)。导出工具会在此值前面加上chronicle.googleapis.com。 - 将
<PROJECT_NUMBER>替换为 IAM 和管理 > 设置中的项目编号。 - 将
<CUSTOMER_ID>替换为实际客户 ID。 - 将
/path/to/ingestion-authentication-file.json更新为第 1 步中保存服务账号密钥文件(选项 1)的文件路径。
旧版提取 API 导出工具
如果您使用选项 2 中的数据注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <CUSTOMER_ID> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'AIDE' raw_log_field: body ingestion_labels:
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector
在 AIDE 上配置 Syslog 转发
打开 AIDE 配置文件:
sudo vi /etc/aide/aide.conf前往报告部分。
添加以下配置:
- report_level:输入
list_entries。 - report_format:输入
json(适用于 AIDE 0.18+)或plain。 - report_url:输入
syslog:authpriv。
配置示例:
```ini report_level=list_entries report_format=json report_url=syslog:authpriv ```- report_level:输入
保存配置。
配置 rsyslog,以将 AIDE 日志转发到 Bindplane 代理。打开 rsyslog 配置:
sudo vi /etc/rsyslog.d/aide-forward.conf添加以下配置,以将
authpriv设施日志转发到 Bindplane 代理:authpriv.* @<BINDPLANE_AGENT_IP>:514- 将
<BINDPLANE_AGENT_IP>替换为 Bindplane 代理主机的 IP 地址。 - 使用
@进行 UDP 转发,或使用@@进行 TCP 转发。
- 将
重启 rsyslog:
sudo systemctl restart rsyslog如果是全新安装,请初始化 AIDE 数据库:
sudo aide --init sudo mv /var/lib/aide/aide.db.new /var/lib/aide/aide.db测试配置:
sudo aide --check使用 cron 设置自动检查:
sudo crontab -e添加以下行,以便在每天凌晨 4:05 运行 AIDE:
05 4 * * * root /usr/sbin/aide --check
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
added_label |
principal.asset.attribute.labels |
已合并 |
changed_label |
principal.asset.attribute.labels |
已合并 |
old_acl_label |
principal.asset.attribute.labels |
已合并 |
old_md5_label |
principal.asset.attribute.labels |
已合并 |
old_perms_label |
principal.asset.attribute.labels |
已合并 |
old_sha256_label |
principal.asset.attribute.labels |
已合并 |
old_ts_label |
principal.asset.attribute.labels |
已合并 |
removed_label |
principal.asset.attribute.labels |
已合并 |
total_label |
principal.asset.attribute.labels |
已合并 |
file_path |
principal.file.full_path |
直接映射 |
path |
principal.file.full_path |
直接映射 |
old_size |
principal.file.size |
直接映射 |
host |
principal.hostname |
直接映射 |
sr |
security_result |
已合并 |
new_acl_label |
target.asset.attribute.labels |
已合并 |
new_md5_label |
target.asset.attribute.labels |
已合并 |
new_perms_label |
target.asset.attribute.labels |
已合并 |
new_sha256_label |
target.asset.attribute.labels |
已合并 |
new_ts_label |
target.asset.attribute.labels |
已合并 |
path |
target.file.full_path |
直接映射 |
new_size |
target.file.size |
直接映射 |
| 不适用 | metadata.event_type |
常量:GENERIC_EVENT |
| 不适用 | metadata.product_name |
常量:AIDE |
| 不适用 | metadata.vendor_name |
常量:AIDE |
| 不适用 | principal.application |
常量:aide |
| 不适用 | principal.file.size |
常量:sizedata |
| 不适用 | target.file.size |
常量:sizedata_target |
total_files", "added_files", "removed_files", "changed_files", "old_timestamp", "old_perms", "old_sha256", "old_md5", and "old_acl |
principal.asset.attribute.labels |
从更新日志映射 |
new_timestamp", "new_perms", "new_sha256", "new_md5", and "new_acl |
target.asset.attribute.labels |
从更新日志映射 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。