HP Linux 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 HP-UX 운영체제 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
HP-UX는 HP Integrity 및 PA-RISC 서버용 엔터프라이즈 UNIX 운영체제입니다. HP-UX 시스템 로그는 인증 이벤트, 프로세스 실행, 보안 감사 데이터, 일반 시스템 활동을 캡처합니다. 시스템 로그 파일은 /var/adm/syslog/에 로컬로 저장됩니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - Bindplane 에이전트와 HP-UX 서버 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- HP-UX 서버에 대한 권한 (루트) 액세스
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 수집 인증 파일을 다운로드합니다.
Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/hp_linux: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: HP_LINUX raw_log_field: body ingestion_labels: env: production service: pipelines: logs/hpux_to_chronicle: receivers: - udplog exporters: - chronicle/hp_linux
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
udplog: 프로토콜 기반 수신기 유형입니다.- UDP syslog용
udplog - TCP syslog용
tcplog
- UDP syslog용
0.0.0.0: 리슨할 IP 주소:0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)- 하나의 인터페이스에서 수신 대기할 특정 IP 주소
514: 수신할 포트 번호입니다 (예:514,1514,6514).
내보내기 도구 구성:
hp_linux: 내보내기 도구의 설명 이름creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>: 이전 단계의 고객 IDendpoint: 리전 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
HP_LINUX: Chronicle에 표시되는 로그 유형ingestion_labels: YAML 형식의 선택적 라벨 (예:env: production)
파이프라인 구성:
hpux_to_chronicle: 파이프라인의 설명 이름
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc을 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
HP-UX syslog 전달 구성
- 루트 권한으로 HP-UX 서버에 로그인합니다.
syslog 구성 파일을 수정합니다.
vi /etc/syslog.conf모든 syslog 메시지를 Bindplane 에이전트로 전달하려면 다음 줄을 추가합니다.
*.* @<BINDPLANE_AGENT_IP><BINDPLANE_AGENT_IP>를 Bindplane 에이전트 호스트의 IP 주소로 바꿉니다.@접두사는 UDP를 통해 로그를 전송합니다. HP-UX syslog는 기본적으로 UDP를 사용합니다.
특정 시설만 전달하려면 개별 행을 사용하세요.
auth.* @<BINDPLANE_AGENT_IP> kern.* @<BINDPLANE_AGENT_IP> *.err @<BINDPLANE_AGENT_IP>저장하고 파일을 닫습니다.
syslog 데몬을 다시 시작하여 변경사항을 적용합니다.
/sbin/init.d/syslogd stop /sbin/init.d/syslogd startBindplane 에이전트 로그를 확인하여 syslog 메시지가 수신되고 있는지 확인합니다.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
audit_type_label |
additional.fields |
병합됨 |
auth_failures_label |
additional.fields |
병합됨 |
ctladdr_label |
additional.fields |
병합됨 |
da_instance_label |
additional.fields |
병합됨 |
delay_label |
additional.fields |
병합됨 |
dsn_label |
additional.fields |
병합됨 |
event_code_label |
additional.fields |
병합됨 |
mailer_label |
additional.fields |
병합됨 |
msg_id_label |
additional.fields |
병합됨 |
pri_label |
additional.fields |
병합됨 |
raw_severity_label |
additional.fields |
병합됨 |
ssh_version_label |
additional.fields |
병합됨 |
stat_label |
additional.fields |
병합됨 |
suite_label |
additional.fields |
병합됨 |
syslog_priority_label |
additional.fields |
병합됨 |
to_label |
additional.fields |
병합됨 |
tty_label |
additional.fields |
병합됨 |
xdelay_label |
additional.fields |
병합됨 |
process |
extensions.auth.type |
매핑됨: "sshd", "login" → AUTHTYPE_UNSPECIFIED |
msg |
metadata.description |
직접 매핑됨 |
ts |
metadata.event_timestamp |
MMM d HH:mm:ss로 파싱됨 |
utc |
metadata.event_timestamp |
UNIX_MS로 파싱됨 |
event_type |
metadata.event_type |
직접 매핑됨 |
action_type |
metadata.product_event_type |
직접 매핑됨 |
centrifyEventID |
metadata.product_log_id |
직접 매핑됨 |
version |
metadata.product_version |
직접 매핑됨 |
message |
network.application_protocol |
매핑됨: (?i)ssh → SSH |
proto |
network.ip_protocol |
매핑됨: tcp → TCP |
DASessID |
network.session_id |
직접 매핑됨 |
process |
principal.application |
직접 매핑됨 |
host |
principal.asset.hostname |
직접 매핑됨 |
src_ip |
principal.asset.ip |
병합됨 |
host |
principal.hostname |
직접 매핑됨 |
src_ip |
principal.ip |
병합됨 |
src_port |
principal.port |
직접 매핑됨 |
p_id |
principal.process.pid |
직접 매핑됨 |
principal_user |
principal.user.userid |
직접 매핑됨 |
user |
principal.user.userid |
직접 매핑됨 |
security_result_action |
security_result.action |
병합됨 |
ruleset |
security_result.rule_name |
직접 매핑됨 |
log_level |
security_result.severity |
매핑됨: INFO → INFORMATIONAL |
sev |
security_result.severity |
매핑됨: (?i)ERROR → ERROR |
log_level |
security_result.severity_details |
직접 매핑됨 |
t_domain |
target.administrative_domain |
직접 매핑됨 |
t_app |
target.application |
직접 매핑됨 |
t_hostname |
target.asset.hostname |
직접 매핑됨 |
target_hostname |
target.asset.hostname |
직접 매핑됨 |
t_hostname |
target.hostname |
직접 매핑됨 |
target_hostname |
target.hostname |
직접 매핑됨 |
target_user |
target.user.userid |
직접 매핑됨 |
user |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | extensions.auth.type |
상수: AUTHTYPE_UNSPECIFIED |
| 해당 사항 없음 | metadata.product_name |
상수: HP Linux |
| 해당 사항 없음 | metadata.vendor_name |
상수: HP Linux |
| 해당 사항 없음 | network.application_protocol |
상수: SSH |
| 해당 사항 없음 | network.ip_protocol |
상수: TCP |
| 해당 사항 없음 | security_result.severity |
상수: INFORMATIONAL |
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.