Darktrace 로그 수집

파서 버전: 19.0

다음에서 지원:

이 문서에서는 Bindplane 에이전트를 사용하여 Darktrace 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

Darktrace는 위협과 이상치를 실시간으로 감지하는 AI 기반 사이버 보안 플랫폼입니다. 파서는 CEF 및 JSON 형식의 Darktrace 로그를 모두 처리하여 필드를 추출하고 통합 데이터 모델 (UDM)에 매핑합니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 설치된 Linux 호스트
  • Bindplane 에이전트와 Darktrace 어플라이언스 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Darktrace 웹 UI에 대한 액세스 권한

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.

  • 새 배포: Chronicle API를 사용합니다 (옵션 1).
  • 기존 배포: 2027년 7월 20일에 수집 API가 지원 중단될 때까지 수집 인증 파일 (옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정으로 이동합니다.
  3. 서비스 계정 만들기를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다 (예: bindplane-ingest).
    • 서비스 계정 설명: 설명을 입력합니다 (예: Bindplane agent log ingestion).
  5. 만들고 계속하기를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기를 클릭합니다.
  10. JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리 (Linux의 경우 /opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에 ingestion-auth.json로 저장하거나 config.yaml의 creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다.
  12. IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.

옵션 2: 데이터 수집 인증 파일 다운로드 (기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트로 이동합니다.
  3. 데이터 수집 인증 파일을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 관리자 권한으로 명령 프롬프트 또는 PowerShell을 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

    서비스가 실행 중으로 표시되어야 합니다.

Linux 설치

  1. 루트 또는 sudo 권한이 있는 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

    서비스가 active (running)으로 표시됩니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.

syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

구성 파일 설정

  • config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.

    receivers:
      tcplog:
        listen_address: "0.0.0.0:10282"
    
    exporters:
      chronicle/darktrace:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: DARKTRACE
        raw_log_field: body
    
    service:
      pipelines:
        logs/darktrace_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/darktrace
    

구성 매개변수

다음 자리표시자를 바꿉니다.

  • 수신자 구성:

    • listen_address: 리슨할 IP 주소 및 포트:
      • 0.0.0.0: 모든 인터페이스에서 수신 대기 (권장)
      • 포트 10282은 기본 Darktrace CEF syslog 포트입니다 (필요에 따라 조정).
  • 내보내기 도구 구성:

    • creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps 콘솔에서 복사한 고객 ID
    • location: <LOCATION>을 Google SecOps 인스턴스의 리전 (예: us, europe, asia-southeast1)으로 바꿉니다. 내보내기 프로그램은 chronicle.googleapis.com에 이 값을 접두사로 추가합니다. 전체 목록은 리전 엔드포인트를 참조하세요.
    • project: <PROJECT_NUMBER>을 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
    • endpoint: chronicle.googleapis.com로 설정된 상태로 유지합니다.

기존 수집 API 내보내기 도구

  • 옵션 2의 데이터 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path을 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com을 리전 엔드포인트 (예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/darktrace:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: DARKTRACE
        raw_log_field: body
    

구성 파일 저장

  • 수정 후 파일을 저장합니다.
    • Linux: Ctrl+O, Enter, Ctrl+X를 차례로 누릅니다.
    • Windows: 파일 > 저장을 클릭합니다.

변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.

  • Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

      sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.

    • 관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔:

      1. Win+R 키를 누르고 services.msc를 입력한 다음 Enter 키를 누릅니다.
      2. observIQ OpenTelemetry Collector를 찾습니다.
      3. 마우스 오른쪽 버튼으로 클릭하고 다시 시작을 선택합니다.
      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Darktrace에서 syslog 구성

  1. Darktrace 웹 UI에 로그인합니다.
  2. 관리 > 시스템 구성으로 이동합니다.
  3. 알림 설정 확인을 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • CEF Syslog Alerts(CEF Syslog 알림): True(참)를 선택합니다.
    • CEF 시스템로그 서버: Bindplane IP 주소를 입력합니다.
    • CEF 시스템로그 서버 포트: Bindplane 포트 번호를 입력합니다 (예: 10282).
    • CEF Syslog TCP Alert: True를 선택합니다.
  5. 저장을 클릭합니다.

지원되는 Darktrace 샘플 로그

  • SYSLOG + KV (CEF)

    {
    "acknowledged": false,
    "commentCount": 0,
    "pbid": 900000001,
    "time": 1604055367000,
    "creationTime": 1604055367000,
    "model": {
        "name": "Compromise::Agent Beacon to New Endpoint",
        "uuid": "dfd6f10b-b91c-4244-9fd5-7c35caf21b33",
        "description": "A device is initiating multiple connections to a new external endpoint...",
        "priority": 2,
        "category": "Informational",
        "mitre": {
        "tactics": [
            "command-and-control"
        ],
        "techniques": [
            "T1071.001"
        ]
        }
    },
    "triggeredComponents": [
        {
        "time": 1677679818000,
        "ip": " ",
        "port": 443,
        "metric": {
            "name": "externalconnections"
        },
        "triggeredFilters": [
            {
            "filterType": "Connection hostname",
            "trigger": {
                "value": "beacon.external.io"
            }
            }
        ]
        }
    ],
    "score": 0.85,
    "device": {
        "did": 90001,
        "macaddress": " ",
        "ip": " ",
        "hostname": "user-laptop-1"
    }
    }
    
  • SYSLOG + JSON

    {
    "dpi_engine": "dt-sensor-101",
    "proto": "tcp",
    "source_ip": " ",
    "source_port": 51000,
    "dest_ip": " ",
    "dest_port": 389,
    "src": " ",
    "dst": " ",
    "details": "AP request: srealm is [TESTDOMAIN.LOCAL], service is [LDAP/DC99.testdomain.local/testdomain.local], ST cipher is [aes256-cts-hmac-sha1-96]",
    "epochdate": 1690471502.2252,
    "@host": "log-collector-host",
    "uid": "ABCDEFGHIJ1234567890",
    "note": "KERBEROS::App",
    "@type": "notice"
    }
    

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
darktraceUrl security_result.url_back_to_product darktraceUrl 필드에서 값을 가져옵니다.
darktrace_host observer.hostname IP 주소가 아닌 경우 값은 darktrace_host 필드에서 가져옵니다.
darktrace_ip observer.ip darktrace_ip 필드에서 값을 가져옵니다.
darktrace_user observer.user.userid 값은 darktrace_user 필드에서 가져옵니다.
설명 security_result.summary, metadata.description description 필드에서 값을 가져옵니다.
device.customFields.DT-AUTO.macaddress principal.mac 값은 device.customFields.DT-AUTO.macaddress 필드에서 가져옵니다.
device.did principal.asset.asset_id 값은 device.did 필드에서 가져와 문자열로 변환되고 Device ID:이 앞에 붙습니다.
device.firstSeen principal.asset.first_seen_time 값은 device.firstSeen 필드에서 가져와 문자열로 변환되고 밀리초 단위의 UNIX 타임스탬프로 파싱됩니다.
device.hostname principal.hostname, principal.asset.hostname 값은 device.hostname 필드에서 가져옵니다.
device.ip principal.ip, principal.asset.ip IP 주소 형식과 일치하는 경우 device.ip 필드에서 값을 가져옵니다.
device.ips.0.subnet additional.fields.subnet 값은 device.ips.0.subnet 필드에서 가져오고 subnet이 접두사로 붙습니다.
device.ips.ip principal.ip, principal.asset.ip 값은 목록에 있는 각 IP 주소의 device.ips.ip 필드에서 가져옵니다.
device.lastSeen principal.asset.last_discover_time 값은 device.lastSeen 필드에서 가져와 문자열로 변환되고 밀리초 단위의 UNIX 타임스탬프로 파싱됩니다.
device.macaddress principal.mac device.macaddress 필드에서 값을 가져옵니다.
device.objecttype principal.asset.type 값이 device이면 UDM 필드가 WORKSTATION로 설정됩니다.
device.sid principal.resource.attribute.labels.sid 값은 device.sid 필드에서 가져와 문자열로 변환됩니다.
device.typelabel principal.resource.attribute.labels.typelabel 값은 device.typelabel 필드에서 가져옵니다.
device.typename principal.resource.attribute.labels.typename device.typename 필드에서 값을 가져옵니다.
dst target.ip, target.asset.ip dst 필드에서 값을 가져옵니다.
dpt target.port 값은 dpt 필드에서 가져와 정수로 변환됩니다.
dvc principal.ip, principal.asset.ip dvc 값이 IP 주소인 경우 UDM 필드에 추가됩니다.
dvchost principal.hostname, principal.asset.hostname 값은 dvchost 필드에서 가져옵니다.
endpoint target.url 값은 endpoint 필드에서 가져옵니다.
event_time metadata.event_timestamp 값은 event_time 필드에서 가져와 ISO8601 타임스탬프로 파싱됩니다.
externalId metadata.product_log_id 값은 externalId 필드에서 가져옵니다.
incidentEventUrl principal.url incidentEventUrl 필드에서 값을 가져옵니다.
ip principal.ip, principal.asset.ip IP 주소 형식과 일치하는 경우 ip 필드에서 값을 가져옵니다.
issue_msg security_result.summary issue_msg 필드에서 값을 가져옵니다.
메시지 security_result.description message 필드에서 값을 가져옵니다.
메서드 network.http.method method 필드에서 값을 가져옵니다.
model.description metadata.description model.description 필드에서 값을 가져옵니다.
model.name metadata.product_event_type 값은 model.name 필드에서 가져옵니다.
model.now.category security_result.severity 값이 critical인 경우 UDM 필드가 CRITICAL로 설정됩니다. 값이 Informational인 경우 UDM 필드가 INFORMATIONAL로 설정됩니다. 값이 Suspicious인 경우 UDM 필드가 HIGH로 설정되고 카테고리가 NETWORK_SUSPICIOUS로 설정됩니다.
model.now.description metadata.description model.now.description 필드에서 값을 가져옵니다.
model.now.message security_result.description model.now.message 필드에서 값을 가져옵니다.
model.now.name metadata.product_event_type model.now.name 필드에서 값을 가져옵니다.
model.now.pid principal.process.pid 값은 model.now.pid 필드에서 가져와 문자열로 변환됩니다.
model.now.uuid principal.user.userid 값은 model.now.uuid 필드에서 가져오고 이벤트 유형은 USER_UNCATEGORIZED로 설정됩니다.
model.pid principal.process.pid 값은 model.pid 필드에서 가져와 문자열로 변환됩니다.
model.then.description principal.resource.attribute.labels.Model Then Description 값은 model.then.description 필드에서 가져옵니다.
model.then.name principal.resource.attribute.labels.Model Then Name model.then.name 필드에서 값을 가져옵니다.
model.then.pid principal.resource.attribute.labels.Model, Pid 값은 model.then.pid 필드에서 가져와 문자열로 변환됩니다.
model.then.uuid principal.resource.attribute.labels.Model Then UUID 값은 model.then.uuid 필드에서 가져옵니다.
model.uuid principal.user.userid 값은 model.uuid 필드에서 가져오고 이벤트 유형은 USER_UNCATEGORIZED로 설정됩니다.
relatedBreaches.0.modelName security_result.description relatedBreaches.0.modelName 필드에서 값을 가져옵니다.
점수 security_result.priority, security_result.priority_details 값이 0.8과 1 사이이면 우선순위가 HIGH_PRIORITY로 설정됩니다. 값이 0.5~0.79이면 우선순위가 MEDIUM_PRIORITY로 설정됩니다. 값이 0에서 0.49 사이이면 우선순위가 LOW_PRIORITY로 설정됩니다. 우선순위 세부정보는 Score :로 설정되고 그 뒤에 score 값이 문자열로 변환되어 옵니다.
줄이는 것을 security_result.severity 값이 2인 경우 UDM 필드가 MEDIUM로 설정됩니다. 값이 2보다 크면 UDM 필드가 HIGH로 설정됩니다.
shost principal.hostname, principal.asset.hostname shost 필드에서 값을 가져옵니다.
smac principal.mac smac 필드에서 값을 가져옵니다.
src principal.ip, principal.asset.ip 값은 src 필드에서 가져옵니다.
상태 network.http.response_code 값은 status 필드에서 가져와 문자열로 변환됩니다.
요약 metadata.description summary 필드에서 값을 가져옵니다.
시간 값은 time 필드에서 가져와 문자열로 변환되고 밀리초 단위의 UNIX 타임스탬프로 파싱됩니다.
타임스탬프 값은 timestamp 필드에서 가져오며 ISO8601 타임스탬프 또는 UNIX 타임스탬프(밀리초)로 파싱됩니다.
제목 security_result.summary title 필드에서 값을 가져옵니다.
triggeredComponents.ip intermediary.ip IP 주소 형식과 일치하는 경우 triggeredComponents.ip 필드에서 값을 가져옵니다.
triggeredComponents.port intermediary.port 값은 triggeredComponents.port 필드에서 가져와 정수로 변환됩니다.
사용자 이름 principal.user.userid username 필드에서 값을 가져옵니다.
metadata.vendor_name DARKTRACE로 설정합니다.
metadata.product_name DCIP로 설정합니다.
metadata.log_type DARKTRACE로 설정합니다.
network.ip_protocol issue_msg에 UDP가 포함되지 않은 경우 TCP로 설정합니다. 그렇지 않으면 UDP로 설정합니다.
security_result.action status이 401이면 BLOCK로 설정하고, 그렇지 않으면 ALLOW로 설정합니다.
security_result.severity INFORMATIONAL로 설정합니다.
network.application_protocol method가 비어 있지 않으면 HTTP로 설정합니다.
metadata.event_type method가 비어 있지 않으면 NETWORK_HTTP로 설정합니다. description에 logged into \\\\S+ over ssh이 포함된 경우 USER_LOGIN로 설정합니다. target_ip가 비어 있지 않으면 NETWORK_CONNECTION로 설정합니다. 그렇지 않으면 STATUS_UPDATE로 설정합니다.
extensions.auth.type description에 logged into \\\\S+ over ssh이 포함된 경우 MACHINE로 설정합니다.
security_result.category issue_msg에 Exfiltration이 포함된 경우 DATA_EXFILTRATION로 설정합니다. issue_msg에 Compromise이 포함된 경우 NETWORK_MALICIOUS로 설정합니다. 그렇지 않으면 NETWORK_SUSPICIOUS로 설정합니다.
percentScore event.idm.read_only_udm.additional.fields 변경 로그에서 매핑됨
device.credentials event.idm.read_only_udm.target.user.userid 변경 로그에서 매핑됨
url event.idm.read_only_udm.principal.url 변경 로그에서 매핑됨
username event.idm.read_only_udm.principal.user.userid 변경 로그에서 매핑됨
iris-event-type event.idm.read_only_udm.metadata.product_event_type 변경 로그에서 매핑됨
inhibitor event.idm.read_only_udm.target.ip 변경 로그에서 매핑됨
inhibitor event.idm.read_only_udm.target.asset.ip 변경 로그에서 매핑됨
inhibitor event.idm.read_only_udm.target.port 변경 로그에서 매핑됨
device.os event.idm.read_only_udm.principal.platform 변경 로그에서 매핑됨
device.typename event.idm.read_only_udm.principal.asset.type 변경 로그에서 매핑됨
device.ossource event.idm.read_only_udm.additional.fields 변경 로그에서 매핑됨
model.tags event.idm.read_only_udm.additional.fields 변경 로그에서 매핑됨
codeid event.idm.read_only_udm.security_result.rule_id 변경 로그에서 매핑됨
inhibitor event.idm.read_only_udm.security_result.description 변경 로그에서 매핑됨
host_ip event.idm.read_only_udm.intermediary.ip 변경 로그에서 매핑됨
technique_data event.idm.read_only_udm.security_result.attack_details.techniques 변경 로그에서 매핑됨
tactics_data event.idm.read_only_udm.security_result.attack_details.tactics 변경 로그에서 매핑됨
model.created.userid principal.user.userid 변경 로그에서 매핑됨
model.edited.userid additional.fields 변경 로그에서 매핑됨
direction network.direction 변경 로그에서 매핑됨
filterType" under "triggeredFilters additional.fields 변경 로그에서 매핑됨
trigger.value" under "triggeredFilters additional.fields 변경 로그에서 매핑됨
from principal.user.email_addresses 변경 로그에서 매핑됨
subject metadata.description 변경 로그에서 매핑됨
anomaly_score", "tags", "link_hosts", and "message_id additional.fields 변경 로그에서 매핑됨
recipients observer.user.email_addresses 변경 로그에서 매핑됨
attachment_sha1s" and "attachment_sha256s security_result.detection_fields 변경 로그에서 매핑됨
triggeredFilter.trigger.value target.ip 변경 로그에서 매핑됨
from network.email.from 변경 로그에서 매핑됨
subject network.email.subject 변경 로그에서 매핑됨
attachment_sha1s", "attachment_sha256s", "recipients", "link_hosts", "tags", "actions", "anomaly_score", "message_id security_result.detection_fields 변경 로그에서 매핑됨
model.name principal.user.user_display_name 변경 로그에서 매핑됨
breachUrl security_result.url_back_to_product 변경 로그에서 매핑됨
device.typelabel", "device.sid", "device.typename principal.resource.attribute.labels 변경 로그에서 매핑됨
device.ips.0.subnet additional_fields 변경 로그에서 매핑됨
device.device.lastSeen principal.asset.last_seen_time 변경 로그에서 매핑됨
mitreTechniques security_result.attack_details.techniques 변경 로그에서 매핑됨
details sec_result.about.resource.attribute.labels 변경 로그에서 매핑됨
principal_port_no principal.port 변경 로그에서 매핑됨
location principal.location.country_or_region 변경 로그에서 매핑됨
target_host target.hostname 변경 로그에서 매핑됨
source_ip principal.ip 변경 로그에서 매핑됨
source_port principal.port 변경 로그에서 매핑됨
dest_ip target.ip 변경 로그에서 매핑됨
dest_port target.port 변경 로그에서 매핑됨
@host principal.hostname 변경 로그에서 매핑됨
note principal.application 변경 로그에서 매핑됨
@type sec_result.about.resource.attribute.labels 변경 로그에서 매핑됨
opcode sec_result.about.resource.attribute.labels 변경 로그에서 매핑됨
trans_id sec_result.about.resource.attribute.labels 변경 로그에서 매핑됨
query_class sec_result.about.resource.attribute.labels 변경 로그에서 매핑됨
deviceMacAddress principal.mac 변경 로그에서 매핑됨

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.