ניהול סביבת העבודה של Apigee

הדף הזה רלוונטי ל-Apigee ול-Apigee Hybrid.

לעיון במסמכי התיעוד של Apigee Edge

כדי לפתח את ממשקי ה-API של Apigee באופן מקומי באמצעות Cloud Code, צריך ליצור סביבת עבודה חדשה של Apigee ב-Cloud Code או לפתוח סביבת עבודה קיימת. סביבת עבודה של Apigee מכילה את מבנה הספריות שנדרש לפיתוח מקומי.

בקטעים הבאים מוסבר איך ליצור, לפתוח ולנהל סביבת עבודה של Apigee.

יצירת סביבת עבודה של Apigee

כדי ליצור סביבת עבודה של Apigee:

  1. מבצעים אחת מהפעולות הבאות:

    • אם אין סביבת עבודה פתוחה של Apigee, לוחצים על Create Apigee workspace (יצירת סביבת עבודה של Apigee) בקטע Apigee.

      כפתור ליצירת סביבת עבודה של Apigee בממשק המשתמש

    • בחר תצוגה > לוח פקודות כדי לפתוח את לוח הפקודות ובחר קוד ענן: צור סביבת עבודה של Apigee.

  2. בוחרים את סוג סביבת העבודה שמתאים לסגנון הפיתוח המועדף. אתם יכולים לבחור בין סביבת עבודה עם מאגר יחיד לבין סביבת עבודה עם כמה מאגרים.

  3. מזינים שם לסביבת העבודה של Apigee.

  4. עוברים לספרייה שבה רוצים לשמור את סביבת העבודה של Apigee. אם אתם משתמשים בניהול מקורות, בוחרים מיקום במאגר המקורות.

  5. לוחצים על בחירת תיקייה בסביבת העבודה. סביבת העבודה של Apigee נוצרת, מאוחסנת בספרייה המקומית שצוינה ונפתחת ב-VS Code Explorer.

  6. לוחצים על הסמל הסמל של Apigee ב-Cloud Code Cloud Code בסרגל הפעילות.

סביבת העבודה של Apigee מוצגת בקטע Apigee:

‫Apigee Explorer מציג תיקיות של סביבת עבודה ב-Apigee, כולל apiproxies,‏ sharedflows,‏ environments ו-tests.

בהתאם לסוג סביבת העבודה שנבחרה, התוכן הבא נוצר:

פתיחת סביבת עבודה של Apigee

כדי לפתוח סביבת עבודה קיימת של Apigee:

  1. מבצעים אחת מהפעולות הבאות:

    • לחץ על פתח את סביבת העבודה של Apigee בצומת פיתוח מקומי של Apigee Explorer אם אין סביבת עבודה של Apigee פתוחה.

      כפתור פתיחת סביבת העבודה של Apigee בממשק המשתמש

    • בחר תצוגה > לוח פקודות כדי לפתוח את לוח הפקודות ובחר קוד ענן: פתיחת סביבת עבודה של Apigee.

  2. עוברים לסביבת העבודה של Apigee בסביבה המקומית.

    • אם אתם פותחים סביבת עבודה עם מאגר יחיד, בחרו את התיקייה ברמה העליונה של סביבת העבודה של Apigee שמכילה את התיקייה src/main/apigee.
    • אם אתם פותחים סביבת עבודה עם מאגרים מרובים, בחרו את קובץ סביבת העבודה עם הסיומת .code-workspace.
  3. לחץ על בחר תיקיית סביבת עבודה או קובץ סביבת עבודה עם מאגרים מרובים. סביבת העבודה של Apigee נפתחת ב-Cloud Code, ואפשר לעיין בתוכן שלה.

  4. לחץ על סמל קוד הענן הסמל של Apigee ב-Cloud Code בסרגל הפעילות.

סביבת העבודה של Apigee מוצגת ב-Apigee Explorer:

‫Apigee Explorer מציג תיקיות של סביבת עבודה ב-Apigee, כולל apiproxies,‏ sharedflows,‏ environments ו-tests.

הבנת המבנה של סביבת עבודה של מאגר יחיד של Apigee

כשיוצרים סביבת עבודה של Apigee עם מאגר יחיד ב-Apigee ב- Google Cloud, נוצרת קבוצה של תיקיות שמאפשרת לפתח פרוקסי של API ותהליכים משותפים, להגדיר ולפרוס סביבות, וליצור ולייצא משאבי בדיקה. סביבת העבודה של Apigee מאוחסנת ב-your-workspace-folder/src/main/apigee בסביבה המקומית שלך.

הטבלה הבאה מסכמת את מבנה סביבת העבודה של Apigee ברמה גבוהה.

תיקייה תיאור
apiproxies מכיל תיקייה נפרדת של apiproxy-name/apiproxy עבור כל תצורת proxy ל-API, בנויה כמתואר במבנה ספריית תצורת proxy ל-API.

לדוגמה: helloworld/apiproxy

מידע נוסף זמין במאמר פיתוח פרוקסי של API.

environments הגדרת הקשרים של זמן הריצה לשרתי ה-proxy של ה-API ולזרימות המשותפות שרוצים לפרוס, כולל:
  • הגדרות פריסה של שרת proxy ל-API ותהליך משותף
  • משאבים ברמת הסביבה
  • הוקים של תהליכים משותפים
  • שרתי היעד
  • מאגרי מפתחות

למידע נוסף, ראו הגדרה ופריסה של סביבות.

sharedflows מכילה תיקייה נפרדת sharedflow-name/sharedflowbundle לכל הגדרה של תהליך משותף, במבנה שמתואר במאמר הפניה להגדרת חבילת תהליכים משותפים.

לדוגמה: mysharedflow/sharedflowbundle

מידע נוסף זמין במאמר בנושא פיתוח של תהליכים משותפים.

tests מספק סט של משאבי בדיקה, כגון מוצרי API או מפתחים, הנדרשים לבדיקת ממשקי ה-API שלך באופן מקומי.

למידע נוסף, ראו בנייה וייצוא של משאבי בדיקה.

בדוגמה הזו אפשר לראות את המבנה של סביבת עבודה של Apigee בסביבה המקומית, כאשר src/main/apigee הוא שורש:

מבנה סביבת העבודה של Apigee ב-Cloud Code

להבין את המבנה של סביבת עבודה מרובת מאגרים של Apigee

סביבת עבודה עם כמה מאגרי קוד פועלת באופן דומה לסביבת עבודה עם כמה תיקיות שורש ב-Cloud Code. המשתמשים יכולים לבחור מיקומי אחסון נפרדים לארטיפקטים שלהם, אבל לפתח אותם יחד באמצעות סביבת עבודה אחת. לדוגמה כאשר המשתמש מעדיף מאגר ניהול קוד מקור אחד לכל פרוקסי.

סביבת עבודה מרובת מאגרים היא קובץ טקסט JSON עם סיומת .code-workspace.

זו דוגמה לתוכן של סביבת עבודה עם כמה מאגרי קוד, שמכילה שני שרתי proxy של API (authentication-proxy, products-proxy), זרימת נתונים משותפת אחת (SF-threat-protection), שתי סביבות (dev, test) וחבילת בדיקה אחת (test-products):

{
  "folders": [
    {
      "name": "authentication-proxy",
      "type": "proxy",
      "path": "/work/quickdemo/multi/authentication-proxy"
    },
    {
      "name": "products-proxy",
      "type": "proxy",
      "path": "/work/quickdemo/multi/products-proxy"
    },
    {
      "name": "SF-threat-protection",
      "type": "sharedflow",
      "path": "/work/quickdemo/multi/SF-threat-protection"
    },
    {
      "name": "dev",
      "type": "environment",
      "path": "/work/quickdemo/multi/dev"
    },
    {
      "name": "test",
      "type": "environment",
      "path": "/work/quickdemo/multi/test"
    },
    {
      "name": "test-products",
      "type": "test",
      "path": "/work/quickdemo/multi/test-products"
    }
  ]
}

דרישות אלה חלות על כל סוג תיקייה שניתן להוסיף לסביבת עבודה מרובת מאגרים:

סוג התיקייה מבנה תיקיות נדרש
environment מגדיר את תצורת הסביבה, כמתואר בהגדרת סביבה. שם התיקייה משמש כשם הסביבה.
proxy מגדיר את מבנה ה-proxy של ה-API, כמתואר במבנה ספריית תצורת proxy של ה-API. שם התיקייה משמש כשם של proxy ל-API.
sharedflow מגדיר את הזרימה המשותפת עם מבנה, כמתואר במדריך תצורת חבילת זרימה משותפת. שם התיקייה משמש כשם הזרימה המשותפת.
test מגדיר קבוצה של משאבי בדיקה, כמתואר בבניית משאבי בדיקה.שם התיקייה משמש כשם משאב הבדיקה.

עריכת סביבת עבודה מרובת מאגרים של Apigee

כדי לערוך סביבת עבודה עם כמה מאגרים, פותחים את הקובץ your-workspace.code-workspace ב-Cloud Code או בעורך המועדף.

כדי לפתוח את הקובץ מהתוסף Apigee ב-Cloud Code:

  • לחץ על ערוך סביבת עבודה בצומת פיתוח מקומי של Apigee Explorer.

    כפתור פתיחת סביבת העבודה של Apigee בממשק המשתמש

  • בוחרים באפשרות תצוגה > לוח הפקודות כדי לפתוח את לוח הפקודות, ואז בוחרים באפשרות Cloud Code: עריכת סביבת העבודה.

ניהול תיקיות וקבצים בסביבת עבודה של Apigee

הסעיפים הבאים מתארים כיצד לנהל תיקיות וקבצים בסביבת עבודה של Apigee.

עריכת קבצים בסביבת עבודה של Apigee

כדי לערוך קובץ בסביבת עבודה של Apigee:

  1. לוחצים על שם הקובץ שרוצים לערוך ב-Apigee Explorer. התוכן מוצג בעורך.

  2. ערוך את הקובץ, לפי הצורך.

  3. כדי לשמור את השינויים, לוחצים על קובץ > שמירה או על ‎⌘S.

העתקת תיקיות וקבצים בסביבת עבודה של Apigee

כדי להעתיק תיקייה או קובץ בסביבת עבודה של Apigee:

  1. לוחצים לחיצה ימנית על התיקייה או הקובץ שרוצים להעתיק ב-Apigee Explorer ובוחרים באפשרות Copy (העתקה).

  2. מזינים שם ייחודי לתיקייה או לקובץ ולוחצים על Enter.

התיקייה או הקובץ המועתקים מופיעים בסביבת העבודה של Apigee.

שינוי השם של תיקיות וקבצים בסביבת עבודה של Apigee

כדי לשנות את השם של תיקייה או קובץ בסביבת עבודה של Apigee:

  1. לוחצים לחיצה ימנית על התיקייה או הקובץ שרוצים להעתיק ב-Apigee Explorer ובוחרים באפשרות שינוי שם.

  2. מזינים שם ייחודי לתיקייה או לקובץ ולוחצים על Enter.

השם של התיקייה או הקובץ משתנה ב-Apigee Explorer.

מחיקת תיקיות וקבצים מסביבת עבודה של Apigee

כדי למחוק תיקייה או קובץ מסביבת עבודה של Apigee, לוחצים לחיצה ימנית על התיקייה או הקובץ שרוצים להעתיק ב-Apigee Explorer ובוחרים באפשרות מחיקה. התיקייה או הקובץ יוסרו מסביבת העבודה של Apigee.

רענן את תצוגת סביבת העבודה של Apigee

כדי לרענן את תצוגת סביבת העבודה של Apigee ולסנכרן את כל השינויים האחרונים שבוצעו (אולי מחוץ ל-Cloud Code), בצע אחת מהפעולות הבאות:

  • מקמו את הסמן מעל שורת הכותרת של Apigee Explorer ולחצו על סמל הרענון של Apigee Explorer.

  • בוחרים באפשרות View > Command Palette (תצוגה > לוח הפקודות) כדי לפתוח את לוח הפקודות, ואז בוחרים באפשרות Cloud Code: Refresh Apigee Explorer view (Cloud Code: רענון התצוגה של Apigee Explorer).