Diese Seite gilt für Apigee und Apigee Hybrid.
Apigee Edge-Dokumentation aufrufen
Bevor Sie Ihre Apigee APIs lokal mit Cloud Code entwickeln können, müssen Sie einen neuen Apigee-Arbeitsbereich in Cloud Code erstellen oder einen vorhandenen öffnen. Ein Apigee-Arbeitsbereich enthält die Verzeichnisstruktur, die für die lokale Entwicklung erforderlich ist.
In den folgenden Abschnitten wird beschrieben, wie Sie einen Apigee-Arbeitsbereich erstellen, öffnen und verwalten.
Erstellen Sie einen Apigee-Arbeitsbereich
So erstellen Sie einen Apigee-Arbeitsbereich:
Führen Sie eine der folgenden Aktionen aus:
Klicken Sie im Abschnitt Apigee auf Apigee-Arbeitsbereich erstellen, falls kein Apigee-Arbeitsbereich geöffnet ist.

Wählen Sie Ansicht > Befehlspalette aus, um die Befehlspalette zu öffnen, und wählen Sie Cloud Code: Create Apigee Workspace aus.
Wählen Sie den Arbeitsbereichstyp aus, der Ihrem bevorzugten Entwicklungsstil entspricht. Sie können zwischen einem Arbeitsbereich mit einem einzelnen Repository oder einem Arbeitsbereich mit mehreren Repositories wählen.
Geben Sie einen Namen für den Apigee-Arbeitsbereich ein.
Wechseln Sie in das Verzeichnis, in dem Sie den Apigee-Arbeitsbereich speichern möchten. Wenn Sie die Versionsverwaltung verwenden, wählen Sie einen Speicherort in Ihrem Quellcodesteuer-Repository aus.
Klicken Sie auf Arbeitsbereich auswählen. Der Apigee-Arbeitsbereich wird erstellt, im angegebenen lokalen Verzeichnis gespeichert und im VS Code Explorer geöffnet.
Klicken Sie in der Aktivitätsleiste auf das Cloud Code-Symbol
.
Der Apigee-Arbeitsbereich wird im Abschnitt Apigee angezeigt:

Je nach Typ des ausgewählten Arbeitsbereichs wird der folgende Inhalt erstellt:
-
Für einen Arbeitsbereich mit einem einzelnen Repository wird eine Reihe von Ordnern unter
your-workspace-locationerstellt. Weitere Informationen finden Sie unter Funktionsweise eines Apigee-Arbeitsbereichs mit einem einzelnen Repository. -
Bei einem Arbeitsbereich mit mehreren Repositories wird eine Datei namens
your-workspace-location.code-workspacemit dem erforderlichen JSON-Inhalt erstellt. Weitere Informationen finden Sie unter Funktionsweise eines Apigee-Multi-Repository-Arbeitsbereichs.
Apigee-Arbeitsbereich öffnen
So öffnen Sie einen vorhandenen Apigee-Arbeitsbereich:
Führen Sie eine der folgenden Aktionen aus:
Klicken Sie auf Open Apigee workspace auf dem Knoten Apigee Explorer Local development, falls kein Apigee-Arbeitsbereich geöffnet ist.

Wählen Sie Ansicht > Befehlspalette aus, um die Befehlspalette zu öffnen, und wählen Sie Cloud Code: Open Apigee Workspace aus.
Rufen Sie den Apigee-Arbeitsbereich in Ihrer lokalen Umgebung auf.
- Wenn Sie einen Arbeitsbereich mit einem einzelnen Repository öffnen, wählen Sie den Ordner der obersten Ebene Ihres Apigee-Arbeitsbereichs aus, der den Ordner
src/main/apigeeenthält. - Wenn Sie einen Arbeitsbereich mit mehreren Repositories öffnen, wählen Sie die Arbeitsbereichsdatei mit der Erweiterung
.code-workspaceaus.
- Wenn Sie einen Arbeitsbereich mit einem einzelnen Repository öffnen, wählen Sie den Ordner der obersten Ebene Ihres Apigee-Arbeitsbereichs aus, der den Ordner
Klicken Sie auf Arbeitsbereich oder Arbeitsbereich mit mehreren Repositories auswählen. Der Apigee-Arbeitsbereich wird in Cloud Code geöffnet, wo Sie den Inhalt des Arbeitsbereichs untersuchen können.
Klicken Sie in der Aktivitätsleiste auf das Cloud Code-Symbol
.
Der Apigee-Arbeitsbereich wird im Apigee Explorer angezeigt:

Die Struktur eines Apigee-Einzelrepository-Arbeitsbereichs verstehen
Wenn Sie einen Apigee-Arbeitsbereich mit einem einzigen Repository in Apigee in Google Clouderstellen, wird eine Reihe von Ordnern erstellt, die es Ihnen ermöglichen, API-Proxys und gemeinsame Abläufe zu entwickeln, Umgebungen zu konfigurieren und bereitzustellen sowie Testressourcen zu erstellen und zu exportieren. Der Apigee-Arbeitsbereich wird unter your-workspace-folder/src/main/apigee in Ihrer lokalen Umgebung gespeichert.
In der folgenden Tabelle erhalten Sie eine allgemeine Übersicht über die Struktur eines Apigee-Arbeitsbereichs.
| Ordner | Beschreibung |
|---|---|
apiproxies
|
Enthält für jede API-Proxy-Konfiguration einen separaten Ordner apiproxy-name/apiproxy, der wie in API-Proxy-Konfigurationsverzeichnisstruktur beschrieben strukturiert ist.
Beispiel: Weitere Informationen finden Sie unter API-Proxys entwickeln. |
environments
|
Definiert die Laufzeitausführungskontexte für die bereitzustellenden API-Proxys und freigegebenen Abläufe, einschließlich:
Weitere Informationen finden Sie unter Umgebungen konfigurieren und bereitstellen. |
sharedflows
|
Enthält einen separaten sharedflow-name/sharedflowbundle-Ordner für jede gemeinsam genutzte Ablaufkonfiguration, die in der Referenz zur Konfiguration des freigegebenen Ablauf-Hooks beschrieben ist.
Beispiel: Weitere Informationen finden Sie unter Freigegebene Abläufe entwickeln. |
tests
|
Stellt eine Reihe von Testressourcen wie API-Produkten oder Entwicklern bereit, die für das lokale Testen Ihrer APIs erforderlich sind.
Weitere Informationen finden Sie unter Testressourcen erstellen und exportieren. |
Hier sehen Sie ein Beispiel für die Struktur eines Apigee-Workspace in Ihrer lokalen Umgebung, wobei src/main/apigee das Wurzelverzeichnis ist:

Die Struktur eines Apigee-Multi-Repository-Arbeitsbereichs verstehen
Ein Arbeitsbereich mit mehreren Repositories funktioniert ähnlich wie ein Multi-Root-Arbeitsbereich in Cloud Code. Nutzer haben die Möglichkeit, einzelne Speicherorte für ihre Artefakte flexibel auszuwählen und gemeinsam in einem einzigen Arbeitsbereich zu entwickeln. Dies ist beispielsweise der Fall, wenn der Nutzer ein Quellcode-Verwaltungs-Repository pro Proxy bevorzugt.
Ein Arbeitsbereich mit mehreren Repositories ist eine JSON-Textdatei mit der Erweiterung .code-workspace.
Unten finden Sie ein Beispiel für den Inhalt eines Arbeitsbereichs mit mehreren Repositories, der zwei API-Proxys (authentication-proxy, products-proxy), einen freigegebenen Ablauf (SF-threat-protection), zwei Umgebungen (dev, test) und ein Test-Bundle (test-products) enthält:
{
"folders": [
{
"name": "authentication-proxy",
"type": "proxy",
"path": "/work/quickdemo/multi/authentication-proxy"
},
{
"name": "products-proxy",
"type": "proxy",
"path": "/work/quickdemo/multi/products-proxy"
},
{
"name": "SF-threat-protection",
"type": "sharedflow",
"path": "/work/quickdemo/multi/SF-threat-protection"
},
{
"name": "dev",
"type": "environment",
"path": "/work/quickdemo/multi/dev"
},
{
"name": "test",
"type": "environment",
"path": "/work/quickdemo/multi/test"
},
{
"name": "test-products",
"type": "test",
"path": "/work/quickdemo/multi/test-products"
}
]
}Diese Anforderungen gelten für jeden Ordnertyp, der einem Multi-Repository-Arbeitsbereich hinzugefügt werden kann:
| Ordnertyp | Erforderliche Ordnerstruktur |
|---|---|
environment |
Definiert die Umgebungskonfiguration, wie in Konfigurieren einer Umgebung beschrieben. Der Name des Ordners wird als Name der Umgebung verwendet. |
proxy |
Definiert die API-Proxy-Struktur, wie unter API-Proxy-Konfigurationsverzeichnisstruktur beschrieben. Der Name des Ordners wird als Name des API-Proxys verwendet. |
sharedflow |
Definiert den freigegebenen Ablauf mit Struktur, wie in der Konfigurationsreferenz für das freigegebene Ablauf-Bundle beschrieben. Der Name des Ordners wird als Name des freigegebenen Ablaufs verwendet. |
test |
Definiert eine Reihe von Testressourcen, wie unter Testressourcen erstellen beschrieben.Der Name des Ordners wird als Name der Testressource verwendet. |
Apigee-Arbeitsbereich mit mehreren Repositories bearbeiten
Bearbeiten Sie einen Arbeitsbereich mit mehreren Repositories. Öffnen Sie dazu die Datei your-workspace.code-workspace in Cloud Code oder Ihrem bevorzugten Editor.
So öffnen Sie die Datei über die Apigee-Erweiterung in Cloud Code:
Klicken Sie im Apigee Explorer-Knoten Lokale Entwicklung auf Arbeitsbereich bearbeiten.

Wählen Sie Ansicht > Befehlspalette aus, um die Befehlspalette zu öffnen, und wählen Sie Cloud Code: Arbeitsbereich bearbeiten aus.
Ordner und Dateien in einem Apigee-Arbeitsbereich verwalten
In den folgenden Abschnitten wird beschrieben, wie Ordner und Dateien in einem Apigee-Arbeitsbereich verwaltet werden.
Dateien in einem Apigee-Arbeitsbereich bearbeiten
So bearbeiten Sie eine Datei in einem Apigee-Arbeitsbereich:
Klicken Sie auf den Namen der Datei, die Sie in Apigee Explorer bearbeiten möchten. Der Inhalt wird im Editor angezeigt.
Bearbeiten Sie die Datei wie gewünscht.
Wählen Sie Datei > Speichern oder ⌘S aus, um Ihre Änderungen zu speichern.
Ordner und Dateien in einem Apigee-Arbeitsbereich kopieren
So kopieren Sie einen Ordner oder eine Datei in einem Apigee-Arbeitsbereich:
Klicken Sie mit der rechten Maustaste auf den Ordner oder die Datei, die Sie im Apigee Explorer kopieren möchten, und wählen Sie Kopieren.
Geben Sie einen eindeutigen Namen für den Ordner oder die Datei ein und drücken Sie die Eingabetaste.
Der kopierte Ordner oder die kopierte Datei wird im Apigee-Arbeitsbereich angezeigt.
Ordner und Dateien in einem Apigee-Arbeitsbereich umbenennen
So benennen Sie einen Ordner oder eine Datei in einem Apigee-Arbeitsbereich um:
Klicken Sie mit der rechten Maustaste auf den Ordner oder die Datei, die Sie im Apigee Explorer kopieren möchten, und wählen Sie Umbenennen.
Geben Sie einen eindeutigen Namen für den Ordner oder die Datei ein und drücken Sie die Eingabetaste.
Der Ordner oder die Datei wird im Apigee Explorer umbenannt.
Ordner und Dateien aus einem Apigee-Arbeitsbereich löschen
Um einen Ordner oder eine Datei aus einem Apigee-Arbeitsbereich zu löschen, klicken Sie im Apigee Explorer mit der rechten Maustaste auf den Ordner oder die Datei, die Sie kopieren möchten, und wählen Sie Löschen. Der Ordner oder die Datei wird aus dem Apigee-Arbeitsbereich entfernt.
Aktualisieren Sie die Apigee-Arbeitsbereichsansicht
Führen Sie eine der folgenden Aktionen aus, um die Ansicht des Apigee-Arbeitsbereichs zu aktualisieren und alle kürzlich vorgenommenen Änderungen zu synchronisieren, die sich (möglicherweise außerhalb von Cloud Code) befinden:
Bewegen Sie den Mauszeiger über die Titelleiste Apigee Explorer und klicken Sie auf
.Wählen Sie Ansicht > Befehlspalette aus, um die Befehlspalette zu öffnen, und wählen Sie Cloud Code: Refresh Apigee Explorer view aus.