Elastic Windows 이벤트 로그 Beats 로그 수집
파서 버전: 19.0
이 문서에서는 Bindplane 에이전트를 사용하여 Elastic Windows 이벤트 로그 비트 로그를 Google Security Operations에 수집하는 방법을 설명합니다.
Winlogbeat는 Windows 이벤트 로그를 수집하여 다양한 대상으로 전달하는 Elastic의 Windows 전용 이벤트 로그 전송 에이전트입니다. Windows 시스템에서 Windows 서비스로 실행되며 애플리케이션, 보안, 시스템, 기타 Windows 이벤트 로그 채널에서 이벤트를 수집할 수 있습니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는 Bindplane 에이전트를 실행하기 위한
systemd가 있는 Linux 호스트 - Bindplane 에이전트와 Logstash 서버 간의 네트워크 연결
- Logstash와 Bindplane 에이전트 간의 네트워크 연결
- 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- 이벤트 로그를 수집하기 위해 Winlogbeat가 설치될 Windows 시스템
- Winlogbeat 설치를 위한 Windows 시스템에 대한 관리자 액세스 권한
- 중간 처리를 위한 Logstash 서버(버전 7.x 또는 8.x)
Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기
Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택합니다.
- 새 배포: Chronicle API를 사용합니다(옵션 1).
- 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일(옵션 2)을 계속 사용합니다.
옵션 1: Chronicle API의 서비스 계정 만들기(권장)
- Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
- IAM 및 관리자 > 서비스 계정으로 이동합니다.
- 서비스 계정 만들기를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 서비스 계정 이름: 계정 이름을 입력합니다(예:
bindplane-ingest). - 서비스 계정 설명: 설명을 입력합니다(예:
Bindplane agent log ingestion).
- 서비스 계정 이름: 계정 이름을 입력합니다(예:
- 만들고 계속하기를 클릭합니다.
- 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택을 클릭하고 Chronicle 편집자를 선택합니다.
- 계속을 클릭한 다음 완료를 클릭합니다.
- 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
- 키 추가 > 새 키 만들기를 클릭합니다.
- JSON을 선택하고 만들기를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
- 키 파일을 Bindplane 수집기 디렉터리(Linux의 경우
/opt/observiq-otel-collector/ingestion-auth.json, Windows의 경우C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)에ingestion-auth.json로 저장하거나config.yaml의creds_file_path를 업데이트하여 저장한 경로와 일치시킵니다. - IAM 및 관리자 > 설정으로 이동하여 프로젝트 번호를 복사합니다. 내보내기 도구 구성에 필요합니다.
옵션 2: 데이터 수집 인증 파일 다운로드(기존)
- Google SecOps 콘솔에 로그인합니다.
- 설정 > 데이터 관리 > 수집 에이전트로 이동합니다. SIEM 전용 플랫폼을 사용하는 경우 설정 > 수집 에이전트로 이동합니다.
- 데이터 수집 인증 파일을 다운로드합니다.
- Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- 설정 > 관리 > 프로필로 이동합니다. SIEM 전용 플랫폼을 사용하는 경우 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스 상태는 RUNNING이어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스 상태는 활성(실행 중)이어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참조하세요.
syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 콘텐츠를 다음 구성으로 바꿉니다.receivers: tcplog: listen_address: "0.0.0.0:1514" exporters: chronicle/winlogbeat: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: chronicle.googleapis.com log_type: ELASTIC_WINLOGBEAT raw_log_field: body ingestion_labels: env: production source: winlogbeat service: pipelines: logs/winlogbeat_to_chronicle: receivers: - tcplog exporters: - chronicle/winlogbeat다음 자리표시자를 바꿉니다.
수신자 구성:
listen_address: 포트 1514(TCP)의 모든 인터페이스에서 수신 대기하도록0.0.0.0:1514로 설정합니다. 필요한 경우 포트 번호를 변경할 수 있지만 Logstash syslog 출력 구성과 일치해야 합니다.
내보내기 도구 구성:
<CREDS_FILE_PATH>: 서비스 계정 JSON 키 파일의 전체 경로(옵션 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<CUSTOMER_ID>: 이전 단계의 고객 IDlocation:<LOCATION>을 Google SecOps 인스턴스의 리전으로 바꿉니다(예:us,europe또는asia-southeast1). 내보내기 도구는 이 값으로chronicle.googleapis.com에 프리픽스를 추가합니다. 전체 목록은 리전 엔드포인트를 참조하세요.project:<PROJECT_NUMBER>를 IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.endpoint:chronicle.googleapis.com로 설정된 상태로 유지합니다.
구성 예:
receivers:
tcplog:
listen_address: "0.0.0.0:1514"
exporters:
chronicle/winlogbeat:
protocol: https
# Region of your instance, for example us, europe, asia-southeast1
location: <LOCATION>
# Project number of the Google Cloud project linked to the instance
project: '<PROJECT_NUMBER>'
compression: gzip
creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
customer_id: 'a1b2c3d4-e5f6-g7h8-i9j0-k1l2m3n4o5p6'
endpoint: chronicle.googleapis.com
log_type: ELASTIC_WINLOGBEAT
raw_log_field: body
ingestion_labels:
env: production
source: winlogbeat
service:
pipelines:
logs/winlogbeat_to_chronicle:
receivers:
- tcplog
exporters:
- chronicle/winlogbeat
기존 수집 API 내보내기 도구
옵션 2의 데이터 수집 인증 파일을 사용하는 경우
exporters블록을 다음으로 바꿉니다.creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우malachiteingestion-pa.googleapis.com를 리전 엔드포인트(예:europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.exporters: chronicle/winlogbeat: compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: malachiteingestion-pa.googleapis.com log_type: ELASTIC_WINLOGBEAT raw_log_field: body ingestion_labels: env: production source: winlogbeat
구성 파일 저장
수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X를 차례로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
Bindplane 에이전트를 다시 시작하여 변경사항을 적용합니다.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 안내를 따르세요.
다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 안내를 따르세요.
다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell을 실행합니다.
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R를 누르고services.msc를 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼으로 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Logstash 설치 및 구성
Winlogbeat에서 이벤트를 수신하고 syslog를 통해 Bindplane 에이전트로 전달하려면 Logstash가 중개자로 필요합니다. Winlogbeat에는 기본 syslog 출력 기능이 없습니다.
Logstash 설치
- Elastic 다운로드 페이지에서 Logstash를 다운로드합니다.
- Windows 또는 Linux 서버에 Logstash를 설치합니다.
Linux (Debian/Ubuntu):
wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add - sudo apt-get install apt-transport-https echo "deb https://artifacts.elastic.co/packages/8.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-8.x.list sudo apt-get update && sudo apt-get install logstashLinux (RHEL/CentOS):
sudo rpm --import https://artifacts.elastic.co/GPG-KEY-elasticsearch sudo tee /etc/yum.repos.d/logstash.repo <<EOF [logstash-8.x] name=Elastic repository for 8.x packages baseurl=https://artifacts.elastic.co/packages/8.x/yum gpgcheck=1 gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch enabled=1 autorefresh=1 type=rpm-md EOF sudo yum install logstashWindows:
- Elastic 다운로드 페이지에서 ZIP 파일을 다운로드합니다.
C:\logstash에 추출합니다.
Logstash 파이프라인 구성
새 파이프라인 구성 파일을 만듭니다.
Linux:
sudo nano /etc/logstash/conf.d/winlogbeat-to-syslog.confWindows:
notepad "C:\logstash\config\winlogbeat-to-syslog.conf"
다음 구성을 추가합니다.
input { beats { port => 5044 } } output { syslog { host => "<BINDPLANE_AGENT_IP>" port => 1514 protocol => "tcp" rfc => "rfc5424" appname => "winlogbeat" facility => "user-level" severity => "informational" } }<BINDPLANE_AGENT_IP>를 Bindplane 에이전트를 실행하는 서버의 IP 주소로 바꿉니다.
Logstash 구성 예시
input {
beats {
port => 5044
}
}
output {
syslog {
host => "192.168.1.100"
port => 1514
protocol => "tcp"
rfc => "rfc5424"
appname => "winlogbeat"
facility => "user-level"
severity => "informational"
}
}
Logstash 시작
Linux:
Logstash를 시작합니다.
sudo systemctl start logstash sudo systemctl enable logstashLogstash가 실행 중인지 확인합니다.
sudo systemctl status logstashLogstash 로그를 확인합니다.
sudo tail -f /var/log/logstash/logstash-plain.log
Windows:
cd C:\logstash\bin logstash.bat -f C:\logstash\config\winlogbeat-to-syslog.conf프로덕션 용도로 사용하려면 NSSM 또는 유사한 도구를 사용하여 Logstash를 Windows 서비스로 설치합니다.
Windows 시스템에 Winlogbeat 설치
Winlogbeat 다운로드
- Elastic 다운로드 페이지에서 Winlogbeat를 다운로드합니다.
- Windows용 ZIP 또는 MSI 설치 프로그램을 선택합니다.
Winlogbeat 설치
MSI 설치 프로그램 사용:
- MSI 설치 프로그램을 실행합니다.
- 설치 마법사를 따릅니다.
- 기본 위치(
C:\Program Files\Winlogbeat)에 설치합니다.
ZIP 파일 사용:
- ZIP 파일을
C:\Program Files\Winlogbeat에 압축 해제합니다. - PowerShell을 관리자로 엽니다.
Winlogbeat 디렉터리로 이동합니다.
cd 'C:\Program Files\Winlogbeat'설치 스크립트를 실행합니다.
.\install-service-winlogbeat.ps1
- ZIP 파일을
Logstash로 로그를 전송하도록 Winlogbeat 구성
Winlogbeat 구성 파일을 엽니다.
notepad "C:\Program Files\Winlogbeat\winlogbeat.yml"수집할 이벤트 로그를 구성합니다.
winlogbeat.event_logs섹션을 찾아 다음과 같이 구성합니다.winlogbeat.event_logs: - name: Application ignore_older: 72h - name: System - name: Security - name: Microsoft-Windows-Sysmon/Operational ignore_older: 72h - name: Windows PowerShell event_id: 400, 403, 600, 800 - name: Microsoft-Windows-PowerShell/Operational event_id: 4103, 4104, 4105, 4106 - name: ForwardedEvents tags: [forwarded]각 줄의 시작 부분에
#를 추가하여 Elasticsearch 출력 섹션을 주석 처리합니다.#output.elasticsearch: # hosts: ["localhost:9200"]Logstash 출력 섹션의 주석 처리를 삭제하고 구성합니다.
output.logstash: hosts: ["<LOGSTASH_SERVER_IP>:5044"]<LOGSTASH_SERVER_IP>를 Logstash 서버의 IP 주소로 바꿉니다.
Winlogbeat 구성 예시
winlogbeat.event_logs:
- name: Application
ignore_older: 72h
- name: System
- name: Security
- name: Microsoft-Windows-Sysmon/Operational
ignore_older: 72h
output.logstash:
hosts: ["192.168.1.50:5044"]
구성 파일 저장
저장하고 파일을 닫습니다.
Winlogbeat 서비스 시작
- PowerShell을 관리자로 엽니다.
Winlogbeat 서비스를 시작합니다.
Start-Service winlogbeat서비스가 실행 중인지 확인합니다.
Get-Service winlogbeat상태가 실행 중으로 표시됩니다.
Winlogbeat 로그에서 오류를 확인합니다.
Get-Content "C:\ProgramData\winlogbeat\Logs\winlogbeat" -Tail 50
로그 흐름 확인
Winlogbeat에서 Logstash로의 연결 확인
Logstash 서버에서 Logstash 로그를 확인합니다.
Linux:
sudo tail -f /var/log/logstash/logstash-plain.logWindows:
type C:\logstash\logs\logstash-plain.log
Beats 연결을 나타내는 메시지를 찾습니다.
[INFO ][logstash.inputs.beats] Beats inputs: Starting input listener {:address=>"0.0.0.0:5044"}
Logstash에서 Bindplane 에이전트로의 연결 확인
Bindplane 에이전트 서버에서 에이전트 로그를 확인합니다.
Linux:
sudo journalctl -u observiq-otel-collector -fWindows:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
로그 수집이 성공했음을 나타내는 메시지를 찾습니다.
Google SecOps에서 로그 확인
- Google SecOps 콘솔에 로그인합니다.
- 검색으로 이동합니다.
검색어를 실행하여 Winlogbeat 로그가 수집되고 있는지 확인합니다.
metadata.log_type = "ELASTIC_WINLOGBEAT"Windows 이벤트 로그가 검색 결과에 표시되는지 확인합니다.
문제 해결
Winlogbeat가 Logstash에 연결되지 않음
Winlogbeat와 Logstash 간의 네트워크 연결을 확인합니다.
Test-NetConnection -ComputerName <LOGSTASH_IP> -Port 5044Windows 방화벽 규칙이 포트 5044에서 아웃바운드 연결을 허용하는지 확인합니다.
Logstash가 포트 5044에서 리슨하는지 확인합니다.
Linux:
sudo netstat -tulpn | grep 5044Windows:
netstat -an | findstr 5044
Logstash가 Bindplane 에이전트로 전달되지 않음
Logstash와 Bindplane 에이전트 간의 네트워크 연결을 확인합니다.
Linux:
telnet <BINDPLANE_IP> 1514Windows:
Test-NetConnection -ComputerName <BINDPLANE_IP> -Port 1514
방화벽 규칙이 포트 1514에서 TCP 연결을 허용하는지 확인합니다.
Bindplane 에이전트가 포트 1514에서 리슨하는지 확인합니다.
Linux:
sudo netstat -tulpn | grep 1514Windows:
netstat -an | findstr 1514
Google SecOps에 로그가 표시되지 않음
- 고객 ID와 데이터 수집 인증 파일이 올바른지 확인합니다.
- Bindplane 에이전트 로그에서 인증 오류를 확인합니다.
- 리전 엔드포인트가 Google SecOps 인스턴스 리전과 일치하는지 확인합니다.
log_type이 표시된 대로 정확하게ELASTIC_WINLOGBEAT로 설정되어 있는지 확인합니다.
UDM 매핑 테이블
| winlog.event_data.powershell.HostApplication | event.idm.read_only_udm.target.process.command_line | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.ScriptName | event.idm.read_only_udm.target.process.file.full_path | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.UserId | event.idm.read_only_udm.principal.user.userid | 변경 로그에서 매핑됨 |
| host.mac | event.idm.read_only_udm.principal.mac 및 event.idm.read_only_udm.principal.asset.mac | 변경 로그에서 매핑됨 |
| _event.created | event.idm.read_only_udm.metadata.collected_timestamp | 변경 로그에서 매핑됨 |
| agent.name | event.idm.read_only_udm.principal.hostname 및 event.idm.read_only_udm.principal.asset.hostname | 변경 로그에서 매핑됨 |
| host.domain | event.idm.read_only_udm.principal.administrative_domain | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.CommandName | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.CommandLine | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.HostVersion | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.DetailSequence | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.DetailTotal | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.HostId | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.HostName | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.PipelineId | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.RunspaceId | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.SequenceNumber | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.keywords | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.powershell.EngineVersion | event.idm.read_only_udm.security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.TaskName | event.idm.read_only_udm.target.resource.name | 변경 로그에서 매핑됨 |
| winlog.event_data.ClientProcessId | event.idm.read_only_udm.target.process.pid | 변경 로그에서 매핑됨 |
| winlog.event_data.ParentProcessId | event.idm.read_only_udm.target.process.parent_process.pid | 변경 로그에서 매핑됨 |
| winlog.event_data.ClientProcessStartKey | event.idm.read_only_udm.target.process.product_specific_process_id | 변경 로그에서 매핑됨 |
| TimeTriggerStartBoundary | event.idm.read_only_udm.additional.fields | 변경 로그에서 매핑됨 |
| EventVersion | event.idm.read_only_udm.additional.fields | 변경 로그에서 매핑됨 |
| winlog.version | event.idm.read_only_udm.additional.fields | 변경 로그에서 매핑됨 |
| RegistrationInfoSecurityDescriptor | event.idm.read_only_udm.additional.fields | 변경 로그에서 매핑됨 |
| winlog.event_data.RpcCallClientLocality | event.idm.read_only_udm.additional.fields | 변경 로그에서 매핑됨 |
| winlog.provider_guid | event.idm.read_only_udm.additional.fields | 변경 로그에서 매핑됨 |
| winlog.event_data.param1 | event.idm.read_only_udm.target.application | 변경 로그에서 매핑됨 |
| DestinationIp | target.ip | 변경 로그에서 매핑됨 |
| source_network_address | src.ip | 변경 로그에서 매핑됨 |
| source_port | src.port | 변경 로그에서 매핑됨 |
| winlog.event_data.TaskContent | additional.fields | 변경 로그에서 매핑됨 |
| principal_user_id | principal.user.userid | 변경 로그에서 매핑됨 |
| principal_command_line | principal.process.command_line | 변경 로그에서 매핑됨 |
| run_level", "arguments", "RegistrationInfoURI", "WnfStateChangeTriggerEnabled", "WnfStateChangeTriggerStateName", "WnfStateChangeTriggerData", "WnfStateChangeTriggerDataOffset", "IdleSettingsRestartOnIdle", "IdleSettingsStopOnIdleEnd", "IdleSettingsWaitTimeout", "IdleSettingsDuration", "Priority", "ExecutionTimeLimit", "RunOnlyIfIdle", "DisallowStartOnRemoteAppSession", "UseUnifiedSchedulingEngine", "DisallowStartIfOnBatteries", "MultipleInstancesPolicy", "StopIfGoingOnBatteries", "AllowHardTerminate", "StartWhenAvailable", "RunOnlyIfNetworkAvailable", "AllowStartOnDemand", "Enabled", "Hidden", and "WakeToRun | additional.fields | 변경 로그에서 매핑됨 |
| winlog.event_data.ObjectServer | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| process.executable | principal.process.file.full_path | 변경 로그에서 매핑됨 |
| process.parent.executable | principal.process.parent_process.file.full_path | 변경 로그에서 매핑됨 |
| process.name | principal.process.file.names | 변경 로그에서 매핑됨 |
| process.parent.name | principal.process.parent_process.file.names | 변경 로그에서 매핑됨 |
| process.entity_id | target.process.product_specific_process_id | 변경 로그에서 매핑됨 |
| process.pid | principal.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.logon.failure.sub_status", "winlog.logon.failure.reason" and "winlog.logon.failure.status | security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.GroupMembership | principal.user.group_identifiers | 변경 로그에서 매핑됨 |
| client_ip | principal.asset.ip | 변경 로그에서 매핑됨 |
| ip | principal.asset.ip | 변경 로그에서 매핑됨 |
| winlog.event_data.SourceIp | principal.asset.ip | 변경 로그에서 매핑됨 |
| destination.ip | target.asset.ip | 변경 로그에서 매핑됨 |
| winlog.event_data.DestinationIp | target.asset.ip | 변경 로그에서 매핑됨 |
| agent.hostname | target.asset.hostname | 변경 로그에서 매핑됨 |
| winlog.event_data.IpAddress | principal.asset.ip | 변경 로그에서 매핑됨 |
| source.ip | principal.asset.ip | 변경 로그에서 매핑됨 |
| winlog.event_data.Binary", "winlog.event_data.process.thread.id", "winlog.event_data.param1", "winlog.event_data.param2", "winlog.event_data.param3", "winlog.event_data.param4", "winlog.event_data.param5", "winlog.event_data.param6", "winlog.event_data.param7", "winlog.event_data.param8", "winlog.event_data.param9", "winlog.event_data.param10", "winlog.event_data.param11", "winlog.event_data.param12", "winlog.event_data.param13", "winlog.channel", "winlog.opcode | security_result.detection_fields | 변경 로그에서 매핑됨 |
| host.ip | principal.ip | 변경 로그에서 매핑됨 |
| winlog.process.pid | principal.process.pid | 변경 로그에서 매핑됨 |
| message | metadata.description | 변경 로그에서 매핑됨 |
| message | security_result.detection_fields | 변경 로그에서 매핑됨 |
| metadata.event_type | SERVICE_STOP | 변경 로그에서 매핑됨 |
| metadata.event_type | SERVICE_START | 변경 로그에서 매핑됨 |
| winlog.event_data.HandleId | resource_ancestors.product_object_id | 변경 로그에서 매핑됨 |
| winlog.event_data.ObjectType | target.resource.resource_subtype | 변경 로그에서 매핑됨 |
| winlog.event_data.OperationType | security_result.summary | 변경 로그에서 매핑됨 |
| object_server | resource_ancestors.name | 변경 로그에서 매핑됨 |
| Accesses | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| Properties | security_result.detection_fields | 변경 로그에서 매핑됨 |
| event_data.param1 | target.application | 변경 로그에서 매핑됨 |
| event_data.param2 | security_result.action | 변경 로그에서 매핑됨 |
| event_data.param1 | target.resource.attribute.permissions | 변경 로그에서 매핑됨 |
| event_data.param5 | target.resource.product_object_id | 변경 로그에서 매핑됨 |
| event_data.param6 | target.user.userid | 변경 로그에서 매핑됨 |
| event_data.param7 | target.administrative_domain | 변경 로그에서 매핑됨 |
| event_data.param8 | target.user.windows_sid | 변경 로그에서 매핑됨 |
| event_data.param10 | target.application | 변경 로그에서 매핑됨 |
| event_data.param1 | target.user.userid | 변경 로그에서 매핑됨 |
| client_ip | principal.ip | 변경 로그에서 매핑됨 |
| database_name | target.hostname | 변경 로그에서 매핑됨 |
| summary | security_result.summary | 변경 로그에서 매핑됨 |
| event_id | metadata.product_event_type | 변경 로그에서 매핑됨 |
| computer_name | principal.hostname | 변경 로그에서 매핑됨 |
| type | observer.application | 변경 로그에서 매핑됨 |
| task | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| source_name | security_result.about.labels | 변경 로그에서 매핑됨 |
| process_id | principal.process.pid | 변경 로그에서 매핑됨 |
| provider_guid | additional.fields | 변경 로그에서 매핑됨 |
| level | security_result.severity | 변경 로그에서 매핑됨 |
| thread_id | security_result.about.resource.attribute.labels | 변경 로그에서 매핑됨 |
| beat.version | principal.platform_version | 변경 로그에서 매핑됨 |
| message | security_result.description | 변경 로그에서 매핑됨 |
| winlog.event_data.LmPackageName | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.AuthenticationPackageName | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.LogonProcessName | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.WorkstationName | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.TargetOutboundUserName | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| CN" from "winlog.event_data.MemberName | target.user.userid | 변경 로그에서 매핑됨 |
| metadata.event_type | GROUP_MODIFICATION | 변경 로그에서 매핑됨 |
| winlog.event_data.Image | target.process.file.full_path | 변경 로그에서 매핑됨 |
| winlog.event_data.ProcessGuid | target.process.product_specific_process_id | 변경 로그에서 매핑됨 |
| winlog.event_data.ProcessId | target.process.pid | 변경 로그에서 매핑됨 |
| winlog.event_data.TargetObject | target.registry.registry_value_name | 변경 로그에서 매핑됨 |
| winlog.event_data.EventType | metadata.product_event_type | 변경 로그에서 매핑됨 |
| winlog.event_data.Subject | security_result.detection_fields | 변경 로그에서 매핑됨 |
| winlog.event_data.Requester | principal.user.userid | 변경 로그에서 매핑됨 |
| winlog.event_data.LogonType | extensions.auth.auth_details | 변경 로그에서 매핑됨 |
| winlog.event_data.ParentProcessId | principal.process.pid | 변경 로그에서 매핑됨 |
| winlog.event_data.ParentProcessGuid | principal.process.product_specific_process_id | 변경 로그에서 매핑됨 |
| winlog.event_data.ParentCommandLine | principal.process.command_line | 변경 로그에서 매핑됨 |
| winlog.event_data.ParentUser | principal.user.userid | 변경 로그에서 매핑됨 |
| winlog.event_data.CommandLine | target.process.command_line | 변경 로그에서 매핑됨 |
| winlog.event_data.User | target.user.userid | 변경 로그에서 매핑됨 |
| winlog.event_data.LogonGuid | target.resource.product_object_id | 변경 로그에서 매핑됨 |
| winlog.event_data.Hashes.SHA1 | target.process.file.sha1 | 변경 로그에서 매핑됨 |
| winlog.event_data.Hashes.SHA256 | target.process.file.sha256 | 변경 로그에서 매핑됨 |
| winlog.event_data.Hashes.MD5 | target.process.file.md5 | 변경 로그에서 매핑됨 |
| host.mac | principal.mac | 변경 로그에서 매핑됨 |
| winlog.event_data.ImageLoaded | target.process.file.full_path | 변경 로그에서 매핑됨 |
| winlog.opcode | security_result.description | 변경 로그에서 매핑됨 |
| winlog.event_data.MemberName | target.user.userid | 변경 로그에서 매핑됨 |
| winlog.event_data.MemberSid | target.user.windows_sid | 변경 로그에서 매핑됨 |
| winlog.event_data.TargetUserName | target.user.userid | 변경 로그에서 매핑됨 |
| winlog.event_data.TicketOptions", "winlog.event_data.TicketEncryptionType", "winlog.event_data.TicketEncryptionTypeDescription", "winlog.event_data.TransmittedServices", "winlog.event_data.TicketOptionsDescription | security_result.about.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.ServiceSid | target.user.windows_sid | 변경 로그에서 매핑됨 |
| winlog.event_data.TargetDomainName | target.administrative_domain | 변경 로그에서 매핑됨 |
| winlog.event_data.ServiceName | target.application | 변경 로그에서 매핑됨 |
| Failure Code" and "TicketOptions | security_result.about.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.Status | security_result.action_details | 변경 로그에서 매핑됨 |
| winlog.event_data.Status" and "winlog.event_data.StatusDescription | metadata.description | 변경 로그에서 매핑됨 |
| winlog.event_data.RelativeTargetName | target.process.file.full_path | 변경 로그에서 매핑됨 |
| event.original | security_result.detection_fields | 변경 로그에서 매핑됨 |
| ip | principal.ip | 변경 로그에서 매핑됨 |
| mac | principal.mac | 변경 로그에서 매핑됨 |
| Account Domain | principal.administrative-domain | 변경 로그에서 매핑됨 |
| metadata.event_type | USER_CHANGE_PASSWORD | 변경 로그에서 매핑됨 |
| event.outcome | security_result.outcomes | 변경 로그에서 매핑됨 |
| event.action and event.outcome | security_result.summary | 변경 로그에서 매핑됨 |
| log.level | security_result.severity_details | 변경 로그에서 매핑됨 |
| User Account control | security_result.description | 변경 로그에서 매핑됨 |
| winlog.event_data.ObjectValueName | target.registry.registry_value_name | 변경 로그에서 매핑됨 |
| Operation Type | security_result.summary | 변경 로그에서 매핑됨 |
| metadata.event_type | REGISTRY_MODIFICATION | 변경 로그에서 매핑됨 |
| winlog.event_data.ProcessName | target.process.file.full_path | 변경 로그에서 매핑됨 |
| winlog.event_data.ObjectName | target.resource.name | 변경 로그에서 매핑됨 |
| winlog.event_data.OldValue | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.NewValue | target.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.computer_name | target.hostname | 변경 로그에서 매핑됨 |
| winlog.provider_name | metadata.product_name | 변경 로그에서 매핑됨 |
| winlog.event_data.OpCorrelationID | network.session_id | 변경 로그에서 매핑됨 |
| winlog.api","winlog.event_data.AttributeValue","winlog.provider_guid","winlog.event_data.ObjectDN","winlog.event_data.SubjectLogonId","event_data.AttributeSyntaxOID | additional.fields | 변경 로그에서 매핑됨 |
| winlog.record_id | metadata.product_log_id | 변경 로그에서 매핑됨 |
| winlog.event_data.AttributeLDAPDisplayName | target.resource.type | 변경 로그에서 매핑됨 |
| winlog.event_data.ObjectGUID | target.group.product_object_id | 변경 로그에서 매핑됨 |
| winlog.channel","winlog.process.thread.id","winlog.event_data.DSType","winlog.event_data.ObjectClass | security_result.about.resource.attribute.labels | 변경 로그에서 매핑됨 |
| winlog.event_data.DSName | target.hostname | 변경 로그에서 매핑됨 |
| winlog.event_id | metadata.product_event_type | 변경 로그에서 매핑됨 |
| source.ip | principal.ip | 변경 로그에서 매핑됨 |
| source.port | principal.port | 변경 로그에서 매핑됨 |
| user.name | principal.user.user_display_name | 변경 로그에서 매핑됨 |
| related.user | principal.user.group_identifiers | 변경 로그에서 매핑됨 |
이 파서에는 필드 매핑 정보를 사용할 수 없습니다.
변경 로그
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.