Fortinet Switch 로그 수집

파서 버전: 1.0

다음에서 지원:

이 가이드에서는 Bindplane 에이전트를 사용하여 Fortinet Switch 로그를 Google Security Operations로 수집하는 방법을 설명합니다.

Fortinet Switch는 엔터프라이즈 네트워크를 위해 설계된 안전한 고성능 이더넷 스위치 제품군입니다. FortiSwitch는 레이어 2 및 레이어 3 전환 기능, VLAN 지원, 링크 집계, PoE (Power over Ethernet) 및 통합 보안 기능을 제공합니다. FortiSwitch 장치는 독립형 모드로 작동하거나 FortiLink를 통해 FortiGate 방화벽으로 관리할 수 있습니다.

시작하기 전에

다음 기본 요건이 충족되었는지 확인합니다.

  • Google SecOps 인스턴스
  • Windows Server 2016 이상 또는 systemd가 있는 Linux 호스트
  • Bindplane 에이전트와 Fortinet Switch 간의 네트워크 연결
  • 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
  • Fortinet Switch 관리 콘솔 또는 FortiGate 콘솔 (관리형 스위치용)에 대한 권한 있는 액세스
  • FortiSwitchOS 7.0 이상을 실행하는 Fortinet Switch

Bindplane 에이전트의 Google SecOps 사용자 인증 정보 가져오기

Google SecOps에 Bindplane 에이전트를 인증하려면 다음 방법 중 하나를 선택하세요.

  • 새 배포: Chronicle API (옵션 1)를 사용합니다.
  • 기존 배포: 2027년 7월 20일에 Ingestion API가 중단될 때까지 데이터 수집 인증 파일 (옵션 2)을 계속 사용합니다.
  1. Google Cloud 콘솔에 로그인하고 Google SecOps 인스턴스에 연결된 Google Cloud 프로젝트를 선택합니다.
  2. IAM 및 관리자 > 서비스 계정 으로 이동합니다.
  3. 서비스 계정 만들기 를 클릭합니다.
  4. 다음 구성 세부정보를 제공합니다.
    • 서비스 계정 이름: 계정 이름을 입력합니다 (예: bindplane-ingest).
    • 서비스 계정 설명: 설명을 입력합니다 (예: Bindplane agent log ingestion).
  5. 만들고 계속하기 를 클릭합니다.
  6. 이 서비스 계정에 프로젝트에 대한 액세스 권한 부여 섹션에서 역할 선택 을 클릭하고 Chronicle 편집자 를 선택합니다.
  7. 계속을 클릭한 다음 완료를 클릭합니다.
  8. 만든 서비스 계정을 클릭한 다음 키 탭으로 이동합니다.
  9. 키 추가 > 새 키 만들기 를 클릭합니다.
  10. JSON 을 선택하고 만들기 를 클릭합니다. 키 파일이 컴퓨터에 다운로드됩니다.
  11. 키 파일을 Bindplane 수집기 디렉터리(/opt/observiq-otel-collector/ingestion-auth.json(Linux) 또는 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json(Windows))에 ingestion-auth.json으로 저장하거나 config.yaml에서 creds_file_path를 저장하는 경로와 일치하도록 업데이트합니다.
  12. IAM 및 관리자 > 설정 으로 이동하여 프로젝트 번호 를 복사합니다. 내보내기 구성에 필요합니다.

옵션 2: 데이터 수집 인증 파일 다운로드 (기존)

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 수집 에이전트 로 이동합니다.
  3. 데이터 수집 인증 파일 을 다운로드합니다.
  4. Bindplane 에이전트가 설치될 시스템에 파일을 안전하게 저장합니다.

Google SecOps 고객 ID 가져오기

  1. Google SecOps 콘솔에 로그인합니다.
  2. SIEM 설정 > 프로필 로 이동합니다.
  3. 조직 세부정보 섹션에서 고객 ID 를 복사하여 저장합니다.

Bindplane 에이전트 설치

다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.

Windows 설치

  1. 관리자 권한으로 명령 프롬프트 또는 PowerShell 을 엽니다.
  2. 다음 명령어를 실행합니다.

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sc query observiq-otel-collector
    

    서비스가 RUNNING 으로 표시되어야 합니다.

Linux 설치

  1. 루트 또는 sudo 권한으로 터미널을 엽니다.
  2. 다음 명령어를 실행합니다.

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 설치가 완료될 때까지 기다립니다.

  4. 다음을 실행하여 설치를 확인합니다.

    sudo systemctl status observiq-otel-collector
    

    서비스가 active (running) 으로 표시되어야 합니다.

추가 설치 리소스

추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.

syslog를 수집하고 Google SecOps로 전송하도록 Bindplane 에이전트 구성

구성 파일 찾기

Linux:

sudo nano /opt/observiq-otel-collector/config.yaml

Windows:

notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"

구성 파일 설정

다음 구성으로 config.yaml의 전체 콘텐츠를 바꿉니다.

receivers:
  udplog:
    listen_address: "0.0.0.0:514"

exporters:
  chronicle/fortiswitch:
    protocol: https
    # Region of your instance, for example us, europe, asia-southeast1
    location: <LOCATION>
    # Project number of the Google Cloud project linked to the instance
    project: '<PROJECT_NUMBER>'
    compression: gzip
    creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
    customer_id: 'YOUR_CUSTOMER_ID'
    endpoint: chronicle.googleapis.com
    log_type: FORTINET_SWITCH
    raw_log_field: body
    ingestion_labels:
      env: production

service:
  pipelines:
    logs/fortiswitch_to_chronicle:
      receivers:
        - udplog
      exporters:
        - chronicle/fortiswitch

구성 매개변수

다음 자리표시자를 바꿉니다.

수신기 구성:

  • 수신기는 Fortinet Switch의 syslog 메시지를 위해 UDP 포트 514에서 수신 대기하도록 구성됩니다.
  • 모든 인터페이스에서 수신 대기하려면 0.0.0.0:514를 사용합니다.
  • Linux에서 권한이 없는 포트를 사용하려면 0.0.0.0:1514로 변경하고 포트 1514로 전송하도록 Fortinet Switch를 구성합니다.

내보내기 구성:

  • creds_file_path: 서비스 계정 JSON 키 파일의 전체 경로 (옵션 1):
    • Linux: /opt/observiq-otel-collector/ingestion-auth.json
    • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
  • customer_id: 이전 단계의 고객 ID입니다.
  • location: <LOCATION>을 Google SecOps 인스턴스의 리전 (예: us, europe 또는 asia-southeast1)으로 바꿉니다. 내보내기는 이 값으로 chronicle.googleapis.com에 접두사를 붙입니다. 전체 목록은 리전 엔드포인트를 참고하세요.
  • project: <PROJECT_NUMBER>을(를) IAM 및 관리자 > 설정의 프로젝트 번호로 바꿉니다.
  • endpoint: chronicle.googleapis.com으로 설정된 상태로 유지합니다.
  • log_type: 정확히 FORTINET_SWITCH여야 합니다.
  • ingestion_labels: YAML 형식의 선택적 라벨 (예: env: production)

기존 Ingestion API 내보내기

  • 옵션 2의 데이터 수집 인증 파일을 사용하는 경우 exporters 블록을 다음으로 바꿉니다. creds_file_path를 데이터 수집 인증 파일의 경로로 설정하고 인스턴스가 미국 외부에 있는 경우 malachiteingestion-pa.googleapis.com을(를) 리전 엔드포인트(예: europe-malachiteingestion-pa.googleapis.com)로 바꿉니다.

    exporters:
      chronicle/fortiswitch:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: 'YOUR_CUSTOMER_ID'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: FORTINET_SWITCH
        raw_log_field: body
        ingestion_labels:
          env: production
    

구성 파일 저장

수정 후 파일을 저장합니다.

  • Linux: Ctrl+O를 누른 다음 Enter을 누르고 Ctrl+X를 누릅니다.
  • Windows: File > Save를 클릭합니다.

Bindplane 에이전트를 다시 시작하여 변경사항 적용

  • Linux

    sudo systemctl restart observiq-otel-collector
    
    1. 서비스가 실행 중인지 확인합니다.

      sudo systemctl status observiq-otel-collector
      
    2. 로그에서 오류를 확인합니다.

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows

    다음 옵션 중 하나를 선택합니다.

    • 명령 프롬프트 또는 PowerShell을 관리자로 사용:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 서비스 콘솔 사용:

      1. Win+R을 누르고 services.msc를 입력한 다음 Enter 를 누릅니다.
      2. observIQ OpenTelemetry Collector 를 찾습니다.
      3. 마우스 오른쪽 버튼을 클릭하고 다시 시작 을 선택합니다.

      4. 서비스가 실행 중인지 확인합니다.

        sc query observiq-otel-collector
        
      5. 로그에서 오류를 확인합니다.

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Fortinet Switch syslog 전달 구성

Bindplane 에이전트로 로그를 전송하도록 Fortinet Switch를 구성합니다. 구성 단계는 스위치가 독립형인지 FortiGate에서 관리하는지에 따라 다릅니다.

독립형 FortiSwitch (GUI 구성)의 경우

  1. FortiSwitch 웹 인터페이스에 로그인합니다.
  2. 로그 > 구성 으로 이동합니다.
  3. Syslog 에서 사용 설정 을 선택합니다.
  4. 로깅할 이벤트의 심각도를 선택합니다 (예: 정보 이상).
  5. 서버 필드에 Bindplane 에이전트 호스트의 IP 주소 또는 정규화된 도메인 이름을 입력합니다.
  6. 포트 필드에 514 (또는 Bindplane 에이전트에 구성된 포트)를 입력합니다.
  7. 시설 드롭다운에서 local7 을 선택합니다.
  8. 적용 을 클릭합니다.

독립형 FortiSwitch (CLI 구성)의 경우

  1. SSH 또는 콘솔을 통해 FortiSwitch CLI에 로그인합니다.
  2. 다음 명령어를 입력합니다.

    config log syslogd setting
        set status enable
        set server <BINDPLANE_AGENT_IP>
        set port 514
        set facility local7
    end
    
    config log syslogd filter
        set severity information
    end
    

    <BINDPLANE_AGENT_IP>를 Bindplane 에이전트 호스트의 IP 주소로 바꿉니다.

  3. 구성 확인

    show log syslogd setting
    

FortiGate에서 관리하는 FortiSwitch의 경우

FortiGate에서 FortiSwitch를 관리하는 경우 FortiGate CLI에서 syslog 전달을 구성합니다.

  1. SSH 또는 콘솔을 통해 FortiGate CLI에 로그인합니다.
  2. 다음 명령어를 입력하여 관리형 FortiSwitch의 원격 syslog를 구성합니다.

    config switch-controller remote-log
        edit "chronicle-syslog"
            set status enable
            set server <BINDPLANE_AGENT_IP>
            set port 514
            set severity information
            set facility local7
        next
    end
    

    <BINDPLANE_AGENT_IP>를 Bindplane 에이전트 호스트의 IP 주소로 바꿉니다.

  3. 구성 확인

    show switch-controller remote-log
    
  4. FortiGate 방화벽 정책이 FortiLink 인터페이스에서 Bindplane 에이전트가 있는 인터페이스로 syslog 트래픽을 허용하는지 확인합니다. 필요한 경우 정책을 만듭니다.

    config firewall policy
        edit 0
            set srcintf <fortilink_interface>
            set dstintf <bindplane_interface>
            set srcaddr "all"
            set dstaddr "all"
            set action accept
            set schedule "always"
            set service "SYSLOG"
        next
    end
    

    <fortilink_interface>를 FortiLink 인터페이스 이름으로 바꾸고 <bindplane_interface>를 Bindplane 에이전트에 연결할 수 있는 인터페이스로 바꿉니다.

UDM 매핑 테이블

로그 필드 UDM 매핑 로직
metadata.event_type 이 레코드로 표시되는 이벤트 유형입니다.
이벤트 metadata.product_event_type 제품에서 보고한 이벤트 유형입니다.
log_id metadata.product_log_id 제품에서 할당한 로그 항목의 고유 식별자입니다.
device_id principal.asset.asset_id 저작물의 고유 식별자입니다.
devname principal.asset.hostname 주체와 연결된 저작물의 호스트 이름입니다.
devname principal.hostname 주체와 연결된 호스트 이름입니다.
vd principal.user.attribute.labels 사용자와 연결된 라벨 목록입니다.
oldrole principal.user.attribute.roles 사용자와 연결된 역할 목록입니다.
단위 principal.user.role_description 사용자의 역할에 관한 설명입니다.
사용자 principal.user.userid 사용자의 고유 식별자입니다.
action security_result.action_details 취해진 작업에 관한 세부정보입니다.
msg security_result.description 보안 결과에 관한 설명입니다.
type, subtype, switch.physical-port, instanceid security_result.detection_fields 감지에 사용된 필드 목록입니다.
pri security_result.priority_details 이벤트의 우선순위에 관한 세부정보입니다.
상태 security_result.summary 보안 결과 요약입니다.
newrole target.user.attribute.roles 타겟 사용자와 연결된 역할 목록입니다.
metadata.product_name 이벤트를 생성한 제품의 이름입니다.
metadata.vendor_name 제품을 생산한 공급업체의 이름입니다.

변경 로그

이 파서의 변경 로그 보기

도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.