Cisco Secure Network Analytics のログを収集する

パーサーのバージョン: 19.0

以下でサポートされています。

このドキュメントでは、Bindplane エージェントを使用して Cisco Secure Network Analytics(以前の Stealthwatch)ログを Google Security Operations に取り込む方法について説明します。

Cisco Secure Network Analytics は、既存のネットワーク インフラストラクチャからのテレメトリーを使用して脅威を検出するネットワーク トラフィック分析ソリューションです。ネットワーク アクティビティの可視化、異常な動作の特定、コマンド&コントロール通信、ラテラル ムーブメント、データ引き出しなどの高度な脅威の検出を、エージェントや追加のハードウェアを必要とせずに行うことができます。

始める前に

次の前提条件を満たしていることを確認してください。

  • Google SecOps インスタンス。
  • Windows Server 2016 以降、または systemd を使用する Linux ホスト。
  • プロキシの背後で実行している場合は、Bindplane エージェントの要件に従ってファイアウォール ポートが開いていることを確認します。
  • Cisco Secure Network Analytics Manager(以前の Stealthwatch Management Console)への特権アクセス。
  • Cisco Secure Network Analytics Manager と Bindplane エージェント ホスト間のネットワーク接続(UDP ポート 514 または選択した Syslog ポート)。

Google SecOps の取り込み認証ファイルを取得する

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [収集エージェント] に移動します。
  3. 取り込み認証ファイルをダウンロードする
  4. Bindplane をインストールするシステムにファイルを安全に保存します。

Google SecOps のお客様 ID を取得する

  1. Google SecOps コンソールにログインします。
  2. [SIEM 設定] > [プロファイル] に移動します。
  3. [組織の詳細情報] セクションから [お客様 ID] をコピーして保存します。

Bindplane エージェントをインストールする

次の手順に沿って、Windows または Linux オペレーティング システムに Bindplane エージェントをインストールします。

Windows のインストール

  1. 管理者としてコマンド プロンプトまたは PowerShell を開きます。
  2. 次のコマンドを実行します。

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sc query observiq-otel-collector
    

    サービスは RUNNING と表示されます。

Linux のインストール

  1. root 権限または sudo 権限でターミナルを開きます。
  2. 次のコマンドを実行します。

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. インストールが完了するまで待ちます。

  4. 次のコマンドを実行して、インストールの内容を確認します。

    sudo systemctl status observiq-otel-collector
    

    サービスが [アクティブ(実行中)] と表示されます。

その他のインストール リソース

その他のインストール オプションとトラブルシューティングについては、Bindplane エージェントのインストール ガイドをご覧ください。

syslog を取り込んで Google SecOps に送信するように Bindplane エージェントを構成する

構成ファイルを探す

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

構成ファイルを編集します。

  • config.yaml の内容全体を次の構成に置き換えます。

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/cisco_sna:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: 'your-customer-id-here'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: CISCO_STEALTHWATCH
            raw_log_field: body
            ingestion_labels:
    
    service:
        pipelines:
            logs/cisco_sna_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/cisco_sna
    

構成パラメータ

各プレースホルダを次のように置き換えます。

  • レシーバーの構成:

    • listen_address: リッスンする IP アドレスとポート。すべてのインターフェースでリッスンするには、0.0.0.0 を使用します。ポートは、Cisco Secure Network Analytics で構成されたポートと一致する必要があります(デフォルト: 514)。
  • エクスポータの構成:

    • creds_file_path: 取り込み認証ファイルのフルパス:
      • Linux: /etc/bindplane-agent/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id: Google SecOps からコピーしたお客様 ID。
    • endpoint: リージョナル エンドポイント URL:
      • 米国: malachiteingestion-pa.googleapis.com
      • ヨーロッパ: europe-malachiteingestion-pa.googleapis.com
      • アジア: asia-southeast1-malachiteingestion-pa.googleapis.com
      • 完全なリストについては、リージョン エンドポイントをご覧ください。

構成ファイルを保存する

  • 編集後、ファイルを保存します。
    • Linux: Ctrl+OEnterCtrl+X の順に押します。
    • Windows: [ファイル] > [保存] をクリックします。

Bindplane エージェントを再起動して変更を適用する

  • Linux で Bindplane エージェントを再起動するには、次のコマンドを実行します。

    sudo systemctl restart observiq-otel-collector
    
    1. サービスが実行されていることを確認します。

      sudo systemctl status observiq-otel-collector
      
    2. ログでエラーを確認します。

      sudo journalctl -u observiq-otel-collector -f
      
  • Windows で Bindplane エージェントを再起動するには、次のいずれかのオプションを選択します。

    • 管理者としてコマンド プロンプトまたは PowerShell を開きます。
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • サービス コンソール:

      1. Win+R キーを押して「services.msc」と入力し、Enter キーを押します。
      2. observIQ OpenTelemetry Collector を見つけます。
      3. 右クリックして [再起動] を選択します。
      4. サービスが実行されていることを確認します。

        sc query observiq-otel-collector
        
      5. ログでエラーを確認します。

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

Cisco Secure Network Analytics の syslog 転送を構成する

  1. Cisco Secure Network Analytics Manager(以前の Stealthwatch Management Console)にログインします。
  2. [構成] > [検出レスポンス管理] に移動します。
  3. [アクション] タブをクリックします。
  4. リストでデフォルトの [Syslog に送信] アクションを見つけます。
  5. [Syslog に送信] の横にある [アクション] 列の省略記号(...)をクリックし、[編集] をクリックします。
  6. 次の構成の詳細を指定します。
    • Syslog サーバー アドレス: Bindplane エージェント ホストの IP アドレスを入力します。
    • UDP ポート: 514(または Bindplane エージェント config.yaml で構成されたポート)を入力します。
    • メッセージ形式: [CEF] を選択します。
  7. 右上にある青色の [保存] ボタンをクリックします。
  8. [ルール] タブをクリックします。
  9. [新しいルールを追加] をクリックするか、既存のルールを編集します。
  10. ルール条件を構成して、syslog アクションをトリガーするアラームを定義します。
    • ホスト アラーム: 転送するアラーム カテゴリを選択します(例: High Concern IndexExfiltrationCommand and Control)。
    • Host Group Relationship Alarm: 転送する関係ポリシーを選択します(例: High TrafficSYN Flood)。
  11. [レスポンス アクション] セクションで、[Syslog に送信] アクションを選択します。
  12. [保存] をクリックします。
  13. Bindplane エージェントのログを確認して、syslog メッセージが受信されていることを確認します。

詳細については、Cisco Secure Network Analytics のドキュメントResponse Management の syslog 構成ガイドをご覧ください。

UDM マッピング テーブル

ログフィールド UDM マッピング ロジック
_about about 統合済み
about about 統合済み
deviceNtDomain about.administrative_domain 名前変更済み/マッピング済み
deviceExternalId about.asset.asset_id 直接マッピングされます。
device_product about.asset.asset_id 直接マッピングされます。
device_vendor about.asset.asset_id 直接マッピングされます。
fileHash about.file.full_path 直接マッピングされます。
filePath about.file.full_path 名前変更済み/マッピング済み
_hash about.file.sha256 名前変更済み/マッピング済み
fileHash about.file.sha256 名前変更済み/マッピング済み
fsize about.file.size 名前変更済み/マッピング済み
dvchost about.hostname 名前変更済み/マッピング済み
ips about.ip 統合済み
dvcmac about.mac 統合済み
mac_address about.mac 統合済み
deviceTranslatedAddress about.nat_ip 統合済み
Emne about.process.command_line 直接マッピングされます。
Path about.process.command_line 直接マッピングされます。
Subject about.process.command_line 直接マッピングされます。
deviceProcessName about.process.command_line 名前変更済み/マッピング済み
dvcpid about.process.pid 名前変更済み/マッピング済み
permissions about.resource.attribute.permissions 統合済み
additional_cfp1 additional.fields 統合済み
additional_cfp2 additional.fields 統合済み
additional_cfp3 additional.fields 統合済み
additional_cfp4 additional.fields 統合済み
additional_cn1 additional.fields 統合済み
additional_cn2 additional.fields 統合済み
additional_cn3 additional.fields 統合済み
additional_cs1 additional.fields 統合済み
additional_cs2 additional.fields 統合済み
additional_cs3 additional.fields 統合済み
additional_cs4 additional.fields 統合済み
additional_cs5 additional.fields 統合済み
additional_cs6 additional.fields 統合済み
additional_cs7 additional.fields 統合済み
additional_devicePayloadId additional.fields 統合済み
additional_eventId additional.fields 統合済み
additional_flexString1 additional.fields 統合済み
additional_fname additional.fields 統合済み
cs5_label additional.fields 統合済み
field_ additional.fields 統合済み
_intermediary intermediary 統合済み
data.short_text metadata.description 直接マッピングされます。
desc metadata.description 直接マッピングされます。
description metadata.description 直接マッピングされます。
leef.fullmessage metadata.description 直接マッピングされます。
msg metadata.description 名前変更済み/マッピング済み
short_text metadata.description 直接マッピングされます。
device_event_class_id metadata.product_event_type 直接マッピングされます。
eventData_id metadata.product_event_type 直接マッピングされます。
event_name metadata.product_event_type 直接マッピングされます。
reportName metadata.product_event_type 直接マッピングされます。
externalId metadata.product_log_id 直接マッピングされます。
id metadata.product_log_id 直接マッピングされます。
device_product metadata.product_name 直接マッピングされます。
Version metadata.product_version 直接マッピングされます。
device_version metadata.product_version 直接マッピングされます。
version metadata.product_version 直接マッピングされます。
device_vendor metadata.vendor_name 名前変更済み/マッピング済み
app_protocol_output network.application_protocol 直接マッピングされます。
protocol network.application_protocol 直接マッピングされます。
method network.http.method 直接マッピングされます。
requestMethod network.http.method 名前変更済み/マッピング済み
requestClientApplication network.http.user_agent 名前変更済み/マッピング済み
ip_protocol_out network.ip_protocol 直接マッピングされます。
ServerBytes network.received_bytes 名前変更済み/マッピング済み
in network.received_bytes 名前変更済み/マッピング済み
peerBytes network.received_bytes 名前変更済み/マッピング済み
data.packets_in network.received_packets 直接マッピングされます。
packets_in network.received_packets 直接マッピングされます。
ClientBytes network.sent_bytes 名前変更済み/マッピング済み
hostBytes network.sent_bytes 名前変更済み/マッピング済み
out network.sent_bytes 名前変更済み/マッピング済み
data.packets_out network.sent_packets 直接マッピングされます。
packets_out network.sent_packets 直接マッピングされます。
session_id network.session_id 直接マッピングされます。
SourceModuleType observer.application 直接マッピングされます。
leef_flowCollectorIP observer.asset.ip 統合済み
leef.flowCollectorName observer.hostname 直接マッピングされます。
leef_flowCollectorIP observer.ip 統合済み
leef.domain principal.administrative_domain 直接マッピングされます。
sntdom principal.administrative_domain 名前変更済み/マッピング済み
sourceServiceName principal.application 名前変更済み/マッピング済み
details.title principal.asset.hostname 直接マッピングされます。
hostname principal.asset.hostname 直接マッピングされます。
prin_host principal.asset.hostname 直接マッピングされます。
source_name principal.asset.hostname 直接マッピングされます。
ClientIP principal.asset.ip 統合済み
MessageSourceAddress principal.asset.ip 統合済み
connected_ip principal.asset.ip 統合済み
data.connected_ip principal.asset.ip 統合済み
details.ip principal.asset.ip 統合済み
host.ipAddress principal.asset.ip 統合済み
host_ip principal.asset.ip 統合済み
ip principal.asset.ip 統合済み
leef.src principal.asset.ip 統合済み
prin_ip principal.asset.ip 統合済み
sourceIPv4Address principal.asset.ip 統合済み
source_name principal.asset.ip 統合済み
src_ip principal.asset.ip 統合済み
Group_name principal.group.group_display_name 直接マッピングされます。
Gruppenavn principal.group.group_display_name 直接マッピングされます。
Device_name principal.hostname 直接マッピングされます。
Enhetsnavn principal.hostname 直接マッピングされます。
details.title principal.hostname 直接マッピングされます。
hostname principal.hostname 直接マッピングされます。
prin_host principal.hostname 直接マッピングされます。
shost principal.hostname 名前変更済み/マッピング済み
source_name principal.hostname 直接マッピングされます。
ClientIP principal.ip 統合済み
MessageSourceAddress principal.ip 統合済み
connected_ip principal.ip 統合済み
data.connected_ip principal.ip 統合済み
details.ip principal.ip 統合済み
host.ipAddress principal.ip 統合済み
host_ip principal.ip 統合済み
ip principal.ip 統合済み
leef.src principal.ip 統合済み
prin_ip principal.ip 統合済み
principal_ip principal.ip 統合済み
shost principal.ip 統合済み
sourceIPv4Address principal.ip 統合済み
source_name principal.ip 統合済み
src_ip principal.ip 統合済み
Source_HG principal.location.country_or_region 直接マッピングされます。
host.country principal.location.country_or_region 直接マッピングされます。
leef.sourceHG principal.location.country_or_region 直接マッピングされます。
ClientMAC principal.mac 統合済み
mac principal.mac 統合済み
source_mac_address principal.mac 統合済み
source_info.namespace principal.namespace 直接マッピングされます。
sourceTranslatedAddress principal.nat_ip 統合済み
sourceTranslatedPort principal.nat_port 名前変更済み/マッピング済み
ClientPort principal.port 名前変更済み/マッピング済み
SourcePort principal.port 名前変更済み/マッピング済み
data.port principal.port 名前変更済み/マッピング済み
port principal.port 名前変更済み/マッピング済み
spt principal.port 名前変更済み/マッピング済み
sproc principal.process.command_line 名前変更済み/マッピング済み
process_name principal.process.file.full_path 直接マッピングされます。
process_pid principal.process.pid 直接マッピングされます。
spid principal.process.pid 名前変更済み/マッピング済み
Source_HostSnapshot principal.url 直接マッピングされます。
leef.sourceHostSnapshot principal.url 直接マッピングされます。
principal_role principal.user.attribute.roles 統合済み
actor_email principal.user.email_addresses 統合済み
actor_name principal.user.email_addresses 統合済み
UserName principal.user.user_display_name 直接マッピングされます。
actor.username principal.user.user_display_name 直接マッピングされます。
data.actor.username principal.user.user_display_name 直接マッピングされます。
source_username principal.user.user_display_name 直接マッピングされます。
suser principal.user.user_display_name 直接マッピングされます。
actor.id principal.user.userid 直接マッピングされます。
data.actor.id principal.user.userid 直接マッピングされます。
suid principal.user.userid 名前変更済み/マッピング済み
user_name principal.user.userid 直接マッピングされます。
security_res security_result 統合済み
security_result security_result 統合済み
_action security_result.action 統合済み
Action_Taken security_result.action_details 直接マッピングされます。
act security_result.action_details 直接マッピングされます。
cat security_result.category_details 統合済み
Scan_Type security_result.description 直接マッピングされます。
Type security_result.description 直接マッピングされます。
msg_data_2 security_result.description 直接マッピングされます。
infection_channel_label security_result.detection_fields 統合済み
operasjon_label security_result.detection_fields 統合済み
operation_label security_result.detection_fields 統合済み
permission_label security_result.detection_fields 統合済み
spyware_Grayware_Type_label security_result.detection_fields 統合済み
threat_probability_label security_result.detection_fields 統合済み
tillatelse_label security_result.detection_fields 統合済み
mwProfile security_result.rule_name 直接マッピングされます。
Result security_result.summary 直接マッピングされます。
appcategory security_result.summary 直接マッピングされます。
reason security_result.summary 名前変更済み/マッピング済み
Spyware security_result.threat_name 直接マッピングされます。
Unknown_Threat security_result.threat_name 直接マッピングされます。
Virus_Malware_Name security_result.threat_name 直接マッピングされます。
oldFilePath src.file.full_path 名前変更済み/マッピング済み
oldFileSize src.file.size 名前変更済み/マッピング済み
old_permissions src.resource.attribute.permissions 統合済み
dntdom target.administrative_domain 名前変更済み/マッピング済み
destinationServiceName target.application 名前変更済み/マッピング済み
target_hostname target.asset.hostname 直接マッピングされます。
DestIPv4Address target.asset.ip 統合済み
ServerIP target.asset.ip 統合済み
ipt target.asset.ip 統合済み
leef.dst target.asset.ip 統合済み
peer.ipAddress target.asset.ip 統合済み
file_path target.file.full_path 直接マッピングされます。
file_type target.file.mime_type 直接マッピングされます。
target_hostname target.hostname 直接マッピングされます。
temp_dhost target.hostname 直接マッピングされます。
DestIPv4Address target.ip 統合済み
IPv6_Address target.ip 統合済み
ServerIP target.ip 統合済み
dst_ip target.ip 統合済み
ipt target.ip 統合済み
leef.dst target.ip 統合済み
peer.ipAddress target.ip 統合済み
peer.country target.location.country_or_region 直接マッピングされます。
ServerMAC target.mac 統合済み
mac_address target.mac 統合済み
target_mac_address target.mac 統合済み
destination_translated_address target.nat_ip 統合済み
destinationTranslatedPort target.nat_port 名前変更済み/マッピング済み
DestPort target.port 名前変更済み/マッピング済み
ServerPort target.port 名前変更済み/マッピング済み
dpt target.port 名前変更済み/マッピング済み
dproc target.process.command_line 名前変更済み/マッピング済み
File_name target.process.file.full_path 直接マッピングされます。
Infected_Resource target.process.file.full_path 直接マッピングされます。
Object target.process.file.full_path 直接マッピングされます。
Objekt target.process.file.full_path 直接マッピングされます。
dpid target.process.pid 名前変更済み/マッピング済み
process_id target.process.pid 直接マッピングされます。
resource_Type_label target.resource.attribute.labels 統合済み
SourceModuleName target.resource.name 直接マッピングされます。
Target_HostSnapshot target.url 直接マッピングされます。
leef.targetHostSnapshot target.url 直接マッピングされます。
request target.url 直接マッピングされます。
target_role target.user.attribute.roles 統合済み
CustomerName target.user.user_display_name 直接マッピングされます。
temp_duser target.user.user_display_name 直接マッピングされます。
Bruker target.user.userid 直接マッピングされます。
User_value target.user.userid 直接マッピングされます。
temp_duid target.user.userid 直接マッピングされます。
sid target.user.windows_sid 直接マッピングされます。
該当なし about 定数: about
該当なし about.ip 定数: ips
該当なし about.mac 定数: mac_address
該当なし about.nat_ip 定数: deviceTranslatedAddress
該当なし about.resource.attribute.permissions 定数: permissions
該当なし additional.fields 定数: additional_eventId
該当なし intermediary 定数: _intermediary
該当なし metadata.event_type 定数: PROCESS_UNCATEGORIZED
該当なし metadata.product_name 定数: Cisco Stealthwatch
該当なし metadata.vendor_name 定数: Cisco
該当なし network.direction 定数: INBOUND
該当なし network.ip_protocol 定数: TCP
該当なし observer.asset.ip 定数: leef_flowCollectorIP
該当なし observer.ip 定数: leef_flowCollectorIP
該当なし principal.asset.ip 定数: host_ip
該当なし principal.ip 定数: host_ip
該当なし principal.mac 定数: mac
該当なし principal.nat_ip 定数: sourceTranslatedAddress
該当なし principal.user.attribute.roles 定数: principal_role
該当なし principal.user.email_addresses 定数: actor_name
該当なし security_result 定数: security_result
該当なし security_result.action 定数: _action
該当なし security_result.category_details 定数: cat
該当なし security_result.detection_fields 定数: operation_label
該当なし security_result.severity 定数: LOW
該当なし src.resource.attribute.permissions 定数: old_permissions
該当なし target.asset.ip 定数: leef.dst
該当なし target.ip 定数: leef.dst
該当なし target.mac 定数: mac_address
該当なし target.nat_ip 定数: destination_translated_address
該当なし target.resource.attribute.labels 定数: resource_Type_label
該当なし target.user.attribute.roles 定数: target_role
ProtocolIdentifier network.ip_protocol 変更履歴からマッピング
inputSNMPIface", "outputSNMPIface", "InPackets additional.fields 変更履歴からマッピング

変更履歴

このパーサーの変更ログを表示する

さらにサポートが必要な場合 コミュニティ メンバーや Google SecOps のプロフェッショナルから回答を得ることができます。