Cisco Secure Email 및 웹 로그 수집
이 문서에서는 Bindplane 에이전트를 사용하여 Cisco Secure Email and Web (이전 명칭: IronPort) 로그를 Google Security Operations로 수집하는 방법을 설명합니다.
Cisco Secure Email and Web은 스팸, 피싱, 멀웨어, 데이터 손실과 같은 이메일 기반 위협으로부터 조직을 보호하는 보안 게이트웨이 솔루션입니다. 인바운드 및 아웃바운드 이메일과 웹 트래픽에 대한 지능형 위협 방어, 콘텐츠 필터링, 암호화, URL 방어를 제공합니다. 게이트웨이는 Cisco AsyncOS를 실행하고 syslog 푸시를 비롯한 여러 검색 방법을 사용하여 중앙 집중식 로깅을 지원합니다.
시작하기 전에
다음 기본 요건이 충족되었는지 확인합니다.
- Google SecOps 인스턴스
- Windows Server 2016 이상 또는
systemd가 설치된 Linux 호스트 - 프록시 뒤에서 실행하는 경우 Bindplane 에이전트 요구사항에 따라 방화벽 포트가 열려 있는지 확인합니다.
- Cisco Secure Email and Web 관리 콘솔에 대한 권한 있는 액세스 (관리자 역할)
- 구성된 syslog 포트의 Cisco Secure Email and Web 어플라이언스와 Bindplane 에이전트 호스트 간의 네트워크 연결
Google SecOps 수집 인증 파일 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 수집 에이전트로 이동합니다.
- 수집 인증 파일을 다운로드합니다.
Bindplane이 설치될 시스템에 파일을 안전하게 저장합니다.
Google SecOps 고객 ID 가져오기
- Google SecOps 콘솔에 로그인합니다.
- SIEM 설정 > 프로필로 이동합니다.
조직 세부정보 섹션에서 고객 ID를 복사하여 저장합니다.
Bindplane 에이전트 설치
다음 안내에 따라 Windows 또는 Linux 운영체제에 Bindplane 에이전트를 설치합니다.
Windows 설치
- 명령 프롬프트 또는 PowerShell을 관리자로 엽니다.
다음 명령어를 실행합니다.
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sc query observiq-otel-collector서비스가 실행 중으로 표시되어야 합니다.
Linux 설치
- 루트 또는 sudo 권한으로 터미널을 엽니다.
다음 명령어를 실행합니다.
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh설치가 완료될 때까지 기다립니다.
다음을 실행하여 설치를 확인합니다.
sudo systemctl status observiq-otel-collector서비스가 active (running)으로 표시되어야 합니다.
추가 설치 리소스
추가 설치 옵션 및 문제 해결은 Bindplane 에이전트 설치 가이드를 참고하세요.
syslog를 수집하여 Google SecOps로 전송하도록 Bindplane 에이전트 구성
구성 파일 찾기
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
구성 파일 설정
config.yaml의 전체 내용을 다음 구성으로 바꿉니다.receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/cisco_ironport: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: 'YOUR_CUSTOMER_ID' endpoint: malachiteingestion-pa.googleapis.com log_type: 'CISCO_IRONPORT' raw_log_field: body ingestion_labels: service: pipelines: logs/cisco_ironport_to_chronicle: receivers: - tcplog exporters: - chronicle/cisco_ironport
구성 매개변수
다음 자리표시자를 바꿉니다.
수신기 구성:
tcplog: TCP syslog (Cisco Secure Email and Web에 권장)의 경우tcplog를 사용하고 UDP syslog의 경우udplog를 사용합니다.0.0.0.0: 리슨할 IP 주소 (모든 인터페이스에서 리슨하려면0.0.0.0)514: 리슨할 포트 번호 (표준 syslog 포트)
내보내기 도구 구성:
creds_file_path: 수집 인증 파일의 전체 경로입니다.- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
YOUR_CUSTOMER_ID: 고객 ID 가져오기 섹션의 고객 IDendpoint: 리전 엔드포인트 URL:- 미국:
malachiteingestion-pa.googleapis.com - 유럽:
europe-malachiteingestion-pa.googleapis.com - 아시아:
asia-southeast1-malachiteingestion-pa.googleapis.com - 전체 목록은 리전 엔드포인트를 참고하세요.
- 미국:
log_type: Chronicle에 표시되는 로그 유형 (CISCO_IRONPORT)
구성 파일 저장
- 수정 후 파일을 저장합니다.
- Linux:
Ctrl+O,Enter,Ctrl+X순서로 누릅니다. - Windows: 파일 > 저장을 클릭합니다.
- Linux:
변경사항을 적용하려면 Bindplane 에이전트를 다시 시작하세요.
Linux에서 Bindplane 에이전트를 다시 시작하려면 다음 명령어를 실행합니다.
sudo systemctl restart observiq-otel-collector서비스가 실행 중인지 확인합니다.
sudo systemctl status observiq-otel-collector로그에서 오류를 확인합니다.
sudo journalctl -u observiq-otel-collector -f
Windows에서 Bindplane 에이전트를 다시 시작하려면 다음 옵션 중 하나를 선택합니다.
관리자 권한으로 명령 프롬프트 또는 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector서비스 콘솔:
Win+R키를 누르고services.msc을 입력한 다음 Enter 키를 누릅니다.- observIQ OpenTelemetry Collector를 찾습니다.
- 마우스 오른쪽 버튼을 클릭하고 다시 시작을 선택합니다.
서비스가 실행 중인지 확인합니다.
sc query observiq-otel-collector로그에서 오류를 확인합니다.
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
Cisco Secure Email 및 Web syslog 전달 구성
- Cisco Secure Email and Web 관리 콘솔에 로그인합니다.
- 시스템 관리 > 로그 구독으로 이동합니다.
- 로그 구독 추가를 클릭합니다.
- 다음 구성 세부정보를 제공합니다.
- 로그 유형: 전달할 로그 유형을 선택합니다 (예: 텍스트 메일 로그).
- 로그 이름: 설명이 포함된 이름을 입력합니다 (예:
secops-mail-logs). - 로그 수준: 정보를 선택합니다.
- 가져오기 방법: Syslog 푸시를 선택합니다.
- 호스트 이름: Bindplane 에이전트 호스트의 IP 주소 또는 호스트 이름을 입력합니다.
- 포트:
514(또는 Bindplane 에이전트에서 구성된 포트)를 입력합니다. - 프로토콜: TCP를 선택합니다.
참고: Bindplane 에이전트 수신기에서 구성된 것과 동일한 프로토콜을 선택합니다 (TCP의 경우
tcplog, UDP의 경우udplog). - Facility: 메일 관련 로그의 경우 LOG_MAIL을 선택하고 기타 로그 유형의 경우 LOG_LOCAL0~LOG_LOCAL7을 선택합니다.
- 제출을 클릭합니다.
- 전달하려는 각 로그 유형에 대해 3~5단계를 반복합니다. 사용 가능한 로그 유형은 다음과 같습니다.
- 텍스트 메일 로그
- 시스템 로그
- 안티 스팸 로그
- 바이러스 백신 로그
- AMP 엔진 로그
- 콘텐츠 필터 로그
- 메시지 추적 로그
- LDAP 디버그 로그
- 허용 목록/차단 목록 로그
- 로그 보고
- 업데이터 로그 참고: 인증 로그와 바운스 로그는 Syslog 푸시 가져오기 방법을 지원하지 않습니다.
- 변경사항 커밋을 클릭하여 구성을 적용합니다.
- Bindplane 에이전트 로그를 확인하여 로그가 전송되고 있는지 확인합니다.
자세한 내용은 Cisco Secure Email Gateway 사용자 가이드를 참고하세요.
UDM 매핑 테이블
| 로그 필드 | UDM 매핑 | 논리 |
|---|---|---|
about |
about |
병합됨 |
about1 |
about |
병합됨 |
deviceNtDomain |
about.administrative_domain |
이름이 변경됨/매핑됨 |
deviceExternalId |
about.asset.asset_id |
직접 매핑됨 |
device_product |
about.asset.asset_id |
직접 매핑됨 |
device_vendor |
about.asset.asset_id |
직접 매핑됨 |
fileHash |
about.file.full_path |
직접 매핑됨 |
filePath |
about.file.full_path |
이름이 변경됨/매핑됨 |
file_name |
about.file.full_path |
직접 매핑됨 |
AMP.fileHash |
about.file.sha256 |
직접 매핑됨 |
_hash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fileHash |
about.file.sha256 |
이름이 변경됨/매핑됨 |
fsize |
about.file.size |
이름이 변경됨/매핑됨 |
dvchost |
about.hostname |
이름이 변경됨/매핑됨 |
ips |
about.ip |
병합됨 |
dvcmac |
about.mac |
병합됨 |
mac_address |
about.mac |
병합됨 |
deviceTranslatedAddress |
about.nat_ip |
병합됨 |
Emne |
about.process.command_line |
직접 매핑됨 |
Path |
about.process.command_line |
직접 매핑됨 |
Subject |
about.process.command_line |
직접 매핑됨 |
deviceProcessName |
about.process.command_line |
이름이 변경됨/매핑됨 |
dvcpid |
about.process.pid |
이름이 변경됨/매핑됨 |
permissions |
about.resource.attribute.permissions |
병합됨 |
ESAURLDetails |
about.url |
직접 매핑됨 |
_field |
additional.fields |
병합됨 |
additional_cfp1 |
additional.fields |
병합됨 |
additional_cfp2 |
additional.fields |
병합됨 |
additional_cfp3 |
additional.fields |
병합됨 |
additional_cfp4 |
additional.fields |
병합됨 |
additional_cn1 |
additional.fields |
병합됨 |
additional_cn2 |
additional.fields |
병합됨 |
additional_cn3 |
additional.fields |
병합됨 |
additional_cs1 |
additional.fields |
병합됨 |
additional_cs2 |
additional.fields |
병합됨 |
additional_cs3 |
additional.fields |
병합됨 |
additional_cs4 |
additional.fields |
병합됨 |
additional_cs5 |
additional.fields |
병합됨 |
additional_cs6 |
additional.fields |
병합됨 |
additional_cs7 |
additional.fields |
병합됨 |
additional_devicePayloadId |
additional.fields |
병합됨 |
additional_eventId |
additional.fields |
병합됨 |
additional_flexString1 |
additional.fields |
병합됨 |
additional_fname |
additional.fields |
병합됨 |
cs5_label |
additional.fields |
병합됨 |
cs_uri_label |
additional.fields |
병합됨 |
internal_id_label |
additional.fields |
병합됨 |
s_hierarchy_label |
additional.fields |
병합됨 |
sc_bytes_label |
additional.fields |
병합됨 |
intermediary |
intermediary |
병합됨 |
ESAHeloDomain |
intermediary.administrative_domain |
직접 매핑됨 |
syslog_program |
intermediary.application |
직접 매핑됨 |
hostname |
intermediary.asset.hostname |
직접 매핑됨 |
column3 |
intermediary.hostname |
직접 매핑됨 |
hostname |
intermediary.hostname |
직접 매핑됨 |
s_computerName |
intermediary.hostname |
직접 매핑됨 |
intermediary_ip |
intermediary.ip |
병합됨 |
msg |
metadata.description |
이름이 변경됨/매핑됨 |
msg2 |
metadata.description |
직접 매핑됨 |
device_event_class_id |
metadata.product_event_type |
직접 매핑됨 |
event_name |
metadata.product_event_type |
직접 매핑됨 |
product_event |
metadata.product_event_type |
직접 매핑됨 |
externalId |
metadata.product_log_id |
직접 매핑됨 |
device_product |
metadata.product_name |
직접 매핑됨 |
device_product_name |
metadata.product_name |
직접 매핑됨 |
device_version |
metadata.product_version |
직접 매핑됨 |
device_vendor |
metadata.vendor_name |
이름이 변경됨/매핑됨 |
network |
network |
이름이 변경됨/매핑됨 |
app_protocol_output |
network.application_protocol |
직접 매핑됨 |
from |
network.email.from |
직접 매핑됨 |
mailfrom.sender |
network.email.from |
직접 매핑됨 |
message_id |
network.email.mail_id |
직접 매핑됨 |
subject |
network.email.subject |
병합됨 |
to |
network.email.to |
병합됨 |
cs_method |
network.http.method |
직접 매핑됨 |
http_method |
network.http.method |
직접 매핑됨 |
requestMethod |
network.http.method |
이름이 변경됨/매핑됨 |
cs_user_agent |
network.http.parsed_user_agent |
이름이 변경됨/매핑됨 |
http_response_code |
network.http.response_code |
직접 매핑됨 |
response_code |
network.http.response_code |
직접 매핑됨 |
cs_user_agent |
network.http.user_agent |
직접 매핑됨 |
requestClientApplication |
network.http.user_agent |
이름이 변경됨/매핑됨 |
useragent |
network.http.user_agent |
직접 매핑됨 |
ip_protocol_out |
network.ip_protocol |
직접 매핑됨 |
in |
network.received_bytes |
이름이 변경됨/매핑됨 |
received_bytes |
network.received_bytes |
직접 매핑됨 |
out |
network.sent_bytes |
이름이 변경됨/매핑됨 |
total_bytes |
network.sent_bytes |
이름이 변경됨/매핑됨 |
ESATLSInCipher |
network.tls.cipher |
직접 매핑됨 |
sntdom |
principal.administrative_domain |
이름이 변경됨/매핑됨 |
sourceServiceName |
principal.application |
이름이 변경됨/매핑됨 |
principal_host |
principal.asset.hostname |
직접 매핑됨 |
c_ip |
principal.asset.ip |
병합됨 |
cs_x_forwarded_for |
principal.asset.ip |
병합됨 |
source_ip |
principal.asset.ip |
병합됨 |
src_ip |
principal.asset.ip |
병합됨 |
Group_name |
principal.group.group_display_name |
직접 매핑됨 |
Gruppenavn |
principal.group.group_display_name |
직접 매핑됨 |
Device_name |
principal.hostname |
직접 매핑됨 |
Enhetsnavn |
principal.hostname |
직접 매핑됨 |
principal_host |
principal.hostname |
직접 매핑됨 |
shost |
principal.hostname |
이름이 변경됨/매핑됨 |
c_ip |
principal.ip |
병합됨 |
cs_x_forwarded_for |
principal.ip |
병합됨 |
principal_ip |
principal.ip |
병합됨 |
shost |
principal.ip |
병합됨 |
source_ip |
principal.ip |
병합됨 |
src_ip |
principal.ip |
병합됨 |
mac |
principal.mac |
병합됨 |
sourceTranslatedAddress |
principal.nat_ip |
병합됨 |
sourceTranslatedPort |
principal.nat_port |
이름이 변경됨/매핑됨 |
c_port |
principal.port |
직접 매핑됨 |
spt |
principal.port |
이름이 변경됨/매핑됨 |
src_port |
principal.port |
직접 매핑됨 |
sproc |
principal.process.command_line |
이름이 변경됨/매핑됨 |
processName |
principal.process.file.full_path |
직접 매핑됨 |
spid |
principal.process.pid |
이름이 변경됨/매핑됨 |
principalUrl |
principal.url |
직접 매핑됨 |
principal_role |
principal.user.attribute.roles |
병합됨 |
email |
principal.user.email_addresses |
병합됨 |
helo.sender |
principal.user.email_addresses |
병합됨 |
suser |
principal.user.user_display_name |
직접 매핑됨 |
authenticated_user |
principal.user.userid |
직접 매핑됨 |
cs_username |
principal.user.userid |
직접 매핑됨 |
suid |
principal.user.userid |
이름이 변경됨/매핑됨 |
sec_result |
security_result |
병합됨 |
security_result |
security_result |
병합됨 |
_action |
security_result.action |
병합됨 |
tempaction |
security_result.action |
병합됨 |
Action_Taken |
security_result.action_details |
직접 매핑됨 |
act |
security_result.action_details |
직접 매핑됨 |
cat |
security_result.category_details |
병합됨 |
Scan_Type |
security_result.description |
직접 매핑됨 |
Type |
security_result.description |
직접 매핑됨 |
msg_data_2 |
security_result.description |
직접 매핑됨 |
field1 |
security_result.detection_fields |
병합됨 |
infection_channel_label |
security_result.detection_fields |
병합됨 |
operasjon_label |
security_result.detection_fields |
병합됨 |
operation_label |
security_result.detection_fields |
병합됨 |
permission_label |
security_result.detection_fields |
병합됨 |
spyware_Grayware_Type_label |
security_result.detection_fields |
병합됨 |
threat_probability_label |
security_result.detection_fields |
병합됨 |
tillatelse_label |
security_result.detection_fields |
병합됨 |
mwProfile |
security_result.rule_name |
직접 매핑됨 |
Result |
security_result.summary |
직접 매핑됨 |
appcategory |
security_result.summary |
직접 매핑됨 |
reason |
security_result.summary |
이름이 변경됨/매핑됨 |
Spyware |
security_result.threat_name |
직접 매핑됨 |
Unknown_Threat |
security_result.threat_name |
직접 매핑됨 |
Virus_Malware_Name |
security_result.threat_name |
직접 매핑됨 |
oldFilePath |
src.file.full_path |
이름이 변경됨/매핑됨 |
oldFileSize |
src.file.size |
이름이 변경됨/매핑됨 |
old_permissions |
src.resource.attribute.permissions |
병합됨 |
target |
target |
이름이 변경됨/매핑됨 |
dntdom |
target.administrative_domain |
이름이 변경됨/매핑됨 |
destinationServiceName |
target.application |
이름이 변경됨/매핑됨 |
host |
target.asset.hostname |
직접 매핑됨 |
dst_ip1 |
target.asset.ip |
병합됨 |
ip |
target.asset.ip |
병합됨 |
target_ip |
target.asset.ip |
병합됨 |
host |
target.hostname |
직접 매핑됨 |
s_computerName |
target.hostname |
직접 매핑됨 |
s_hostname |
target.hostname |
직접 매핑됨 |
target_host |
target.hostname |
직접 매핑됨 |
temp_dhost |
target.hostname |
직접 매핑됨 |
IPv6_Address |
target.ip |
병합됨 |
dst_ip |
target.ip |
병합됨 |
dst_ip1 |
target.ip |
병합됨 |
ip |
target.ip |
병합됨 |
target_ip |
target.ip |
병합됨 |
mac_address |
target.mac |
병합됨 |
destination_translated_address |
target.nat_ip |
병합됨 |
destinationTranslatedPort |
target.nat_port |
이름이 변경됨/매핑됨 |
dpt |
target.port |
이름이 변경됨/매핑됨 |
dst_port |
target.port |
직접 매핑됨 |
s_port |
target.port |
직접 매핑됨 |
dproc |
target.process.command_line |
이름이 변경됨/매핑됨 |
File_name |
target.process.file.full_path |
직접 매핑됨 |
Infected_Resource |
target.process.file.full_path |
직접 매핑됨 |
Object |
target.process.file.full_path |
직접 매핑됨 |
Objekt |
target.process.file.full_path |
직접 매핑됨 |
dpid |
target.process.pid |
이름이 변경됨/매핑됨 |
resource_Type_label |
target.resource.attribute.labels |
병합됨 |
request |
target.url |
직접 매핑됨 |
target_url |
target.url |
직접 매핑됨 |
url1 |
target.url |
직접 매핑됨 |
url2 |
target.url |
직접 매핑됨 |
target_role |
target.user.attribute.roles |
병합됨 |
CustomerName |
target.user.user_display_name |
직접 매핑됨 |
temp_duser |
target.user.user_display_name |
직접 매핑됨 |
Bruker |
target.user.userid |
직접 매핑됨 |
User_value |
target.user.userid |
직접 매핑됨 |
target_user |
target.user.userid |
직접 매핑됨 |
temp_duid |
target.user.userid |
직접 매핑됨 |
| 해당 사항 없음 | about |
상수: about |
| 해당 사항 없음 | about.ip |
상수: ips |
| 해당 사항 없음 | about.mac |
상수: mac_address |
| 해당 사항 없음 | about.nat_ip |
상수: deviceTranslatedAddress |
| 해당 사항 없음 | about.resource.attribute.permissions |
상수: permissions |
| 해당 사항 없음 | additional.fields |
상수: additional_eventId |
| 해당 사항 없음 | extensions.auth.type |
상수: AUTHTYPE_UNSPECIFIED |
| 해당 사항 없음 | intermediary |
상수: intermediary |
| 해당 사항 없음 | intermediary.ip |
상수: intermediary_ip |
| 해당 사항 없음 | metadata.event_type |
상수: PROCESS_UNCATEGORIZED |
| 해당 사항 없음 | metadata.product_name |
상수: Cisco Ironport |
| 해당 사항 없음 | metadata.vendor_name |
상수: Cisco |
| 해당 사항 없음 | network.application_protocol |
상수: SMTP |
| 해당 사항 없음 | network.direction |
상수: INBOUND |
| 해당 사항 없음 | network.email.subject |
상수: subject |
| 해당 사항 없음 | network.email.to |
상수: to |
| 해당 사항 없음 | network.received_bytes |
상수: uinteger |
| 해당 사항 없음 | principal.asset.ip |
상수: src_ip |
| 해당 사항 없음 | principal.ip |
상수: principal_ip |
| 해당 사항 없음 | principal.mac |
상수: mac |
| 해당 사항 없음 | principal.nat_ip |
상수: sourceTranslatedAddress |
| 해당 사항 없음 | principal.user.attribute.roles |
상수: principal_role |
| 해당 사항 없음 | principal.user.email_addresses |
상수: email |
| 해당 사항 없음 | security_result |
상수: security_result |
| 해당 사항 없음 | security_result.action |
상수: _action |
| 해당 사항 없음 | security_result.category_details |
상수: cat |
| 해당 사항 없음 | security_result.detection_fields |
상수: field1 |
| 해당 사항 없음 | security_result.severity |
상수: LOW |
| 해당 사항 없음 | src.resource.attribute.permissions |
상수: old_permissions |
| 해당 사항 없음 | target.asset.ip |
상수: dst_ip1 |
| 해당 사항 없음 | target.ip |
상수: dst_ip |
| 해당 사항 없음 | target.mac |
상수: mac_address |
| 해당 사항 없음 | target.nat_ip |
상수: destination_translated_address |
| 해당 사항 없음 | target.resource.attribute.labels |
상수: resource_Type_label |
| 해당 사항 없음 | target.user.attribute.roles |
상수: target_role |
도움이 더 필요하신가요? 커뮤니티 회원 및 Google SecOps 전문가에게 문의하여 답변을 받으세요.