Modifier des tableaux de bord définis par l'utilisateur

Modifiez vos tableaux de bord Looker définis par l'utilisateur pour affiner les visualisations de données et fournir des informations claires et pertinentes pour vos workflows opérationnels. Vous pouvez personnaliser leur contenu, leur mise en page et leurs paramètres d'affichage pour optimiser la présentation et l'utilisation des données.

Pour modifier un tableau de bord, vous devez remplir les conditions préalables suivantes :

En outre, pour modifier une vignette de tableau de bord spécifique, vous devez avoir accès au modèle sur lequel est basée la vignette.

Si vous n'avez pas accès à tous les modèles sur lesquels sont basées les vignettes d'un tableau de bord particulier, vous pouvez toujours modifier d'autres parties du tableau de bord, telles que le titre du tableau de bord, les paramètres du tableau de bord, les filtres du tableau de bord (bien que vous ne verrez pas de suggestions de filtres pour les filtres basés sur des champs d'un modèle auquel vous n'avez pas accès) et les vignettes pour lesquelles vous avez accès au modèle.

Lorsque vous modifiez un tableau de bord, gardez à l'esprit les pratiques recommandées pour la construction d'un tableau de bord. Vous trouverez des informations et des recommandations sur la création de tableaux de bord performants sur la page de bonnes pratiques Points à prendre en compte lors de la création de tableaux de bord Looker performants.

Accès au Mode Édition dans les tableaux de bord

Pour passer en mode Édition, sélectionnez Modifier le tableau de bord dans le menu à trois points Actions sur le tableau de bord.

En mode Édition, vous pouvez ajouter, redimensionner et repositionner, modifier ou supprimer des vignettes, des groupes de vignettes, des filtres ou des onglets de tableau de bord. Vous pouvez également modifier le titre du tableau de bord.

En mode Édition, Looker affiche une barre d'outils bleue en haut du tableau de bord, qui contient les options suivantes :

Une fois que vous avez effectué au moins une modification, le bouton Enregistrer devient disponible. Cliquez sur Enregistrer pour enregistrer vos modifications et quitter le mode Édition.

Pour supprimer vos modifications, cliquez sur Annuler. Dans la boîte de dialogue Annuler les modifications ?, cliquez sur Annuler pour confirmer que vous souhaitez annuler et quitter le mode Édition. La boîte de dialogue Ignorer les modifications ? s'affiche également si vous essayez de quitter le tableau de bord en cliquant sur le fil d'Ariane ou sur les flèches "Suivant" ou "Précédent" de votre navigateur.

Pour en savoir plus sur le déplacement d'un filtre de tableau de bord, consultez la page de documentation Ajouter et modifier des filtres de tableau de bord définis par l'utilisateur.

Pour savoir comment ajouter et configurer des filtres directement sur des tuiles de visualisation individuelles, consultez la documentation Filtres sur les tuiles de visualisation.

Réorganisation et redimensionnement des vignettes

En mode Édition, vous pouvez déplacer et redimensionner les vignettes d'un tableau de bord.

Pour déplacer une vignette, faites glisser l'icône à six points située en haut à gauche de la vignette. Lorsque vous faites glisser une vignette vers un nouvel emplacement sur le tableau de bord, des lignes de grille bleues s'affichent pour vous aider à positionner la vignette. Looker affiche la largeur et la hauteur de chaque vignette, ainsi que le pourcentage de la largeur totale du tableau de bord occupé par la vignette.

Vous pouvez également utiliser l'option Déplacer la vignette dans le menu de modification de la vignette pour la déplacer vers le haut ou le bas du tableau de bord. Si votre tableau de bord comporte des onglets, vous pouvez également utiliser l'option Déplacer vers l'onglet du menu de modification de la tuile pour la déplacer vers un autre onglet.

Pour redimensionner une vignette, faites glisser son angle inférieur droit ou utilisez l'option Redimensionner la vignette dans le menu à trois points Actions sur la vignette en haut à droite de chaque vignette. Les tailles présélectionnées disponibles sont les suivantes :

  • Très petite : chaque vignette occupe un sixième de la ligne du tableau de bord.
  • Petite : chaque vignette occupe un quart de la ligne du tableau de bord.
  • Moyenne : chaque vignette occupe un tiers de la ligne du tableau de bord.
  • Grande : chaque vignette occupe la moitié de la ligne du tableau de bord.
  • Très grand : chaque tuile occupe toute la largeur de la ligne du tableau de bord.

Seule la vignette sélectionnée est redimensionnée. La taille des tuiles s'adapte à celle du tableau de bord.

Si vous souhaitez réduire considérablement la hauteur d'une vignette, vous pouvez masquer son titre.

Taille de la vignette et disposition de la grille

Lorsque vous ajoutez une visualisation utilisant une disposition en grille à un tableau de bord, la disposition de la grille peut s'adapter à la taille de la vignette du tableau de bord.

Par exemple, imaginons que vous disposez d'une vignette de tableau de bord avec une visualisation qui utilise une disposition de grille de quatre petits graphiques. Si réduisez ou agrandissez la vignette, les petits graphiques s'afficheront sur l'une des quatre lignes. Si vous formez la vignette comme un carré, les petits graphiques sont repositionnés sur deux lignes de deux. Si vous agrandissez la vignette mais de sorte qu'elle soit plus étroite, les petits graphiques sont repositionnés sur quatre lignes d'une.

Pour vous assurer que la disposition de la grille est responsive, ne saisissez pas de nombre dans le paramètre Nombre de graphiques par ligne de la visualisation. Si vous saisissez une valeur dans Nombre de graphiques par ligne, la vignette de tableau de bord respectera ce paramètre quelle que soit sa taille ou sa forme.

Ajout de vignettes

En mode Édition, vous pouvez ajouter des vignettes, des groupes de vignettes, des onglets ou du texte à votre tableau de bord. Pour savoir comment ajouter du texte et des vignettes, consultez la page de documentation Créer des tableaux de bord définis par l'utilisateur. Pour savoir comment ajouter des onglets aux tableaux de bord, consultez la page de documentation Ajouter des onglets aux tableaux de bord.

Modification de vignettes

En mode Édition, le menu à trois points Actions sur les vignettes en haut à droite de chaque vignette affiche les options de modification disponibles.

Ces options diffèrent légèrement selon que vous affichez une vignette de requête ou une vignette liée à une présentation.

  • Dans les deux cas, Looker affiche les options Modifier, Masquer le titre, Ajouter une note, Ajouter une description d'accessibilité et Déplacer la tuile. Si votre tableau de bord comporte des onglets, l'option Déplacer vers l'onglet s'affiche. Si la tuile se trouve dans un groupe de tuiles, l'option Dissocier la tuile s'affiche également.
    • Pour les tuiles de requête, Looker affiche également les options Dupliquer la tuile, Supprimer et Afficher.
    • Pour les vignettes liées à une présentation, Looker affiche également l'option Supprimer la présentation.

Le menu à trois points Actions sur la vignette inclut également l'option Afficher les filtres, qui vous permet d'afficher les filtres appliqués à la vignette.

Modification du titre d'une vignette de requête

En mode Édition, vous pouvez modifier le titre d'une vignette de requête en cliquant dessus et en apportant vos modifications. Cliquez sur Enregistrer en haut à droite du tableau de bord pour enregistrer vos modifications.

Vous pouvez également modifier les titres des vignettes de requête et des vignettes liées à une présentation lorsque vous modifiez la requête ou la présentation sous-jacente d'une vignette.

Modification de la requête ou du Look d'une vignette

En mode Édition, vous pouvez modifier la requête ou la présentation sous-jacente d'une vignette (y compris le titre de la vignette et la visualisation) directement dans le tableau de bord.

Cliquez sur Modifier (ou Modifier la requête fusionnée pour une tuile de requête fusionnée) dans le menu à trois points Actions de la tuile.

Si vous modifiez un Look, la barre d'outils Modifier le Look affiche les tableaux de bord contenant des vignettes liées à ce Look. Vos modifications s'appliqueront à ces tableaux de bord. Si vous modifiez une vignette de requête, aucune liste de tableaux de bord affectés ne s'affichera dans le volet de modification, car vos modifications s'appliqueront uniquement à la vignette et au tableau de bord dans lequel vous vous trouvez.

Ajouter et modifier des filtres sur une vignette de visualisation

Lorsque la fonctionnalité en preview Filtres sur les vignettes de visualisation est activée, vous pouvez ajouter et configurer des filtres directement sur une vignette de visualisation individuelle, et pas seulement dans la barre de filtres du tableau de bord.

En mode Édition, vous pouvez effectuer les tâches suivantes :

  • Ajouter un filtre à une tuile : sélectionnez l'icône Ajouter un filtre de visualisation dans l'en-tête de la tuile, puis sélectionnez Ajouter un filtre dans la boîte de dialogue qui s'affiche pour configurer le champ et les paramètres du filtre. Pour obtenir des instructions détaillées, consultez Ajouter un filtre à une vignette de visualisation.
  • Réorganiser les filtres : cliquez de manière prolongée sur l'icône Maintenir et faire glisser pour réorganiser dans la barre de filtres de la vignette, puis faites glisser le filtre vers une nouvelle position dans la barre de filtres de la vignette.
  • Modifier ou supprimer un filtre : sélectionnez l'icône du menu Filtre à trois points à côté d'un filtre dans la barre de filtres de la vignette, puis sélectionnez Modifier ou Supprimer.

Lorsque vous avez terminé de modifier le tableau de bord, sélectionnez Enregistrer dans la barre d'outils de modification du tableau de bord pour enregistrer vos modifications et quitter le mode Édition.

Pour en savoir plus sur le comportement, la priorité et les limites des filtres au niveau des tuiles, consultez la documentation Filtres sur les tuiles de visualisation.

Masquage ou affichage du titre d'une vignette

En mode Édition, vous pouvez masquer ou afficher le titre d'une vignette. Les titres des vignettes sont affichés par défaut. Vous pouvez masquer un titre en cliquant sur Masquer le titre dans le menu à trois points Actions de la vignette de la vignette.

Si le titre est masqué, Looker affiche l'option Afficher le titre dans le menu à trois points Actions sur la vignette.

L'option permettant de masquer ou d'afficher n'apparaît pas dans le menu d'actions à trois points Actions sur les tuiles des tuiles de texte ou des tuiles qui utilisent des visualisations de KPI (valeur unique) ou des visualisations de valeur unique (ancienne version). Pour masquer ou afficher le titre d'une visualisation de valeur unique, cliquez sur Modifier dans le menu à trois points Actions sur la vignette, activez ou désactivez l'option Afficher le titre dans le menu de style, puis enregistrez. Pour masquer ou afficher le titre d'une vignette de texte, cliquez sur Modifier dans le menu à trois points Actions sur la vignette de la vignette, supprimez ou rétablissez le titre de la vignette, puis enregistrez.

Ajout d'une note à une vignette

En mode Édition, cliquez sur le bouton Ajouter une note dans le menu à trois points Actions de la tuile de la tuile.

Saisissez le texte de la note et configurez les options d'affichage suivantes :

  1. Dans le champ Texte de la note, saisissez le texte de la note à afficher sur la vignette. Vous pouvez utiliser du texte brut ou du HTML.
  2. Dans le champ Emplacement d'affichage, sélectionnez l'emplacement de la note. Vous pouvez la placer au-dessus de la visualisation, en dessous de la visualisation ou la faire apparaître lorsque les utilisateurs passent leur curseur au-dessus de l'icône représentant un i dans un cercle sur la droite du titre de la vignette. Pour les tuiles contenant des visualisations de KPI (valeur unique) d'une hauteur de 150 pixels ou moins, les notes de titre s'affichent sous forme de texte lorsque vous pointez sur le champ Emplacement d'affichage.
  3. Cochez la case Réduire la note pour réduire la note par défaut. Une note réduite affiche uniquement la première ligne, avec des points de suspension à la fin de la ligne. Décochez cette case pour afficher l'intégralité du texte de la note par défaut. Si vous sélectionnez Survol de l'icône dans Afficher l'emplacement, vous ne verrez pas cette option.
  4. Cliquez sur Ajouter ou Annuler pour ajouter la note à la vignette ou l'annuler.

La note apparaît sur la vignette accompagnée d'une flèche de réduction ou de développement à gauche de la note. Cliquez sur la flèche ou n'importe où sur la note pour naviguer entre les affichages réduit et développé.

Une fois que vous avez ajouté une note à une vignette, le menu à trois points Actions sur la vignette de la vignette affiche Modifier la note et non plus Ajouter une note. Cliquez sur Modifier la note pour modifier ou supprimer votre note.

Ajouter ou modifier une description d'accessibilité

Vous pouvez ajouter une description textuelle alternative à une tuile de visualisation pour les lecteurs d'écran. L'ajout d'une description d'accessibilité permet aux utilisateurs de lecteurs d'écran d'accéder aux données et aux résultats représentés dans le graphique sans modifier l'apparence visuelle du tableau de bord.

Pour ajouter ou modifier une description d'accessibilité, procédez comme suit :

  1. En mode Édition, sélectionnez le menu à trois points Actions sur la tuile de la tuile, puis sélectionnez Ajouter une description d'accessibilité (ou Modifier la description d'accessibilité si une description existe déjà).
  2. Dans le champ Texte de description pour l'accessibilité, saisissez le texte que les lecteurs d'écran doivent annoncer lorsque les utilisateurs accèdent à la tuile.
  3. Sélectionnez Ajouter (ou Enregistrer).

Lorsqu'une personne utilisant un lecteur d'écran accède à la tuile, le lecteur d'écran lit à voix haute la description d'accessibilité après avoir lu le titre de la tuile.

Pour supprimer une description d'accessibilité, sélectionnez Modifier la description d'accessibilité dans le menu à trois points Actions sur la tuile de la tuile, sélectionnez Supprimer, puis confirmez la suppression.

Duplication d'une vignette de requête

En mode Édition, vous pouvez dupliquer des cartes de requête en cliquant sur l'option Dupliquer la carte dans le menu à trois points Actions sur la carte.

Looker crée une copie de la vignette avec les mêmes paramètres de requête et de visualisation, et l'ajoute au bas du tableau de bord. À ce stade, vous pouvez déplacer ou redimensionner la vignette, modifier son titre ou modifier la nouvelle vignette pour ajuster la visualisation ou la requête sous-jacente.

Vous ne pouvez pas dupliquer une vignette liée à une présentation. L'option Dupliquer la vignette n'apparaît pas dans le menu à trois points Actions sur la vignette des vignettes liées à une présentation.

Modification de texte

Il existe deux types de tuiles de texte, chacune offrant une expérience d'édition différente, mais aboutissant au même type de tuile :

Pour modifier une tuile Texte, passez en mode Édition, puis cliquez dans la tuile pour apporter vos modifications.

Pour modifier une tuile Markdown, passez en mode Édition et sélectionnez Modifier dans le menu à trois points Actions sur la tuile.

Options de déplacement de la vignette

En mode Édition, vous pouvez déplacer une vignette vers le haut, le bas, la gauche ou la droite du tableau de bord. Cliquez sur le menu à trois points Actions sur le tableau de bord, sélectionnez Déplacer la tuile, puis l'une des options suivantes :

  • Placer en première position
  • Placer en dernière position
  • Déplacer vers la gauche
  • Déplacer vers la droite

La vignette restera dans la colonne ou la ligne dans laquelle elle se trouve. Lorsque la vignette est déjà en haut, en bas, à gauche ou à droite de la colonne, l'option pour la déplacer vers cet endroit est désactivée.

Suppression d'une vignette

En mode Édition, vous pouvez supprimer une vignette d'un tableau de bord. Sélectionnez Supprimer (pour une vignette de requête) ou Supprimer la présentation (pour une vignette associée à un Look) dans le menu à trois points Actions sur la vignette. Cette suppression est irréversible.

La suppression d'une vignette liée à un Look d'un tableau de bord n'a pas d'incidence sur le Look sous-jacent.

Organiser les tuiles en groupes

Si votre administrateur Looker a activé la fonctionnalité en preview Groupes de vignettes de tableau de bord, vous pouvez organiser plusieurs vignettes dans des conteneurs de groupes réductibles sur les tableaux de bord qui utilisent la mise en page de grille par défaut. Le regroupement de tuiles vous permet d'organiser visuellement le contenu associé, et de déplacer, dupliquer ou supprimer plusieurs tuiles en une seule fois.

Créer un groupe de tuiles

Pour créer un groupe de tuiles sur un tableau de bord, procédez comme suit :

  1. Passez en mode Édition.
  2. Cliquez sur le bouton Ajouter dans la barre d'outils en haut du tableau de bord (ou au centre du volet du tableau de bord si le tableau de bord est vide), puis sélectionnez Groupe. Looker ajoute un nouveau conteneur de groupe pleine largeur au canevas du tableau de bord avec un titre par défaut (par exemple, Mon groupe 1), une flèche de développement ou de réduction, et des commandes d'en-tête de groupe.
  3. Pour renommer le groupe, cliquez sur le titre du groupe dans l'en-tête du groupe, puis saisissez un nouveau titre.
  4. Cliquez sur Enregistrer dans la barre d'outils pour enregistrer les modifications.

Ajouter des tuiles à un groupe

En mode Édition, vous pouvez ajouter de nouvelles vignettes directement à un groupe ou déplacer des vignettes existantes non groupées du canevas du tableau de bord vers un groupe :

  • Ajouter une vignette à un groupe : dans l'en-tête du groupe, cliquez sur l'icône Ajouter une vignette au groupe, puis sélectionnez le type de vignette que vous souhaitez créer (Visualisation, Texte, Markdown, Bouton ou Extension). Vous pouvez également enregistrer une vignette directement dans un groupe à partir d'une exploration. Par défaut, les nouvelles tuiles d'un groupe sont dimensionnées à un tiers de la largeur du groupe et sont placées de gauche à droite à mesure que de nouvelles tuiles sont ajoutées.
  • Ajouter une vignette existante à un groupe : dans l'en-tête du groupe, cliquez sur l'icône Ajouter une vignette existante au groupe, puis cliquez sur la vignette non groupée du canevas du tableau de bord que vous souhaitez déplacer dans le groupe.

Vous ne pouvez pas déplacer une tuile directement d'un groupe de tuiles à un autre. Pour déplacer une tuile vers un autre groupe, commencez par dissocier la tuile pour la replacer sur le canevas du tableau de bord principal, puis cliquez sur Ajouter une tuile existante au groupe dans l'en-tête du groupe de destination.

Réorganiser, redimensionner et gérer des groupes de vignettes

En mode Édition, vous pouvez réorganiser et redimensionner les vignettes individuelles d'un groupe et le conteneur du groupe lui-même :

  • Développer et réduire un groupe : cliquez sur la flèche à côté du titre du groupe pour réduire ou développer le conteneur du groupe. La réduction d'un groupe masque les tuiles qu'il contient et réduit le conteneur à son en-tête.
  • Réorganiser et redimensionner les tuiles d'un groupe : faites glisser et redimensionnez les tuiles individuelles d'un conteneur de groupe, comme vous le feriez sur le canevas du tableau de bord principal. Si le déplacement ou le redimensionnement d'une tuile dans un groupe pousse les tuiles vers une nouvelle ligne, le conteneur du groupe s'agrandit automatiquement en hauteur.
  • Déplacer un conteneur de groupe : faites glisser l'icône Appuyer de manière prolongée et faire glisser pour réorganiser dans l'en-tête du groupe pour repositionner le groupe sur le canevas du tableau de bord. Vous pouvez également cliquer sur le menu Actions de groupe dans l'en-tête du groupe, sélectionner Déplacer le groupe, puis En haut ou En bas. Si votre tableau de bord comporte des onglets, vous pouvez déplacer l'ensemble du groupe et ses tuiles vers un autre onglet en cliquant sur le menu Actions sur le groupe, en sélectionnant Déplacer vers l'onglet, puis en choisissant l'onglet de destination.
  • Redimensionner un conteneur de groupe : par défaut, les groupes de vignettes occupent toute la largeur du tableau de bord. Faites glisser la poignée de redimensionnement sur la bordure du conteneur du groupe pour ajuster sa largeur et sa hauteur. Vous ne pouvez pas redimensionner un conteneur de groupe pour qu'il soit plus petit que la zone occupée par les tuiles qu'il contient.
  • Dupliquer un groupe : cliquez sur le menu Actions de groupe dans l'en-tête du groupe, puis sélectionnez Dupliquer le groupe pour créer une copie du conteneur de groupe et de toutes les tuiles qu'il contient.

Dissocier des vignettes et supprimer des groupes de vignettes

Vous pouvez supprimer des tuiles individuelles d'un groupe, mais aussi supprimer un groupe entier et ses tuiles :

  • Dissocier une tuile : la dissociation est effectuée sur des tuiles individuelles plutôt que sur le conteneur de groupe. Pour supprimer une vignette d'un groupe sans la supprimer, cliquez sur le menu Actions sur la vignette de la vignette individuelle dans le groupe, puis sélectionnez Dégrouper la vignette. Looker supprime la vignette du groupe et la place sur le canevas du tableau de bord principal. Il n'est pas possible de faire glisser une tuile hors d'un groupe.
  • Supprimer un groupe de tuiles : pour supprimer un conteneur de groupe et toutes les tuiles qu'il contient, cliquez sur le menu Actions de groupe dans l'en-tête du groupe, sélectionnez Supprimer, puis confirmez la suppression dans la boîte de dialogue.

Modification des paramètres d'un tableau de bord

En mode Édition, cliquez sur Paramètres en haut à gauche de la barre d'outils bleue pour modifier les paramètres du tableau de bord.

Sur la page des paramètres du tableau de bord, sélectionnez l'un des onglets suivants :

Paramètres du tableau de bord : Général

Dans l'onglet Général, vous pouvez modifier les paramètres suivants du tableau de bord :

Fuseau horaire

Cette option n'est disponible que si votre administrateur Looker a activé le paramètre Fuseau horaire spécifique à l'utilisateur.

Sélectionnez le fuseau horaire dans lequel votre tableau de bord sera exécuté. Les utilisateurs qui consultent le tableau de bord pourront modifier temporairement le paramètre de fuseau horaire.

Les options suivantes sont disponibles :

  • Fuseau horaire de chaque vignette pour exécuter toutes les vignettes dans le fuseau horaire où elles ont été enregistrées
  • Fuseau horaire de l'utilisateur pour exécuter les vignettes dans le fuseau horaire de chaque utilisateur
  • Permet de sélectionner un fuseau horaire dans un menu déroulant pour exécuter toutes les vignettes dans ce fuseau horaire

Exécuter au chargement

Si l'option Exécuter lors du chargement est activée, les données du tableau de bord sont automatiquement exécutées lorsque le tableau de bord est chargé pour la première fois.

Si l'option Exécuter au chargement est désactivée, le tableau de bord n'affiche aucune donnée tant que vous n'avez pas cliqué sur l'icône Recharger les données.

Autoriser le mode plein écran pour les visualisations

Si votre administrateur Looker a activé le paramètre Visualisations en plein écran, l'option Autoriser le mode plein écran pour les visualisations s'affiche dans les paramètres du tableau de bord. Cette option est activée par défaut.

Si vous désactivez cette option sur un tableau de bord, les utilisateurs qui le consultent ne verront pas l'option Afficher dans le menu à trois points Actions sur le tableau de bord de chaque vignette du tableau de bord. Ils ne pourront pas non plus voir les vignettes du tableau de bord en plein écran ni en format développé.

Conserver la mise en page pour ordinateur

Lorsque cette option est activée, la mise en page complète pour ordinateur d'un tableau de bord est conservée lorsque les utilisateurs le consultent dans un navigateur plus petit ou sur un écran mobile. Les utilisateurs peuvent naviguer dans le tableau de bord à l'aide d'un curseur de zoom qui agrandit les tuiles.

Les utilisateurs peuvent basculer entre l'affichage sur ordinateur et l'affichage sur mobile en cliquant sur le bouton Passer à l'affichage sur mobile pour revenir à l'affichage des vignettes du tableau de bord dans une seule colonne, et en cliquant sur le bouton Passer à l'affichage sur ordinateur pour afficher le tableau de bord dans la mise en page pour ordinateur.

Actualisation automatique

Vous pouvez actualiser automatiquement les données à intervalles réguliers pour vous assurer qu'elles sont à jour. Vous pouvez définir des fréquences d'actualisation automatique pour un tableau de bord complet ou pour certaines vignettes. L'actualisation automatique ne récupère pas les résultats du cache de Looker, mais directement de la base de données.

Pour définir l'actualisation automatique d'un tableau de bord et de toutes ses tuiles, procédez comme suit :

  1. Activez l'option Actualiser automatiquement le tableau de bord.
  2. Sélectionnez une fréquence d'actualisation pour mettre automatiquement à jour le tableau de bord et l'ensemble de ses vignettes.
  3. Pour ajuster la fréquence de certaines vignettes, accédez à la section Vignette, où chaque vignette du tableau de bord est listée. Cliquez sur le menu déroulant de cette tuile dans la colonne Fréquence d'actualisation, sélectionnez Actualiser toutes les, puis définissez la fréquence.
  4. Cliquez sur Enregistrer pour enregistrer les modifications.

Pour définir l'actualisation automatique pour des vignettes individuelles, mais pas pour le tableau de bord, procédez comme suit :

  1. Désactivez l'option Actualiser automatiquement le tableau de bord (si elle était activée).
  2. Dans la colonne Fréquence d'actualisation de la section Tuile, cliquez sur le menu déroulant d'une tuile à actualiser automatiquement.
  3. Sélectionnez Fréquence d'actualisation.
  4. Définissez la fréquence.
  5. Pour les vignettes que vous ne souhaitez pas actualiser automatiquement, laissez le paramètre sur Ne pas actualiser.
  6. Cliquez sur Enregistrer pour enregistrer les modifications.

Les paramètres de fréquence prennent en charge les nombres entiers.

Les intervalles d'actualisation automatique commencent à l'heure à laquelle vous activez cette fonctionnalité. Le tableau de bord est actualisé à l'intervalle défini, à condition qu'il soit ouvert dans un onglet de navigateur et qu'il ne soit pas en Mode Édition. Si le tableau de bord est fermé ou en mode Édition au moment de l'actualisation prévue, il ne sera pas actualisé. Si le tableau de bord est fermé ou passe en Mode Édition, que ce soit ou non au moment de l'actualisation prévue, l'intervalle d'actualisation reprend dès que le tableau de bord est à nouveau ouvert ou qu'il n'est plus en Mode Édition.

Par exemple, si vous définissez une actualisation quotidienne à 8h33, le tableau de bord s'actualisera le lendemain à 8h33, puis tous les jours suivants à 8h33. En revanche, si un jour vous passez en mode Édition à 9h02 et que vous le quittez à 9h45, l'actualisation quotidienne aura lieu à 9h45 à partir du jour suivant.

Les options Vider le cache et actualiser et Recharger les données sont indépendantes de l'intervalle d'actualisation automatique. Cela signifie que l'actualisation manuelle du tableau de bord ne redémarre pas l'intervalle d'actualisation automatique. Par exemple, si l'intervalle d'actualisation automatique d'un tableau de bord est d'une heure, vous pouvez utiliser l'option Vider le cache et actualiser 40 minutes après une actualisation automatique. Le tableau de bord s'actualisera automatiquement 20 minutes plus tard (une heure après la dernière actualisation automatique).

De même, l'actualisation automatique fonctionne que l'option Exécuter lors du chargement soit activée ou non. Si l'option Exécuter au chargement est désactivée et que vous ouvrez un tableau de bord avec des paramètres d'actualisation automatique, l'intervalle d'actualisation commence à l'ouverture, que vous cliquiez ou non sur l'icône Recharger les données pour charger les données initialement.

Actualisation automatique et performances

Les mises à jour fréquentes des tableaux de bord, notamment ceux de grande taille, peuvent soumettre certains systèmes de bases de données à une charge importante. Vous pouvez en discuter avec votre administrateur Looker. Mais évitez au maximum de définir un intervalle d'actualisation plus court que celui de mise à jour de votre base de données car aucune nouvelle donnée ne serait à actualiser et cette option engendrerait des requêtes inutiles.

De même, l'accès à un tableau de bord paramétré pour s'actualiser automatiquement par plusieurs utilisateurs peut nuire aux performances. Pour afficher votre tableau de bord sur un écran partagé alors que plusieurs utilisateurs y accèdent simultanément, vous pouvez créer deux tableaux de bord identiques et activer l'actualisation automatique uniquement pour celui affiché sur l'écran partagé.

Pour en savoir plus et obtenir des recommandations sur la création de tableaux de bord performants, consultez la page de bonnes pratiques Éléments à prendre en compte lors de la création de tableaux de bord Looker performants.

Paramètres du tableau de bord : filtres

Dans l'onglet Filtres, vous pouvez modifier les paramètres de tableau de bord suivants :

Vue des filtres par défaut

Dans l'onglet Filtres de la fenêtre Paramètres, vous pouvez définir l'option Vue des filtres par défaut sur l'une des valeurs suivantes :

  • Développé : la barre de filtres s'affiche lors du chargement de page et les filtres sont révélés par défaut.
  • Réduit : la barre de filtres ne s'affiche pas lors du chargement de la page et les filtres sont masqués par défaut.

Cliquez sur Enregistrer pour enregistrer la modification.

L'option Vue des filtres par défaut est définie sur Développée par défaut. Si vous définissez ce paramètre sur Réduit, vous devez quitter le mode Édition puis actualiser le tableau de bord pour voir vos modifications.

Les lecteurs du tableau de bord peuvent temporairement réduire ou développer la barre de filtres en cliquant sur l'icône de filtres. Toutefois, seul le paramètre Affichage des filtres par défaut permet de modifier de façon permanente l'affichage par défaut de la barre de filtres.

Emplacement des filtres

Dans l'onglet Filtres de la fenêtre Paramètres, vous pouvez définir l'option Emplacement des filtres sur l'une des valeurs suivantes :

  • En haut : la barre de filtres s'affiche en haut du tableau de bord.
  • Droite : la barre de filtres s'affiche à droite du tableau de bord.

Cliquez sur Enregistrer pour enregistrer la modification.

L'option Emplacement du filtre est définie par défaut sur En haut.

Afficher les filtres appliqués sur les tuiles

Lorsque la fonctionnalité en preview Filtres sur les vignettes de visualisation ou Filtres sous forme de vignettes et contexte de filtre au niveau des vignettes est activée, l'onglet Filtres de la fenêtre Paramètres inclut le paramètre Informations sur les filtres de vignettes pour configurer si et comment les filtres sont affichés sur les vignettes de visualisation.

Vous pouvez définir l'option Informations sur le filtre de la vignette sur l'une des valeurs suivantes :

  • Tout afficher : affiche les filtres au niveau du tableau de bord, les filtres au niveau de la requête (configurés dans l'exploration sous-jacente) et les filtres au niveau de la visualisation (si la fonctionnalité en preview Filtres sur les vignettes de visualisation est activée).
  • Masquer les filtres de requête (par défaut) : affiche uniquement les filtres au niveau du tableau de bord et les filtres au niveau de la visualisation (si la fonctionnalité en preview Filtres sur les vignettes de visualisation est activée).
  • Ne pas afficher : empêche l'option et l'icône Afficher les filtres d'apparaître sur les tuiles de visualisation.

Cliquez sur Enregistrer pour enregistrer la modification.

Pour en savoir plus sur la façon dont les utilisateurs interagissent avec les filtres appliqués à une tuile, consultez Afficher les filtres appliqués à une tuile de visualisation.

Paramètres du tableau de bord : Téléchargements

Dans l'onglet Téléchargements, vous pouvez modifier les paramètres suivants du tableau de bord :

Ces paramètres deviennent les options par défaut lorsque les utilisateurs téléchargent des données à partir des vignettes du tableau de bord. Les utilisateurs dont le rôle inclut les autorisations de téléchargement des données peuvent modifier ces options si nécessaire. Pour en savoir plus sur le téléchargement de tableaux de bord, consultez la page de documentation Télécharger du contenu.

Format

Dans la section Format, sélectionnez le format de fichier pour les données de tuile téléchargées.

Vous pouvez télécharger des données à partir de vignettes de tableau de bord dans les formats de fichiers suivants :

  • TXT (valeurs séparées par une tabulation)
  • Feuille de calcul Excel (Excel 2007 ou version ultérieure)
  • CSV
  • JSON
  • HTML
  • Markdown
  • PNG (image de la visualisation)

Résultats

Dans la section Résultats, sélectionnez la façon dont le téléchargement affiche les résultats des données. Sélectionnez Avec les options de visualisation appliquées pour inclure dans le téléchargement les options de configuration appliquées dans la visualisation de la vignette, telles que la mise en forme conditionnelle ou les libellés personnalisés. Sélectionnez Tel qu'affiché dans le tableau de données pour que le téléchargement affiche les données telles qu'elles apparaissent dans le tableau de données de la vignette.

Valeurs

Dans la section Valeurs, choisissez comment vous souhaitez que les valeurs des données téléchargées soient mises en forme.

Limite

Dans la section Limite, spécifiez le nombre de lignes et de colonnes à inclure dans le téléchargement des données. Vous avez le choix entre les options suivantes :

  • Table des résultats actuels : téléchargez uniquement les résultats affichés dans la vignette du tableau de bord.
  • Tous les résultats : téléchargez l'ensemble des résultats de la requête. L'option Tous les résultats n'est visible que par les utilisateurs dont le rôle inclut l'autorisation download_without_limit.
  • Personnalisé : spécifiez le nombre par défaut de lignes et de colonnes à inclure dans le téléchargement des données.

Mise en page rapide

En mode Édition, cliquez sur Mise en page rapide en haut à gauche de la barre d'outils bleue pour définir la même taille pour toutes les tuiles. Voici les cinq options de taille de tuile :

  • XS : six tuiles tiennent sur une ligne du tableau de bord.
  • S : quatre tuiles tiennent sur une ligne du tableau de bord.
  • M : trois vignettes tiennent sur une ligne du tableau de bord.
  • L : deux tuiles tiennent sur une ligne du tableau de bord.
  • XL : une vignette tient sur une ligne du tableau de bord.

La taille des tuiles change en fonction de la taille du tableau de bord. La mise en page rapide affecte toutes les tuiles non groupées, y compris les tuiles de texte, les tuiles de visualisation, les tuiles Markdown et les boutons, mais elle ne redimensionne pas les groupes de tuiles ni les tuiles d'un groupe.

Appliquer un thème à votre tableau de bord

Un thème est un ensemble d'éléments visuels prédéfinis, tels que la couleur d'arrière-plan, la couleur du texte et la famille de polices, que vous pouvez appliquer à votre tableau de bord.

Si votre administrateur Looker a activé la fonctionnalité en preview Thèmes des tableaux de bord internes, l'option Style s'affiche dans la barre d'outils bleue lorsque vous êtes en mode Édition.

Cliquez sur Style pour ouvrir le panneau Style, puis sélectionnez un thème dans le champ Thème. Le thème sera appliqué à votre tableau de bord. Si vous sélectionnez Aucun et que votre instance possède un thème par défaut, celui-ci sera appliqué.

Si vous êtes un administrateur Looker ou si vous disposez de l'autorisation manage_internal_themes, le bouton Gérer les thèmes s'affiche. Il ouvre la page Admin > Thèmes, où vous pouvez créer et modifier des thèmes de tableau de bord.

Modification des détails du tableau de bord

En mode Édition, sélectionnez Afficher les détails du tableau de bord dans le menu à trois points Actions sur le tableau de bord. Le champ Description devient alors modifiable.

Une fois que vous avez terminé de modifier la description, cliquez sur Enregistrer pour enregistrer le changement.

Supprimer des tableaux de bord

Si vous disposez du niveau d'accès Gérer l'accès, Modifier pour un tableau de bord, vous pouvez le supprimer de deux manières :

Une fois que vous avez supprimé un tableau de bord, seul un administrateur Looker peut le restaurer.

Raccourcis clavier lorsque les tableaux de bord sont en mode Édition

Pour connaître les raccourcis clavier que vous pouvez utiliser lorsque vous modifiez des tableaux de bord, consultez la page de documentation Raccourcis clavier dans Looker.