Mit dem Looker-Power BI-Connector können Sie Microsoft Power BI Desktop verwenden, um eine Verbindung zu Daten aus einem Looker-Explore herzustellen.
Der Looker-Power BI-Connector ist für die Verwendung mit dem DirectQuery-Modus von Power BI konzipiert.
Wenn Sie den Looker-Power BI-Connector im DirectQuery-Modus verwenden, werden Ihre Daten nicht von Power BI importiert oder kopiert. Stattdessen generiert Power BI für jede Visualisierung, jeden Filter und jede DAX-Berechnung einen Power Query M-Ausdruck. Der Looker-Power BI-Connector übersetzt diese Ausdrücke mithilfe der Looker API in Live-Abfragen.
Dieser Prozess basiert auf dem Power BI-Query-Folding. Wenn in Ihrer Abfrage eine Funktion verwendet wird, die vom Looker-Power BI-Connector nicht unterstützt wird, wird das Query Folding beendet. Wenn die Abfragefaltung beendet wird, lädt Power BI alle Daten herunter, um die Ergebnisse lokal zu berechnen. Dadurch wird das Laden von Berichten verlangsamt und die Netzwerknutzung erhöht.
Power BI Desktop für die Verbindung mit Looker einrichten
Die allgemeinen Schritte zur Verwendung des Looker-Power BI-Connectors sind:
- Prüfen Sie die Anforderungen.
- Aktivieren Sie den Connector in Ihrer Looker-Instanz.
- Connector-Datei herunterladen und speichern: Jeder Nutzer, der auf den Looker-Power BI-Connector zugreifen möchte, muss die
looker_1.4.3.mez-Datei herunterladen und in einem bestimmten Verzeichnis auf seinem Computer speichern. - Power BI Desktop für einen benutzerdefinierten Connector einrichten: Jeder Power BI-Nutzer muss seine Power BI Desktop-Sicherheitseinstellungen so konfigurieren, dass ein nicht zertifizierter benutzerdefinierter Connector verwendet wird.
In den Abschnitten auf dieser Seite werden diese Schritte ausführlich beschrieben.
Nachdem Sie die Schritte zum Verbinden von Looker mit Power BI Desktop ausgeführt haben, können Sie über Power BI eine Verbindung zu Looker-Daten herstellen und Berichte in Power BI veröffentlichen. Optional können Sie den Power BI-Dienst (Power BI online) verwenden, um in einem Webbrowser mit Ihren Looker-Berichten zu interagieren. Sie können auch Berichte mit dem Power BI-Dienst unter Verwendung der Sicherheit auf Zeilenebene veröffentlichen.
Voraussetzungen
Für die Einrichtung des Looker-Power BI-Connectors benötigen Sie Folgendes:
- Microsoft Power BI Desktop ist auf Ihrem Computer installiert.
- Ein Looker-Nutzerkonto auf der Looker-Instanz mit der Berechtigung
explore, die für den Zugriff auf Explores in Looker erforderlich ist. Wenn Sie mit Abfragen mit mehr als 5.000 Zeilen arbeiten möchten, benötigen Sie außerdem die Berechtigungdownload_without_limit. Informationen zu Downloadlimits finden Sie unter Zeilenlimits für Abfragen.
Außerdem muss Ihre Looker-Instanz die folgenden Anforderungen erfüllen:
- Ihre Instanz muss für den Microsoft Power BI-Connector aktiviert sein. Ein Looker-Administrator muss den vorkonfigurierten Microsoft Power BI-Client auf dem Tab Anwendungsbibliothek der Seite OAuth-Clients verwalten (Admin > Authentifizierung > OAuth-Clients verwalten) aktivieren oder den Schalter Microsoft Power BI auf der Looker-Seite BI-Connectors aktivieren.
- Looker (Google Cloud Core)-Instanzen, die für private Verbindungen konfiguriert sind, und vom Kunden gehostete Looker-Instanzen müssen die folgenden Anforderungen erfüllen:
- Auf der Instanz muss Looker 25.16 oder höher ausgeführt werden.
- Ihr Netzwerkadministrator muss Ihr Netzwerk so konfigurieren, dass der Traffic vom Looker-Power BI-Connector Ihre Looker-Instanz erreichen kann.
Connector in Ihrer Looker-Instanz aktivieren
Die Looker-Instanz, die Sie mit dem Looker-Power BI-Connector verwenden möchten, muss für den Microsoft Power BI-Connector aktiviert sein:
- Bei Looker (Google Cloud Core)-Instanzen sind BI-Connectors standardmäßig aktiviert.
- Bei Looker (Original)-Instanzen sind BI-Connectors standardmäßig deaktiviert.
Ihr Looker-Administrator kann den vorkonfigurierten Microsoft Power BI-Client auf der Seite OAuth-Clients verwalten (Admin > Authentifizierung > OAuth-Clients verwalten) auf dem Tab Anwendungsbibliothek aktivieren oder BI-Connectors im Bereich Plattform des Looker-Menüs Admin im Bereich „BI-Connectors“ aktivieren.
Connector-Datei herunterladen und speichern
So laden Sie die Connector-Datei auf den Computer herunter, auf dem Microsoft Power BI Desktop installiert ist:
- Klicken Sie auf den folgenden Link, um die Connector-Datei herunterzuladen:
looker_1.4.3.mez - Verschieben Sie die Datei
looker_1.4.3.meznach Abschluss des Downloads in das Verzeichnis [Dokumente]\Microsoft Power BI Desktop\Custom Connectors. (Erstellen Sie die Ordner auf Ihrem Computer, falls sie noch nicht vorhanden sind.)
Power BI Desktop für einen benutzerdefinierten Connector einrichten
Wenn Sie den Looker-Power BI-Connector in Power BI Desktop einrichten möchten, folgen Sie der Anleitung unter Benutzerdefinierte Connectors auf der Microsoft Power BI-Website.
Wählen Sie wie in der Anleitung beschrieben unter Datenerweiterungen die Option (Nicht empfohlen) Laden von Erweiterungen ohne Validierung oder Warnung zulassen aus. Wählen Sie OK aus und starten Sie Power BI Desktop neu.
Verbindung zu Looker-Daten über Power BI Desktop herstellen
Nachdem Sie die looker_1.4.3.mez-Connector-Datei heruntergeladen und Ihre Power BI Desktop-Anwendung für einen benutzerdefinierten Connector eingerichtet haben, können Sie mit Power BI Desktop eine Verbindung zu Daten aus Ihrer Looker-Instanz herstellen:
- Wählen Sie in der Power BI Desktop-Symbolleiste Daten abrufen > Mehr… aus.
- Geben Sie im Dialogfeld Daten abrufen den Suchbegriff Looker in das Suchfeld ein.
- Klicken Sie in den Suchergebnissen auf den Eintrag Looker und dann auf Verbinden.
- Klicken Sie im Dialogfeld Verbindung zu einem Drittanbieterdienst herstellen auf Weiter.
- In Power BI Desktop wird ein Looker-Anmeldedialogfeld angezeigt. Geben Sie im Feld Host die URL Ihrer Instanz ein. Beispiel:
example.cloud.looker.com Optional können Sie auf Erweiterte Optionen klicken, um den Abschnitt zu maximieren und die folgenden zusätzlichen Optionen zu konfigurieren:
- Über das Drop-down-Menü Ausgeblendete Explores und Felder anzeigen können Sie Explores und Felder einbeziehen, die in LookML als ausgeblendet konfiguriert sind. Weitere Informationen finden Sie in der Dokumentation zu hidden (für Explores) und hidden (für Felder):
- FALSE (Standard): Ausgeblendete Felder werden unterdrückt.
- TRUE: Ausgeblendete Felder werden angezeigt.
- Verwenden Sie das Drop-down-Menü Logging aktivieren, um Diagnoseprotokolle im Connector zur Fehlerbehebung zu aktivieren oder zu deaktivieren. Weitere Informationen finden Sie im Abschnitt Debugging-Logging für Power BI Desktop aktivieren.
- Über das Drop-down-Menü Ausgeblendete Explores und Felder anzeigen können Sie Explores und Felder einbeziehen, die in LookML als ausgeblendet konfiguriert sind. Weitere Informationen finden Sie in der Dokumentation zu hidden (für Explores) und hidden (für Felder):
Wählen Sie die Option DirectQuery aus, um eine Live-Verbindung zu Ihren Daten in Looker herzustellen.
Klicken Sie auf OK.
Klicken Sie im Dialogfeld Looker auf Anmelden.
Melden Sie sich auf dem Looker-Anmeldebildschirm in Ihrer Looker-Instanz an.
Power BI Desktop kehrt zum Looker-Anmeldedialogfeld zurück und zeigt eine Meldung an, dass Sie angemeldet sind. Klicken Sie auf Verbinden.
In Power BI Desktop wird eine Liste der Looker-Modelle angezeigt, auf die Sie Zugriff haben. Jedes Modell wird als Ordner dargestellt. Klicken Sie auf das Looker-Modell, auf das Sie zugreifen möchten, und setzen Sie dann ein Häkchen neben dem Looker-Explore, das Sie in Power BI Desktop laden möchten. Damit Sie ein Modell sehen können, müssen Sie als Looker-Nutzer oder -Gruppe Zugriff auf einen Modellsatz haben, der das Modell enthält. Für den Zugriff auf Explores benötigen Sie die Looker-Berechtigung
explore.Klicken Sie auf Laden.
In Power BI Desktop wird der Bereich Daten mit den Feldern aus dem ausgewählten Explore gefüllt. Anschließend können Sie die Looker-Daten aus dem Explore verwenden, um Berichte in Power BI Desktop zu erstellen. Informationen dazu, wie Looker-Elemente vom Looker-Power BI-Connector angezeigt werden, finden Sie unter Looker-Elemente in Power BI Desktop ansehen.
Feldnamen werden in einer einzelnen Liste im Format ViewName.FieldName angezeigt.
Looker-Elemente in Power BI Desktop ansehen
Nachdem Sie über Power BI Desktop eine Verbindung zu Looker-Daten hergestellt haben, werden im Bereich Daten von Power BI Desktop die Felder aus dem ausgewählten Explore angezeigt.
Der Looker-Power BI-Connector verwendet das folgende Format, um Looker-Felder in Power BI Desktop anzuzeigen:
ViewName.FieldType.FieldName
- Der Wert
ViewNameist die LookML-Ansicht, in der das Feld definiert ist. - Der Wert
FieldTypekann einer der folgenden Typen sein, die vom Looker-Power BI-Connector unterstützt werden:dim: Dimension, ein Feld, das ein Attribut, einen Fakt oder einen Wert darstellt, z. B. Datumsangaben, Namen und IDs. Dimensionen entsprechen oft Spalten in der zugrunde liegenden Datentabelle. In LookML werden Dimensionen mit dem Parameterdimensiondefiniert.mea: Messwert, ein Feld, das messbare Informationen zu Ihren Daten darstellt, z. B. Summen, Anzahlen, Durchschnittswerte, Mindest- und Höchstwerte. In LookML werden Measures mit dem Parametermeasuredefiniert.fil: Filter, ein Nur-Filter-Feld, das nur zum Erstellen eines Filters in einer Explore-Abfrage verwendet wird. Filterfelder sind nicht im Ergebnissatz einer Abfrage enthalten. In LookML werden Filter mit dem Parameterfilterdefiniert.par: Parameter, ein Feld, das nur zum Erstellen eines Filters in einer Explore-Abfrage verwendet wird. Parameterfelder sind nicht im Ergebnissatz einer Abfrage enthalten. Ein Parameter kann interaktive Abfrageergebnisse, Labels, URLs und mehr erstellen, wenn er mit den Liquid-Variablen{% parameter parameter_name %}undparameter_name._parameter_valuedefiniert wird. In LookML werden Parameter mit dem Parameterparameterdefiniert.
- Der Wert
FieldNameist der Name des Felds, wie er im Looker-Explore angezeigt wird.
In Power BI Desktop werden Looker-Elemente genau so angezeigt wie im Looker-Explore, mit derselben Groß-/Kleinschreibung und demselben Wortabstand. Wenn beispielsweise in einem Looker-Explore eine LookML-Dimension als Created Date aus einer Ansicht angezeigt wird, die als Order Items angezeigt wird, wird dieses Feld in Power BI Desktop als Order Items.dim.Created Date angezeigt.
Abfragen mit Looker-Dimensionen und ‑Messwerten erstellen
Mit dem Looker-Power BI-Connector können Sie Dimensionen und Measures von Looker verwenden, um Abfragen in Power BI Desktop zu erstellen.
So erstellen Sie eine Abfrage in Power BI Desktop mit Looker-Dimensionen und -Messwerten:
- Stellen Sie über Power BI Desktop eine Verbindung zu Looker-Daten her und warten Sie, bis Power BI den Bereich Daten mit den Feldern aus dem ausgewählten Looker-Explore gefüllt hat.
- Wählen Sie im Power BI-Bereich Daten das Kästchen für jede Looker-Dimension oder -Messwert aus, die Sie in die Abfrage aufnehmen möchten.
Wenn Sie eine Dimension oder ein Measure auswählen, aktualisiert Power BI die Abfrage, die im Berichtsbereich angezeigt wird.
Abfragen mit Looker-Filtern und -Parametern filtern
Mit dem Looker-Power BI-Connector können Sie LookML-Parameter und Nur-Filter-Felder aus einem Looker-Explore verwenden, um Ihrem Power BI-Bericht Filter hinzuzufügen.
So filtern Sie einen Bericht in Power BI Desktop mit Looker-Parametern und Nur-Filter-Feldern:
Falls noch nicht geschehen, stellen Sie über Power BI Desktop eine Verbindung zu Looker-Daten her und warten Sie, bis Power BI den Bereich Daten mit den Feldern aus dem ausgewählten Looker-Explore gefüllt hat.
Ziehen Sie im Power BI-Bereich Daten den Namen eines Parameters oder eines Nur-Filter-Felds in eines der Felder Datenfelder hier hinzufügen im Bereich Filter, entweder für Filter auf dieser Seite oder für Filter auf allen Seiten. Weitere Informationen zum Hinzufügen von Filtern zu einem Bericht in Power BI finden Sie in der Power BI-Dokumentation.
Beachten Sie Folgendes, wenn Sie Looker-Parameter und Nur-Filter-Felder in Power BI verwenden:
- Für Nur-Filter-Felder, die in LookML mit dem Parameter
suggestionsodersuggest_dimensionkonfiguriert sind, ruft Power BI die Vorschlagswerte ab und zeigt sie im Bereich Filter unter Einfache Filterung an. Für Parameter, die in LookML mit dem Attribut
allowed_valuekonfiguriert sind, ruft Power BI alle zulässigen Werte ab, die in LookML für den Parameter konfiguriert sind, und zeigt sie im Bereich Filter unter Einfache Filterung an.
DAX mit dem Looker-Power BI-Connector verwenden
DAX (Data Analysis Expressions) ist eine Formelsprache, die in Power BI verwendet wird, um benutzerdefinierte Berechnungen zu erstellen.
Power BI übersetzt DAX-Abfragen in Power Query M-Ausdrücke und sendet sie an den Looker-Power BI-Connector. Der Looker-Power BI-Connector übersetzt diese M-Ausdrücke dann in Looker API-Aufrufe.
Wenn eine DAX- oder Power Query M-Funktion nicht unterstützt wird, wird die Abfragefaltung beendet. In diesem Fall ruft Power BI die gesamte Rohtabelle von Looker ab, um den Vorgang lokal zu verarbeiten. Dies kann zu erheblichen Leistungseinbußen führen. Eine Liste der unterstützten Funktionen finden Sie im Abschnitt Unterstützte Power Query M-Funktionen.
Messwerte im Vergleich zu Spalten
Power BI bietet zwei Hauptmöglichkeiten, um neue Daten mit DAX zu erstellen: Neues Measure und Neue Spalte.
- Neues Measure: Power BI berechnet diesen dynamischen Wert spontan, wenn Sie ihn in einer Visualisierung verwenden. Dieser Wert wird von diesem Modell nicht gespeichert. Verwenden Sie Messwerte hauptsächlich zum Aggregieren von Daten.
- Beispiel:
Total Sales = SUM('Sales'[Revenue])
- Beispiel:
- Neue Spalte: Power BI berechnet diesen statischen Wert Zeile für Zeile. Sie wird nur aktualisiert, wenn die Daten aktualisiert werden. Das Modell speichert diesen Wert. Verwenden Sie Spalten hauptsächlich zum Kategorisieren von Daten.
- Beispiel:
Profit = 'Sales'[Revenue] - 'Sales'[Cost]
- Beispiel:
Neuen Messwert erstellen
So erstellen Sie eine neue Messung in Power BI:
- Klicken Sie im Bereich Daten mit der rechten Maustaste auf die Tabelle, der Sie die Messung hinzufügen möchten.
- Wählen Sie Neue Messung aus.
- Geben Sie in der Formelleiste Ihre DAX-Formel ein. Ersetzen Sie
Measuredurch den ausgewählten Messwertnamen.
Neue Spalte erstellen
So erstellen Sie eine neue Spalte in Power BI:
- Klicken Sie im Bereich Daten mit der rechten Maustaste auf die Tabelle, der Sie die Spalte hinzufügen möchten.
- Wählen Sie Neue Spalte aus.
- Geben Sie in der Formelleiste Ihre DAX-Formel ein. Ersetzen Sie
Columndurch den ausgewählten Spaltennamen.
Beispiele für DAX-Abfragen
In den folgenden Tabellen finden Sie Beispiele für DAX-Abfragen für gängige Aggregationen. Weitere Informationen finden Sie in der DAX-Dokumentation.
In der folgenden Tabelle finden Sie einige Beispiele für das Erstellen von Measures für gängige Aggregationen.
| Aggregationstyp | Beispiel |
|---|---|
| SUMME | Total Sales = SUM('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| AVERAGE | Average Sale Price = AVERAGE('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MIN | Minimum Sale Price = MIN('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MAX | Maximum Sale Price = MAX('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| COUNT | Order Count = COUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
| DISTINCTCOUNT | Distinct Order Count = DISTINCTCOUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
In der folgenden Tabelle sehen Sie, wie Sie grundlegende arithmetische Operationen ausführen.
| Aggregationstyp | Beispiel |
|---|---|
| Addition | Total Orders = [Shipped Orders] + [Pending Orders] |
| Subtraktion | Total Profit = [Total Sales] - [Total Cost] |
| Multiplikation | Total Sales with Tax = [Total Sales] * 1.05 |
| Abteilung | Profit Margin = DIVIDE([Total Profit], [Total Sales]) |
| Stromversorgung | Sales Squared = POWER([Total Sales], 2)oder Sales Squared = [Total Sales] ^ 2 |
| Quadratwurzel | Square Root of Sales = SQRT([Total Sales]) |
| Modulo | Order ID Type = IF(MOD('The Look E-Commerce'[Order Items Ecomm.dim.Order ID], 2) = 0,"Even","Odd") |
| Absoluter Wert | Absolute Profit = ABS([Total Profit]) |
Unterstützte Power Query M-Funktionen
Wenn Sie den Looker-Power BI-Connector im DirectQuery-Modus verwenden, generiert Power BI für jede Visualisierung, jeden Filter und jede DAX-Berechnung einen Power Query M-Ausdruck. Der Looker-Power BI-Connector übersetzt diese Ausdrücke mithilfe der Looker API in Live-Abfragen.
Text
Text.FromText.AtText.CombineText.Contains(beiText.Containswird die Groß-/Kleinschreibung beachtet)Text.EndText.EndsWithText.LengthText.LowerText.UpperText.MiddleText.PositionOfText.RangeText.RemoveRangeText.ReplaceText.StartText.StartsWithText.InsertText.SplitText.FromBinary
Liste und Tabelle
Value.Equals/Value.NullableEqualsTable.RowCountTable.FirstTable.FirstNTable.SelectRowsTable.SortList.SumList.AverageList.MaxList.MinList.CountList.DistinctList.SelectList.ContainsList.AnyTrue
Numerisch
Grundrechenarten
Value.AddValue.SubtractValue.MultiplyValue.Divide
Wissenschaftliche und komplexe Mathematik
Number.PowerNumber.SqrtNumber.ExpNumber.LnNumber.Log10Number.LogNumber.PI
Zahlenattribute
Number.SignNumber.IsEvenNumber.IsOddNumber.Abs
Division und Rest
Number.ModNumber.IntegerDivide
Generierung von Zufallszahlen
Number.RandomNumber.RandomBetween
Typkonvertierungen
Der Connector unterstützt nicht die Verwendung der folgenden numerischen Konvertierungsfunktionen in Visualisierungen:
Byte.FromCurrency.FromDecimal.FromInt8.From,Int16.From,Int32.From,Int64.FromNumber.From,Number.FromTextSingle.From,Double.From
Numerische Rundung
Number.RoundNumber.RoundDownNumber.RoundUpNumber.RoundTowardZeroNumber.RoundAwayFromZero
In der folgenden Tabelle finden Sie Beispiele für die einzelnen Rundungsvorgänge:
| Eingabe | Number.Round |
Number.RoundDown |
Number.RoundUp |
Number.RoundTowardZero |
Number.RoundAwayFromZero |
|---|---|---|---|---|---|
| 2.7 | 3 | 2 | 3 | 2 | 3 |
| 2.5 | 3 | 2 | 3 | 2 | 3 |
| 2.2 | 2 | 2 | 3 | 2 | 3 |
| 0 | 0 | 0 | 0 | 0 | 0 |
| -2,2 | -2 | -3 | -2 | -2 | -3 |
| -2,5 | -3 | -3 | -2 | -2 | -3 |
| -2,7 | -3 | -3 | -2 | -2 | -3 |
Datum und Uhrzeit
Aktuelles Datum und aktuelle Uhrzeit abrufen
DateTime.LocalNowDateTime.FixedLocalNowDateTimeZone.UtcNowDateTimeZone.FixedUtcNowDateTimeZone.LocalNowDateTimeZone.FixedLocalNow
Datetime-Typkonvertierung
DateTime.FromTextDateTimeZone.FromTextDateTime.FromDateTimeZone.FromDate.FromTextTime.ToText
Datumsarithmetik
Date.AddDaysDate.AddMonthsDate.AddYears
Datums- und Uhrzeitangaben extrahieren
Date.DayDate.MonthDate.YearTime.HourTime.MinuteTime.SecondDateTime.Time
Datums- und Zeitraumbegrenzungen
Date.StartOfDayDate.StartOfYearDate.EndOfDayDate.EndOfYearTime.StartOfHourTime.EndOfHour
Funktionen höherer Ordnung
Der Looker-Power BI-Connector unterstützt die folgenden Funktionen höherer Ordnung, sofern der Looker-Power BI-Connector auch die verschachtelten Vorgänge unterstützt.
Table.AddColumn- Einschränkung: Der Looker-Power BI-Connector muss die im Parameter
columnGeneratordefinierte Funktion unterstützen. - Beispiel: Die folgende Abfrage funktioniert, weil der Looker-Power BI-Connector die verschachtelte Funktion
Text.Lengthunterstützt:powerquery Table.AddColumn(LookerTable, "NewColumnName", each Text.Length([lookerTextDimensionColumn]))
- Einschränkung: Der Looker-Power BI-Connector muss die im Parameter
Table.Group- Einschränkung: Der Looker-Power BI-Connector muss alle Aggregationsfunktionen unterstützen, die in der
aggregatedColumns-Liste verwendet werden. - Beispiel: Die folgende Abfrage funktioniert, weil der Looker-Power BI-Connector die verschachtelte Funktion
List.Sumunterstützt:powerquery Table.Group(LookerTable, "CustomerID", {"total", each List.Sum([price])})
- Einschränkung: Der Looker-Power BI-Connector muss alle Aggregationsfunktionen unterstützen, die in der
Looker-Messwerte in Power BI im DirectQuery-Modus verwenden
Viele Power BI-Visualisierungen, die Säulen-, Balken- und Liniendiagramme verwenden, erfordern einen aggregierten Wert auf der Y-Achse. Power BI benötigt einen einzelnen Wert, um zu bestimmen, wo der Datenpunkt dargestellt werden soll, z. B. die Höhe einer Säule oder die Position einer Linie. Ohne Aggregation wird die Visualisierung nicht gerendert.
Hier sehen Sie beispielsweise die Visualisierung eines Looker-Messwerts von type: sum, der die Gesamtkosten pro Artikel zeigt:

Power BI zeigt in den meisten Visualisierungen keine type: sum-Messwerte an, es sei denn, Sie wenden eine Aggregation an. Wenn Sie die Summe anzeigen lassen möchten, können Sie die Power BI-Aggregation auf Summe festlegen. Hier ist die resultierende Visualisierung in Power BI mit einer Summenaggregation:

Ebenso können Sie die Summenaggregation von Power BI verwenden, um Looker-Messwerte zu visualisieren, die die folgenden Aggregationstypen verwenden:
Power BI-Funktionen mit dem Looker-Power BI-Connector verwenden
In den folgenden Abschnitten wird die Unterstützung verschiedener Power BI-Funktionen durch den Looker-Power BI-Connector beschrieben:
Sparkline
Sparklines zu Tabellen- oder Matrixvisualisierungen hinzufügen Weitere Informationen finden Sie in der Power BI-Dokumentation zu Sparklines.
Bedingte Formatierung
Die bedingte Formatierung kann auf Tabellen- oder Matrixvisualisierungen angewendet werden. Der Looker-Power BI-Connector unterstützt die bedingte Formatierung für numerische Spalten, aber nicht für Textfelder. Eine allgemeine Anleitung zur Einrichtung finden Sie in der Power BI-Dokumentation.
Typkonvertierung
Der Looker-Power BI-Connector unterstützt nicht die Konvertierung einer Spalte in eine Zahl oder ein Datum innerhalb einer Visualisierung. Der Connector unterstützt jedoch die Konvertierung einer Spalte in Text und die Verwendung dieses Felds in einer Visualisierung.
Mit Excel verbinden
Sie können Daten aus Looker direkt in Excel für Desktop oder Excel für Web laden. Eine Anleitung zur Einrichtung finden Sie in der Power BI-Dokumentation unter Excel mit Power BI-Datasets verbinden.
Wenn Sie den Looker-Power BI-Connector in Excel verwenden, funktioniert er ähnlich wie der DirectQuery-Modus in Power BI. Wenn die Daten gefiltert werden, wendet der Connector den Filter auf die Quelle an, bevor die Daten in Excel geladen werden.
Sie können in Excel eine der folgenden Methoden verwenden, um eine Verbindung zu Ihren Daten herzustellen:
Pivot-Tabelle einfügen
So fügen Sie eine Pivot-Tabelle ein, die direkt mit dem Dataset verbunden ist:
- Wählen Sie den Tab Einfügen aus.
- Wählen Sie PivotTable > Aus Power BI aus.
Daten abrufen
So importieren Sie die Daten über das Menüband Daten:
- Wählen Sie den Tab Daten aus.
- Wählen Sie Daten abrufen > Aus Fabric und Power Platform > Aus Power BI aus.
Looker-Power BI-Connector überwachen
Ein Looker-Administrator kann die Nutzung des Looker-Power BI-Connectors über die Feldgruppe Query API Client Properties im System Activity History Explore einsehen. Jedes Mal, wenn eine neue Abfrage ausgeführt wird, wird ein Eintrag im Explore Verlauf erstellt.
In der Feldgruppe Query API Client Properties wird für API Client Name der Wert Power BI angezeigt, um Looker–Power BI Connector-Einträge zu identifizieren.
Im Folgenden finden Sie ein Beispiel für eine Systemaktivitäts-URL, die die Power BI-Nutzung zeigt. Ersetzen Sie <instance_name.looker.com> durch die URL Ihrer Instanz.
https://<instance_name.looker.com>/explore/system__activity/history?fields=query_api_client_context.name,user.name,history.created_date,history.created_time_of_day&f[query_api_client_context.name]=Power+BI&sorts=history.created_time_of_day+desc&limit=5000
Power BI-Dienst
Nachdem Sie eine Verbindung zu Looker-Daten aus Power BI hergestellt und Berichte in Power BI veröffentlicht haben, können Sie optional den Power BI-Dienst (Power BI online) verwenden, um in einem Webbrowser mit Ihren Looker-Berichten zu interagieren.
Sie können auch Berichte mit dem Power BI-Dienst unter Verwendung der Sicherheit auf Zeilenebene veröffentlichen.
Überlegungen zur Authentifizierung
Wenn Sie einen Bericht im Power BI-Dienst veröffentlichen, werden die Anmeldedaten, die Sie zum Erstellen des Berichts verwendet haben, in den Bericht eingebettet. Diese Anmeldedaten werden für alle Nutzer wiederverwendet, die den Bericht im Power BI-Dienst aufrufen.
Diese Wiederverwendung von Anmeldedaten erfolgt, weil das Microsoft Power BI-Connector-Framework die Einmalanmeldung (SSO) für Endnutzer für benutzerdefinierte Connectors nicht unterstützt. Wenn Sie den Datenzugriff basierend auf dem Nutzer einschränken möchten, der den Bericht aufruft, verwenden Sie die Sicherheit auf Zeilenebene (Row-Level Security, RLS) in Power BI.
Bericht mit dem Power BI-Dienst und Sicherheit auf Zeilenebene veröffentlichen
Nachdem Sie Berichte in Power BI Desktop mit dem Looker-Power BI-Connector veröffentlicht haben, können Sie optional den Power BI-Dienst verwenden, um über einen Webbrowser mit den Berichten zu interagieren.
Mit Power BI Desktop können Sie die Sicherheit auf Zeilenebene verwenden, um den Datenzugriff für bestimmte Nutzer einzuschränken. Informationen zum Definieren von Rollen und Regeln und zum Validieren der Rollen in Power BI Desktop finden Sie in der Power BI-Dokumentation.
Nachdem Sie die Rollen in Power BI Desktop definiert haben, können Sie die Rollen und Regeln online mit dem Power BI-Dienst verwenden.
So veröffentlichen Sie einen Bericht mit dem Power BI-Dienst unter Verwendung der Sicherheit auf Zeilenebene:
- Öffnen Sie in Power BI Desktop Ihren Bericht und wählen Sie oben im Fenster das Menü Startseite aus.
- Wählen Sie im Menü Startseite die Option Veröffentlichen aus.
- Wählen Sie im Drop-down-Menü einen Arbeitsbereich aus und klicken Sie dann auf Auswählen. In Power BI Desktop wird eine Erfolgsmeldung mit einem Link zum Öffnen des Berichts in Power BI angezeigt.
- Klicken Sie auf den Link, um Power BI zu öffnen.
- Gehen Sie im Power BI-Dienst zu Arbeitsbereiche und wählen Sie den Arbeitsbereich aus, in dem Sie den Bericht veröffentlicht haben.
- Suchen Sie den Eintrag für das Dataset Ihres Berichts (nicht den Bericht selbst).
- Klicken Sie im Eintrag des Datasets auf das Dreipunkt-Menü Weitere Optionen und wählen Sie Sicherheit aus.
In Power BI wird das Fenster Sicherheit auf Zeilenebene angezeigt. Hier können Sie die Rolle auswählen, die Sie in Power BI Desktop erstellt haben, und Personen oder Gruppen hinzufügen, die zur Rolle gehören, und Ihre Rollen im Power BI-Dienst validieren.
Jetzt können Sie den Bericht für beliebige Personen freigeben. Diese sehen dann nur die Daten, die sie gemäß den von Ihnen erstellten Rollen sehen dürfen.
Debug-Logging für Power BI Desktop aktivieren
Zur Fehlerbehebung oder Diagnose eines Problems können Sie das Logging für die Verbindung zwischen Power BI und Looker aktivieren.
Sie müssen das Logging für die Verbindung und auch für Power BI selbst aktivieren, wie in den folgenden Abschnitten beschrieben:
Logging auf Connector-Ebene aktivieren
Zur Fehlerbehebung können Sie das Diagnose-Logging im Looker-Power BI-Connector aktivieren.
Wenn Sie eine neue Verbindung zu Looker-Daten über Power BI Desktop erstellen, aktivieren Sie das Logging so:
- Maximieren Sie im Dialogfeld für die Looker-Verbindung die Option Erweiterte Optionen.
- Wählen Sie im Drop-down-Menü Protokollierung aktivieren die Option TRUE aus.
Wenn Sie bereits eine Verbindung zu Looker-Daten aus Power BI Desktop erstellt haben, müssen Sie die Abfrage im Power Query-Editor manuell bearbeiten. Gehen Sie dazu so vor:
- Wählen Sie in Power BI Desktop die Option Daten transformieren aus.
- Wählen Sie im Menüband Startseite die Option Erweiterter Editor aus.
- Suchen Sie die Zeile, die mit
Source = Looker.DataSourcebeginnt. Aktualisieren Sie das zweite Argument der Funktion, um
EnableLogging=trueeinzuschließen.Looker.DataSource("instance.looker.com", [EnableLogging=true])Klicken Sie auf Fertig.
Tracing auf Power BI-Ebene aktivieren
Zusätzlich zum Aktivieren des Loggings für die Verbindung zu Looker-Daten über Power BI Desktop müssen Sie auch das Tracing über Power BI Desktop aktivieren. Gehen Sie dazu so vor:
- Wählen Sie Datei > Optionen und Einstellungen > Optionen aus.
- Wählen Sie im Dialogfeld Optionen die Option Diagnose aus.
- Wählen Sie unter Diagnoseoptionen die Option Tracing aktivieren aus.
- Wählen Sie Ordner für Crash-Dumps/Traces öffnen aus, um die Logdateien aufzurufen.
Wichtige Punkte
Limits für Abfragezeilen
Abfragen vom Looker-Power BI-Connector enthalten automatisch eine LIMIT 5000-Anweisung, es sei denn, das Looker-Nutzerkonto hat die Berechtigung download_without_limit. Wenn das Looker-Nutzerkonto download_without_limit hat, gilt für Abfragen über den Looker-Power BI-Connector kein Zeilenlimit.
Filter in Explores
Wenn das Looker-Explore mit den LookML-Parametern always_filter oder conditionally_filter definiert ist, werden die Filter auf Abfragen im Looker-Power BI-Connector angewendet, auch wenn die Filter in Power BI nicht sichtbar sind.
Unterstützte Zeiträume für Dimensionsgruppen
Für den dimension_group von type: time werden mit dem Looker-Power BI-Connector nur die Zeiträume date und time unterstützt. Andere Zeiträume werden ausgeblendet.
Explores für Systemaktivitäten werden nicht im Looker-Power BI-Connector angezeigt.
Explores für Systemaktivitäten werden im Looker-Power BI-Connector nicht angezeigt. Looker-Administratoren können die Explores für die Systemaktivität direkt in der Looker-Benutzeroberfläche aufrufen.
Einschränkungen bei der Typkonvertierung
Wenn möglich, sollten Sie Spaltentypen in Ihrer LookML-Ansicht festlegen.
Bekannte Einschränkungen
Beachten Sie bei der Verwendung des Looker-Power BI-Connectors die folgenden Einschränkungen:
Datenmodellierung und Modi
- Numerische Dimensionen: Sowohl numerische Dimensionen als auch Messwerte werden in Power BI als Messwerte angezeigt. Wenn Sie eine numerische Dimension als Dimension verwenden möchten, müssen Sie die Standardzusammenfassung in Power BI Desktop in Nicht zusammenfassen ändern.
- Importmodus: Verwenden Sie für eine optimale Leistung den DirectQuery-Modus. Wenn Sie den Importmodus von Power BI verwenden, beachten Sie die folgenden Einschränkungen:
- Leistung: Berichte, die auf große Modelle zugreifen, werden möglicherweise langsam geladen.
- Zeitüberschreitungen: Wenn der Prozess „Daten abrufen“ hängen bleibt oder eine Zeitüberschreitung auftritt, wechseln Sie in den DirectQuery-Modus.
- Feldeinschränkungen: Im Importmodus sind Nur-Filter-Felder und Parameterfelder deaktiviert.
- Messwertauswertung: Im Importmodus kann Looker keine Messwerte im Explore auswerten, was die Genauigkeit von Berichten beeinträchtigen kann.
Zusammenfassungen
Power BI wendet eigene Aggregationen auf Looker-Messwerte an. Dies kann zu Fehlern oder inkonsistenten Ergebnissen führen, insbesondere bei Matrixvisualisierungen.
- Unterstützte Typen: Verwenden Sie nur
average,count,count_distinct,max,minundsum. - Nicht unterstützte Typen: Der Connector unterstützt keine Abfragen für Standardabweichung, Varianz oder alphabetische erste oder letzte String-Aggregationen.
- Medianleistung: Power BI berechnet den Median lokal, indem alle Werte abgerufen werden. Dies ist bei großen Datasets langsam und kann zu einer Zeitüberschreitung führen.
Filtern und Sortieren
- Nach ausgeblendeten Feldern sortieren: Sie können nicht nach einem Feld sortieren, das nicht in der Visualisierung enthalten ist. Wenn Sie nach einem Feld sortieren möchten, fügen Sie es der Visualisierung hinzu.
- Einschränkungen für erweiterte Filter: Aufgrund von Unterschieden zwischen Power Query und Looker-Filterausdrücken gelten die folgenden Einschränkungen:
- Text: Mehrere Textfilter werden nicht unterstützt.
- Datumsangaben: Für Datums- und Datums-/Uhrzeitfelder werden nur
is,is not,is on or afterundis beforeunterstützt. - Mehrere Nummernfilter werden nur in den folgenden Fällen unterstützt:
- UNGLEICHHEIT UND UNGLEICHHEIT (z. B. „ist kleiner als“ UND „ist größer als“).
- UNGLEICHHEIT ODER UNGLEICHHEIT (z. B. „ist kleiner als“ ODER „ist größer als“).
- is OR is.
- Mehrere Datums- und Uhrzeitfilter werden nur in den folgenden Fällen unterstützt:
is on or after AND is beforeis or is
Power Query-Funktionen
Die folgenden Tabellenfunktionen sind nicht faltbar:
Table.DistinctTable.JoinTable.NestedJoinTable.Skip
Fehlerbehebung
In den folgenden Abschnitten werden häufige Probleme und ihre Lösungen beschrieben.
Der Looker-Power BI-Connector wird nicht in der Power BI-Liste Daten abrufen angezeigt.
Prüfen Sie, ob das Verzeichnis [Documents]\Microsoft Power BI Desktop\Custom Connectors die Datei looker_1.4.3.mez enthält.
- Prüfen Sie in Power BI Desktop die Sicherheitseinstellungen:
- Wählen Sie Datei > Optionen und Einstellungen > Optionen aus.
- Wählen Sie Sicherheit aus.
- Wählen Sie unter Datenerweiterungen die Option (Nicht empfohlen) Laden aller Erweiterungen ohne Validierung oder Warnung zulassen aus.
- Klicken Sie auf OK.
- Starten Sie Power BI Desktop neu.
Fehler: Feldnamen dürfen nur Buchstaben, Ziffern und Unterstriche enthalten
In einigen Fällen wird beim Aktualisieren von Daten oder Übernehmen von Änderungen die folgende Fehlermeldung angezeigt:
DataSource.Error
Message: A LookML model issue has occurred.
Details: Invalid field name "...". Field names may only include letters, numbers and underscores and must start with a letter or underscore for Google BigQuery Standard SQL
Dieser Fehler tritt auf, wenn ein Spaltenname Leerzeichen oder Sonderzeichen enthält, die von der zugrunde liegenden Datenbank (z. B. BigQuery) nicht unterstützt werden.
Gehen Sie so vor, um dieses Problem zu beheben:
- Ermitteln Sie die Spalte, die den Fehler verursacht (normalerweise im Abschnitt
Detailsder Fehlermeldung angegeben). - Benennen Sie die Spalte so um, dass sie nur Buchstaben, Ziffern und Unterstriche enthält.
- Falsch:
Custom Column Name - Richtig:
Custom_Column_Name
- Falsch:
Fehler: Fehler beim Abrufen der Daten für diese visuelle Darstellung
In einigen Fällen erhalten Sie in Power BI möglicherweise einen Authentifizierungsfehler, der auf einen OAuth-Fehler oder ein Problem mit den Anmeldedaten hinweist, z. B. Looker database authentication required.
Wenn dieser Fehler angezeigt wird, fehlen in Ihrem Looker-Konto die erforderlichen OAuth-Anmeldedaten für die Datenbankverbindung. Gehen Sie so vor, um dieses Problem zu beheben:
- Melden Sie sich in Ihrer Looker-Instanz an.
- Wähle dein Nutzerprofilsymbol und dann Konto aus.
- Rufen Sie den Abschnitt Anmeldedaten für die OAuth-Verbindung auf.
- Suchen Sie die Verbindung, auf die Sie zugreifen möchten, und wählen Sie Anmelden aus.
- Kehren Sie zu Power BI Desktop zurück und aktualisieren Sie die Daten.
Änderungsprotokoll für den Looker-Power BI-Connector
In den folgenden Abschnitten werden die Updates in den einzelnen Versionen des Looker-Power BI-Connectors beschrieben:
Version 1.4.3
Version 1.4.3 des Looker-Power BI-Connectors enthält die folgenden Aktualisierungen:
- Das Connector-Label enthält jetzt die Connector-Versionsnummer.
- Die neue Option Protokollierung aktivieren wurde hinzugefügt, um Diagnoseprotokolle im Connector zur Fehlerbehebung dynamisch zu aktivieren.
- Die neue Option Ausgeblendete Explores und Felder anzeigen wurde hinzugefügt. Wenn diese Option aktiviert ist, werden ausgeblendete Explores und Felder angezeigt. Diese Option ersetzt die vorherige Option Ausgeblendete Felder anzeigen.
Version 1.4.3 des Looker-Power BI-Connectors enthält die folgenden Fehlerkorrekturen:
- Ein Problem wurde behoben, bei dem der DAX-Operator für die Stringverkettung (
&) fehlschlug. - Es wurde ein Problem behoben, bei dem das Anwenden einer Power BI-Messung auf eine Looker-Messung zu einem Fehler führte.
- Im Menü „Anmeldedatenkonfiguration“ wird jetzt wieder das Looker-Symbol angezeigt.
Version 1.4.2
Version 1.4.2 des Looker-Power BI-Connectors enthält die folgenden Aktualisierungen:
- Die Verbindungseinstellung Vorschauoptimierung deaktivieren wurde entfernt.
- Die Verbindungsoption Ausgeblendete Felder anzeigen wurde in den Bereich Erweiterte Optionen verschoben.
- Das Beta-Flag wurde entfernt. Der Connector wird in Power BI nicht mehr als Beta-Version angezeigt.
Version 1.4.2 des Looker-Power BI-Connectors enthält die folgenden Fehlerkorrekturen:
- Der Regressionsfehler, bei dem boolesche Datenschnitte und Datums-Datenschnitte in Power BI fehlschlugen, wurde behoben.
- Problem behoben, bei dem der Filter „
is-not“ für den Filter „dates“ nicht funktionierte.
Version 1.4.0
Version 1.4.0 des Looker-Power BI-Connectors enthält die folgenden Updates:
- Unterstützung für den Importmodus hinzugefügt
- Datenvorschau aktiviert
- Verbessertes Verhalten beim Ausführen von
SELECT *-Abfragen - Verbesserte Looker-Cache-Trefferquote
- Verbesserte Leistung beim Abrufen von Filtervorschlägen
Version 1.4.0 des Looker-Power BI-Connectors enthält die folgenden Fehlerkorrekturen:
- Fehler behoben, bei dem Looker nicht erkannte, dass Werte für Filter- und Parameterfelder übergeben wurden
- Ein Fehler wurde behoben, durch den vorgeschlagene Parameterwerte manchmal in Datenschnitten fehlten.
- Fehler behoben, bei dem Liquid-Variablen von LookML-Anweisungen ignoriert wurden
- Fehler behoben, bei dem die Werte für die Anzahl der unterschiedlichen Messwerte in Power BI-Matrixansichten inkonsistent waren
Version 1.3.1
Version 1.3.1 des Looker-Power BI-Connectors enthält die folgenden Updates:
- Option zum Anzeigen ausgeblendeter Felder hinzugefügt
Version 1.3.1 des Looker-Power BI-Connectors enthält die folgende Fehlerkorrektur:
- Ein Fehler wurde behoben, durch den ein visuelles Element nicht funktionierte, wenn sowohl für das visuelle Element als auch für den Bericht ein Filter vorhanden war.
Version 1.3.0
Version 1.3.0 des Looker-Power BI-Connectors enthält die folgenden Updates:
- Vereinfachte Datums-/Uhrzeitformatierung
- Verbesserte Erkennung nicht unterstützter Textausdrücke
- Verbesserte Berichte zu Fehlermeldungen
Version 1.3.0 des Looker-Power BI-Connectors enthält die folgende Fehlerkorrektur:
- Verbesserte Unterstützung für Escape-Zeichen in Filterwerten
Version 1.2.0
Version 1.2.0 des Looker-Power BI-Connectors enthält die folgenden Updates:
- Parameter und Nur-Filter-Felder werden jetzt unterstützt
- Unterstützung erweiterter Filter für Nur-Filter-Felder vom Typ „Text“, „Zahl“, „Datum“ und „Datum/Uhrzeit“
- Grundlegende Filterunterstützung für Nur-Filter-Felder mit von Looker vorgeschlagenen Werten