Planifier et envoyer des tableaux de bord

Cette page présente la planification et l'envoi de tableaux de bord. Pour en savoir plus sur la planification de Looks ou d'explorations, consultez la page de documentation Utiliser le planificateur Looker pour fournir du contenu.

Looker vous permet de planifier l'envoi immédiat ou récurrent de tableaux de bord grâce à l'option Planifier l'envoi du menu du tableau de bord.

Selon la manière dont votre administrateur Looker a configuré vos autorisations pour la distribution des données, vous pouvez envoyer votre contenu vers une ou plusieurs des destinations de distribution intégrées de Looker :

Vous pouvez également planifier l'envoi de données à un service tiers intégré à Looker, tel que Slack.

Si des résultats valides sont disponibles dans le cache, Looker enverra les résultats mis en cache. Si aucun résultat n'est disponible ou que les résultats mis en cache ont expiré, Looker exécutera à nouveau la requête et ces résultats seront mis en cache.

Lancement d'un envoi à partir d'un tableau de bord

Assurez-vous que le tableau de bord n'est pas en mode Édition. Sélectionnez le menu à trois points Actions sur le tableau de bord en haut à droite du tableau de bord, puis choisissez Planifier l'envoi. Si vous ne voyez pas l'option Planifier un envoi, adressez-vous à votre administrateur Looker pour savoir quelles autorisations il vous a assignées.

Une fois que vous avez sélectionné Planifier l'envoi, une fenêtre de planifications existantes ou une fenêtre Planifier l'envoi ou Envoyer s'affiche, selon que vous avez déjà créé des planifications sur le tableau de bord ou non.

Lancement d'un envoi à partir d'un dossier

Vous pouvez également lancer l'envoi d'un tableau de bord à partir du dossier dans lequel il se trouve.

Sélectionnez Planifier l'envoi dans le menu à trois points sur la droite de la ligne du tableau de bord (sous forme de liste) ou à partir du menu à trois points en haut à droite de la miniature (mode Grille).

Fenêtre des planifications existantes

Si vous avez déjà créé des planifications pour ce tableau de bord, une fenêtre de planifications existantes apparaît. Cette fenêtre affiche les planifications que vous avez définies, ainsi que des informations concernant chacune d'elles, telles que la destination et le format. Les envois qui utilisent la récurrence Envoyer maintenant et les planifications créées par d'autres personnes n'apparaissent pas dans cette fenêtre.

La période de planification existante montrant une livraison de tableau de bord planifiée appelée "Order Analysis".

Vous pouvez effectuer les actions suivantes dans la fenêtre des planifications existantes :

  • Sélectionnez Envoyer maintenant pour effectuer un envoi immédiat d'un contenu planifié existant sans perturber la cadence planifiée.

  • Sélectionnez le menu à trois points pour modifier, dupliquer ou supprimer une planification.

  • Sélectionnez OK pour quitter la fenêtre.

  • Sélectionnez Nouveau pour ouvrir la fenêtre Planifier l'envoi ou Envoyer, et créer une planification ou effectuer un nouvel envoi immédiat.

Fenêtre "Programmer l'envoi"

Si vous sélectionnez Nouveau dans la fenêtre des planifications existantes, ou si vous n'avez pas de planifications préexistantes pour le tableau de bord, la fenêtre Planifier l'envoi ou Envoyer s'ouvre. Cette fenêtre vous permet de personnaliser la périodicité, la destination, le format, les filtres ainsi que d'autres aspects :

La fenêtre "Planifier l'envoi" affiche des options permettant de personnaliser le nom, la récurrence, la destination et le format d'un envoi de tableau de bord.

L'onglet Paramètres de la fenêtre Planifier l'envoi ou Envoyer vous permet de personnaliser la périodicité, la destination, le format et d'autres aspects de l'envoi.

Appellation d'un envoi

Le nom attribué automatiquement à l'envoi s'affiche en haut de la fenêtre Planifier l'envoi ou Envoyer. Le nom attribué par défaut est le nom du tableau de bord. Pour modifier le nom de l'envoi, sélectionnez le nom (indiqué par le trait de soulignement en pointillé) et apportez des modifications.

En fonction de la destination de votre envoi, la vignette peut également s'afficher à d'autres endroits :

  • Pour les envois par e-mail, cet intitulé est utilisé en objet de l'e-mail et, si vous sélectionnez un format utilisant une pièce jointe, fait partie du nom du fichier.
  • Pour les webhooks, cet intitulé figure dans la charge utile du webhook, dans le champ Title.
  • Pour les envois à un bucket Amazon S3, l'intitulé est utilisé dans le nom du fichier d'envoi des données et, le cas échéant, dans les e-mails d'erreur qui vous sont adressés. Le nom de fichier de la livraison respecte le format TITLE_TIMESTAMP_HASH, où HASH est un identifiant aléatoire de six caractères et TIMESTAMP suit le format YYYY-MM-DDTHHMM (par exemple, la partie du code temporel ressemblerait à 2019-05-31T0933 pour le 31 mai 2019 à 9h33). Le fuseau horaire du code temporel correspondra au fuseau horaire de livraison.
  • Pour les envois SFTP, l'intitulé figure dans le nom du fichier d'envoi. Le nom de fichier de la livraison respecte le format TITLE_TIMESTAMP_HASH, où HASH est un identifiant aléatoire de six caractères et TIMESTAMP suit le format YYYY-MM-DDTHHMM (par exemple, la partie du code temporel ressemblerait à 2019-05-31T0933 pour le 31 mai 2019 à 9h33). Le fuseau horaire du code temporel correspondra au fuseau horaire d'envoi.
  • Pour les envois à des services intégrés qui génèrent une pièce jointe, l'intitulé figure dans le nom du fichier d'envoi.

Récurrence

Personnalisez le calendrier de livraison dans la section Récurrence.

Envoyer maintenant

Si vous sélectionnez Envoyer maintenant dans le menu déroulant Récurrence, le tableau de bord est envoyé une seule fois après que vous avez rempli les champs obligatoires et sélectionné le bouton Envoyer maintenant en bas de la fenêtre.

Planifications en fonction de la date et de l'heure

Sélectionnez l'une des options suivantes dans le menu déroulant Récurrence :

  • Tous les mois
  • Toutes les semaines
  • Tous les jours
  • Toutes les heures
  • Minutes
  • Mois spécifiques
  • Jours spécifiques

Les options de périodicité changent en fonction de l'option que vous choisissez. Par exemple, les paramètres Toutes les heures incluent une heure de début et une heure de fin. Looker enverra la livraison toutes les heures, de l'heure de début à l'heure de fin.

Les champs Heure, Début et Fin utilisent une horloge sur 24 heures. Si l'heure que vous souhaitez n'est pas disponible dans le menu déroulant, sélectionnez le champ et saisissez manuellement l'heure, par exemple 9:15 ou 15:37.

Les programmations Toutes les heures et Toutes les minutes se répètent quotidiennement dans la période Début et Fin que vous avez définie. L'heure de fin des intervalles Horaire et Minutes n'est pas inclusive. Le dernier envoi est effectué au dernier intervalle sélectionné avant l'heure de fin spécifiée. Par exemple, si un tableau de bord est planifié toutes les heures entre minuit et 23h, il est envoyé toutes les heures, de minuit à 22h. Si une récurrence est définie toutes les 30 minutes entre minuit et 23h, le dernier envoi est effectué à 22h30.

Planifications déclenchées par des mises à jour de groupes de données

Si votre développeur LookML a configuré des groupes de données, vous pouvez planifier l'envoi d'un tableau de bord après qu'un groupe de données a été déclenché, a géré le cache et a reconstruit les tables PDT pertinentes.

Sélectionnez Mise à jour du groupe de données dans le menu déroulant Récurrence. Un champ Groupe de données accompagné d'un menu déroulant apparaît. Sélectionnez le groupe de données dont la mise à jour doit déclencher l'envoi.

Pour planifier un tableau de bord à l'aide d'un déclencheur de mise à jour de groupe de données, le tableau de bord doit contenir au moins une vignette basée sur un fichier de modèle incluant un paramètre de groupe de données. Le menu déroulant Groupe de données répertorie tous les groupes de données définis dans les modèles du tableau de bord, même si les groupes de données ne sont pas utilisés pour gérer la mise en cache des requêtes ou des tables PDT. Même si le groupe de données est utilisé dans un seul modèle de vignette, le tableau de bord complet sera envoyé au terme de la mise à jour du groupe de données sélectionné.

Les planifications fondées sur des groupes de données sont envoyées uniquement au terme du processus de régénération de toutes les tables PDT liées à ce paramètre du groupe de données, et vous assurent que l'envoi contient les données les plus récentes.

Destination

Le paramètre Destination peut afficher plusieurs destinations possibles pour les envois de tableaux de bord. Une fois que vous avez sélectionné une destination, un nouveau champ de paramètre apparaît pour vous permettre d'ajouter des détails propres à cette destination, tels qu'une adresse e-mail ou l'URL d'un webhook. Consultez les sections suivantes pour plus d'informations relatives aux paramètres de chaque destination.

E-mail

Lorsque l'option E-mail est sélectionnée dans le champ Destination, un nouveau champ Adresses e-mail s'affiche. Ce champ est obligatoire.

Saisissez les adresses e-mail des destinataires dans le champ Adresses e-mail. Pour saisir plusieurs adresses e-mail, appuyez sur la touche Entrée ou ajoutez une virgule après chaque adresse. Vous pouvez ajouter autant de destinataires que vous le souhaitez.

En fonction des paramètres de votre instance Looker et des autorisations qui vous sont attribuées, il est possible que vous puissiez envoyer des e-mails à des adresses e-mail qui ne sont pas associées à un compte utilisateur dans votre instance Looker. Ces e-mails sont alors considérés comme des e-mails externes. Les indicateurs Tous et Externes à droite du champ indiquent le nombre de destinataires de tous les e-mails et le nombre de destinataires des e-mails externes uniquement. Sélectionnez chaque indicateur pour afficher tous les destinataires des e-mails ou uniquement les destinataires externes. Pour que vous puissiez envoyer du contenu à des utilisateurs externes, votre administrateur Looker doit vous avoir accordé les autorisations nécessaires pour envoyer du contenu à des utilisateurs externes ou avoir ajouté les domaines de messagerie de ces destinataires à la liste d'autorisation des domaines de messagerie pour le contenu planifié.

Si un destinataire est un autre utilisateur Looker, l'e-mail contiendra un lien vers le tableau de bord, sauf si votre administrateur Looker a défini la règle d'envoi des données par e-mail de votre instance Looker sur Envoyer uniquement les données ou si l'option Inclure des liens est désélectionnée.

Les envois par e-mail ne peuvent pas dépasser 20 Mo (pour les formats envoyés dans le corps de l'e-mail) et 15 Mo (pour les formats envoyés en pièce jointe).

Consultez la section Options avancées sur cette page pour en savoir plus sur les envois d'e-mails.

Webhook

Les webhooks permettent de déclencher des échanges entre des services Internet. Grâce à un service Web, tel que Zapier, les webhooks peuvent autoriser l'envoi de données Looker à un large éventail d'applications. Par exemple, vous pouvez planifier l'envoi périodique d'un tableau de bord à un webhook.

Pour configurer un webhook, accédez à votre service web et procédez comme suit :

  • Obtenez une URL à laquelle Looker doit envoyer une requête HTTPS.
  • Indiquez une application de destination pour envoyer vos données Looker. Il est possible que vous deviez la configurer pour recevoir des données de Looker.

La procédure exacte varie selon le service Web et l'application de destination que vous utilisez pour l'envoi de données. Consultez le post de la communauté Scheduling Looks and Dashboards Using Webhooks (Planifier des Looks et des tableaux de bord à l'aide de webhooks) pour savoir comment configurer une autre application afin de recevoir les données de webhook de Looker.

Lorsque Webhook est sélectionné dans le champ Destination, un nouveau champ URL de webhook s'affiche. Ce champ est obligatoire.

Saisissez l'URL à laquelle Looker doit adresser une demande HTTPS pour cet envoi dans le champ URL du webhook. Vous pouvez vous procurer cette URL auprès du service Web utilisé pour gérer le webhook.

Amazon S3

Les paquets Amazon S3 sont couramment utilisés pour stocker de grands volumes de données. Vous ou votre entreprise devrez créer un paquet S3 avec Amazon avant que Looker ne puisse l'utiliser.

Lorsque Amazon S3 est sélectionné dans le champ Destination, plusieurs nouveaux champs s'affichent et vous invitent à fournir des informations sur votre bucket Amazon S3 :

  • Bucket : nom de votre bucket Amazon S3. Ce champ est obligatoire.
  • Chemin d'accès facultatif : dossier dans lequel vous voulez enregistrer vos données, le cas échéant.
  • Clé d'accès : ID de la clé d'accès à votre bucket S3, fourni par Amazon. Ce champ est obligatoire.
  • Clé secrète : clé d'accès secrète à votre bucket S3, fournie par Amazon. Ce champ est obligatoire.
  • Région : région des services Amazon où votre bucket S3 est hébergé.

Pour en savoir plus sur l'envoi de données à l'aide d'un bucket Amazon S3, consultez le post de la communauté Scheduling (unlimited) Results to S3 (Planifier l'envoi de résultats (illimités) vers S3).

SFTP

Choisissez SFTP dans la section Où ces données doivent-elles aller ? pour envoyer votre contenu vers un serveur SFTP. Il est recommandé d'envoyer des résultats à un serveur SFTP lorsque votre visualisation ou vos données sont trop volumineuses pour être envoyées par e-mail. Si vous choisissez cette option d'envoi, Looker vous invitera à indiquer l'adresse du serveur SFTP, votre nom d'utilisateur et votre mot de passe, comme expliqué ci-dessous.

Notez les éléments suivants à propos des livraisons :

  • Pour recevoir des livraisons SFTP de Looker, assurez-vous que votre administrateur réseau a ajouté les adresses IP de Looker à la liste d'autorisation d'adresses IP ou aux règles de trafic entrant de votre serveur SFTP.
  • Pour les livraisons à un serveur SFTP, seuls les caractères alphanumériques, les traits de soulignement (_) et les tirets (-) sont pris en charge dans le nom de fichier de la livraison. Looker supprime tous les caractères autres que A-Z, a-z, 0-9, _ ou - de ce que vous saisissez dans le champ Nommez votre planification.

Lorsque vous choisissez SFTP, Looker vous invite à en saisir l'URL et les informations de connexion :

  • Adresse : URL ou adresse IP du serveur SFTP auquel vous voulez envoyer les données. Exemple :

    • sftp://files.looker.com/Marketing/In/
    • sftp://192.168.0.10/Marketing/In/

    Cet exemple d'URL se termine par le caractère /. ce qui indique que le fichier sera enregistré dans un dossier nommé In. Si vous omettez le / final, le fichier sera enregistré dans le dossier Marketing et "In" sera ajouté au début du nom de fichier. Vous devez disposer d'un accès en écriture au dossier dans lequel vous voulez créer le fichier.

  • Nom d'utilisateur et mot de passe : identifiants de connexion au serveur SFTP

  • Algorithme d'échange de clés privilégié : ce champ est facultatif. Pour le configurer, choisissez l'algorithme d'échange de clé SSH préféré pour établir la connexion. Les options acceptées sont les suivantes :

    • ecdh-sha2-nistp521
    • ecdh-sha2-nistp384
    • ecdh-sha2-nistp256
    • diffie-hellman-group-exchange-sha256
    • diffie-hellman-group14-sha256
    • diffie-hellman-group14-sha1

    Si la connexion n'est pas établie dans les cinq minutes, choisissez un algorithme différent. Certains algorithmes prennent longtemps à générer une clé SSH. Cette option vous permet d'utiliser un algorithme susceptible de prendre moins de temps. Le choix d'un des algorithmes en fait l'algorithme préféré pour établir la connexion SSH. Si l'algorithme n'est pas pris en charge par le serveur, tous les autres algorithmes sont utilisés lors de tentatives ultérieures. Lorsque ce champ est défini sur Par défaut, l'ordre d'origine des algorithmes dans la bibliothèque de connexion est utilisé.

La prise en charge des identifiants SFTP est limitée au nom d'utilisateur et au mot de passe. Les clés privées SSH ne sont pas reconnues comme identifiants.

Les algorithmes de clé hôte compatibles avec les livraisons SFTP Looker sont les suivants :

  • ssh-ed25519-cert-v01@openssh.com
  • ssh-ed25519
  • ecdsa-sha2-nistp521-cert-v01@openssh.com
  • ecdsa-sha2-nistp384-cert-v01@openssh.com
  • ecdsa-sha2-nistp256-cert-v01@openssh.com
  • ecdsa-sha2-nistp521
  • ecdsa-sha2-nistp384
  • ecdsa-sha2-nistp256
  • ssh-rsa-cert-v01@openssh.com
  • ssh-rsa-cert-v00@openssh.com
  • ssh-rsa
  • rsa-sha2-256
  • rsa-sha2-512

Les algorithmes de chiffrement (chiffres) compatibles avec les livraisons SFTP Looker sont les suivants :

  • aes256-ctr
  • aes192-ctr
  • aes128-ctr
  • aes256-gcm@openssh.com
  • aes128-gcm@openssh.com

Les algorithmes de code d'authentification de message compatibles avec les livraisons SFTP Looker sont les suivants :

  • hmac-sha2-512-etm@openssh.com
  • hmac-sha2-256-etm@openssh.com
  • hmac-sha2-512
  • hmac-sha2-256
  • hmac-sha1

Looker télécharge le fichier vers l'annuaire spécifié sur votre serveur SFTP à l'aide de la convention suivante pour le nom de fichier :

<name>_<timestamp>_<token>.<file extension>
  • <name> est le nom que vous avez indiqué dans le champ Donnez un nom à votre planification, après que Looker a supprimé tous les caractères autres que A-Z, a-z, 0-9, _ ou -.
  • <timestamp> est l'horodatage auquel l'horaire a été envoyé, au format %Y-%m-%dT%H%M.
  • <token> est un jeton, caractérisé par une chaîne de six caractères aléatoires.
  • <file extension> est l'extension de fichier.

Par exemple : Test_Schedule_2019-04-11T1130_HWkvys.csv

Destinations de service intégré

Vous pouvez planifier ou effectuer un envoi de tableau de bord à un service qui est intégré à Looker, tel que Slack, Dropbox, Google Drive ou autre. Les intégrations doivent être activées par votre administrateur Looker. Les administrateurs Looker doivent accorder spécifiquement des autorisations aux utilisateurs et aux utilisateurs intégrés pour envoyer et planifier des données vers des intégrations tierces.

Lorsqu'un service intégré est sélectionné dans le champ Destination du planificateur, plusieurs nouveaux champs peuvent apparaître et vous inviter à saisir des informations.

La liste suivante répertorie les services Action Hub Looker auxquels vous pouvez envoyer le contenu d'un tableau de bord.

Voici comment utiliser la liste :

  • Les URL affichées dans la colonne Lien vers le fichier README fournissent des instructions pour activer et configurer le service intégré afin qu'il fonctionne avec Looker.
  • Les URL affichées dans la colonne How to use this integration (Comment utiliser cette intégration) fournissent des instructions pour envoyer des données de Looker au service intégré. Certains de ces articles contiennent également des instructions d'activation.
  • Balises LookML requises liste toutes les balises requises qui doivent être utilisées avec le paramètre tags dans le modèle sous-jacent du contenu.
  • Le type d'action indique le niveau de données envoyé par le service intégré : champ, requête ou tableau de bord. Une action au niveau du champ envoie la valeur d'une seule cellule spécifiée dans un tableau de données. Une action au niveau de la requête envoie les résultats d'une requête entière, par exemple toutes les lignes d'une exploration ou d'une présentation. Une action au niveau du tableau de bord envoie une image d'un tableau de bord.
  • Utilise l'authentification Google OAuth indique si le service intégré utilise des identifiants Google OAuth pour l'authentification.
  • Utilise le streaming de données indique si le service intégré accepte les résultats de requête en streaming. Les tableaux de bord ne peuvent pas diffuser de données.
Service intégré Description Lien vers le fichier README Comment utiliser cette intégration Balises LookML obligatoires Utilise l'authentification Google OAuth (Oui/Non) Utilise le streaming de données (Oui/Non)
Azure Storage Envoyez et stockez un fichier de données sur Azure Storage. Afficher le fichier README sur GitHub Consulter l'article de la communauté Aucun Non Non
DigitalOcean Spaces Envoyez et stockez un fichier de données dans DigitalOcean Storage. Afficher le fichier README sur GitHub Consulter l'article de la communauté Aucun Non Non
Dropbox Envoyez et stockez un fichier de données sur Dropbox. Aucun fichier README disponible Consulter la documentation Aucun Oui Non
Google Cloud Storage Écrire des fichiers de données dans un bucket Google Cloud Storage Afficher le fichier README sur GitHub Consulter l'article de la communauté Aucun Non Non
Google Drive Envoyer des données à Google Drive. Aucun fichier README disponible Consulter la documentation Aucun Oui Non
SendGrid Envoyez des données et planifiez l'envoi des résultats à une adresse e-mail à l'aide de l'API SendGrid. Afficher le fichier README sur GitHub Consulter l'article de la communauté Aucun Non Non
Slack Envoyez du contenu Looker dans des messages directs, des canaux publics et des canaux privés dans Slack à l'aide d'OAuth. Elle est disponible pour les déploiements hébergés sur Looker à partir de la version 6.24+ avec la fonctionnalité liste autorisée d'adresses IP désactivée. Aucun fichier README disponible Consulter la documentation Aucun Oui Non
Pièce jointe Slack (jeton d'API) Envoyez des données directement dans un canal Slack avec les identifiants utilisateur. Vous pouvez également consulter la documentation de Lookerbot pour découvrir d'autres fonctionnalités Slack. Afficher le fichier README sur GitHub Consulter la documentation Aucun Non Non
Teams – Webhook entrant Envoyez des données à Microsoft Teams à l'aide d'un webhook entrant. Afficher le fichier README sur GitHub Voir le fichier README Aucun Non Non

Format

Le champ Format contient un menu déroulant des formats disponibles :

  • Fichier ZIP CSV : données non mises en forme du tableau de bord, envoyées comme un ensemble de fichiers de valeurs séparées par des virgules (CSV) dans un répertoire zippé. Pour les envois par e-mail, le fichier ZIP est envoyé comme pièce jointe.
  • PDF : une image du tableau de bord est envoyée sous forme de fichier PDF unique. Par défaut, les vignettes sont affichées telles qu'elles sont disposées dans le tableau de bord, mais d'autres options de disposition et de taille sont disponibles dans la section Options avancées. Pour les envois par e-mail, le fichier est envoyé comme pièce jointe.

  • Visualisation PNG : une image du tableau de bord est envoyée sous forme de fichier PNG unique. Par défaut, les vignettes sont affichées telles qu'elles sont disposées dans le tableau de bord, mais d'autres options de disposition sont disponibles dans la section Options avancées. Pour les envois par e-mail, l'image s'affiche en ligne au sein du corps de l'e-mail.

Télécharger les onglets

Si votre tableau de bord comporte des onglets, vous pouvez sélectionner une option dans le menu Télécharger les onglets lorsque vous téléchargez un tableau de bord au format PDF. Vous pouvez choisir d'envoyer l'intégralité du tableau de bord, l'onglet ouvert ou une sélection personnalisée d'onglets. Si vous sélectionnez Personnalisé, vous pouvez spécifier les onglets à télécharger dans le champ Sélectionner des onglets. Si plusieurs onglets sont sélectionnés (par exemple, si l'option Tableau de bord entier est sélectionnée, ou si un ou plusieurs onglets sont spécifiés pour l'option Personnalisé), tous les onglets s'afficheront sur la même page. Le contenu de chaque onglet sera organisé sous un en-tête de contenu portant le nom de l'onglet.

Options avancées

L'onglet Options avancées permet de personnaliser davantage vos envois. Les options disponibles dépendent de la destination sélectionnée et du format de votre envoi.

Message personnalisé

Cette option est disponible uniquement pour les e-mails.

Saisissez un message que vous souhaitez inclure dans le corps de l'e-mail envoyé aux destinataires. Looker limite le nombre de caractères d'un message personnalisé à 1 500.

Exécuter la programmation en tant que destinataire

Cette option est disponible uniquement pour les e-mails.

L'option Exécuter la programmation en tant que destinataire permet aux utilisateurs de spécifier une liste de destinataires qui recevront tous le contenu par e-mail comme s'ils avaient exécuté la requête, en fonction de leurs autorisations. Cela signifie que les filtres d'accès et les attributs utilisateur de chaque utilisateur seront appliqués aux données incluses dans chaque e-mail.

Si l'utilisateur est un administrateur Looker, l'option Exécution de la planification en tant que destinataire lui permet de spécifier une liste d'utilisateurs qui recevront tous la diffusion de contenu comme s'ils avaient exécuté la requête, en fonction de leurs autorisations. Les utilisateurs non administrateurs peuvent également saisir leurs propres adresses e-mail pour recevoir un envoi comme s'ils avaient demandé le contenu, en fonction de leurs autorisations. Cela signifie que les filtres d'accès et les attributs utilisateur de chaque utilisateur seront appliqués aux données incluses dans chaque e-mail.

Dans l'exemple suivant, un administrateur Looker doit planifier un envoi de données qui liste le nombre d'utilisateurs par État.

Le filtre d'accès de l'utilisateur A est défini sur users.state = 'California'. Lorsque l'option Exécuter la programmation en tant que destinataire est sélectionnée, la requête programmée applique le filtre d'accès users.state = 'California' et envoie les résultats filtrés à l'utilisateur A. Les résultats filtrés n'incluront que les données concernant la Californie.

Dans l'onglet Options avancées, cochez la case Exécuter la planification en tant que destinataire, puis ajoutez les adresses e-mail de vos destinataires dans le champ de texte Adresses e-mail de l'onglet Paramètres. Cette option prend en compte les autorisations de l'utilisateur qui crée la planification ainsi que les types d'adresses e-mail ajoutées au champ Adresses e-mail. Dans certains cas, l'option Exécuter la planification en tant que destinataire n'est pas disponible :

  • Lorsqu'un utilisateur ajoute l'adresse e-mail d'un utilisateur désactivé
  • Lorsqu'un utilisateur ajoute une adresse e-mail qui n'appartient pas à un utilisateur Looker, comme l'indique le décompte Externe à côté de la liste des adresses e-mail.

    Exemple de planification montrant le nombre d'adresses e-mail externes pour les destinataires qui ne sont pas des utilisateurs Looker.

Dans ce cas, que vous ayez sélectionné une option avant ou après avoir saisi l'adresse e-mail externe, l'option Exécuter la programmation en tant que destinataire reste activée, mais la programmation ne peut pas être enregistrée tant que vous n'avez pas désélectionné Exécuter la programmation en tant que destinataire ou supprimé l'adresse e-mail externe de la liste des destinataires.

Dans le cas particulier où un utilisateur est listé comme destinataire d'une planification pour laquelle l'option Exécuter la planification en tant que destinataire est activée, et que le compte de cet utilisateur est ensuite désactivé, la planification ne sera pas envoyée à l'utilisateur désactivé à partir de sa prochaine exécution. Si le compte de cet utilisateur est supprimé, la planification n'est envoyée à aucun destinataire. Un administrateur Looker ou un utilisateur disposant de l'autorisation see_schedules pourra diagnostiquer cet échec sur la page Historique du planificateur du panneau Admin.

Cette option est disponible uniquement pour les e-mails.

Si votre administrateur Looker a défini la politique d'envoi des données par e-mail de votre instance Looker sur Envoyer des liens et des données, la fenêtre Planifier l'envoi ou Envoyer affiche l'option Inclure les liens. Sélectionnez cette option pour insérer un lien View full dashboard vers le tableau de bord Looker dans vos e-mails d'envoi de données. Les liens vers les tableaux de bord n'incluent aucun paramètre hide_filter.

Les destinataires doivent se connecter à Looker et disposer des autorisations nécessaires pour accéder aux modèles sur lesquels le tableau de bord envoyé est basé pour pouvoir consulter ce contenu dans Looker. Pour retirer ce lien de vos e-mails d'envoi de données, décochez la case Insérer des liens.

Cette option n'est disponible que pour les e-mails et les tableaux de bord intégrés. Il s'affiche lorsque l'option Inclure des liens est sélectionnée.

L'option Inclure un lien personnalisé vous permet de configurer une URL personnalisée vers laquelle le lien Afficher le tableau de bord complet redirigera, au lieu de rediriger vers le tableau de bord dans Looker. Vous pouvez également modifier le texte du lien Afficher le tableau de bord complet.

Pour utiliser cette option, un administrateur Looker ou un utilisateur disposant de l'autorisation schedule_look_emails ou create_alerts doit d'abord spécifier les domaines autorisés pour le lien personnalisé et sélectionner le format de l'URL du lien personnalisé sur la page Intégrer du menu Admin.

Domaine

Sélectionnez le domaine de l'URL dans la liste des domaines configurés sur la liste d'autorisation. Exemple :app.customer.com

Chemin d'accès

L'option Chemin d'accès ne s'affiche que si l'option URL définie par l'utilisateur est sélectionnée dans le champ Sélectionner le chemin d'accès au contenu de la page Intégrer du menu Admin.

Saisissez ici un chemin d'accès personnalisé pour l'URL du lien. Par exemple, si vous souhaitez que votre lien personnalisé pointe vers l'URL app.customer.com/my_embed_app, saisissez le chemin d'accès /my_embed_app ici.

Libellé pour l'URL

Utilisez ce champ pour saisir un nouveau texte de lien, qui remplacera le texte Afficher le tableau de bord complet dans les envois par e-mail. Ce champ affiche par défaut tout texte saisi dans le champ Libellé de l'URL de la page Intégrer du menu Admin. Vous pouvez le modifier dans ce champ.

Résultats

Ce champ est disponible uniquement pour les formats d'envoi de tableaux de bord sous fichier CSV zippé. Il contient deux options : Avec les options de visualisation appliquées ou Comme affiché dans le tableau de données. Vous pouvez choisir l'une des deux options.

Choisissez l'option Avec application des options de visualisation pour appliquer certains paramètres de visualisation des vignettes du tableau de bord au tableau de bord que vous souhaitez envoyer. Les fichiers envoyés sont présentés sous forme de tableaux. Tous les paramètres des menus Tracé, Série et Mise en forme configurés pour une visualisation seront appliqués à la diffusion des données :

Choisissez l'option Tel qu'affiché dans le tableau de données pour envoyer les données telles qu'elles apparaissent dans le tableau de données de la fenêtre Explorer à partir d'ici de chaque vignette du tableau de bord.

Valeurs

Ce champ est disponible uniquement pour les formats d'envoi de tableaux de bord sous fichier CSV zippé. Il contient deux options : Formatted (Mise en forme) ou Unformatted (Sans mise en forme). Vous pouvez choisir l'une des deux options.

  • Sélectionnez Mise en forme si vous souhaitez que les données s'affichent de la même manière que dans l'expérience d'exploration de Looker, même si certaines fonctionnalités (comme l'association) ne sont pas compatibles avec tous les types de fichiers.
  • Sélectionnez Non mises en forme si vous ne souhaitez pas appliquer de mise en forme particulière aux résultats de vos requêtes, comme l'arrondi des nombres longs ou l'ajout de caractères spéciaux éventuellement mis en place par les développeurs Looker. Cette façon de procéder est souvent préférable lorsque les données sont transmises à un autre outil de traitement.

Développer les tables pour afficher toutes les lignes

Cette option est disponible uniquement pour les formats PDF des tableaux de bord envoyés.

Cochez la case Développer les tables pour afficher toutes les lignes pour afficher toutes les lignes des visualisations de tables dans le tableau de bord, plutôt que seulement les lignes qui s'affichent dans les vignettes des tuiles du tableau de bord.

À partir de Looker 26.4, les résultats de requête pour chaque graphique de tableau d'un PDF de tableau de bord peuvent afficher jusqu'à 50 000 lignes, dans la limite de 200 000 cellules par tableau de bord, si votre administrateur a augmenté la limite de lignes. Si le nombre total de cellules des tableaux d'un tableau de bord est supérieur à 200 000, les résultats des tableaux peuvent être tronqués. Si ce maximum est atteint, les utilisateurs verront un avertissement qui s'affichera également en bas du PDF généré.

Si l'option Développer les tables pour afficher toutes les lignes est sélectionnée, les vignettes de tableau de bord contenant des visualisations de tables peuvent être légèrement différentes dans les PDF envoyés par rapport à Looker. Les différences suivantes peuvent être visibles dans le PDF :

  • Les personnalisations des couleurs d'arrière-plan et des tailles de police sont supprimées des en-têtes de colonnes et des lignes de sous-totaux.
  • Les tableaux s'affichent dans le thème blanc.
  • L'icône de tri n'apparaît pas sur les tableaux croisés dynamiques qui n'ont pas été triés manuellement.
  • Les tableaux pour lesquels l'option Largeur de colonne optimale est activée s'étirent sur toute la largeur de la tuile.
  • Les tableaux pour lesquels le regroupement de lignes est activé s'affichent sous forme de données plates, et la colonne de regroupement se développe pour afficher toutes les colonnes.

De plus, pour les tableaux de plus de 20 000 cellules, les différences suivantes peuvent être visibles dans le PDF :

Si l'option Développer les tableaux pour afficher toutes les lignes ne s'affiche pas lorsque vous avez choisi PDF dans le champ Format, demandez à votre administrateur Looker d'installer la version appropriée du moteur de rendu Chromium pour votre instance Looker.

Disposer les vignettes du tableau de bord en une seule colonne

Cette option est disponible uniquement pour les formats de visualisation PDF et PNG des tableaux de bord envoyés. Lorsque Slack est sélectionné comme destination de l'envoi, seul le format PDF est pris en charge.

Sélectionnez Placer les vignettes du tableau de bord dans une colonne unique pour disposer votre visualisation PDF ou PNG dans une mise en page en une seule colonne. Avec cette option, les vignettes du tableau de bord s'affichent dans une seule colonne verticale. Ne la cochez pas si vous souhaitez afficher les vignettes telles qu'elles sont disposées dans le tableau de bord.

Format de papier

Cette option est disponible uniquement pour les formats PDF des tableaux de bord envoyés.

Vous pouvez indiquer la taille et l'orientation optimales des fichiers PDF de tableaux de bord en sélectionnant les options souhaitées dans le menu déroulant Format de papier. Il est possible que vous deviez redimensionner les visualisations de grande taille ou les vignettes de tableau de bord qui se chevauchent afin qu'elles s'affichent correctement dans une page PDF. Si l'option Format de papier n'est pas visible, vérifiez auprès de l'administrateur Looker s'il a bien installé la dernière version du moteur de rendu Chromium pour votre instance Looker.

Résolution de la table

Cette option n'est disponible que pour le format de visualisation PNG et lorsque la case Organiser les vignettes du tableau de bord en une seule colonne est cochée.

Vous pouvez personnaliser la largeur de votre visualisation à l'aide du menu déroulant Résolution de table. Vous disposez des options de largeur suivantes :

  • Normal : 800 pixels
  • Large : 1 680 pixels

Pour l'envoi de données par e-mail, si vous choisissez Large et que la largeur de visualisation dépasse la limite fixée par votre client de messagerie, les destinataires des e-mails devront peut-être faire défiler l'écran horizontalement afin de pouvoir consulter toute la visualisation.

Fuseau horaire d'envoi

Par défaut, Looker utilise le fuseau horaire associé à votre compte pour déterminer à quel moment envoyer les données. Si aucun fuseau horaire n'est associé à votre compte, Looker utilise celui sélectionné dans le paramètre Fuseau horaire de l'application.

Pour indiquer un autre fuseau horaire, sélectionnez-en un dans le menu déroulant. Le fuseau horaire sélectionné n'a aucune incidence sur les données de votre présentation ou de votre tableau de bord ; il détermine uniquement l'heure d'envoi.

Filtres

L'onglet Filtres de la fenêtre Planifier l'envoi ou Envoyer affiche les filtres appliqués au tableau de bord, ainsi que leurs valeurs. Cet onglet vous permet de modifier les valeurs des filtres existants appliqués au tableau de bord et de saisir de nouvelles valeurs à appliquer à l'envoi. Les modifications n'ont aucune incidence sur le tableau de bord en lui-même.

Vous ne pouvez pas ajouter de filtres à votre planification dans l'onglet Filtres, mais uniquement afficher et modifier les valeurs des filtres existants du tableau de bord.

Par exemple, vous pouvez envoyer aux équipes régionales des résultats filtrés en fonction de leurs domaines d'intérêt.

Si un filtre de tableau de bord nécessite une valeur de filtre, vous devez saisir une valeur dans l'onglet Filtres pour créer ou enregistrer des modifications apportées à l'envoi.

En cas de changement des filtres d'un tableau de bord

Il arrive que les filtres d'un tableau de bord changent lors de la création d'une planification. Le tableau ci-dessous explique quelle incidence ces changements ont sur les filtres appliqués aux envois planifiés.

Action Incidence sur le filtre de planification
Une planification est créée avec un filtre. La valeur du filtre change ensuite dans le tableau de bord. Aucune incidence sur la valeur du filtre de la planification. La valeur définie dans l'onglet Filtres est conservée, même si cette valeur est N'importe quelle valeur.
Une planification est créée avec un filtre. Ultérieurement, le filtre est renommé dans le tableau de bord. Le filtre est supprimé des données envoyées.
Une planification est créée avec un filtre. Ultérieurement, le filtre est supprimé du tableau de bord. Le filtre est supprimé des données envoyées.
Une planification est créée. Ultérieurement, un nouveau filtre (non obligatoire ou obligatoire) est ajouté au tableau de bord. Le filtre est appliqué aux données envoyées selon la valeur de filtre définie dans l'onglet Filtres. Si aucune valeur n'est définie dans l'onglet Filtres, la valeur est interprétée comme étant N'importe quelle valeur, ce qui équivaut à une suppression de filtre.

Utilisation de filtres d'attributs utilisateur

Si votre administrateur Looker a configuré des valeurs spécifiques à l'utilisateur, appelées attributs utilisateur, et que vous disposez des droits de modification pour un tableau de bord, vous pouvez créer un filtre de tableau de bord qui utilise l'option de filtre correspond à un attribut utilisateur. Ce type de filtre personnalise automatiquement la valeur de filtre en fonction de chaque personne qui consulte le tableau de bord. Il vous permet ainsi d'envoyer des résultats personnalisés aux destinataires de chaque envoi. Pour en savoir plus sur les attributs utilisateur, consultez la page Attributs utilisateur de la documentation.

Test d'une planification

Si vous définissez le champ Récurrence sur une valeur autre que Envoyer maintenant, un bouton Tester maintenant s'affiche en bas de la fenêtre Planifier l'envoi ou Envoyer.

Sélectionnez le bouton Tester maintenant pour envoyer un e-mail de test ponctuel de la planification à vous-même uniquement. Une coche verte apparaît pour confirmer que l'e-mail de test a été envoyé. Si le bouton Tester maintenant n'est pas disponible, vous pouvez définir le champ Récurrence sur Envoyer maintenant pour envoyer un e-mail de test ponctuel.

L'option Tester maintenant ne tient pas compte de certains paramètres des Options avancées, mais respecte les filtres sélectionnés.

Enregistrement d'une planification ou envoi immédiat

Si vous définissez le champ Récurrence sur Envoyer maintenant, sélectionnez le bouton Envoyer maintenant en bas de la fenêtre pour effectuer un envoi ponctuel vers la destination indiquée.

Si vous définissez le champ Récurrence sur une valeur autre que Envoyer maintenant, sélectionnez le bouton Enregistrer pour enregistrer votre planification et fermer la fenêtre.

Sélectionnez le bouton Annuler pour quitter la fenêtre sans enregistrer ni envoyer la planification.

Vos planifications enregistrées pour un tableau de bord sont affichées dans la fenêtre des planifications existantes. Vos planifications enregistrées pour tous les contenus s'affichent sur la page Planifications de votre profil utilisateur.

Modification d'une planification

Vous pouvez modifier uniquement les planifications que vous avez créées. Pour modifier une planification :

  1. Sélectionnez le menu à trois points Actions sur le tableau de bord en haut à droite du tableau de bord.
  2. Sélectionnez Programmer l'envoi dans le menu déroulant.
  3. Dans la fenêtre des planifications existantes, sélectionnez le menu à trois points correspondant à la planification que vous souhaitez modifier.
  4. Sélectionnez Modifier dans le menu déroulant.
  5. La fenêtre Planifier l'envoi ou Envoyer s'affiche pour cette planification. Apportez vos modifications dans cette fenêtre.
  6. Sélectionnez Enregistrer lorsque vous avez terminé, ou Annuler pour annuler vos modifications.

Duplication d'une planification

Vous pouvez dupliquer une planification, puis la modifier si vous le souhaitez. Pour dupliquer une planification :

  1. Sélectionnez le menu à trois points Actions sur le tableau de bord en haut à droite du tableau de bord.
  2. Sélectionnez Programmer l'envoi dans le menu déroulant.
  3. Dans la fenêtre des planifications existantes, sélectionnez le menu à trois points correspondant à la planification que vous souhaitez modifier.
  4. Sélectionnez Dupliquer dans le menu déroulant.
  5. La fenêtre Planifier l'envoi ou Envoyer s'affiche pour la planification dupliquée. La mention "Copy" est ajoutée au nom de la planification.
  6. Apportez vos modifications.
  7. Lorsque vous avez terminé, sélectionnez Enregistrer ou Annuler pour annuler vos modifications et supprimer la programmation dupliquée.

La duplication d'une planification n'a aucune incidence sur la planification d'origine.

Les filtres d'une planification dupliquée seront définis aux mêmes valeurs que celles sélectionnées dans l'onglet Filtres de la planification d'origine, mais vous pourrez les modifier. Si des filtres ont été modifiés depuis la création de la planification d'origine, ils seront affectés comme indiqué dans la section En cas de changement des filtres d'un tableau de bord. Si un filtre obligatoire a été ajouté par la suite au tableau de bord sur lequel la planification d'origine est fondée, vous devez sélectionner une valeur pour ce filtre avant d'enregistrer la planification dupliquée.

Suppression d'une planification

Vous pouvez supprimer uniquement les planifications que vous avez créées. Pour supprimer une planification :

  1. Sélectionnez le menu à trois points en haut à droite du tableau de bord.
  2. Sélectionnez Programmer l'envoi dans le menu déroulant.
  3. Dans la fenêtre des planifications existantes, sélectionnez le menu à trois points correspondant à la planification que vous souhaitez modifier.
  4. Sélectionnez Supprimer dans le menu déroulant.
  5. Une nouvelle fenêtre s'ouvre. Sélectionnez Supprimer pour supprimer la programmation ou Annuler pour la conserver.

Vous pouvez également supprimer une programmation depuis la page Programmations de votre profil utilisateur.

Effets de la suppression d'un tableau de bord associé à une planification

Si vous supprimez un tableau de bord, toutes les planifications qui lui sont associées seront également supprimées. Le propriétaire de la planification verra immédiatement que le nom du tableau de bord a été supprimé de la planification ou de la page utilisateur Planifications que vous avez créées. Après la prochaine exécution de la requête programmée, son état sera Désactivé.

Problèmes de planification

Il arrive qu'un envoi planifié par e-mail ne parvienne pas à la totalité des destinataires prévus. C'est notamment le cas si le modèle sous-jacent comporte une erreur, si le destinataire n'a pas accès aux données, s'il existe des problèmes de rendu ou en présence d'erreurs au niveau des pages.

Notez les limites suivantes concernant la diffusion de contenu :

  • Si votre entreprise a configuré ses propres paramètres de messagerie dans la section Admin de Looker, vos administrateurs Looker devront s'assurer que les paramètres sont corrects et que votre fournisseur de messagerie fonctionne correctement. Un serveur SMTP externe peut avoir ses propres limites quotidiennes ou par message concernant le nombre de destinataires.
  • Selon le paramètre Limite, la livraison des données sera limitée à 5 000 lignes ou à une taille de fichier maximale de 15 Mo pour les e-mails avec pièces jointes et de 20 Mo pour les e-mails avec contenu intégré. Les e-mails contenant davantage de lignes ou de données ne sont donc pas envoyés.
  • Bien que Looker ne code pas en dur de limite pour le nombre de destinataires que vous pouvez spécifier dans un envoi par e-mail, si vous configurez votre envoi sur "Exécuter en tant que destinataire ", l'envoi déclenche une requête distincte pour chaque personne. Cette charge peut avoir un impact important sur les performances de la base de données et n'est pas recommandée pour les listes de destinataires volumineuses. Dans la mesure du possible, nous vous recommandons d'utiliser des groupes ou des alias de messagerie.
  • Si un e-mail n'est pas envoyé à l'heure prévue, mais finit par arriver, il est probable que ce retard soit dû à l'exécution simultanée d'autres tâches Looker. Il peut s'agir d'autres e-mails planifiés, d'un nombre élevé d'utilisateurs explorant des données en même temps ou de la création de tables dérivées persistantes. Si cela se produit, renseignez-vous sur les tâches concurrentes auprès de l'administrateur Looker.
  • Si un e-mail particulier ne cesse de disparaître de votre liste de distribution, il est probable qu'un utilisateur se soit désabonné. Cela peut être problématique si vous utilisez un alias de messagerie de groupe pour envoyer l'e-mail à plusieurs personnes, car chaque destinataire peut désabonner l'ensemble de l'alias. Pour en savoir plus sur les désabonnements, consultez ce post de la communauté Looker sur la surveillance des événements de désabonnement du planificateur.

Si l'envoi vers un serveur SFTP échoue, envisagez les possibilités suivantes :

  • Lorsque Looker tente d'effectuer une livraison sur un serveur SFTP, la livraison peut être marquée comme terminée dans le panneau de planification et les journaux, même si elle n'arrive pas en raison de problèmes de configuration réseau, tels qu'une liste d'autorisation d'adresses IP incorrecte sur le serveur de destination ou un port sortant fermé sur l'instance Looker. Comme l'historique de planification peut afficher l'état Success malgré ces erreurs, vérifiez toujours les journaux de votre serveur SFTP de destination si vous pensez qu'un envoi est manquant.

  • Looker stocke les empreintes SFTP de votre serveur SFTP. Si vous rencontrez des erreurs lors de votre envoi SFTP, les empreintes SFTP sont peut-être invalides. Dans ce cas, contactez votre administrateur Looker.

  • L'erreur Net::SSH::Exception. message: could not settle on host_key algorithm est due à une incompatibilité entre les algorithmes de clé hôte proposés par les anciennes versions de Looker (antérieures à Looker 26.2) et les algorithmes de sécurité modernes strictement appliqués par le serveur SFTP cible (comme Red Hat 9 ou Azure Blob Storage SFTP). Si vous recevez cette erreur, vous pouvez la résoudre en mettant à niveau Looker vers la version 26.2 ou une version ultérieure pour prendre en charge les algorithmes SHA-2 modernes (comme ecdsa-sha2-nistp256, rsa-sha2-256 et rsa-sha2-512). Vous pouvez également configurer le serveur SFTP cible pour autoriser au moins une clé hôte ou un algorithme de chiffrement compatible avec votre version actuelle de Looker.

  • L'erreur OpenSSL::Cipher::CipherError. Error: authentication tag already generated by cipher peut se produire lorsque des données sont envoyées avec SFTP après la mise à niveau de Looker vers la version 26.2.14 ou une version ultérieure, ou lorsque votre instance se connecte à des services hôtes tels qu'Azure Blob Storage SFTP ou via un proxy. Cette erreur est due à un problème JRuby connu lors de la négociation du chiffrement. Pour résoudre cette erreur, limitez les algorithmes de chiffrement autorisés sur le serveur SFTP de destination à aes256-ctr. Par exemple, modifiez le fichier sshd_config du serveur SFTP pour ajouter ou restreindre la directive Ciphers : Ciphers aes256-ctr.

  • Si vous recevez l'erreur Java::JavaLang::NullPointerExceptions lorsque vous transmettez des données à un serveur SFTP, elle peut être due à un bug dans JRuby qui empêche l'utilisation d'algorithmes de courbe elliptique (EC) ou de clés d'hôte pour les connexions SSH de Looker vers des destinations SFTP. Pour éviter tout problème lors de l'envoi de données vers des destinations SFTP, n'utilisez pas d'algorithmes EC dans les fichiers ~/.ssh/config ou /etc/ssh_config, et ne stockez pas de clés d'hôte EC dans ~/.ssh sur votre hôte Looker.

  • L'erreur Net::SFTP::StatusException (2, 'no such file') se produit si Looker ne peut pas construire correctement le chemin de destination sur le serveur SFTP. Les causes courantes incluent l'utilisation d'un chemin relatif au lieu d'un chemin absolu dans le champ Adresse, l'absence d'une barre oblique finale (/) dans le champ Adresse, ou le nom du Look, du tableau de bord ou de la planification contenant des espaces ou des caractères spéciaux (comme /) qui entraînent des échecs de construction du chemin d'accès. Pour résoudre cette erreur, procédez comme suit :

    • Utilisez des chemins absolus : connectez-vous au serveur SFTP, exécutez pwd pour récupérer le chemin absolu complet, puis saisissez cette valeur dans le champ Adresse de votre planification, en veillant à ce qu'elle se termine par une barre oblique (/).
    • Supprimez les caractères spéciaux : supprimez les barres obliques (/) des noms des Looks, des tableaux de bord et des planifications.
    • Utilisez des noms lisibles par une machine : renommez la programmation pour utiliser des traits de soulignement au lieu d'espaces (par exemple, Report_Name).
  • L'erreur Net::SSH::Exception. Error: could not settle on kex algorithm se produit lorsque Looker et le serveur SFTP distant ne parviennent pas à s'accorder sur un algorithme d'échange de clés (KEX) mutuellement compatible, généralement parce que des algorithmes obsolètes sont utilisés d'un côté. Pour résoudre cette erreur, examinez les algorithmes d'échange de clés compatibles avec votre serveur SFTP et assurez-vous qu'ils correspondent aux algorithmes KEX compatibles avec Looker (tels que ecdh-sha2-nistp256, ecdh-sha2-nistp384 ou ecdh-sha2-nistp521).

  • Si votre livraison SFTP planifiée échoue avec l'erreur Net::SSH::Exception: could not settle on encryption_client algorithm, cela signifie que votre serveur SFTP et Looker n'ont pas pu s'accorder sur un chiffrement partagé. Looker ne prend plus en charge les chiffrements plus anciens et moins sécurisés tels que CBC (par exemple, aes256-cbc et 3des-cbc). Pour résoudre cette erreur, transmettez ce message d'erreur à l'administrateur de votre serveur SFTP et demandez-lui de mettre à jour le fichier sshd_config du serveur pour activer la prise en charge d'au moins un des algorithmes de chiffrement et d'échange de clés compatibles avec Looker.

Éléments à prendre en compte lors d'envois par les administrateurs

Les administrateurs Looker peuvent consulter, modifier, réattribuer et supprimer les planifications de n'importe quel utilisateur. De plus, les administrateurs Looker doivent prendre certains éléments en compte lors de la configuration de l'envoi de données pour leur instance Looker et de l'octroi d'autorisations aux utilisateurs pour l'envoi ou la planification d'envois de données. Pour en savoir plus, rendez-vous sur les pages de documentation suivantes :