Looker–Power BI コネクタを使用すると、Microsoft Power BI Desktop を使用して Looker Explore のデータに接続できます。
Looker–Power BI コネクタは、Power BI の DirectQuery モードで使用するように設計されています。
DirectQuery モードで Looker - Power BI コネクタを使用する場合、Power BI はデータをインポートまたはコピーしません。代わりに、Power BI はすべてのビジュアリゼーション、フィルタ、DAX 計算に対して Power Query M 式を生成します。Looker - Power BI コネクタは、Looker API を使用してこれらの式をライブクエリに変換します。
このプロセスは、Power BI クエリのフォールディングに依存しています。クエリで Looker–Power BI コネクタがサポートしていない関数を使用している場合、クエリの折りたたみは停止します。クエリ フォールディングが停止すると、Power BI はすべてのデータをダウンロードしてローカルで結果を計算するため、レポートの読み込みが遅くなり、ネットワーク使用量が増加します。
Looker に接続するための Power BI Desktop の設定
Looker–Power BI コネクタを使用する一般的な手順は次のとおりです。
- 要件を確認します。
- Looker インスタンスでコネクタを有効にする。
- コネクタ ファイルをダウンロードして保存する: Looker–Power BI コネクタにアクセスする各ユーザーは、
looker_1.4.3.mezファイルをダウンロードしてパソコン上の特定のディレクトリに保存する必要があります。 - カスタム コネクタ用に Power BI Desktop を設定する: 各 Power BI ユーザーは、認定されていないカスタム コネクタを使用するように Power BI Desktop セキュリティ設定を構成する必要があります。
このページの各セクションでは、これらのステップについて詳しく説明します。
Looker を Power BI デスクトップに接続する手順を完了したら、Power BI から Looker データに接続して、Power BI でレポートを公開できます。必要に応じて、Power BI サービス(Power BI オンライン)を使用して、ウェブブラウザで Looker レポートを操作できます。行レベルのセキュリティを使用して Power BI サービスでレポートを公開することもできます。
要件
Looker–Power BI コネクタを設定するには、次のものが必要です。
- パソコンにインストールされた Microsoft Power BI Desktop。
explore権限を持つ Looker インスタンスの Looker ユーザー アカウント。これは Looker の Explore にアクセスするために必要です。5,000 行を超えるクエリを操作するには、download_without_limit権限も必要です(ダウンロードの上限については、クエリの行数制限をご覧ください)。
また、Looker インスタンスは次の要件を満たしている必要があります。
- インスタンスは、Microsoft Power BI コネクタに対して有効になっている必要があります。Looker 管理者は、[Manage OAuth Clients] ページ([Admin>Authentication>Manage OAuth clients])の [Application Library] タブで、事前構成済みの Microsoft Power BI OAuth クライアントを有効にするか、Looker の [BI Connectors] ページで [Microsoft Power BI] スイッチを有効にする必要があります。
- プライベート接続用に構成された Looker(Google Cloud コア)インスタンスとセルフホスト型 Looker インスタンスは、次の要件を満たす必要があります。
- インスタンスで Looker 25.16 以降が実行されている必要があります。
- ネットワーク管理者は、Looker - Power BI コネクタからのトラフィックが Looker インスタンスに到達できるようにネットワークを構成する必要があります。
Looker インスタンスでコネクタを有効にする
Looker–Power BI コネクタで使用する Looker インスタンスは、Microsoft Power BI コネクタに対して有効になっている必要があります。
- Looker(Google Cloud コア)インスタンスでは、BI コネクタがデフォルトで有効になっています。
- Looker(オリジナル)インスタンスの場合、BI コネクタはデフォルトで無効になっています。
Looker 管理者は、[OAuth クライアントの管理] ページ([管理] > [認証] > [OAuth クライアントの管理])の [アプリケーション ライブラリ] タブから、事前構成済みの Microsoft Power BI クライアントを有効にできます。また、Looker の [管理] メニューの [プラットフォーム] セクションにある [BI コネクタ] パネルで BI コネクタを有効にすることもできます。
コネクタ ファイルをダウンロードして保存する
コネクタ ファイルをダウンロードするには、Microsoft Power BI Desktop がインストールされているパソコンで次の操作を行います。
- コネクタ ファイルをダウンロードするには、次のリンクをクリックします:
looker_1.4.3.mez - ダウンロードが完了したら、
looker_1.4.3.mezファイルをディレクトリ [Documents]\Microsoft Power BI Desktop\Custom Connectors に移動します。(まだ作成していない場合は、パソコンにフォルダを作成します)。
カスタム コネクタ用の Power BI Desktop の設定
Looker - Power BI コネクタを Power BI Desktop 側で設定するには、Microsoft Power BI ウェブサイトのカスタム コネクタの手順を行います。
手順に沿って [Data Extensions] の下にある [(Not Recommended) Allow any extension to load without validation or warning] オプションを選択します。[OK] を選択して、Power BI デスクトップを再起動します。
Power BI Desktop から Looker のデータに接続する
looker_1.4.3.mez コネクタ ファイルをダウンロードし、カスタム コネクタ用の Power BI Desktop アプリケーションを設定したら、Power BI Desktop を使用して Looker インスタンスのデータに接続します。
- Power BI デスクトップのツールバーから、[データを取得] > [その他] を選択します。
- [データを取得] ダイアログで、検索フィールドに「Looker」と入力します。
- 検索結果で、[Looker] エントリをクリックし、[接続] をクリックします。
- [サードパーティ サービスへの接続] ダイアログで、[続行] をクリックします。
- Power BI Desktop に Looker のログイン ダイアログが表示されます。[ホスト] フィールドで、インスタンスの URL を入力します。例:
example.cloud.looker.com。 必要に応じて、[詳細オプション] をクリックしてセクションを開き、次の追加オプションを構成します。
- [非表示の Explore とフィールドを表示] プルダウンを使用して、LookML で非表示として構成されている Explore とフィールドを含めます(詳細については、非表示(Explore 用)と非表示(フィールド用)のドキュメントをご覧ください)。
- FALSE(デフォルト): 非表示フィールドは抑制されます。
- TRUE: 非表示フィールドが表示されます。
- [ロギングを有効にする] プルダウンを使用して、トラブルシューティングのためにコネクタ内の診断ログを有効または無効にします。詳細については、Power BI Desktop のデバッグ ロギングを有効にするをご覧ください。
- [非表示の Explore とフィールドを表示] プルダウンを使用して、LookML で非表示として構成されている Explore とフィールドを含めます(詳細については、非表示(Explore 用)と非表示(フィールド用)のドキュメントをご覧ください)。
[DirectQuery] オプションを選択して、Looker 上のデータへのライブ接続を作成します。
[OK] をクリックします。
[Looker] ダイアログで [ログイン] をクリックします。
Looker のログイン画面で、Looker インスタンスにログインします。
Power BI Desktop が Looker のログイン ダイアログに戻り、ログインしていることを示すメッセージが表示されます。[接続] をクリックします。
Power BI Desktop には、アクセス可能な Looker モデルのリストがフォルダごとに表示されます。アクセスする Looker モデルをクリックし、Power BI Desktop に読み込む Looker Explore の横にあるチェックボックスを選択します。モデルを表示するには、モデルを含むモデルセットに対する Looker ユーザー アクセス権またはグループ アクセス権が必要です。Explore にアクセスするには、Looker の
explore権限が必要です。[読み込み] をクリックします。
Power BI Desktop の [データ] ペインに、選択した Explore のフィールドが入力されます。その後、Explore から Looker のデータを使用して Power BI Desktop でレポートを作成できます。Looker–Power BI コネクタで Looker 要素が表示される仕組みについては、Power BI Desktop で Looker 要素を表示するをご覧ください。
フィールド名は、ViewName.FieldName の形式で 1 つのリストに表示されます。
Power BI Desktop で Looker 要素を表示する
Power BI Desktop から Looker データに接続すると、Power BI Desktop の [データ] ペインに、選択した Explore のフィールドが入力されます。
Looker–Power BI コネクタは、次の形式を使用して Power BI Desktop に Looker フィールドを表示します。
ViewName.FieldType.FieldName
ViewName値は、フィールドが定義されている LookML ビューです。FieldTypeの値は、Looker – Power BI コネクタでサポートされている次のいずれかの型になります。dim: ディメンション。属性、事実、値(日付、名前、ID など)を表すフィールド。ディメンションは、多くの場合、基になるデータテーブルの列に対応します。LookML では、ディメンションはdimensionパラメータで定義されます。mea: メジャー。合計、カウント、平均、最小値、最大値など、データに関する測定可能な情報を表すフィールド。LookML では、メジャーはmeasureパラメータで定義されます。fil: フィルタ。Explore クエリでフィルタを作成する場合にのみ使用されるフィルタ専用フィールドです。フィルタ フィールドはクエリの結果セットに含まれません。LookML では、フィルタはfilterパラメータで定義されます。par: パラメータ。Explore クエリでフィルタを作成する場合にのみ使用されるフィールドです。パラメータ フィールドはクエリの結果セットに含まれません。パラメータを{% parameter parameter_name %}とparameter_name._parameter_valueの Liquid 変数で定義すると、インタラクティブなクエリ結果、ラベル、URL などを作成できます。LookML では、パラメータはparameterパラメータで定義されます。
FieldName値は、Looker Explore に表示されるフィールドの名前です。
Power BI Desktop には、Looker Explore に表示されるのと同じように、同じ大文字と単語の間隔で Looker 要素が表示されます。たとえば、Looker Explore で LookML ディメンションが Order Items として表示されるビューから Created Date として表示される場合、Power BI Desktop ではこのフィールドが Order Items.dim.Created Date として表示されます。
Looker のディメンションと measure を使用してクエリを作成する
Looker–Power BI コネクタを使用すると、Looker のディメンションと measure を使用して Power BI Desktop でクエリを作成できます。
Looker のディメンションと measure を使用して Power BI Desktop でクエリを作成する手順は次のとおりです。
- Power BI Desktop から Looker のデータに接続し、Power BI の [データ] ペインに、選択した Looker Explore のフィールドが入力されるまで待ちます。
- Power BI の [データ] ペインで、クエリに含める Looker のディメンションまたは measure ーのチェックボックスをオンにします。
各ディメンションまたは measure を選択すると、レポート キャンバスに表示されるクエリが更新されます。
Looker のフィルタとパラメータを使用してクエリをフィルタリングする
Looker–Power BI コネクタを使用すると、Looker Explore の LookML パラメータとフィルタ限定フィールドを使用して、Power BI レポートにフィルタを追加できます。
Looker パラメータとフィルタ限定フィールドを使用して Power BI Desktop でレポートをフィルタリングする手順は次のとおりです。
まだ接続していない場合は、Power BI Desktop から Looker データに接続し、Power BI が選択した Looker Explore のフィールドを [データ] ペインに入力するまで待ちます。
Power BI の [データ] ペインで、パラメータまたはフィルタ限定フィールドの名前を、[フィルタ] ペインの [ここにデータ フィールドを追加] ボックス([このページのフィルタ] または [すべてのページのフィルタ])にドラッグします。Power BI でレポートにフィルタを追加する方法については、Power BI のドキュメントをご覧ください。
Power BI で Looker パラメータとフィルタ限定フィールドを使用する場合は、次の点に注意してください。
- LookML で
suggestionsパラメータまたはsuggest_dimensionパラメータを使用して構成されたフィルタ限定のフィールドの場合、Power BI は候補値を取得し、[フィルタ] ペインの [基本フィルタリング] オプションに表示します。 LookML で
allowed_value属性を使用して構成されたパラメータの場合、Power BI は、LookML で構成されたパラメータのすべての許可された値を取得し、[フィルタ] ペインの [基本フィルタ] オプションに表示します。
Looker–Power BI コネクタで DAX を使用する
DAX(Data Analysis Expressions)は、Power BI でカスタム計算を作成するために使用される数式言語です。
Power BI は DAX クエリを Power Query M 式に変換し、Looker–Power BI コネクタに送信します。Looker - Power BI コネクタは、これらの M 式を Looker API 呼び出しに変換します。
DAX 関数または Power Query M 関数がサポートされていない場合、クエリの折りたたみは停止します。この場合、Power BI はローカルでオペレーションを処理するために Looker から未加工のテーブル全体を取得します。これにより、パフォーマンスが大幅に低下する可能性があります。サポートされている関数の一覧については、サポートされている Power Query M 関数をご覧ください。
メジャーと列
Power BI では、DAX を使用して新しいデータを作成する主な方法として、新しいメジャーと新しい列の 2 つが用意されています。
- 新しいメジャー: Power BI は、ビジュアリゼーションで使用するときに、この動的な値をオンザフライで計算します。このモデルでは、この値は保存されません。主にデータの集計にメジャーを使用します。
- 例:
Total Sales = SUM('Sales'[Revenue])
- 例:
- 新しい列: Power BI は、この静的な値を 1 行ずつ計算します。データが更新された場合にのみ更新されます。モデルはこの値を保存します。列は主にデータの分類に使用します。
- 例:
Profit = 'Sales'[Revenue] - 'Sales'[Cost]
- 例:
新しいメジャーを作成する
Power BI で新しいメジャーを作成する手順は次のとおりです。
- [データ] ペインで、メジャーを追加するテーブルを右クリックします。
- [新しいメジャー] を選択します。
- 数式バーに DAX 数式を入力します。
Measureは、選択したメジャー名に置き換えます。
新しい列を作成する
Power BI で新しい列を作成する手順は次のとおりです。
- [データ] ペインで、列を追加するテーブルを右クリックします。
- [新しい列] を選択します。
- 数式バーに DAX 数式を入力します。
Columnは、選択した列名に置き換えます。
DAX クエリの例
次の表に、一般的な集計の DAX クエリの例を示します。詳細については、DAX のドキュメントをご覧ください。
次の表に、一般的な集計のメジャーを作成する方法の例を示します。
| 集計方法 | 例 |
|---|---|
| SUM | Total Sales = SUM('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| AVERAGE | Average Sale Price = AVERAGE('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MIN | Minimum Sale Price = MIN('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MAX | Maximum Sale Price = MAX('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| COUNT | Order Count = COUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
| DISTINCTCOUNT | Distinct Order Count = DISTINCTCOUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
次の表に、基本的な算術演算を実行する方法を示します。
| 集計方法 | 例 |
|---|---|
| 加算 | Total Orders = [Shipped Orders] + [Pending Orders] |
| 減算 | Total Profit = [Total Sales] - [Total Cost] |
| 乗算 | Total Sales with Tax = [Total Sales] * 1.05 |
| 部門 | Profit Margin = DIVIDE([Total Profit], [Total Sales]) |
| 電源 | Sales Squared = POWER([Total Sales], 2)または Sales Squared = [Total Sales] ^ 2 |
| 平方根 | Square Root of Sales = SQRT([Total Sales]) |
| モジュロ | Order ID Type = IF(MOD('The Look E-Commerce'[Order Items Ecomm.dim.Order ID], 2) = 0,"Even","Odd") |
| 絶対値 | Absolute Profit = ABS([Total Profit]) |
サポートされている Power Query M 関数
DirectQuery モードで Looker - Power BI コネクタを使用すると、Power BI はすべてのビジュアリゼーション、フィルタ、DAX 計算に対して Power Query M 式を生成します。Looker - Power BI コネクタは、Looker API を使用してこれらの式をライブクエリに変換します。
テキスト
Text.FromText.AtText.CombineText.Contains(Text.Containsでは大文字と小文字が区別されます)Text.EndText.EndsWithText.LengthText.LowerText.UpperText.MiddleText.PositionOfText.RangeText.RemoveRangeText.ReplaceText.StartText.StartsWithText.InsertText.SplitText.FromBinary
リストと表
Value.Equals/Value.NullableEqualsTable.RowCountTable.FirstTable.FirstNTable.SelectRowsTable.SortList.SumList.AverageList.MaxList.MinList.CountList.DistinctList.SelectList.ContainsList.AnyTrue
数値
基本的な算術
Value.AddValue.SubtractValue.MultiplyValue.Divide
科学計算と高度な数学
Number.PowerNumber.SqrtNumber.ExpNumber.LnNumber.Log10Number.LogNumber.PI
数値プロパティ
Number.SignNumber.IsEvenNumber.IsOddNumber.Abs
除算と剰余
Number.ModNumber.IntegerDivide
乱数の生成
Number.RandomNumber.RandomBetween
型変換
このコネクタは、ビジュアリゼーション内で次の数値変換関数を使用することをサポートしていません。
Byte.FromCurrency.FromDecimal.FromInt8.From、Int16.From、Int32.From、Int64.FromNumber.From、Number.FromTextSingle.From、Double.From
数値の丸め
Number.RoundNumber.RoundDownNumber.RoundUpNumber.RoundTowardZeroNumber.RoundAwayFromZero
次の表に、各丸め演算の例を示します。
| 入力 | Number.Round |
Number.RoundDown |
Number.RoundUp |
Number.RoundTowardZero |
Number.RoundAwayFromZero |
|---|---|---|---|---|---|
| 2.7 | 3 | 2 | 3 | 2 | 3 |
| 2.5 | 3 | 2 | 3 | 2 | 3 |
| 2.2 | 2 | 2 | 3 | 2 | 3 |
| 0 | 0 | 0 | 0 | 0 | 0 |
| -2.2 | -2 | -3 | -2 | -2 | -3 |
| -2.5 | -3 | -3 | -2 | -2 | -3 |
| -2.7 | -3 | -3 | -2 | -2 | -3 |
日時
現在の日時を取得する
DateTime.LocalNowDateTime.FixedLocalNowDateTimeZone.UtcNowDateTimeZone.FixedUtcNowDateTimeZone.LocalNowDateTimeZone.FixedLocalNow
日時型の変換
DateTime.FromTextDateTimeZone.FromTextDateTime.FromDateTimeZone.FromDate.FromTextTime.ToText
日付の計算
Date.AddDaysDate.AddMonthsDate.AddYears
日付と時刻の部分の抽出
Date.DayDate.MonthDate.YearTime.HourTime.MinuteTime.SecondDateTime.Time
日付と期間の境界
Date.StartOfDayDate.StartOfYearDate.EndOfDayDate.EndOfYearTime.StartOfHourTime.EndOfHour
高階関数
Looker – Power BI コネクタは、次の高階関数をサポートしています。ただし、Looker – Power BI コネクタがネストされたオペレーションもサポートしていることが条件となります。
Table.AddColumn- 制約: Looker-Power BI コネクタは、
columnGeneratorパラメータで定義された関数をサポートしている必要があります。 - 例: 次のクエリは、Looker–Power BI コネクタがネストされた関数
Text.Lengthをサポートしているため、機能します。powerquery Table.AddColumn(LookerTable, "NewColumnName", each Text.Length([lookerTextDimensionColumn]))
- 制約: Looker-Power BI コネクタは、
Table.Group- 制約: Looker–Power BI コネクタは、
aggregatedColumnsリストで使用される集計関数をサポートしている必要があります。 - 例: 次のクエリは、Looker–Power BI コネクタがネストされた関数
List.Sumをサポートしているため、機能します。powerquery Table.Group(LookerTable, "CustomerID", {"total", each List.Sum([price])})
- 制約: Looker–Power BI コネクタは、
DirectQuery モードで Power BI の Looker メジャーを使用する
列グラフ、棒グラフ、折れ線グラフを使用する Power BI のビジュアリゼーションの多くは、Y 軸に集計値を必要とします。Power BI では、データポイントをプロットする場所(列の高さや線の位置など)を決定するために、単一の値が必要です。集計がないと、ビジュアリゼーションはレンダリングされません。
たとえば、次の図は、アイテムあたりの総費用を示す type: sum の Looker メジャーのビジュアリゼーションです。

Power BI では、集計を適用しない限り、ほとんどのビジュアリゼーションに type: sum メジャーが表示されません。合計を表示するには、Power BI の集計を [Sum] に設定します。合計集計を使用した Power BI でのビジュアリゼーションの結果は次のとおりです。

同様に、Power BI の合計集計を使用して、次のタイプの集計を使用する Looker メジャーを可視化できます。
Looker–Power BI コネクタで Power BI 機能を使用する
以降のセクションでは、さまざまな Power BI 機能に対する Looker – Power BI コネクタのサポートについて説明します。
スパークライン
テーブルまたはマトリックスのビジュアリゼーションにスパークラインを追加します。詳細については、Power BI スパークラインのドキュメントをご覧ください。
条件付き書式
条件付き書式は、テーブルまたはマトリックスのビジュアリゼーションに適用できます。Looker–Power BI コネクタは、数値列の条件付き書式をサポートしていますが、テキスト フィールドはサポートしていません。一般的な設定手順については、Power BI のドキュメントをご覧ください。
型変換
Looker-Power BI コネクタは、ビジュアリゼーション内で列を数値または日付に変換することをサポートしていません。ただし、コネクタは列をテキストに変換し、そのフィールドを可視化内で使用することをサポートしています。
Excel と接続する
Looker から Excel for Desktop または Excel for Web にデータを直接読み込むことができます。設定手順については、Power BI のドキュメントの Excel を Power BI データセットに接続するをご覧ください。
Excel で Looker - Power BI コネクタを使用する場合、Power BI の DirectQuery モードと同様に機能します。データがフィルタされると、コネクタはデータを Excel に読み込む前にソースにフィルタを適用します。
Excel で次のいずれかの方法を使用してデータに接続できます。
ピボットテーブルを挿入する
データセットに直接接続されたピボット テーブルを挿入する手順は次のとおりです。
- [挿入] タブを選択します。
- [ピボットテーブル] > [Power BI から] を選択します。
データを取得する
[データ] リボンを使用してデータをインポートする手順は次のとおりです。
- [Data] タブを選択します。
- [Get Data] > [From Fabric & Power Platform] > [From Power BI] を選択します。
Looker–Power BI コネクタのモニタリング
Looker 管理者は、System Activity History Explore で Query API Client Properties グループを使用して Looker–Power BI コネクタの使用状況を確認できます。新しいクエリが実行されるたびに、[History] Explore にエントリが作成されます。
[Query API Client Properties] フィールド グループの [API クライアント名] に、Looker–Power BI コネクタのエントリを識別するための Power BI 値が表示されます。
以下に、Power BI の使用状況を示すシステム アクティビティ URL の例を示します。<instance_name.looker.com> をインスタンスの URL に置き換えます。
https://<instance_name.looker.com>/explore/system__activity/history?fields=query_api_client_context.name,user.name,history.created_date,history.created_time_of_day&f[query_api_client_context.name]=Power+BI&sorts=history.created_time_of_day+desc&limit=5000
Power BI サービス
Power BI から Looker データに接続して Power BI でレポートを公開したら、必要に応じて Power BI サービス(Power BI オンライン)を使用して、ウェブブラウザで Looker レポートを操作できます。
行レベルのセキュリティを使用して Power BI サービスでレポートを公開することもできます。
認証に関する考慮事項
レポートを Power BI サービスに公開すると、レポートの作成に使用した認証情報がレポートに埋め込まれます。これらの認証情報は、Power BI サービスでレポートを表示するすべてのユーザーに再利用されます。
この認証情報の再利用は、Microsoft Power BI コネクタ フレームワークがカスタム コネクタのエンドユーザー シングル サインオン(SSO)認証をサポートしていないために発生します。レポートを閲覧するユーザーに基づいてデータアクセスを制限するには、Power BI 内で行レベルのセキュリティ(RLS)を使用します。
行レベルのセキュリティを使用した Power BI サービスでのレポートの公開
Looker - Power BI コネクタを使用して Power BI Desktop でレポートを公開したら、必要に応じて Power BI サービスを使用してウェブブラウザからレポートを操作できます。
Power BI Desktop では、行レベルのセキュリティ(RLS)を使用して、特定のユーザーのデータアクセスを制限できます。Power BI Desktop 内でロールとルールを定義し、ロールを検証する手順については、Power BI のドキュメントをご覧ください。
Power BI デスクトップでロールを定義すると、Power BI サービスでロールとルールをオンラインで使用できます。
行レベルのセキュリティを使用して Power BI サービスでレポートを公開する手順は次のとおりです。
- Power BI デスクトップでレポートを開き、ウィンドウの上部にある [ホーム] メニューを選択します。
- [Home] メニューから [Publish] オプションを選択します。
- プルダウン メニューからワークスペースを選択し、[Select] をクリックします。Power BI デスクトップに、Power BI でレポートを開くためのリンクを含む成功のメッセージが表示されます。
- リンクをクリックして Power BI を開きます。
- Power BI サービスで [Workspaces] に移動し、レポートを公開したワークスペースを選択します。
- レポートのデータセットのリストを見つけます(レポート自体ではありません)。
- データセットのリストで、3 つの点からなる [その他のオプション] メニューをクリックし、[セキュリティ] を選択します。
Power BI に [Row-Level Security] ウィンドウが表示されます。ここから、Power BI デスクトップで作成したロールを選択し、ロールに属するユーザーまたはグループを追加して、Power BI サービスのロールを検証します。
これで、レポートを任意のユーザーと共有できるようになりました。共有相手には、作成したロールに基づいて、表示が許可されているデータのみが表示されます。
Power BI Desktop のデバッグ ロギングを有効にする
問題のトラブルシューティングや診断を行うには、Power BI と Looker 間の接続のロギングを有効にします。
次のセクションで説明するように、接続と Power BI 自体のロギングを有効にする必要があります。
コネクタレベルのロギングを有効にする
問題をトラブルシューティングするには、Looker–Power BI コネクタ内で診断ロギングを有効にします。
Power BI Desktop から Looker データへの新しい接続を作成するときに、次の手順に沿ってロギングを有効にします。
- Looker 接続ダイアログで、[詳細オプション] を開きます。
- [Enable Logging] プルダウン メニューから [TRUE] を選択します。
Power BI Desktop から Looker データへの接続をすでに作成している場合は、次の手順に沿って Power Query エディタ内でクエリを手動で編集する必要があります。
- Power BI Desktop で、[Transform Data] を選択します。
- [ホーム] リボンで、[詳細エディタ] を選択します。
Source = Looker.DataSourceで始まる行を見つけます。関数の 2 番目の引数を更新して、
EnableLogging=trueを含めます。Looker.DataSource("instance.looker.com", [EnableLogging=true])[完了] をクリックします。
Power BI レベルのトレースを有効にする
Power BI Desktop から Looker データへの接続でロギングを有効にするだけでなく、次の手順に沿って Power BI Desktop からトレースを有効にする必要があります。
- [ファイル] > [オプションと設定] > [オプション] を選択します。
- [Options] ダイアログで [Diagnostics] を選択します。
- [診断オプション] で [トレースを有効にする] を選択します。
- ログファイルを表示するには、[クラッシュ ダンプ / トレース フォルダを開く] を選択します。
注意点
クエリの行数制限
Looker ユーザー アカウントに download_without_limit 権限がない限り、Looker–Power BI コネクタからのクエリには LIMIT 5000 ステートメントが自動的に含まれます。Looker ユーザー アカウントに download_without_limit がある場合、Looker–Power BI コネクタのクエリにはクエリ行の上限は適用されません。
探索の絞り込み
Looker Explore が always_filter または conditionally_filter LookML パラメータで定義されている場合、フィルタが Power BI に表示されなくても、Looker–Power BI コネクタのクエリにはフィルタが適用されます。
サポートされるディメンション グループのタイムフレーム
type: time の dimension_group では、date と time のタイムフレームのみが Looker–Power BI コネクタでサポートされています。他のタイムフレームは非表示になります。
System Activity Explore が Looker–Power BI コネクタに表示されない
System Activity Explore は、Looker–Power BI コネクタに表示されません。Looker 管理者は、Looker UI で System Activity Explore を直接表示できます。
型変換の制限
可能であれば、LookML ビュー内で列タイプを設定することをおすすめします。
既知の制限事項
Looker–Power BI コネクタを使用する場合は、次の制限事項に注意してください。
データ モデリングとモード
- 数値ディメンション: 数値ディメンションとメジャーは、どちらも Power BI でメジャーとして表示されます。数値ディメンションをディメンションとして使用するには、Power BI Desktop でデフォルトの集計を [集計しない] に変更する必要があります。
- インポート モード: 最適なパフォーマンスを得るには、DirectQuery モードを使用します。Power BI のインポート モードを使用している場合は、次の制約に注意してください。
- パフォーマンス: 大規模なモデルにアクセスするレポートは、読み込みに時間がかかることがあります。
- タイムアウト: 「データの取得」プロセスがハングまたはタイムアウトした場合は、DirectQuery モードに切り替えます。
- フィールドの制限: インポート モードでは、フィルタ限定のフィールドとパラメータ フィールドが無効になります。
- メジャーの評価: インポート モードでは、Looker が Explore 内のメジャーを評価できないため、レポートの精度に影響する可能性があります。
集約
Power BI は、Looker のメジャーに独自の集計を適用します。これにより、特にマトリックス ビジュアルでエラーや不整合な結果が発生する可能性があります。
- サポートされているタイプ:
average、count、count_distinct、max、min、sumのみを使用します。 - サポートされていないタイプ: コネクタは、標準偏差、分散、アルファベット順の最初または最後の文字列集計のクエリをサポートしていません。
- 中央値のパフォーマンス: Power BI は、すべての値を取得してローカルで中央値を計算します。大規模なデータセットでは処理が遅くなり、タイムアウトする可能性があります。
フィルタリングと並べ替え
- 非表示のフィールドによる並べ替え: ビジュアリゼーションに含まれていないフィールドで並べ替えることはできません。フィールドで並べ替えるには、そのフィールドをビジュアリゼーションに追加します。
- 高度なフィルタの制限事項: Power Query と Looker フィルタ式の違いにより、次の制限事項が適用されます。
- テキスト: 複数のテキスト フィルタはサポートされていません。
- 日付: 日付フィールドと日時フィールドでは、
is、is not、is on or after、is beforeのみがサポートされています。 - 複数の数値フィルタは、次の場合にのみサポートされます。
- 不等式と不等式(例: 未満かつより大きい)。
- 不等式または不等式(例: 「より小さい」または「より大きい」)。
- 「is」または「is」。
- 複数の日付フィルタと日時フィルタは、次のケースでのみサポートされます。
is on or after AND is beforeis or is
Power Query 関数
次のテーブル関数は折りたたみ可能ではありません。
Table.DistinctTable.JoinTable.NestedJoinTable.Skip
トラブルシューティング
以降のセクションでは、一般的な問題とその解決策について説明します。
Looker - Power BI コネクタが Power BI の [データを取得] リストに表示されない
[Documents]\Microsoft Power BI Desktop\Custom Connectors ディレクトリに looker_1.4.3.mez ファイルが含まれていることを確認します。
- Power BI Desktop で、セキュリティ設定を確認します。
- [File] > [Options and settings] > [Options] を選択します。
- [Security] を選択します。
- [Data Extensions] で [(Not Recommended) Allow any extension to load without validation or warning] を選択します。
- [OK] をクリックします。
- Power BI Desktop を再起動します。
エラー: フィールド名に使用できるのは、英字、数字、アンダースコアのみです
場合によっては、データの更新時または変更の適用時に次のエラー メッセージが表示されることがあります。
DataSource.Error
Message: A LookML model issue has occurred.
Details: Invalid field name "...". Field names may only include letters, numbers and underscores and must start with a letter or underscore for Google BigQuery Standard SQL
このエラーは、列名に、基盤となるデータベース(BigQuery など)でサポートされていないスペースや特殊文字が含まれている場合に発生します。
この問題を解決する手順は次のとおりです。
- エラーの原因となっている列を特定します(通常はエラー メッセージの
Detailsセクションで参照されます)。 - 英字、数字、アンダースコアのみを使用するように列の名前を変更します。
- 不適切:
Custom Column Name - 適切:
Custom_Column_Name
- 不適切:
エラー: このビジュアルのデータの取得中にエラーが発生しました
場合によっては、Power BI で OAuth の失敗や認証情報の問題(Looker database authentication required など)を示す認証エラーが表示されることがあります。
このエラーが表示された場合は、Looker アカウントにデータベース接続に必要な OAuth 認証情報がありません。この問題を解決する手順は次のとおりです。
- Looker インスタンスにログインします。
- ユーザー プロフィール アイコンを選択し、[アカウント] を選択します。
- [OAuth Connection Credentials] セクションに移動します。
- アクセスする接続を見つけて、[ログイン] を選択します。
- Power BI Desktop に戻り、データを更新します。
Looker–Power BI コネクタの変更履歴
以降のセクションでは、Looker–Power BI コネクタの各バージョンの更新内容について説明します。
バージョン 1.4.3
Looker–Power BI コネクタのバージョン 1.4.3 には、次の更新が含まれています。
- コネクタラベルにコネクタのバージョン番号が含まれるようになりました。
- トラブルシューティングのためにコネクタ内で診断ログを動的に有効にする、新しい [ロギングを有効にする] オプションを追加しました。
- 新しい [非表示の Explore とフィールドを表示] オプションを追加しました。有効にすると、非表示の Explore とフィールドが表示されます。これは、以前の [Show Hidden Fields] オプションに代わるものです。
Looker–Power BI コネクタのバージョン 1.4.3 では、次のバグの修正が行われています。
- 文字列連結 DAX 演算子(
&)が失敗する問題を修正しました。 - Power BI メジャーを Looker メジャーに適用するとエラーが発生する問題を修正しました。
- [Credential Configuration] メニューに Looker アイコンが再び表示されます。
バージョン 1.4.2
Looker–Power BI コネクタのバージョン 1.4.2 には、次の更新が含まれています。
- [Disable Preview Optimization] 接続設定が削除されました。
- [Show Hidden Fields] 接続オプションが [Advanced Options] セクションに移動しました。
- ベータ版フラグが削除され、Power BI でコネクタがベータ版として表示されなくなりました。
Looker–Power BI コネクタのバージョン 1.4.2 では、次のバグの修正が行われています。
- Power BI でブール値スライサーと日付スライサーが失敗する回帰エラーを修正しました。
datesフィルタでis-notフィルタが機能しない問題を修正しました。
バージョン 1.4.0
Looker–Power BI コネクタのバージョン 1.4.0 には、次の更新が含まれています。
- インポート モードのサポートを追加
- データ プレビューを有効にしました
SELECT *クエリを実行する際の動作を改善- Looker のキャッシュ ヒット率の向上
- フィルタ候補の取得のパフォーマンスが向上
Looker–Power BI コネクタのバージョン 1.4.0 では、次のバグの修正が行われています。
- フィルタ フィールドとパラメータ フィールドに値が渡されたことを Looker が検出しないバグを修正しました。
- パラメータの推奨値がスライサーに表示されないことがあるバグを修正しました。
- Liquid 変数が LookML ステートメントで無視されるバグを修正しました
- Power BI マトリックス ビューで、個別のメジャー値のカウントが不整合になるバグを修正しました。
バージョン 1.3.1
Looker–Power BI コネクタのバージョン 1.3.1 には、次の更新が含まれています。
- 非表示フィールドを表示するオプションを追加
Looker–Power BI コネクタのバージョン 1.3.1 では、次のバグの修正が行われています。
- ビジュアルとレポートの両方にフィルタが存在する場合にビジュアルが失敗するバグを修正しました。
バージョン 1.3.0
Looker–Power BI コネクタのバージョン 1.3.0 には、次の更新が含まれています。
- 簡素化された日時形式
- サポートされていないテキスト表現の検出を改善
- エラー メッセージ レポートの改善
Looker–Power BI コネクタのバージョン 1.3.0 では、次のバグの修正が行われています。
- フィルタ値のエスケープ文字のサポートを改善
バージョン 1.2.0
Looker–Power BI コネクタのバージョン 1.2.0 には、次の更新が含まれています。
- パラメータとフィルタ限定のフィールドがサポートされるようになりました
- テキスト、数値、日付、日時のフィルタ限定フィールドに対する高度なフィルタのサポート
- Looker の推奨値を利用したフィルタ限定フィールドの基本的なフィルタのサポート