Cómo agregar y editar filtros de paneles definidos por el usuario

En esta página, se describen los filtros estándar del panel. Para obtener información sobre los filtros cruzados de los paneles, visita la página de documentación Filtros cruzados de los paneles.

Acerca de los filtros del panel

Los filtros del panel permiten que un usuario limite los resultados del panel solo a los datos que le interesan. Los filtros del panel se pueden aplicar a todos los campos del panel o a solo uno.

Cuando un usuario ve un panel, puede actualizar temporalmente los valores de los filtros del panel, lo que no afecta a ningún otro usuario. Esto difiere de los filtros que forman parte de una consulta subyacente de una tarjeta del panel, ya que los usuarios no pueden cambiar estos filtros, a menos que tengan permiso para editar la tarjeta o para Explorar desde aquí.

Para realizar cambios permanentes en los filtros que verán todos los usuarios, o para agregar o borrar filtros, debes tener el nivel de acceso Administrar acceso, Editar para el panel y estar en el modo de edición.

Comportamiento de anulación del filtro del panel

Los filtros de un panel se pueden aplicar en diferentes niveles. Cuando varios filtros afectan el mismo campo, Looker determina la prioridad según la siguiente jerarquía (de mayor a menor prioridad):

  1. Filtros cruzados (mayor prioridad): Se crean cuando los usuarios interactúan con los datos en los mosaicos del panel que tienen habilitados los filtros cruzados.
  2. Filtros a nivel de la visualización: Se colocan directamente en un mosaico de visualización específico.
  3. Filtros a nivel del panel: Se aplican a nivel del panel en uno o más campos.
  4. Filtros a nivel de la consulta (precedencia más baja): Se configuran en la consulta subyacente del mosaico (Explorar o Look).

El comportamiento de anulación entre estos filtros se determina de la siguiente manera:

  • Anulación del mismo campo:
    • Cuando se aplican un filtro a nivel de la visualización y un filtro a nivel del panel al mismo campo, el filtro a nivel de la visualización anula el filtro a nivel del panel para ese mosaico. Solo se aplica el valor del filtro a nivel de la visualización a esa tarjeta.
    • Cuando se aplica un filtro a nivel del panel o a nivel de la visualización, junto con un filtro en la consulta subyacente del mosaico, al mismo campo, el filtro a nivel del panel o a nivel de la visualización anula el filtro de la consulta. Solo se muestra y aplica el valor del filtro de nivel superior.
    • Los filtros cruzados anulan los filtros a nivel de la visualización, del panel y de la consulta en el mismo campo.
  • Expresiones personalizadas: Si la consulta subyacente usa una expresión personalizada, los filtros de nivel superior no anulan los campos del filtro de expresión personalizada, independientemente de las columnas a las que se haga referencia. En este caso, se muestran y aplican tanto el filtro de nivel superior como el filtro de consulta.
  • Filtros complejos (condiciones OR): Si la agrupación de filtros de la búsqueda subyacente contiene al menos una condición OR, el filtro se trata como un filtro complejo, y los filtros de nivel superior no anulan ningún campo al que se haga referencia en ese filtro de búsqueda. Se muestran y aplican ambos filtros.

En resumen, un filtro en la consulta subyacente se trata como un filtro personalizado que los filtros de nivel superior nunca anularán si se cumple una de las siguientes condiciones:

  • El agrupamiento AND/OR más interno contiene al menos una condición OR.
  • El filtro contiene una expresión personalizada.

Filtros del panel y LookML

Si un modelo, una exploración o un campo usan los parámetros label (modelo), label (exploración) o label (campo), respectivamente, para cambiar su nombre en el menú Explorar o en el selector de campos, el nombre que se proporciona en el parámetro label se usa en la ventana Agregar filtro.

Si eres desarrollador de LookML y estás en el Modo de desarrollo, puedes crear un filtro de panel en un campo que solo aparece en la versión del modelo del Modo de desarrollo, pero el filtro no funcionará como se espera cuando salgas del Modo de desarrollo o cuando otros usuarios lo utilicen. Del mismo modo, si un campo de filtro se borra o se cambia de nombre después de que se crea el filtro, este no funcionará como se espera.

Cómo agregar filtros de panel

Para comenzar, asegúrate de que el panel esté en modo de edición y de que tengas al menos un mosaico de consulta o un mosaico vinculado a un Look. Selecciona Filtros en la barra de herramientas superior y, luego, Agregar filtro.

A continuación, aparecerá una ventana Agregar filtro.

La ventana Agregar filtro

La ventana Agregar filtro aparece completada previamente con campos (dimensiones o medidas) de cualquier Explorar que se haya usado en la creación de los mosaicos de este panel.

Por ejemplo, en la siguiente ventana Add Filter, se muestran las exploraciones que se usan en los mosaicos del panel: la exploración Flights del modelo E Faa y la exploración Order Items del modelo MB ecommerce_demo.

Los Explorar que se completan previamente en la ventana Agregar filtro aparecen después de la barra de búsqueda Filtrar por.

Selecciona la flecha junto a una exploración para mostrar sus vistas. Luego, cada vista se puede expandir para revelar sus campos.

Para filtrar un campo de una de estas Exploraciones, puedes usar el diálogo Filtrar por para buscar campos o ingresar manualmente el nombre de un campo. También puedes hacer clic en un nombre de campo, como ID del pedido, para agregarlo al diálogo Filtrar por.

Si seleccionas un campo que ya usa otro filtro, Looker te alertará. Si bien aún puedes crear el filtro, no puedes aplicar varios filtros que usen el mismo campo a la misma tarjeta del panel.

Si deseas crear un filtro en un campo de un Explorar que no se usa en el panel, consulta la sección Filtros avanzados en esta página.

Una vez que hayas seleccionado el campo por el que deseas filtrar, selecciona Agregar.

Filtros avanzados

Los filtros avanzados te permiten crear filtros de panel con campos que no se encuentran en las Exploraciones que se usan para crear mosaicos en el panel. En la ventana Agregar filtro, habilita el interruptor Avanzado para usar filtros avanzados. Esto actualiza la ventana Agregar filtro con opciones para seleccionar un modelo, una exploración y un campo con los que crear el filtro:

Primero, selecciona un nombre de modelo en el menú desplegable Modelo. El menú desplegable contiene todos los modelos de LookML a los que tienes acceso.

Una vez que se selecciona un modelo, el diálogo Explorar se completa con un menú desplegable de todas las Exploraciones que están presentes en el modelo seleccionado.

Una vez que se seleccionan el modelo y la exploración, los campos disponibles en esa exploración completarán la ventana Agregar filtro. Puedes usar la barra de búsqueda para encontrar el campo por el que deseas filtrar o seleccionar un nombre de campo.

Una vez que hayas seleccionado el campo por el que deseas filtrar, selecciona Agregar.

Personaliza la configuración del filtro

Una vez que selecciones un campo de filtro y Agregar, en la ventana Agregar filtro, se mostrarán varios parámetros de configuración personalizables en las pestañas Configuración y Mosaicos que se actualizarán.

La pestaña Configuración

  • Título: Ingresa el título del filtro tal como quieres que aparezca en el panel. La opción de título se completa previamente con el nombre del campo de filtro.
  • Control: Selecciona un tipo de control de una lista, que varía según el tipo de datos que filtres. Consulta la sección Controles de filtros del panel en esta página para obtener más información sobre los diferentes tipos de controles.
  • Pantalla: Para los controles que se pueden mostrar como elementos intercalados o como ventanas emergentes, selecciona cómo se mostrará el filtro. Consulta la sección Cómo mostrar los filtros del panel en esta página para obtener más información sobre las diferentes formas de mostrar los filtros. Si un control solo se puede mostrar de una manera, no aparecerá esta opción.
  • Valores: Para establecer opciones de valores específicos para el filtro, elige una opción del menú desplegable o ingresa las opciones de valores en este campo. Déjalo en blanco para permitir que se muestren las opciones de valor de la base de datos, hasta la cantidad máxima de valores disponibles para ese control. En el caso de los datos numéricos, este campo se reemplaza por los campos Mín. y Máx..
  • Configurar valor predeterminado: De manera opcional, establece el valor predeterminado para el filtro.
  • Requerir un valor de filtro: Haz clic en Opciones adicionales para ver la opción Requerir un valor de filtro. Haz clic en la casilla de verificación para requerir un valor para el filtro. Consulta la sección Cómo solicitar un valor de filtro en esta página para obtener más información sobre cómo solicitar valores de filtro.
  • Selecciona filtros para actualizarlos cuando este filtro cambie: Haz clic en Opciones adicionales para ver la opción Selecciona filtros para actualizarlos cuando este filtro cambie. Haz clic en la casilla de verificación para vincular otros filtros a este. Consulta la sección Cómo configurar filtros vinculados en esta página para obtener más información sobre los filtros vinculados. Si no hay otros filtros en el panel, esta opción estará inhabilitada.
  • Agregar y Cancelar: Haz clic en uno de estos botones para guardar o cancelar el filtro nuevo.

La pestaña Mosaicos que se actualizarán te permite determinar qué mosaicos responden al filtro.

Comportamiento predeterminado de la pestaña Mosaicos que se actualizarán

De forma predeterminada, Looker aplica automáticamente el filtro a los mosaicos que se crearon a partir de la misma exploración que el filtro y establece el valor de Campo para filtrar en el mismo campo que el elegido para el filtro.

Si se agregan mosaicos nuevos al panel después de que se crea el filtro, y si se crearon a partir de la misma Exploración que el filtro, el filtro del panel se aplicará automáticamente a ese mosaico.

Cómo realizar ediciones en la pestaña Mosaicos que se actualizarán

Si quieres ajustar qué tarjetas escuchan qué filtro o qué campos se ven afectados por los filtros, tienes disponibles los siguientes parámetros de configuración.

  • Selecciona Todos o Ninguno para activar o desactivar el filtro en todas las tarjetas.

  • En la sección Campo para filtrar, para cada tarjeta, elige qué campo se verá afectado por el filtro o elige no aplicar el filtro a una tarjeta individual. Si el campo de un filtro nuevo ya se usa en un filtro preexistente, las tarjetas filtradas por el filtro preexistente no estarán disponibles para el filtro nuevo.

  • Selecciona Agregar o Cancelar para guardar o cancelar la nueva configuración del filtro.

Controles de filtros del panel

Los controles de filtros del panel te permiten personalizar la apariencia de los filtros para los usuarios del panel. Los tipos de controles de filtro disponibles en el menú desplegable Control a medida que creas un filtro del panel dependen del type de datos de LookML asignado al campo por el que filtras.

S = Funciona con el tipo de datos string

N = Funciona con el tipo de datos number y las medidas numéricas

T = Funciona con el tipo de datos tier

ZC = Funciona con el tipo de datos zipcode

YN = Funciona con el tipo de datos yesno

DI = Funciona con el tipo de datos distance

DU = Funciona con el tipo de datos duration

DT = Funciona con la mayoría de los tipos de datos de fecha y hora *

L = Funciona con el tipo de datos location

P = Funciona con el parámetro parameter

ControlDescripciónAparienciaTipos de datos
Selección múltiple
Grupo de botones Este tipo de filtro es útil para ofrecer a los usuarios un conjunto seleccionado de opciones limitadas. Se pueden seleccionar hasta 30 opciones en el parámetro de configuración Valores. En el caso de los tipos de datos string, tier y zipcode, si el parámetro de configuración Valores se deja en blanco, se muestran los primeros 30 valores de la base de datos.

Un botón se colorea una vez que se selecciona.
Los controles de grupo de botones aparecen como una serie horizontal de botones separados que representan valores de filtro. S N T ZC YN DI DU
Casillas de verificación Al igual que un grupo de botones, pero con un diseño ligeramente diferente, este tipo de filtro es útil para brindarles a los usuarios un conjunto seleccionado de opciones limitadas. Se pueden seleccionar hasta 50 opciones en el parámetro de configuración Valores. En el caso de los tipos de datos string, tier y zipcode, si el parámetro de configuración Valores se deja en blanco, se muestran los primeros 50 valores de la base de datos. Los controles de casilla de verificación aparecen como una serie horizontal de casillas que representan valores de filtro. S N T ZC YN DI DU
Lista de etiquetasUna combinación de filtros de casillas de verificación y menús desplegables. Las opciones del menú desplegable se pueden seleccionar en el parámetro de configuración Valores. En el caso de los tipos de datos string, tier y zipcode, todos los valores pueden aparecer en la base de datos si el parámetro de configuración Valores se deja en blanco.

Los usuarios pueden expandir el menú de valores haciendo clic en el campo de filtro o en el corchete angular. Los usuarios pueden seleccionar o anular la selección de valores individuales haciendo clic en la casilla de verificación de un valor. Los usuarios también pueden hacer clic en el ícono de X junto al valor de un filtro para anular su selección. Los usuarios pueden seleccionar todos los valores disponibles haciendo clic en la casilla de verificación (Cantidad seleccionada) de (Cantidad de opciones) (por ejemplo, 0 de 200 seleccionadas) para agregar todos los valores coincidentes al filtro y pueden seleccionar Anular la selección de todo para quitar todos los valores coincidentes. Todos los cambios se aplicarán automáticamente, a menos que el usuario haga clic en el botón Cancelar.

Los controles de la lista de etiquetas solo pueden aparecer en la orientación de ventana emergente o detrás del botón Más. La opción Seleccionar todo no está disponible si la URL del panel supera los 2,083 caracteres.
La lista de etiquetas aparece como un menú desplegable con casillas de verificación junto a los elementos del menú. S N T ZC DI DU
Control deslizante de rangoLos valores mínimo y máximo del control deslizante de rango se pueden establecer en la pestaña Configuración de la ventana de configuración del filtro.

Los usuarios pueden establecer el rango de valores del filtro ajustando ambos extremos del control deslizante.
Un control deslizante de rango aparece como una escala numérica horizontal con extremos móviles en cada lado para personalizar un rango de valores. N DI DU
Selección única
Activación o desactivación de los botonesEste tipo de filtro es útil para ofrecer a los usuarios un conjunto seleccionado de opciones limitadas. Se pueden seleccionar hasta 30 opciones en el parámetro de configuración Valores. En el caso de los tipos de datos string, tier y zipcode, si el parámetro de configuración Valores se deja en blanco, se muestran los primeros 30 valores de la base de datos.

Un botón se colorea una vez que se selecciona.
Los botones de activación aparecen como una serie horizontal de botones conectados que representan valores de filtros. S N T ZC YN DI DU P
Botones de selecciónAl igual que un botón de activación, pero con un diseño ligeramente diferente, este tipo de filtro es útil para brindarles a los usuarios un conjunto seleccionado de opciones limitadas. Se pueden seleccionar hasta 50 opciones en el parámetro de configuración Valores. En el caso de los tipos de datos string, tier y zipcode, si el parámetro de configuración Valores se deja en blanco, se muestran los primeros 50 valores de la base de datos. Los botones de selección aparecen como una lista horizontal de valores con un botón de selección circular a la izquierda de cada valor. S N T ZC YN DI DU P
Menú desplegableLas opciones del menú desplegable se pueden seleccionar en el parámetro de configuración Valores. En el caso de los tipos de datos string, tier y zipcode, todos los valores pueden aparecer en la base de datos si el parámetro de configuración Valores se deja en blanco.

Los usuarios pueden expandir el menú desplegable haciendo clic en el campo de filtro o en el corchete angular. Los usuarios pueden seleccionar una opción en el menú desplegable o escribir en el cuadro para reducir las opciones del menú. Los usuarios también pueden seleccionar Cualquier valor.

Los controles de menú desplegable solo pueden aparecer en la orientación intercalada o detrás del botón Más.
Aparecerá un menú desplegable con un solo valor y un chevron. Cuando se selecciona, el chevron revela una lista de posibles valores de filtro. S N T ZC YN DI DU P
Control deslizanteLos valores mínimo y máximo del control deslizante se pueden establecer en la pestaña Configuración de la ventana de configuración del filtro.

Los usuarios pueden establecer el valor del filtro ajustando el extremo derecho del control deslizante.
Aparece un control deslizante como una escala numérica horizontal con un extremo móvil en el lado derecho para personalizar el valor máximo.N DI DU
Fechas y horarios
Un solo día Los usuarios pueden seleccionar la fecha para expandir el calendario y elegir un nuevo día.

Los controles de menú de un solo día solo pueden aparecer en la orientación intercalada o detrás del botón Más.
Inicialmente, el control de un solo día aparece como una sola fecha, que se puede seleccionar para mostrar un calendario mensual. DT *El control de un solo día se puede usar con la mayoría de los períodos y los tipos basados en el tiempo, pero los usuarios solo pueden seleccionar fechas únicas con este tipo de control.
PeríodoLos usuarios pueden seleccionar el período para expandir el calendario y elegir uno nuevo.

Los controles del menú de período pueden aparecer solo en la orientación intercalada o detrás del botón Más.
Inicialmente, los controles de período aparecen como un período, pero se pueden seleccionar para mostrar un calendario de 2 meses. Se pueden seleccionar fechas en el calendario para actualizar el valor del filtro. DT * El control de período se puede usar con la mayoría de los períodos y los tipos basados en el tiempo, pero los usuarios solo pueden seleccionar períodos con este tipo de control.
PeríodosLos usuarios pueden seleccionar un conjunto de períodos integrados en Looker o crear sus propios períodos personalizados seleccionando la pestaña Personalizado. Consulta la página de documentación Cómo ver paneles para ver la gama completa de opciones de períodos para un filtro de períodos.

Las opciones de períodos, como Últimos 7 días, incluyen el día actual. Para un período que excluye el día actual, selecciona Avanzado en el menú desplegable de control y configura el valor con días completos.

En lo que va del año incluye el período desde el comienzo del año hasta el segundo actual.

Los usuarios pueden seleccionar el período para ver las opciones.

Los controles del menú de períodos solo pueden aparecer en la orientación intercalada o detrás del botón Más.
Inicialmente, los controles de período aparecen como un período. Puedes seleccionar el período para revelar un menú de períodos predeterminados y una pestaña personalizada. DT * El control de período se puede usar con la mayoría de los períodos y los tipos basados en el tiempo, pero los usuarios no pueden seleccionar opciones de tiempo con este tipo de control.
Otro
AvanzadoConsulta la sección Uso de controles avanzados en esta página para obtener más información sobre los controles avanzados.

Los controles avanzados solo pueden aparecer en la orientación de la ventana emergente o detrás del botón Más.
Inicialmente, los controles avanzados aparecen como una condición de filtro. Se puede seleccionar esa condición para que se muestre una serie de menús desplegables y campos de texto para personalizar la condición. S N T ZC YN DT DI DU L P
* Nota sobre los datos de fecha y hora: Algunos períodos y tipos basados en el tiempo se interpretan como diferentes tipos de datos cuando Looker selecciona opciones de control para ellos. Dos ejemplos son el período yesno, que se interpreta como un tipo de datos yesno y, por lo tanto, tiene las opciones de control disponibles para el tipo yesno, y el período hour_of_day, que se interpreta como un tipo de datos number y, por lo tanto, tiene las opciones de control disponibles para el tipo number.

Cómo usar los controles avanzados

Se puede aplicar un control avanzado a todos los tipos de datos y proporciona cierta flexibilidad adicional en las condiciones de filtro que puedes configurar. Para crear un control avanzado, expande el menú desplegable Control en la ventana de configuración del filtro y selecciona Avanzado.

Una vez que selecciones Avanzado, la sección Configurar opciones de filtro se completará con las opciones de condición de filtro adecuadas para el tipo de datos que estás filtrando. Por ejemplo, si creaste un filtro para un campo con un tipo de datos string, aparecerán las opciones de condición del filtro, como es, contiene y comienza con. Los filtros en otros tipos de datos, como los tipos number o date, mostrarán diferentes opciones de condición. Para establecer las opciones de condición del filtro, haz clic en la casilla de cada opción.

La opción Permitir múltiples valores de filtro permite que los usuarios seleccionen más de un valor para el filtro. Está habilitada de forma predeterminada. Cuando se habilita, aparece un símbolo de + Agregar junto al campo Configurar valor predeterminado. Selecciona el símbolo + para agregar un valor de filtro adicional. Para restringir a los usuarios de modo que solo puedan seleccionar un valor, inhabilita esta opción. La opción Permitir múltiples valores de filtro no está disponible para los filtros basados en el tipo de datos location ni en el parámetro parameter.

Una vez que selecciones la opción de condición de filtro, podrás seleccionar un valor en el menú Configurar valor predeterminado, que se completa con valores de tu base de datos. También puedes ingresar un valor para recibir una sugerencia.

También puedes ingresar un valor por tu cuenta y presionar Intro en PC o Retorno en Mac para crear un valor.

Puedes seleccionar el ícono + junto al valor del filtro para agregar condiciones nuevas al filtro, que se agregarán como condiciones OR o AND, según los tipos de condiciones y valores.

Para quitar una condición, haz clic en la X junto a ella.

Controles, fechas y horas avanzados

Si bien existen varios controles de filtros que permiten filtrar por fechas, también puedes usar controles avanzados con fechas. Entre otras cosas, usar los controles avanzados permite a los usuarios seleccionar rangos "completos" que no incluyen el período actual. Para ello, deben seleccionar rangos como días completos o semanas completas en las opciones de condición. Esto es diferente del control del filtro de período, que incluye el período actual.

Los controles avanzados también permiten a los usuarios seleccionar valores de tiempo, como horas, minutos y segundos.

Coincide con un atributo de usuario

Los controles avanzados también te permiten seleccionar coincide con un atributo del usuario en la sección Configurar opciones de filtro. Esta opción te permite establecer filtros que cambian de forma dinámica según los atributos del usuario de los usuarios del panel. Consulta la página de documentación Cómo filtrar y limitar datos para obtener más información.

Partidos avanzados

Si haces clic en coincide con avanzado en la sección Configurar opciones de filtro, puedes ingresar una expresión de filtro de Looker para personalizar un filtro más allá de las opciones que se proporcionan en el menú de opciones.

También puedes hacer referencia a los atributos del usuario en los filtros avanzados de coincidencias con la siguiente sintaxis:

{{ _user_attributes['name_of_your_attribute'] }}

Cómo mostrar los filtros del panel

Tienes varias opciones para modificar la forma en que se muestran los filtros del panel. Puedes ajustar la apariencia de los controles de filtro individuales o de toda la barra de filtros.

Apariencia de los filtros individuales

Para configurar la forma en que aparece un filtro, primero asegúrate de que tu panel esté en modo de edición y, luego, selecciona el estilo de visualización en el campo Display de la ventana de configuración del filtro que aparece cuando seleccionas Edit en el menú del filtro. La mayoría de los filtros del panel se pueden mostrar de las siguientes maneras:

  • En línea: El filtro se muestra directamente en la barra superior del panel.

  • Ventana emergente: Aparece un valor de resumen en la barra superior del panel. Selecciona el valor para ver el filtro completo.

  • Los filtros también se pueden colocar detrás de un botón Más: Aparecerá un botón Más en la barra de filtros con un indicador que muestra la cantidad de filtros que contiene la barra. Los usuarios pueden seleccionar el botón para ver los filtros y sus valores.

Algunos controles de filtro solo se pueden mostrar en orientación intercalada. Cuando edites un panel con estos controles de filtro, no verás un campo Display en la ventana de configuración del filtro. Estos controles de filtro solo se pueden mostrar en orientación intercalada:

  • Menú desplegable
  • Un solo día
  • Períodos
  • Período

Además, algunos controles de filtro solo se pueden mostrar en orientación de ventana emergente. Cuando edites un panel con estos controles de filtro, no verás un campo Display en la ventana de configuración del filtro. Estos controles de filtro solo se pueden mostrar en orientación de ventana emergente:

  • Lista de etiquetas
  • Avanzado

En general, recomendamos que los filtros importantes o que se usan con frecuencia se muestren como elementos intercalados o ventanas emergentes, y que los filtros que se usan con menos frecuencia se muestren como desbordamiento.

Apariencia de la barra de filtros

Para establecer la forma en que aparece una barra de filtros, sigue estos pasos:

  1. Asegúrate de que el panel esté en modo de edición.
  1. Abre la ventana Configuración del panel.
  2. Selecciona la pestaña Filtros de la ventana Configuración.
  3. Puedes establecer la opción Vista de filtros predeterminada en Expandida o Contraída. (El valor predeterminado es Expandido).
  4. La opción Ubicación de los filtros te permite colocar la barra de filtros en la parte superior o a la derecha del panel. (El valor predeterminado se encuentra en la parte superior).

Cómo requerir un valor de filtro

De forma predeterminada, los filtros no requieren valores. Si se deja en blanco un filtro que no requiere un valor, los datos simplemente no se restringen por el campo del filtro. Por ejemplo, si tienes un filtro en un campo Estado en un panel y a ese filtro no se le asignó un valor, el panel devolverá datos para todos los estados.

Si un filtro requiere un valor, el panel no se ejecutará hasta que selecciones uno. Un filtro obligatorio sin ningún valor seleccionado muestra advertencias junto al filtro y cuando se mantiene el puntero sobre el ícono de recarga hasta que se elige un valor.

Además, no puedes crear una programación del panel sin seleccionar un valor para un filtro obligatorio ni borrar la caché y actualizar una tarjeta vinculada a un filtro obligatorio que no tenga un valor.

Para exigir que un usuario ingrese un valor en un filtro antes de poder ejecutar el panel, haz lo siguiente:

  1. Asegúrate de que el panel esté en modo de edición.
  1. Abre la ventana de configuración del filtro, ya sea agregando un filtro nuevo para el panel o editando uno existente.
  2. Selecciona la flecha junto al encabezado Opciones adicionales para revelar las opciones adicionales.
  3. Selecciona la casilla de verificación Requiere un valor de filtro.
  4. Selecciona Actualizar para guardar el cambio.

La casilla de verificación Requiere un valor de filtro simplemente requiere que los usuarios seleccionen cualquier valor. Para restringir los valores que puede seleccionar un usuario, establece los valores permitidos en el campo Valores de la ventana de configuración del filtro.

Los filtros obligatorios son útiles para limitar el tamaño de las consultas que se envían a tu base de datos. Para limitar el acceso a los datos de los usuarios del panel, usa el parámetro access_filter de LookML en su lugar.

Cómo configurar filtros vinculados

Los filtros del panel pueden vincularse de modo que las opciones de valores de filtro para un filtro se reduzcan según el valor o los valores de filtro seleccionados para otro filtro en el mismo panel.

Por ejemplo, puedes vincular un filtro del panel para la ciudad a un filtro independiente para el estado. Las opciones de valor del filtro para Ciudad cambiarán según el estado o los estados seleccionados en el filtro Estado.

Una vez que selecciones un valor de filtro para Estado, aparecerá un ícono de vínculo con el filtro Ciudad. Si mantienes el puntero sobre el ícono de vínculo, aparecerá un cuadro que indica que el filtro Estado redujo las opciones de valor para ese filtro.

Puedes ir más allá y vincular un filtro de código postal a los filtros de ciudad y estado, lo que reduce las opciones de valores para el código postal según la ciudad y el estado seleccionados. Por ejemplo, si el filtro Estado es Nueva Jersey y el filtro Ciudad es Asbury Park, en el menú desplegable del filtro Código postal solo se mostrará el valor del código postal dentro de Asbury Park.

Si vinculas filtros y tus datos no contienen valores para un filtro "secundario" (el filtro que se debe acotar), dados los valores seleccionados en el filtro "principal" (el filtro que acota las opciones del filtro secundario), los usuarios verán el mensaje No se encontraron coincidencias para el filtro secundario.

Los filtros vinculados funcionan en una sola dirección, del elemento superior al secundario. Si realizas una selección en un filtro secundario, no se verán afectadas las opciones de valores del filtro que se te presenten para el filtro principal.

Cuando vinculas filtros, cualquier filtro se puede usar como filtro "principal" (el filtro que reduce las opciones de otro filtro), pero el filtro "secundario" (el filtro que se reducirá) solo puede usar un campo de tipo string, que se usa comúnmente para palabras o frases, o de tipo zipcode, que se usa comúnmente para códigos postales.

Si solo hay un filtro en el panel, se inhabilitará la capacidad de vincular filtros.

Para vincular un filtro a otro, sigue estos pasos:

  1. Asegúrate de que el panel esté en modo de edición.
  1. Abre la ventana de configuración del filtro "principal" agregando un filtro de panel nuevo o editando uno existente.
  2. Selecciona la flecha junto al encabezado Opciones adicionales para revelar las opciones adicionales.
  3. Selecciona la casilla de verificación Selecciona filtros para actualizarlos cuando este filtro cambie.
  4. Selecciona el cuadro de campo para que aparezca un menú desplegable con los otros filtros string y zipcode presentes en el panel.
  5. Selecciona el filtro o los filtros string o zipcode que deseas vincular a este filtro.
  6. Selecciona Actualizar para guardar el cambio.

Cómo mover y cambiar la posición de los filtros del panel

Una vez que se colocan los filtros en un panel, puedes moverlos o cambiar su posición de las siguientes maneras:

  1. Entrar al modo de edición en el panel
  1. Coloca el cursor sobre el filtro para mostrar el ícono de seis puntos. El ícono de seis puntos aparece en la parte superior izquierda del filtro.
  2. Selecciona y mantén presionado el ícono de seis puntos, y arrastra el filtro a la posición que desees.

    Este método de arrastre se puede usar para cambiar la posición de los filtros intercalados y emergentes, reconfigurar qué filtros se colocan detrás de un botón Más y cambiar la posición de los filtros dentro del menú desplegable del botón Más.

    Si no hay filtros detrás del botón Más, aparecerá temporalmente un botón Más vacío mientras arrastras un filtro. Puedes mover el filtro sobre el botón Más para colocarlo dentro de él. Si no colocas el filtro en el botón Más, desaparecerá cuando dejes de sostenerlo.

Si el filtrado cruzado está habilitado en un panel, no puedes cambiar la posición de los filtros cruzados con la función de arrastrar y soltar, y si ingresas al modo de edición, se borrarán todos los filtros cruzados establecidos en el panel.

Filtros como mosaicos

La función Filtros como mosaicos te permite colocar filtros del panel directamente en el lienzo del panel como mosaicos, en lugar de restringirlos a la barra de filtros en la parte superior del panel. Esta función permite a los creadores de paneles colocar controles de filtro junto a los mosaicos de visualización específicos a los que afectan.

Además, la función Filtros como mosaicos permite a los usuarios ver la lista de filtros que se aplican a un mosaico de visualización específico.

Coloca filtros como mosaicos del panel

Una vez que se habilita el botón de activación de vista previa Filtros como mosaicos y contexto de filtro a nivel del mosaico, los editores de paneles pueden convertir los filtros en mosaicos arrastrables en el lienzo del panel de las siguientes maneras:

  • Para enviar un filtro de la barra de filtros al lienzo del panel, haz lo siguiente:

    • Arrastra el filtro al espacio Arrastra los filtros aquí para agregarlos al panel en la barra de filtros.
    • También puedes seleccionar el ícono de Menú de filtros de tres puntos que se encuentra junto al filtro y, luego, Enviar al panel.
  • Para enviar un filtro del lienzo del panel a la barra de filtros, haz lo siguiente:

    • Selecciona el ícono de Menú de filtros de tres puntos en la tarjeta de filtro y, luego, Enviar a la barra de filtros.

Un editor puede arrastrar y organizar las tarjetas de filtro en el lienzo del panel de la misma manera que otras tarjetas del panel. Un filtro puede residir en la barra de filtros superior o en el lienzo del panel, y su posición no afecta a qué tarjetas se aplica.

Un filtro solo puede aparecer una vez en el panel, ya sea en la barra de filtros superior o en el lienzo. Si duplicas una tarjeta de filtro en el lienzo de un panel, se creará un filtro nuevo con un ID diferente.

Cuando se duplica una pestaña del panel

Si una pestaña incluye un filtro colocado como una tarjeta, duplicar esa pestaña también duplicará la tarjeta de filtro en la pestaña nueva. La tarjeta duplicada sigue siendo la misma instancia de filtro y comparte el mismo ID de filtro que la original, por lo que cambiar un valor en una lo actualiza en la otra.

Inhabilita el botón de activación de vista previa Filtros como tarjetas y contexto de filtro a nivel de la tarjeta.

Si inhabilitas el botón de activación de la vista previa, se producirán los siguientes cambios:

  • Los filtros que se agregaron anteriormente al lienzo del panel como mosaicos aparecerán en la barra de filtros en la parte superior del panel.
  • Los mosaicos de filtro en el lienzo del panel se mostrarán como mosaicos en blanco.
  • En el modo de edición, se mostrará una nota en los mosaicos del panel en blanco para indicar que eran mosaicos de filtro.

Cómo mostrar los filtros aplicados para una tarjeta de visualización

Cuando se habilita la función de vista previa Filtros como mosaicos y contexto de filtro a nivel del mosaico o Filtros en mosaicos de visualización, los usuarios pueden verificar qué filtros se aplican a un mosaico de visualización específico.

Para ver los filtros aplicados en una tarjeta de visualización, haz una de las siguientes acciones:

  • Selecciona el ícono de filtro Mostrar filtros en el encabezado superior derecho de la tarjeta de visualización.
  • Mantén el puntero sobre la tarjeta de visualización, selecciona el ícono de tres puntos Acciones de la tarjeta y, luego, Mostrar filtros.

En un menú lateral, se muestran todos los filtros aplicados y sus valores seleccionados, organizados en las siguientes categorías:

  • Filtros de visualización: Muestra los filtros que se aplican directamente al mosaico de visualización (si la función de vista previa Filtros en mosaicos de visualización está habilitada).
  • Filtros del panel: Muestra los filtros a nivel del panel que se aplican a la tarjeta. Esto incluye los filtros cruzados.
  • Filtros de consulta: Muestra los filtros que se configuraron en la consulta subyacente del mosaico (en la Exploración o la Vista).

Si no se aplican filtros relevantes a la tarjeta, el menú mostrará Sin filtros.

Los creadores y editores de paneles pueden configurar si se muestran filtros en los mosaicos de visualización y cuáles se muestran con el parámetro de configuración Información del filtro de mosaico en la pestaña Filtros de la ventana Configuración del panel:

  • Mostrar todo: Muestra los filtros a nivel del panel, los filtros a nivel de la consulta (configurados en la función Explorar subyacente) y los filtros a nivel de la visualización (si está habilitada la función de vista previa Filtros en tarjetas de visualización).
  • Ocultar filtros de consultas (opción predeterminada): Muestra solo los filtros a nivel del panel y los filtros a nivel de la visualización (si está habilitada la función de vista previa Filtros en mosaicos de visualización).
  • No mostrar: Evita que la opción y el ícono de Mostrar filtros aparezcan en los mosaicos de visualización.

Cuando se muestran los filtros a nivel de la búsqueda, se comportan de la siguiente manera:

  • Aparecen con un ícono de información junto a ellos para distinguirlos de los filtros a nivel del panel.
  • Si se implementó lógica compleja (como la lógica AND/OR) en las consultas subyacentes del Explorar, el contexto del filtro se resume con una etiqueta de filtro personalizado.

Filtros como mosaicos en los paneles de LookML

Los paneles de LookML admiten los filtros como tarjetas. Los elementos de filtro se pueden configurar en la sección elements del código del panel de LookML para colocarlos como tarjetas en el lienzo del panel. Además, un parámetro de configuración del contexto del filtro controla la visualización de los filtros aplicados en las tarjetas de visualización. Si se omite este parámetro, el comportamiento predeterminado es ocultar los filtros de búsqueda.

Filtros en los mosaicos de visualización

La función Filtros en mosaicos de visualización permite que los creadores de paneles coloquen y administren filtros directamente en mosaicos de visualización individuales, en lugar de solo en la barra de filtros de la parte superior del panel. Esta función proporciona controles de filtrado contextuales y localizados que se aplican exclusivamente a la tarjeta específica en la que se configuran.

Para usar esta función, un administrador de Looker debe habilitar el botón de activación Filters on Visualization Tiles en la página Preview Features del panel Admin.

Cómo agregar un filtro a un mosaico de visualización

Para agregar filtros a un mosaico de visualización, debes tener privilegios de edición del panel. Para agregar un filtro directamente a una tarjeta de visualización individual, haz lo siguiente:

  1. Asegúrate de que el panel esté en modo de edición.
  2. En la tarjeta de visualización en la que deseas agregar un filtro, selecciona el ícono Agregar filtro de visualización en el encabezado de la tarjeta.
  3. En el diálogo que aparece, selecciona la opción Agregar filtro.
  4. Aparecerá una ventana Agregar filtro, completada previamente con los campos de la Exploración que se usó para crear la tarjeta. Selecciona el campo por el que deseas filtrar.
  5. Configura los parámetros del filtro, como el título, el tipo de control y el valor predeterminado.
  6. Selecciona Agregar.
  7. Cuando termines de editar el panel, selecciona Guardar en la barra de herramientas de edición del panel para guardar los cambios y salir del modo de edición.

El control de filtro aparece en una barra de filtros directamente en la parte superior del mosaico de visualización. La barra de filtros de tarjetas solo aparece cuando se configuran filtros en esa tarjeta.

Cómo interactuar con los filtros a nivel de la visualización y organizarlos

Los usuarios y editores del panel pueden interactuar con los filtros a nivel de la visualización directamente en el mosaico:

  • Actualización temporal de los valores de los filtros: Los usuarios pueden cambiar los valores de los filtros directamente desde la barra de filtros de la tarjeta sin obstruir la visualización subyacente.
  • Reordenar filtros: Cuando el panel está en modo de edición, los editores pueden mantener presionado el ícono Mantener presionado y arrastrar para reordenar en la barra de filtros de la tarjeta para cambiar el orden en que se muestran.
  • Desplazamiento horizontal: Los filtros a nivel de la visualización se ubican en la parte superior de la tarjeta y no se ajustan a varias líneas. Si la cantidad de filtros supera el ancho del mosaico, aparecerá una barra de desplazamiento horizontal en la barra de filtros del mosaico.

Cómo editar o borrar filtros a nivel de la visualización

Debes tener privilegios de edición del panel para editar o borrar filtros en un mosaico de visualización. Para editar o borrar un filtro en una tarjeta de visualización, haz lo siguiente:

  1. Asegúrate de que el panel esté en modo de edición.
  2. Haz clic en el ícono de menú de filtro de tres puntos junto al filtro.
  3. Para editar el filtro, selecciona Editar. Actualiza la configuración del filtro en la ventana de configuración del filtro y, luego, selecciona Actualizar.
  4. Para borrar el filtro, selecciona Borrar.
  5. Cuando termines de editar el panel, selecciona Guardar en la barra de herramientas de edición del panel para guardar los cambios y salir del modo de edición.

Consideraciones y limitaciones

Ten en cuenta las siguientes consideraciones y limitaciones cuando uses filtros en las tarjetas de visualización:

  • Alcance específico del mosaico: Un filtro a nivel de la visualización se aplica solo al mosaico específico en el que se coloca. No afecta a otras tarjetas del panel.
  • Un filtro por campo y por tarjeta: Solo puedes agregar un filtro a nivel de la visualización por campo en cada tarjeta. Si intentas agregar otro filtro para un campo que ya tiene un filtro en ese mosaico, Looker mostrará un error.
  • Se diferencian de los filtros a nivel del panel: Los filtros a nivel de la visualización no se pueden mover para convertirse en filtros a nivel del panel, y los filtros a nivel del panel no se pueden mover directamente a una tarjeta.
  • Explorar desde aquí: Si un usuario selecciona Explorar desde aquí en el menú de tres puntos Acciones de la tarjeta de la tarjeta, los filtros a nivel de la visualización no se transfieren a la Exploración (lo que coincide con los filtros a nivel del panel).
  • Exportación y descarga: Cuando descargas o imprimes un panel como PDF o imagen, los filtros a nivel de la visualización se capturan en un formato basado en el marco visible. Si una barra de filtros de tarjetas contiene filtros desbordados que requieren desplazamiento, solo se incluirán en la exportación los filtros visibles en la pantalla. Los filtros desbordados se cortarán.
  • URLs del panel: Los valores de filtro activos a nivel de la visualización se capturan en la URL del panel (por ejemplo, con sintaxis de parámetros como vis_id<id>.<field_name>=<value>), lo que permite a los usuarios compartir vistas filtradas específicas de un panel.
  • Paneles de LookML: En los paneles de LookML, los filtros a nivel de la visualización se especifican con el subparámetro vis_filter: true en el parámetro filters:. Para los filtros estándar a nivel del panel, no es necesario configurar vis_filter: false.

Cómo ocultar los filtros del panel

Puedes ocultar los filtros del panel modificando la URL del panel para incluir un parámetro hide_filter para cada filtro que desees ocultar. Cada vez que los usuarios accedan al panel con esa URL, verán una versión del panel con esos filtros ocultos. Sin embargo, si los usuarios navegan al panel de otras maneras o acceden a él con una URL que no contiene el parámetro hide_filter, los filtros no se ocultarán.

Por ejemplo, la siguiente es la URL de un panel con dos filtros que no están ocultos: User State, que tiene un valor de filtro establecido en Nueva Jersey, y Date, que no tiene un valor de filtro establecido.

https://mycompany.looker.com/dashboards/390?User+State=New+Jersey&Date=

Para ocultar un filtro, agrega un parámetro hide_filter a la URL, precedido por un signo de unión (&) y seguido por un signo igual (=), y asígnale al parámetro el valor del nombre del filtro, con los espacios del nombre reemplazados por signos más (+). No es necesario que incluyas el valor del filtro (si hay alguno) en el parámetro hide_filter.

Para ocultar solo el filtro Estado del usuario, modifica la URL de la siguiente manera:

https://mycompany.looker.com/dashboards/390?User+State=New+Jersey&Date=&hide_filter=User+State

Para ocultar los filtros Estado del usuario y Fecha, agrega otro parámetro hide_filter para el filtro Fecha:

https://mycompany.looker.com/dashboards/390?User+State=New+Jersey&Date=&hide_filter=User+State&hide_filter=Date

En el caso de los nombres de filtros con caracteres especiales, como los paréntesis y la barra diagonal en First Purchase (Yes / No), la URL codifica los caracteres especiales:

https://mycompany.looker.com/dashboards/390?First+Purchase+%28Yes+%2F+No%29=

Para ocultar ese filtro, puedes copiar el nombre del filtro codificado que ya existe en la URL (First+Purchase+%28Yes+%2F+No%29) y usarlo como el valor del parámetro hide_filter.

Hay algunos aspectos adicionales que debes comprender sobre cómo ocultar los filtros del panel:

  • Cualquier usuario con acceso de visualización a un panel puede ocultar los filtros del panel con la URL. El usuario no necesita tener acceso de edición al panel.
  • Los filtros ocultos del panel siguen aplicándose a los resultados del panel, aunque los controles de filtro no estén visibles en el panel.
  • Los valores de los filtros ocultos se pueden cambiar y aplicar al panel cambiando los valores en la URL.
  • Los filtros ocultos se pueden revelar quitando los parámetros hide_filter de la URL.
  • No verás los filtros ocultos en el modo de edición.
  • Si ocultas un filtro obligatorio sin un valor, los paneles del panel producirán errores de Filtros no válidos. Para solucionar uno de estos errores, asigna un valor al filtro obligatorio.
  • Si los paneles se programan o envían, los vínculos a los paneles que se incluyen en la entrega no incluyen el parámetro hide_filter.
  • Si los paneles incluyen alertas, los vínculos a los paneles que se incluyen en la entrega de alertas no incluyen el parámetro hide_filter.

Cómo aplicar filtros del panel a las alertas

El menú Filtros también te permite aplicar ediciones de filtros a las alertas presentes en los mosaicos de un panel. Consulta la página de documentación Efecto de las ediciones del panel en las alertas para obtener más información.

Cómo editar filtros de panel

En el modo de edición, aparece un ícono de menú de filtros de tres puntos junto a cada filtro. Para editar un filtro, selecciona el ícono. Se abrirá el menú de filtros, en el que se muestran opciones para editar o borrar un filtro.

Selecciona la opción del menú Editar para abrir una ventana de configuración del filtro, similar a la que se usa para agregar un filtro, que se completará con la configuración existente del filtro. Desde allí, puedes actualizar el campo de filtro, la configuración del filtro o los mosaicos que se actualizarán. Selecciona Actualizar o Cancelar en la ventana de configuración del filtro para guardar o cancelar los cambios.

Una vez que hayas editado los filtros, selecciona el botón Actualizar del panel para aplicar la nueva configuración de filtros a los mosaicos.

Selecciona Guardar en la barra de herramientas de edición del panel para guardar los cambios y salir del modo de edición.

Cómo borrar filtros del panel

En el modo de edición, aparece el ícono de menú de filtro de tres puntos junto a cada filtro.

Para borrar un filtro, haz lo siguiente:

  1. Selecciona el ícono de menú de filtros de tres puntos.
  2. Se abrirá el menú de filtros. En este menú, se muestran opciones para editar o borrar un filtro.
  3. Selecciona la opción de menú Borrar para borrar el filtro.
  4. Selecciona Guardar en la barra de herramientas azul para guardar los cambios y salir del modo de edición.
  5. Una vez que hayas borrado los filtros, selecciona el botón Actualizar del panel para aplicar la nueva configuración de filtros a los mosaicos.

Como alternativa, puedes seleccionar la opción del menú Editar, que abre la ventana de configuración del filtro. Selecciona el botón Borrar en la ventana de configuración del filtro para borrarlo.

La acción de borrar un filtro no se puede deshacer.