En esta página, se explica cómo programar y enviar un panel. Para obtener información sobre cómo programar vistas o exploraciones, consulta la página de documentación Usa el programador de Looker para enviar contenido.
Looker te permite programar entregas inmediatas o recurrentes de paneles con la opción de menú Programar entrega del panel.
Según cómo el administrador de Looker haya configurado tus permisos para la entrega de datos, es posible que puedas enviar tu contenido a uno o más de los destinos de entrega integrados de Looker:
También puedes programar un envío de datos a un servicio de terceros que esté integrado en Looker, como Slack.
Si hay resultados válidos en la caché, Looker los entregará. Si no hay resultados o si los resultados almacenados en caché vencieron, Looker volverá a ejecutar la consulta y almacenará en caché esos resultados.
Cómo iniciar una entrega desde un panel
Asegúrate de que el panel no esté en modo de edición. Selecciona el menú de tres puntos Acciones del panel en la parte superior derecha del panel y elige Programar envío. Si no ves la opción Programar entrega, comunícate con tu administrador de Looker para consultar los permisos que tienes asignados.

Una vez que selecciones Programar envío, aparecerá una ventana de programas existentes o una ventana de Programar envío o Enviar, según si ya creaste programas existentes en el panel.
Cómo iniciar una publicación desde una carpeta
También puedes iniciar el envío de un panel desde la carpeta en la que se encuentra.
Selecciona Programar envío en el menú de tres puntos que se encuentra en el lado derecho de la fila de ese panel (en la vista de lista) o en el menú de tres puntos que se encuentra en la parte superior derecha de la miniatura (en la vista de cuadrícula).
Ventana de programaciones existentes
Si ya creaste programas para este panel, aparecerá una ventana de programas existentes. En esta ventana, se muestran los programas que configuraste junto con información sobre cada uno, como el destino y el formato. En esta ventana, no aparecen los envíos que usan la recurrencia Enviar ahora ni las programaciones que crearon otras personas.

Puedes realizar las siguientes funciones en la ventana de programas existentes:
Selecciona Enviar ahora para enviar de inmediato el contenido programado existente sin interrumpir la cadencia programada.
Selecciona el menú de tres puntos para editar, duplicar o borrar un programa.
Selecciona Listo para salir de la ventana.
Selecciona Nuevo para abrir la ventana Programar entrega o Enviar y crear un programa nuevo o enviar una entrega nueva de inmediato.
Ventana Programar entrega
Si seleccionas Nuevo en la ventana de programas existentes o si no tienes ningún programa preexistente para el panel, se abrirá la ventana Programar entrega o Enviar. Esta ventana te permite personalizar la recurrencia, el destino, el formato, los filtros y mucho más:

La pestaña Configuración de la ventana Programar envío o Enviar te permite personalizar la recurrencia, el destino, el formato y mucho más de tu envío.
Asigna un nombre a una publicación
En la parte superior de la ventana Programar envío o Enviar, se muestra el nombre que se asigna automáticamente al envío. El nombre predeterminado es el nombre del panel. Para editar el nombre de la publicación, selecciónalo (indicado por el subrayado punteado) y realiza los cambios.
Según el destino de la publicación, el título también puede aparecer en otros lugares:
- En el caso de las entregas por correo electrónico, el título se usa para la línea de asunto del correo electrónico y como parte del nombre del archivo si seleccionas un formato que use un archivo adjunto de correo electrónico.
- En el caso de los webhooks, el título se incluye en la carga útil del webhook en el campo Título.
- En el caso de los envíos a un bucket de Amazon S3, el título se usa en el nombre de archivo del envío y en los correos electrónicos de error que se envían. El nombre de archivo de la entrega sigue el formato
TITLE_TIMESTAMP_HASH, en el queHASHes un identificador aleatorio de seis caracteres yTIMESTAMPsigue el patrónYYYY-MM-DDTHHMM(por ejemplo, la parte de la marca de tiempo se vería como2019-05-31T0933para el 31 de mayo de 2019 a las 9:33 a.m.). La zona horaria de la marca de tiempo coincidirá con la zona horaria de entrega. - En el caso de las entregas por SFTP, el título se incluye en el nombre del archivo de la entrega. El nombre de archivo de la entrega sigue el formato
TITLE_TIMESTAMP_HASH, en el queHASHes un identificador aleatorio de seis caracteres yTIMESTAMPsigue el patrónYYYY-MM-DDTHHMM(por ejemplo, la parte de la marca de tiempo se vería como2019-05-31T0933para el 31 de mayo de 2019 a las 9:33 a.m.). La zona horaria de la marca de tiempo coincidirá con la zona horaria de entrega. - En el caso de las entregas a servicios integrados que generan un archivo adjunto, el título se incluye en el nombre de archivo de la entrega.
Recurrencia
Personaliza el momento de la entrega en la sección Recurrencia.
Enviar ahora
Si seleccionas Enviar ahora en el menú desplegable Recurrencia, se enviará una entrega única del panel después de que completes los campos obligatorios y selecciones el botón Enviar ahora en la parte inferior de la ventana.
Programaciones basadas en el tiempo y en la fecha
Selecciona una de las siguientes opciones en el menú desplegable Recurrencia:
- Mensualmente
- Semanalmente
- Diaria
- Por hora
- Minutos
- Meses específicos
- Días específicos
Las opciones de tiempo cambian según la opción que elijas. Por ejemplo, la configuración Por hora incluye una hora de inicio y una hora de finalización. Looker enviará la entrega cada hora, desde la hora de Inicio hasta la hora de Finalización.
Los campos Hora, Inicio y Fin usan un reloj de 24 horas. Si la hora que quieres no está disponible en el menú desplegable, selecciona el campo y, luego, ingresa la hora de forma manual, como 9:15 o 15:37.
Los programas Por hora y Por minutos se repiten diariamente dentro del período de Inicio y Finalización que establezcas. La hora de finalización de los intervalos Por hora y Minutos no es inclusiva. La última entrega se envía en el último intervalo seleccionado antes de la hora de finalización especificada. Por ejemplo, si un panel está programado para enviarse Cada hora entre las 12:00 a.m. y las 11:00 p.m., se enviará cada hora, de 12:00 a.m. a 10:00 p.m. Si la recurrencia es cada 30 minutos entre las 12:00 a.m. y las 11:00 p.m., el último envío se realizará a las 10:30 p.m.
Programaciones activadas por actualizaciones de grupos de datos
Si tu desarrollador de LookML configuró grupos de datos, puedes programar el envío de un panel para que se realice después de que se haya activado un grupo de datos, se haya administrado la caché y se hayan vuelto a compilar las PDT pertinentes.
Selecciona Actualización del grupo de datos en el menú desplegable Recurrencia. Esto revela un campo Datagroup con un menú desplegable. Selecciona el grupo de datos cuya actualización debería activar la publicación.
Para programar un panel con un activador de actualización de grupo de datos, el panel debe contener al menos una tarjeta que se base en un archivo de modelo que incluya un parámetro datagroup. En el menú desplegable Datagroup, se enumeran todos los grupos de datos definidos en los modelos que se incluyen en el panel, incluso si no se usan para controlar el almacenamiento en caché de las consultas o las PDT. Incluso si el grupo de datos se usa en el modelo de una sola tarjeta, se enviará todo el panel cuando se complete la actualización del grupo de datos seleccionado.
Los programas basados en grupos de datos solo se envían después de que se completa el proceso de regeneración para todas las PDT que se conservan con ese parámetro de grupo de datos, lo que garantiza que tu entrega incluya los datos más actualizados.
Destino
El parámetro de configuración Destino puede mostrar varias opciones de destino para las entregas de paneles. Una vez que hayas seleccionado un destino de datos, aparecerá un nuevo campo de configuración para que agregues detalles específicos sobre ese destino, como una dirección de correo electrónico o una URL de webhook. Consulta las siguientes secciones para obtener información sobre la configuración de cada destino.
Correo electrónico
Cuando se selecciona Correo electrónico en el campo Destino, aparece un nuevo campo Direcciones de correo electrónico. Este es un campo obligatorio.
Ingresa las direcciones de correo electrónico de los destinatarios en el campo Direcciones de correo electrónico. Si ingresas varias direcciones de correo electrónico, presiona la tecla Intro o agrega una coma después de cada dirección. No hay límite para la cantidad de destinatarios que puedes agregar.
Según la configuración de tu instancia de Looker y los permisos asignados, es posible que puedas enviar correos electrónicos a direcciones de correo electrónico que no estén asociadas con ninguna cuenta de usuario en tu instancia de Looker. Estos correos electrónicos se clasifican como externos. Los indicadores Todos y Externos que se encuentran a la derecha del campo muestran la cantidad de todos los destinatarios de correo electrónico y la cantidad de solo los destinatarios de correo electrónico externos. Selecciona cada indicador para alternar entre mostrar todos los destinatarios de correo electrónico y mostrar solo los destinatarios externos. Para que puedas enviar contenido a usuarios externos, tu administrador de Looker debe haberte otorgado permisos para enviar contenido a usuarios externos o haber agregado los dominios de correo electrónico de esos destinatarios a la lista de entidades permitidas de dominios de correo electrónico para contenido programado.
Si un destinatario es otro usuario de Looker, esa persona verá la opción para volver al panel desde el correo electrónico, a menos que tu administrador de Looker haya configurado la política de datos enviados por correo electrónico de tu instancia de Looker como Solo enviar datos o que se haya deseleccionado la opción Incluir vínculos.
Los envíos por correo electrónico no pueden superar los 20 MB (para los formatos que se envían en el cuerpo del correo electrónico) ni los 15 MB (para los formatos que se envían como archivo adjunto).
Consulta la sección Opciones avanzadas de esta página para obtener más información sobre los envíos por correo electrónico.
Webhook
Los webhooks son una forma de activar intercambios entre servicios basados en Internet. Con un servicio web como Zapier, los webhooks pueden permitir que los datos de Looker se entreguen a una amplia gama de aplicaciones. Por ejemplo, puedes programar la entrega periódica de un panel a un webhook.
Para configurar un webhook, ve a tu servicio web y haz lo siguiente:
- Obtén una URL a la que Looker deba enviar una solicitud HTTPS.
- Especifica una aplicación de destino para la entrega de datos de Looker. Es posible que la aplicación de destino requiera una configuración adicional para recibir datos de Looker.
El procedimiento exacto varía según el servicio web y la aplicación de destino que uses para entregar los datos. Consulta la publicación de Comunidad Programación de vistas y paneles con webhooks para obtener lineamientos sobre cómo configurar otra aplicación para recibir los datos de webhook de Looker.
Cuando se selecciona Webhook en el campo Destino, aparece un nuevo campo URL de webhook. Este es un campo obligatorio.
Ingresa la URL a la que Looker debe enviar una solicitud HTTPS para esta entrega en el campo URL de webhook. Puedes obtener esta URL del servicio web que usas para controlar tu webhook.
Amazon S3
Los buckets de Amazon S3 son una forma común de almacenar grandes cantidades de datos. Tú o tu empresa deberán haber creado un bucket de S3 con Amazon antes de que Looker pueda usarlo.
Cuando se selecciona Amazon S3 en el campo Destino, aparecen varios campos nuevos en los que se te solicita información sobre tu bucket de Amazon S3:
- Bucket: Es el nombre de tu bucket de Amazon S3. Este es un campo obligatorio.
- Ruta de acceso opcional: Es la carpeta, si la hay, en la que deseas guardar tus datos.
- Clave de acceso: Es el ID de la clave de acceso a tu bucket de S3, proporcionado por Amazon. Este es un campo obligatorio.
- Clave secreta: Es la clave de acceso secreta a tu bucket de S3, proporcionada por Amazon. Este es un campo obligatorio.
- Región: Es la región de servicios de Amazon en la que se aloja tu bucket de S3.
Consulta la publicación de Comunidad Programación de resultados (ilimitados) en S3 para obtener más detalles sobre la entrega de datos con un bucket de Amazon S3.
SFTP
Elige SFTP en la sección ¿A dónde deben ir estos datos? para enviar tu contenido a un servidor SFTP. Enviar resultados a un servidor SFTP es un buen método para usar cuando tus datos o visualizaciones son demasiado grandes para enviarlos por correo electrónico. Si eliges esta opción de entrega, Looker te solicitará la dirección, el nombre de usuario y la contraseña del servidor SFTP, como se describe a continuación.
Ten en cuenta lo siguiente sobre los envíos por SFTP:
- Para recibir entregas de SFTP de Looker, asegúrate de que el administrador de red haya agregado las direcciones IP de Looker a la lista de IP permitidas o a las reglas de tráfico entrante del servidor SFTP.
- Cuando se realiza el envío a un servidor SFTP, solo se admiten caracteres alfanuméricos, guiones bajos (_) y guiones (-) en el nombre de archivo del envío. Looker quitará cualquier carácter que no sea
A-Z,a-z,0-9,_o-de lo que ingreses en el campo Asigna un nombre a tu programa.
Cuando eliges SFTP, Looker te solicita la URL y la información de acceso del servidor:
Dirección: Es la URL o la dirección IP del servidor SFTP al que deseas enviar tus datos. Por ejemplo:
sftp://files.looker.com/Marketing/In/sftp://192.168.0.10/Marketing/In/
Esta URL de ejemplo termina con el carácter
/. Esto indica que el archivo se guardará en una carpeta llamadaIn. Si omites la/final, el archivo se guardará en la carpetaMarketingy se antepondrá "In" al nombre del archivo. Debes tener acceso de escritura a la carpeta en la que deseas crear el archivo.Nombre de usuario y Contraseña: Son las credenciales de acceso para el servidor SFTP.
Algoritmo de intercambio de claves preferido: Este campo es opcional. Para configurarlo, elige el algoritmo de intercambio de claves SSH preferido para establecer la conexión. Las opciones compatibles son las siguientes:
ecdh-sha2-nistp521ecdh-sha2-nistp384ecdh-sha2-nistp256diffie-hellman-group-exchange-sha256diffie-hellman-group14-sha256diffie-hellman-group14-sha1
Si la conexión no se establece en un plazo de cinco minutos, elige un algoritmo diferente. Algunos algoritmos tardan mucho tiempo en generar una clave SSH. Esta opción te permite usar un algoritmo que podría tardar menos tiempo. Si eliges uno de los algoritmos, se convertirá en el preferido para establecer la conexión SSH. Si el servidor no admite el algoritmo, se usarán todos los demás algoritmos en los intentos posteriores. Cuando este campo se establece en Predeterminado, se usa el orden original de los algoritmos en la biblioteca de conexiones.
La compatibilidad con SFTP se limita a las credenciales de nombre de usuario y contraseña. No se admiten las credenciales de clave privada SSH.
Los algoritmos de clave de host que admiten las entregas de SFTP de Looker son los siguientes:
ssh-ed25519-cert-v01@openssh.comssh-ed25519ecdsa-sha2-nistp521-cert-v01@openssh.comecdsa-sha2-nistp384-cert-v01@openssh.comecdsa-sha2-nistp256-cert-v01@openssh.comecdsa-sha2-nistp521ecdsa-sha2-nistp384ecdsa-sha2-nistp256ssh-rsa-cert-v01@openssh.comssh-rsa-cert-v00@openssh.comssh-rsarsa-sha2-256rsa-sha2-512
Los algoritmos de encriptación (algoritmos de cifrado) que admiten las entregas de SFTP de Looker son los siguientes:
aes256-ctraes192-ctraes128-ctraes256-gcm@openssh.comaes128-gcm@openssh.com
Los algoritmos de código de autenticación de mensajes que admiten las entregas de SFTP de Looker son los siguientes:
hmac-sha2-512-etm@openssh.comhmac-sha2-256-etm@openssh.comhmac-sha2-512hmac-sha2-256hmac-sha1
Looker sube el archivo al directorio especificado en tu servidor SFTP con la siguiente convención para el nombre de archivo:
<name>_<timestamp>_<token>.<file extension>
<name>es el nombre que proporcionaste en el campo Asigna un nombre a tu programa, después de que Looker quite todos los caracteres que no seanA-Z,a-z,0-9,_o-.<timestamp>es la marca de tiempo en la que se envió el programa, en el formato%Y-%m-%dT%H%M.<token>es un token que consiste en una cadena aleatoria de seis caracteres.<file extension>es la extensión de archivo.
Por ejemplo: Test_Schedule_2019-04-11T1130_HWkvys.csv.
Destinos de servicios integrados
Puedes programar o enviar entregas de paneles a un servicio que esté integrado en Looker, como Slack, Dropbox, Google Drive y otros. Tu administrador de Looker debe habilitar las integraciones. Los administradores de Looker deben otorgar permisos específicos para que los usuarios y los usuarios incorporados envíen y programen datos a integraciones de terceros.
Cuando se selecciona un servicio integrado en el campo Destino del Programador, pueden aparecer varios campos nuevos y solicitarte más información.
En la siguiente lista, se muestran los servicios del Action Hub de Looker a los que puedes enviar el contenido de un panel.
A continuación, se indica cómo usar la lista:
- Las URLs que se muestran en la columna Vínculo al archivo README proporcionan instrucciones para habilitar y configurar el servicio integrado para que funcione con Looker.
- Las URLs que se muestran en la columna Cómo usar esta integración proporcionan instrucciones para enviar datos de Looker al servicio integrado. Algunos de estos artículos también contienen instrucciones de habilitación.
- En Etiquetas de LookML obligatorias, se enumeran las etiquetas obligatorias que se deben usar con el parámetro
tagsen el modelo subyacente del contenido. - El tipo de acción indica qué nivel de datos envía el servicio integrado: campo, consulta o panel. Una acción a nivel del campo envía el valor de una sola celda especificada en una tabla de datos. Una acción a nivel de la consulta envía los resultados de una consulta completa, como todas las filas de una exploración o un diseño. Una acción a nivel del panel envía una imagen de un panel.
- Usa la autenticación de OAuth de Google indica si el servicio integrado usa credenciales de OAuth de Google para la autenticación.
- Usa la transmisión de datos indica si el servicio integrado admite resultados de consultas transmitidos. Los paneles no pueden transmitir datos.
| Servicio integrado | Descripción | Vínculo al archivo README | Cómo usar esta integración | Etiquetas de LookML obligatorias | Usa la autenticación de OAuth de Google (sí/no) | Usa la transmisión de datos (sí/no) |
|---|---|---|---|---|---|---|
| Azure Storage | Envía y almacena un archivo de datos en Azure Storage. | Ver el archivo README en GitHub | Ver artículo de la comunidad | Ninguno | No | No |
| DigitalOcean Spaces | Enviar un archivo de datos al almacenamiento de DigitalOcean y guardarlo allí | Ver el archivo README en GitHub | Ver artículo de la comunidad | Ninguno | No | No |
| Dropbox | Envía y almacena un archivo de datos en Dropbox. | No hay un archivo README disponible | Ver la documentación | Ninguno | Sí | No |
| Google Cloud Storage | Escribir archivos de datos en un bucket de Google Cloud Storage | Ver el archivo README en GitHub | Ver artículo de la comunidad | Ninguno | No | No |
| Google Drive | Envía datos a Google Drive. | No hay un archivo README disponible | Ver la documentación | Ninguno | Sí | No |
| SendGrid | Envía datos y programa los resultados para que se envíen a una dirección de correo electrónico con la API de SendGrid. | Ver el archivo README en GitHub | Ver artículo de la comunidad | Ninguno | No | No |
| Slack | Envía contenido de Looker en mensajes directos, canales públicos y canales privados en Slack con OAuth. Está disponible para implementaciones alojadas en Looker en la versión 6.24 y posteriores con la función Lista de IPs permitidas inhabilitada. | No hay un archivo README disponible | Ver la documentación | Ninguno | Sí | No |
| Adjunto de Slack (token de API) | Enviar datos directamente a un canal de Slack junto con las credenciales del usuario También puedes consultar la documentación de Lookerbot para obtener más información sobre la funcionalidad de Slack. | Ver el archivo README en GitHub | Ver la documentación | Ninguno | No | No |
| Teams: Webhook entrante | Envía datos a Microsoft Teams con un webhook entrante. | Ver el archivo README en GitHub | Consulta el archivo README | Ninguno | No | No |
Formato
El campo Formato contiene un menú desplegable con los formatos disponibles:
- Archivo ZIP de CSV: Son los datos sin formato del panel que se entregan como una colección de archivos de valores separados por comas (CSV) en un directorio comprimido. En el caso de las entregas por correo electrónico, el archivo ZIP se envía como un archivo adjunto.
PDF: Una imagen del panel como un solo archivo PDF. El diseño predeterminado muestra las tarjetas tal como están organizadas en el panel, pero hay otras opciones de diseño y tamaño disponibles en Opciones avanzadas. En el caso de los envíos por correo electrónico, el archivo se envía como un archivo adjunto.
Visualización de PNG: Es una imagen del panel como un solo archivo PNG. El diseño predeterminado muestra las tarjetas tal como están organizadas en el panel, pero hay otras opciones de diseño disponibles en Opciones avanzadas. En el caso de las entregas por correo electrónico, la imagen aparece intercalada en el cuerpo del correo electrónico.
Descargar pestañas
Si tu panel tiene pestañas, puedes seleccionar una opción del menú Descargar pestañas cuando descargues un panel como PDF. Puedes enviar todo el panel, la pestaña que está abierta o una selección personalizada de pestañas. Si eliges Personalizado, puedes especificar las pestañas que deseas descargar en el campo Seleccionar pestañas. Si se seleccionan varias pestañas (por ejemplo, si se selecciona Todo el panel o si se especifican una o más pestañas para la opción Personalizado), todas las pestañas aparecerán en la misma página. El contenido de cada pestaña se organizará bajo un encabezado de contenido con el nombre de la pestaña.
Opciones avanzadas
La pestaña Opciones avanzadas proporciona personalización adicional para tu publicación. Las opciones disponibles dependen del destino y el formato seleccionados para la publicación.
Mensaje personalizado
Esta opción solo está disponible para el destino de correo electrónico.
Ingresa un mensaje que quieras incluir en el cuerpo de los correos electrónicos para los destinatarios. Looker limita la cantidad de caracteres de un mensaje personalizado a 1,500.
Ejecutar programación como destinatario
Esta opción solo está disponible para el destino de correo electrónico.
La opción Ejecutar programa como destinatario permite que los usuarios especifiquen una lista de destinatarios que recibirán la publicación de contenido como si cada uno de ellos hubiera ejecutado la consulta, según los permisos de cada persona. Esto significa que los filtros de acceso y los atributos de usuario de cada usuario se aplicarán a los datos que se incluyan en cada correo electrónico.
Si un usuario es administrador de Looker, la opción Ejecutar programa como destinatario le permite especificar una lista de usuarios que recibirán la entrega de contenido como si cada uno de ellos ejecutara la consulta, según los permisos de cada persona. Los usuarios que no son administradores también pueden ingresar su propia dirección de correo electrónico para recibir una entrega como si hubieran consultado el contenido, según sus permisos. Esto significa que los filtros de acceso y los atributos de usuario de cada usuario se aplicarán a los datos que se incluyan en cada correo electrónico.
En el siguiente ejemplo, un administrador de Looker necesita programar un envío de datos que enumere los recuentos de usuarios por estado.

El usuario A tiene un filtro de acceso establecido como users.state = 'California'. Cuando se selecciona Ejecutar programación como destinatario, la consulta programada aplicará el filtro de acceso users.state = 'California' y enviará los resultados filtrados al usuario A. Los resultados filtrados solo incluirán datos sobre California.

En la pestaña Opciones avanzadas, selecciona la casilla de verificación Ejecutar programa como destinatario y, luego, agrega las direcciones de correo electrónico de tus destinatarios en el campo de texto Direcciones de correo electrónico de la pestaña Configuración. Esta opción tiene en cuenta los permisos del usuario que crea el programa, así como los tipos de direcciones de correo electrónico que se agregan al campo Direcciones de correo electrónico. En algunos casos, la opción Ejecutar programación como destinatario no está disponible:
- Cuando un usuario agrega el correo electrónico de un usuario inhabilitado
Cuando un usuario agrega un correo electrónico que no pertenece a un usuario de Looker, como se indica en el recuento Externo junto a la lista de direcciones de correo electrónico.

En estas situaciones, independientemente de si seleccionaste una opción antes o después de ingresar la dirección de correo electrónico externa, la opción Ejecutar programación como destinatario permanecerá habilitada, pero la programación no se podrá guardar hasta que anules la selección de Ejecutar programación como destinatario o quites la dirección de correo electrónico externa de la lista de destinatarios.
En el caso especial en el que un usuario aparece como destinatario en un programa que tiene habilitada la opción Ejecutar programa como destinatario y, luego, se inhabilita la cuenta de ese usuario, el programa no se entregará al usuario inhabilitado a partir de la próxima vez que se ejecute. Si se borra la cuenta de ese usuario, no se enviará la programación completa a ningún destinatario. Un administrador o usuario de Looker con el permiso see_schedules podrá diagnosticar este error en la página Historial del programador del panel Administrador.
Incluir vínculos
Esta opción solo está disponible para el destino de correo electrónico.
Si el administrador de Looker estableció la política de datos enviados por correo electrónico de tu instancia de Looker en Enviar vínculos y datos, la ventana Programar entrega o Enviar muestra la opción Incluir vínculos. Selecciona esta opción para incluir en los correos electrónicos de entrega de datos un vínculo Ver panel completo que dirija al panel en Looker. Los vínculos del panel no incluyen ningún parámetro hide_filter.
Los destinatarios deben acceder a Looker y tener permisos para acceder a los modelos en los que se basa el panel enviado para ver ese contenido en Looker. Si quieres quitar este vínculo de tus correos electrónicos de entrega de datos, desmarca la casilla de verificación Incluir vínculos.
Incluir vínculo personalizado
Esta opción solo está disponible para el destino de correo electrónico y solo para los paneles incorporados. Se muestra cuando se selecciona la opción Incluir vínculos.
La opción Incluir vínculo personalizado te permite configurar una URL personalizada a la que se conectará el vínculo Ver panel completo, en lugar de vincularlo al panel en Looker. También puedes cambiar el texto del vínculo Ver panel completo (opcional).
Para usar esta opción, un administrador de Looker o un usuario con el permiso schedule_look_emails o create_alerts primero debe especificar los dominios permitidos para el vínculo personalizado y seleccionar el formato de la URL del vínculo personalizado en la página Incorporar del menú Administrador.
Dominio
Selecciona el dominio de la URL de la lista de dominios configurados en la lista de entidades permitidas. Por ejemplo, app.customer.com
Ruta
La opción Ruta solo se muestra si se selecciona URL definida por el usuario en el campo Seleccionar ruta de contenido de la página Incorporar del menú Administrador.
Ingresa una ruta de acceso personalizada para la URL del vínculo aquí. Por ejemplo, si deseas que tu vínculo personalizado dirija a la URL app.customer.com/my_embed_app, ingresa la ruta de acceso /my_embed_app aquí.
Etiqueta de URL
Usa este campo para ingresar un nuevo texto de vínculo, que reemplazará el texto Ver panel completo en las entregas por correo electrónico. Este campo mostrará cualquier texto que se ingrese en el campo Etiqueta de la URL de la página Incorporar del menú Administrador de forma predeterminada y se puede cambiar en este campo.
Resultados
Este campo solo está disponible para los formatos de archivo ZIP de CSV de los envíos de paneles. Contiene dos opciones: Con las opciones de visualización aplicadas o Como se muestra en la tabla de datos. Puedes elegir una de las dos opciones.
Elige la opción Con opciones de visualización aplicadas para aplicar algunos de los parámetros de configuración de visualización de las tarjetas del panel a la entrega del panel. Esto hace que los archivos de tu publicación se muestren de forma similar a los gráficos de tabla. Cualquiera de los siguientes parámetros de configuración de los menús Gráfico, Serie y Formato que se configuren para una visualización se aplicarán a la entrega de datos:
- Mostrar números de fila
- Ocultar totales
- Ocultar totales de filas
- Limitar las filas que se muestran a un máximo de 500 filas mostradas u ocultas
- Mostrar nombre completo del campo
- Etiquetas personalizadas para cada columna
Elige la opción Como se muestran en la tabla de datos para entregar los datos tal como aparecen en la tabla de datos de la ventana Explorar desde aquí de cada tarjeta del panel.
Valores
Este campo solo está disponible para los formatos de archivo ZIP de CSV de los envíos de paneles. Contiene dos opciones: Con formato o Sin formato. Puedes elegir una de las dos opciones.
- Selecciona Con formato si quieres que los datos se muestren de forma similar a como aparecen en la experiencia de Exploración en Looker, aunque algunas funciones (como la vinculación) no son compatibles con todos los tipos de archivos.
- Selecciona Sin formato si no quieres aplicar ningún formato especial de tus resultados de consulta, como redondear los números largos o agregar caracteres especiales, que los desarrolladores de Looker podrían haber establecido. Por lo general, esto es lo que se prefiere cuando los datos se ingresan a otra herramienta para su procesamiento.
Expandir las tablas para mostrar todas las filas
Esta opción solo está disponible para los formatos PDF de las entregas de paneles.
Selecciona la casilla Expandir las tablas para mostrar todas las filas para mostrar todas las filas de cualquier visualización de tabla en el panel, en lugar de solo las filas que se muestran en las miniaturas de las tarjetas del panel.
A partir de Looker 26.4, los resultados de la consulta para cada gráfico de tabla en un PDF de panel pueden mostrar hasta 50,000 filas, con un límite total máximo de 200,000 celdas por panel, si tu administrador aumentó el parámetro de configuración del límite de filas. Si el total de celdas combinadas de los gráficos de tabla de un panel supera las 200,000 celdas, es posible que se recorten los resultados de los gráficos de tabla. Si se alcanza este máximo, los usuarios verán una advertencia que también se mostrará en la parte inferior del PDF renderizado.
Si se selecciona la opción Expandir las tablas para mostrar todas las filas, es posible que las tarjetas del panel que contienen visualizaciones de tablas se vean un poco diferentes en los archivos PDF entregados que en Looker. Es posible que notes las siguientes diferencias en el PDF:
- Se quitarán las personalizaciones de los colores de fondo y los tamaños de fuente de los encabezados de columna y las filas de subtotales.
- Las tablas aparecen en el tema blanco.
- El ícono de ordenamiento no aparece en las tablas dinámicas que no se ordenaron de forma manual.
- Las tablas con la opción Ajustar el tamaño de las columnas habilitada se extienden a todo el ancho de la tarjeta.
- Las tablas con la opción Agrupación de filas habilitada aparecen como datos planos, y la columna de agrupación se expande para mostrar todas las columnas.
Además, en el caso de las tablas con más de 20,000 celdas, es posible que se noten las siguientes diferencias en el PDF:
- Ya no aparecen las opciones de Formato condicional que no sean Color de fondo.
- Ya no aparecen las visualizaciones de celdas en las columnas numéricas.
Si no ves la opción Expandir tablas para mostrar todas las filas cuando elegiste PDF en el campo Formato, comunícate con tu administrador de Looker para instalar la versión adecuada del renderizador de Chromium para tu instancia de Looker.
Organizar los mosaicos del panel en una sola columna
Esta opción solo está disponible para los formatos de visualización en PDF y PNG de los envíos de paneles. Cuando se selecciona Slack como destino de entrega, solo se admiten archivos PDF.
Selecciona la casilla Organizar los mosaicos del panel en una sola columna para dar formato a tu visualización en PDF o PNG en un diseño de una sola columna. Este diseño muestra los mosaicos del panel en una sola columna vertical. Deja la casilla sin marcar para mostrar las tarjetas tal como están organizadas en el panel.
Tamaño del papel
Esta opción solo está disponible para los formatos PDF de las entregas de paneles.
Puedes especificar el tamaño y la orientación óptimos de los archivos PDF del panel seleccionando una opción en el menú desplegable Tamaño del papel. Es posible que debas cambiar el tamaño de las visualizaciones grandes o los grupos de tarjetas de panel superpuestas para que quepan de forma ordenada en una página de PDF. Si no ves la opción Tamaño del papel, comunícate con tu administrador de Looker para que instale la versión más reciente del renderizador de Chromium para tu instancia de Looker.
Resolución de la tabla
Esta opción solo está disponible para el formato de visualización PNG y cuando la casilla Organizar tarjetas del panel en una sola columna está marcada.
Puedes personalizar el ancho de tu visualización con el menú desplegable Resolución de la tabla. Las opciones de ancho son las siguientes:
- Normal: 800 píxeles
- Ancho: 1,680 píxeles
En el caso de las entregas por correo electrónico, si eliges Ancho y el ancho de la visualización supera el límite establecido por tu cliente de correo electrónico, es posible que los destinatarios de la entrega por correo electrónico deban desplazarse de forma horizontal para ver toda la visualización.
Zona horaria de la entrega
De forma predeterminada, Looker usa la zona horaria asociada con tu cuenta para determinar cuándo enviar la entrega de datos. Si no tienes una zona horaria asociada a tu cuenta, Looker usa el parámetro de configuración Zona horaria de la aplicación.
Si quieres especificar una zona horaria diferente, selecciónala en el menú desplegable. La zona horaria que selecciones no afectará los datos de tu vista o panel, solo el momento de la entrega.
Filtros
La pestaña Filtros de la ventana Programar envío o Enviar muestra los filtros aplicados al panel, así como sus valores. En esta pestaña, puedes editar los valores de los filtros existentes que se aplican al panel, y los valores nuevos se aplicarán al envío. El panel en sí no se verá afectado.
No puedes agregar filtros a tu programa en la pestaña Filtros, solo puedes ver y editar los valores de los filtros existentes del panel.
Por ejemplo, puedes enviar a los equipos regionales los resultados filtrados por los estados de su interés.

Si un filtro del panel requiere un valor de filtro, debes ingresar un valor en la pestaña Filtros para crear o guardar cualquier edición en la entrega.
Cuando cambian los filtros del panel
A veces, los filtros del panel cambian después de que se crea un programa. En la siguiente tabla, se explica cómo esto afecta los filtros aplicados a los envíos programados.
| Acción | Efecto en el filtro de programación |
|---|---|
| Se crea una programación con un filtro. Más adelante, se cambia el valor del filtro en el panel. | No tiene efecto en el valor del filtro de programación. Se mantiene el valor establecido en la pestaña Filtros, incluso si ese valor es es cualquier valor. |
| Se crea una programación con un filtro. Más adelante, se cambia el nombre del filtro en el panel. | Se quita el filtro de los datos entregados. |
| Se crea una programación con un filtro. Más adelante, se borra el filtro en el panel. | El filtro se quita de los datos entregados. |
| Se crea una programación. Más adelante, se agrega un filtro nuevo (no obligatorio o obligatorio) al panel. | El filtro se aplica a los datos entregados con el valor de filtro establecido en la pestaña Filtros. Si no se establece ningún valor en la pestaña Filtros, el valor se interpreta como es cualquier valor, lo que, en esencia, quita el filtro. |
Usa filtros de atributos de usuario
Si tu administrador de Looker configuró valores específicos del usuario, llamados atributos de usuario, y tienes privilegios de edición para un panel, puedes crear un filtro de panel que use la opción de filtro coincide con un atributo de usuario. Un filtro de este tipo personaliza automáticamente el valor del filtro para cada visualizador del panel. Con este tipo de filtro, puedes entregar resultados personalizados a los destinatarios de cada entrega. Para obtener más información sobre los atributos de usuario, visita la página de documentación Atributos de usuario.
Prueba un programa
Si configuras el campo Recurrencia con cualquier valor que no sea Enviar ahora, aparecerá el botón Probar ahora en la parte inferior de la ventana Programar entrega o Enviar.
Selecciona el botón Probar ahora para enviarte solo a ti una entrega de prueba única de la programación. Aparecerá una marca de verificación verde para confirmar que se envió una prueba. Si el botón Probar ahora no está disponible, puedes establecer el campo Recurrencia en Enviar ahora para enviar una entrega de prueba única.
La opción Probar ahora no tiene en cuenta algunos parámetros de configuración de las Opciones avanzadas, pero sí respeta los filtros seleccionados.
Cómo guardar una programación o enviar un mensaje ahora
Si configuras el campo Recurrencia como Enviar ahora, selecciona el botón Enviar ahora en la parte inferior de la ventana para realizar una entrega única al destino indicado.
Si configuras el campo Recurrencia con cualquier valor que no sea Enviar ahora, selecciona el botón Guardar para guardar la programación y cerrar la ventana.
Selecciona el botón Cancelar para salir de la ventana sin guardar ni enviar el programa.
Los programas guardados para un panel aparecen en su ventana de programas existentes. Las programaciones guardadas para todo el contenido aparecen en la página Programaciones de tu perfil de usuario.
Cómo editar una programación
Solo puedes editar las programaciones que creaste. Para editar una programación, sigue estos pasos:
- Selecciona el menú de tres puntos Acciones del panel en la parte superior derecha del panel.
- Selecciona Programar envío en el menú desplegable.
- En la ventana de programaciones existentes, selecciona el menú de tres puntos que se aplica a la programación que quieres editar.
- Elige Editar en el menú desplegable.
- Aparecerá la ventana Programar envío o Enviar para esa programación. Realiza los cambios en esta ventana.
- Selecciona Guardar cuando termines de editar o Cancelar para cancelar los cambios.
Cómo duplicar un programa
Te recomendamos duplicar un programa y, luego, editarlo. Para duplicar un programa, sigue estos pasos:
- Selecciona el menú de tres puntos Acciones del panel en la parte superior derecha del panel.
- Selecciona Programar envío en el menú desplegable.
- En la ventana de programaciones existentes, selecciona el menú de tres puntos que se aplica a la programación que quieres editar.
- Elige Duplicar en el menú desplegable.
- Aparecerá la ventana Programar envío o Enviar para el programa duplicado. Se agrega "Copia" al nombre de la programación.
- Realiza los cambios correspondientes.
- Selecciona Guardar cuando termines de editar o Cancelar para cancelar los cambios y borrar el programa duplicado.
La programación original no cambia cuando creas un duplicado.
Los filtros de una programación duplicada se establecerán con los mismos valores que se encuentran en la pestaña Filtros de la programación original, aunque puedes editarlos. Si algún filtro cambió desde que se creó el programa original, se verá afectado como se muestra en la sección Cuando cambian los filtros del panel. Si, más adelante, se agregó un filtro obligatorio al panel en el que se basa el programa original, debes seleccionar un valor para ese filtro antes de guardar el programa duplicado.
Borra una programación
Solo puedes borrar las programaciones que creaste. Para borrar un programa, sigue estos pasos:
- Selecciona el menú de tres puntos en la parte superior derecha del panel.
- Selecciona Programar envío en el menú desplegable.
- En la ventana de programaciones existentes, selecciona el menú de tres puntos que se aplica a la programación que quieres editar.
- Elige Borrar en el menú desplegable.
- Aparecerá una ventana nueva. Selecciona Borrar para borrar el programa o Cancelar para conservarlo.
También puedes borrar una programación en la página Programaciones de tu perfil de usuario.
Efectos de borrar un panel que tiene una programación
Si borras un panel, también se borrarán todos los programas afiliados a él. El propietario del programa verá de inmediato que se borró el nombre del panel para el programa o la página de usuario Programas que creaste. Después de la próxima vez que se ejecute la consulta programada, su estado se mostrará como Inhabilitada.
Desafíos de la programación
En ocasiones, es posible que un envío de correo electrónico programado no llegue a uno o más de sus destinatarios. Esto podría suceder si el modelo subyacente tiene un error, si el destinatario no tiene acceso a los datos o si hay problemas de renderización o errores de página.
Ten en cuenta las siguientes limitaciones de la publicación de contenido:
- Si tu empresa configuró sus propios parámetros de correo electrónico en la sección Administrador de Looker, tus administradores de Looker deberán asegurarse de que los parámetros de configuración sean correctos y de que tu proveedor de correo electrónico funcione correctamente. Un servidor SMTP externo puede tener sus propios límites diarios o por mensaje para los destinatarios.
- Según el parámetro de configuración Límite, la entrega de datos se limitará a 5,000 filas o a un tamaño de archivo máximo de 15 MB para correos electrónicos con archivos adjuntos y 20 MB para correos electrónicos con contenido intercalado. No se enviarán los correos electrónicos que tengan más filas o datos que estos límites.
- Aunque Looker no codifica un límite para la cantidad de destinatarios que puedes especificar en un envío por correo electrónico, si configuras el envío para que se "ejecute como destinatario", el envío activa una consulta independiente para cada persona. Esta carga puede afectar gravemente el rendimiento de la base de datos y no se recomienda para listas de destinatarios grandes. Te recomendamos que uses grupos o alias de correo electrónico siempre que sea posible.
- Si un correo electrónico no se envía en el momento previsto, pero llega con retraso, es probable que se deba a que compite con otras tareas de Looker. Estas tareas pueden incluir otros correos electrónicos programados, muchas personas que exploran datos al mismo tiempo o tablas derivadas persistentes que se están creando. Si esto sucede, consulta con tus administradores de Looker sobre las tareas que compiten.
- Si un correo electrónico específico sigue desapareciendo de tu lista de distribución, es probable que se deba a que un usuario canceló la suscripción a ese correo electrónico programado. Esto puede ser un desafío particular si usas un alias de correo electrónico de grupo para enviar mensajes a varias personas, ya que cualquier destinatario individual puede cancelar la suscripción de todo ese alias de correo electrónico. Para obtener más información sobre las cancelaciones de suscripciones, consulta esta publicación de Comunidad de Looker sobre la supervisión de los eventos de cancelación de suscripción del programador.
Si falla el envío a un servidor SFTP, considera las siguientes posibilidades:
Cuando Looker intenta realizar un envío a un servidor SFTP, es posible que el envío se marque como completado en el panel de programación y en los registros, incluso si no llega debido a problemas de configuración de red, como una lista de IPs permitidas incorrecta en el servidor de destino o un puerto de salida cerrado en la instancia de Looker. Debido a que el historial de programación puede mostrar un estado
Successa pesar de estos errores, siempre verifica los registros del servidor SFTP de destino si sospechas que falta una entrega.Looker almacena las huellas digitales de SFTP de tu servidor SFTP. Si encuentras errores con la publicación por SFTP, es posible que las huellas digitales de SFTP no sean válidas. En este caso, comunícate con tu administrador de Looker.
El error
Net::SSH::Exception. message: could not settle on host_key algorithmse produce por una incompatibilidad entre los algoritmos de clave de host que ofrecen las versiones anteriores de Looker (anteriores a Looker 26.2) y los algoritmos de seguridad modernos que aplica estrictamente el servidor SFTP de destino (como Red Hat 9 o Azure Blob Storage SFTP). Si recibes este error, puedes resolverlo actualizando Looker a la versión 26.2 o una posterior para que admita algoritmos SHA-2 modernos (comoecdsa-sha2-nistp256,rsa-sha2-256yrsa-sha2-512). Como alternativa, configura el servidor SFTP de destino para que permita al menos una clave de host o un algoritmo de encriptación que admita tu versión actual de Looker.El error
OpenSSL::Cipher::CipherError. Error: authentication tag already generated by cipherpuede ocurrir cuando se entregan datos con SFTP después de que Looker se actualizó a la versión 26.2.14 o posterior, o cuando tu instancia se conecta a servicios de host como Azure Blob Storage SFTP o a través de un proxy. Este error se debe a un problema conocido de JRuby durante la negociación de cifrado. Para resolver este error, restringe los algoritmos de encriptación (algoritmos de cifrado) que se permiten en el servidor SFTP de destino aaes256-ctr. Por ejemplo, edita el archivosshd_configdel servidor SFTP para agregar o restringir la directivaCiphers:Ciphers aes256-ctr.Si recibes el error
Java::JavaLang::NullPointerExceptionscuando entregas datos a un servidor SFTP, es posible que se deba a un error en JRuby que impide el uso de algoritmos de curva elíptica (EC) o claves de host para conexiones SSH de Looker a destinos de SFTP. Para evitar problemas con el envío de datos a destinos de SFTP, no uses algoritmos de EC en los archivos~/.ssh/configo/etc/ssh_configni almacenes claves de host de EC en~/.sshen tu host de Looker.El error
Net::SFTP::StatusException (2, 'no such file')se produce si Looker no puede construir correctamente la ruta de destino en el servidor SFTP. Entre las causas comunes, se incluyen que el campo Dirección use una ruta de acceso relativa en lugar de una ruta de acceso absoluta, que al campo Dirección le falte una barra diagonal final (/) o que el nombre de la vista, el panel o la programación contenga espacios o caracteres especiales (como/) que causen fallas en la construcción de la ruta de acceso. Para resolver este error, sigue estos pasos:- Usa rutas de acceso absolutas: Accede al servidor SFTP, ejecuta
pwdpara recuperar la ruta de acceso absoluta completa y, luego, ingresa este valor en el campo Dirección de tu programa, asegurándote de que termine con una barra diagonal (/). - Quita los caracteres especiales: Quita las barras diagonales (
/) de los nombres de las vistas, los paneles y los programas. - Usa nombres compatibles con máquinas: Cambia el nombre del programa para usar guiones bajos en lugar
de espacios (por ejemplo,
Report_Name).
- Usa rutas de acceso absolutas: Accede al servidor SFTP, ejecuta
El error
Net::SSH::Exception. Error: could not settle on kex algorithmse produce cuando Looker y el servidor SFTP remoto no pueden acordar un algoritmo de intercambio de claves (KEX) compatible con ambos, por lo general, porque se usan algoritmos obsoletos en un lado. Para resolver este error, revisa los algoritmos de intercambio de claves que admite tu servidor SFTP y asegúrate de que se alineen con los algoritmos de KEX compatibles con Looker (comoecdh-sha2-nistp256,ecdh-sha2-nistp384oecdh-sha2-nistp521).Si la entrega programada de SFTP falla con el error
Net::SSH::Exception: could not settle on encryption_client algorithm, significa que tu servidor SFTP y Looker no pudieron acordar un algoritmo de encriptación compartido. Looker quitó la compatibilidad con algoritmos de cifrado más antiguos y menos seguros, como CBC (por ejemplo,aes256-cbcy3des-cbc). Para resolver este error, proporciona este mensaje de error al administrador del servidor SFTP y pídele que actualice el archivosshd_configdel servidor para habilitar la compatibilidad con al menos uno de los algoritmos de encriptación y de intercambio de claves que son compatibles con Looker.
Consideraciones de entrega para administradores
Los administradores de Looker pueden ver, editar, reasignar y borrar los programas de cualquier usuario. Además, los administradores de Looker deben tener en cuenta algunos aspectos cuando configuran el envío de datos para su instancia de Looker y otorgan permisos a los usuarios para enviar o programar envíos de datos. Para obtener más información, consulta las siguientes páginas de documentación:
- Configuración del administrador: Programas
- Configuración de administrador: Historial de programación
- Administra las funciones de los usuarios empresariales