Mengelola notebook

Dokumen ini menjelaskan cara mengelola notebook Colab Enterprise di BigQuery, termasuk cara melihat, membandingkan, memulihkan, dan menghapus notebook.

Dokumen ini juga menjelaskan cara melihat dan mengelola metadata notebook di Knowledge Catalog.

Notebook adalah aset kode BigQuery Studio yang didukung oleh Dataform.

Sebelum memulai

  1. Buat notebook.
  2. Untuk mengelola metadata notebook di Knowledge Catalog, pastikan Dataplex API diaktifkan di project Google Cloud Anda.

Izin yang diperlukan

Untuk membagikan notebook, Anda memerlukan peran Identity and Access Management (IAM) berikut:

Untuk menyimpan dan menghapus notebook, Anda memerlukan peran IAM berikut:

Untuk menggunakan revisi notebook, Anda memerlukan peran IAM berikut:

Untuk mengetahui informasi selengkapnya tentang IAM BigQuery, lihat Kontrol akses dengan IAM.

Untuk mengelola metadata notebook di Knowledge Catalog, pastikan Anda memiliki peran Knowledge Catalog yang diperlukan.

Memberikan akses ke notebook

Untuk memberi pengguna lain akses ke notebook, tambahkan pengguna tersebut ke peran IAM yang sesuai.

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

    Jika Anda tidak melihat panel kiri, klik Luaskan panel kiri untuk membuka panel.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Temukan notebook yang ingin Anda beri akses.

  5. Klik Open actions di samping notebook, lalu klik Share.

  6. Di panel Share permissions, klik Add user/group.

  7. Di kolom New principals, masukkan akun utama.

  8. Di daftar Role, pilih salah satu peran berikut:

    • Code Owner: Dapat melakukan tindakan apa pun pada notebook, termasuk menghapus atau membagikannya.
    • Code Editor: Dapat mengedit notebook.
    • Code Viewer: Dapat melihat notebook.
  9. Opsional: Untuk melihat daftar lengkap peran dan setelan berbagi lanjutan, klik Berbagi lanjutan.

  10. Klik Simpan.

  11. Untuk kembali ke halaman informasi notebook, klik Close.

Membagikan notebook

Untuk membagikan notebook kepada pengguna lain, Anda dapat membuat dan membagikan link ke notebook. Agar pengguna lain dapat melihat notebook yang Anda bagikan, Anda harus memberikan akses ke notebook tersebut terlebih dahulu.

Untuk menjalankan notebook, pengguna harus memiliki akses ke data yang diakses notebook. Untuk mengetahui informasi selengkapnya, lihat Memberikan akses ke set data.

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

    Jika Anda tidak melihat panel kiri, klik Luaskan panel kiri untuk membuka panel.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Cari notebook yang ingin Anda bagikan. Anda dapat menggunakan fitur penelusuran atau filter untuk menemukan notebook.

  5. Klik View actions di samping notebook, lalu klik Share > Copy link.

  6. Bagikan link kepada pengguna lain.

Menonaktifkan penyimpanan output notebook

Anda dapat mencegah output notebook tersimpan dibagikan kepada pengguna lain yang memiliki akses ke file notebook dengan menonaktifkan penyimpanan output notebook.

Jika Anda menonaktifkan penyimpanan output untuk notebook yang dipilih, BigQuery akan menghapus semua output yang disimpan dalam file notebook dan tidak akan menyimpan output dari operasi berikutnya.

Namun, pengguna yang memiliki akses ke notebook tetap dapat melihat outputnya dengan cara berikut:

  • Jalankan notebook untuk melihat outputnya saat ini. Output ini tidak disimpan.
  • Melihat versi arsip notebook dan output-nya di histori revisi.

Untuk menonaktifkan penyimpanan output untuk notebook yang dipilih, ikuti langkah-langkah berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

    Jika Anda tidak melihat panel kiri, klik Luaskan panel kiri untuk membuka panel.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Klik notebook yang ingin Anda nonaktifkan penyimpanan output-nya.

  5. Untuk meluaskan panel menu, klik keyboard_arrow_down Aktifkan/nonaktifkan visibilitas header.

  6. Klik Edit > Notebook settings.

  7. Di jendela Notebook settings, pilih Omit code cell output when saving this notebook.

  8. Klik Simpan.

  9. Klik Muat ulang.

Selesaikan konflik

Jika Anda dan pengguna lain membuat perubahan yang bertentangan dalam notebook, layanan akan memunculkan error Automatic saving failed. This file was updated remotely or in another tab. dan memberikan link Show diff. Untuk menyelesaikan konflik, ikuti langkah-langkah berikut:

  1. Klik link Show diff. Dialog Review remote changes akan terbuka.
  2. Opsional: Untuk membandingkan kode sumber notebook, centang kotak Sumber mentah.
  3. Opsional: Untuk membandingkan versi secara inline, bukan di panel terpisah, centang kotak Inline diff.
  4. Tinjau perubahan dan tentukan mana yang akan dipertahankan, lalu revisi input Anda jika perlu.
  5. Klik Simpan perubahan.

Lihat semua notebook

Untuk melihat daftar semua notebook di project Anda, lakukan hal berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

    Jika Anda tidak melihat panel kiri, klik Luaskan panel kiri untuk membuka panel.

  3. Di panel Explorer, klik View actions di samping Notebooks, lalu lakukan salah satu tindakan berikut:

  • Untuk membuka daftar di tab saat ini, klik Tampilkan semua.
  • Untuk membuka daftar di tab baru, klik Tampilkan semua di > Tab baru.
  • Untuk membuka daftar di tab terpisah, klik Tampilkan semua di > Tab terpisah.

Melihat metadata notebook

Untuk melihat metadata notebook, ikuti langkah-langkah berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Klik nama notebook yang ingin Anda lihat metadatanya.

  5. Lihat detail ringkasan untuk mengetahui informasi tentang notebook, seperti region yang digunakan untuk data dan tanggal notebook terakhir diubah.

Menggunakan versi notebook

Anda dapat memilih untuk membuat notebook di dalam atau di luar repositori. Pembuatan versi notebook ditangani secara berbeda berdasarkan lokasi notebook.

Pembuatan versi notebook di repositori

Repositori adalah repositori Git yang berada di BigQuery atau di penyedia pihak ketiga. Anda dapat menggunakan ruang kerja di repositori untuk melakukan kontrol versi pada notebook. Untuk mengetahui informasi selengkapnya, lihat Menggunakan kontrol versi dengan file.

Pembuatan versi notebook di luar repositori

Gunakan bagian berikut untuk mempelajari cara melihat, membandingkan, dan memulihkan versi notebook.

Melihat versi notebook

Untuk melihat versi notebook, ikuti langkah-langkah berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks. Klik nama notebook yang ingin Anda lihat histori versinya.

  4. Untuk melihat daftar histori versi notebook dalam urutan menurun berdasarkan tanggal, klik Version history.

Membandingkan versi notebook

Untuk membandingkan versi notebook, ikuti langkah-langkah berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Klik nama notebook yang ingin Anda bandingkan informasi versinya.

  5. Klik Histori versi.

  6. Klik Lihat tindakan di samping versi notebook, lalu klik Bandingkan. Panel perbandingan akan terbuka, yang membandingkan versi notebook yang Anda pilih dengan versi notebook saat ini.

  7. Opsional: Untuk membandingkan versi sebagai bagian dari teks, bukan di panel terpisah, klik Bandingkan, lalu klik Inline.

  8. Opsional: Untuk membandingkan kode sumber versi, klik Bandingkan, lalu klik Tampilkan sumber mentah.

  9. Opsional: Untuk menyembunyikan output perintah di notebook, klik Bandingkan, lalu batalkan pilihan Tampilkan output.

Memulihkan versi notebook

Memulihkan versi notebook dari panel perbandingan memungkinkan Anda membandingkan versi notebook saat ini dan sebelumnya sebelum memilih untuk memulihkan versi sebelumnya. Memulihkan notebook akan membuat versi baru dari notebook, bukan menimpa versi saat ini. Tidak ada histori versi yang hilang.

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Klik nama notebook yang ingin Anda pulihkan ke versi sebelumnya.

  5. Klik Histori versi.

  6. Klik Lihat tindakan di samping versi, lalu klik Bandingkan. Panel perbandingan akan terbuka, yang membandingkan versi notebook yang Anda pilih dengan versi notebook terbaru.

  7. Jika Anda ingin memulihkan versi notebook sebelumnya setelah perbandingan, klik Pulihkan.

  8. Klik Konfirmasi.

Mengganti nama notebook

Untuk mengganti nama notebook, ikuti langkah-langkah berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Klik notebook yang ingin Anda ganti namanya.

  5. Klik keyboard_arrow_down Aktifkan/nonaktifkan visibilitas header untuk meluaskan panel menu.

  6. Klik File > Ganti nama.

  7. Di dialog Rename notebook, ketik nama untuk notebook, lalu klik Rename.

Mendownload notebook

Untuk mendownload notebook, ikuti langkah-langkah berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Klik nama notebook yang ingin Anda download. Anda dapat menggunakan fitur penelusuran atau filter untuk menemukan notebook.

  5. Luaskan panel menu dan buka menu File:

    Panel menu notebook

  6. Pilih Download, lalu pilih jenis file yang ingin Anda gunakan untuk mendownload file.

Menghapus notebook

Untuk menghapus notebook, ikuti langkah-langkah berikut:

  1. Di konsol Google Cloud , buka halaman BigQuery.

    Buka BigQuery

  2. Di panel kiri, klik Explorer:

    Tombol yang ditandai untuk panel Explorer.

  3. Di panel Explorer, luaskan project Anda dan klik Notebooks.

  4. Cari notebook yang ingin Anda hapus.

  5. Klik Lihat tindakan di samping notebook, lalu klik Hapus.

  6. Untuk mengonfirmasi penghapusan, ketik delete pada dialog.

  7. Klik Hapus.

Mengelola metadata di Knowledge Catalog

Knowledge Catalog memungkinkan Anda menyimpan dan mengelola metadata untuk notebook. Notebook tersedia di Knowledge Catalog secara default, tanpa konfigurasi tambahan.

Anda dapat menggunakan Knowledge Catalog untuk mengelola notebook di semua lokasi BigQuery. Pengelolaan notebook di Knowledge Catalog tunduk pada kuota dan batas Knowledge Catalog serta harga Knowledge Catalog.

Knowledge Catalog otomatis mengambil metadata berikut dari notebook:

  • Nama aset data
  • Induk aset data
  • Lokasi aset data
  • Jenis aset data
  • Project Google Cloud yang sesuai

Knowledge Catalog mencatat notebook sebagai entri dengan nilai entri berikut:

Grup entri sistem
Grup entri sistem untuk notebook adalah @dataform. Untuk melihat detail entri notebook di Knowledge Catalog, Anda perlu melihat grup entri sistem dataform. Untuk mengetahui petunjuk tentang cara melihat daftar semua entri dalam grup entri, lihat Melihat detail grup entri dalam dokumentasi Knowledge Catalog.
Jenis entri sistem
Jenis entri sistem untuk notebook adalah dataform-code-asset. Untuk melihat detail notebook, Anda perlu melihat jenis entri sistem dataform-code-asset, memfilter hasil dengan filter berbasis aspek, dan menetapkan kolom type di dalam aspek dataform-code-asset ke NOTEBOOK. Kemudian, pilih entri notebook yang dipilih. Untuk mengetahui petunjuk tentang cara melihat detail jenis entri yang dipilih, lihat Melihat detail jenis entri dalam dokumentasi Knowledge Catalog. Untuk mengetahui petunjuk tentang cara melihat detail entri yang dipilih, lihat Melihat detail entri dalam dokumentasi Knowledge Catalog.
Jenis aspek sistem
Jenis aspek sistem untuk notebook adalah dataform-code-asset. Untuk memberikan konteks tambahan ke notebook di Knowledge Catalog dengan menganotasi entri notebook dengan aspek, lihat jenis aspek dataform-code-asset, filter hasilnya dengan filter berbasis aspek, dan tetapkan kolom type di dalam aspek dataform-code-asset ke NOTEBOOK. Untuk mengetahui petunjuk tentang cara menganotasi entri dengan aspek, lihat Mengelola aspek dan memperkaya metadata dalam dokumentasi Knowledge Catalog.
Jenis
Jenis untuk kanvas data adalah NOTEBOOK. Jenis ini memungkinkan Anda memfilter notebook dalam jenis entri sistem dataform-code-asset dan jenis aspek dataform-code-asset menggunakan kueri aspect:dataplex-types.global.dataform-code-asset.type=NOTEBOOK dalam filter berbasis aspek.

Untuk mengetahui petunjuk tentang cara menelusuri aset di Knowledge Catalog, lihat Menelusuri aset data di Knowledge Catalog dalam dokumentasi Knowledge Catalog.

Pemecahan masalah

Untuk mengetahui informasi selengkapnya, lihat Memecahkan Masalah Colab Enterprise.

Langkah berikutnya