Administrar notebooks

En este documento, se describe cómo administrar notebooks de Colab Enterprise en BigQuery, incluido cómo ver, comparar, restablecer y borrar notebooks.

En este documento, también se describe cómo ver y administrar los metadatos de los notebooks en Knowledge Catalog.

Los notebooks son recursos de código de BigQuery Studio con tecnología de Dataform.

Antes de comenzar

  1. Crea un notebook.
  2. Para administrar los metadatos de los notebooks en Knowledge Catalog, asegúrate de que la API de Dataplex esté habilitada en tu proyecto de Google Cloud .

Permisos necesarios

Para compartir los notebooks, necesitas los siguientes roles de Identity and Access Management (IAM):

Para guardar y borrar notebooks, necesitas los siguientes roles de IAM:

Para trabajar con revisiones del notebook, necesitas los siguientes roles de IAM:

Para obtener más información sobre IAM de BigQuery, consulta Control de acceso con IAM.

Para administrar los metadatos de los notebooks en Knowledge Catalog, asegúrate de tener los roles de Knowledge Catalog necesarios.

Otorga acceso a los notebooks

Para otorgar acceso a un notebook a otros usuarios, agrégalos a un rol de IAM adecuada.

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

    Si no ves el panel izquierdo, haz clic en Expandir panel izquierdo para abrirlo.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Busca el notebook al que quieres otorgar acceso.

  5. Haz clic en Abrir acciones junto al notebook y, luego, en Compartir.

  6. En el panel Permisos de uso compartido, haz clic en Agregar usuario o grupo.

  7. En el campo Principales nuevas, ingresa una principal.

  8. En la lista Rol, selecciona uno de los siguientes roles:

  9. Opcional: Para ver una lista completa de las funciones y la configuración de uso compartido avanzada, haz clic en Uso compartido avanzado.

  10. Haz clic en Guardar.

  11. Para volver a la página de información del notebook, haz clic en Cerrar.

Comparte notebooks

Para compartir un notebook con otros usuarios, puedes generar y compartir un vínculo al notebook. Para que otros usuarios vean el notebook que compartes, primero debes otorgar acceso al notebook.

Para ejecutar un notebook, los usuarios deben tener acceso a los datos a los que accede el notebook. Para obtener más información, consulta Otorga acceso a un conjunto de datos.

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

    Si no ves el panel izquierdo, haz clic en Expandir panel izquierdo para abrirlo.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Busca la carpeta que quieras compartir. Puedes usar la función de búsqueda o los filtros para encontrar tu notebook.

  5. Haz clic en Ver acciones junto al notebook y, luego, en Compartir > Copiar vínculo.

  6. Comparte el vínculo con otros usuarios.

Inhabilita el guardado de resultados de notebook

Puedes evitar que se comparta el resultado del notebook guardado con otros usuarios que tengan acceso al archivo del notebook si inhabilitas el guardado de resultados del notebook.

Cuando inhabilitas el guardado de resultados para un notebook seleccionado, BigQuery borra todos los resultados guardados en el archivo del notebook y no guarda el resultado de las ejecuciones posteriores.

Sin embargo, los usuarios que tienen acceso al notebook aún pueden ver el resultado de las siguientes maneras:

  • Ejecuta el notebook para ver su resultado actual. No se guardó este resultado.
  • Visualiza una versión de archivo del notebook y su resultado en el historial de revisión.

Para inhabilitar el guardado de resultados en un notebook seleccionado, sigue estos pasos:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

    Si no ves el panel izquierdo, haz clic en Expandir panel izquierdo para abrirlo.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Haz clic en el notebook en el que deseas inhabilitar el guardado de resultados.

  5. Para expandir la barra de menú, haz clic en keyboard_arrow_down Alternar visibilidad del encabezado.

  6. Haz clic en Editar > Configuración del notebook.

  7. En la ventana Configuración del notebook, selecciona Omitir el resultado de la celda de código cuando guardas este notebook.

  8. Haz clic en Guardar.

  9. Haz clic en Volver a cargar.

Resolver conflictos

Si tú y otro usuario realizan cambios conflictivos en un notebook, el servicio genera el error Automatic saving failed. This file was updated remotely or in another tab. y proporciona un vínculo Show diff. Para resolver el conflicto, sigue estos pasos:

  1. Haz clic en el vínculo Show diff. Se abrirá el cuadro de diálogo Revisa los cambios remotos.
  2. Opcional: Para comparar el código fuente del notebook, selecciona la casilla de verificación Fuente sin procesar.
  3. Opcional: Para comparar las versiones intercaladas en lugar de en paneles separados, selecciona la casilla de verificación Diferencia intercalada.
  4. Revisa los cambios y decide cuáles conservar. Si es necesario, modifica tu entrada.
  5. Haz clic en Guardar los cambios.

Visualiza todos los notebooks

Para ver una lista de todos los notebooks de tu proyecto, haz lo siguiente:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

    Si no ves el panel izquierdo, haz clic en Expandir panel izquierdo para abrirlo.

  3. En el panel Explorador, haz clic en Ver acciones junto a Notebooks y, luego, realiza una de las siguientes acciones:

  • Para abrir la lista en la pestaña actual, haz clic en Mostrar todo.
  • Para abrir la lista en una pestaña nueva, haz clic en Mostrar todo en > Pestaña nueva.
  • Para abrir la lista en una pestaña dividida, haz clic en Mostrar todo en > Pestaña dividida.

Cómo ver los metadatos del notebook

Para ver los metadatos del notebook, sigue estos pasos:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Haz clic en el nombre del notebook del que quieres ver los metadatos.

  5. Mira los detalles del resumen para ver información sobre el notebook, como la región que usa para los datos y la fecha en que se modificó por última vez.

Trabaja con versiones de notebooks

Puedes optar por crear un notebook dentro o fuera de un repositorio. El control de versiones de los notebooks se administra de manera diferente según la ubicación del notebook.

Control de versiones de notebooks en repositorios

Los repositorios son repositorios de Git que residen en BigQuery o con un proveedor externo. Puedes usar espacios de trabajo en repositorios para realizar el control de versión en los notebooks. Para obtener más información, consulta Cómo control de versión con un archivo.

Control de versiones de notebooks fuera de los repositorios

Usa las siguientes secciones para aprender a ver, comparar y restablecer versiones de un notebook.

Cómo ver las versiones de notebook

Para ver las versiones de notebook, sigue estos pasos:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks. Haz clic en el nombre del notebook del que quieres ver el historial de versiones.

  4. Para ver una lista de las versiones de notebook en orden descendente por fecha, haz clic en Historial de versiones.

Cómo comparar versiones de notebooks

Para comparar las versiones de notebook, sigue estos pasos:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Haz clic en el nombre del notebook del que quieres comparar la información de la versión.

  5. Haz clic en Historial de versiones.

  6. Haz clic en Ver acciones junto a la versión de un notebook y, luego, en Comparar. Se abrirá el panel de comparación y se comparará la versión del notebook que seleccionaste con la versión actual del notebook.

  7. Opcional: Para comparar las versiones intercaladas en lugar de en paneles separados, haz clic en Comparar y, luego, en Intercalado.

  8. Opcional: Para comparar el código fuente de las versiones, haz clic en Comparar y, luego, en Mostrar fuente sin procesar.

  9. Opcional: Para ocultar el resultado del comando en el notebook, haz clic en Comparar y, luego, desmarca Mostrar resultado.

Restablece una versión de notebook

Restablecer una versión de un notebook desde el panel de comparación te permite comparar las versiones actuales y anteriores del notebook antes de restablecer la versión anterior. Si restableces un notebook, se crea una versión nueva del notebook en lugar de reemplazar la actual. No se pierde el historial de versiones.

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Haz clic en el nombre del notebook del que quieres restablecer una versión anterior.

  5. Haz clic en Historial de versiones.

  6. Haz clic en Ver acciones junto a la versión y, luego, en Comparar. Se abrirá el panel de comparación y se comparará la versión del notebook que seleccionaste con la versión más reciente del notebook.

  7. Si deseas restablecer la versión anterior del notebook después de la comparación, haz clic en Restablecer.

  8. Haz clic en Confirmar.

Cómo cambiar el nombre de un cuaderno

Para borrar un notebook, sigue estos pasos:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Haz clic en el notebook al que quieres cambiarle el nombre.

  5. Haz clic en keyboard_arrow_down Activar o desactivar la visibilidad del encabezado para expandir la barra de menú.

  6. Haz clic en Archivo > Cambiar nombre.

  7. En el cuadro de diálogo Cambiar nombre de notebook, escribe un nombre para el notebook y, luego, haz clic en Cambiar nombre.

Descarga un notebook

Para descargar un notebook, sigue estos pasos:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Haz clic en el nombre del notebook que deseas descargar. Puedes usar la función de búsqueda o los filtros para encontrar tu notebook.

  5. Expande la barra de menú y ve al menú Archivo:

    La barra de menú del notebook

  6. Selecciona Descargar y, luego, el tipo de archivo en el que deseas descargarlo.

Cómo borrar notebooks

Para borrar un notebook, sigue estos pasos:

  1. En la consola de Google Cloud , ve a la página BigQuery.

    Ir a BigQuery

  2. En el panel de la izquierda, haz clic en Explorar.

    Botón destacado del panel Explorador.

  3. En el panel Explorador, expande tu proyecto y haz clic en Notebooks.

  4. Busca el notebook que quieres borrar.

  5. Haz clic en Ver acciones junto al notebook y, luego, en Borrar.

  6. Para confirmar la eliminación, escribe delete en el cuadro de diálogo.

  7. Haz clic en Borrar.

Administra metadatos en Knowledge Catalog

Knowledge Catalog te permite almacenar y administrar metadatos para notebooks. Los notebooks están disponibles en Knowledge Catalog de forma predeterminada, sin configuración adicional.

Puedes usar Knowledge Catalog para administrar notebooks en todas las ubicaciones de BigQuery. La administración de notebooks en Knowledge Catalog está sujeta a las cuotas y los límites de Knowledge Catalog y a los precios de Knowledge Catalog.

Knowledge Catalog recupera automáticamente los siguientes metadatos de los notebooks:

  • Nombre del recurso de datos
  • Superior del recurso de datos
  • Ubicación del recurso de datos
  • Tipo de recurso de datos
  • Proyecto de Google Cloud correspondiente

Knowledge Catalog registra los notebooks como entradas con los siguientes valores de entrada:

Grupo de entradas del sistema
El grupo de entradas del sistema para los notebooks es @dataform. Para ver los detalles de las entradas de notebooks en Knowledge Catalog, debes ver el grupo de entradas del sistema dataform. Para obtener instrucciones sobre cómo ver una lista de todas las entradas de un grupo de entradas, consulta Visualiza los detalles de un grupo de entradas en la documentación de Knowledge Catalog.
Tipo de entrada del sistema
El tipo de entrada del sistema para los notebooks es dataform-code-asset. Para ver los detalles de los notebooks, debes ver el tipo de entrada del sistema dataform-code-asset, filtrar los resultados con un filtro basado en aspectos y establecer el campo type dentro del aspecto dataform-code-asset en NOTEBOOK. Luego, selecciona una entrada del cuaderno seleccionado. Para obtener instrucciones sobre cómo ver los detalles de un tipo de entrada seleccionado, consulta Visualiza los detalles de un tipo de entrada en la documentación de Knowledge Catalog. Para obtener instrucciones sobre cómo ver los detalles de una entrada seleccionada, consulta Visualiza los detalles de una entrada en la documentación de Knowledge Catalog.
Tipo de aspecto del sistema
El tipo de aspecto del sistema para los notebooks es dataform-code-asset. Para proporcionar contexto adicional a los notebooks en Knowledge Catalog anotando las entradas de notebooks con aspectos, visualiza el tipo de aspecto dataform-code-asset, filtra los resultados con un filtro basado en aspectos y establece el campo type dentro del aspecto dataform-code-asset en NOTEBOOK. Para obtener instrucciones sobre cómo anotar entradas con aspectos, consulta Administra aspectos y enriquece metadatos en la documentación de Knowledge Catalog.
Tipo
El tipo de lienzo de datos es NOTEBOOK. Este tipo te permite filtrar notebooks en el tipo de entrada del sistema dataform-code-asset y el tipo de aspecto dataform-code-asset con la consulta aspect:dataplex-types.global.dataform-code-asset.type=NOTEBOOK en un filtro basado en aspectos.

Para obtener instrucciones sobre cómo buscar recursos en Knowledge Catalog, consulta Busca recursos de datos en Knowledge Catalog en la documentación de Knowledge Catalog.

Soluciona problemas

Para obtener más información, consulta Soluciona problemas de Colab Enterprise.

¿Qué sigue?