Gestisci i notebook

Questo documento descrive come gestire i notebook di Colab Enterprise in BigQuery, tra cui come visualizzare, confrontare, ripristinare ed eliminare i notebook.

Questo documento descrive anche come visualizzare e gestire i metadati dei notebook in Knowledge Catalog.

Notebooks sono asset di codice di BigQuery Studio basati su Dataform.

Prima di iniziare

  1. Crea un notebook.
  2. Per gestire i metadati dei notebook in Knowledge Catalog, assicurati che l'API Dataplex sia abilitata nel tuo progetto Google Cloud .

Autorizzazioni obbligatorie

Per condividere i notebook, devi disporre dei seguenti ruoli IAM (Identity and Access Management):

Per salvare ed eliminare i notebook, devi disporre dei seguenti ruoli IAM:

Per lavorare con le revisioni dei notebook, devi disporre dei seguenti ruoli IAM:

Per saperne di più su BigQuery IAM, consulta Controllo dell'accesso con IAM.

Per gestire i metadati dei notebook in Knowledge Catalog, assicurati di disporre dei ruoli di Knowledge Catalog richiesti.

Concedi l'accesso ai notebook

Per concedere ad altri utenti l'accesso a un notebook, aggiungili a un ruolo IAM appropriato.

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

    Se non vedi il riquadro a sinistra, fai clic su Espandi riquadro sinistro per aprirlo.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Trova il notebook a cui vuoi concedere l'accesso.

  5. Fai clic su Apri azioni accanto al notebook, quindi fai clic su Condividi.

  6. Nel riquadro Autorizzazioni di condivisione, fai clic su Aggiungi utente/gruppo.

  7. Nel campo Nuove entità, inserisci un'entità.

  8. Nell'elenco Ruolo, seleziona uno dei seguenti ruoli:

  9. (Facoltativo) Per visualizzare un elenco completo di ruoli e impostazioni di condivisione avanzate, fai clic su Condivisione avanzata.

  10. Fai clic su Salva.

  11. Per tornare alla pagina delle informazioni sul notebook, fai clic su Chiudi.

Condividi i notebook

Per condividere un notebook con altri utenti, puoi generare e condividere un link al notebook. Affinché altri utenti possano visualizzare il notebook che condividi, devi prima concedere l'accesso al notebook.

Per eseguire un notebook, gli utenti devono avere accesso ai dati a cui accede il notebook. Per saperne di più, consulta Concedi l'accesso a un set di dati.

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

    Se non vedi il riquadro a sinistra, fai clic su Espandi riquadro sinistro per aprirlo.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Trova il notebook che vuoi condividere. Puoi utilizzare la funzionalità di ricerca o i filtri per trovare il tuo notebook.

  5. Fai clic su Visualizza azioni accanto al notebook, quindi su Condividi > Copia link.

  6. Condividi il link con altri utenti.

Disabilita il salvataggio dell'output del notebook

Puoi impedire la condivisione dell'output del notebook salvato con altri utenti che hanno accesso al file del notebook disattivando il salvataggio dell'output del notebook.

Quando disattivi il salvataggio dell'output per un blocco note selezionato, BigQuery elimina tutto l'output salvato nel file del blocco note e non salva l'output delle esecuzioni successive.

Tuttavia, gli utenti che hanno accesso al notebook possono comunque visualizzarne l'output nei seguenti modi:

  • Esegui il notebook per visualizzare l'output corrente. Questo output non viene salvato.
  • Visualizza una versione di archiviazione del notebook e del relativo output nella cronologia delle revisioni.

Per disattivare il salvataggio dell'output per un notebook selezionato, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

    Se non vedi il riquadro a sinistra, fai clic su Espandi riquadro sinistro per aprirlo.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Fai clic sul notebook per cui vuoi disattivare il salvataggio dell'output.

  5. Per espandere la barra dei menu, fai clic su keyboard_arrow_down Attiva/disattiva visibilità intestazione.

  6. Fai clic su Modifica > Impostazioni notebook.

  7. Nella finestra Impostazioni notebook, seleziona Ometti l'output della cella di codice durante il salvataggio di questo notebook.

  8. Fai clic su Salva.

  9. Fai clic su Ricarica.

Risolvi conflitti

Se tu e un altro utente apportate modifiche in conflitto in un notebook, il servizio genera l'errore Automatic saving failed. This file was updated remotely or in another tab. e fornisce un link Show diff. Per risolvere il conflitto, procedi nel seguente modo:

  1. Fai clic sul link Show diff. Si apre la finestra di dialogo Rivedi modifiche da remoto.
  2. (Facoltativo) Per confrontare il codice sorgente del notebook, seleziona la casella di controllo Codice sorgente non elaborato.
  3. (Facoltativo) Per confrontare le versioni in linea anziché in riquadri separati, seleziona la casella di controllo Differenza in linea.
  4. Esamina le modifiche e decidi quali mantenere, rivedendo l'input se necessario.
  5. Fai clic su Salva le modifiche.

Visualizza tutti i notebook

Per visualizzare un elenco di tutti i notebook nel tuo progetto, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

    Se non vedi il riquadro a sinistra, fai clic su Espandi riquadro sinistro per aprirlo.

  3. Nel riquadro Explorer, fai clic su Visualizza azioni accanto a Notebook, quindi esegui una delle seguenti operazioni:

  • Per aprire l'elenco nella scheda corrente, fai clic su Mostra tutto.
  • Per aprire l'elenco in una nuova scheda, fai clic su Mostra tutto in > Nuova scheda.
  • Per aprire l'elenco in una scheda divisa, fai clic su Mostra tutto in > Scheda divisa.

Visualizza i metadati del notebook

Per visualizzare i metadati del notebook, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Fai clic sul nome del notebook di cui vuoi visualizzare i metadati.

  5. Esamina i dettagli del riepilogo per visualizzare informazioni sul notebook, ad esempio la regione che utilizza per i dati e la data dell'ultima modifica.

Utilizza le versioni dei notebook

Puoi scegliere di creare un notebook all'interno o all'esterno di un repository. Il controllo delle versioni dei notebook viene gestito in modo diverso a seconda della posizione del notebook.

Controllo delle versioni dei notebook nei repository

I repository sono repository Git che si trovano in BigQuery o presso un provider di terze parti. Puoi utilizzare le aree di lavoro nei repository per eseguire il controllo della versione sui notebook. Per saperne di più, consulta Utilizza il controllo della versione con un file.

Controllo delle versioni dei notebook al di fuori dei repository

Utilizza le sezioni seguenti per scoprire come visualizzare, confrontare e ripristinare le versioni di un notebook.

Visualizza le versioni del notebook

Per visualizzare le versioni del blocco note, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook. Fai clic sul nome del blocco note di cui vuoi visualizzare la cronologia delle versioni.

  4. Per visualizzare un elenco delle versioni del notebook in ordine decrescente per data, fai clic su Cronologia delle versioni.

Confronta le versioni dei notebook

Per confrontare le versioni del notebook, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Fai clic sul nome del blocco note per cui vuoi confrontare le informazioni sulla versione.

  5. Fai clic su Cronologia delle versioni.

  6. Fai clic su Visualizza azioni accanto a una versione del notebook, quindi fai clic su Confronta. Si apre il riquadro di confronto, che mette a confronto la versione del notebook selezionata con quella attuale.

  7. (Facoltativo) Per confrontare le versioni in linea anziché in riquadri separati, fai clic su Confronta e poi su In linea.

  8. (Facoltativo) Per confrontare il codice sorgente delle versioni, fai clic su Confronta e poi su Mostra codice sorgente non elaborato.

  9. (Facoltativo) Per nascondere l'output comando nel notebook, fai clic su Confronta e poi deseleziona Mostra output.

Ripristina una versione del notebook

Il ripristino di una versione del notebook dal riquadro di confronto ti consente di confrontare le versioni corrente e precedente del notebook prima di scegliere di ripristinare la versione precedente. Il ripristino di un notebook crea una nuova versione del notebook anziché sovrascrivere la versione corrente. Nessuna cronologia delle versioni andrà persa.

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Fai clic sul nome del notebook di cui vuoi ripristinare una versione precedente.

  5. Fai clic su Cronologia delle versioni.

  6. Fai clic su Visualizza azioni accanto alla versione, quindi su Confronta. Si apre il riquadro di confronto, che confronta la versione del notebook che hai selezionato con la versione più recente.

  7. Se vuoi ripristinare la versione precedente del notebook dopo il confronto, fai clic su Ripristina.

  8. Fai clic su Conferma.

Rinomina un notebook

Per rinominare un notebook, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Fai clic sul notebook che vuoi rinominare.

  5. Fai clic su keyboard_arrow_down Attiva/disattiva visibilità intestazione per espandere la barra dei menu.

  6. Fai clic su File > Rinomina.

  7. Nella finestra di dialogo Rinomina notebook, digita un nome per il notebook, quindi fai clic su Rinomina.

Scarica un notebook

Per scaricare un notebook, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Fai clic sul nome del notebook che vuoi scaricare. Puoi utilizzare la funzionalità di ricerca o i filtri per trovare il tuo notebook.

  5. Espandi la barra dei menu e vai al menu File:

    La barra dei menu del notebook

  6. Seleziona Scarica, quindi seleziona il tipo di file in cui vuoi scaricare il file.

Elimina i notebook

Per eliminare un notebook, segui questi passaggi:

  1. Nella console Google Cloud , vai alla pagina BigQuery.

    Vai a BigQuery

  2. Nel riquadro a sinistra, fai clic su Spazio di esplorazione:

    Pulsante evidenziato per il riquadro Spazio di esplorazione.

  3. Nel riquadro Explorer, espandi il progetto e fai clic su Notebook.

  4. Trova il notebook che vuoi eliminare.

  5. Fai clic su Visualizza azioni accanto al notebook, quindi fai clic su Elimina.

  6. Per confermare l'eliminazione, digita delete nella finestra di dialogo.

  7. Fai clic su Elimina.

Gestisci i metadati in Knowledge Catalog

Knowledge Catalog consente di archiviare e gestire i metadati per i notebook. Notebooks sono disponibili in Knowledge Catalog per impostazione predefinita, senza configurazioni aggiuntive.

Puoi utilizzare Knowledge Catalog per gestire i notebook in tutte le località di BigQuery. La gestione dei notebook in Knowledge Catalog è soggetta alle quote e ai limiti di Knowledge Catalog e ai prezzi di Knowledge Catalog.

Knowledge Catalog recupera automaticamente i seguenti metadati dai notebook:

  • Nome dell'asset di dati
  • Asset di dati padre
  • Posizione dell'asset di dati
  • Tipo di asset di dati
  • Progetto Google Cloud componente corrispondente

Knowledge Catalog registra i notebook come voci con i seguenti valori:

Gruppo di voci di sistema
Il gruppo di voci di sistema per i notebook è @dataform. Per visualizzare i dettagli delle voci dei blocchi note in Knowledge Catalog, devi visualizzare il gruppo di voci di sistema dataform. Per istruzioni su come visualizzare un elenco di tutte le voci di un gruppo di voci, consulta Visualizza i dettagli di un gruppo di voci nella documentazione di Knowledge Catalog.
Tipo di voce di sistema
Il tipo di voce di sistema per i notebook è dataform-code-asset. Per visualizzare i dettagli dei notebook, devi visualizzare il tipo di voce di sistema dataform-code-asset, filtrare i risultati con un filtro basato sugli aspetti e impostare il campo type all'interno dell'aspetto dataform-code-asset su NOTEBOOK. Poi, seleziona una voce del notebook selezionato. Per istruzioni su come visualizzare i dettagli di un tipo di voce selezionato, consulta Visualizza i dettagli di un tipo di voce nella documentazione di Knowledge Catalog. Per istruzioni su come visualizzare i dettagli di una voce selezionata, consulta Visualizza i dettagli di una voce nella documentazione di Knowledge Catalog.
Tipo di aspetto del sistema
Il tipo di aspetto di sistema per i notebook è dataform-code-asset. Per fornire un contesto aggiuntivo ai notebook in Knowledge Catalog annotando le voci dei notebook con gli aspetti, visualizza il tipo di aspetto dataform-code-asset, filtra i risultati con un filtro basato sugli aspetti e imposta il campo type all'interno dell'aspetto dataform-code-asset su NOTEBOOK. Per istruzioni su come annotare le voci con gli aspetti, consulta Gestisci gli aspetti e arricchisci i metadati nella documentazione di Knowledge Catalog.
Tipo
Il tipo per i canvas di dati è NOTEBOOK. Questo tipo consente di filtrare i notebook nel tipo di voce di sistema dataform-code-asset e nel tipo di aspetto dataform-code-asset utilizzando la query aspect:dataplex-types.global.dataform-code-asset.type=NOTEBOOK in un filtro basato sugli aspetti.

Per istruzioni su come cercare asset in Knowledge Catalog, consulta Cerca asset di dati in Knowledge Catalog nella documentazione di Knowledge Catalog.

Risoluzione dei problemi

Per saperne di più, consulta Risolvi i problemi di Colab Enterprise.

Passaggi successivi