Looker-Power BI 連接器可讓您使用 Microsoft Power BI Desktop,連結 Looker 探索中的資料。
Looker-Power BI 連接器可與 Power BI 的 DirectQuery 模式搭配使用。
在 DirectQuery 模式下使用 Looker–Power BI Connector 時,Power BI 不會匯入或複製資料,而是為每個圖表、篩選器和 DAX 計算產生 Power Query M 運算式。Looker-Power BI 連接器會使用 Looker API,將這些運算式轉譯為即時查詢。
這項程序仰賴 Power BI 查詢摺疊。如果查詢使用的函式不受 Looker - Power BI 連接器支援,查詢摺疊就會停止。查詢摺疊停止時,Power BI 會下載所有資料,在本機計算結果,這會降低報表載入速度,並增加網路用量。
設定 Power BI Desktop 以連線至 Looker
使用 Looker-Power BI 連接器的一般步驟如下:
- 確認需求條件。
- 在 Looker 執行個體啟用連接器。
- 下載並儲存連接器檔案:每位想存取 Looker-Power BI 連接器的使用者,都必須下載
looker_1.4.3.mez檔案,並儲存到電腦上的特定目錄。 - 為自訂連接器設定 Power BI Desktop:每位 Power BI 使用者都必須調整 Power BI Desktop 安全性設定,才能使用未經認證的自訂連接器。
本頁各節將詳細說明這些步驟。
完成將 Looker 連結至 Power BI Desktop 的步驟後,您就可以從 Power BI 連結至 Looker 資料,並在 Power BI 中發布報表。您也可以選擇使用 Power BI 服務 (Power BI 線上版),在網路瀏覽器中與 Looker 報表互動。您也可以使用資料列層級安全性,透過 Power BI 服務發布報表。
需求條件
如要設定 Looker-Power BI 連接器,您需要:
- 電腦上已安裝 Microsoft Power BI Desktop。
- Looker 執行個體上的 Looker 使用者帳戶,具備
explore權限,才能存取 Looker 中的「探索」功能。如要處理超過 5,000 列的查詢,您也需要download_without_limit權限 (如要瞭解下載限制,請參閱「查詢列數限制」)。
此外,Looker 執行個體必須符合下列規定:
- 執行個體必須啟用 Microsoft Power BI 連接器。Looker 管理員必須在「管理 OAuth 用戶端」頁面 (依序點選「管理」>「驗證」>「管理 OAuth 用戶端」) 的「應用程式庫」分頁,啟用預先設定的 Microsoft Power BI 用戶端,或是在 Looker 的「商業智慧連接器」頁面啟用「Microsoft Power BI」切換鈕。
- 設定為私人連線的 Looker (Google Cloud Core) 執行個體和客戶託管的 Looker 執行個體必須符合下列規定:
- 執行個體必須搭載 Looker 25.16 以上版本。
- 網路管理員必須設定網路,讓 Looker–Power BI Connector 的流量能傳送至 Looker 執行個體。
在 Looker 執行個體啟用連接器
您要與 Looker-Power BI 連接器搭配使用的 Looker 執行個體,必須啟用 Microsoft Power BI 連接器:
- Looker (Google Cloud Core) 執行個體預設會啟用商業智慧連接器。
- Looker (原始) 執行個體的商業智慧連接器預設為停用。
Looker 管理員可以前往「管理 OAuth 用戶端」頁面 (依序點選「管理」>「驗證」>「管理 OAuth 用戶端」),在「應用程式庫」分頁啟用預先設定的 Microsoft Power BI 用戶端,或是在 Looker「管理」選單的「平台」部分,透過「商業智慧連接器」面板啟用商業智慧連接器。
下載並儲存連接器檔案
如要下載連接器檔案,請在已安裝 Microsoft Power BI Desktop 的電腦上,按照下列步驟操作:
- 如要下載連接器檔案,請按一下下列連結:
looker_1.4.3.mez - 下載完成後,請將
looker_1.4.3.mez檔案移至 [Documents]\Microsoft Power BI Desktop\Custom Connectors 目錄。(如果電腦上沒有這些資料夾,請自行建立)。
設定 Power BI Desktop 以使用自訂連接器
如要在 Power BI Desktop 設定 Looker–Power BI Connector,請按照 Microsoft Power BI 網站上的自訂連接器操作說明進行。
如操作說明所述,在「資料擴充功能」下方,選取「(不建議) 允許載入任何擴充功能,不進行驗證或顯示警告」選項。選取「OK」,然後重新啟動 Power BI Desktop。
從 Power BI Desktop 連結 Looker 資料
下載 looker_1.4.3.mez 連接器檔案,並為自訂連接器設定 Power BI Desktop 應用程式後,即可使用 Power BI Desktop 連線至 Looker 執行個體的資料:
- 在 Power BI Desktop 工具列中,依序選取「Get Data」>「More...」。
- 在「Get Data」對話方塊的搜尋欄位中,輸入 Looker。
- 在搜尋結果中,按一下「Looker」項目,然後點選「Connect」。
- 在「連結至第三方服務」對話方塊中,按一下「繼續」。
- Power BI Desktop 會顯示 Looker 登入對話方塊。在「Host」欄位中,輸入執行個體的網址。例如:
example.cloud.looker.com。 (選用) 按一下「Advanced Options」(進階選項) 展開該部分,並設定下列其他選項:
- 使用「顯示隱藏的探索和欄位」下拉式選單,納入在 LookML 中設為隱藏的探索和欄位 (詳情請參閱隱藏 (探索) 和隱藏 (欄位) 說明文件):
- FALSE (預設):隱藏欄位會遭到抑制。
- TRUE:顯示隱藏欄位。
- 使用「Enable Logging」(啟用記錄功能) 下拉式選單,啟用或停用連接器中的診斷記錄,以便排解問題。詳情請參閱「啟用 Power BI Desktop 的偵錯記錄檔功能」一節。
- 使用「顯示隱藏的探索和欄位」下拉式選單,納入在 LookML 中設為隱藏的探索和欄位 (詳情請參閱隱藏 (探索) 和隱藏 (欄位) 說明文件):
選取「DirectQuery」DirectQuery選項,建立 Looker 資料的即時連線。
按一下 [確定]。
在「Looker」對話方塊中,點選「登入」。
在 Looker 登入畫面中,登入 Looker 執行個體。
Power BI Desktop 會返回 Looker 登入對話方塊,並顯示您已登入的訊息。點選「連線」。
Power BI Desktop 會顯示您有權存取的 Looker 模型清單,每個模型都會以資料夾表示。按一下要存取的 Looker 模型,然後找出要載入 Power BI Desktop 的 Looker 探索,並勾選旁邊的核取方塊。如要查看模型,您必須具備 Looker 使用者存取權,或群組存取權,可存取包含該模型的模型集。您必須具備 Looker
explore權限,才能存取探索。按一下「載入」。
Power BI Desktop 會在「資料」窗格中,填入所選探索中的欄位。接著,您可以使用「探索」中的 Looker 資料,在 Power BI Desktop 中建立報表。如要瞭解 Looker-Power BI 連接器如何顯示 Looker 元素,請參閱「在 Power BI Desktop 中查看 Looker 元素」。
欄位名稱會以 ViewName.FieldName 格式顯示在單一清單中。
在 Power BI Desktop 中查看 Looker 元素
從 Power BI Desktop 連結至 Looker 資料後,Power BI Desktop 會在「資料」窗格中填入所選探索中的欄位。
Looker-Power BI 連接器會使用下列格式,在 Power BI Desktop 中顯示 Looker 欄位:
ViewName.FieldType.FieldName
ViewName值是定義欄位的 LookML 檢視表。FieldType值可以是 Looker-Power BI 連接器支援的下列任一類型:dim:維度,代表屬性、事實或值的欄位,例如日期、名稱和 ID。維度通常會對應至基礎資料表中的資料欄。在 LookML 中,維度是以dimension參數定義。mea:測量指標,代表資料可測量資訊的欄位,例如總和、計數、平均值、最小值和最大值。在 LookML 中,測量指標是以measure參數定義。fil:篩選器,僅用於在探索查詢中建立篩選器的篩選器限定欄位;篩選器欄位不會包含在查詢的結果集中。在 LookML 中,篩選器是以filter參數定義。par:參數,這個欄位僅用於在探索查詢中建立篩選器,不會包含在查詢結果集中。使用{% parameter parameter_name %}和parameter_name._parameter_value液體變數定義參數時,參數可以建立互動式查詢結果、標籤、網址等。在 LookML 中,參數是以parameter參數定義。
FieldName值是 Looker 探索中顯示的欄位名稱。
Power BI Desktop 顯示 Looker 元素的方式與 Looker 探索相同,大小寫和字詞間距也一樣。舉例來說,如果 Looker 探索將 LookML 維度顯示為 Created Date,而檢視畫面顯示為 Order Items,Power BI Desktop 會將這個欄位顯示為 Order Items.dim.Created Date。
使用 Looker 維度和測量指標建立查詢
Looker - Power BI 連接器可讓您使用 Looker 維度和測量指標,在 Power BI Desktop 中建立查詢。
如要在 Power BI Desktop 中使用 Looker 維度和測量指標建立查詢,請按照下列步驟操作:
- 從 Power BI Desktop 連結至 Looker 資料,並等待 Power BI 在「資料」窗格中填入所選 Looker 探索的欄位。
- 在 Power BI 的「資料」窗格中,找出要納入查詢的 Looker 維度或測量指標,然後勾選對應的核取方塊。
選取各個維度或測量指標時,Power BI 會更新報表畫布中顯示的查詢。
使用 Looker 篩選器和參數篩選查詢
Looker-Power BI 連接器可讓您使用 Looker 探索中的 LookML 參數和篩選器限定欄位,在 Power BI 報表中新增篩選器。
如要在 Power BI Desktop 中,使用 Looker 參數和篩選器限定欄位篩選報表,請按照下列步驟操作:
如果尚未從 Power BI Desktop 連結至 Looker 資料,請先完成這項操作,並等待 Power BI 將所選 Looker 探索中的欄位填入「資料」窗格。
在 Power BI 的「資料」窗格中,將參數或篩選器限定欄位的名稱,拖曳到「篩選器」窗格中「在此新增資料欄位」方塊,可拖曳到「此頁面的篩選」或「所有頁面的篩選」。如要瞭解如何在 Power BI 報表中新增篩選器,請參閱 Power BI 說明文件。
在 Power BI 中使用 Looker 參數和篩選器限定欄位時,請注意下列事項:
- 如果篩選器限定欄位是在 LookML 中使用
suggestions參數或suggest_dimension參數設定,Power BI 會擷取建議值,並顯示在「篩選」窗格的「基本篩選」選項中。 如果參數是在 LookML 中使用
allowed_value屬性設定,Power BI 會擷取 LookML 中為該參數設定的所有允許值,並顯示在「篩選器」窗格的「基本篩選」選項中。
搭配使用 DAX 和 Looker-Power BI 連接器
DAX (資料分析運算式) 是 Power BI 中用於建立自訂計算的公式語言。
Power BI 會將 DAX 查詢轉譯為 Power Query M 運算式,並傳送至 Looker-Power BI 連接器。Looker-Power BI 連接器會將這些 M 運算式轉譯為 Looker API 呼叫。
如果系統不支援 DAX 或 Power Query M 函式,查詢摺疊就會停止。發生這種情況時,Power BI 會從 Looker 擷取整個原始資料表,以便在本機處理作業,這可能會導致效能大幅降低。如需支援的函式清單,請參閱「支援的 Power Query M 函式」一節。
測量指標與資料欄
Power BI 提供兩種主要方式,可使用 DAX 建立新資料:「新增量值」和「新增資料欄」。
- 新增測量指標:在視覺化圖表中使用這個動態值時,Power BI 會即時計算。這個模型不會儲存這個值。主要用於匯總資料。
- 範例:
Total Sales = SUM('Sales'[Revenue])
- 範例:
- 新資料欄:Power BI 會逐列計算這個靜態值。只有在資料重新整理時才會更新。模型會儲存這個值。資料欄主要用於分類資料。
- 範例:
Profit = 'Sales'[Revenue] - 'Sales'[Cost]
- 範例:
建立新測量指標
如要在 Power BI 中建立新的測量指標,請按照下列步驟操作:
- 在「資料」窗格中,在要新增測量指標的資料表上按一下滑鼠右鍵。
- 選取「新增測量指標」。
- 在公式列中輸入 DAX 公式。將
Measure替換為所選測量指標名稱。
建立新資料欄
如要在 Power BI 中建立新資料欄,請按照下列步驟操作:
- 在「資料」窗格中,對要新增資料欄的資料表按一下滑鼠右鍵。
- 選取「新增資料欄」。
- 在公式列中輸入 DAX 公式。將
Column替換為所選資料欄名稱。
DAX 查詢範例
下表提供常見匯總的 DAX 查詢範例。詳情請參閱 DAX 說明文件。
下表提供一些範例,說明如何為常見的匯總建立測量指標。
| 匯總類型 | 範例 |
|---|---|
| SUM | Total Sales = SUM('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| AVERAGE | Average Sale Price = AVERAGE('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MIN | Minimum Sale Price = MIN('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MAX | Maximum Sale Price = MAX('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| COUNT | Order Count = COUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
| DISTINCTCOUNT | Distinct Order Count = DISTINCTCOUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
下表說明如何執行基本算術運算。
| 匯總類型 | 範例 |
|---|---|
| 加 | Total Orders = [Shipped Orders] + [Pending Orders] |
| 減 | Total Profit = [Total Sales] - [Total Cost] |
| 乘 | Total Sales with Tax = [Total Sales] * 1.05 |
| 部門 | Profit Margin = DIVIDE([Total Profit], [Total Sales]) |
| 功率 | Sales Squared = POWER([Total Sales], 2)或 Sales Squared = [Total Sales] ^ 2 |
| 平方根 | Square Root of Sales = SQRT([Total Sales]) |
| 模數 | Order ID Type = IF(MOD('The Look E-Commerce'[Order Items Ecomm.dim.Order ID], 2) = 0,"Even","Odd") |
| 絕對值 | Absolute Profit = ABS([Total Profit]) |
支援的 Power Query M 函式
在 DirectQuery 模式下使用 Looker-Power BI 連接器時,Power BI 會為每個圖表、篩選器和 DAX 運算產生 Power Query M 運算式。Looker-Power BI 連接器會使用 Looker API,將這些運算式轉譯為即時查詢。
文字
Text.FromText.AtText.CombineText.Contains(Text.Contains須區分大小寫)Text.EndText.EndsWithText.LengthText.LowerText.UpperText.MiddleText.PositionOfText.RangeText.RemoveRangeText.ReplaceText.StartText.StartsWithText.InsertText.SplitText.FromBinary
清單和表格
Value.Equals/Value.NullableEqualsTable.RowCountTable.FirstTable.FirstNTable.SelectRowsTable.SortList.SumList.AverageList.MaxList.MinList.CountList.DistinctList.SelectList.ContainsList.AnyTrue
數字
基本算術
Value.AddValue.SubtractValue.MultiplyValue.Divide
科學和進階數學
Number.PowerNumber.SqrtNumber.ExpNumber.LnNumber.Log10Number.LogNumber.PI
數字屬性
Number.SignNumber.IsEvenNumber.IsOddNumber.Abs
除法和餘數
Number.ModNumber.IntegerDivide
隨機產生數字
Number.RandomNumber.RandomBetween
類型轉換
連接器不支援在圖表中使用下列數值轉換函式:
Byte.FromCurrency.FromDecimal.FromInt8.From、Int16.From、Int32.From、Int64.FromNumber.From、Number.FromTextSingle.From、Double.From
數值四捨五入
Number.RoundNumber.RoundDownNumber.RoundUpNumber.RoundTowardZeroNumber.RoundAwayFromZero
下表列出各項四捨五入作業的範例:
| 輸入 | Number.Round |
Number.RoundDown |
Number.RoundUp |
Number.RoundTowardZero |
Number.RoundAwayFromZero |
|---|---|---|---|---|---|
| 2.7 | 3 | 2 | 3 | 2 | 3 |
| 2.5 | 3 | 2 | 3 | 2 | 3 |
| 2.2 | 2 | 2 | 3 | 2 | 3 |
| 0 | 0 | 0 | 0 | 0 | 0 |
| -2.2 | -2 | -3 | -2 | -2 | -3 |
| -2.5 | -3 | -3 | -2 | -2 | -3 |
| -2.7 | -3 | -3 | -2 | -2 | -3 |
日期與時間
正在取得目前日期和時間
DateTime.LocalNowDateTime.FixedLocalNowDateTimeZone.UtcNowDateTimeZone.FixedUtcNowDateTimeZone.LocalNowDateTimeZone.FixedLocalNow
日期時間類型轉換
DateTime.FromTextDateTimeZone.FromTextDateTime.FromDateTimeZone.FromDate.FromTextTime.ToText
日期運算
Date.AddDaysDate.AddMonthsDate.AddYears
擷取日期和時間部分
Date.DayDate.MonthDate.YearTime.HourTime.MinuteTime.SecondDateTime.Time
日期和時間範圍界線
Date.StartOfDayDate.StartOfYearDate.EndOfDayDate.EndOfYearTime.StartOfHourTime.EndOfHour
高階函式
Looker - Power BI 連接器支援下列高階函式,前提是 Looker - Power BI 連接器也支援巢狀運算。
Table.AddColumn- 限制:Looker - Power BI 連接器必須支援
columnGenerator參數中定義的函式。 - 範例:Looker–Power BI Connector 支援巢狀函式
Text.Length,因此下列查詢可以運作:powerquery Table.AddColumn(LookerTable, "NewColumnName", each Text.Length([lookerTextDimensionColumn]))
- 限制:Looker - Power BI 連接器必須支援
Table.Group- 限制:Looker-Power BI 連接器必須支援
aggregatedColumns清單中使用的任何匯總函式。 - 範例:Looker–Power BI Connector 支援巢狀函式
List.Sum,因此下列查詢可以運作:powerquery Table.Group(LookerTable, "CustomerID", {"total", each List.Sum([price])})
- 限制:Looker-Power BI 連接器必須支援
在 Power BI 中以 DirectQuery 模式使用 Looker 測量指標
許多使用柱狀圖、長條圖和折線圖的 Power BI 視覺效果,都需要在 Y 軸上顯示匯總值。Power BI 需要單一值來決定資料點的繪製位置,例如資料欄的高度或線條的位置。如果沒有匯總,圖表就不會顯示。
舉例來說,以下是 Looker 測量指標 type: sum 的圖表,顯示每項商品的總費用:

除非套用匯總,否則 Power BI 不會在大多數圖表中顯示 type: sum 測量指標。如要顯示總和,請將 Power BI 匯總設為「Sum」。以下是在 Power BI 中使用加總匯總功能產生的圖表:

同樣地,您可以使用 Power BI 的加總匯總功能,以視覺化方式呈現使用下列匯總類型的 Looker 測量指標:
透過 Looker-Power BI 連接器使用 Power BI 功能
以下各節說明 Looker-Power BI 連接器對各種 Power BI 功能的支援:
Sparkline
在表格或矩陣圖表中加入走勢圖。詳情請參閱 Power BI 走勢圖說明文件。
條件式格式設定
條件式格式設定可套用至表格或矩陣圖表。Looker–Power BI 連接器支援數值欄的條件式格式設定,但不支援文字欄位。如需一般設定操作說明,請參閱 Power BI 說明文件。
類型轉換
Looker–Power BI 連接器不支援在圖表中將資料欄轉換為數字或日期。不過,連接器支援將資料欄轉換為文字,並在圖表中運用該欄位。
連結 Excel
您可以將 Looker 資料直接載入 Excel 桌面版或網頁版。如需設定操作說明,請參閱 Power BI 說明文件中的「將 Excel 連結至 Power BI 資料集」。
在 Excel 中使用 Looker - Power BI 連接器時,其運作方式與 Power BI 中的 DirectQuery 模式類似。篩選資料時,連接器會在來源套用篩選器,然後才將資料載入 Excel。
您可以在 Excel 中使用下列任一方法連結資料:
插入資料透視表
如要插入直接連結至資料集的工作表,請按照下列步驟操作:
- 選取「插入」分頁標籤。
- 依序選取「資料透視表」>「從 Power BI」。
取得資料
如要使用「資料」功能區匯入資料,請按照下列步驟操作:
- 選取「資料」分頁標籤。
- 依序選取「Get Data」>「From Fabric & Power Platform」>「From Power BI」。
監控 Looker-Power BI 連接器
Looker 管理員可以透過系統活動記錄探索中的「Query API 用戶端屬性」欄位群組,查看 Looker-Power BI 連接器的使用情形。每次執行新查詢時,系統都會在「History」(記錄) 探索中建立項目。
在「Query API Client Properties」欄位群組中,「API 用戶端名稱」會顯示 Power BI 值,用於識別 Looker-Power BI Connector 項目。
以下是顯示 Power BI 使用情形的系統活動網址範例。將 <instance_name.looker.com> 替換為執行個體網址。
https://<instance_name.looker.com>/explore/system__activity/history?fields=query_api_client_context.name,user.name,history.created_date,history.created_time_of_day&f[query_api_client_context.name]=Power+BI&sorts=history.created_time_of_day+desc&limit=5000
Power BI 服務
從 Power BI 連結至 Looker 資料並在 Power BI 中發布報表後,您可以視需要使用 Power BI 服務 (Power BI 線上版),在網路瀏覽器中與 Looker 報表互動。
您也可以使用資料列層級安全性,透過 Power BI 服務發布報表。
驗證注意事項
將報表發布至 Power BI 服務時,您用來建立報表的憑證會嵌入報表中。在 Power BI 服務中查看報表的所有使用者,都會重複使用這些憑證。
之所以會重複使用憑證,是因為 Microsoft Power BI 連接器架構不支援自訂連接器的使用者單一登入 (SSO) 驗證。如要根據查看報表的使用者限制資料存取權,請在 Power BI 中使用資料列層級安全性 (RLS)。
使用 Power BI 服務發布報表,並採用資料列層級安全性
使用 Looker-Power BI 連接器在 Power BI Desktop 發布報表後,您可以視需要使用 Power BI 服務,透過網路瀏覽器與報表互動。
Power BI Desktop 可讓您使用資料列層級安全性 (RLS),限制特定使用者的資料存取權。如要瞭解如何在 Power BI Desktop 中定義角色和規則,以及驗證角色,請參閱 Power BI 說明文件。
在 Power BI Desktop 中定義角色後,即可在 Power BI 服務中線上使用角色和規則。
如要使用資料列層級安全性,透過 Power BI 服務發布報表,請按照下列步驟操作:
- 在 Power BI Desktop 中開啟報表,然後選取視窗頂端的「Home」選單。
- 在「首頁」選單中,選取「發布」選項。
- 從下拉式選單中選取工作區,然後按一下「選取」。Power BI Desktop 會顯示成功訊息,其中包含在 Power BI 中開啟報表的連結。
- 按一下連結開啟 Power BI。
- 在 Power BI 服務中,前往「Workspaces」,然後選取報表發布位置的工作區。
- 找出報表資料集 (而非報表本身) 的清單。
- 在資料集清單中,按一下三點圖示「更多選項」選單,然後選取「安全性」。
Power BI 會顯示「Row-Level Security」(資料列層級安全性) 視窗。接著,您可以選取在 Power BI Desktop 中建立的角色,並新增屬於該角色的使用者或群組,以及在 Power BI 服務中驗證角色。
現在,您可以與任何人共用報表,他們只會看到您建立的角色允許查看的資料。
啟用 Power BI Desktop 的偵錯記錄檔功能
如要疑難排解或診斷問題,可以啟用 Power BI 和 Looker 之間的連線記錄功能。
您必須為連線和 Power BI 啟用記錄功能,方法如下:
啟用連接器層級記錄功能
如要排解問題,您可以在 Looker - Power BI 連接器中啟用診斷記錄功能。
從 Power BI Desktop 建立 Looker 資料的新連線時,請按照下列步驟啟用記錄功能:
- 在 Looker 連線對話方塊中,展開「進階選項」。
- 在「Enable Logging」下拉式選單中,選取「TRUE」。
如果您已在 Power BI Desktop 建立 Looker 資料連結,請按照下列步驟,在 Power Query 編輯器中手動編輯查詢:
- 在 Power BI Desktop 中,選取「Transform Data」。
- 在「常用」功能區中,選取「進階編輯器」。
- 找出開頭為
Source = Looker.DataSource的行。 更新函式的第二個引數,納入
EnableLogging=true。Looker.DataSource("instance.looker.com", [EnableLogging=true])按一下「完成」。
啟用 Power BI 層級追蹤
除了啟用 Power BI Desktop 連至 Looker 資料的記錄功能,您也必須按照下列步驟,啟用 Power BI Desktop 的追蹤功能:
- 依序選取「檔案」>「選項和設定」>「選項」。
- 在「Options」對話方塊中,選取「Diagnostics」。
- 在「Diagnostic Options」下方,選取「Enable tracing」。
- 如要查看記錄檔,請選取「開啟當機 dump 檔/追蹤記錄資料夾」。
注意事項
查詢資料列限制
除非 Looker 使用者帳戶具備 download_without_limit 權限,否則 Looker - Power BI 連接器的查詢會自動包含 LIMIT 5000 陳述式。如果 Looker 使用者帳戶具備 download_without_limit,Looker-Power BI 連接器的查詢就不會受到查詢資料列限制。
探索篩選條件
如果 Looker 探索是以 always_filter 或 conditionally_filter LookML 參數定義,篩選器會套用至 Looker–Power BI Connector 中的查詢,但不會顯示在 Power BI 中。
支援的維度群組時間範圍
如果是 type: time 的 dimension_group,Looker-Power BI 連接器僅支援 date 和 time 時間範圍。其他時間範圍則會隱藏。
Looker-Power BI 連接器不會顯示系統活動探索
Looker - Power BI 連接器不會顯示系統活動探索。Looker 管理員可以直接在 Looker UI 中查看系統活動探索。
類型轉換限制
建議您盡可能在 LookML 檢視表內設定資料欄類型。
已知限制
使用 Looker-Power BI 連接器時,請注意下列限制:
資料建模和模式
- 數值維度:數值維度和測量指標在 Power BI 中都會顯示為測量指標。如要將數值維度做為維度使用,您必須在 Power BI Desktop 中,將預設摘要變更為「不摘要」。
- 匯入模式:為獲得最佳效能,請使用 DirectQuery 模式。如果您使用 Power BI 匯入模式,請注意下列限制:
- 成效:存取大型模型的報表可能載入速度較慢。
- 逾時:如果「取得資料」程序停止運作或逾時,請切換至 DirectQuery 模式。
- 欄位限制:匯入模式會停用篩選器限定欄位和參數欄位。
- 評估指標:匯入模式會限制 Looker 評估探索中的指標,這可能會影響報表準確度。
匯總資料
Power BI 會將自己的匯總套用至 Looker 測量指標。這可能會導致錯誤或結果不一致,尤其是在矩陣圖表中。
- 支援的類型:僅限使用
average、count、count_distinct、max、min和sum。 - 不支援的類型:連接器不支援查詢標準差、變異數,或依字母順序排列的第一個或最後一個字串匯總。
- 中位數效能:Power BI 會擷取所有值,在本機計算中位數。如果資料集很大,這個方法會很慢,而且可能會逾時。
篩選與排序
- 依隱藏欄位排序:您無法依未包含在圖表中的欄位排序。如要依欄位排序,請將欄位新增至圖表。
- 進階篩選器限制:由於 Power Query 和 Looker 篩選運算式之間存在差異,因此有下列限制:
- 文字:不支援多個文字篩選器。
- 日期:日期和日期時間欄位僅支援
is、is not、is on or after和is before。 - 只有在下列情況下,才支援多個數字篩選器:
- 不等式和不等式 (例如「小於」和「大於」)。
- INEQUALITY OR INEQUALITY (例如「小於」或「大於」)。
- 是 OR 是。
- 只有在下列情況下,才支援多個日期和日期時間篩選器:
is on or after AND is beforeis or is
Power Query 函式
下列資料表函式無法摺疊:
Table.DistinctTable.JoinTable.NestedJoinTable.Skip
疑難排解
以下各節說明常見問題和解決方法。
Looker-Power BI 連接器未顯示在 Power BI 的「取得資料」清單中
確認 [Documents]\Microsoft Power BI Desktop\Custom Connectors 目錄包含 looker_1.4.3.mez 檔案。
- 在 Power BI Desktop 中,驗證安全性設定:
- 依序選取「檔案」>「選項和設定」>「選項」。
- 選取「安全性」。
- 在「資料擴充功能」下方,選取「(不建議) 允許載入任何擴充功能,不進行驗證或顯示警告」。
- 按一下 [確定]。
- 重新啟動 Power BI Desktop。
錯誤:欄位名稱只能使用英文字母、數字和底線
在某些情況下,重新整理資料或套用變更時,可能會收到下列錯誤訊息:
DataSource.Error
Message: A LookML model issue has occurred.
Details: Invalid field name "...". Field names may only include letters, numbers and underscores and must start with a letter or underscore for Google BigQuery Standard SQL
如果資料欄名稱含有基礎資料庫 (例如 BigQuery) 不支援的空格或特殊字元,就會發生這項錯誤。
如要解決這個問題,請按照下列步驟操作:
- 找出造成錯誤的資料欄 (通常會在錯誤訊息的
Details部分中提及)。 - 重新命名資料欄,只使用英文字母、數字和底線。
- 不正確做法:
Custom Column Name - 正確:
Custom_Column_Name
- 不正確做法:
錯誤:擷取這個圖表的資料時發生錯誤
在某些情況下,Power BI 可能會顯示驗證錯誤訊息,指出 OAuth 失敗或憑證問題,例如 Looker database authentication required。
如果看到這則錯誤訊息,表示 Looker 帳戶缺少資料庫連線所需的 OAuth 憑證。如要解決這個問題,請按照下列步驟操作:
- 登入 Looker 執行個體。
- 選取使用者個人資料圖示,然後選取「帳戶」。
- 前往「OAuth Connection Credentials」(OAuth 連線憑證) 專區。
- 找出要存取的連結,然後選取「登入」。
- 返回 Power BI Desktop 並重新整理資料。
Looker–Power BI Connector 異動記錄
以下各節說明 Looker-Power BI 連接器各版本的更新內容:
1.4.3 版
Looker-Power BI Connector 1.4.3 版有下列更新:
- 連接器標籤現在包含連接器版本號碼。
- 新增「啟用記錄」選項,可動態啟用連接器中的診斷記錄,以便排解問題。
- 新增「顯示隱藏的探索和欄位」選項。啟用後,系統會顯示隱藏的探索和欄位。這會取代先前的「顯示隱藏欄位」選項。
Looker-Power BI Connector 1.4.3 版修正了下列錯誤:
- 修正字串串連 DAX 運算子 (
&) 失敗的問題。 - 修正問題:將 Power BI 測量指標套用至 Looker 測量指標時會發生錯誤。
- 「憑證設定」選單現在會再次顯示 Looker 圖示。
1.4.2 版
Looker–Power BI Connector 1.4.2 版有下列更新:
- 「停用預覽最佳化」連線設定已移除。
- 「顯示隱藏欄位」連線選項已移至「進階選項」部分。
- Beta 版標記已移除,連接器在 Power BI 中不再顯示為 Beta 版。
Looker–Power BI Connector 1.4.2 版修正了下列錯誤:
- 修正迴歸錯誤,解決 Power BI 中布林值交叉分析篩選器和日期交叉分析篩選器失敗的問題。
- 修正
is-not篩選器不適用於dates篩選器的問題。
1.4.0 版
Looker–Power BI Connector 1.4.0 版有下列更新:
- 新增匯入模式支援
- 已啟用資料預覽
- 改善執行
SELECT *查詢時的行為 - 提高 Looker 快取命中率
- 改善篩選器建議擷取效能
Looker–Power BI 連接器 1.4.0 版修正了下列錯誤:
- 修正錯誤:Looker 無法偵測到篩選器和參數欄位已傳遞值
- 修正篩選器有時不會顯示參數建議值的錯誤
- 修正 LookML 陳述式會忽略液體變數的錯誤
- 修正 Power BI 矩陣檢視畫面中,不重複計數測量值不一致的錯誤
1.3.1 版
Looker - Power BI 連接器 1.3.1 版有下列更新:
- 新增顯示隱藏欄位的選項
Looker–Power BI Connector 1.3.1 版修正了下列錯誤:
- 修正錯誤:如果視覺效果和報表都有篩選器,視覺效果會失敗
1.3.0 版
Looker - Power BI 連接器 1.3.0 版有下列更新:
- 簡化日期時間格式
- 加強偵測不支援的文字運算式
- 改善錯誤訊息回報
Looker - Power BI 連接器 1.3.0 版修正了下列錯誤:
- 改善篩選器值中逸出字元的支援
1.2.0 版
Looker–Power BI 連接器 1.2.0 版有下列更新:
- 現已支援參數和篩選器限定欄位
- 進階篩選器支援文字、數字、日期和日期時間類型的篩選器限定欄位
- 支援基本篩選器,可使用 Looker 建議值篩選限定欄位