Com o conector do Looker para Power BI, você pode usar o Microsoft Power BI Desktop para se conectar aos dados de uma Análise do Looker.
O conector do Looker para Power BI foi projetado para ser usado com o modo DirectQuery do Power BI.
Quando você usa o conector do Looker para Power BI no modo DirectQuery, o Power BI não importa nem copia seus dados. Em vez disso, o Power BI gera uma expressão Power Query M para cada visualização, filtro e cálculo DAX. O conector do Looker para o Power BI traduz essas expressões em consultas em tempo real usando a API Looker.
Esse processo depende da dobra de consulta do Power BI. Se a consulta usar uma função que não é compatível com o conector do Looker para Power BI, a dobra de consulta será interrompida. Quando a dobragem de consultas é interrompida, o Power BI faz o download de todos os dados para calcular os resultados localmente, o que atrasa o carregamento do relatório e aumenta o uso da rede.
Como configurar o Power BI Desktop para se conectar ao Looker
As etapas gerais para usar o conector do Looker para Power BI são as seguintes:
- Verifique os requisitos.
- Ative o conector na sua instância do Looker.
- Baixar e salvar o arquivo do conector: cada usuário que quiser acessar o conector do Looker para o Power BI precisa baixar o arquivo
looker_1.4.3.meze salvá-lo em um diretório específico no computador. - Configurar o Power BI Desktop para um conector personalizado: cada usuário do Power BI precisa definir as configurações de segurança do Power BI Desktop para usar um conector personalizado não certificado.
As seções desta página descrevem essas etapas em detalhes.
Depois de concluir as etapas para conectar o Looker ao Power BI Desktop, você pode se conectar aos dados do Looker no Power BI e publicar relatórios no Power BI. Se quiser, use o serviço do Power BI (Power BI on-line) para interagir com seus relatórios do Looker em um navegador da Web. Também é possível publicar relatórios com o serviço do Power BI usando a segurança no nível da linha.
Requisitos
Para configurar o conector do Looker para o Power BI, você precisa do seguinte:
- Microsoft Power BI Desktop instalado no computador.
- Uma conta de usuário do Looker na instância do Looker com a permissão
explore, que é necessária para acessar as Análises no Looker. Se você quiser trabalhar com consultas com mais de 5.000 linhas, também precisará da permissãodownload_without_limit. Consulte Limites de linhas de consulta para mais informações sobre limites de download.
Além disso, sua instância do Looker precisa atender aos seguintes requisitos:
- Sua instância precisa estar ativada para o conector do Microsoft Power BI. Um administrador do Looker precisa ativar o cliente pré-configurado do Microsoft Power BI na guia Biblioteca de aplicativos na página Gerenciar clientes OAuth (Administrador > Autenticação > Gerenciar clientes OAuth) ou ativar a chave do Microsoft Power BI na página Conectores de BI do Looker.
- As instâncias do Looker (Google Cloud Core) configuradas para conexões particulares e as instâncias do Looker hospedadas pelo cliente precisam atender aos seguintes requisitos:
- A instância precisa estar executando o Looker 25.16 ou mais recente.
- O administrador da rede precisa configurar a rede para que o tráfego do conector do Looker para o Power BI possa chegar à instância do Looker.
Ativar o conector na instância do Looker
A instância do Looker que você quer usar com o conector do Looker para o Power BI precisa estar ativada para o conector do Microsoft Power BI:
- Para instâncias do Looker (Google Cloud Core), os conectores de BI são ativados por padrão.
- Nas instâncias do Looker (original), os conectores de BI ficam desativados por padrão.
O administrador do Looker pode ativar o cliente pré-configurado do Microsoft Power BI na guia Biblioteca de aplicativos na página Gerenciar clientes OAuth (Administrador > Autenticação > Gerenciar clientes OAuth) ou ativar os conectores de BI no painel "Conectores de BI" na seção Plataforma do menu Administrador do Looker.
Fazer o download e salvar o arquivo do conector
Para fazer o download do arquivo do conector, siga estas etapas no computador com o Microsoft Power BI Desktop instalado:
- Para fazer o download do arquivo do conector, clique no seguinte link:
looker_1.4.3.mez - Quando o download for concluído, mova o arquivo
looker_1.4.3.mezpara o diretório [Documents]\Microsoft Power BI Desktop\Custom Connectors. Crie as pastas no computador, se elas ainda não existirem.
Como configurar o Power BI Desktop para um conector personalizado
Para configurar o conector do Looker para o Power BI no Power BI Desktop, siga as instruções em Conectores personalizados no site do Microsoft Power BI.
Como dizem as instruções, em Extensões de dados, selecione a opção (Não recomendado) Permitir que qualquer extensão seja carregada sem validação ou aviso. Selecione OK e reinicie o Power BI Desktop.
Como se conectar aos dados do Looker no Power BI Desktop
Depois de fazer o download do arquivo do conector do looker_1.4.3.mez e configurar o aplicativo Power BI Desktop para um conector personalizado, use o Power BI Desktop para se conectar aos dados da sua instância do Looker:
- Na barra de ferramentas do Power BI Desktop, selecione Obter dados > Mais...
- Na caixa de diálogo Get Data, digite Looker no campo de pesquisa.
- Nos resultados da pesquisa, clique na entrada Looker e em Conectar.
- Na caixa de diálogo Conectar a um serviço de terceiros, clique em Continuar.
- O Power BI Desktop vai mostrar uma caixa de diálogo de login do Looker. No campo Host, digite o URL da instância. Por exemplo,
example.cloud.looker.com. Se quiser, clique em Opções avançadas para abrir a seção e configurar as seguintes opções adicionais:
- Use o menu suspenso Mostrar análises e campos ocultos para incluir análises e campos configurados como ocultos no LookML. Para mais informações, consulte a documentação sobre oculto (para análises) e oculto (para campos):
- FALSE (padrão): os campos ocultos são suprimidos.
- TRUE: os campos ocultos são mostrados.
- Use o menu suspenso Ativar geração de registros para ativar ou desativar os registros de diagnóstico no conector para fins de solução de problemas. Consulte a seção Ativar o registro de depuração para o Power BI Desktop para mais informações.
- Use o menu suspenso Mostrar análises e campos ocultos para incluir análises e campos configurados como ocultos no LookML. Para mais informações, consulte a documentação sobre oculto (para análises) e oculto (para campos):
Selecione a opção DirectQuery para criar uma conexão em tempo real com seus dados no Looker.
Clique em OK.
Na caixa de diálogo do Looker, clique em Fazer login.
Na tela de login do Looker, faça login na sua instância do Looker.
O Power BI Desktop vai retornar à caixa de diálogo de login do Looker, com uma mensagem informando que você fez login. Clique em Conectar.
O Power BI Desktop vai mostrar uma lista dos modelos do Looker que você pode acessar, cada um representado como uma pasta. Clique no modelo do Looker que você quer acessar e marque a caixa de seleção ao lado da Análise do Looker que você quer carregar no Power BI Desktop. Para ver um modelo, você precisa ter acesso de usuário ou de grupo do Looker a um conjunto de modelos que contenha o modelo. Para acessar as análises, você precisa ter a permissão
exploredo Looker.Clique em Carregar.
O Power BI Desktop vai preencher o painel Dados com os campos da Análise selecionada. Em seguida, use os dados do Looker da Análise para criar relatórios no Power BI Desktop. Consulte Como visualizar elementos do Looker no Power BI Desktop para saber como os elementos do Looker são exibidos pelo conector do Looker para Power BI.
Os nomes dos campos vão aparecer em uma única lista no formato ViewName.FieldName.
Como visualizar elementos do Looker no Power BI Desktop
Depois que você se conectar aos dados do Looker no Power BI Desktop, o painel Dados será preenchido com os campos da Análise selecionada.
O conector do Looker para Power BI usa o seguinte formato para exibir campos do Looker no Power BI Desktop:
ViewName.FieldType.FieldName
- O valor
ViewNameé a visualização do LookML em que o campo é definido. - O valor
FieldTypepode ser um dos seguintes tipos compatíveis com o conector do Looker para Power BI:dim: dimensão, um campo que representa um atributo, um fato ou um valor, como datas, nomes e IDs. As dimensões geralmente correspondem às colunas na tabela de dados subjacente. No LookML, as dimensões são definidas com o parâmetrodimension.mea: medida, um campo que representa informações mensuráveis sobre seus dados, como somas, contagens, médias, mínimos e máximos. No LookML, as medições são definidas com o parâmetromeasure.fil: filtro, um campo somente para filtros que é usado apenas para criar um filtro em uma consulta de Análise. Os campos de filtro não são incluídos no conjunto de resultados de uma consulta. No LookML, os filtros são definidos com o parâmetrofilter.par: parâmetro, um campo usado apenas para criar um filtro em uma consulta de Análise. Os campos de parâmetro não são incluídos no conjunto de resultados de uma consulta. Um parâmetro pode criar resultados de consulta interativos, rótulos, URLs e muito mais quando é definido com as variáveis líquidas{% parameter parameter_name %}eparameter_name._parameter_value. No LookML, os parâmetros são definidos com o parâmetroparameter.
- O valor
FieldNameé o nome do campo como ele é exibido na Análise do Looker.
O Power BI Desktop mostra os elementos do Looker exatamente como aparecem na Análise do Looker, com as mesmas letras maiúsculas e espaçamento entre palavras. Por exemplo, se uma Análise do Looker mostrar uma dimensão do LookML como Created Date de uma visualização exibida como Order Items, o Power BI Desktop vai mostrar esse campo como Order Items.dim.Created Date.
Criar consultas com dimensões e medições do Looker
O conector do Looker para Power BI permite usar dimensões e medições do Looker para criar consultas no Power BI Desktop.
Para criar uma consulta no Power BI Desktop usando dimensões e medições do Looker, siga estas etapas:
- Conecte-se aos dados do Looker no Power BI Desktop e aguarde o Power BI preencher o painel Dados com os campos da Análise do Looker selecionada.
- No painel Dados do Power BI, marque a caixa de seleção de cada dimensão ou métrica do Looker que você quer incluir na consulta.
Conforme você seleciona cada dimensão ou medida, o Power BI atualiza a consulta exibida na tela do relatório.
Como filtrar consultas com filtros e parâmetros do Looker
O conector do Looker para o Power BI permite usar parâmetros e campos somente para filtros do LookML de uma Análise do Looker para adicionar filtros ao seu relatório do Power BI.
Para filtrar um relatório no Power BI Desktop usando parâmetros do Looker e campos somente para filtro, siga estas etapas:
Se ainda não tiver feito isso, conecte-se aos dados do Looker no Power BI Desktop e aguarde o Power BI preencher o painel Dados com os campos da Análise do Looker selecionada.
No painel Dados do Power BI, arraste o nome de um parâmetro ou de um campo somente para filtros para uma das caixas Adicionar campos de dados aqui no painel Filtros, em Filtros nesta página ou em Filtros em todas as páginas. Consulte a documentação do Power BI para saber como adicionar filtros a um relatório no Power BI.
Observe o seguinte sobre o uso de parâmetros do Looker e campos somente para filtros no Power BI:
- Para campos somente para filtro configurados no LookML com o parâmetro
suggestionsousuggest_dimension, o Power BI vai buscar os valores de sugestão e mostrá-los nas opções de Filtragem básica no painel Filtros. Para parâmetros configurados no LookML com o atributo
allowed_value, o Power BI vai buscar todos os valores permitidos configurados no LookML para o parâmetro e os exibirá nas opções de Filtragem básica no painel Filtros.
Como usar o DAX com o conector do Looker para Power BI
DAX (Data Analysis Expressions) é uma linguagem de fórmulas usada no Power BI para criar cálculos personalizados.
O Power BI traduz as consultas DAX em expressões Power Query M e as envia para o conector do Looker para Power BI. O conector do Looker para Power BI traduz essas expressões M em chamadas de API Looker.
Se uma função DAX ou Power Query M não for compatível, a dobragem de consulta será interrompida. Quando isso acontece, o Power BI recupera toda a tabela bruta do Looker para processar a operação localmente, o que pode causar uma degradação significativa do desempenho. Consulte a seção Funções M do Power Query compatíveis para ver uma lista de funções compatíveis.
Medidas x colunas
O Power BI oferece duas maneiras principais de criar dados usando DAX: Nova medida e Nova coluna.
- Nova medida: o Power BI calcula esse valor dinâmico em tempo real quando você o usa em uma visualização. Este modelo não armazena esse valor. Use as medidas principalmente para agregar dados.
- Exemplo:
Total Sales = SUM('Sales'[Revenue])
- Exemplo:
- Nova coluna: o Power BI calcula esse valor estático linha por linha. Ele só é atualizado quando os dados são atualizados. O modelo armazena esse valor. Use colunas principalmente para categorizar dados.
- Exemplo:
Profit = 'Sales'[Revenue] - 'Sales'[Cost]
- Exemplo:
Criar uma medição
Para criar uma nova medida no Power BI, siga estas etapas:
- No painel Dados, clique com o botão direito do mouse na tabela em que você quer adicionar a medida.
- Selecione Nova medição.
- Na barra de fórmulas, insira sua fórmula DAX. Substitua
Measurepelo nome da medição selecionada.
Criar uma nova coluna
Para criar uma nova coluna no Power BI, siga estas etapas:
- No painel Dados, clique com o botão direito do mouse na tabela em que você quer adicionar a coluna.
- Selecione Nova coluna.
- Na barra de fórmulas, insira sua fórmula DAX. Substitua
Columnpelo nome da coluna selecionada.
Exemplos de consulta DAX
As tabelas a seguir mostram exemplos de consultas DAX para agregações comuns. Para mais informações, consulte a documentação do DAX.
A tabela a seguir mostra alguns exemplos de como criar medições para agregações comuns.
| Tipo de agregação | Exemplo |
|---|---|
| SUM | Total Sales = SUM('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MÉDIA | Average Sale Price = AVERAGE('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MÍNIMO | Minimum Sale Price = MIN('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MÁXIMO | Maximum Sale Price = MAX('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| COUNT | Order Count = COUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
| DISTINCTCOUNT | Distinct Order Count = DISTINCTCOUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
A tabela a seguir mostra como realizar operações aritméticas básicas.
| Tipo de agregação | Exemplo |
|---|---|
| Adição | Total Orders = [Shipped Orders] + [Pending Orders] |
| Subtração | Total Profit = [Total Sales] - [Total Cost] |
| Multiplicação | Total Sales with Tax = [Total Sales] * 1.05 |
| Divisão | Profit Margin = DIVIDE([Total Profit], [Total Sales]) |
| Energia | Sales Squared = POWER([Total Sales], 2)ou Sales Squared = [Total Sales] ^ 2 |
| Raiz quadrada | Square Root of Sales = SQRT([Total Sales]) |
| Módulo | Order ID Type = IF(MOD('The Look E-Commerce'[Order Items Ecomm.dim.Order ID], 2) = 0,"Even","Odd") |
| Valor absoluto | Absolute Profit = ABS([Total Profit]) |
Funções do Power Query M compatíveis
Quando você usa o conector do Looker para Power BI no modo DirectQuery, o Power BI gera uma expressão Power Query M para cada visualização, filtro e cálculo DAX. O conector do Looker para o Power BI traduz essas expressões em consultas em tempo real usando a API Looker.
Texto
Text.FromText.AtText.CombineText.Contains(Text.Containsdiferencia maiúsculas de minúsculas)Text.EndText.EndsWithText.LengthText.LowerText.UpperText.MiddleText.PositionOfText.RangeText.RemoveRangeText.ReplaceText.StartText.StartsWithText.InsertText.SplitText.FromBinary
Lista e tabela
Value.Equals/Value.NullableEqualsTable.RowCountTable.FirstTable.FirstNTable.SelectRowsTable.SortList.SumList.AverageList.MaxList.MinList.CountList.DistinctList.SelectList.ContainsList.AnyTrue
Numérico
Aritmética básica
Value.AddValue.SubtractValue.MultiplyValue.Divide
Matemática científica e avançada
Number.PowerNumber.SqrtNumber.ExpNumber.LnNumber.Log10Number.LogNumber.PI
Propriedades de número
Number.SignNumber.IsEvenNumber.IsOddNumber.Abs
Divisão e resto
Number.ModNumber.IntegerDivide
Geração de números aleatórios
Number.RandomNumber.RandomBetween
Conversões de tipos
O conector não permite o uso das seguintes funções de conversão numérica em visualizações:
Byte.FromCurrency.FromDecimal.FromInt8.From,Int16.From,Int32.From,Int64.FromNumber.From,Number.FromTextSingle.From,Double.From
Arredondamento numérico
Number.RoundNumber.RoundDownNumber.RoundUpNumber.RoundTowardZeroNumber.RoundAwayFromZero
A tabela a seguir mostra exemplos de cada operação de arredondamento:
| Entrada | Number.Round |
Number.RoundDown |
Number.RoundUp |
Number.RoundTowardZero |
Number.RoundAwayFromZero |
|---|---|---|---|---|---|
| 2.7 | 3 | 2 | 3 | 2 | 3 |
| 2.5 | 3 | 2 | 3 | 2 | 3 |
| 2.2 | 2 | 2 | 3 | 2 | 3 |
| 0 | 0 | 0 | 0 | 0 | 0 |
| -2,2 | -2 | -3 | -2 | -2 | -3 |
| -2,5 | -3 | -3 | -2 | -2 | -3 |
| -2,7 | -3 | -3 | -2 | -2 | -3 |
Data e hora
Como acessar a data e a hora atuais
DateTime.LocalNowDateTime.FixedLocalNowDateTimeZone.UtcNowDateTimeZone.FixedUtcNowDateTimeZone.LocalNowDateTimeZone.FixedLocalNow
Conversão de tipo de data e hora
DateTime.FromTextDateTimeZone.FromTextDateTime.FromDateTimeZone.FromDate.FromTextTime.ToText
Aritmética de data
Date.AddDaysDate.AddMonthsDate.AddYears
Extração de partes de data e hora
Date.DayDate.MonthDate.YearTime.HourTime.MinuteTime.SecondDateTime.Time
Limites de período de data e hora
Date.StartOfDayDate.StartOfYearDate.EndOfDayDate.EndOfYearTime.StartOfHourTime.EndOfHour
Funções de ordem superior
O conector do Looker para Power BI é compatível com as seguintes funções de ordem superior, desde que também seja compatível com as operações aninhadas.
Table.AddColumn- Restrição: o conector do Looker para Power BI precisa ser compatível com a função definida no parâmetro
columnGenerator. - Exemplo: a consulta a seguir funciona porque o conector do Looker para Power BI é compatível com a função aninhada
Text.Length:powerquery Table.AddColumn(LookerTable, "NewColumnName", each Text.Length([lookerTextDimensionColumn]))
- Restrição: o conector do Looker para Power BI precisa ser compatível com a função definida no parâmetro
Table.Group- Restrição: o conector do Looker para Power BI precisa ser compatível com todas as funções de agregação usadas na lista
aggregatedColumns. - Exemplo: a consulta a seguir funciona porque o conector do Looker para Power BI é compatível com a função aninhada
List.Sum:powerquery Table.Group(LookerTable, "CustomerID", {"total", each List.Sum([price])})
- Restrição: o conector do Looker para Power BI precisa ser compatível com todas as funções de agregação usadas na lista
Como usar medições do Looker no Power BI no modo DirectQuery
Muitas visualizações do Power BI que usam gráficos de colunas, barras e linhas exigem um valor agregado no eixo Y. O Power BI precisa de um único valor para determinar onde plotar o ponto de dados, como a altura de uma coluna ou a posição de uma linha. Sem uma agregação, a visualização não será renderizada.
Por exemplo, veja a visualização de uma medição do Looker de type: sum que mostra o custo total por item:

O Power BI não mostra uma medida type: sum na maioria das visualizações, a menos que você aplique uma agregação. Para mostrar a soma, defina a agregação do Power BI como Soma. Confira a visualização resultante no Power BI usando uma agregação de soma:

Da mesma forma, é possível usar a agregação de soma do Power BI para visualizar as medições do Looker que usam os seguintes tipos de agregação:
Como usar os recursos do Power BI com o conector do Looker para o Power BI
As seções a seguir descrevem o suporte do conector do Looker para Power BI para vários recursos do Power BI:
Sparkline
Adicione minigráficos a visualizações de tabela ou matriz. Para mais informações, consulte a documentação sobre minigráficos do Power BI.
Formatação condicional
A formatação condicional pode ser aplicada a visualizações de tabela ou matriz. O conector do Looker para Power BI é compatível com a formatação condicional para colunas numéricas, mas não para campos de texto. Para instruções gerais de configuração, consulte a documentação do Power BI.
Conversão de tipo
O conector do Looker para o Power BI não permite converter uma coluna em um número ou uma data em uma visualização. No entanto, o conector permite converter uma coluna em texto e usar esse campo em uma visualização.
Conectar-se ao Excel
É possível carregar dados do Looker diretamente no Excel para computador ou para Web. Para instruções de configuração, consulte a documentação do Power BI Conectar o Excel a conjuntos de dados do Power BI.
Ao usar o conector do Looker para Power BI no Excel, ele funciona de maneira semelhante ao modo DirectQuery no Power BI. Quando os dados são filtrados, o conector aplica o filtro na origem antes de carregar os dados no Excel.
É possível se conectar aos seus dados usando um dos seguintes métodos no Excel:
Inserir uma tabela dinâmica
Para inserir uma tabela dinâmica conectada diretamente ao conjunto de dados, siga estas etapas:
- Selecione a guia Inserir.
- Selecione Tabela dinâmica > Do Power BI.
Receber dados
Para importar os dados usando a faixa de opções Dados, siga estas etapas:
- Selecione a guia Dados.
- Selecione Obter dados > Do Fabric e da Power Platform > Do Power BI.
Como monitorar o conector do Looker para Power BI
Um administrador do Looker pode conferir o uso do conector do Looker para Power BI usando o grupo de campos Propriedades do cliente da API Query na Análise do histórico de atividades do sistema. Uma entrada é criada na Análise Histórico sempre que uma nova consulta é executada.
No grupo de campos Propriedades do cliente da API de consulta, o Nome do cliente da API mostra um valor Power BI para identificar as entradas do Conector do Looker para Power BI.
Veja a seguir um exemplo de URL de atividade do sistema que mostra o uso do Power BI. Substitua <instance_name.looker.com> pelo URL da instância.
https://<instance_name.looker.com>/explore/system__activity/history?fields=query_api_client_context.name,user.name,history.created_date,history.created_time_of_day&f[query_api_client_context.name]=Power+BI&sorts=history.created_time_of_day+desc&limit=5000
Serviço do Power BI
Depois de conectar os dados do Looker ao Power BI e publicar relatórios no Power BI, você pode usar o serviço do Power BI (Power BI on-line) para interagir com os relatórios do Looker em um navegador da Web.
Também é possível publicar relatórios com o serviço do Power BI usando a segurança no nível da linha.
Considerações sobre autenticação
Quando você publica um relatório no serviço do Power BI, as credenciais usadas para criar o relatório são incorporadas a ele. Essas credenciais são reutilizadas para todos os usuários que visualizam o relatório no serviço do Power BI.
Essa reutilização de credenciais ocorre porque o framework do conector do Microsoft Power BI não é compatível com a autenticação de Logon único (SSO) do usuário final para conectores personalizados. Para restringir o acesso aos dados com base no usuário que está visualizando o relatório, use a segurança no nível da linha (RLS) no Power BI.
Publicar um relatório com o serviço do Power BI usando a segurança no nível da linha
Depois de publicar relatórios no Power BI Desktop usando o conector do Looker para Power BI, você pode usar o serviço do Power BI para interagir com os relatórios em um navegador da web.
O Power BI Desktop permite usar a segurança no nível da linha (RLS, na sigla em inglês) para restringir o acesso aos dados de determinados usuários. Consulte a documentação do Power BI para saber como definir funções e regras e validar as funções no Power BI Desktop.
Depois de definir os papéis no Power BI Desktop, você pode usar os papéis e as regras on-line com o serviço do Power BI.
Para publicar um relatório com o serviço do Power BI usando a segurança no nível da linha, siga estas etapas:
- No Power BI Desktop, abra seu relatório e selecione o menu Página Inicial na parte de cima da janela.
- Selecione a opção Publicar no menu Início.
- Selecione um espaço de trabalho no menu suspenso e clique em Selecionar. O Power BI Desktop mostra uma mensagem de sucesso que inclui um link para abrir o relatório no Power BI.
- Clique no link para abrir o Power BI.
- No serviço do Power BI, acesse Workspaces e selecione o espaço de trabalho em que você publicou o relatório.
- Encontre a listagem do conjunto de dados do relatório (não o relatório em si).
- Na listagem do conjunto de dados, clique no menu de três pontos Mais opções e selecione Segurança.
O Power BI vai mostrar a janela Segurança no nível da linha. Nessa tela, você pode selecionar a função criada no Power BI Desktop, adicionar pessoas ou grupos que pertencem à função e validar suas funções no serviço do Power BI.
Agora você pode compartilhar o relatório com quem quiser, e as pessoas vão ver apenas os dados que têm permissão para acessar, com base nas funções que você criou.
Como ativar a geração de registros de depuração para o Power BI Desktop
Para resolver problemas ou diagnosticar um problema, ative a geração de registros para a conexão entre o Power BI e o Looker.
É preciso ativar a geração de registros para a conexão e também para o próprio Power BI, conforme descrito nas seções a seguir:
Como ativar a geração de registros no nível do conector
Para resolver problemas, ative o registro de diagnóstico no conector do Looker para o Power BI.
Ao criar uma nova conexão com os dados do Looker no Power BI Desktop, siga estas etapas para ativar a geração de registros:
- Na caixa de diálogo de conexão do Looker, abra as Opções avançadas.
- Selecione TRUE no menu suspenso Ativar geração de registros.
Se você já tiver criado uma conexão com os dados do Looker no Power BI Desktop, edite a consulta manualmente no editor de consultas do Power Query seguindo estas etapas:
- No Power BI Desktop, selecione Transformar dados.
- Na faixa de opções Página Inicial, selecione Editor Avançado.
- Localize a linha que começa com
Source = Looker.DataSource. Atualize o segundo argumento da função para incluir
EnableLogging=true.Looker.DataSource("instance.looker.com", [EnableLogging=true])Clique em Concluído.
Como ativar o rastreamento de nível do Power BI
Além de ativar a geração de registros na conexão com os dados do Looker no Power BI Desktop, você também precisa ativar o rastreamento no Power BI Desktop seguindo estas etapas:
- Selecione Arquivo > Opções e configurações > Opções.
- Na caixa de diálogo Opções, selecione Diagnóstico.
- Em Opções de diagnóstico, selecione Ativar rastreamento.
- Para ver os arquivos de registro, selecione Open crash dump/traces folder.
Informações importantes
Limites de linhas de consulta
As consultas do conector do Looker para o Power BI vão incluir automaticamente uma instrução LIMIT 5000, a menos que a conta de usuário do Looker tenha a permissão download_without_limit. Se a conta de usuário do Looker tiver download_without_limit, as consultas do conector do Looker para Power BI não terão um limite de linhas de consulta imposto.
Filtros de Análise
Se a Análise do Looker for definida com os parâmetros do LookML always_filter ou conditionally_filter, os filtros serão aplicados às consultas no conector do Looker para Power BI, mesmo que não estejam visíveis no Power BI.
Períodos de grupos de dimensões compatíveis
Para o dimension_group de type: time, apenas os períodos date e time são compatíveis com o conector do Looker para o Power BI. Os outros períodos vão ficar ocultos.
As análises de atividade do sistema não são mostradas com o conector do Looker para Power BI
As Análises da Atividade do Sistema não aparecem no conector do Looker para o Power BI. Os administradores do Looker podem ver as Análises da Atividade do Sistema diretamente na interface do Looker.
Limitações de conversão de tipo
Sempre que possível, é melhor definir os tipos de coluna na visualização do LookML.
Limitações conhecidas
Esteja ciente das seguintes limitações ao usar o conector do Looker para Power BI:
Modelagem e modos de dados
- Dimensões numéricas: as dimensões e as medidas numéricas aparecem como medidas no Power BI. Para usar uma dimensão numérica como uma dimensão, mude o resumo padrão para Não resumir no Power BI Desktop.
- Modo de importação: para um desempenho ideal, use o modo DirectQuery. Se você estiver usando o Modo de importação do Power BI, observe as seguintes restrições:
- Desempenho: os relatórios que acessam modelos grandes podem carregar lentamente.
- Tempo limite: se o processo "Obter dados" travar ou atingir o tempo limite, mude para o modo DirectQuery.
- Restrições de campo: o modo de importação desativa os campos somente para filtros e os campos de parâmetro.
- Avaliação de medições: o modo de importação impede que o Looker avalie medições na Análise, o que pode afetar a precisão dos relatórios.
Agregações
O Power BI aplica as próprias agregações às medidas do Looker. Isso pode causar erros ou resultados inconsistentes, principalmente em recursos visuais de matriz.
- Tipos aceitos: use apenas
average,count,count_distinct,max,minesum. - Tipos não aceitos: o conector não aceita consultas de desvio padrão, variância ou agregações de primeira ou última string em ordem alfabética.
- Desempenho mediano: o Power BI calcula a mediana localmente recuperando todos os valores. Isso é lento em conjuntos de dados grandes e pode expirar.
Filtragem e classificação
- Classificação por campos ocultos: não é possível classificar por um campo que não está incluído na visualização. Para ordenar por um campo, adicione-o à visualização.
- Limitações do filtro avançado: devido às diferenças entre o Power Query e as expressões de filtro do Looker, as seguintes limitações se aplicam:
- Texto: não é possível usar vários filtros de texto.
- Datas: para campos de data e data/hora, apenas
is,is not,is on or aftereis beforesão aceitos. - Vários filtros de número são aceitos apenas nos seguintes casos:
- DESIGUALDADE E DESIGUALDADE (por exemplo, é menor que E é maior que).
- DESIGUALDADE OU DESIGUALDADE (por exemplo, é menor que OU é maior que).
- é OU é.
- Vários filtros de data e data/hora são aceitos apenas nos seguintes casos:
is on or after AND is beforeis or is
Funções do Power Query
As seguintes funções de tabela não são dobráveis:
Table.DistinctTable.JoinTable.NestedJoinTable.Skip
Solução de problemas
As seções a seguir descrevem problemas comuns e as soluções para eles.
O conector do Looker para Power BI não aparece na lista Obter dados do Power BI
Verifique se o diretório [Documents]\Microsoft Power BI Desktop\Custom Connectors contém o arquivo looker_1.4.3.mez.
- No Power BI Desktop, verifique as configurações de segurança:
- Selecione Arquivo > Opções e configurações > Opções.
- Selecione Segurança.
- Em Extensões de dados, selecione (Não recomendado) Permitir que qualquer extensão seja carregada sem validação ou aviso.
- Clique em OK.
- Reinicie o Power BI Desktop.
Erro: os nomes dos campos só podem incluir letras, números e sublinhados
Em alguns casos, a seguinte mensagem de erro pode aparecer ao atualizar dados ou implementar mudanças:
DataSource.Error
Message: A LookML model issue has occurred.
Details: Invalid field name "...". Field names may only include letters, numbers and underscores and must start with a letter or underscore for Google BigQuery Standard SQL
Esse erro ocorre quando um nome de coluna contém espaços ou caracteres especiais que não são compatíveis com o banco de dados subjacente (como o BigQuery).
Para resolver o problema, siga estas etapas:
- Identifique a coluna que está causando o erro (geralmente referenciada na seção
Detailsda mensagem de erro). - Renomeie a coluna para usar apenas letras, números e sublinhados.
- Incorreto:
Custom Column Name - Correto:
Custom_Column_Name
- Incorreto:
Erro: erro ao buscar dados para este visual
Em alguns casos, você pode receber um erro de autenticação no Power BI que indica uma falha do OAuth ou um problema de credencial, como Looker database authentication required.
Se você receber esse erro, significa que sua conta do Looker não tem as credenciais OAuth necessárias para a conexão com o banco de dados. Para resolver o problema, siga estas etapas:
- Faça login na sua instância do Looker.
- Selecione o ícone do seu perfil de usuário e, em seguida, Conta.
- Acesse a seção Credenciais de conexão OAuth.
- Encontre a conexão que você está tentando acessar e selecione Fazer login.
- Volte ao Power BI Desktop e atualize os dados.
Registro de alterações do conector do Looker para o Power BI
As seções a seguir mostram as atualizações em cada versão do conector do Looker para Power BI:
Versão 1.4.3
A versão 1.4.3 do conector do Looker para Power BI tem as seguintes atualizações:
- O rótulo do conector agora inclui o número da versão do conector.
- Adicionamos uma nova opção Ativar geração de registros para ativar dinamicamente os registros de diagnóstico no conector para fins de solução de problemas.
- Adicionamos uma nova opção Mostrar análises e campos ocultos. Quando ativada, as análises e os campos ocultos são mostrados. Isso substitui a opção anterior Mostrar campos ocultos.
A versão 1.4.3 do conector do Looker para Power BI tem as seguintes correções de bugs:
- Correção de um problema em que o operador DAX de concatenação de strings (
&) falhava. - Correção do problema em que a aplicação de uma medida do Power BI a uma medida do Looker causava um erro.
- O menu "Configuração de credenciais" agora mostra o ícone do Looker novamente.
Versão 1.4.2
A versão 1.4.2 do conector do Looker para Power BI tem as seguintes atualizações:
- A configuração de conexão Desativar otimização de visualização foi removida.
- A opção de conexão Mostrar campos ocultos foi movida para a seção Opções avançadas.
- A sinalização Beta foi removida. O conector não aparece mais como Beta no Power BI.
A versão 1.4.2 do conector do Looker para o Power BI tem as seguintes correções de bugs:
- Corrigimos o erro de regressão em que as segmentações booleanas e de data falhavam no Power BI.
- Corrigimos o filtro
is-notque não funcionava para o filtrodates.
Versão 1.4.0
A versão 1.4.0 do conector do Looker para o Power BI tem as seguintes atualizações:
- Adição de suporte ao modo de importação
- Visualização de dados ativada
- Melhoria no comportamento ao realizar consultas
SELECT * - Melhoria na taxa de ocorrência em cache do Looker
- Melhoria no desempenho da recuperação de sugestões de filtro
A versão 1.4.0 do conector do Looker para Power BI tem as seguintes correções de bugs:
- Correção de um bug em que o Looker não detectava que os valores tinham sido transmitidos para campos de filtro e parâmetro
- Correção de um bug em que os valores sugeridos de parâmetros às vezes não apareciam nos controles de filtros.
- Correção de bug em que as variáveis líquidas eram ignoradas pelas instruções do LookML
- Correção de um bug em que os valores de medida de contagem distinta eram inconsistentes nas visualizações de matriz do Power BI
Versão 1.3.1
A versão 1.3.1 do conector do Looker para Power BI tem as seguintes atualizações:
- Adicionamos a opção de mostrar campos ocultos
A versão 1.3.1 do conector do Looker para Power BI tem a seguinte correção de bug:
- Correção de um bug em que um elemento visual falhava se houvesse um filtro no elemento e no relatório
Versão 1.3.0
A versão 1.3.0 do conector do Looker para Power BI tem as seguintes atualizações:
- Formatação simplificada de data e hora
- Melhoria na detecção de expressões de texto não compatíveis
- Relatórios de mensagens de erro aprimorados
A versão 1.3.0 do conector do Looker para Power BI tem a seguinte correção de bug:
- Melhoria na compatibilidade com caracteres de escape em valores de filtro
Versão 1.2.0
A versão 1.2.0 do conector do Looker para o Power BI tem as seguintes atualizações:
- Agora há suporte para campos de parâmetro e somente para filtro
- Suporte de filtros avançados para campos somente para filtros do tipo texto, número, data e data/hora
- Suporte básico para campos somente para filtros usando valores sugeridos do Looker