Conector de Looker a Power BI

El conector de Looker-Power BI te permite usar Microsoft Power BI Desktop para conectarte a los datos de una exploración de Looker.

El conector de Looker-Power BI está diseñado para usarse con el modo DirectQuery de Power BI.

Cuando usas el conector de Looker-Power BI en el modo DirectQuery, Power BI no importa ni copia tus datos. En su lugar, Power BI genera una expresión de Power Query M para cada visualización, filtro y cálculo de DAX. El conector de Looker-Power BI traduce estas expresiones en consultas en vivo con la API de Looker.

Este proceso se basa en el plegado de consultas de Power BI. Si tu consulta usa una función que el conector de Looker-Power BI no admite, se detiene el plegado de consultas. Cuando se detiene el plegado de consultas, Power BI descarga todos tus datos para calcular los resultados de forma local, lo que ralentiza la carga de informes y aumenta el uso de la red.

Configura Power BI Desktop para conectarte a Looker

Los pasos generales para usar el conector de Looker a Power BI son los siguientes:

  1. Verifica los requisitos.
  2. Habilita el conector en tu instancia de Looker.
  3. Descarga y guarda el archivo del conector: Cada usuario que quiera acceder al conector de Looker-Power BI debe descargar el archivo looker_1.4.3.mez y guardarlo en un directorio específico de su computadora.
  4. Configura Power BI Desktop para un conector personalizado: Cada usuario de Power BI debe establecer la configuración de seguridad de Power BI Desktop para usar un conector personalizado no certificado.

En las secciones de esta página, se describen estos pasos en detalle.

Después de completar los pasos para conectar Looker con Power BI Desktop, puedes conectarte a los datos de Looker desde Power BI y publicar informes en Power BI. De manera opcional, puedes usar el servicio de Power BI (Power BI en línea) para interactuar con tus informes de Looker en un navegador web. También puedes publicar informes con el servicio de Power BI usando la seguridad a nivel de fila.

Requisitos

Para configurar el conector de Looker-Power BI, necesitas lo siguiente:

  • Microsoft Power BI Desktop instalado en tu computadora
  • Una cuenta de usuario de Looker en la instancia de Looker con el permiso explore, que se requiere para acceder a las exploraciones en Looker. Si quieres trabajar con consultas de más de 5,000 filas, también necesitas el permiso download_without_limit (consulta Límites de filas de consultas para obtener información sobre los límites de descarga).

Además, tu instancia de Looker debe cumplir con los siguientes requisitos:

Habilita el conector en tu instancia de Looker

La instancia de Looker que quieras usar con el conector de Looker-Power BI debe estar habilitada para el conector de Microsoft Power BI:

  • En el caso de las instancias de Looker (Google Cloud Core), los conectores de IE están habilitados de forma predeterminada.
  • En las instancias de Looker (original), los conectores de IE están inhabilitados de forma predeterminada.

Tu administrador de Looker puede habilitar el cliente de Microsoft Power BI preconfigurado desde la pestaña Biblioteca de aplicaciones en la página Administrar clientes de OAuth (Administrador > Autenticación > Administrar clientes de OAuth) o habilitar los conectores de IE en el panel Conectores de BI en la sección Plataforma del menú Administrador de Looker.

Descarga y guarda el archivo del conector

Para descargar el archivo del conector, sigue estos pasos en la computadora que tiene instalado Microsoft Power BI Desktop:

  1. Para descargar el archivo del conector, haz clic en el siguiente vínculo: looker_1.4.3.mez
  2. Cuando se complete la descarga, mueve el archivo looker_1.4.3.mez al directorio [Documents]\Microsoft Power BI Desktop\Custom Connectors. (Crea las carpetas en tu computadora si aún no existen).

Configura Power BI Desktop para un conector personalizado

Para configurar el conector de Looker-Power BI en el lado de Power BI Desktop, sigue las instrucciones de Conectores personalizados en el sitio web de Microsoft Power BI.

Como se indica en las instrucciones, en Extensiones de datos, selecciona la opción (No recomendado) Permitir que se cargue cualquier extensión sin validación ni advertencia. Selecciona Aceptar y, luego, reinicia Power BI Desktop.

Conéctate a los datos de Looker desde Power BI Desktop

Una vez que hayas descargado el archivo del conector de looker_1.4.3.mez y configurado la aplicación de Power BI Desktop para un conector personalizado, puedes usar Power BI Desktop para conectarte a los datos de tu instancia de Looker:

  1. En la barra de herramientas de Power BI Desktop, selecciona Obtener datos > Más…
  2. En el cuadro de diálogo Obtener datos, ingresa Looker en el campo de búsqueda.
  3. En los resultados de la búsqueda, haz clic en la entrada Looker y, luego, en Conectar.
  4. En el cuadro de diálogo Conexión a un servicio de terceros, haz clic en Continuar.
  5. Power BI Desktop mostrará un diálogo de acceso de Looker. En el campo Host, escribe la URL de tu instancia. Por ejemplo: example.cloud.looker.com.
  6. De manera opcional, haz clic en Opciones avanzadas para expandir la sección y configurar las siguientes opciones adicionales:

    • Usa el menú desplegable Mostrar exploraciones y campos ocultos para incluir exploraciones y campos que están configurados como ocultos en LookML (para obtener más información, consulta la documentación de hidden (para exploraciones) y hidden (para campos)):
      • FALSE (predeterminado): Se suprimen los campos ocultos.
      • TRUE: Se muestran los campos ocultos.
    • Usa el menú desplegable Habilitar registro para habilitar o inhabilitar los registros de diagnóstico en el conector con fines de solución de problemas. Consulta la sección Habilita el registro de depuración para Power BI Desktop para obtener más información.
  7. Selecciona la opción DirectQuery para crear una conexión en vivo con tus datos en Looker.

  8. Haz clic en Aceptar.

  9. En el cuadro de diálogo de Looker, haz clic en Acceder.

  10. En la pantalla de acceso de Looker, accede a tu instancia de Looker.

  11. Power BI Desktop volverá al diálogo de acceso de Looker, con un mensaje que indica que accediste. Haz clic en Conectar.

  12. Power BI Desktop mostrará una lista de los modelos de Looker a los que tienes acceso, cada uno representado como una carpeta. Haz clic en el modelo de Looker al que deseas acceder y, luego, selecciona la casilla de verificación junto a la exploración de Looker que deseas cargar en Power BI Desktop. Para ver un modelo, debes tener acceso de usuario o de grupo de Looker a un conjunto de modelos que contenga el modelo. Para acceder a las exploraciones, debes tener el permiso explore de Looker.

  13. Haz clic en Cargar.

Power BI Desktop propagará su panel Datos con los campos de la exploración que seleccionaste. Luego, puedes usar los datos de Looker de la exploración para crear informes en Power BI Desktop. Consulta Cómo ver elementos de Looker en Power BI Desktop para obtener información sobre cómo el conector de Looker-Power BI muestra los elementos de Looker.

Los nombres de los campos aparecerán en una sola lista con el formato ViewName.FieldName.

Visualiza elementos de Looker en Power BI Desktop

Después de conectarte a los datos de Looker desde Power BI Desktop, Power BI Desktop propagará su panel Datos con los campos de la exploración que seleccionaste.

El conector de Looker-Power BI usa el siguiente formato para mostrar los campos de Looker en Power BI Desktop:

ViewName.FieldType.FieldName

  • El valor ViewName es la vista de LookML en la que se define el campo.
  • El valor FieldType puede ser uno de los siguientes tipos compatibles con el conector de Looker-Power BI:
    • dim: Dimensión, un campo que representa un atributo, un hecho o un valor, como fechas, nombres y IDs. A menudo, las dimensiones corresponden a las columnas de tu tabla de datos subyacente. En LookML, las dimensiones se definen con el parámetro dimension.
    • mea: Medición, un campo que representa información medible sobre tus datos, como sumas, recuentos, promedios, mínimos y máximos. En LookML, las mediciones se definen con el parámetro measure.
    • fil: Filtro, un campo solo de filtro que se usa únicamente para crear un filtro en una consulta de Explorar; los campos de filtro no se incluyen en el conjunto de resultados de una consulta. En LookML, los filtros se definen con el parámetro filter.
    • par: Parámetro, un campo que solo se usa para crear un filtro en una consulta de exploración; los campos de parámetro no se incluyen en el conjunto de resultados de una consulta. Un parámetro puede crear resultados de consultas, etiquetas, URLs y mucho más interactivos cuando se define con las variables de Liquid {% parameter parameter_name %} y parameter_name._parameter_value. En LookML, los parámetros se definen con el parámetro parameter.
  • El valor FieldName es el nombre del campo tal como se muestra en la exploración de Looker.

Power BI Desktop muestra los elementos de Looker tal como se muestran en la exploración de Looker, con el mismo uso de mayúsculas y espaciado de palabras. Por ejemplo, si una exploración de Looker muestra una dimensión de LookML como Created Date de una vista que se muestra como Order Items, Power BI Desktop mostrará este campo como Order Items.dim.Created Date.

Crear consultas con dimensiones y mediciones de Looker

El conector de Looker para Power BI te permite usar las dimensiones y mediciones de Looker para crear consultas en Power BI Desktop.

Para crear una consulta en Power BI Desktop con dimensiones y mediciones de Looker, sigue estos pasos:

  1. Conéctate a los datos de Looker desde Power BI Desktop y espera a que Power BI complete su panel Datos con los campos de la exploración de Looker que seleccionaste.
  2. En el panel Datos de Power BI, selecciona la casilla de verificación de cada dimensión o medición de Looker que quieras incluir en la consulta.

A medida que selecciones cada dimensión o medida, Power BI actualizará la consulta que se muestra en el lienzo del informe.

Filtra consultas con filtros y parámetros de Looker

El conector de Looker-Power BI te permite usar parámetros de LookML y campos de solo filtro de una exploración de Looker para agregar filtros a tu informe de Power BI.

Para filtrar un informe en Power BI Desktop con parámetros de Looker y campos de solo filtro, sigue estos pasos:

  1. Si aún no lo hiciste, conéctate a los datos de Looker desde Power BI Desktop y espera a que Power BI complete su panel Datos con los campos de la exploración de Looker que seleccionaste.

  2. En el panel Datos de Power BI, arrastra el nombre de un parámetro o un campo solo de filtro a uno de los cuadros Agregar campos de datos aquí del panel Filtros, ya sea para Filtros en esta página o para Filtros en todas las páginas. Consulta la documentación de Power BI para obtener detalles sobre cómo agregar filtros a un informe en Power BI.

Ten en cuenta lo siguiente sobre el uso de parámetros de Looker y campos de solo filtro en Power BI:

  • Para los campos de solo filtro que se configuran en LookML con el parámetro suggestions o el parámetro suggest_dimension, Power BI recuperará los valores de sugerencia y los mostrará en las opciones de Filtrado básico del panel Filtros.
  • En el caso de los parámetros que se configuran en LookML con el atributo allowed_value, Power BI recuperará todos los valores permitidos que se configuran en LookML para el parámetro y los mostrará en las opciones de Filtrado básico del panel Filtros.

Usa DAX con el conector de Looker a Power BI

DAX (Expresiones de análisis de datos) es un lenguaje de fórmulas que se usa en Power BI para crear cálculos personalizados.

Power BI traduce las consultas de DAX en expresiones de Power Query M y las envía al conector de Looker-Power BI. Luego, el conector de Looker a Power BI traduce estas expresiones de M en llamadas a la API de Looker.

Si no se admite una función de DAX o Power Query M, se detiene el plegado de consultas. Cuando esto sucede, Power BI recupera toda la tabla sin procesar de Looker para procesar la operación de forma local, lo que puede causar una degradación significativa del rendimiento. Consulta la sección Funciones de Power Query M compatibles para obtener una lista de las funciones compatibles.

Mediciones en comparación con columnas

Power BI proporciona dos formas principales de crear datos nuevos con DAX: Nueva medida y Nueva columna.

  • Nueva medición: Power BI calcula este valor dinámico sobre la marcha cuando lo usas en una visualización. Este modelo no almacena este valor. Usa medidas principalmente para agregar datos.
    • Ejemplo: Total Sales = SUM('Sales'[Revenue])
  • Nueva columna: Power BI calcula este valor estático fila por fila. Solo se actualiza cuando se actualizan los datos. El modelo almacena este valor. Usa columnas principalmente para categorizar datos.
    • Ejemplo: Profit = 'Sales'[Revenue] - 'Sales'[Cost]

Crea una medición nueva

Para crear una nueva medida en Power BI, sigue estos pasos:

  1. En el panel Datos, haz clic con el botón derecho en la tabla en la que quieres agregar la medición.
  2. Selecciona Nueva medición.
  3. En la barra de fórmulas, ingresa tu fórmula DAX. Reemplaza Measure por el nombre de la medición que seleccionaste.

Crea una columna nueva

Para crear una columna nueva en Power BI, sigue estos pasos:

  1. En el panel Datos, haz clic con el botón derecho en la tabla en la que quieres agregar la columna.
  2. Selecciona Nueva columna.
  3. En la barra de fórmulas, ingresa tu fórmula DAX. Reemplaza Column por el nombre de la columna que seleccionaste.

Ejemplos de consultas de DAX

En las siguientes tablas, se proporcionan ejemplos de consultas de DAX para agregaciones comunes. Para obtener más información, consulta la documentación de DAX.

En la siguiente tabla, se proporcionan algunos ejemplos de cómo crear mediciones para agregaciones comunes.

Tipo de agregación Ejemplo
SUM Total Sales = SUM('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
AVERAGE Average Sale Price = AVERAGE('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
MIN Minimum Sale Price = MIN('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
MAX Maximum Sale Price = MAX('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
COUNT Order Count = COUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID])
DISTINCTCOUNT Distinct Order Count = DISTINCTCOUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID])

En la siguiente tabla, se muestra cómo realizar operaciones aritméticas básicas.

Tipo de agregación Ejemplo
Suma Total Orders = [Shipped Orders] + [Pending Orders]
Resta Total Profit = [Total Sales] - [Total Cost]
Multiplicación Total Sales with Tax = [Total Sales] * 1.05
División Profit Margin = DIVIDE([Total Profit], [Total Sales])
Potencia Sales Squared = POWER([Total Sales], 2)
o
Sales Squared = [Total Sales] ^ 2
Raíz cuadrada Square Root of Sales = SQRT([Total Sales])
Módulo Order ID Type =
IF(
MOD('The Look E-Commerce'[Order Items Ecomm.dim.Order ID], 2) = 0,
"Even",
"Odd"
)
Valor absoluto Absolute Profit = ABS([Total Profit])

Funciones de Power Query M compatibles

Cuando usas el conector de Looker para Power BI en el modo DirectQuery, Power BI genera una expresión de Power Query M para cada visualización, filtro y cálculo de DAX. El conector de Looker-Power BI traduce estas expresiones en consultas en vivo con la API de Looker.

Texto

  • Text.From
  • Text.At
  • Text.Combine
  • Text.Contains (Text.Contains distingue mayúsculas de minúsculas)
  • Text.End
  • Text.EndsWith
  • Text.Length
  • Text.Lower
  • Text.Upper
  • Text.Middle
  • Text.PositionOf
  • Text.Range
  • Text.RemoveRange
  • Text.Replace
  • Text.Start
  • Text.StartsWith
  • Text.Insert
  • Text.Split
  • Text.FromBinary

Lista y tabla

  • Value.Equals/Value.NullableEquals
  • Table.RowCount
  • Table.First
  • Table.FirstN
  • Table.SelectRows
  • Table.Sort
  • List.Sum
  • List.Average
  • List.Max
  • List.Min
  • List.Count
  • List.Distinct
  • List.Select
  • List.Contains
  • List.AnyTrue

Numérico

Aritmética básica
  • Value.Add
  • Value.Subtract
  • Value.Multiply
  • Value.Divide
Matemáticas científicas y avanzadas
  • Number.Power
  • Number.Sqrt
  • Number.Exp
  • Number.Ln
  • Number.Log10
  • Number.Log
  • Number.PI
Propiedades de números
  • Number.Sign
  • Number.IsEven
  • Number.IsOdd
  • Number.Abs
División y resto
  • Number.Mod
  • Number.IntegerDivide
Generación de números al azar
  • Number.Random
  • Number.RandomBetween
Tipos de conversiones

El conector no admite el uso de las siguientes funciones de conversión numérica en las visualizaciones:

  • Byte.From
  • Currency.From
  • Decimal.From
  • Int8.From, Int16.From, Int32.From, Int64.From
  • Number.From, Number.FromText
  • Single.From, Double.From

Redondeo numérico

  • Number.Round
  • Number.RoundDown
  • Number.RoundUp
  • Number.RoundTowardZero
  • Number.RoundAwayFromZero

En la siguiente tabla, se muestran ejemplos de cada operación de redondeo:

Entrada Number.Round Number.RoundDown Number.RoundUp Number.RoundTowardZero Number.RoundAwayFromZero
2.7 3 2 3 2 3
2.5 3 2 3 2 3
2.2 2 2 3 2 3
0 0 0 0 0 0
-2.2 -2 -3 -2 -2 -3
-2.5 -3 -3 -2 -2 -3
-2.7 -3 -3 -2 -2 -3

Fecha y hora

Obteniendo la fecha y hora actuales
  • DateTime.LocalNow
  • DateTime.FixedLocalNow
  • DateTimeZone.UtcNow
  • DateTimeZone.FixedUtcNow
  • DateTimeZone.LocalNow
  • DateTimeZone.FixedLocalNow
Conversión de tipo de fecha y hora
  • DateTime.FromText
  • DateTimeZone.FromText
  • DateTime.From
  • DateTimeZone.From
  • Date.FromText
  • Time.ToText
Aritmética de fechas
  • Date.AddDays
  • Date.AddMonths
  • Date.AddYears
Extrae partes de fecha y hora
  • Date.Day
  • Date.Month
  • Date.Year
  • Time.Hour
  • Time.Minute
  • Time.Second
  • DateTime.Time
Límites de períodos de fecha y hora
  • Date.StartOfDay
  • Date.StartOfYear
  • Date.EndOfDay
  • Date.EndOfYear
  • Time.StartOfHour
  • Time.EndOfHour

Funciones de orden superior

El conector de Looker-Power BI admite las siguientes funciones de orden superior, siempre que el conector de Looker-Power BI también admita las operaciones anidadas.

  • Table.AddColumn

    • Restricción: El conector de Looker-Power BI debe admitir la función que se define en el parámetro columnGenerator.
    • Ejemplo: La siguiente consulta funciona porque el conector de Looker-Power BI admite la función anidada Text.Length: powerquery Table.AddColumn(LookerTable, "NewColumnName", each Text.Length([lookerTextDimensionColumn]))
  • Table.Group

    • Restricción: El conector de Looker para Power BI debe admitir cualquier función de agregación que se use en la lista aggregatedColumns.
    • Ejemplo: La siguiente consulta funciona porque el conector de Looker-Power BI admite la función anidada List.Sum: powerquery Table.Group(LookerTable, "CustomerID", {"total", each List.Sum([price])})

Usa las mediciones de Looker en Power BI en el modo DirectQuery

Muchas visualizaciones de Power BI que usan gráficos de columnas, barras y líneas requieren un valor agregado en el eje Y. Power BI necesita un solo valor para determinar dónde trazar el punto de datos, como la altura de una columna o la posición de una línea. Sin una agregación, la visualización no se renderizará.

Por ejemplo, aquí se muestra la visualización de una medición de Looker de type: sum que muestra el costo total por artículo:

Visualización de Looker del costo total por artículo

Power BI no mostrará una medida type: sum en la mayoría de las visualizaciones, a menos que apliques una agregación. Para mostrar la suma, puedes establecer la agregación de Power BI en Suma. Esta es la visualización resultante en Power BI con una agregación de suma:

Visualización de suma de Power BI

Del mismo modo, puedes usar la agregación de suma de Power BI para visualizar las mediciones de Looker que usan los siguientes tipos de agregación:

Usa las funciones de Power BI con el conector de Looker-Power BI

En las siguientes secciones, se describe la compatibilidad del conector de Looker-Power BI con varias funciones de Power BI:

Sparkline

Agregar minigráficos a las visualizaciones de tablas o matrices Para obtener más información, consulta la documentación sobre minigráficos de Power BI.

Formato condicional

El formato condicional se puede aplicar a las visualizaciones de tablas o matrices. El conector de Looker para Power BI admite el formato condicional para las columnas numéricas, pero no para los campos de texto. Para obtener instrucciones de configuración generales, consulta la documentación de Power BI.

Conversión de tipos

El conector de Looker-Power BI no admite la conversión de una columna en un número o una fecha dentro de una visualización. Sin embargo, el conector admite la conversión de una columna en texto y el uso de ese campo en una visualización.

Conéctate con Excel

Puedes cargar datos de Looker directamente en Excel para computadoras o Excel para la Web. Para obtener instrucciones de configuración, consulta la documentación de Power BI sobre cómo conectar Excel a conjuntos de datos de Power BI.

Cuando usas el conector de Looker para Power BI en Excel, funciona de manera similar al modo DirectQuery en Power BI. Cuando se filtran los datos, el conector aplica el filtro en la fuente antes de cargar los datos en Excel.

Puedes conectarte a tus datos con uno de los siguientes métodos en Excel:

Insertar una tabla dinámica

Para insertar una tabla dinámica que esté conectada directamente al conjunto de datos, sigue estos pasos:

  1. Selecciona la pestaña Insertar.
  2. Selecciona Tabla dinámica > Desde Power BI.

Obtén datos

Para importar los datos con la cinta Datos, sigue estos pasos:

  1. Selecciona la pestaña Datos.
  2. Selecciona Get Data > From Fabric & Power Platform > From Power BI.

Supervisa el conector de Looker-Power BI

Un administrador de Looker puede ver el uso del conector de Looker-Power BI con el grupo de campos Propiedades del cliente de la API de consultas en la exploración del historial de actividad del sistema. Se crea una entrada en la exploración Historial cada vez que se ejecuta una consulta nueva.

En el grupo de campos Propiedades del cliente de la API de consulta, el Nombre del cliente de la API muestra un valor Power BI para identificar las entradas del conector de Looker-Power BI.

A continuación, se muestra un ejemplo de una URL de actividad del sistema que indica el uso de Power BI. Reemplaza <instance_name.looker.com> por la URL de tu instancia.

https://<instance_name.looker.com>/explore/system__activity/history?fields=query_api_client_context.name,user.name,history.created_date,history.created_time_of_day&f[query_api_client_context.name]=Power+BI&sorts=history.created_time_of_day+desc&limit=5000

Servicio de Power BI

Después de conectarte a los datos de Looker desde Power BI y publicar informes en Power BI, puedes usar opcionalmente el servicio de Power BI (Power BI en línea) para interactuar con tus informes de Looker en un navegador web.

También puedes publicar informes con el servicio de Power BI usando la seguridad a nivel de fila.

Consideraciones sobre la autenticación

Cuando publicas un informe en el servicio de Power BI, las credenciales que usaste para crearlo se incorporan en él. Estas credenciales se reutilizan para todos los usuarios que ven el informe en el servicio de Power BI.

Esta reutilización de credenciales se produce porque el framework del conector de Microsoft Power BI no admite la autenticación de inicio de sesión único (SSO) del usuario final para los conectores personalizados. Para restringir el acceso a los datos según el usuario que visualiza el informe, usa la seguridad a nivel de fila (RLS) en Power BI.

Publicar un informe con el servicio de Power BI usando la seguridad a nivel de fila

Después de publicar informes en Power BI Desktop con el conector de Looker-Power BI, puedes usar el servicio de Power BI para interactuar con los informes desde un navegador web.

Power BI Desktop te permite usar la seguridad a nivel de fila (RLS) para restringir el acceso a los datos de ciertos usuarios. Consulta la documentación de Power BI para conocer los procedimientos para definir roles y reglas y validar los roles en Power BI Desktop.

Una vez que definas los roles en Power BI Desktop, podrás usarlos junto con las reglas en línea con el servicio de Power BI.

Para publicar un informe con el servicio de Power BI usando la seguridad a nivel de fila, sigue estos pasos:

  1. En Power BI Desktop, abre tu informe y selecciona el menú Inicio en la parte superior de la ventana.
  2. Selecciona la opción Publicar en el menú Página principal.
  3. Selecciona un espacio de trabajo en el menú desplegable y, luego, haz clic en Seleccionar. Power BI Desktop muestra un mensaje de éxito que incluye un vínculo para abrir el informe en Power BI.
  4. Haz clic en el vínculo para abrir Power BI.
  5. En el servicio de Power BI, ve a Áreas de trabajo y selecciona el área de trabajo en la que publicaste el informe.
  6. Busca la ficha del conjunto de datos de tu informe (no el informe en sí).
  7. En la lista del conjunto de datos, haz clic en el menú de tres puntos Más opciones y, luego, selecciona Seguridad.

Power BI mostrará la ventana Seguridad a nivel de fila. Desde aquí, puedes seleccionar el rol que creaste en Power BI Desktop y agregar personas o grupos que pertenezcan al rol y validar tus roles en el servicio de Power BI.

Ahora puedes compartir el informe con quien quieras, y solo verá los datos que tiene permitido ver, según los roles que creaste.

Habilita el registro de depuración para Power BI Desktop

Para solucionar problemas o diagnosticar un problema, puedes habilitar el registro de la conexión entre Power BI y Looker.

Debes habilitar el registro para la conexión y también para Power BI, como se describe en las siguientes secciones:

Habilita el registro a nivel del conector

Para solucionar problemas, puedes habilitar el registro de diagnóstico en el conector de Looker-Power BI.

Cuando crees una conexión nueva a los datos de Looker desde Power BI Desktop, sigue estos pasos para habilitar el registro:

  1. En el cuadro de diálogo de conexión de Looker, expande Opciones avanzadas.
  2. Selecciona TRUE en el menú desplegable Habilitar registro.

Si ya creaste una conexión con los datos de Looker desde Power BI Desktop, debes editar la consulta de forma manual en el editor de consultas de Power Query siguiendo estos pasos:

  1. En Power BI Desktop, selecciona Transformar datos.
  2. En la cinta Inicio, selecciona Editor avanzado.
  3. Busca la línea que comienza con Source = Looker.DataSource.
  4. Actualiza el segundo argumento de la función para incluir EnableLogging=true.

    Looker.DataSource("instance.looker.com", [EnableLogging=true])
    
  5. Haz clic en Listo.

Habilita el seguimiento a nivel de Power BI

Además de habilitar el registro en la conexión a los datos de Looker desde Power BI Desktop, también debes habilitar el seguimiento desde Power BI Desktop. Para ello, sigue estos pasos:

  1. Selecciona Archivo > Opciones y configuración > Opciones.
  2. En el cuadro de diálogo Opciones, selecciona Diagnóstico.
  3. En Opciones de diagnóstico, selecciona Habilitar seguimiento.
  4. Para ver los archivos de registro, selecciona Abrir carpeta de volcados de fallas/seguimientos.

Aspectos para tener en cuenta

Límites de filas de consultas

Las consultas del conector de Looker-Power BI incluirán automáticamente una declaración LIMIT 5000, a menos que la cuenta de usuario de Looker tenga el permiso download_without_limit. Si la cuenta de usuario de Looker tiene download_without_limit, las consultas del conector de Looker-Power BI no tienen un límite de filas de consulta impuesto.

Filtros de Explorar

Si la exploración de Looker se define con los parámetros de LookML always_filter o conditionally_filter, los filtros se aplicarán a las consultas en el conector de Looker-Power BI, aunque los filtros no serán visibles en Power BI.

Períodos admitidos para los grupos de dimensiones

Para el dimension_group de type: time, solo se admiten los períodos date y time con el conector de Looker-Power BI. Se ocultarán los demás períodos.

Las exploraciones de la actividad del sistema no se muestran con el conector de Looker-Power BI

Las Exploraciones de actividad del sistema no se muestran en el conector de Looker para Power BI. Los administradores de Looker pueden ver las exploraciones de la actividad del sistema directamente en la IU de Looker.

Limitaciones de la conversión de tipos

Cuando sea posible, se recomienda establecer los tipos de columnas dentro de la vista de LookML.

Limitaciones conocidas

Ten en cuenta las siguientes limitaciones cuando uses el conector de Looker-Power BI:

Modelado y modos de datos

  • Dimensiones numéricas: Tanto las dimensiones como las mediciones numéricas aparecen como mediciones en Power BI. Para usar una dimensión numérica como dimensión, debes cambiar su resumen predeterminado a No resumir en Power BI Desktop.
  • Modo de importación: Para obtener un rendimiento óptimo, usa el modo DirectQuery. Si usas el modo de importación de Power BI, ten en cuenta las siguientes restricciones:
    • Rendimiento: Es posible que los informes que acceden a modelos grandes se carguen con lentitud.
    • Tiempos de espera: Si el proceso "Obtener datos" se bloquea o se agota el tiempo de espera, cambia al modo DirectQuery.
    • Restricciones de campos: El modo de importación inhabilita los campos de solo filtro y los campos de parámetros.
    • Evaluación de mediciones: El modo de importación restringe a Looker de evaluar las mediciones dentro de la exploración, lo que puede afectar la precisión de los informes.

Agregaciones

Power BI aplica sus propias agregaciones a las mediciones de Looker. Esto puede causar errores o resultados incoherentes, en especial en los objetos visuales de matriz.

  • Tipos admitidos: Solo usa average, count, count_distinct, max, min y sum.
  • Tipos no admitidos: El conector no admite consultas de desviación estándar, varianza ni agregaciones de primera o última cadena alfabética.
  • Rendimiento de la mediana: Power BI calcula la mediana de forma local recuperando todos los valores. Este proceso es lento en conjuntos de datos grandes y puede agotar el tiempo de espera.

Filtración y ordenamiento

  • Ordenar por campos ocultos: No puedes ordenar por un campo que no esté incluido en la visualización. Para ordenar por un campo, agrégalo a la visualización.
  • Limitaciones de los filtros avanzados: Debido a las diferencias entre Power Query y las expresiones de filtro de Looker, se aplican las siguientes limitaciones:
    • Texto: No se admiten varios filtros de texto.
    • Fechas: Para los campos de fecha y fecha y hora, solo se admiten is, is not, is on or after y is before.
    • Solo se admiten varios filtros de números en los siguientes casos:
      • DESIGUALDAD Y DESIGUALDAD (por ejemplo, es menor que Y es mayor que)
      • DESIGUALDAD O DESIGUALDAD (por ejemplo, es menor que O es mayor que)
      • es O es.
    • Los filtros de varias fechas y fechas y horas solo se admiten en los siguientes casos:
      • is on or after AND is before
      • is or is

Funciones de Power Query

Las siguientes funciones de tabla no se pueden plegar:

  • Table.Distinct
  • Table.Join
  • Table.NestedJoin
  • Table.Skip

Soluciona problemas

En las siguientes secciones, se describen los problemas habituales y sus soluciones.

El conector de Looker-Power BI no aparece en la lista Obtener datos de Power BI

Verifica que el directorio [Documents]\Microsoft Power BI Desktop\Custom Connectors contenga el archivo looker_1.4.3.mez.

  1. En Power BI Desktop, verifica la configuración de seguridad:
  2. Selecciona Archivo > Opciones y configuración > Opciones.
  3. Selecciona Seguridad.
  4. En Extensiones de datos, selecciona (No recomendado) Permitir que se cargue cualquier extensión sin validación ni advertencia.
  5. Haz clic en Aceptar.
  6. Reinicia Power BI Desktop.

Error: Los nombres de los campos solo pueden incluir letras, números y guiones bajos

En algunos casos, es posible que recibas el siguiente mensaje de error cuando actualices los datos o apliques cambios:

DataSource.Error
Message: A LookML model issue has occurred.
Details: Invalid field name "...". Field names may only include letters, numbers and underscores and must start with a letter or underscore for Google BigQuery Standard SQL

Este error se produce cuando el nombre de una columna contiene espacios o caracteres especiales que no son compatibles con la base de datos subyacente (como BigQuery).

Para resolver este problema, sigue estos pasos:

  1. Identifica la columna que causa el error (por lo general, se hace referencia a ella en la sección Details del mensaje de error).
  2. Cambia el nombre de la columna para que solo use letras, números y guiones bajos.
    • Incorrecto: Custom Column Name
    • Correcto: Custom_Column_Name

Error: Se produjo un error cuando se recuperaban los datos de este elemento visual

En algunos casos, es posible que recibas un error de autenticación en Power BI que indique una falla de OAuth o un problema con las credenciales, como Looker database authentication required.

Si ves este error, significa que a tu cuenta de Looker le faltan las credenciales de OAuth necesarias para la conexión de la base de datos. Para resolver este problema, sigue estos pasos:

  1. Accede a tu instancia de Looker.
  2. Selecciona el ícono de tu perfil de usuario y, luego, Cuenta.
  3. Ve a la sección Credenciales de conexión de OAuth.
  4. Busca la conexión a la que intentas acceder y selecciona Acceder.
  5. Regresa a Power BI Desktop y actualiza los datos.

Registro de cambios del conector de Looker-Power BI

En las siguientes secciones, se muestran las actualizaciones de cada versión del conector de Looker para Power BI:

Versión 1.4.3

La versión 1.4.3 del conector de Looker-Power BI incluye las siguientes actualizaciones:

  • La etiqueta del conector ahora incluye el número de versión del conector.
  • Se agregó una nueva opción Habilitar registro para habilitar de forma dinámica los registros de diagnóstico dentro del conector con fines de solución de problemas.
  • Se agregó una nueva opción Mostrar exploraciones y campos ocultos. Cuando se habilita, se muestran las exploraciones y los campos ocultos. Esto reemplaza la opción anterior Mostrar campos ocultos.

La versión 1.4.3 del conector de Looker-Power BI incluye las siguientes correcciones de errores:

  • Se corrigió un problema por el que fallaba el operador DAX de concatenación de cadenas (&).
  • Se solucionó el problema por el que se producía un error cuando se aplicaba una medición de Power BI a una de Looker.
  • En el menú Configuración de credenciales, ahora se vuelve a mostrar el ícono de Looker.

Versión 1.4.2

La versión 1.4.2 del conector de Looker-Power BI incluye las siguientes actualizaciones:

  • Se quitó el parámetro de configuración de conexión Inhabilitar la optimización de la vista previa.
  • La opción de conexión Mostrar campos ocultos se movió a la sección Opciones avanzadas.
  • Se quitó la marca Beta; el conector ya no aparece como beta en Power BI.

La versión 1.4.2 del conector de Looker-Power BI incluye las siguientes correcciones de errores:

  • Se corrigió el error de regresión en el que fallaban las segmentaciones booleanas y de fecha en Power BI.
  • Se corrigió el filtro is-not que no funcionaba para el filtro dates.

Versión 1.4.0

La versión 1.4.0 del conector de Looker-Power BI incluye las siguientes actualizaciones:

  • Se agregó compatibilidad con el modo de importación
  • Se habilitó la vista previa de los datos
  • Se mejoró el comportamiento cuando se realizan consultas de SELECT *.
  • Mejoró la tasa de acierto de caché de Looker
  • Se mejoró el rendimiento de la recuperación de sugerencias de filtros.

La versión 1.4.0 del conector de Looker-Power BI incluye las siguientes correcciones de errores:

  • Se corrigió un error por el que Looker no detectaba que se habían pasado valores para los campos de filtro y parámetro.
  • Se corrigió un error por el que, a veces, faltaban los valores sugeridos de los parámetros en los controles de filtro.
  • Se corrigió un error por el que las sentencias de LookML ignoraban las variables de Liquid.
  • Se corrigió un error por el que los valores de medición de recuento de valores distintos eran incoherentes en las vistas de matriz de Power BI.

Versión 1.3.1

La versión 1.3.1 del conector de Looker-Power BI incluye las siguientes actualizaciones:

  • Se agregó la opción para mostrar los campos ocultos.

La versión 1.3.1 del conector de Looker-Power BI incluye la siguiente corrección de errores:

  • Se corrigió un error por el que un elemento visual fallaba si existía un filtro tanto en el elemento visual como en el informe.

Versión 1.3.0

La versión 1.3.0 del conector de Looker-Power BI incluye las siguientes actualizaciones:

  • Formato de fecha y hora simplificado
  • Se mejoró la detección de expresiones de texto no admitidas.
  • Se mejoraron los informes de mensajes de error.

La versión 1.3.0 del conector de Looker-Power BI incluye la siguiente corrección de errores:

  • Se mejoró la compatibilidad con los caracteres de escape en los valores de filtro.

Versión 1.2.0

La versión 1.2.0 del conector de Looker-Power BI incluye las siguientes actualizaciones:

  • Ahora se admiten los campos de parámetros y de solo filtrado
  • Compatibilidad de los filtros avanzados con campos de solo filtrado de tipo texto, número, fecha y fecha y hora
  • Compatibilidad con filtros básicos para campos de solo filtro con valores sugeridos de Looker