시각적 모델링 캔버스 사용

Looker의 시각적 모델링 캔버스를 사용하면 BigQuery 데이터 소스에 연결하여 대화형 드래그 앤 드롭 캔버스를 사용하여 LookML 데이터 모델을 빌드하고 수정할 수 있습니다. 시각적 모델링 캔버스를 사용하면 LookML 코드를 작성하지 않고도 테이블을 시각적으로 조인하고, 측정기준과 측정값을 정의하고, 쿼리 결과를 실시간으로 미리 보고, Explore를 게시할 수 있습니다.

시각적 모델링 캔버스

캔버스 구성요소

시각적 모델링 캔버스에는 다음과 같은 작업공간 구성요소와 탐색 탭이 포함됩니다.

  • 소스 데이터베이스: 활성 연결에서 사용 가능한 데이터베이스 데이터 세트, 테이블, 뷰를 표시하는 검색 가능한 사이드바
  • 시각적 캔버스 graph_4: 테이블을 드래그하고, 테이블 노드를 정렬하고, 조인 관계를 정의하는 기본 작업공간
  • LookML 코드 code: 시각적 모델의 기반이 되는 생성된 LookML 코드를 표시하는 패널
  • 데이터 미리보기 table_chart: 조인된 데이터 세트의 실시간 쿼리 미리보기 (LIMIT 100)를 표시하는 접을 수 있는 하단 패널
  • 필드 편집기 edit_attributes: 측정기준 및 측정값을 추가, 이름 변경, 맞춤설정하는 패널

시작하기 전에

시각적 모델링 캔버스를 사용하려면 다음이 있어야 합니다.

시각적 모델 만들기

다음 섹션에서는 시각적 모델링 캔버스를 사용하여 새 데이터 모델을 만드는 단계를 설명합니다.

  1. 데이터베이스에 연결
  2. 캔버스에 테이블 추가
  3. 관계 및 조인 정의
  4. 측정값 및 측정기준 추가 및 구성
  5. 데이터를 실시간으로 미리보기
  6. 모델의 LookML 보기
  7. Explore에 모델 게시

데이터베이스에 연결

데이터베이스에 연결하려면 다음 단계를 따르세요.

  1. Looker의 기본 탐색에서 만들기 버튼을 클릭합니다.
  2. 데이터 소스 를 선택합니다.
  3. 데이터 소스 만들기 대화상자에서 데이터베이스에 연결 탭을 선택합니다.
  4. BigQuery 연결 드롭다운 메뉴에서 데이터베이스 연결을 선택합니다.
  5. 프로젝트를 지정합니다.
    • 목록에서 선택 을 선택하여 연결에서 사용 가능한 프로젝트 중에서 선택합니다.
    • 직접 입력 을 선택하여 프로젝트 ID를 직접 입력합니다.
  6. 모든 테이블을 포함할지 아니면 특정 테이블을 선택할지 지정합니다.
    • 선택한 이 프로젝트의 모든 데이터 세트 및 테이블 포함 을 선택하여 빈 캔버스로 시작합니다. 빈 캔버스에서 소스 목록의 테이블을 추가할 수 있습니다.
    • 특정 테이블 선택 을 선택하여 캔버스에 추가할 단일 데이터 세트 및 테이블을 지정합니다. 시각적 모델링 캔버스가 필드 편집기로 열리고 선택한 테이블의 필드가 로드됩니다. 탐색 메뉴에서 시각적 캔버스 graph_4를 클릭하여 캔버스에서 테이블을 볼 수 있습니다. 소스 목록에서 다른 테이블을 추가할 수 있습니다.
  7. 계속 을 클릭하여 시각적 모델링 캔버스를 엽니다.

캔버스에 테이블 추가

캔버스에 테이블을 추가하여 데이터 모델링을 시작하려면 다음 단계를 따르세요.

  1. 소스 데이터베이스 사이드바에서 모델링할 데이터 세트, 테이블 또는 뷰를 찾아보거나 검색합니다.
  2. 사이드바에서 각 테이블을 캔버스로 드래그합니다.
  3. 캔버스에서 테이블 노드의 위치를 변경하여 데이터 모델 레이아웃을 정리합니다.

테이블을 캔버스로 드래그하면 시각적 모델링 캔버스가 이를 테이블 노드 로 나타냅니다. 캔버스에 테이블 이름과 BigQuery 프로젝트 및 데이터 세트 ID가 표시됩니다. 캔버스에 추가된 첫 번째 테이블에는 기본 뷰 라는 라벨이 지정됩니다.

관계 및 조인 정의

캔버스에 테이블을 두 개 이상 추가하면 시각적 모델링 캔버스가 일치하는 열 이름 (예: ordersorder_itemsorder_id)을 검색하고 테이블 간의 조인 연결선을 자동으로 제안합니다.

데이터베이스의 테이블 간 관계를 수정하거나 만들려면 다음 단계를 따르세요.

  1. 두 테이블 노드 사이의 조인 연결선을 클릭하여 조인 구성 패널을 엽니다. 조인 구성 패널에서 조인을 구성합니다.
    • 조인 유형: 조인 유형 (왼쪽 외부, 내부 또는 전체 외부)을 선택합니다. 기본적으로 Looker는 왼쪽 외부 조인을 사용합니다.
    • 관계 (카디널리티): 관계 유형 (일대일, 일대다, 다대일 또는 다대다)을 선택합니다.
    • 조인 절: 자동으로 제안된 조인 키를 검토하거나 맞춤 조인 조건을 추가합니다. 여러 조인 조건 (예: orders.id = order_items.order_id AND orders.date = order_items.date)을 지정할 수 있습니다.
  2. 조인 오류 해결: 조인으로 인해 잘못된 SQL 경로 또는 순환 참조가 생성되면 연결선이 설명 도움말과 함께 빨간색으로 바뀝니다. 조인 키 또는 관계 카디널리티를 조정하여 오류를 해결합니다.
  3. 조인 설정을 변경한 경우 적용 을 클릭하여 변경사항을 조인에 적용합니다.

측정값 및 측정기준 추가 및 구성

시각적 모델링 캔버스는 테이블의 측정기준과 측정값을 자동으로 설정하고 맞춤 계산을 추가할 수 있도록 합니다. 기본적으로 시각적 모델링 캔버스는 숫자 필드에 count 또는 sum 유형의 측정값을 만들고 이름에 ID, Key 또는 Code가 포함된 필드를 숫자 측정기준으로 유지합니다. 일대다 관계를 정의하면 시각적 모델링 캔버스가 대칭 집계 로직을 자동으로 적용하여 팬아웃 및 중복 값 계산 오류를 방지합니다.

생성된 필드는 삭제할 수 없습니다. 필드 편집기의 필드 톱니바퀴 메뉴에서 숨기기를 선택하거나 필드의 수정 edit 아이콘을 클릭하고 Explore 및 시각화에서 이 필드 숨기기 체크박스를 선택하여 숨길 수만 있습니다.

테이블의 필드를 보려면 캔버스에서 테이블 노드를 선택한 후 필드 수정 을 클릭합니다.

필드 편집기에서 다음 작업을 실행할 수 있습니다.

측정기준 수정

기존 측정기준을 수정하려면 다음 단계를 따르세요.

  1. 시각적 모델링 캔버스에서 캔버스의 테이블 노드를 선택한 후 필드 수정 을 클릭하여 필드 편집기를 엽니다.
  2. 필드 편집기에서 측정기준 탭을 클릭합니다.
  3. 수정할 측정기준을 찾고 필드의 수정 edit 아이콘을 클릭하여 측정기준 수정 대화상자를 엽니다.
  4. 다음 필드를 업데이트합니다 (데이터 유형 필드는 읽기 전용임).
    • 형식: 드롭다운 메뉴에서 형식 지정 옵션을 선택합니다.
    • 이름: LookML 및 표현식에서 측정기준을 식별하는 데 사용되는 이름을 수정합니다.
    • 라벨: Explore 및 시각화에 표시되는 라벨을 수정합니다.
    • + 설명 추가: 이 옵션을 클릭하여 측정기준의 선택적 설명을 입력하거나 수정합니다.
    • Explore 및 시각화에서 이 필드 숨기기: 이 체크박스를 선택하거나 선택 해제하여 측정기준을 숨기거나 표시합니다.
  5. 저장 을 클릭합니다.

측정 수정

기존 측정값을 수정하려면 다음 단계를 따르세요.

  1. 시각적 모델링 캔버스에서 캔버스의 테이블 노드를 선택한 후 필드 수정 을 클릭하여 필드 편집기를 엽니다.
  2. 필드 편집기에서 측정값 탭을 클릭합니다.
  3. 수정할 측정값을 찾고 필드의 수정 edit 아이콘을 클릭하여 측정 수정 대화상자를 엽니다.
  4. 다음 필드를 업데이트합니다.

    • 측정할 필드: 드롭다운 메뉴에서 집계할 필드를 선택합니다.
    • 측정 유형: 드롭다운 메뉴에서 집계 유형 (예: 합계, 개수, 평균, 최솟값 또는 최댓값)을 선택합니다.
    • 라벨: Explore 및 시각화에 표시되는 라벨을 수정합니다.
    • 필터 탭: 결과 범위 좁히기에서 필터 이름 드롭다운 메뉴의 필드를 선택하고 필터 값을 지정합니다. +- 버튼을 사용하여 필터 조건을 추가하거나 삭제합니다.
    • 필드 세부정보 탭: 형식 드롭다운 메뉴에서 형식 지정 옵션을 선택하고 선택적 설명 (최대 255자)을 입력합니다.
    • Explore 및 시각화에서 이 필드 숨기기: 이 체크박스를 선택하거나 선택 해제하여 측정값을 숨기거나 표시합니다.
  5. 저장 을 클릭합니다.

맞춤 측정기준 만들기

Looker 표현식을 사용하여 맞춤 측정기준을 만들려면 다음 단계를 따르세요.

  1. 시각적 모델링 캔버스에서 캔버스의 테이블 노드를 선택한 후 필드 수정 을 클릭하여 필드 편집기를 엽니다.
  2. 시각적 모델링 캔버스의 필드 편집기에서 측정기준 추가 를 클릭하여 측정기준 만들기 대화상자를 엽니다.
  3. 표현식 편집기 상자에 측정기준을 정의하는 Looker 표현식을 입력하거나 Gemini 글쓰기 도우미를 사용하여 표현식 작성하기를 클릭하여 표현식을 생성합니다.
  4. 형식 드롭다운 메뉴에서 형식 지정 옵션을 선택합니다.
  5. 측정기준의 이름라벨 을 입력합니다.
  6. 선택적으로 + 설명 추가를 클릭하여 측정기준의 설명을 입력하거나 수정합니다.
  7. 선택적으로 Explore 및 시각화에서 이 필드 숨기기 체크박스를 선택하여 측정기준을 숨깁니다.
  8. 저장 을 클릭합니다.

맞춤 측정값 만들기

맞춤 측정값을 만들려면 다음 단계를 따르세요.

  1. 시각적 모델링 캔버스에서 캔버스의 테이블 노드를 선택한 후 필드 수정 을 클릭하여 필드 편집기를 엽니다.
  2. 필드 편집기에서 측정값 탭을 클릭한 후 측정값 추가 를 클릭하여 측정값 만들기 대화상자를 엽니다.
  3. 측정할 필드 드롭다운 메뉴에서 집계할 필드를 선택합니다.
  4. 측정 유형 드롭다운에서 측정할 필드 필드에 실행할 집계 유형을 선택합니다.
  5. 측정값의 라벨 을 입력합니다.
  6. 선택적 필터 조건 또는 형식 세부정보를 구성합니다.
    • 필터 탭: 결과 범위 좁히기에서 필터 이름 드롭다운 메뉴의 필드를 선택하고 필터 값을 지정합니다. +- 버튼을 사용하여 필터 조건을 추가하거나 삭제합니다.
    • 필드 세부정보 탭: 형식 드롭다운 메뉴에서 형식 지정 옵션을 선택하고 선택적 설명 (최대 255자)을 입력합니다.
  7. 선택적으로 Explore 및 시각화에서 이 필드 숨기기 체크박스를 선택하여 측정값을 숨깁니다.
  8. 저장 을 클릭합니다.

데이터를 실시간으로 미리보기

다음 단계에 따라 모델의 데이터 출력을 확인합니다.

  1. 시각적 모델링 캔버스의 탐색 메뉴에서 데이터 미리보기table_chart를 클릭합니다.
  2. 캔버스에서 테이블을 클릭하여 해당 테이블의 필드를 선택합니다.
  3. 데이터 미리보기 창에서 열 미리보기 드롭다운 메뉴를 클릭합니다.
  4. 드롭다운 메뉴에서 쿼리할 테이블의 필드를 선택한 후 미리보기 를 클릭합니다.

    시각적 모델링 캔버스가 데이터베이스를 쿼리하고 데이터 미리보기 창의 테이블에 쿼리 결과를 표시합니다.

  5. 데이터를 검사하여 의도하지 않은 행 팬아웃 또는 삭제된 레코드가 발생하지 않도록 합니다.

  6. 필요에 따라 조인 또는 필드를 업데이트한 후 데이터 미리보기 창에서 스키마 새로고침 을 클릭하여 테이블을 업데이트합니다.

LookML 보기

LookML 코드code를 클릭하여 모델에 대해 생성된 LookML을 검사합니다. 시각적 모델의 LookML은 읽기 전용입니다. 필드와 조인을 수정하려면 시각적 모델링 캔버스를 사용하세요.

Explore에 모델 게시

모델을 저장하려면 시각적 모델링 캔버스에서 데이터 탐색 버튼을 클릭합니다.

Looker는 기본 LookML 모델 파일을 생성하고 캔버스 레이아웃 좌표를 저장합니다. 이제 모델이 게시되었으며 쿼리할 준비가 되었습니다.

시각적 모델 액세스

게시된 시각적 모델은 Looker 탐색의 셀프서비스 Explore 섹션에 있는 Explore 아래에 표시됩니다.

시각적 모델을 쿼리하려면 다음 단계를 따르세요.

  1. Looker의 기본 탐색에서 Explore 를 클릭합니다.
  2. 셀프서비스 Explore에서 모델의 Explore 이름을 선택합니다.
  3. 필드 선택 도구에서 측정기준과 측정값을 선택하고, 필터를 추가하고, 쿼리를 실행하여 시각화 및 대시보드 타일을 만듭니다.

기존 시각적 모델 수정

시각적 모델링 캔버스로 만든 기존 모델을 수정하려면 다음 단계를 따르세요.

  1. Looker의 기본 탐색 메뉴에서 Explore 를 클릭합니다.
  2. 셀프서비스 Explore에서 수정할 모델의 Explore를 엽니다.
  3. Explore의 필드 선택 도구에서 모델 수정 을 선택하여 시각적 모델링 캔버스를 엽니다. 기존 Explore 환경을 사용하는 경우 Explore의 톱니바퀴 메뉴에서 모델 수정 을 선택합니다.
  4. 시각적 모델링 캔버스에서 변경사항을 적용합니다 (예: 테이블 추가, 조인 절 업데이트, 새 측정값 만들기).
  5. 데이터 탐색 을 클릭하여 모델을 업데이트합니다.

시각적 모델 삭제

시각적 모델을 삭제하려면 다음 단계를 따르세요.

  1. Looker의 기본 탐색 메뉴에서 Explore 를 클릭합니다.
  2. 셀프서비스 Explore에서 수정할 모델의 Explore를 엽니다.
  3. Explore의 필드 선택 도구에서 모델 수정 을 선택하여 시각적 모델링 캔버스를 엽니다. 기존 Explore 환경을 사용하는 경우 Explore의 톱니바퀴 메뉴에서 모델 수정 을 선택합니다.
  4. 시각적 모델링 캔버스에서 점 3개로 된 메뉴에서 삭제 를 선택합니다.