Cloud Workstations 隨附預設基礎編輯器,可讓您編寫、建構、測試、偵錯及執行應用程式。基本編輯器是以 Code-OSS 開放原始碼專案為基礎,支援 Open VSX Registry 提供的 IDE 擴充功能,並預先安裝 Cloud Code IDE 擴充功能。
如要開始使用 Cloud Workstations 基礎編輯器,請按照下列步驟操作:
- 按照快速入門指南的說明建立工作站設定。系統提示選取「Environment customization」(環境自訂) 時,請選取「Code OSS (default)」(Code OSS (預設)) 做為程式碼編輯器。
按照快速入門指南的操作說明,使用剛建立的設定建立工作站。
前往 Google Cloud 控制台的「Cloud Workstations」頁面,從瀏覽器啟動工作站。
活動列
活動列會顯示在側邊,您可以存取 Cloud Workstations 基礎編輯器中的可用檢視畫面。這些活動列檢視畫面如下:
Explorer:查看目前工作區中的資料夾和檔案
搜尋:在檔案中搜尋字串或規則運算式
原始碼控管:使用 Cloud Workstations 基礎編輯器的 Git 支援功能管理應用程式檔案
Debug:設定中斷點並檢查變數,對應用程式進行偵錯
擴充功能:搜尋擴充功能目錄,為 IDE 新增額外功能
Cloud Code:直接從 IDE 建立及部署 Google Cloud 應用程式
設定:自訂 Cloud Workstations 基礎編輯器,以符合工作流程
查看及編輯檔案
內建程式碼編輯器,可讓您瀏覽檔案目錄,以及查看和編輯工作站中的檔案。
如要使用基本編輯器,請按照下列步驟操作:
使用活動列切換檢視畫面。
使用編輯器查看及編輯檔案。
使用「Explorer」(探索工具) 檢視畫面瀏覽檔案目錄、上傳及下載檔案、在 Cloud Workstations 虛擬機器執行個體上預覽網頁應用程式,以及查看使用統計資料。
圖 1. Cloud Workstations 基礎編輯器
上傳及下載檔案和目錄
如要在 Code-OSS Explorer 檢視畫面中上傳或下載檔案和目錄,請使用下列任一方法:
將檔案拖曳到「Explorer」檢視畫面,即可新增至工作區。
前往要使用的檔案和目錄,按一下滑鼠右鍵,然後選擇「Upload」(上傳) 或「Download」(下載)。
圖 2. 在檔案總管檢視畫面中按一下滑鼠右鍵,即可上傳及下載檔案
語言支援
Cloud Workstations 基本編輯器透過擴充功能支援 Go、Python、Java、.NET Core 和 Node.js 等語言,並提供下列語言功能:
- 智慧重點、程式碼建議和依據相關資訊提供的程式碼完成建議
- Linting 並提供描述性錯誤
- 程式碼導覽 (前往定義、宣告、參照和實作)
- 直覺式偵錯支援
Cloud Code 整合
Cloud Code 為 Kubernetes 和 Cloud Run 應用程式的完整開發週期提供 IDE 支援,包括從範例應用程式建立及自訂新應用程式,以及執行完成的應用程式。Cloud Code 也提供可立即執行的範例、設定程式碼片段和量身打造的偵錯體驗,全程支援您的開發作業。
Cloud Code 整合 AI 輔助協作工具 Gemini,可簡化開發作業。使用 Gemini 更有效率地完成工作。
Cloud Code 支援以 Node.js、Python、Java、Go 和 .NET Core 開發應用程式。
除了 Cloud Workstations 狀態列中的 Cloud Code 選單外,您也可以透過指令面板存取 Cloud Code 指令。如要開啟指令面板,請按下 Control+Shift+P (在 macOS 上為 Command+Shift+P),或依序點選「View」(檢視)>「Command Palette」(指令面板)。
Data Agent Kit 整合
如要直接在基礎編輯器中管理資料科學和資料工程工作負載,可以使用與 Cloud Code 整合的 Google Cloud Data Agent Kit。如要使用 Data Agent Kit,請按一下基礎編輯器活動列中的「Google Cloud Data Agent Kit」圖示。詳情請參閱「Data Agent Kit 總覽」。
版本管控支援
Cloud Workstations 基礎編輯器隨附預先設定的版本管控功能。您可以初始化存放區、比較檔案狀態、暫存、取消暫存及修訂變更。您也可以使用公開、私人或自行託管的存放區,只要工作站可存取這些存放區即可。
工作區管理
Cloud Workstations 可讓您將專案當做工作區管理及設定。工作區通常代表根專案資料夾,您可以使用 Cloud Workstations 基本編輯器建立、開啟及儲存工作區,並使用專案專屬設定自訂工作區。
如要將資料夾做為工作區開啟,請使用活動列頂端的選單,然後依序選取「File」>「Open Folder」。或者,您也可以使用基本編輯器歡迎頁面上的「Open File」(開啟檔案) 或「Recent Workspace」(最近的工作區) 選項,或使用網址參數 folder 指定要開啟的資料夾路徑,例如 &folder=/home/user/foo。
偵錯應用程式
Cloud Workstations 支援 Go、Node.js、Python 和 Java 應用程式,可讓您對應用程式進行偵錯。您可以在 Cloud Workstations 中建立啟動設定、設定中斷點及檢查變數。
此外,您也可以在本機叢集 (例如 minikube 或 Docker Desktop)、GKE 上的遠端叢集,或任何其他雲端服務供應商上,對 Kubernetes 應用程式進行偵錯。
整合式終端機
您可以透過整合式終端機與基礎開發環境互動。使用下列任一方法開啟或關閉終端機檢視畫面:
- 按下
Control+。 - 按下 Control+Shift+P 鍵 (在 macOS 上為 Command+Shift+P 鍵),或依序點選「View」>「Command Palette」,然後輸入
View: Toggle Terminal。 - 依序選取「Terminal」>「New Terminal」。
- 依序選取「View」>「Terminal」。
- 在終端機分頁清單中,按一下「新增」圖示 add。
如要開啟多個終端機視窗,請按一下 「Split」(分割),或按下 Control+Shift+5。
管理及自訂終端機分頁
如果開啟多個終端機,終端機檢視畫面側邊會顯示終端機分頁清單。這份清單包含已開啟終端機的名稱。
在清單中選取終端機名稱時,會顯示
「Split」(分割) 和
「Delete」(刪除) 圖示。按一下對應的圖示,即可分割或刪除終端機視窗。
如要查看其他終端機選項,例如「Move Terminal into Editor Area」(將終端機移至編輯器區域)、「Rename」(重新命名)、「Change Color」(變更顏色)、「Change Icon」(變更圖示)等,請在終端機名稱上按一下滑鼠右鍵。
圖 5. 自訂終端機
捲動螢幕
除了在瀏覽器焦點位於工作階段分頁時使用滑鼠外,您也可以在 Windows 和 Linux 上按下 Control+Shift+PageUp 和 Control+Shift+PageDn (或在 macOS 上按下 Fn+Shift+Up 和 Fn+Shift+Down) 捲動畫面。
自訂設定
如要自訂編輯器、使用者介面和功能行為,Cloud Workstations 基礎編輯器提供下列範圍來定義設定:
機器設定:連線至 Cloud Workstations 虛擬個體時,全域套用的設定,會顯示在工作站的
$HOME/.codeoss-cloudworkstations/data/Machine/settings.json檔案中。使用者設定:連線至 Cloud Workstations 虛擬個體時,全域套用的設定,且會保留在每個工作站執行個體的瀏覽器儲存空間中。
Workspace Settings:儲存在工作區中的設定,只有在開啟該工作區時才會套用。這些設定會與工作區檔案一起顯示在
$WORKSPACE_ROOT/.vscode/settings.json檔案中。
編輯器會分別評估各個設定範圍。
鍵盤快速鍵
由於預設的基本編輯器是在瀏覽器中執行,因此部分鍵盤快速鍵可能會由瀏覽器保留,而不會由編輯器擷取。
為支援所有鍵盤快速鍵,預設的基本編輯器會綁定漸進式網頁應用程式 (PWA),讓編輯器擷取這些快速鍵。
如要使用 PWA,請按照下列步驟操作:
- 在瀏覽器中開啟工作站。
- 按一下瀏覽器網址列中顯示的安裝圖示。
PWA 應會安裝,且 Workstation 會在 PWA 中重新開啟。後續載入工作站時,瀏覽器會在網址列中顯示選項,讓您在 PWA 中重新開啟工作站。