Looker-Rezeptbuch: Viele Informationen mit einer Visualisierung mit einem einzelnen Wert präsentieren

Wenn Informationen klar und prägnant dargestellt werden, können Nutzer schnell nachvollziehen, wie ein einzelner Datenpunkt mit größeren Trends zusammenhängt oder wie er im Vergleich zu anderen Werten abschneidet, ohne dass sie zusätzliche Zeit für die Suche nach Kontext aufwenden müssen. Die folgende Visualisierung aus dem Abschnitt Einzelnen Wert im Vergleich zu anderen Werten anzeigen auf dieser Seite hilft Nutzern beispielsweise, einen Wert mit anderen Werten zu vergleichen:

Einzelner Wert von 41.394,51 $ mit dem Untertitel „Gesamtgewinn des letzten vollständigen Monats“ und dem Untertext mit einem Abwärtspfeil neben 40 % im Vergleich zum Vormonat.

In diesem Cookbook erfahren Sie, wie Sie eine Visualisierung erstellen, die einen einzelnen Datenpunkt mit so viel Kontext wie möglich darstellt.

Die folgenden Beispiele sind auf dieser Seite enthalten:

Produkte

Vorbereitung

Für die Erstellung einer Einzelwertvisualisierung ist Folgendes erforderlich:

Überlegungen bei der Verwendung von Einzelwertvisualisierungen

Beachten Sie beim Erstellen und Verwenden von Einzelwertvisualisierungen Folgendes:

  • Wenn Sie mehrere Einzelwert-Visualisierungen in einem Dashboard ansehen, wird für jede Visualisierung standardmäßig dieselbe Schriftgröße verwendet, um ein einheitliches Erscheinungsbild zu erzielen. Bei Einzelwertvisualisierungen wird die Schriftgröße jedoch automatisch angepasst, wenn die Größe einer Tile reduziert wird. Wenn die Schriftart für eine Visualisierung den gesamten Wert nicht im verfügbaren Platz anzeigen kann, wird der Wert durch Auslassungspunkte (...) abgeschnitten.
  • Wenn die Funktion Intelligente Textgröße für einzelne Werte aktiviert ist, wird die Schriftgröße bei Visualisierungen einzelner Werte, die in Dashboard-Tiles angezeigt werden, automatisch so angepasst, dass mindestens 8–10 Zeichen des Werts in der Tile angezeigt werden, unabhängig von der Größe der Tile.
  • Die Schriftart kann für eingebettete Inhalte nur geändert werden, wenn dies von einem Looker-Administrator in einem benutzerdefinierten Design festgelegt wurde.
  • Die Schriftgröße kann nicht über das Menü Bearbeiten der Visualisierung angepasst werden. Die einzigen Möglichkeiten, den Schriftstil und die Schriftgröße von Werten anzupassen, sind die folgenden Problemumgehungen, die Sie auf eigenes Risiko ausführen können:
    • Fügen Sie der LookML-Definition des Felds einen html-Parameter hinzu und geben Sie die Schriftart- und Größeneinstellungen mithilfe von HTML-Stil-Tags an. Beispiel: html: <p style="color: red; font-size: 50px">{{-Wert }}</p> ;;
    • Verwenden Sie die im Community-Beitrag Edit font size in a single value viz beschriebene Methode für Streudiagramme.

Wenn mehrere Visualisierungen mit einzelnen Werten auf einem Dashboard angezeigt werden, kann die Schriftgröße weiterhin von den im ersten Punkt dieser Liste beschriebenen Überlegungen beeinflusst werden.

Beispiel: Ein einzelner Wert im Vergleich zu anderen Werten

Eine Vanity-Metrik allein bietet Nutzenden wenig Mehrwert. Wenn Sie jedoch einen Vergleich mit einem früheren Datenpunkt hinzufügen, können Sie Nutzern schnell Perspektive und Kontext bieten.

In der folgenden Abfrage wird beispielsweise der Gesamtgewinn nach Erstellungsmonat für die letzten 12 Monate angezeigt. In der Visualisierung mit einem einzelnen Wert wird standardmäßig nur der Wert der obersten Zeile des Messwerts Total Profit angezeigt, der für den letzten vollständigen Monat, Dezember (2019-12), 41.394,51 $ beträgt.

Einzelwertvisualisierung mit dem Wert 41.394,51 $.

Ohne die Datentabelle als Kontext bietet der Wert den Nutzern nicht viele Informationen. Was ist, wenn Sie den Gesamtgewinn des letzten vollständigen Monats mit dem Gesamtgewinn des Vormonats vergleichen möchten? Mit den Einstellungen im Menü Bearbeiten der Visualisierung können Sie einen Vergleich dieser Werte in der Visualisierung erstellen.

So zeigen Sie einen Vergleich des aktuellen Werts mit dem Wert der vorherigen Zeile an:

Bereiten Sie Ihren Explore vor:

  1. Organisieren Sie Ihre Explore-Abfrage so, dass die Visualisierung den gewünschten Wert anzeigt.
  2. Fügen Sie der Explore-Abfrage ein Feld hinzu, in dem die Werte der aktuellen und der vorherigen Zeile verglichen werden.

    Wenn in der Feldauswahl kein Vergleichsfeld verfügbar ist und Sie die erforderlichen Berechtigungen haben, können Sie ein Kürzel für die Tabellenkalkulation verwenden. In diesem Beispiel wird die Berechnung % Änderung gegenüber vorheriger Zeile verwendet.

Passen Sie die Einzelwert-Visualisierung an:

  1. Öffnen Sie in der Leiste Visualisierung das Menü Bearbeiten.
  2. Wählen Sie auf dem Tab Stil die gewünschten Stiloptionen aus. Sie können beispielsweise einen benutzerdefinierten Titel hinzufügen, der als Untertext unter dem Wert angezeigt wird, und die Wertformatierung im Excel-Stil festlegen.

    In diesem Beispiel wird im Bereich Titel überschreiben „Gesamtgewinn im letzten vollständigen Monat“ eingegeben, um besser zu verdeutlichen, was der Wert darstellt.

  3. Wählen Sie auf dem Tab Vergleich die Option Anzeigen aus.

  4. Wählen Sie im Drop-down-Menü Wertlabels die Option Als Änderung anzeigen aus.

  5. Wählen Sie die Option Positive Werte sind falsch aus, um eine positive Änderung in Rot und eine negative Änderung in Grün anzuzeigen, wenn das für Ihren Anwendungsfall geeignet ist.

    In diesem Beispiel weisen negative Änderungen darauf hin, dass der Gesamtgewinn im Dezember im Vergleich zum November niedriger war, was als „schlechte“ Änderung gilt.

  6. Passen Sie das Label für den Wertvergleich auf dem Tab Vergleich nach Bedarf an.

    Entfernen Sie das Häkchen bei Label anzeigen, um das Feldlabel auszublenden.

    Lassen Sie die Optionen für Label anzeigen unverändert, um das Feldlabel unverändert zu übernehmen.

    Geben Sie im Feld Label ein benutzerdefiniertes Label ein. In diesem Beispiel wird das benutzerdefinierte Label „from previous month“ angewendet.

Das Endergebnis ist der Wert Total Profit (Gesamtgewinn) für Dezember, 41.394,51 $, wobei der Untertext den Vergleich mit dem Gesamtgewinn des Vormonats hervorhebt, der um 40 % gesunken ist.

Einzelner Wert von 41.394,51 $ mit dem Untertitel „Gesamtgewinn des letzten vollständigen Monats“ und dem Untertext mit einem Abwärtspfeil neben 40 % im Vergleich zum Vormonat.

Bedingte Formatierung für mehr Kontext hinzufügen

Mit der bedingten Formatierung können Sie zusätzliche Kontextinformationen hinzufügen, ohne die Visualisierung zu überladen.

In diesem Beispiel liegt der Gewinnschwellenwert für einen erfolgreichen Monat bei 30.000 $. Alle monatlichen Gewinne über diesem Schwellenwert sollen grün dargestellt werden.

Sie können die Einstellungen für die bedingte Formatierung auf dem Tab Formatierung im Menü Bearbeiten der Visualisierung verwenden, um zu verdeutlichen, dass der Wert über dem Gewinnschwellenwert liegt.

So aktivieren Sie die bedingte Formatierung im Menü Bearbeiten der Einzelwertvisualisierung:

  1. Öffnen Sie in der Leiste Visualisierung das Menü Bearbeiten.
  2. Wählen Sie auf dem Tab Formatierung die Option Bedingte Formatierung aktivieren aus.
  3. Wählen Sie im Bereich Farben im Drop-down-Menü Sammlung eine Farbpalette aus.
  4. Geben Sie Ihre Formatierungsregeln im Bereich Regeln ein.

    Wählen Sie im Drop-down-Menü Format die Bedingung aus.In diesem Beispiel ist Wenn der Wert größer ist als ausgewählt.

    Geben Sie den Wert für den Regelschwellenwert ein. In diesem Beispiel wird „30000“ eingegeben.

    Wählen Sie die gewünschte Hintergrundfarbe und Schriftfarbe aus. Achten Sie auf den Farbkontrast, um die Barrierefreiheit Ihrer Inhalte zu gewährleisten. In diesem Beispiel werden ein weißer Hintergrund und eine dunkelgrüne Schriftart ausgewählt.

  5. Wenn Sie eine weitere Regel hinzufügen möchten, klicken Sie unten auf dem Tab auf den Button Regel hinzufügen.

    In diesem Beispiel wird eine weitere Regel erstellt, um anzugeben,wann die Gesamtgewinnwerte kleiner als der Schwellenwert von 30.000 $ sind.

Der Gesamtgewinn im Dezember (41.394,51 $) ist zwar 40 % niedriger als der Gesamtgewinn des Vormonats, liegt aber immer noch über dem Gewinnschwellenwert. Der Gesamtgewinn wird jetzt in Grün angezeigt, um Nutzern zu signalisieren, dass er über dem Gewinnschwellenwert liegt.

Beispiel: Einzelner Wert im Kontext des Fortschritts im Hinblick auf ein Ziel

Eine weitere Option für die Einzelwertvisualisierung ist die Anzeige eines Werts im Kontext des Fortschritts in Bezug auf ein Ziel.

Wenn Sie beispielsweise dasselbe Dataset verwenden (Gesamtgewinn gruppiert nach Erstellungsmonat für die letzten 12 Monate), können Sie den Gesamtgewinn seit Jahresbeginn mit dem Gewinnziel für das gesamte Jahr vergleichen. Das jährliche Gewinnziel für dieses Beispiel beträgt 1.000.000 €.

So stellen Sie den Einzelwert im Kontext des Fortschritts dar:

Bereiten Sie Ihren Explore vor:

  1. Erstellen Sie mit einer Tabellenkalkulation eine Summe der Werte für Total Profit. Der Ausdruck für die Tabellenkalkulation lautet sum(${view_name.field_name}).

    In diesem Beispiel lautet der Ausdruck sum(${order_items.total_profit}).

  2. Fügen Sie ein Feld oder eine neue Tabellenkalkulation hinzu, die das Ziel darstellt, mit dem der Wert verglichen wird.

    Wenn Sie eine Tabellenkalkulation erstellen, muss der Wert als Messwert dargestellt werden, damit er in die Visualisierung aufgenommen wird.

    Multiplizieren Sie im Berechnungsausdruck einen Messwert mit null und fügen Sie den Zielvorhabenwert hinzu: (${measure_viewname.measure_fieldname}*0) + <value that is the goal>.

    In diesem Beispiel lautet der Ausdruck (${order_items.total_profit}*0) + 1000000.

Passen Sie die Einzelwert-Visualisierung an:

  1. Öffnen Sie in der Leiste Visualisierung das Menü Bearbeiten.
  2. Wählen Sie auf dem Tab Stil die gewünschten Stiloptionen aus. Sie können beispielsweise einen benutzerdefinierten Titel hinzufügen, der als Untertext unter dem Wert angezeigt wird, und die Wertformatierung im Excel-Stil festlegen.

    In diesem Beispiel wird im Bereich Titel überschreiben „Gewinn seit Jahresbeginn“ eingegeben, um besser zu verdeutlichen, was der Wert darstellt.

  3. Wählen Sie auf dem Tab Vergleich die Option Anzeigen aus.

  4. Wählen Sie im Drop-down-Menü Wertlabels entweder die Option Fortschritt berechnen oder Fortschritt berechnen (mit Prozentangabe) aus.

    Bei Fortschritt berechnen wird eine Fortschrittsanzeige mit einem schattierten Wert angezeigt, der den aktuellen Status im Vergleich zum Ziel angibt. Wenn die Standardeinstellungen für Label angewendet werden, wird auch der Feldname angezeigt.

    Bei Fortschritt berechnen (mit Prozentangabe) wird die schattierte Fortschrittsanzeige mit dem Text X % von X angezeigt, wobei die Standardeinstellungen für Label angewendet werden.

  5. Passen Sie das Label für die Fortschrittsanzeige auf dem Tab Vergleich nach Bedarf an.

    Entfernen Sie das Häkchen bei Label anzeigen, um das Feldlabel auszublenden. Wenn Sie die Option Fortschritt berechnen auswählen, wird nur eine schattierte Fortschrittsanzeige angezeigt. Wenn Sie die Option Fortschritt berechnen (mit Prozentangabe) auswählen, wird der Text X % von X in einer schattierten Fortschrittsanzeige dargestellt.

    Lassen Sie die Optionen für Label anzeigen unverändert, um das Feldlabel unverändert zu übernehmen.

    Geben Sie im Feld Label ein benutzerdefiniertes Label ein.

Das Endergebnis ist der Gewinnwert seit Jahresbeginn von 730.362,93 $, wobei eine Fortschrittsanzeige den Fortschritt im Hinblick auf das jährliche Umsatzziel von 1.000.000 $ anzeigt.

Das Beispiel sieht anders aus, wenn die Einstellungen Fortschritt berechnen und Fortschritt berechnen (mit Prozentangabe) angewendet werden.

  • So sieht das Beispiel aus, wenn die Option Fortschritt berechnen und die Einstellungen für das benutzerdefinierte Label „Fortschritt beim Erreichen des jährlichen Verkaufsziels“ auf dem Tab Vergleich angewendet werden:

    Einzelner Wert von 730.362,93 $ mit dem Untertitel „Gewinn seit Jahresbeginn“ und einer Fortschrittsanzeige mit der Bezeichnung „Fortschritt beim Erreichen des jährlichen Umsatzziels“, die zu drei Vierteln schattiert ist.

  • So sieht das Beispiel aus, wenn die Option Fortschritt berechnen (mit Prozentangabe) und die Einstellungen für das benutzerdefinierte Label „yearly sales goal“ auf dem Tab Vergleich angewendet werden:

    Einzelner Wert von 730.362,93 $ mit dem Untertitel „Gewinn seit Jahresbeginn“ und einer Fortschrittsanzeige mit der Beschriftung „73 % des jährlichen Umsatzziels von 1.000.000 $“, die zu 3/4 schattiert ist.

Nächste Schritte:

Nachdem Sie die Einzelwert-Visualisierung erstellt haben, können Sie sie für andere freigeben: