Konektor Looker–Power BI

Konektor Looker–Power BI memungkinkan Anda menggunakan Microsoft Power BI Desktop untuk terhubung ke data dari Explore Looker.

Konektor Looker–Power BI dirancang untuk digunakan dengan Mode DirectQuery Power BI.

Saat Anda menggunakan Konektor Looker–Power BI dalam mode DirectQuery, Power BI tidak mengimpor atau menyalin data Anda. Sebagai gantinya, Power BI membuat ekspresi Power Query M untuk setiap visualisasi, filter, dan penghitungan DAX. Looker–Power BI Connector menerjemahkan ekspresi ini menjadi kueri langsung menggunakan Looker API.

Proses ini mengandalkan pelipatan kueri Power BI. Jika kueri Anda menggunakan fungsi yang tidak didukung oleh Konektor Looker–Power BI, pelipatan kueri akan berhenti. Saat pelipatan kueri berhenti, Power BI akan mendownload semua data Anda untuk menghitung hasil secara lokal, yang memperlambat pemuatan laporan dan meningkatkan penggunaan jaringan.

Menyiapkan Power BI Desktop untuk terhubung ke Looker

Langkah-langkah umum untuk menggunakan Konektor Looker–Power BI adalah sebagai berikut:

  1. Verifikasi persyaratan.
  2. Aktifkan konektor di instance Looker Anda.
  3. Mendownload dan menyimpan file konektor: Setiap pengguna yang ingin mengakses Looker–Power BI Connector harus mendownload file looker_1.4.3.mez dan menyimpannya di direktori tertentu di komputer mereka.
  4. Menyiapkan Power BI Desktop untuk konektor kustom: Setiap pengguna Power BI harus mengonfigurasi setelan keamanan Power BI Desktop mereka untuk menggunakan konektor kustom yang tidak bersertifikasi.

Bagian di halaman ini menjelaskan langkah-langkah tersebut secara mendetail.

Setelah menyelesaikan langkah-langkah untuk menghubungkan Looker dengan Power BI Desktop, Anda dapat menghubungkan ke data Looker dari Power BI dan memublikasikan laporan di Power BI. Secara opsional, Anda dapat menggunakan layanan Power BI (Power BI online) untuk berinteraksi dengan laporan Looker di browser web. Anda juga dapat memublikasikan laporan dengan layanan Power BI menggunakan keamanan tingkat baris.

Persyaratan

Untuk menyiapkan Looker–Power BI Connector, Anda memerlukan hal berikut:

  • Microsoft Power BI Desktop diinstal di komputer Anda.
  • Akun pengguna Looker di instance Looker dengan izin explore, yang diperlukan untuk mengakses Eksplorasi di Looker. Jika ingin menggunakan kueri dengan lebih dari 5.000 baris, Anda juga memerlukan izin download_without_limit (lihat Batas baris kueri untuk mengetahui informasi tentang batas download).

Selain itu, instance Looker Anda harus memenuhi persyaratan berikut:

Mengaktifkan konektor di instance Looker Anda

Instance Looker yang ingin Anda gunakan dengan Looker–Power BI Connector harus diaktifkan untuk konektor Microsoft Power BI:

  • Untuk instance Looker (Google Cloud core), konektor BI diaktifkan secara default.
  • Untuk instance Looker (asli), konektor BI dinonaktifkan secara default.

Admin Looker Anda dapat mengaktifkan konektor BI di panel Konektor BI di bagian Platform pada menu Admin Looker.

Mendownload dan menyimpan file konektor

Untuk mendownload file konektor, ikuti langkah-langkah berikut di komputer yang telah diinstal Microsoft Power BI Desktop:

  1. Untuk mendownload file konektor, klik link berikut: looker_1.4.3.mez
  2. Setelah download selesai, pindahkan file looker_1.4.3.mez ke direktori [Documents]\Microsoft Power BI Desktop\Custom Connectors. (Buat folder di komputer Anda jika belum ada.)

Menyiapkan Power BI Desktop untuk konektor kustom

Untuk menyiapkan Looker–Power BI Connector di sisi Power BI Desktop, ikuti petunjuk Custom connectors di situs Microsoft Power BI.

Seperti yang disebutkan dalam petunjuk, di bagian Data Extensions, Anda akan memilih opsi (Not Recommended) Allow any extension to load without validation or warning. Pilih OK, lalu mulai ulang Power BI Desktop.

Menghubungkan ke data Looker dari Power BI Desktop

Setelah mendownload file konektor looker_1.4.3.mez dan menyiapkan aplikasi Power BI Desktop untuk konektor kustom, Anda dapat menggunakan Power BI Desktop untuk terhubung ke data dari instance Looker:

  1. Dari toolbar Power BI Desktop, pilih Get Data > More...
  2. Di dialog Get Data, masukkan Looker di kolom penelusuran.
  3. Di hasil penelusuran, klik entri Looker, lalu klik Hubungkan.
  4. Dalam dialog Connecting to a third-party service, klik Continue.
  5. Power BI Desktop akan menampilkan dialog login Looker. Di kolom Host, ketik URL instance Anda. Contoh: example.cloud.looker.com.
  6. Jika perlu, klik Opsi Lanjutan untuk meluaskan bagian dan mengonfigurasi opsi tambahan berikut:

    • Gunakan drop-down Tampilkan Eksplorasi dan Kolom Tersembunyi untuk menyertakan Eksplorasi dan kolom yang dikonfigurasi sebagai tersembunyi di LookML (untuk mengetahui informasi selengkapnya, lihat dokumentasi untuk tersembunyi (untuk Eksplorasi) dan tersembunyi (untuk kolom)):
      • FALSE (default): Kolom tersembunyi akan disembunyikan.
      • TRUE: Kolom tersembunyi ditampilkan.
    • Gunakan drop-down Aktifkan Logging untuk mengaktifkan atau menonaktifkan log diagnostik dalam konektor untuk tujuan pemecahan masalah. Lihat bagian Mengaktifkan logging debug untuk Power BI Desktop untuk mengetahui informasinya.
  7. Pilih opsi DirectQuery untuk membuat koneksi langsung ke data Anda di Looker.

  8. Klik Oke.

  9. Dalam dialog Looker, klik Login.

  10. Di layar login Looker, login ke instance Looker Anda.

  11. Power BI Desktop akan kembali ke dialog login Looker, dengan pesan yang menyatakan bahwa Anda telah login. Klik Hubungkan.

  12. Power BI Desktop akan menampilkan daftar model Looker yang dapat Anda akses, yang masing-masing ditampilkan sebagai folder. Klik model Looker yang ingin Anda akses, lalu centang kotak di samping Looker Explore yang ingin Anda muat di Power BI Desktop. Untuk melihat model, Anda harus memiliki akses pengguna atau akses grup Looker ke set model yang berisi model tersebut. Untuk mengakses Explore, Anda harus memiliki izin explore Looker.

  13. Klik Load.

Power BI Desktop akan mengisi panel Data dengan kolom dari Explore yang Anda pilih. Kemudian, Anda dapat menggunakan data Looker dari Explore untuk membuat laporan di Power BI Desktop. Lihat Melihat elemen Looker di Power BI Desktop untuk mengetahui informasi tentang cara elemen Looker ditampilkan oleh Looker–Power BI Connector.

Nama kolom akan muncul dalam satu daftar dengan format ViewName.FieldName.

Melihat elemen Looker di Power BI Desktop

Setelah Anda terhubung ke data Looker dari Power BI Desktop, Power BI Desktop akan mengisi panel Data dengan kolom dari Jelajah yang Anda pilih.

Konektor Looker–Power BI menggunakan format berikut untuk menampilkan kolom Looker di Power BI Desktop:

ViewName.FieldType.FieldName

  • Nilai ViewName adalah tabel virtual LookML tempat kolom ditentukan.
  • Nilai FieldType dapat berupa salah satu jenis berikut yang didukung oleh Looker–Power BI Connector:
    • dim: Dimensi, kolom yang merepresentasikan atribut, fakta, atau nilai, seperti tanggal, nama, dan ID. Dimensi sering kali sesuai dengan kolom dalam tabel data pokok Anda. Di LookML, dimensi ditentukan dengan parameter dimension.
    • mea: Ukuran, kolom yang mewakili informasi terukur tentang data Anda, seperti jumlah, hitungan, rata-rata, minimum, dan maksimum. Di LookML, ukuran ditentukan dengan parameter measure.
    • fil: Filter, kolom hanya filter yang hanya digunakan untuk membuat filter dalam kueri Eksplorasi; kolom filter tidak disertakan dalam kumpulan hasil kueri. Di LookML, filter ditentukan dengan parameter filter.
    • par: Parameter, kolom yang hanya digunakan untuk membuat filter dalam kueri Eksplorasi; kolom parameter tidak disertakan dalam kumpulan hasil kueri. Parameter dapat membuat hasil kueri, label, URL, dan lainnya yang interaktif jika ditentukan dengan variabel Liquid {% parameter parameter_name %} dan parameter_name._parameter_value. Di LookML, parameter ditentukan dengan parameter parameter.
  • Nilai FieldName adalah nama kolom sebagaimana ditampilkan di Eksplorasi Looker.

Power BI Desktop menampilkan elemen Looker seperti yang ditampilkan di Looker Explore, dengan kapitalisasi dan spasi kata yang sama. Misalnya, jika Eksplorasi Looker menampilkan dimensi LookML sebagai Created Date dari tampilan yang ditampilkan sebagai Order Items, Power BI Desktop akan menampilkan kolom ini sebagai Order Items.dim.Created Date.

Membuat kueri dengan dimensi dan ukuran Looker

Dengan Looker–Power BI Connector, Anda dapat menggunakan dimensi dan ukuran Looker untuk membuat kueri di Power BI Desktop.

Untuk membuat kueri di Power BI Desktop menggunakan dimensi dan ukuran Looker, ikuti langkah-langkah berikut:

  1. Hubungkan ke data Looker dari Power BI Desktop, dan tunggu hingga Power BI mengisi panel Data dengan kolom dari Jelajah Looker yang Anda pilih.
  2. Di panel Data Power BI, centang kotak untuk setiap dimensi atau ukuran Looker yang ingin Anda sertakan dalam kueri.

Saat Anda memilih setiap dimensi atau ukuran, Power BI akan memperbarui kueri yang ditampilkan di kanvas laporan.

Memfilter kueri dengan filter dan parameter Looker

Looker–Power BI Connector memungkinkan Anda menggunakan parameter dan kolom hanya filter LookML dari Looker Explore untuk menambahkan filter ke laporan Power BI.

Untuk memfilter laporan di Power BI Desktop menggunakan parameter Looker dan kolom hanya filter, ikuti langkah-langkah berikut:

  1. Jika belum melakukannya, hubungkan ke data Looker dari Power BI Desktop dan tunggu hingga Power BI mengisi panel Data dengan kolom dari Jelajah Looker yang Anda pilih.

  2. Di panel Data Power BI, tarik nama parameter atau kolom khusus filter ke salah satu kotak Add data fields here di panel Filters, baik untuk Filters on this page atau untuk Filters on all pages. Lihat dokumentasi Power BI untuk mengetahui detail tentang cara menambahkan filter ke laporan di Power BI.

Perhatikan hal berikut tentang penggunaan parameter Looker dan kolom khusus filter di Power BI:

  • Untuk kolom hanya filter yang dikonfigurasi di LookML dengan parameter suggestions atau parameter suggest_dimension, Power BI akan mengambil nilai saran dan menampilkannya di opsi Basic filtering di panel Filters.
  • Untuk parameter yang dikonfigurasi di LookML dengan atribut allowed_value, Power BI akan mengambil semua nilai yang diizinkan yang dikonfigurasi di LookML untuk parameter tersebut dan menampilkannya di opsi Basic filtering di panel Filters.

Menggunakan DAX dengan Looker–Power BI Connector

DAX (Data Analysis Expressions) adalah bahasa formula yang digunakan di Power BI untuk membuat penghitungan kustom.

Power BI menerjemahkan kueri DAX ke dalam ekspresi Power Query M dan mengirimkannya ke Konektor Looker–Power BI. Looker–Power BI Connector kemudian menerjemahkan ekspresi M ini menjadi panggilan Looker API.

Jika fungsi DAX atau Power Query M tidak didukung, pelipatan kueri akan berhenti. Jika hal ini terjadi, Power BI akan mengambil seluruh tabel mentah dari Looker untuk memproses operasi secara lokal, yang dapat menyebabkan penurunan performa yang signifikan. Lihat bagian Fungsi M Power Query yang didukung untuk mengetahui daftar fungsi yang didukung.

Ukuran versus kolom

Power BI menyediakan dua cara utama untuk membuat data baru menggunakan DAX: New Measure dan New Column.

  • New Measure: Power BI menghitung nilai dinamis ini secara langsung saat Anda menggunakannya dalam visualisasi. Model ini tidak menyimpan nilai ini. Gunakan ukuran terutama untuk menggabungkan data.
    • Contoh: Total Sales = SUM('Sales'[Revenue])
  • Kolom Baru: Power BI menghitung nilai statis ini baris demi baris. Data ini hanya diperbarui saat data dimuat ulang. Model akan menyimpan nilai ini. Gunakan kolom terutama untuk mengategorikan data.
    • Contoh: Profit = 'Sales'[Revenue] - 'Sales'[Cost]

Membuat ukuran baru

Untuk membuat ukuran baru di Power BI, ikuti langkah-langkah berikut:

  1. Di panel Data, klik kanan tabel tempat Anda ingin menambahkan ukuran.
  2. Pilih Ukuran baru.
  3. Di kolom formula, masukkan formula DAX Anda. Ganti Measure dengan nama ukuran yang Anda pilih.

Membuat kolom baru

Untuk membuat kolom baru di Power BI, ikuti langkah-langkah berikut:

  1. Di panel Data, klik kanan tabel tempat Anda ingin menambahkan kolom.
  2. Pilih Kolom baru.
  3. Di kolom formula, masukkan formula DAX Anda. Ganti Column dengan nama kolom yang Anda pilih.

Contoh kueri DAX

Tabel berikut memberikan contoh kueri DAX untuk agregasi umum. Untuk mengetahui informasi selengkapnya, lihat dokumentasi DAX.

Tabel berikut memberikan beberapa contoh cara membuat ukuran untuk agregasi umum.

Jenis agregasi Contoh
SUM Total Sales = SUM('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
RATA-RATA Average Sale Price = AVERAGE('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
MIN Minimum Sale Price = MIN('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
MAKS Maximum Sale Price = MAX('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price])
COUNT Order Count = COUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID])
DISTINCTCOUNT Distinct Order Count = DISTINCTCOUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID])

Tabel berikut menunjukkan cara melakukan operasi aritmetika dasar.

Jenis agregasi Contoh
Penambahan Total Orders = [Shipped Orders] + [Pending Orders]
Pengurangan Total Profit = [Total Sales] - [Total Cost]
Perkalian Total Sales with Tax = [Total Sales] * 1.05
Pembagian Profit Margin = DIVIDE([Total Profit], [Total Sales])
Daya Sales Squared = POWER([Total Sales], 2)
atau
Sales Squared = [Total Sales] ^ 2
Akar kuadrat Square Root of Sales = SQRT([Total Sales])
Modulus Order ID Type =
IF(
MOD('The Look E-Commerce'[Order Items Ecomm.dim.Order ID], 2) = 0,
"Even",
"Odd"
)
Nilai absolut Absolute Profit = ABS([Total Profit])

Fungsi Power Query M yang didukung

Saat Anda menggunakan Looker–Power BI Connector dalam mode DirectQuery, Power BI akan menghasilkan ekspresi Power Query M untuk setiap visualisasi, filter, dan penghitungan DAX. Looker–Power BI Connector menerjemahkan ekspresi ini menjadi kueri langsung menggunakan Looker API.

Teks

  • Text.From
  • Text.At
  • Text.Combine
  • Text.Contains (Text.Contains peka huruf besar/kecil)
  • Text.End
  • Text.EndsWith
  • Text.Length
  • Text.Lower
  • Text.Upper
  • Text.Middle
  • Text.PositionOf
  • Text.Range
  • Text.RemoveRange
  • Text.Replace
  • Text.Start
  • Text.StartsWith
  • Text.Insert
  • Text.Split
  • Text.FromBinary

Daftar dan tabel

  • Value.Equals/Value.NullableEquals
  • Table.RowCount
  • Table.First
  • Table.FirstN
  • Table.SelectRows
  • Table.Sort
  • List.Sum
  • List.Average
  • List.Max
  • List.Min
  • List.Count
  • List.Distinct
  • List.Select
  • List.Contains
  • List.AnyTrue

Angka

Aritmetika dasar
  • Value.Add
  • Value.Subtract
  • Value.Multiply
  • Value.Divide
Matematika ilmiah dan tingkat lanjut
  • Number.Power
  • Number.Sqrt
  • Number.Exp
  • Number.Ln
  • Number.Log10
  • Number.Log
  • Number.PI
Properti angka
  • Number.Sign
  • Number.IsEven
  • Number.IsOdd
  • Number.Abs
Pembagian dan sisa
  • Number.Mod
  • Number.IntegerDivide
Pembuatan angka acak
  • Number.Random
  • Number.RandomBetween
Konversi jenis

Konektor tidak mendukung penggunaan fungsi konversi numerik berikut dalam visualisasi:

  • Byte.From
  • Currency.From
  • Decimal.From
  • Int8.From, Int16.From, Int32.From, Int64.From
  • Number.From, Number.FromText
  • Single.From, Double.From

Pembulatan numerik

  • Number.Round
  • Number.RoundDown
  • Number.RoundUp
  • Number.RoundTowardZero
  • Number.RoundAwayFromZero

Tabel berikut menunjukkan contoh untuk setiap operasi pembulatan:

Input Number.Round Number.RoundDown Number.RoundUp Number.RoundTowardZero Number.RoundAwayFromZero
2.7 3 2 3 2 3
2,5 3 2 3 2 3
2.2 2 2 3 2 3
0 0 0 0 0 0
-2.2 -2 -3 -2 -2 -3
-2,5 -3 -3 -2 -2 -3
-2.7 -3 -3 -2 -2 -3

Tanggal dan waktu

Mendapatkan tanggal dan waktu saat ini
  • DateTime.LocalNow
  • DateTime.FixedLocalNow
  • DateTimeZone.UtcNow
  • DateTimeZone.FixedUtcNow
  • DateTimeZone.LocalNow
  • DateTimeZone.FixedLocalNow
Konversi jenis datetime
  • DateTime.FromText
  • DateTimeZone.FromText
  • DateTime.From
  • DateTimeZone.From
  • Date.FromText
  • Time.ToText
Aritmetika tanggal
  • Date.AddDays
  • Date.AddMonths
  • Date.AddYears
Mengekstrak bagian tanggal dan waktu
  • Date.Day
  • Date.Month
  • Date.Year
  • Time.Hour
  • Time.Minute
  • Time.Second
  • DateTime.Time
Batas periode tanggal dan waktu
  • Date.StartOfDay
  • Date.StartOfYear
  • Date.EndOfDay
  • Date.EndOfYear
  • Time.StartOfHour
  • Time.EndOfHour

Fungsi tingkat tinggi

Konektor Looker–Power BI mendukung fungsi tingkat tinggi berikut, asalkan Konektor Looker–Power BI juga mendukung operasi bertingkat.

  • Table.AddColumn

    • Batasan: Konektor Looker–Power BI harus mendukung fungsi yang ditentukan dalam parameter columnGenerator.
    • Contoh: Kueri berikut berfungsi karena Konektor Looker–Power BI mendukung fungsi bertingkat Text.Length: powerquery Table.AddColumn(LookerTable, "NewColumnName", each Text.Length([lookerTextDimensionColumn]))
  • Table.Group

    • Batasan: Looker–Power BI Connector harus mendukung fungsi agregasi apa pun yang digunakan dalam daftar aggregatedColumns.
    • Contoh: Kueri berikut berfungsi karena Looker–Power BI Connector mendukung fungsi bertingkat List.Sum: powerquery Table.Group(LookerTable, "CustomerID", {"total", each List.Sum([price])})

Menggunakan ukuran Looker di Power BI dalam mode DirectQuery

Banyak visualisasi Power BI yang menggunakan diagram kolom, batang, dan garis memerlukan nilai gabungan pada sumbu Y. Power BI memerlukan satu nilai untuk menentukan tempat untuk memetakan titik data, seperti tinggi kolom atau posisi garis. Tanpa penggabungan, visualisasi tidak akan dirender.

Misalnya, berikut adalah visualisasi ukuran Looker type: sum yang menampilkan total biaya per item:

Visualisasi Looker untuk total biaya per item

Power BI tidak akan menampilkan ukuran type: sum di sebagian besar visualisasi kecuali jika Anda menerapkan agregasi. Untuk menampilkan jumlah, Anda dapat menetapkan agregasi Power BI ke Sum. Berikut adalah visualisasi yang dihasilkan di Power BI menggunakan agregasi jumlah:

Visualisasi Sum di Power BI

Demikian pula, Anda dapat menggunakan agregasi jumlah Power BI untuk memvisualisasikan ukuran Looker yang menggunakan jenis agregasi berikut:

Menggunakan fitur Power BI dengan Looker–Power BI Connector

Bagian berikut menjelaskan dukungan Konektor Looker–Power BI untuk berbagai fitur Power BI:

Sparkline

Menambahkan diagram bentuk ke visualisasi tabel atau matriks. Untuk mengetahui informasi selengkapnya, lihat dokumentasi sparkline Power BI.

Format bersyarat

Pemformatan bersyarat dapat diterapkan ke visualisasi tabel atau matriks. Looker–Power BI Connector mendukung pemformatan bersyarat untuk kolom numerik, tetapi tidak untuk kolom teks. Untuk mengetahui petunjuk penyiapan umum, lihat dokumentasi Power BI.

Konversi jenis

Looker–Power BI Connector tidak mendukung konversi kolom menjadi angka atau tanggal dalam visualisasi. Namun, konektor mendukung konversi kolom menjadi teks dan penggunaan kolom tersebut dalam visualisasi.

Terhubung dengan Excel

Anda dapat memuat data dari Looker langsung ke Excel untuk Desktop atau Excel untuk web. Untuk petunjuk penyiapan, lihat dokumentasi Power BI Connect Excel to Power BI datasets.

Saat menggunakan Looker–Power BI Connector di Excel, fungsinya mirip dengan mode DirectQuery di Power BI. Saat data difilter, konektor akan menerapkan filter di sumber sebelum memuat data ke Excel.

Anda dapat terhubung ke data menggunakan salah satu metode berikut di Excel:

Menyisipkan PivotTable

Untuk menyisipkan PivotTable yang terhubung langsung ke set data, ikuti langkah-langkah berikut:

  1. Pilih tab Sisipkan.
  2. Pilih PivotTable > From Power BI.

Mendapatkan data

Untuk mengimpor data menggunakan pita Data, ikuti langkah-langkah berikut:

  1. Pilih tab Data.
  2. Pilih Get Data > From Fabric & Power Platform > From Power BI.

Memantau Konektor Looker–Power BI

Admin Looker dapat melihat penggunaan Konektor Looker–Power BI menggunakan grup kolom Query API Client Properties di System Activity History Explore. Entri dibuat di Eksplorasi History setiap kali kueri baru dijalankan.

Di grup kolom Query API Client Properties, API Client Name menampilkan nilai Power BI untuk mengidentifikasi entri Looker–Power BI Connector.

Berikut adalah contoh URL Aktivitas Sistem yang menampilkan penggunaan Power BI. Ganti <instance_name.looker.com> dengan URL instance Anda.

https://<instance_name.looker.com>/explore/system__activity/history?fields=query_api_client_context.name,user.name,history.created_date,history.created_time_of_day&f[query_api_client_context.name]=Power+BI&sorts=history.created_time_of_day+desc&limit=5000

Layanan Power BI

Setelah terhubung ke data Looker dari Power BI dan memublikasikan laporan di Power BI, Anda dapat menggunakan layanan Power BI (Power BI online) untuk berinteraksi dengan laporan Looker di browser web.

Anda juga dapat memublikasikan laporan dengan layanan Power BI menggunakan keamanan tingkat baris.

Pertimbangan autentikasi

Saat Anda memublikasikan laporan ke layanan Power BI, kredensial yang Anda gunakan untuk membuat laporan akan disematkan dalam laporan. Kredensial ini digunakan kembali untuk semua pengguna yang melihat laporan di layanan Power BI.

Penggunaan kembali kredensial ini terjadi karena framework konektor Microsoft Power BI tidak mendukung autentikasi single sign-on (SSO) pengguna akhir untuk konektor kustom. Untuk membatasi akses data berdasarkan pengguna yang melihat laporan, gunakan keamanan tingkat baris (RLS) dalam Power BI.

Memublikasikan laporan dengan layanan Power BI menggunakan keamanan tingkat baris

Setelah memublikasikan laporan di Power BI Desktop menggunakan Konektor Looker–Power BI, Anda dapat secara opsional menggunakan layanan Power BI untuk berinteraksi dengan laporan dari browser web.

Power BI Desktop memungkinkan Anda menggunakan keamanan tingkat baris (RLS) untuk membatasi akses data bagi pengguna tertentu. Lihat dokumentasi Power BI untuk mengetahui prosedur menentukan peran dan aturan serta memvalidasi peran dalam Power BI Desktop.

Setelah menentukan peran di Power BI Desktop, Anda dapat menggunakan peran dan aturan secara online dengan layanan Power BI.

Untuk memublikasikan laporan dengan layanan Power BI menggunakan keamanan tingkat baris, ikuti langkah-langkah berikut:

  1. Di Power BI Desktop, buka laporan Anda dan pilih menu Beranda dari bagian atas jendela.
  2. Pilih opsi Publikasikan dari menu Beranda.
  3. Pilih ruang kerja dari menu drop-down, lalu klik Pilih. Power BI Desktop menampilkan pesan berhasil yang menyertakan link untuk membuka laporan di Power BI.
  4. Klik link untuk membuka Power BI.
  5. Di layanan Power BI, buka Workspaces dan pilih ruang kerja tempat Anda memublikasikan laporan.
  6. Temukan listingan untuk set data laporan Anda (bukan laporan itu sendiri).
  7. Di daftar set data, klik menu tiga titik Opsi lainnya, lalu pilih Keamanan.

Power BI akan menampilkan jendela Row-Level Security. Dari sini, Anda dapat memilih peran yang Anda buat di Power BI Desktop dan menambahkan orang atau grup yang termasuk dalam peran tersebut dan memvalidasi peran Anda di layanan Power BI.

Sekarang Anda dapat membagikan laporan kepada siapa pun yang Anda inginkan, dan mereka hanya akan melihat data yang diizinkan untuk mereka lihat, berdasarkan peran yang Anda buat.

Mengaktifkan logging debug untuk Power BI Desktop

Untuk memecahkan masalah atau mendiagnosis masalah, Anda dapat mengaktifkan logging untuk koneksi antara Power BI dan Looker.

Anda harus mengaktifkan logging untuk koneksi dan juga untuk Power BI itu sendiri, seperti yang dijelaskan di bagian berikut:

Mengaktifkan logging tingkat konektor

Untuk memecahkan masalah, Anda dapat mengaktifkan logging diagnostik dalam Konektor Looker–Power BI.

Saat Anda membuat koneksi baru ke data Looker dari Power BI Desktop, aktifkan logging dengan mengikuti langkah-langkah berikut:

  1. Dalam dialog koneksi Looker, luaskan Opsi Lanjutan.
  2. Pilih TRUE dari menu drop-down Enable Logging.

Jika Anda telah membuat koneksi ke data Looker dari Power BI Desktop, Anda harus mengedit kueri secara manual dalam editor Power Query dengan mengikuti langkah-langkah berikut:

  1. Di Power BI Desktop, pilih Transform Data.
  2. Di pita Home, pilih Advanced Editor.
  3. Temukan baris yang dimulai dengan Source = Looker.DataSource.
  4. Perbarui argumen kedua fungsi untuk menyertakan EnableLogging=true.

    Looker.DataSource("instance.looker.com", [EnableLogging=true])
    
  5. Klik Done.

Mengaktifkan pelacakan tingkat Power BI

Selain mengaktifkan logging pada koneksi ke data Looker dari Power BI Desktop, Anda juga harus mengaktifkan pelacakan dari Power BI Desktop dengan mengikuti langkah-langkah berikut:

  1. Pilih File > Options and settings > Options.
  2. Dalam dialog Options, pilih Diagnostics.
  3. Di bagian Diagnostic Options, pilih Enable tracing.
  4. Untuk melihat file log, pilih Open file dump error/traces folder.

Hal-hal yang perlu dipertimbangkan

Batas baris kueri

Kueri dari Looker–Power BI Connector akan otomatis menyertakan pernyataan LIMIT 5000, kecuali jika akun pengguna Looker memiliki izin download_without_limit. Jika akun pengguna Looker memiliki download_without_limit, kueri dari Looker–Power BI Connector tidak memiliki batas baris kueri yang diberlakukan.

Filter Eksplorasi

Jika Looker Explore ditentukan dengan parameter LookML always_filter atau conditionally_filter, filter akan diterapkan ke kueri di Looker–Power BI Connector, meskipun filter tidak akan terlihat di Power BI.

Rentang waktu grup dimensi yang didukung

Untuk dimension_group dari type: time, hanya jangka waktu date dan time yang didukung dengan Looker–Power BI Connector. Rentang waktu lainnya akan disembunyikan.

Eksplorasi Aktivitas Sistem tidak ditampilkan dengan Konektor Looker–Power BI

Eksplorasi Aktivitas Sistem tidak ditampilkan di Looker–Power BI Connector. Admin Looker dapat melihat Eksplorasi Aktivitas Sistem langsung di UI Looker.

Batasan konversi jenis

Jika memungkinkan, sebaiknya tetapkan jenis kolom di dalam tampilan LookML Anda.

Batasan umum

Perhatikan batasan berikut saat menggunakan Konektor Looker–Power BI:

Pemodelan dan mode data

  • Dimensi numerik: Dimensi dan ukuran numerik muncul sebagai ukuran di Power BI. Untuk menggunakan dimensi numerik sebagai dimensi, Anda harus mengubah ringkasan defaultnya menjadi Do not summarize di Power BI Desktop.
  • Mode impor: Untuk performa yang optimal, gunakan Mode DirectQuery. Jika Anda menggunakan Mode Impor Power BI, perhatikan batasan berikut:
    • Performa: Laporan yang mengakses model besar mungkin dimuat dengan lambat.
    • Waktu tunggu habis: Jika proses "Dapatkan Data" terhenti atau waktu tunggu habis, beralihlah ke Mode DirectQuery.
    • Batasan kolom: Mode Impor menonaktifkan kolom khusus filter dan kolom parameter.
    • Evaluasi ukuran: Mode impor membatasi Looker untuk mengevaluasi ukuran dalam Eksplorasi, yang dapat memengaruhi akurasi laporan.

Agregasi

Power BI menerapkan agregasinya sendiri ke ukuran Looker. Hal ini dapat menyebabkan error atau hasil yang tidak konsisten, terutama dalam visual matriks.

  • Jenis yang didukung: Hanya gunakan average, count, count_distinct, max, min, dan sum.
  • Jenis yang tidak didukung: Konektor tidak mendukung kueri untuk deviasi standar, varians, atau agregasi string pertama atau terakhir menurut abjad.
  • Performa median: Power BI menghitung median secara lokal dengan mengambil semua nilai. Hal ini lambat pada set data besar dan mungkin akan kehabisan waktu.

Memfilter dan mengurutkan

  • Mengurutkan menurut kolom tersembunyi: Anda tidak dapat mengurutkan menurut kolom yang tidak disertakan dalam visualisasi. Untuk mengurutkan menurut kolom, tambahkan kolom tersebut ke visualisasi.
  • Batasan filter lanjutan: Karena perbedaan antara Power Query dan ekspresi filter Looker, batasan berikut berlaku:
    • Teks: Beberapa filter teks tidak didukung.
    • Tanggal: Untuk kolom tanggal dan tanggal waktu, hanya is, is not, is on or after, dan is before yang didukung.
    • Beberapa filter angka hanya didukung dalam kasus berikut:
      • KETIDAKSAMAAN DAN KETIDAKSAMAAN (misalnya, kurang dari DAN lebih besar dari).
      • KETIDAKSAMAAN ATAU KETIDAKSAMAAN (misalnya, kurang dari ATAU lebih besar dari).
      • adalah ATAU adalah.
    • Beberapa filter tanggal dan datetime hanya didukung dalam kasus berikut:
      • is on or after AND is before
      • is or is

Fungsi Power Query

Fungsi tabel berikut tidak dapat dilipat:

  • Table.Distinct
  • Table.Join
  • Table.NestedJoin
  • Table.Skip

Pemecahan masalah

Bagian berikut menjelaskan masalah umum dan solusinya.

Konektor Looker–Power BI tidak muncul dalam daftar Get Data Power BI

Pastikan direktori [Documents]\Microsoft Power BI Desktop\Custom Connectors berisi file looker_1.4.3.mez.

  1. Di Power BI Desktop, verifikasi setelan keamanan:
  2. Pilih File > Options and settings > Options.
  3. Pilih Keamanan.
  4. Di bagian Ekstensi Data, pilih (Tidak Direkomendasikan) Izinkan ekstensi apa pun dimuat tanpa validasi atau peringatan.
  5. Klik Oke.
  6. Mulai ulang Power BI Desktop.

Error: Nama kolom hanya boleh berisi huruf, angka, dan garis bawah

Dalam beberapa kasus, Anda mungkin menerima pesan error berikut saat memuat ulang data atau menerapkan perubahan:

DataSource.Error
Message: A LookML model issue has occurred.
Details: Invalid field name "...". Field names may only include letters, numbers and underscores and must start with a letter or underscore for Google BigQuery Standard SQL

Error ini terjadi saat nama kolom berisi spasi atau karakter khusus yang tidak didukung oleh database pokok (seperti BigQuery).

Untuk mengatasi masalah ini, ikuti langkah-langkah berikut:

  1. Identifikasi kolom yang menyebabkan error (biasanya dirujuk di bagian Details pada pesan error).
  2. Ganti nama kolom agar hanya menggunakan huruf, angka, dan garis bawah.
    • Salah: Custom Column Name
    • Benar: Custom_Column_Name

Error: Terjadi error saat mengambil data untuk visualisasi ini

Dalam beberapa kasus, Anda mungkin menerima error autentikasi di Power BI yang menunjukkan kegagalan OAuth atau masalah kredensial, seperti Looker database authentication required.

Jika Anda melihat error ini, berarti akun Looker Anda tidak memiliki kredensial OAuth yang diperlukan untuk koneksi database. Untuk menyelesaikannya, ikuti langkah-langkah berikut:

  1. Login ke instance Looker Anda.
  2. Pilih ikon profil pengguna Anda, lalu pilih Akun.
  3. Buka bagian OAuth Connection Credentials.
  4. Temukan koneksi yang ingin Anda akses, lalu pilih Login.
  5. Kembali ke Power BI Desktop dan muat ulang data.

Log perubahan Looker–Power BI Connector

Bagian berikut menunjukkan update di setiap versi Looker–Power BI Connector:

Versi 1.4.3

Konektor Looker–Power BI versi 1.4.3 memiliki update berikut:

  • Label konektor kini menyertakan nomor versi konektor.
  • Menambahkan opsi Enable Logging baru untuk mengaktifkan log diagnostik secara dinamis dalam konektor untuk tujuan pemecahan masalah.
  • Menambahkan opsi Tampilkan Eksplorasi dan Kolom Tersembunyi baru. Jika diaktifkan, eksplorasi dan kolom tersembunyi akan ditampilkan. Opsi ini menggantikan opsi Tampilkan Kolom Tersembunyi sebelumnya.

Konektor Looker–Power BI versi 1.4.3 memiliki perbaikan bug berikut:

  • Memperbaiki masalah saat operator DAX penyambungan string (&) gagal.
  • Memperbaiki masalah saat penerapan ukuran Power BI ke ukuran Looker menyebabkan error.
  • Menu Konfigurasi Kredensial kini menampilkan ikon Looker lagi.

Versi 1.4.2

Konektor Looker–Power BI versi 1.4.2 memiliki update berikut:

  • Setelan koneksi Nonaktifkan Pengoptimalan Pratinjau telah dihapus.
  • Opsi koneksi Tampilkan Kolom Tersembunyi telah dipindahkan ke bagian Opsi Lanjutan.
  • Flag Beta telah dihapus; konektor tidak lagi muncul sebagai beta di Power BI.

Looker–Power BI Connector versi 1.4.2 memiliki perbaikan bug berikut:

  • Memperbaiki error regresi saat pemotong Boolean dan pemotong tanggal gagal di Power BI.
  • Memperbaiki filter is-not yang tidak berfungsi untuk filter dates.

Versi 1.4.0

Looker–Power BI Connector versi 1.4.0 memiliki update berikut:

  • Menambahkan dukungan untuk Mode Impor
  • Mengaktifkan pratinjau data
  • Peningkatan perilaku saat menjalankan kueri SELECT *
  • Peningkatan rasio cache ditemukan Looker
  • Peningkatan performa pengambilan saran filter

Konektor Looker–Power BI versi 1.4.0 memiliki perbaikan bug berikut:

  • Memperbaiki bug yang menyebabkan Looker tidak mendeteksi bahwa nilai telah diteruskan untuk kolom filter dan parameter
  • Memperbaiki bug yang menyebabkan nilai yang disarankan parameter terkadang tidak ada di pemotong
  • Memperbaiki bug yang menyebabkan variabel Liquid diabaikan oleh pernyataan LookML
  • Memperbaiki bug yang menyebabkan nilai ukuran hitung yang berbeda tidak konsisten dalam tampilan matriks Power BI

Versi 1.3.1

Looker–Power BI Connector versi 1.3.1 memiliki update berikut:

  • Menambahkan opsi untuk menampilkan kolom tersembunyi

Konektor Looker–Power BI versi 1.3.1 memiliki perbaikan bug berikut:

  • Memperbaiki bug yang menyebabkan visual gagal jika filter ada di visual dan laporan

Versi 1.3.0

Konektor Looker–Power BI versi 1.3.0 memiliki update berikut:

  • Pemformatan tanggal dan waktu yang disederhanakan
  • Peningkatan deteksi pada ekspresi teks yang tidak didukung
  • Peningkatan pelaporan pesan error

Looker–Power BI Connector versi 1.3.0 memiliki perbaikan bug berikut:

  • Peningkatan dukungan untuk karakter escape dalam nilai filter

Versi 1.2.0

Konektor Looker–Power BI versi 1.2.0 memiliki update berikut:

  • Kolom parameter dan hanya filter kini didukung
  • Dukungan filter lanjutan untuk kolom khusus filter dengan jenis teks, angka, tanggal, dan tanggal dan waktu
  • Dukungan filter dasar untuk kolom hanya filter yang menggunakan nilai yang disarankan Looker