המחבר של Looker ל-Power BI מאפשר לכם להשתמש ב-Microsoft Power BI Desktop כדי להתחבר לנתונים מExplore ב-Looker.
המחבר של Looker ל-Power BI מיועד לשימוש עם מצב DirectQuery של Power BI.
כשמשתמשים במחבר Looker – Power BI במצב DirectQuery, Power BI לא מייבא או מעתיק את הנתונים. במקום זאת, Power BI יוצר ביטוי Power Query M לכל תצוגה חזותית, מסנן וחישוב DAX. מחבר Looker–Power BI מתרגם את הביטויים האלה לשאילתות בזמן אמת באמצעות Looker API.
התהליך הזה מסתמך על קיפול שאילתות ב-Power BI. אם השאילתה משתמשת בפונקציה שהמחבר Looker–Power BI לא תומך בה, קיפול השאילתה מפסיק. כשהקיפול של השאילתות נפסק, Power BI מוריד את כל הנתונים כדי לחשב את התוצאות באופן מקומי, מה שמאט את טעינת הדוחות ומגביר את השימוש ברשת.
הגדרת Power BI Desktop לחיבור ל-Looker
אלה השלבים הכלליים לשימוש בכלי Looker–Power BI Connector:
- בודקים את הדרישות.
- מפעילים את המחבר במכונה של Looker.
- הורדה ושמירה של קובץ המחבר: כל משתמש שרוצה לגשת ל-Looker–Power BI Connector צריך להוריד את הקובץ
looker_1.4.3.mezולשמור אותו בספרייה ספציפית במחשב שלו. - הגדרת Power BI Desktop למחבר בהתאמה אישית: כל משתמש ב-Power BI צריך להגדיר את הגדרות האבטחה של Power BI Desktop כדי להשתמש במחבר בהתאמה אישית שלא אושר.
השלבים האלה מתוארים בפירוט בקטעים שבדף הזה.
אחרי שמבצעים את השלבים לחיבור Looker ל-Power BI Desktop, אפשר להתחבר לנתונים של Looker מ-Power BI ולפרסם דוחות ב-Power BI. אתם יכולים גם להשתמש בשירות Power BI (Power BI אונליין) כדי לעבוד עם דוחות Looker בדפדפן אינטרנט. אפשר גם לפרסם דוחות באמצעות שירות Power BI עם אבטחה ברמת השורה.
דרישות
כדי להגדיר את Looker–Power BI Connector, צריך:
- Microsoft Power BI Desktop מותקן במחשב.
- חשבון משתמש ב-Looker במכונה של Looker עם ההרשאה
explore, שנדרשת כדי לגשת ל-Explores ב-Looker. אם רוצים לעבוד עם שאילתות שמכילות יותר מ-5,000 שורות, צריך גם את ההרשאהdownload_without_limit(מידע על מגבלות ההורדה זמין במאמר מגבלות על שורות בשאילתות).
בנוסף, המכונה של Looker צריכה לעמוד בדרישות הבאות:
- צריך להפעיל את המחבר Microsoft Power BI במופע. אדמין ב-Looker צריך להפעיל את המתג Microsoft Power BI בדף BI Connectors ב-Looker.
- מכונות של Looker (Google Cloud core) שמוגדרות לחיבורים פרטיים ומכונות של Looker באירוח בצד הלקוח צריכות לעמוד בדרישות הבאות:
- המכונה צריכה להריץ Looker 25.16 ואילך.
- מנהל הרשת צריך להגדיר את הרשת כך שתנועה מ-Looker–Power BI Connector תוכל להגיע למכונה של Looker.
הפעלת המחבר במכונה של Looker
במכונה של Looker שבה רוצים להשתמש עם המחבר של Looker ל-Power BI, צריך להפעיל את המחבר של Microsoft Power BI:
- במקרים של מופעים של Looker (Google Cloud core), מחברי BI מופעלים כברירת מחדל.
- במופעים של Looker (המקורי), מחברי BI מושבתים כברירת מחדל.
האדמין של Looker יכול להפעיל את מחברי ה-BI בחלונית מחברי ה-BI בקטע Platform בתפריט Admin של Looker.
הורדה ושמירה של קובץ המחבר
כדי להוריד את קובץ המחבר, פועלים לפי השלבים הבאים במחשב שבו מותקן Microsoft Power BI Desktop:
- כדי להוריד את קובץ המחבר, לוחצים על הקישור הבא:
looker_1.4.3.mez - בסיום ההורדה, מעבירים את הקובץ
looker_1.4.3.mezלספרייה [Documents]\Microsoft Power BI Desktop\Custom Connectors. (אם התיקיות לא קיימות במחשב, צריך ליצור אותן).
הגדרת Power BI Desktop למחבר בהתאמה אישית
כדי להגדיר את המחבר של Looker ל-Power BI בצד של Power BI Desktop, פועלים לפי ההוראות בנושא מחברים בהתאמה אישית באתר של Microsoft Power BI.
כמו שכתוב בהוראות, בקטע Data Extensions (תוספים לנתונים), בוחרים באפשרות (Not Recommended) Allow any extension to load without validation or warning (לא מומלץ) לאפשר לכל תוסף להיטען ללא אימות או אזהרה. לוחצים על אישור ומפעילים מחדש את Power BI Desktop.
התחברות לנתוני Looker מ-Power BI Desktop
אחרי שמורידים את קובץ המחבר looker_1.4.3.mez ומגדירים את אפליקציית Power BI Desktop למחבר בהתאמה אישית, אפשר להשתמש ב-Power BI Desktop כדי להתחבר לנתונים ממופע Looker:
- בסרגל הכלים של Power BI Desktop, בוחרים באפשרות קבלת נתונים > עוד...
- בתיבת הדו-שיח Get Data, מזינים Looker בשדה החיפוש.
- בתוצאות החיפוש, לוחצים על הרשומה Looker ואז על Connect.
- בתיבת הדו-שיח מתבצעת התחברות לשירות של צד שלישי, לוחצים על המשך.
- ב-Power BI Desktop תופיע תיבת דו-שיח לכניסה ל-Looker. בשדה מארח, מקלידים את כתובת ה-URL של המכונה. לדוגמה:
example.cloud.looker.com. אופציונלי: לוחצים על אפשרויות מתקדמות כדי להרחיב את הקטע ולהגדיר את האפשרויות הנוספות הבאות:
- בתפריט הנפתח Show Hidden Explores and Fields, אפשר לכלול ניתוחים ושדות שמוגדרים כמוסתרים ב-LookML (מידע נוסף זמין במסמכי התיעוד בנושא hidden (for Explores) ו-hidden (for fields)):
- FALSE (ברירת מחדל): שדות מוסתרים לא מוצגים.
- TRUE: שדות מוסתרים מוצגים.
- כדי להפעיל או להשבית יומני אבחון במחבר לצורך פתרון בעיות, משתמשים בתפריט הנפתח Enable Logging (הפעלת רישום ביומן). מידע נוסף זמין בקטע הפעלת רישום ביומן של ניפוי באגים ב-Power BI Desktop.
- בתפריט הנפתח Show Hidden Explores and Fields, אפשר לכלול ניתוחים ושדות שמוגדרים כמוסתרים ב-LookML (מידע נוסף זמין במסמכי התיעוד בנושא hidden (for Explores) ו-hidden (for fields)):
בוחרים באפשרות DirectQuery כדי ליצור חיבור פעיל לנתונים ב-Looker.
לוחצים על OK.
בתיבת הדו-שיח Looker, לוחצים על כניסה.
במסך הכניסה ל-Looker, נכנסים למופע Looker.
Power BI Desktop יחזור לתיבת הדו-שיח של הכניסה ל-Looker, עם הודעה שאתם מחוברים. לוחצים על Connect.
ב-Power BI Desktop תוצג רשימה של מודלים של Looker שיש לכם גישה אליהם, וכל אחד מהם מיוצג כתיקייה. לוחצים על מודל Looker שרוצים לגשת אליו, ואז מסמנים את התיבה לצד ה-Looker Explore שרוצים לטעון ב-Power BI Desktop. כדי לראות מודל, צריכה להיות לכם גישה למשתמש Looker או גישה לקבוצה של קבוצת מודלים שמכילה את המודל. כדי לגשת לניתוחים, צריכה להיות לכם ההרשאה
exploreב-Looker.לוחצים על טעינה.
השדות מהניתוח שבחרתם יופיעו בחלונית Data ב-Power BI Desktop. לאחר מכן תוכלו להשתמש בנתוני Looker מה-Explore כדי ליצור דוחות ב-Power BI Desktop. במאמר הצגת רכיבי Looker ב-Power BI Desktop מוסבר איך המחבר Looker–Power BI מציג את רכיבי Looker.
שמות השדות יופיעו ברשימה אחת בפורמט ViewName.FieldName.
הצגת רכיבי Looker ב-Power BI Desktop
אחרי התחברות לנתוני Looker מ-Power BI Desktop, החלונית Data ב-Power BI Desktop תתמלא בשדות מניתוח הנתונים שנבחר.
המחבר של Looker ל-Power BI משתמש בפורמט הבא כדי להציג שדות של Looker ב-Power BI Desktop:
ViewName.FieldType.FieldName
- הערך
ViewNameהוא התצוגה של LookML שבה מוגדר השדה. - הערך
FieldTypeיכול להיות אחד מהסוגים הבאים שנתמכים על ידי המחבר Looker–Power BI:-
dim: מאפיין, שדה שמייצג תכונה, עובדה או ערך, כמו תאריכים, שמות ומזהים. מאפיינים בדרך כלל תואמים לעמודות בטבלת הנתונים הבסיסית. ב-LookML, מאפיינים מוגדרים באמצעות הפרמטרdimension. -
mea: מדד, שדה שמייצג מידע מדיד על הנתונים, כמו סכומים, ספירות, ממוצעים, ערכי מינימום וערכי מקסימום. ב-LookML, מדדים מוגדרים באמצעות הפרמטרmeasure. -
fil: מסנן, שדה מסנן בלבד שמשמש רק ליצירת מסנן בשאילתת Explore. שדות מסנן לא נכללים בקבוצת התוצאות של שאילתה. ב-LookML, מסננים מוגדרים באמצעות הפרמטרfilter. -
par: פרמטר, שדה שמשמש רק ליצירת מסנן בשאילתת Explore. שדות של פרמטרים לא נכללים בקבוצת התוצאות של השאילתה. פרמטר יכול ליצור תוצאות אינטראקטיביות של שאילתות, תוויות, כתובות URL ועוד, כשהוא מוגדר עם משתני Liquid מסוג{% parameter parameter_name %}ו-parameter_name._parameter_value. ב-LookML, מגדירים פרמטרים באמצעות הפרמטרparameter.
-
- הערך
FieldNameהוא שם השדה כפי שהוא מוצג ב-Looker Explore.
רכיבי Looker מוצגים ב-Power BI Desktop בדיוק כמו שהם מוצגים ב-Looker Explore, עם אותיות רישיות ורווחים בין המילים זהים. לדוגמה, אם ב-Looker Explore מוצג מאפיין LookML בתור Created Date מתצוגה שמוצגת בתור Order Items, ב-Power BI Desktop השדה הזה יוצג בתור Order Items.dim.Created Date.
יצירת שאילתות באמצעות מאפיינים ומדדים של Looker
המחבר של Looker ל-Power BI מאפשר לכם להשתמש במאפיינים ובמדדים של Looker כדי ליצור שאילתות ב-Power BI Desktop.
כדי ליצור שאילתה ב-Power BI Desktop באמצעות מאפיינים ומדדים של Looker, מבצעים את השלבים הבאים:
- מתחברים לנתוני Looker מ-Power BI Desktop וממתינים עד ש-Power BI יאכלס את החלונית Data בשדות מה-Explore שנבחר ב-Looker.
- בחלונית Data ב-Power BI, מסמנים את התיבה לצד כל מאפיין או מדד של Looker שרוצים לכלול בשאילתה.
כשבוחרים כל מאפיין או מדד, Power BI מעדכן את השאילתה שמוצגת בדוח.
סינון שאילתות באמצעות מסננים ופרמטרים של Looker
המחבר Looker–Power BI מאפשר להשתמש בפרמטרים ובשדות סינון בלבד של LookML מניתוח ב-Looker כדי להוסיף מסננים לדוח Power BI.
כדי לסנן דוח ב-Power BI Desktop באמצעות פרמטרים ושדות סינון בלבד של Looker:
אם עדיין לא עשיתם זאת, התחברו לנתוני Looker מ-Power BI Desktop והמתינו עד ש-Power BI יאכלס את החלונית Data בשדות מה-Explore שנבחר ב-Looker.
בחלונית Data ב-Power BI, גוררים את השם של פרמטר או של שדה סינון בלבד לאחת מהתיבות Add data fields here בחלונית Filters, בקטע Filters on this page או בקטע Filters on all pages. פרטים על הוספת מסננים לדוח ב-Power BI זמינים במסמכי התיעוד של Power BI.
חשוב לדעת את הנקודות הבאות לגבי שימוש בפרמטרים ובשדות של סינון בלבד של Looker ב-Power BI:
- בשדות סינון בלבד שמוגדרים ב-LookML עם הפרמטר
suggestionsאו הפרמטרsuggest_dimension, Power BI יאחזר את ערכי ההצעה ויציג אותם באפשרויות סינון בסיסי בחלונית Filters. לפרמטרים שהוגדרו ב-LookML עם מאפיין
allowed_value, Power BI יאחזר את כל הערכים המותרים שהוגדרו ב-LookML עבור הפרמטר ויציג אותם באפשרויות סינון בסיסי בחלונית מסננים.
שימוש ב-DAX עם Looker–Power BI Connector
DAX (Data Analysis Expressions) היא שפת נוסחאות שמשמשת ב-Power BI ליצירת חישובים בהתאמה אישית.
Power BI מתרגם שאילתות DAX לביטויים של Power Query M ושולח אותם ל-Looker–Power BI Connector. לאחר מכן, Looker–Power BI Connector מתרגם את ביטויי ה-M האלה לקריאות ל-Looker API.
אם פונקציית DAX או Power Query M לא נתמכת, query folding מפסיק. במצב כזה, Power BI מאחזר את כל הטבלה הגולמית מ-Looker כדי לעבד את הפעולה באופן מקומי, מה שעלול לגרום לפגיעה משמעותית בביצועים. בקטע פונקציות Power Query M נתמכות מופיעה רשימה של הפונקציות הנתמכות.
מדדים לעומת עמודות
ב-Power BI יש שתי דרכים עיקריות ליצור נתונים חדשים באמצעות DAX: מדד חדש ועמודה חדשה.
- מדד חדש: מערכת Power BI מחשבת את הערך הדינמי הזה בזמן אמת כשמשתמשים בו בתצוגה חזותית. המודל הזה לא מאחסן את הערך הזה. השתמשו במדדים בעיקר לצבירת נתונים.
- לדוגמה:
Total Sales = SUM('Sales'[Revenue])
- לדוגמה:
- עמודה חדשה: Power BI מחשב את הערך הסטטי הזה שורה אחר שורה. הוא מתעדכן רק כשהנתונים מתרעננים. המודל שומר את הערך הזה. השתמשו בעמודות בעיקר כדי לסווג נתונים.
- לדוגמה:
Profit = 'Sales'[Revenue] - 'Sales'[Cost]
- לדוגמה:
יצירת מדד חדש
כדי ליצור מדד חדש ב-Power BI, פועלים לפי השלבים הבאים:
- בחלונית Data, לוחצים לחיצה ימנית על הטבלה שבה רוצים להוסיף את המדד.
- לוחצים על מדידה חדשה.
- בשורת הנוסחאות, מזינים את נוסחת ה-DAX. מחליפים את
Measureבשם המדד שבחרתם.
יצירת עמודה חדשה
כדי ליצור עמודה חדשה ב-Power BI, פועלים לפי השלבים הבאים:
- בחלונית נתונים, לוחצים לחיצה ימנית על הטבלה שבה רוצים להוסיף את העמודה.
- לוחצים על עמודה חדשה.
- בשורת הנוסחאות, מזינים את נוסחת ה-DAX. מחליפים את
Columnבשם העמודה שבחרתם.
דוגמאות לשאילתות DAX
בטבלאות הבאות מוצגות דוגמאות לשאילתות DAX לצבירות נפוצות. מידע נוסף זמין במאמרי העזרה בנושא DAX.
בטבלה הבאה מפורטות כמה דוגמאות ליצירת מדדים לצבירות נפוצות.
| סוג צבירה | דוגמה |
|---|---|
| SUM | Total Sales = SUM('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| AVERAGE | Average Sale Price = AVERAGE('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| דק‘ | Minimum Sale Price = MIN('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| MAX | Maximum Sale Price = MAX('The Look E-Commerce'[Order Items Ecomm.dim.Sale Price]) |
| COUNT | Order Count = COUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
| DISTINCTCOUNT | Distinct Order Count = DISTINCTCOUNT('The Look E-Commerce'[Order Items Ecomm.dim.Order ID]) |
בטבלה הבאה מוסבר איך לבצע פעולות אריתמטיות בסיסיות.
| סוג צבירה | דוגמה |
|---|---|
| הוספה | Total Orders = [Shipped Orders] + [Pending Orders] |
| חיסור | Total Profit = [Total Sales] - [Total Cost] |
| כפל | Total Sales with Tax = [Total Sales] * 1.05 |
| חטיבה | Profit Margin = DIVIDE([Total Profit], [Total Sales]) |
| הספק | Sales Squared = POWER([Total Sales], 2)או Sales Squared = [Total Sales] ^ 2 |
| שורש ריבועי | Square Root of Sales = SQRT([Total Sales]) |
| מודולוס | Order ID Type = IF(MOD('The Look E-Commerce'[Order Items Ecomm.dim.Order ID], 2) = 0,"Even","Odd") |
| ערך מוחלט | Absolute Profit = ABS([Total Profit]) |
פונקציות Power Query M נתמכות
כשמשתמשים במחבר של Looker ל-Power BI במצב DirectQuery, Power BI יוצר ביטוי Power Query M לכל תצוגה חזותית, מסנן וחישוב DAX. המחבר של Looker ל-Power BI מתרגם את הביטויים האלה לשאילתות בזמן אמת באמצעות Looker API.
טקסט
Text.FromText.AtText.Combine-
Text.Contains(Text.Containsתלוי אותיות רישיות) Text.EndText.EndsWithText.LengthText.LowerText.UpperText.MiddleText.PositionOfText.RangeText.RemoveRangeText.ReplaceText.StartText.StartsWithText.InsertText.SplitText.FromBinary
רשימה וטבלה
Value.Equals/Value.NullableEqualsTable.RowCountTable.FirstTable.FirstNTable.SelectRowsTable.SortList.SumList.AverageList.MaxList.MinList.CountList.DistinctList.SelectList.ContainsList.AnyTrue
Numeric
חשבון בסיסי
Value.AddValue.SubtractValue.MultiplyValue.Divide
מתמטיקה מדעית ומתקדמת
Number.PowerNumber.SqrtNumber.ExpNumber.LnNumber.Log10Number.LogNumber.PI
מאפייני מספרים
Number.SignNumber.IsEvenNumber.IsOddNumber.Abs
חילוק ושארית
Number.ModNumber.IntegerDivide
יצירת מספרים אקראיים
Number.RandomNumber.RandomBetween
המרות של סוגים
המחבר לא תומך בשימוש בפונקציות הבאות להמרת מספרים בתוך ויזואליזציות:
Byte.FromCurrency.FromDecimal.FromInt8.From,Int16.From,Int32.From,Int64.FromNumber.From,Number.FromTextSingle.From,Double.From
עיגול מספרים
Number.RoundNumber.RoundDownNumber.RoundUpNumber.RoundTowardZeroNumber.RoundAwayFromZero
בטבלה הבאה מוצגות דוגמאות לכל פעולת עיגול:
| קלט | Number.Round |
Number.RoundDown |
Number.RoundUp |
Number.RoundTowardZero |
Number.RoundAwayFromZero |
|---|---|---|---|---|---|
| 2.7 | 3 | 2 | 3 | 2 | 3 |
| 2.5 | 3 | 2 | 3 | 2 | 3 |
| 2.2 | 2 | 2 | 3 | 2 | 3 |
| 0 | 0 | 0 | 0 | 0 | 0 |
| -2.2 | -2 | -3 | -2 | -2 | -3 |
| -2.5 | -3 | -3 | -2 | -2 | -3 |
| -2.7 | -3 | -3 | -2 | -2 | -3 |
תאריך ושעה
התאריך והשעה הנוכחיים נשלפים
DateTime.LocalNowDateTime.FixedLocalNowDateTimeZone.UtcNowDateTimeZone.FixedUtcNowDateTimeZone.LocalNowDateTimeZone.FixedLocalNow
המרת סוג של תאריך ושעה
DateTime.FromTextDateTimeZone.FromTextDateTime.FromDateTimeZone.FromDate.FromTextTime.ToText
חישוב תאריכים
Date.AddDaysDate.AddMonthsDate.AddYears
חילוץ של חלקי תאריך ושעה
Date.DayDate.MonthDate.YearTime.HourTime.MinuteTime.SecondDateTime.Time
גבולות של תאריכים ותקופות
Date.StartOfDayDate.StartOfYearDate.EndOfDayDate.EndOfYearTime.StartOfHourTime.EndOfHour
פונקציות מסדר גבוה
המחבר של Looker ל-Power BI תומך בפונקציות הבאות מסדר גבוה יותר, בתנאי שהמחבר של Looker ל-Power BI תומך גם בפעולות בתצוגת עץ.
Table.AddColumn- מגבלה: המחבר של Looker ל-Power BI חייב לתמוך בפונקציה שמוגדרת בפרמטר
columnGenerator. - דוגמה: השאילתה הבאה פועלת כי המחבר של Looker ל-Power BI תומך בפונקציה המוטמעת
Text.Length:powerquery Table.AddColumn(LookerTable, "NewColumnName", each Text.Length([lookerTextDimensionColumn]))
- מגבלה: המחבר של Looker ל-Power BI חייב לתמוך בפונקציה שמוגדרת בפרמטר
Table.Group- מגבלה: מחבר Looker–Power BI צריך לתמוך בכל פונקציות הצבירה שמשמשות ברשימה
aggregatedColumns. - דוגמה: השאילתה הבאה פועלת כי המחבר של Looker ל-Power BI תומך בפונקציה המוטמעת
List.Sum:powerquery Table.Group(LookerTable, "CustomerID", {"total", each List.Sum([price])})
- מגבלה: מחבר Looker–Power BI צריך לתמוך בכל פונקציות הצבירה שמשמשות ברשימה
שימוש במדדים של Looker ב-Power BI במצב DirectQuery
הרבה ויזואליזציות של Power BI שמשתמשות בתרשימי עמודות, תרשימי ברים ותרשימי קווים דורשות ערך מצטבר בציר ה-Y. ל-Power BI נדרש ערך יחיד כדי לקבוע איפה לשרטט את הנקודה על הגרף, כמו גובה של עמודה או מיקום של קו. אם לא תבצעו צבירה, הוויזואליזציה לא תוצג.
לדוגמה, הנה המחשה חזותית של מדד Looker של type: sum שמציג את העלות הכוללת לכל פריט:

ברוב הוויזואליזציות ב-Power BI לא מוצג מדד type: sum אלא אם מפעילים צבירה. כדי להציג את הסכום, אפשר להגדיר את הצבירה ב-Power BI לסכום. כך נראית התוצאה של התצוגה החזותית ב-Power BI באמצעות צבירת סכום:

באופן דומה, אפשר להשתמש בצבירה מסוג sum ב-Power BI כדי להציג חזותית מדדים של Looker שמשתמשים בסוגי הצבירה הבאים:
שימוש בתכונות של Power BI עם המחבר Looker–Power BI
בקטעים הבאים מתוארת התמיכה של Looker–Power BI Connector בתכונות שונות של Power BI:
Sparkline
להוסיף תרשימי קו זעירים לתצוגות חזותיות של טבלאות או מטריצות. מידע נוסף זמין במאמרי העזרה של Power BI בנושא תרשימי קו מיניאטוריים.
עיצוב מותנה
אפשר להחיל עיצוב מותנה על תצוגות חזותיות של טבלה או מטריצה. המחבר של Looker ל-Power BI תומך בעיצוב מותנה של עמודות מספריות, אבל לא של שדות טקסט. הוראות כלליות להגדרה זמינות במסמכי התיעוד של Power BI.
המרת סוג
המחבר Looker–Power BI לא תומך בהמרת עמודה למספר או לתאריך בתוך תצוגה חזותית. עם זאת, המחבר תומך בהמרה של עמודה לטקסט ובשימוש בשדה הזה בתצוגה חזותית.
קישור ל-Excel
אתם יכולים לטעון נתונים מ-Looker ישירות ל-Excel למחשב או ל-Excel לאינטרנט. הוראות להגדרה זמינות במאמר חיבור Excel לקבוצות נתונים של Power BI במסמכי התיעוד של Power BI.
כשמשתמשים ב-Looker–Power BI Connector ב-Excel, הוא פועל באופן דומה למצב DirectQuery ב-Power BI. כשהנתונים מסוננים, המחבר מחיל את המסנן במקור לפני טעינת הנתונים ל-Excel.
אתם יכולים להתחבר לנתונים שלכם באמצעות אחת מהשיטות הבאות ב-Excel:
הוספת טבלת צירים
כדי להוסיף טבלת צירים שמקושרת ישירות למערך הנתונים:
- לוחצים על הכרטיסייה הוספה.
- בוחרים באפשרות PivotTable > From Power BI.
לפרטים
כדי לייבא את הנתונים באמצעות סרגל הכלים נתונים, פועלים לפי השלבים הבאים:
- לוחצים על הכרטיסייה נתונים.
- לוחצים על Get Data (קבלת נתונים) > From Fabric & Power Platform (מ-Fabric ו-Power Platform) > From Power BI (מ-Power BI).
מעקב אחרי מחבר Looker – Power BI
אדמינים ב-Looker יכולים לראות את השימוש ב-Looker–Power BI Connector באמצעות קבוצת השדות Query API Client Properties ב-System Activity History Explore. בכל פעם שמריצים שאילתה חדשה, נוצרת רשומה ב-Explore History.
בקבוצת השדות Query API Client Properties, השדה API Client Name מציג ערך של Power BI כדי לזהות רשומות של Looker–Power BI Connector.
הדוגמה הבאה מציגה כתובת URL של פעילות המערכת שבה מוצג השימוש ב-Power BI. מחליפים את <instance_name.looker.com> בכתובת ה-URL של המכונה.
https://<instance_name.looker.com>/explore/system__activity/history?fields=query_api_client_context.name,user.name,history.created_date,history.created_time_of_day&f[query_api_client_context.name]=Power+BI&sorts=history.created_time_of_day+desc&limit=5000
שירות Power BI
אחרי שמתחברים לנתוני Looker מ-Power BI ומפרסמים דוחות ב-Power BI, אפשר להשתמש בשירות Power BI (Power BI אונליין) כדי לבצע פעולות בדוחות של Looker בדפדפן אינטרנט.
אפשר גם לפרסם דוחות באמצעות שירות Power BI עם אבטחה ברמת השורה.
שיקולים בנושא אימות
כשמפרסמים דוח בשירות Power BI, פרטי הכניסה ששימשו ליצירת הדוח מוטמעים בו. פרטי הכניסה האלה משמשים את כל המשתמשים שצופים בדוח בשירות Power BI.
השימוש החוזר בפרטי הכניסה מתרחש כי מסגרת המחבר של Microsoft Power BI לא תומכת באימות כניסה יחידה (SSO) של משתמשי קצה למחברים בהתאמה אישית. כדי להגביל את הגישה לנתונים על סמך המשתמש שצופה בדוח, משתמשים באבטחה ברמת השורה (RLS) ב-Power BI.
פרסום דוח באמצעות שירות Power BI עם אבטחה ברמת השורה
אחרי שמפרסמים דוחות ב-Power BI Desktop באמצעות מחבר Looker – Power BI, אפשר להשתמש בשירות Power BI כדי ליצור אינטראקציה עם הדוחות מדפדפן אינטרנט.
ב-Power BI Desktop אפשר להשתמש באבטחה ברמת השורה (RLS) כדי להגביל את הגישה לנתונים עבור משתמשים מסוימים. במסמכי התיעוד של Power BI מוסבר איך להגדיר תפקידים וכללים ואיך לאמת את התפקידים ב-Power BI Desktop.
אחרי שמגדירים את התפקידים ב-Power BI Desktop, אפשר להשתמש בתפקידים ובכללים אונליין עם שירות Power BI.
כדי לפרסם דוח באמצעות שירות Power BI עם אבטחה ברמת השורה, פועלים לפי השלבים הבאים:
- ב-Power BI Desktop, פותחים את הדוח ובוחרים בתפריט Home בחלק העליון של החלון.
- בתפריט Home (דף הבית), בוחרים באפשרות Publish (פרסום).
- בוחרים סביבת עבודה מהתפריט הנפתח ולוחצים על בחירה. ב-Power BI Desktop תופיע הודעת הצלחה שכוללת קישור לפתיחת הדוח ב-Power BI.
- לוחצים על הקישור כדי לפתוח את Power BI.
- ב-Power BI Service, עוברים אל Workspaces ובוחרים את סביבת העבודה שבה פרסמתם את הדוח.
- מחפשים את כרטיס המוצר של מערך הנתונים בדוח (לא את הדוח עצמו).
- ברשימת קבוצות הנתונים, לוחצים על סמל האפשרויות הנוספות (3 נקודות) More options ובוחרים באפשרות Security.
ב-Power BI יופיע החלון Row-Level Security. מכאן אפשר לבחור את התפקיד שיצרתם ב-Power BI Desktop ולהוסיף אנשים או קבוצות שמשתייכים לתפקיד ולאמת את התפקידים ב-Power BI Service.
עכשיו אתם יכולים לשתף את הדוח עם כל מי שתרצו, והוא יראה רק את הנתונים שהוא מורשה לראות, על סמך התפקידים שיצרתם.
הפעלת רישום ביומן של ניפוי באגים ב-Power BI Desktop
כדי לפתור או לאבחן בעיה, אתם יכולים להפעיל את הרישום ביומן של החיבור בין Power BI ל-Looker.
צריך להפעיל את הרישום ביומן עבור החיבור וגם עבור Power BI עצמו, כמו שמתואר בקטעים הבאים:
הפעלת רישום ביומן ברמת המחבר
כדי לפתור בעיות, אתם יכולים להפעיל רישום ביומן לצורכי אבחון ב-Looker–Power BI Connector.
כשיוצרים חיבור חדש לנתוני Looker מ-Power BI Desktop, צריך להפעיל את הרישום ביומן הפעילות באופן הבא:
- בתיבת הדו-שיח של קישור Looker, מרחיבים את האפשרויות המתקדמות.
- בתפריט הנפתח Enable Logging, בוחרים באפשרות TRUE.
אם כבר יצרתם חיבור לנתוני Looker מ-Power BI Desktop, עליכם לערוך את השאילתה באופן ידני בתוך עורך השאילתות של Power Query. כדי לעשות זאת:
- ב-Power BI Desktop, בוחרים באפשרות Transform Data.
- ברצועת הכלים Home, בוחרים באפשרות Advanced Editor.
- מאתרים את השורה שמתחילה ב-
Source = Looker.DataSource. מעדכנים את הארגומנט השני של הפונקציה כך שיכלול את
EnableLogging=true.Looker.DataSource("instance.looker.com", [EnableLogging=true])לוחצים על סיום.
הפעלת מעקב ברמת Power BI
בנוסף להפעלת הרישום ביומן בחיבור לנתוני Looker מ-Power BI Desktop, צריך גם להפעיל את המעקב מ-Power BI Desktop. כדי לעשות זאת:
- לוחצים על File > Options and settings > Options (קובץ > אפשרויות והגדרות > אפשרויות).
- בתיבת הדו-שיח Options, בוחרים באפשרות Diagnostics.
- בקטע Diagnostic Options, בוחרים באפשרות Enable tracing.
- כדי לראות את קובצי היומן, לוחצים על פתיחת התיקייה של קובצי ה-dump של הקריסה או קובצי המעקב.
מה כדאי לקחת בחשבון?
מגבלות על שורות בשאילתה
שאילתות מהמחבר של Looker ל-Power BI יכללו באופן אוטומטי הצהרת LIMIT 5000, אלא אם לחשבון המשתמש ב-Looker יש את ההרשאה download_without_limit. אם לחשבון המשתמש ב-Looker יש download_without_limit, לא מוטלת מגבלת שורות על שאילתות שמגיעות מ-Looker–Power BI Connector.
מסננים נוספים
אם ה-Explore ב-Looker מוגדר עם הפרמטרים always_filter או conditionally_filter של LookML, המסננים יחולו על שאילתות במחבר Looker–Power BI, למרות שהמסננים לא יהיו גלויים ב-Power BI.
מסגרות זמן נתמכות של קבוצות מאפיינים
בdimension_group של type: time, רק מסגרות הזמן date ו-time נתמכות במחבר Looker–Power BI. מסגרות זמן אחרות יוסתרו.
המחבר של Looker ל-Power BI לא מציג את שאילתות ה-Explore של פעילות המערכת
שאילתות חקירה של פעילות המערכת לא מוצגות במחבר Looker–Power BI. אדמינים ב-Looker יכולים לראות את ה-Explores של פעילות המערכת ישירות בממשק המשתמש של Looker.
מגבלות על המרת סוגים
כשאפשר, מומלץ להגדיר את סוגי העמודות בתצוגת LookML.
מגבלות ידועות
כשמשתמשים ב-Looker–Power BI Connector, חשוב להביא בחשבון את המגבלות הבאות:
מודלים של נתונים ומצבים
- מאפיינים מספריים: גם מאפיינים מספריים וגם מדדים מופיעים כמדדים ב-Power BI. כדי להשתמש במאפיין מספרי כמאפיין, צריך לשנות את סיכום ברירת המחדל שלו ל-Do not summarize (לא לסכם) ב-Power BI Desktop.
- מצב ייבוא: כדי לקבל ביצועים אופטימליים, השתמשו ב-DirectQuery Mode. אם אתם משתמשים ב-Import Mode ב-Power BI, שימו לב למגבלות הבאות:
- ביצועים: יכול להיות שדוחות שניגשים למודלים גדולים ייטענו לאט.
- זמן קצוב לתפוגה: אם התהליך "Get Data" נתקע או שהזמן הקצוב לתפוגה שלו נגמר, עוברים למצב DirectQuery.
- הגבלות על שדות: מצב ייבוא משבית שדות של סינון בלבד ושדות של פרמטרים.
- הערכת מדדים: מצב ייבוא מגביל את Looker מלהעריך מדדים בתוך Explore, מה שיכול להשפיע על דיוק הדוחות.
צבירות
Power BI מחיל צבירות משלו על מדדים של Looker. זה יכול לגרום לשגיאות או לתוצאות לא עקביות, במיוחד ברכיבים חזותיים של מטריצות.
- סוגים נתמכים: אפשר להשתמש רק ב-
average,count,count_distinct,max,minו-sum. - סוגים לא נתמכים: המחבר לא תומך בשאילתות של סטיית תקן, שונות או צבירות של המחרוזת הראשונה או האחרונה לפי סדר אלפביתי.
- ביצועי חציון: Power BI מחשב את החציון באופן מקומי על ידי אחזור כל הערכים. הפעולה הזו איטית במערכי נתונים גדולים, ויכול להיות שהיא תיפסק בגלל חריגה מזמן קצוב לתפוגה.
סינון ומיון
- מיון לפי שדות מוסתרים: אי אפשר למיין לפי שדה שלא נכלל בתצוגה החזותית. כדי למיין לפי שדה, צריך להוסיף אותו לתצוגה החזותית.
- מגבלות של מסננים מתקדמים: בגלל ההבדלים בין Power Query לבין ביטויי סינון ב-Looker, חלות המגבלות הבאות:
- טקסט: אין תמיכה במסנני טקסט מרובים.
- תאריכים: בשדות של תאריך ושל תאריך ושעה, יש תמיכה רק ב-
is,is not,is on or afterו-is before. - אפשר להשתמש בכמה מסנני מספרים רק במקרים הבאים:
- אי שוויון ואי שוויון (לדוגמה, קטן מ וגדול מ).
- אי-שוויון או אי-שוויון (לדוגמה, קטן מ- או גדול מ-).
- הוא או הוא.
- אפשר להשתמש בכמה מסננים של תאריך ותאריך ושעה רק במקרים הבאים:
is on or after AND is beforeis or is
פונקציות של Power Query
אי אפשר לכווץ את הפונקציות הבאות בטבלה:
Table.DistinctTable.JoinTable.NestedJoinTable.Skip
פתרון בעיות
בקטעים הבאים מתוארות בעיות נפוצות והפתרונות שלהן.
המחבר של Looker ל-Power BI לא מופיע ברשימה Get Data (קבלת נתונים) של Power BI
מוודאים שהספרייה [Documents]\Microsoft Power BI Desktop\Custom Connectors מכילה את הקובץ looker_1.4.3.mez.
- ב-Power BI Desktop, מאמתים את הגדרות האבטחה:
- לוחצים על File > Options and settings > Options (קובץ > אפשרויות והגדרות > אפשרויות).
- לוחצים על אבטחה.
- בקטע תוספי נתונים, בוחרים באפשרות (לא מומלץ) אפשר לטעון כל תוסף בלי אימות או אזהרה.
- לוחצים על OK.
- מפעילים מחדש את Power BI Desktop.
שגיאה: שמות השדות יכולים לכלול רק אותיות, מספרים וקווים תחתונים
במקרים מסוימים, יכול להיות שתופיע הודעת השגיאה הבאה כשמרעננים נתונים או מחילים שינויים:
DataSource.Error
Message: A LookML model issue has occurred.
Details: Invalid field name "...". Field names may only include letters, numbers and underscores and must start with a letter or underscore for Google BigQuery Standard SQL
השגיאה הזו מתרחשת כששם של עמודה מכיל רווחים או תווים מיוחדים שלא נתמכים במסד הנתונים הבסיסי (כמו BigQuery).
כדי לפתור את הבעיה, פועלים לפי השלבים הבאים:
- מזהים את העמודה שגורמת לשגיאה (בדרך כלל היא מצוינת בקטע
Detailsשל הודעת השגיאה). - משנים את שם העמודה כך שיכיל רק אותיות, מספרים וקווים תחתונים.
- לא נכון:
Custom Column Name - נכון:
Custom_Column_Name
- לא נכון:
שגיאה: אירעה שגיאה באחזור הנתונים של התרשים הזה
במקרים מסוימים, יכול להיות שתקבלו שגיאת אימות ב-Power BI שמציינת כשל ב-OAuth או בעיה בהרשאות, כמו Looker database authentication required.
אם השגיאה הזו מופיעה, בחשבון Looker שלכם חסרים פרטי הכניסה הנדרשים של OAuth לחיבור למסד הנתונים. כדי לפתור את הבעיה, פועלים לפי השלבים הבאים:
- מתחברים למכונה של Looker.
- לוחצים על סמל פרופיל המשתמש ואז על חשבון.
- עוברים לקטע OAuth Connection Credentials.
- מוצאים את החיבור שאליו רוצים לגשת ולוחצים על התחברות.
- חוזרים אל Power BI Desktop ומרעננים את הנתונים.
יומן השינויים של מחבר Looker – Power BI
בקטעים הבאים מפורטים העדכונים בכל גרסה של Looker–Power BI Connector:
גרסה 1.4.3
גרסה 1.4.3 של Looker–Power BI Connector כוללת את העדכונים הבאים:
- תווית המחבר כוללת עכשיו את מספר הגרסה של המחבר.
- הוספנו אפשרות חדשה, הפעלת רישום ביומן, כדי להפעיל באופן דינמי יומני אבחון בתוך המחבר לצורך פתרון בעיות.
- הוספנו אפשרות חדשה הצגת ניתוחים ושדות מוסתרים. כשההגדרה הזו מופעלת, מוצגים שדות וניתוחים מוסתרים. האפשרות הזו מחליפה את האפשרות הקודמת הצגת שדות מוסתרים.
גרסה 1.4.3 של Looker–Power BI Connector כוללת את תיקוני הבאגים הבאים:
- תוקנה בעיה שבה אופרטור DAX לשרשור מחרוזות (
&) נכשל. - תוקנה הבעיה שבה החלת מדד Power BI על מדד Looker גרמה לשגיאה.
- הסמל של Looker מופיע שוב בתפריט Credential Configuration (הגדרת פרטי הכניסה).
גרסה 1.4.2
גרסה 1.4.2 של המחבר של Looker ל-Power BI כוללת את העדכונים הבאים:
- הגדרת החיבור השבתת האופטימיזציה של התצוגה המקדימה הוסרה.
- אפשרות החיבור הצגת שדות מוסתרים הועברה לקטע אפשרויות מתקדמות.
- הוסר תיוג הבטא. המחבר לא מופיע יותר כגרסת בטא ב-Power BI.
גרסה 1.4.2 של מחבר Looker – Power BI כוללת את תיקוני הבאגים הבאים:
- תוקנה שגיאת הרגרסיה שבה כלי חיתוך בוליאניים וכלי חיתוך של תאריכים נכשלו ב-Power BI.
- תוקנה בעיה שבה המסנן
is-notלא פעל במסנןdates.
גרסה 1.4.0
גרסה 1.4.0 של המחבר של Looker ל-Power BI כוללת את העדכונים הבאים:
- נוספה תמיכה במצב ייבוא
- הפעלת תצוגה מקדימה של נתונים
- התנהגות משופרת כשמבצעים שאילתות של
SELECT * - שיפור שיעור המציאה במטמון (cache hit) ב-Looker
- שיפור בביצועים של שליפת הצעות לסינון
גרסה 1.4.0 של Looker–Power BI Connector כוללת את תיקוני הבאגים הבאים:
- תוקן באג שגרם לכך ש-Looker לא זיהה שערכים הועברו לשדות של מסננים ופרמטרים
- תוקן באג שגרם לכך שלפעמים ערכים מוצעים של פרמטרים לא הופיעו בפילטרים
- תוקן באג שבו משתני Liquid לא נכללו בהצהרות LookML
- תוקן באג שבו ערכי המדד של ספירת ערכים ייחודיים היו לא עקביים בתצוגות מטריצה ב-Power BI
גרסה 1.3.1
גרסה 1.3.1 של Looker–Power BI Connector כוללת את העדכונים הבאים:
- נוספה אפשרות להצגת שדות מוסתרים
גרסה 1.3.1 של Looker–Power BI Connector כוללת את תיקון הבאג הבא:
- תוקן באג שגרם לכך שרכיב ויזואלי נכשל אם קיים מסנן גם ברכיב הוויזואלי וגם בדוח
גרסה 1.3.0
גרסה 1.3.0 של מחבר Looker – Power BI כוללת את העדכונים הבאים:
- פורמט פשוט של תאריך ושעה
- שיפור הזיהוי של ביטויי טקסט שלא נתמכים
- דיווח משופר על הודעות שגיאה
גרסה 1.3.0 של Looker–Power BI Connector כוללת את תיקון הבאג הבא:
- שיפור התמיכה בתווי escape בערכי מסננים
גרסה 1.2.0
גרסה 1.2.0 של Looker–Power BI Connector כוללת את העדכונים הבאים:
- נוספה תמיכה בפרמטרים ובשדות של סינון בלבד
- תמיכה במסננים מתקדמים לשדות של סינון בלבד מסוג טקסט, מספר, תאריך ותאריך ושעה
- תמיכה במסנן בסיסי לשדה של סינון בלבד באמצעות ערכים מוצעים של Looker