Cómo aprovechar al máximo el libro de recetas de visualizaciones de Looker: Presentar mucha información con una visualización de un solo valor

Presentar la información de forma clara y concisa permite que los usuarios comprendan rápidamente cómo se relaciona un solo dato con tendencias más amplias, o cómo se compara con otros valores, sin necesidad de dedicar más tiempo a buscar el contexto. Por ejemplo, la siguiente visualización de la sección Muestra un solo valor en comparación con otros valores de esta página ayuda a los usuarios a comprender cómo se compara un valor con otros:

Valor único de USD 41,394.51 con el subtítulo "Ganancia total del último mes completo" y un texto secundario que muestra una flecha hacia abajo junto al 40% del mes anterior.

Esta guía te ayudará a comprender cómo crear una visualización que presente un solo dato con la mayor cantidad de contexto posible.

En esta página, se incluyen los siguientes ejemplos:

Componentes

Requisitos previos

Para crear una visualización de un solo valor, se requiere lo siguiente:

Aspectos que debes tener en cuenta cuando uses visualizaciones de un solo valor

Cuando crees y uses visualizaciones de un solo valor, asegúrate de tener en cuenta lo siguiente:

  • Cuando se ven varias visualizaciones de valor único en un panel, cada una usa de forma predeterminada el mismo tamaño de fuente para lograr una apariencia coherente. Sin embargo, las visualizaciones de valor único cambian automáticamente el tamaño de las fuentes cuando se reduce el tamaño de un mosaico. Si la fuente de una visualización no puede mostrar el valor completo en el espacio disponible, el valor se trunca con puntos suspensivos (...).
  • Si la función Tamaño de texto inteligente de valor único está habilitada, las fuentes de las visualizaciones de valor único que se muestran en las tarjetas del panel cambian de tamaño automáticamente para mostrar al menos entre 8 y 10 caracteres de valor dentro de la tarjeta en cualquier tamaño determinado.
  • La fuente solo se puede cambiar para el contenido incorporado cuando un administrador de Looker la especifica en un tema personalizado.
  • El tamaño de la fuente no se puede personalizar desde el menú Editar de la visualización. Las únicas formas de personalizar el estilo y el tamaño de la fuente de los valores son las siguientes (bajo tu propio riesgo):
    • Agrega un parámetro html a la definición de LookML del campo y especifica la configuración de fuente y tamaño con etiquetas de estilo HTML. Por ejemplo: valor de html: <p style="color: red; font-size: 50px">{{ }}</p> ;;
    • Usa el método de gráfico de dispersión que se describe en la publicación de Comunidad Cómo editar el tamaño de la fuente en una visualización de valor único.

Cuando se muestran varias visualizaciones de valor único en un panel, es posible que el tamaño de la fuente se vea afectado por las consideraciones descritas en la primera viñeta de esta lista.

Ejemplo: Muestra un solo valor en comparación con otros valores

Una métrica de vanidad por sí sola proporciona poco valor a los usuarios. Sin embargo, agregar una comparación con un dato anterior puede agregar rápidamente perspectiva y contexto para un usuario.

Por ejemplo, la siguiente consulta muestra las Ganancias totales agrupadas por Mes de creación de los últimos 12 meses. De forma predeterminada, la visualización de valor único solo muestra el valor de la fila superior de la medición Total Profit, que es de USD 41,394.51 para el último mes completo, diciembre (2019-12).

Visualización de un solo valor que muestra el valor $41,394.51.

Sin la tabla de datos para el contexto, el valor no presenta mucha información a los usuarios. ¿Qué sucede si quieres mostrar cómo se comparan las ganancias totales del último mes completo con las ganancias totales del mes anterior? Puedes usar la configuración del menú Editar de la visualización para crear una comparación de estos valores en la visualización.

Para mostrar una comparación del valor actual con el valor de la fila anterior, sigue estos pasos:

Prepara tu exploración:

  1. Organiza tu consulta de Explorar para que la visualización muestre el valor deseado.
  2. Agrega un campo que compare los valores de la fila actual y la anterior a la consulta de la exploración.

    Si no hay un campo de comparación existente disponible en el selector de campos y tienes los permisos necesarios, puedes usar un acceso directo de cálculo basado en tablas. En este ejemplo, se usa el cálculo % de cambio con respecto a la fila anterior.

Personaliza tu visualización de un solo valor:

  1. Abre el menú Editar en la barra Visualización.
  2. Selecciona las opciones de estilo que desees en la pestaña Estilo, como agregar un título personalizado que aparecerá como subtexto debajo del valor, junto con cualquier formato de valor de estilo de Excel.

    En este ejemplo, se ingresa "Ganancias totales del último mes completo" en la sección Anulación del título para proporcionar una mejor indicación de lo que representa el valor.

  3. En la pestaña Comparación, selecciona Mostrar.

  4. Selecciona la opción Mostrar como cambio en el menú desplegable Etiquetas de valor.

  5. Selecciona la opción Los valores positivos son incorrectos para mostrar un cambio positivo en rojo y un cambio negativo en verde, si eso se adapta a tu caso de uso.

    En este ejemplo, los cambios negativos indican que las ganancias totales de diciembre en comparación con las de noviembre fueron más bajas, lo que se considera un cambio "malo".

  6. Personaliza la etiqueta de comparación de valores en la pestaña Comparación como desees.

    Anula la selección de la opción Mostrar etiqueta para ocultar la etiqueta del campo.

    Deja las opciones de Mostrar etiqueta sin cambios para incluir la etiqueta del campo tal como está.

    Ingresa una etiqueta personalizada en el campo Etiqueta. En este ejemplo, se aplica la etiqueta personalizada "del mes anterior".

El resultado final es el valor de Ganancias totales de diciembre, USD 41,394.51, con el texto secundario que destaca la comparación con las ganancias totales del mes anterior, que disminuyeron un 40%.

Valor único de USD 41,394.51 con el subtítulo &quot;Ganancia total del último mes completo&quot; y un texto secundario que muestra una flecha hacia abajo junto al 40% del mes anterior.

Cómo agregar formato condicional para obtener más contexto

Puedes agregar una capa adicional de contexto y, al mismo tiempo, mantener tu visualización limpia y minimalista con el formato condicional.

En este ejemplo, el umbral de ganancias para un mes exitoso es de USD 30,000, y cualquier ganancia mensual que supere este umbral debe indicarse con el color verde.

Puedes usar la configuración de formato condicional en la pestaña Formato del menú Editar de la visualización para indicar que el valor está por encima del umbral de ganancias.

Para habilitar el formato condicional en el menú Editar de la visualización de valor único, sigue estos pasos:

  1. Abre el menú Editar en la barra Visualización.
  2. Selecciona la opción Habilitar el formato condicional en la pestaña Formato.
  3. Selecciona una paleta de colores en el menú desplegable Colección de la sección Colores.
  4. Ingresa tus reglas de formato en la sección Reglas.

    Selecciona la condición en el menú desplegable Formato. En este ejemplo, se selecciona Si el valor es mayor que.

    Ingresa el valor del umbral de la regla. En este ejemplo, se ingresa "30000".

    Selecciona el Color de fondo y el Color de fuente que desees. Asegúrate de tener en cuenta el contraste de color para la accesibilidad de tu contenido. En este ejemplo, se seleccionan un fondo blanco y una fuente verde oscuro.

  5. Para agregar otra regla, selecciona el botón Agregar una regla en la parte inferior de la pestaña.

    En este ejemplo, se crea otra regla para indicar cuándo los valores de las ganancias totales son inferiores al umbral de USD 30,000.

La ganancia total de diciembre, USD 41,394.51, puede ser un 40% menor que la ganancia total del mes anterior, pero aún está por encima del umbral de ganancias. Ahora, el valor de las ganancias totales se muestra en verde para indicarles a los usuarios que está por encima del umbral de ganancias.

Ejemplo: Muestra un solo valor en el contexto del progreso hacia un objetivo

Otra opción de visualización de valor único es mostrar un valor en el contexto del progreso hacia un objetivo.

Por ejemplo, con el mismo conjunto de datos (Ganancia total agrupada por Mes de creación de los últimos 12 meses), puedes mostrar la ganancia total en lo que va del año (YTD) en comparación con el objetivo de ganancias para todo el año. El objetivo de ganancias anuales para este ejemplo es de USD 1,000,000.

Para mostrar el valor único en el contexto del progreso, sigue estos pasos.

Prepara tu exploración:

  1. Usa un cálculo basado en tablas para crear una suma de los valores de Total Profit. La expresión del cálculo basado en tablas es sum(${view_name.field_name}).

    Para este ejemplo, la expresión es sum(${order_items.total_profit}).

  2. Agrega un campo o un nuevo cálculo basado en tablas que represente el objetivo con el que se comparará el valor.

    Si creas un cálculo basado en tablas, el valor deberá representarse como una medida para que se incluya en la visualización.

    En la expresión de cálculo, multiplica una medición por cero y agrega el valor del objetivo: (${measure_viewname.measure_fieldname}*0) + <value that is the goal>.

    Para este ejemplo, la expresión es (${order_items.total_profit}*0) + 1000000.

Personaliza tu visualización de un solo valor:

  1. Abre el menú Editar en la barra Visualización.
  2. Selecciona las opciones de estilo que desees en la pestaña Estilo, como agregar un título personalizado que aparecerá como subtexto debajo del valor, junto con cualquier formato de valor de estilo de Excel.

    En este ejemplo, se ingresa "YTD profit" en la sección Anulación del título para proporcionar una mejor indicación de lo que representa el valor.

  3. En la pestaña Comparación, selecciona Mostrar.

  4. Selecciona la opción Calcular progreso o Calcular progreso (con porcentaje) en el menú desplegable Etiquetas de valor.

    Calcular progreso mostrará una barra de progreso con el valor sombreado para indicar el estado actual en relación con el objetivo. Si se aplica la configuración predeterminada de Etiqueta, también aparecerá el nombre del campo.

    Calcular progreso (con porcentaje) mostrará la barra de progreso sombreada con el texto X% de X con la configuración predeterminada de Etiqueta aplicada.

  5. Personaliza la etiqueta de la barra de progreso en la pestaña Comparación como desees.

    Anula la selección de la opción Mostrar etiqueta para ocultar la etiqueta del campo. Con la opción Calcular progreso, solo se mostrará una barra de progreso sombreada. Con la opción Calcular progreso (con porcentaje), se mostrará el texto X% de X en una barra de progreso sombreada.

    Deja las opciones de Mostrar etiqueta sin cambios para incluir la etiqueta del campo tal como está.

    Ingresa una etiqueta personalizada en el campo Etiqueta.

El resultado final es el valor de las ganancias del último año a la fecha (YTD) de $730,362.93 con una barra de progreso que indica el progreso hacia el objetivo de ventas anuales de $1,000,000.

El ejemplo se ve diferente con los parámetros de configuración Calcular progreso y Calcular progreso (con porcentaje) aplicados.

  • Así se verá el ejemplo con la opción Calcular progreso y la configuración de la etiqueta personalizada "progreso hacia el objetivo de ventas anuales" aplicada desde la pestaña Comparación:

    Valor único de USD 730,362.93 con el subtítulo &quot;YTD profit&quot; y una barra de progreso etiquetada como &quot;progress to yearly sales goal&quot; con 3/4 sombreados.

  • Así se verá el ejemplo con la opción Calcular progreso (con porcentaje) y la configuración de la etiqueta personalizada "objetivo de ventas anuales" aplicada desde la pestaña Comparación:

    Valor único de USD 730,362.93 con el subtítulo &quot;Ganancias del año hasta la fecha&quot; y una barra de progreso con la etiqueta &quot;73% del objetivo de ventas anuales de USD 1,000,000&quot; sombreada en 3/4.

Próximos pasos:

Una vez que hayas creado tu visualización de valor único, puedes compartirla con otras personas: