Cloud Workstations est fourni avec un éditeur de base par défaut qui vous permet d'écrire, de compiler, de tester, de déboguer et d'exécuter vos applications. L'éditeur de base est basé sur le projet Open Source Code-OSS, est compatible avec les extensions IDE fournies avec le registre Open VSX, et est préinstallé avec l'extension IDE Cloud Code.
Pour commencer à utiliser l'éditeur de base Cloud Workstations :
- Suivez les instructions du démarrage rapide pour créer une configuration de station de travail. Lorsque vous êtes invité à sélectionner Personnalisation de l'environnement, sélectionnez Code OSS (par défaut) comme éditeur de code.
Suivez les instructions du démarrage rapide pour créer une station de travail à l'aide de la configuration que vous venez de créer.
Dans la Google Cloud console, accédez à la page Cloud Workstations pour lancer votre station de travail depuis le navigateur.
Barre des tâches
La barre des tâches s'affiche sur le côté et vous pouvez accéder aux vues disponibles dans l'éditeur de base Cloud Workstations. Les vues de la barre des tâches sont les suivantes :
Explorateur : affichez les dossiers et les fichiers dans votre espace de travail actuel.
Rechercher : recherchez une chaîne ou une expression régulière spécifique dans vos fichiers.
Contrôle des sources : gérez les fichiers de l'application grâce à la compatibilité avec Git de l'éditeur de base Cloud Workstations.
Débogage : déboguez votre application en définissant des points d'arrêt et en inspectant des variables.
Extensions: parcourez un catalogue d'extensions qui ajoutent des fonctionnalités supplémentaires à votre IDE.
Cloud Code : créez et déployez des Google Cloud applications directement depuis l'IDE.
Paramètres : personnalisez l'éditeur de base Cloud Workstations en fonction de votre workflow
Afficher et modifier des fichiers
L'éditeur de code intégré vous permet de parcourir les répertoires de fichiers, ainsi que d'afficher et de modifier des fichiers dans votre station de travail.
Pour utiliser l'éditeur de base, procédez comme suit :
Utilisez la barre des tâches pour passer d'une vue à l'autre.
Utilisez l'éditeur pour afficher et modifier vos fichiers.
Utilisez la vue Explorateur pour parcourir les répertoires de fichiers, importer et télécharger des fichiers, prévisualiser des applications Web sur une instance de machine virtuelle Cloud Workstations et afficher des statistiques d'utilisation.
Figure 1. Éditeur de base Cloud Workstations
Importer et télécharger des fichiers et des répertoires
Pour importer ou télécharger des fichiers et des répertoires dans la vue Explorateur de Code-OSS, utilisez l'une des méthodes suivantes :
Faites glisser des fichiers sur la vue Explorateur pour les ajouter à l'espace de travail.
Accédez aux fichiers et aux répertoires que vous souhaitez utiliser, cliquez avec le bouton droit de la souris, puis sélectionnez Importer ou Télécharger.
Figure 2. Cliquez avec le bouton droit de la souris dans la vue Explorateur pour importer et télécharger des fichiers
Langues acceptées
L'éditeur de base Cloud Workstations est compatible avec des langages tels que Go, Python, Java, .NET Core et Node.js via des extensions, qui fournissent des fonctionnalités de langage telles que les suivantes :
- Mise en surbrillance intelligente, suggestions de code et saisie semi-automatique
- Linting et fourniture d'erreurs descriptives
- Navigation au sein du code (consultez les définitions, les déclarations, les références et les implémentations)
- Compatibilité avec le débogage intuitif
Intégration à Cloud Code
Cloud Code fournit une compatibilité IDE pour le cycle de développement complet des applications Kubernetes et Cloud Run, de la création et de la personnalisation d'une nouvelle application à partir d'exemples de modèles à l'exécution d'une application achevée. Cloud Code est également compatible avec des exemples et des extraits de configuration prêts à l'emploi, et offre une expérience de débogage sur mesure.
Cloud Code s'intègre à Gemini, un collaborateur basé sur l'IA, pour simplifier le développement. Utilisez Gemini pour accomplir vos tâches de manière plus efficace.
Cloud Code est compatible avec le développement d'applications en langage Node.js, Python, Java, Go et .NET Core.
En plus du menu Cloud Code disponible dans la barre d'état de Cloud Workstations, vous pouvez également accéder aux commandes Cloud Code via la palette de commandes. Pour ouvrir la palette de commandes, appuyez sur Control+Shift+P (ou Command+Shift+P sous macOS), ou cliquez sur Affichage > Palette de commandes.
Intégration de Data Agent Kit
Pour gérer vos charges de travail de data science et d'ingénierie des données directement dans l'éditeur de base, vous pouvez utiliser Google Cloud Data Agent Kit, qui est intégré à Cloud Code. Pour utiliser Data Agent Kit, cliquez sur l'icône Google Cloud Data Agent Kit dans la barre des tâches de l'éditeur de base. Pour en savoir plus, consultez la présentation de Data Agent Kit overview.
Compatibilité avec le contrôle des versions
L'éditeur de base Cloud Workstations intègre un contrôle des versions préconfiguré. Vous pouvez initialiser les dépôts, comparer les états des fichiers, préparer, mettre en attente, annuler la mise en attente et valider les modifications. Vous pouvez également utiliser des dépôts publics, privés ou même auto-hébergés, à condition qu'ils soient accessibles depuis la station de travail.
Gestion des espaces de travail
Avec Cloud Workstations, vous pouvez gérer et configurer vos projets en tant qu'espaces de travail. Les espaces de travail représentent généralement le dossier racine de votre projet. Avec l'éditeur de base Cloud Workstations, vous pouvez créer, ouvrir et enregistrer des espaces de travail, et les personnaliser avec des paramètres spécifiques à un projet.
Pour ouvrir un dossier en tant qu'espace de travail, utilisez le menu en haut de la barre des tâches et
sélectionnez Fichier > Ouvrir le dossier. Vous pouvez également utiliser
les options Ouvrir un fichier ou Espace de travail récent sur la page de bienvenue de l’éditeur de base
, ou utiliser le paramètre d’URL folder pour spécifier le chemin d’accès au dossier
que vous souhaitez ouvrir, par exemple &folder=/home/user/foo.
Applications de débogage
Cloud Workstations vous permet de déboguer votre application grâce à une compatibilité avec les applications Go, Node.js, Python et Java. Vous pouvez créer des configurations de lancement, définir des points d'arrêt et inspecter des variables, le tout depuis Cloud Workstations.
En outre, vous pouvez déboguer des applications Kubernetes sur un cluster local tel que Minikube ou Docker Desktop, sur un cluster distant sur GKE ou sur tout autre fournisseur cloud.
Terminal intégré
Vous pouvez interagir avec votre environnement de développement sous-jacent via le terminal intégré. Pour activer et désactiver la vue du terminal, procédez de l'une des manières suivantes :
- Appuyez sur
Control+. - Appuyez sur Control+Shift+P (ou Command+Shift+P sous macOS), ou cliquez sur
Affichage > Palette de commandes, puis saisissez
View: Toggle Terminal. - Sélectionnez Terminal > Nouveau terminal.
- Sélectionnez Affichage > Terminal.
- Cliquez sur ajouterAjouter dans la liste des onglets du terminal.
Pour ouvrir plusieurs fenêtres de terminal, cliquez sur Fractionner ou
appuyez sur Control+Shift+5.
Gérer et personnaliser les onglets du terminal
Si vous ouvrez plusieurs terminaux, une liste d'onglets de terminal s'affiche sur le côté de la vue du terminal. Cette liste contient les noms des terminaux ouverts.
Lorsque vous sélectionnez un nom de terminal dans la liste,
Fractionner et
Supprimer icônes s'affichent. Cliquez sur l'icône correspondante pour fractionner ou supprimer une fenêtre de terminal.
Pour afficher d'autres options de terminal telles que Déplacer le terminal dans la zone de l'éditeur, Renommer, Modifier la couleur, Modifier l'icône, etc., cliquez avec le bouton droit de la souris sur un nom de terminal.
Figure 5. Personnaliser votre terminal
Faire défiler l'affichage
En plus d'utiliser votre souris lorsque le focus du navigateur est sur un onglet de session, vous pouvez faire défiler en appuyant sur Control+Shift+PageUp et Control+Shift+PageDn sous Windows et Linux (ou Fn+Shift+Up et Fn+Shift+Down sous macOS).
Personnaliser les paramètres
Pour personnaliser l'éditeur, l'interface utilisateur et le comportement fonctionnel, l'éditeur de base Cloud Workstations fournit les portées suivantes pour définir les paramètres :
Paramètres de la machine : paramètres qui s'appliquent globalement lorsque vous vous connectez à une instance virtuelle Cloud Workstations et qui s'affichent sur votre station de travail dans le
$HOME/.codeoss-cloudworkstations/data/Machine/settings.jsonfichier.Paramètres utilisateur : paramètres qui s'appliquent globalement lorsque vous vous connectez à une instance virtuelle Cloud Workstations et qui sont conservés dans le stockage sur le navigateur pour chaque instance de station de travail.
Paramètres de l'espace de travail : paramètres stockés dans un espace de travail qui ne s' appliquent que lorsque vous ouvrez cet espace de travail. Ces paramètres s'affichent avec les fichiers de votre espace de travail dans le fichier
$WORKSPACE_ROOT/.vscode/settings.json.
L'éditeur évalue chaque portée de paramètres respectivement.
Raccourcis clavier
Étant donné que l'éditeur de base par défaut s'exécute dans le navigateur, certains raccourcis clavier peuvent être réservés par le navigateur et ne pas être capturés par l'éditeur.
Pour prendre en charge tous les raccourcis clavier, l'éditeur de base par défaut regroupe une application Web progressive (PWA) qui permet à l'éditeur de capturer ces raccourcis.
Pour utiliser la PWA :
- Ouvrez la station de travail dans votre navigateur.
- Cliquez sur l'icône d'installation qui s'affiche dans la barre d'adresse de votre navigateur.
La PWA doit ensuite être installée et la station de travail s'ouvre à nouveau dans la PWA. Lors des chargements suivants de votre station de travail, le navigateur propose une option permettant de rouvrir la station de travail dans la PWA dans la barre d'adresse.