El Explorador de métricas te permite crear gráficos temporales para visualizar y analizar rápidamente los datos de métricas que recopila tu proyecto de Google Cloud , como el uso de CPU de una máquina virtual (VM), sin configurar un panel. Puedes crear un gráfico de un solo tipo de métrica, comparar varias métricas o abrir gráficos de paneles existentes en el Explorador de métricas para probar diferentes parámetros de configuración de consultas y visualización. Cuando creas un gráfico que deseas conservar, puedes compartirlo o guardarlo en un panel personalizado.
Antes de comenzar
Para obtener los permisos que
necesitas para crear gráficos con el Explorador de métricas,
pídele a tu administrador que te otorgue el rol de IAM de
Visualizador de Monitoring (roles/monitoring.viewer) en tu proyecto.
Para obtener más información sobre cómo otorgar roles, consulta Administra el acceso a proyectos, carpetas y organizaciones.
También puedes obtener los permisos necesarios a través de roles personalizados o cualquier otro rol predefinido.
Crea un gráfico de un solo tipo de métrica
De forma predeterminada, cuando creas un gráfico, el estilo de visualización se establece como gráfico de líneas. Este estilo de gráfico es adecuado para la mayoría de los datos de métricas. Puedes cambiar el estilo del gráfico con el menú Tipo de widget. A continuación, se muestra un ejemplo de un gráfico para un solo tipo de métrica:

La imagen muestra varias líneas. Cada línea muestra el uso de CPU promedio de todas las VMs en una zona específica.
Para configurar un gráfico de modo que muestre una sola métrica, haz lo siguiente:
-
En la consola de Google Cloud , accede a la página leaderboard Explorador de métricas:
Acceder al Explorador de métricas
Si usas la barra de búsqueda para encontrar esta página, selecciona el resultado cuyo subtítulo es Monitoring.
- En la barra de herramientas de la consola de Google Cloud , selecciona tu proyecto de Google Cloud . Para las configuraciones de App Hub, selecciona el proyecto host o el proyecto de administración de App Hub.
Especifica los datos que se mostrarán en el gráfico. Puedes usar una interfaz controlada por menús o PromQL, o bien ingresar un filtro de Monitoring:
Interfaz controlada por menús
Selecciona los datos de series temporales que deseas ver:
-
En el elemento Métrica, expande el menú Seleccionar una métrica.
El menú Seleccionar una métrica contiene funciones que te ayudan a encontrar los tipos de métricas disponibles:
- Para encontrar un tipo de métrica específico, usa la
barra de filtros filter_list.
Por ejemplo, si ingresas
util, restringes el menú para que muestre las entradas que incluyenutil. Las entradas se muestran cuando pasan una prueba de "contiene" que no distingue mayúsculas de minúsculas. - Para mostrar todos los tipos de métricas, incluso las que no tienen datos, haz clic en Activa. De forma predeterminada, los menús solo muestran los tipos de métricas con datos.
Por ejemplo, puedes elegir las siguientes opciones:
- En el menú Recursos activos, selecciona Instancia de VM.
- En el menú Categorías de métricas activas, elige uptime_check.
- En el menú Métricas activas, selecciona Latencia de la solicitud.
- Haz clic en Aplicar.
- Para encontrar un tipo de métrica específico, usa la
barra de filtros filter_list.
Por ejemplo, si ingresas
- Opcional: Para especificar un subconjunto de datos que se mostrará, en el elemento Filtro, selecciona Agregar filtro y, luego, completa el cuadro de diálogo. Por ejemplo, puedes ver los datos de una zona aplicando un filtro. Puedes agregar varios filtros. Para obtener más información, consulta Filtra datos del gráfico.
Para obtener más información, consulta Selecciona los datos para el gráfico.
-
Combina y alinea series temporales:
- Para mostrar todas las series temporales, en el elemento Agregación, establece el primer menú en Sin agregar y el segundo menú en Ninguno.
- Para combinar series temporales, en el elemento Agregación,
haz lo siguiente:
Expande el primer menú y selecciona una función.
El gráfico se actualiza y muestra una sola serie temporal. Por ejemplo, si seleccionas Media, la serie temporal que se muestra es el promedio de todas las series temporales.
Para combinar series temporales que tienen los mismos valores de etiqueta, expande el segundo menú y, luego, selecciona una o más etiquetas.
El gráfico se actualiza y muestra una serie temporal para cada combinación única de valores de etiqueta. Por ejemplo, para mostrar los datos de series temporales por zona, configura el segundo menú como zona.
Cuando el segundo menú se establece en Ninguno, el gráfico muestra una serie temporal.
- Opcional: Para configurar el espaciado entre los puntos de datos, haz clic en add Agregar elemento de consulta, selecciona Intervalo mín. y, luego, ingresa un valor.
Para obtener más información sobre la agrupación y la alineación, consulta Elige cómo mostrar los datos del gráfico.
- Opcional: Para mostrar solo las series temporales con los valores más altos o más bajos, usa el elemento Ordenar y limitar.
PromQL
- En la barra de herramientas del panel del compilador de consultas, selecciona el botón cuyo nombre sea code PromQL.
-
Ingresa tu consulta en el editor de consultas. Por ejemplo, para graficar el uso promedio de CPU de las instancias de VM en tu proyecto de Google Cloud , usa la siguiente consulta:
avg(compute_googleapis_com:instance_cpu_utilization)
Para obtener más información sobre el uso de PromQL, consulta PromQL en Cloud Monitoring.
Filtro de Monitoring
-
En el elemento Métrica, haz clic en help_outline Ayuda y, luego, selecciona Modo de filtro directo.
Se borran los elementos Métrica y Filtro, y se crea un elemento Filtros que te permite ingresar texto.
Si seleccionaste un tipo de recurso, una métrica o filtros antes de cambiar al modo Modo de filtro directo, esos parámetros de configuración se muestran en el campo del elemento Filtros.
- Ingresa un filtro de Monitoring en el campo del elemento Filtros.
Combina y alinea series temporales:
- Para mostrar todas las series temporales, en el elemento Agregación, establece el primer menú en Sin agregar y el segundo menú en Ninguno.
- Para combinar series temporales, en el elemento Agregación,
haz lo siguiente:
Expande el primer menú y selecciona una función.
El gráfico se actualiza y muestra una sola serie temporal. Por ejemplo, si seleccionas Media, la serie temporal que se muestra es el promedio de todas las series temporales.
Para combinar series temporales que tienen los mismos valores de etiqueta, expande el segundo menú y, luego, selecciona una o más etiquetas.
El gráfico se actualiza y muestra una serie temporal para cada combinación única de valores de etiqueta. Por ejemplo, para mostrar los datos de series temporales por zona, configura el segundo menú como zona.
Cuando el segundo menú se establece en Ninguno, el gráfico muestra una serie temporal.
- Opcional: Para configurar el espaciado entre los datos, haz clic en add Agregar elemento de consulta, selecciona Intervalo mínimo y, luego, ingresa un valor.
Para obtener más información sobre la agrupación y la alineación, consulta Elige cómo mostrar los datos del gráfico.
Opciones de configuración avanzada
En esta sección, se describen las opciones disponibles para personalizar tu widget:
- Desglosa tu gráfico por etiquetas
- Cambia la visualización
- Cómo cambiar la apariencia del gráfico
- Cómo generar un gráfico con varios tipos de métricas
- Crea un gráfico de una proporción de métricas
Desglosa tu gráfico por etiquetas
De forma predeterminada, el Explorador de métricas muestra un gráfico con los datos de la métrica que seleccionaste. Cuando investigas un problema, la función de desglose puede ayudarte a determinar si la causa son tipos de recursos o ubicaciones específicos.
Para ver el tipo de métrica seleccionado desglosado por etiquetas, selecciona Mostrar desglose.
Para obtener información sobre esta función, consulta Cómo desglosar un gráfico por etiquetas.
Cambia la visualización
De forma predeterminada, el Explorador de métricas muestra los datos de la métrica seleccionada como un gráfico de líneas. Este estilo de gráfico es adecuado para la mayoría de los tipos de métricas, pero no para todos.
Actualiza la configuración del gráfico según el tipo de métrica que seleccionaste:
- Para los tipos de métricas de cuota, usa los siguientes parámetros de configuración:
- En la barra de herramientas, establece el control de tiempo en al menos una semana. Las métricas de cuota suelen informar una muestra por día.
- En el panel Mostrar, expande el menú Tipo de widget y, luego, selecciona Gráfico de barras apiladas.
- Para los tipos de métricas que tienen un tipo de valor Distribución, asegúrate de que el menú Tipo de widget esté configurado como Gráfico de mapa de calor. Para obtener más información, consulta Acerca de las métricas con valor de distribución.
- Para otros tipos de métricas, usa el menú Tipo de widget para mostrar cómo se
muestran los datos. En el menú Tipo de widget, se enumeran todos los tipos de widgets disponibles. Sin embargo, es posible que algunos widgets no estén habilitados.
Considera un gráfico que muestra varias series temporales y supone que cada valor medido es un número de punto flotante de doble precisión:
- Los widgets Gráfico de líneas, Gráfico de barras apiladas y Gráfico de áreas apiladas se indican como Compatibles. Puedes seleccionar cualquiera de estos tipos.
- El widget Mapa de calor está inhabilitado porque estos widgets solo pueden mostrar datos con valores de distribución.
Cómo cambiar la apariencia del gráfico
De forma predeterminada, el Explorador de métricas muestra las series temporales con el modo de color. A cada serie temporal se le asigna un color único y el fondo es blanco. Sin embargo, puedes modificar esta apariencia.
Opcional: Para cambiar la forma en que un gráfico o una tabla muestran los datos seleccionados, usa las opciones del panel Visualización:
- Opciones del gráfico:
- Menú Analysis mode: Selecciona entre gráficos de líneas, rayos X y estadísticas.
- Menú Comparar con pasados: Superpone los datos actuales con los datos pasados.
- Menú Línea de umbral: Agrega un umbral de referencia.
- Menú Alias de leyenda: Configura el nombre de una columna de leyenda.
- Menús de asignación del eje Y, etiquetas del eje Y y escala del eje Y: Configura la asignación, las etiquetas o la escala del eje Y.
- Opciones de la tabla:
- Menú Opción de valor: Selecciona entre el valor más reciente y un valor agregado.
- Menú Columnas visibles: Selecciona las columnas que se muestran.
- Menú Formato de columna: Configura los nombres de las columnas, la alineación de los datos en una columna, las unidades y si las celdas tienen un código de color.
- Menú Vista de métricas: Selecciona si el valor se muestra por sí solo o en relación con un rango de valores.
- Menú Alias de la leyenda: Configura el nombre de una columna de leyenda.
Cómo crear gráficos de varios tipos de métricas
Esta función solo está disponible cuando usas la interfaz basada en menús. No está disponible cuando usas PromQL o filtros de Monitoring.
En algunos casos, es posible que desees mostrar series temporales de diferentes tipos de métricas en el mismo gráfico. Por ejemplo, para comparar las cargas de lectura y escritura en una VM, configura un gráfico para que muestre la cantidad de bytes leídos y la cantidad de bytes escritos.
Para graficar varias métricas, debes usar la interfaz basada en menús. Las otras interfaces no admiten la creación de gráficos de varias métricas.
Para mostrar varias métricas en un gráfico, haz lo siguiente:
-
En la consola de Google Cloud , accede a la página leaderboard Explorador de métricas:
Acceder al Explorador de métricas
Si usas la barra de búsqueda para encontrar esta página, selecciona el resultado cuyo subtítulo es Monitoring.
- En la barra de herramientas de la consola de Google Cloud , selecciona tu proyecto de Google Cloud . Para las configuraciones de App Hub, selecciona el proyecto host o el proyecto de administración de App Hub.
Especifica los datos que se mostrarán en el gráfico.
En el elemento Métrica, selecciona el primer tipo de métrica cuyos datos deseas ver. Para obtener información sobre estos pasos, consulta Cómo generar un gráfico de un solo tipo de métrica.
La consulta para esta selección tiene el identificador A.
Para cada tipo de métrica adicional, haz lo siguiente:
- Selecciona Agregar consulta. Se agrega una consulta nueva. Por ejemplo, se podría agregar una consulta con la etiqueta B.
- Para la consulta nueva, en el elemento Métrica, selecciona un tipo de recurso y uno de métrica. También puedes agregar filtros, combinar series temporales, y ordenar y limitar la cantidad de series temporales que se muestran.
En la siguiente captura de pantalla, se ilustra la pantalla del Explorador de métricas cuando se grafican dos tipos de métricas:

Opcional: En el panel Pantalla, expande el menú Eje Y y configura qué eje Y se usa para cada tipo de métrica.
Crea un gráfico de una proporción de métricas
Esta función solo está disponible cuando usas la interfaz controlada por menús o cuando usas PromQL. No está disponible cuando usas filtros de supervisión.
Supervisar la cantidad de errores informados puede ser útil. Sin embargo, es más probable que debas supervisar la tasa de errores. Es decir, quieres saber cuántos errores se produjeron en comparación con la cantidad total de respuestas. Para cumplir con este requisito, puedes configurar un gráfico para que muestre la proporción de dos métricas. Para obtener referencias a ejemplos y para obtener información sobre las anomalías que pueden ocurrir cuando graficas proporciones de métricas, consulta Proporciones de métricas.
Para mostrar una proporción de métricas en un gráfico, haz lo siguiente:
-
En la consola de Google Cloud , accede a la página leaderboard Explorador de métricas:
Acceder al Explorador de métricas
Si usas la barra de búsqueda para encontrar esta página, selecciona el resultado cuyo subtítulo es Monitoring.
- En la barra de herramientas de la consola de Google Cloud , selecciona tu proyecto de Google Cloud . Para las configuraciones de App Hub, selecciona el proyecto host o el proyecto de administración de App Hub.
Especifica los datos que aparecerán en el gráfico:
Interfaz controlada por menús
- Configura el numerador:
- En el elemento Métrica, usa los menús para seleccionar un tipo de recurso y uno de métrica. Para obtener información sobre estos pasos, consulta Crea un gráfico de un solo tipo de métrica.
- Actualiza los campos de agregación. De forma predeterminada, el Explorador de métricas promedia todas las series temporales.
- Opcional: Actualiza el período fijo para que se combinen los puntos dentro de una serie temporal. Para modificar este campo, haz clic en add Agregar elemento de consulta, selecciona Intervalo mínimo y completa el cuadro de diálogo.
- Selecciona Agregar consulta y, luego, configura el denominador:
- Para la nueva consulta, en el elemento Métrica, selecciona un
tipo de recurso y un tipo de métrica.
Selecciona un tipo de métrica cuya clase de métrica sea la misma que la del numerador. Por ejemplo, si la métrica del numerador es una métrica
GAUGE, selecciona una métricaGAUGEpara el denominador. -
Actualiza los campos de agregación.
Te recomendamos que las etiquetas del tipo de métrica del denominador coincidan con los valores establecidos para el tipo de métrica del numerador. Por ejemplo, puedes seleccionar la etiqueta
zonepara el numerador y el denominador.No es necesario que uses el mismo conjunto de etiquetas para ambos tipos de métricas. Sin embargo, solo puedes seleccionar etiquetas que sean comunes a ambos tipos de métricas.
- Haz clic en add Agregar elemento de consulta, selecciona Intervalo mínimo y asegúrate de que este campo esté configurado con el valor que usa el numerador.
- Para la nueva consulta, en el elemento Métrica, selecciona un
tipo de recurso y un tipo de métrica.
-
En la barra de herramientas del panel de consultas, selecciona Crear proporción y, luego, completa el diálogo.
Después de crear la proporción, se muestran tres consultas:
- Proporción A/B identifica la consulta de proporción.
- A identifica la consulta para el numerador.
- La letra B identifica la consulta para el denominador.
En el siguiente ejemplo, se ilustra una proporción que compara la suma de los bytes escritos en el disco por zona con la cantidad total de bytes escritos en el disco:

-
Opcional: Para cambiar las métricas del numerador y del denominador, en el elemento Proporción, expande el menú y, luego, selecciona una opción.
PromQL
- En la barra de herramientas del panel del compilador de consultas, selecciona el botón cuyo nombre sea code PromQL.
-
Ingresa tu consulta en el editor de consultas. Por ejemplo, para trazar la proporción de la latencia promedio de tu métrica
my_summary_latency_seconds, usa la siguiente consulta:sum without (instance)(rate(my_summary_latency_seconds_sum[5m])) / sum without (instance)(rate(my_summary_latency_seconds_count[5m]))
Para obtener más información sobre el uso de PromQL, consulta PromQL en Cloud Monitoring.
- Configura el numerador:
Cómo guardar un gráfico
Después de configurar un gráfico, es posible que desees guardarlo para referencia futura o guardar los datos que muestra. En esta sección, se describen estas opciones.
Cómo guardar un vínculo a un gráfico
Para mantener una referencia a la configuración del gráfico, guarda la URL del gráfico. Debido a que la URL del gráfico codifica la configuración del gráfico, cuando pegas esta URL en un navegador, se muestra el gráfico que configuraste.
Para obtener la URL del gráfico, haz clic en link Vínculo en la barra de herramientas del gráfico.
Agrega tu gráfico a un panel personalizado
El Explorador de métricas te permite crear un gráfico que puedes usar para explorar una métrica. Sin embargo, los gráficos que crea esta herramienta no son persistentes. Cuando sales de la página Explorador de métricas, el gráfico se descarta.
Para guardar un gráfico que configuraste con el Explorador de métricas para referencia futura, agrégalo a un panel personalizado o guarda su URL:
Para agregar tu gráfico a un panel personalizado, realiza una de las siguientes acciones:
Si usas la consola de Google Cloud para administrar tus paneles personalizados, selecciona Guardar como en la barra de herramientas del Explorador de métricas, selecciona Gráfico del panel y, luego, completa el diálogo. Puedes guardar el gráfico en un panel personalizado existente o crear uno.
Si usas la API de Cloud Monitoring para administrar tus paneles personalizados, actualiza el archivo JSON que define el panel y sus widgets. El JSON de cada widget incluye la búsqueda que usa el sistema para recuperar los datos que se mostrarán.
Para acceder a la representación JSON, haz clic en code Editor de JSON en la barra de herramientas del gráfico.
Para obtener información detallada sobre cómo usar la API para administrar tus paneles personalizados, consulta Crea y administra paneles con la API.
Cómo guardar los datos que muestra el gráfico
Para guardar los datos que muestra el gráfico en tu sistema local, haz clic en get_app Descargar CSV.
Crea una política de alertas a partir de tu gráfico
Puedes crear una política de alertas para supervisar los datos que graficaste. Para crear una política de alertas, sigue estos pasos:
En la barra de herramientas, haz clic en Guardar como y selecciona Política de alertas.
Se abrirá el cuadro de diálogo de la política de alertas con los campos de selección de métricas propagados. Tu política de alertas está configurada para notificarte cuando el valor de los datos supervisados sea mayor que el umbral.
Completa lo siguiente y, luego, guarda la política:
- En la sección Configurar activador, actualiza el umbral.
- Agregar canales de notificaciones.
- Ingresa un nombre para la política de alertas.
¿Qué sigue?
Desglosa un gráfico por etiquetas: Cuando investigues un problema, usa la función de desglose del Explorador de métricas para determinar si la causa son tipos de recursos o ubicaciones específicos. El Explorador de métricas puede dividir un gráfico en una serie de tarjetas, cada una de las cuales muestra datos de series temporales para una clave de etiqueta específica. Esta vista te ayuda a identificar aumentos, disminuciones o tendencias que, de lo contrario, la agregación podría ocultar.
Explora los datos en gráficos: Describe cómo usar los controles de gráficos para destacar series temporales, cambiar la resolución de los gráficos, mostrar valores atípicos y comparar los datos actuales con los anteriores.