I grafici di Google Maps ti consentono di visualizzare i dati geografici su mappe reattive e interattive e offrono un controllo significativo sul modo in cui vengono tracciati i punti della mappa. I grafici di Google Maps hanno funzionalità simili al tipo di visualizzazione Grafico a mappa.
Visualizzare un grafico di Google Maps
Quando gli utenti visualizzano un grafico di Google Maps, sul grafico vengono visualizzate diverse icone che consentono loro di interagire con la visualizzazione.
![]()
- Icone Aumenta zoom e Diminuisci zoom: fai clic sull'icona + per aumentare lo zoom e sull'icona - per diminuirlo nella visualizzazione mappa.
- Icona Attiva/Disattiva visualizzazione a schermo intero: fai clic sull'icona Attiva/Disattiva visualizzazione a schermo intero per espandere la mappa a schermo intero. Premi il tasto
escsulla tastiera o fai di nuovo clic sull'icona per tornare alla visualizzazione standard. - Trascina Pegman sulla mappa per aprire Street View: trascina l'icona Pegman in qualsiasi posizione del grafico per passare alla visualizzazione Street View per quella posizione. Fai clic sulla freccia Indietro in alto a sinistra in Street View per tornare al grafico.
- Scala delle distanze: nella parte inferiore del grafico è presente una fare lo scale in metri o chilometri per la visualizzazione corrente della mappa.
- Scorciatoie da tastiera: fai clic su Scorciatoie da tastiera nella parte inferiore del grafico per visualizzare una finestra con le scorciatoie da tastiera disponibili per interagire con il grafico.
- Scala di colori dei valori: se le misure vengono tracciate sul grafico, nella parte inferiore sinistra del grafico viene visualizzata una scala di colori per indicare l'intervallo di colori tra i valori minimo e massimo. Le impostazioni nel menu Valore possono influire sull'aspetto della scala di colori dei valori.
- Apri questa zona in Google Maps: fai clic sul logo Google in basso a sinistra del grafico per aprire la mappa in Google Maps. Google Maps si apre in una nuova scheda del browser.
Creare un grafico di Google Maps
Per creare un grafico di Google Maps, la query deve includere almeno uno dei seguenti campi:
- Una dimensione basata sui dati di latitudine e longitudine. Questo valore è definito da uno sviluppatore LookML come dimensione di
type: location. - Una dimensione a cui è assegnato un livello della mappa. Gli sviluppatori LookML possono aggiungere un livello della mappa integrato, un livello della mappa personalizzato fornendo un URL a un file TopoJSON o un livello della mappa personalizzato a una dimensione utilizzando il parametro
map_layer_name. - Una dimensione del codice postale, a cui viene assegnato automaticamente un livello della mappa dei codici postali statunitensi. Questo valore è definito da uno sviluppatore LookML come dimensione di
type: zipcode. Le regioni con codici postali si basano sulle aree di tabulazione dei codici postali (ZCTA) degli Stati Uniti. Potrebbe non esserci una corrispondenza uno a uno tra i codici postali e le ZCTA utilizzate per le visualizzazioni delle mappe. È possibile che non tutti i punti vengano visualizzati sulla mappa.
Limita la precisione delle coordinate dei dati di latitudine e longitudine a non più di cinque o sei cifre decimali. Se le coordinate superano le sette cifre decimali, la mappa non mostrerà alcun punto dati.
Per creare un grafico di Google Maps, seleziona il tipo di visualizzazione Google Maps nella barra Visualizzazione. Puoi anche modificare la visualizzazione della mappa nel menu di visualizzazione. Fai clic su Modifica nell'angolo in alto a destra della barra Visualizzazione.
Le opzioni descritte in questa pagina sono disponibili nelle diverse schede del menu Modifica. Le opzioni potrebbero essere disattivate o nascoste se sono in conflitto con altre impostazioni che hai scelto.
Opzioni del menu del grafico
La scheda Grafico ti consente di selezionare il modo in cui vengono tracciati i dati sulla posizione. Ogni scelta ha opzioni di formattazione leggermente diverse, a seconda del tipo di grafico. Anche le opzioni di tracciamento variano a seconda che nel LookML per la dimensione sia definito un livello della mappa.
Per le visualizzazioni che non contengono dimensioni del codice postale o dimensioni con un livello della mappa definito, sono supportate le seguenti opzioni di Tracciamento:
- Punti
- Mappa termica automatica
- Mappa termica di densità
- Mappa termica 3D
- Collega con linee
- Connettersi con aree
- Descrizione comando personalizzata
Ciascuna delle opzioni del menu Grafico è descritta in questa sezione.
Punti

Puoi tracciare ogni riga di una tabella di dati sottostante come un punto discreto sulla mappa.
Affinché questo tipo di grafico funzioni correttamente, devi selezionare almeno una dimensione di type: location. Se vuoi, puoi aggiungere una misura.
Una dimensione della località da sola posizionerà punti di dimensioni e colore uniformi. L'aggiunta di una misura alla tabella dei dati sottostanti consente di scalare i punti in base al colore o alle dimensioni nella scheda del menu Punti.
Mappa termica automatica

Una mappa termica automatica mostra i dati come una griglia di mappa termica, che si adatta in granularità quando gli spettatori aumentano o diminuiscono lo zoom sulla mappa.
Affinché questo tipo di grafico funzioni correttamente, devi selezionare sia una dimensione di type: location sia una metrica.
Per visualizzare i dati in una query come griglia della mappa termica, Looker divide la mappa visibile in quadrati uguali e calcola quali valori nei dati rientrano in ogni quadrato. I quadrati sono colorati in base a una misura che scegli. Se aumenti o riduci lo zoom di questa mappa, Looker ricalcola la griglia in modo che la granularità sia appropriata al livello di zoom.
L'opzione Mappa termica Automagic esegue nuovamente una query sui dati per costruire la griglia della mappa termica. Una dimensione della località viene in genere visualizzata come punti distinti con una coordinata di latitudine e longitudine, ma quando utilizzi una mappa termica automatica, la dimensione cambia in rettangoli di selezione ("Regione della mappa termica da ... a ..") di ogni quadrato della griglia.
Mappa termica di densità

Affinché questo tipo di grafico funzioni correttamente, devi selezionare almeno una dimensione di type: location. Se vuoi, puoi aggiungere una misura.
Una mappa termica di densità è utile per visualizzare grandi quantità di dati sulla posizione con molti punti raggruppati in modo denso. La mappa termica della densità mostra i dati utilizzando l'intensità del colore e una scala di colori per trasmettere la concentrazione dei punti dati in ogni area.
Mappa termica 3D
Crea una mappa termica 3D da punti geografici. Una mappa termica 3D aggrega i punti dati in celle esagonali, utilizzando sia il colore che l'altezza (elevazione) per rappresentare la densità o i valori numerici.

Affinché questo tipo di grafico funzioni correttamente, devi selezionare almeno una dimensione di type: location. Se vuoi, puoi aggiungere una misura.
Collega con linee

Affinché questo tipo di grafico funzioni correttamente, sono necessarie due dimensioni di type: location. Se vuoi, puoi aggiungere una misura.
L'opzione Connetti con linee prende due campi di type: location dalla query e li collega con una linea nella visualizzazione. L'aggiunta di una misura alla query consente di aggiungere una scala di colori alle linee.
Collega con aree

Affinché questo tipo di grafico funzioni correttamente, è necessaria una dimensione di type: location. Se vuoi, puoi aggiungere una misura.
La visualizzazione mappa Connetti con aree prende un campo di type: location e collega tutti i punti nell'ordine in cui li hai ordinati con delle linee, formando i confini di un'area sulla mappa. L'aggiunta di una misura alla query consente di formattare le dimensioni e il colore dei singoli punti di posizione che delimitano l'area nella scheda del menu Valore.
Descrizione comando personalizzata
Puoi fare clic sul pulsante Descrizione comando personalizzata per configurare le descrizioni comando nell'editor di visualizzazione Esplora utilizzando una combinazione di impostazioni dell'interfaccia utente e un editor HTML che supporta i modelli Liquid. Scopri di più sui suggerimenti personalizzati.
Opzioni del menu della mappa
Stile mappa
Stile mappa consente agli utenti di modificare il tipo di mappa di sfondo e se devono essere visualizzate le etichette della mappa (come città e strade). Questa opzione include un menu a discesa con un elenco di scelte:
Chiaro:mappa dai colori chiari progettata per fornire un contesto geografico evidenziando al contempo i dati.

Chiaro (senza etichette): come Chiaro, ma la mappa omette le etichette, ad esempio i nomi delle città.
Scuro:mappa di colore scuro progettata per fornire contesto geografico ed evidenziare i dati.

Scuro (senza etichette): come Scuro, ma la mappa omette le etichette, ad esempio i nomi delle città.
Satellite:mappa che mostra immagini satellitari e aeree globali.

Satellite (senza etichette): come Satellite, ma la mappa omette le etichette, ad esempio i nomi delle città.
Strade:mappa per uso generico che enfatizza lo stile leggibile delle reti stradali e di trasporto pubblico.

All'aperto: mappa per uso generico adatta per escursioni, ciclismo e altri usi all'aperto.

Traffico (giorno): mappa dai colori chiari che mette in evidenza le reti di trasporto pubblico e le strade, incluse le informazioni sul traffico in tempo reale.

Traffico (notte): mappa dai colori scuri che mette in evidenza le reti di trasporto pubblico e le strade, incluse le informazioni sul traffico attuali.
Minimale:mappa dai colori chiari senza etichette o linee di confine.

Posizione sulla mappa
Puoi modificare il punto centrale e il livello di zoom di una mappa visibile:
- Adatta ai dati: centra e ingrandisce automaticamente la mappa in modo che tutti i punti dati della query siano visibili.
- Personalizzato: ti consente di impostare manualmente latitudine, longitudine e livello di zoom (numeri più alti creano un livello di zoom più ravvicinato).
Consenti panoramica
Questa opzione ti consente di determinare se gli utenti possono riposizionare la mappa trascinandola. Questa opzione è attiva per impostazione predefinita.
Consenti zoom
Questa opzione ti consente di determinare se deve essere visualizzato un pulsante (+/-) in alto a sinistra nella visualizzazione della mappa, consentendo agli utenti di aumentare e diminuire lo zoom. Questa opzione è attiva per impostazione predefinita.
Mostra nome completo del campo
Questa opzione consente di stabilire se mostrare il nome della visualizzazione insieme al nome del campo nelle descrizioni comando della mappa. Le descrizioni comando vengono visualizzate quando gli utenti fanno clic sui punti dati della mappa. Questa opzione è deselezionata per impostazione predefinita.
Per ulteriori informazioni su come vengono visualizzate le descrizioni comando nei grafici di Google Maps, consulta la sezione Aspetti da considerare in questa pagina.
Mostra legenda
Questa opzione ti consente di determinare se mostrare una legenda della mappa in basso a sinistra di una visualizzazione. La legenda mostra la scala di colori utilizzata dalla mappa, se hai aggiunto una misura alla visualizzazione.
L'opzione Mostra legenda è disponibile per le seguenti opzioni di tracciato:
- Modalità mappa termica automatica
- Modalità Punti, quando la modalità di colore dell'indicatore è impostata su In base al valore
Mostra campo regione nella descrizione comando
L'opzione Mostra campo Regione nella descrizione comando è disponibile quando la query ha almeno una dimensione a cui è assegnato un livello della mappa. Gli sviluppatori LookML possono aggiungere un livello della mappa integrato o un livello della mappa personalizzato a una dimensione utilizzando il parametro map_layer_name.
Questa opzione consente di determinare se visualizzare le informazioni sulla regione nelle descrizioni comando che vengono visualizzate sulla mappa.
Quando l'opzione Mostra campo regione nella descrizione comando è attivata, se gli utenti passano il mouse sopra una regione della mappa, le informazioni sulla regione (fornite da qualsiasi dimensione a cui è assegnato un livello della mappa) vengono visualizzate nella descrizione comando. Nel seguente esempio, la query contiene le dimensioni State e Zipcode con i livelli della mappa integrati assegnati:

Quando l'opzione Mostra campo regione nella descrizione comando è disattivata, se gli utenti passano il mouse sopra una regione della mappa, la descrizione comando contiene solo i valori delle metriche nella query. L'esempio seguente utilizza la stessa query dell'esempio precedente, ma l'opzione Mostra campo regione nella descrizione comando è disattivata:

Per ulteriori informazioni su come vengono visualizzate le descrizioni comando nei grafici di Google Maps, consulta la sezione Aspetti da considerare in questa pagina.
Disegna etichette mappa sopra i dati
Se i dati nella visualizzazione contengono un livello della mappa, viene visualizzata l'opzione di menu Disegna etichette mappa sopra i dati. L'opzione è disattivata per impostazione predefinita.
L'attivazione dell'opzione Disegna etichette mappa sopra i dati sposta le etichette della mappa sopra i dati della mappa termica. Ciò è utile con valori di opacità della mappa termica più elevati. Se una mappa termica è opaca, le etichette non vengono visualizzate a meno che non sia attivata l'opzione Disegna etichette mappa sopra i dati.
Opzioni del menu Punti
Tipo
Questa opzione è disponibile per le mappe con tipi di tracciamento Punti, Collega con linee o Collega con aree.
Type specifica il tipo di punto visualizzato nella visualizzazione della mappa:
- Cerchio: i punti sulla mappa vengono visualizzati come cerchi di dimensioni e colori diversi.

- Icona: i punti sulla mappa vengono visualizzati come icone di vari colori.

- Entrambi: i punti sulla mappa vengono visualizzati sia come cerchi che come icone.

- Nessuno: non vengono visualizzati punti sulla mappa.

La selezione del tipo di punto influisce sulle altre opzioni di formattazione disponibili. Un Tipo di Entrambi include tutte le opzioni. Un Tipo Nessuno non mostra opzioni.
Radius
Questa opzione è disponibile per le mappe con tipi di tracciamento Punti, Collega con linee o Collega con aree.
Se selezioni Cerchio nell'opzione Tipo del menu Punti, viene visualizzata l'opzione di menu Raggio. L'opzione Raggio consente di impostare le dimensioni dei punti del cerchio. Puoi scegliere una delle tre opzioni seguenti:
Proporzionale al valore:regola le dimensioni relative dei cerchi in base alle misure nella query. Quando scegli questa opzione, puoi impostare un raggio minimo e un raggio massimo dei cerchi, che corrispondono ai valori più bassi e più alti dei dati. Puoi anche scegliere tra una scala lineare e una logaritmica per dimensionare i cerchi.
Uguale a valore:regola il raggio dei cerchi in base ai valori di misura effettivi nella query sottostante. Questa opzione ha senso solo se tracci dati di distanza, ad esempio se la misura contiene le dimensioni di un territorio.
Fisso:se scegli Fisso, viene visualizzata un'opzione aggiuntiva Raggio fisso, in cui puoi impostare un raggio fisso da applicare a tutti gli indicatori sulla mappa. Il valore predefinito è 500 unità di raggio.
Unità raggio
Questa opzione è disponibile per le mappe con tipi di tracciamento Punti, Collega con linee o Collega con aree.
Se selezioni Cerchio o Entrambi nell'opzione Tipo del menu Punti, viene visualizzata l'opzione di menu Unità raggio. L'opzione Unità raggio ti consente di impostare le unità dei punti del cerchio come metri o pixel.
Icona
Questa opzione è disponibile per le mappe con tipi di tracciamento Punti, Collega con linee o Collega con aree.
Se selezioni Icona o Entrambi nell'opzione Tipo del menu Punti, viene visualizzata l'opzione di menu Icona. Se espandi il menu a discesa Icona, puoi scegliere un'icona da visualizzare su tutti i segnaposto della mappa. I marcatori non possono essere dinamici in base ai tuoi dati.
Modalità colore indicatore
Questa opzione è disponibile per le mappe con tipi di tracciamento Punti, Collega con linee o Collega con aree.
Se selezioni Cerchio, Icona o Entrambi nell'opzione Tipo del menu Punti, viene visualizzata un'opzione di menu Modalità colore indicatore. Questa opzione ti consente di personalizzare il colore dei segnaposto della mappa in una mappa interattiva. Puoi scegliere una delle due opzioni:
- In base al valore: i colori vengono assegnati dinamicamente ai marcatori in base ai valori della query sottostante. Per configurare i colori nella legenda per questa opzione, vedi l'opzione Colori valori.
- Personalizzato: consente di impostare un unico colore da utilizzare per tutti i segnaposto sulla mappa. Il valore del colore può anche essere formattato come stringa esadecimale RGB, ad esempio
#2ca6cd, o come nomi dei colori CSS, ad esempiomediumblue.
Opzioni del menu Value
Colori valori
Puoi impostare il colore dei punti della mappa o definire l'intervallo di colori da utilizzare se stai codificando i colori in base a una misura.
Puoi inserire un elenco di stringhe esadecimali, ad esempio #2ca6cd, o nomi di colori CSS, ad esempio mediumblue. I colori inseriti per primi sono associati ai valori più bassi.
Mappa a doppio asse
L'opzione Mappa a doppio asse è disponibile quando una query ha almeno due misure. Questo pulsante ti consente di sovrapporre una seconda metrica come livello in scala di grigi sopra le regioni della mappa codificate per colore.

- La prima metrica nella query determina il colore delle regioni.
- La seconda misura nella query determina l'intensità della scala di grigi (dal bianco al nero) della sovrapposizione.
Il livello in scala di grigi utilizza la semitrasparenza per consentire la visualizzazione del livello di colore principale, permettendoti di visualizzare contemporaneamente due metriche diverse sulla stessa mappa.
Tieni presenti le seguenti limitazioni per questa funzionalità:
- Sono supportate al massimo due metriche.
- I dati in pivot non sono supportati.
Quantizza colori
Per impostazione predefinita, l'opzione Quantizza colori è disattivata e Looker visualizza i valori utilizzando una scala di colori sfumati.

Se attivata, l'opzione Quantizza colori modifica la scala dei colori da un gradiente uniforme a blocchi di colori specifici.

Inverti scala dei colori
Se attivata, l'opzione Inverti scala dei colori inverte i colori che indicano i valori alti e bassi nel grafico, invertendo la mappa a gradiente di colore.
Valore minimo/Valore massimo
Puoi impostare i valori minimo e massimo dell'intervallo di colori. In questo modo puoi assegnare a tutti i punti al di sotto di una determinata soglia il colore più basso e a tutti i punti al di sopra di una determinata soglia il colore più alto.
Per impostazione predefinita, questo campo viene lasciato vuoto e i valori minimo e massimo applicati alla legenda sono i valori minimo e massimo della query.
Opzioni del menu Livelli
Le opzioni del menu Livelli ti consentono di aggiungere overlay di Google Maps.
Livello personalizzato
Se abilitata, ti consente di specificare un livello della mappa personalizzato fornendo un URL a un file TopoJSON. Questa opzione è utile per visualizzare regioni geografiche non standard o poligoni personalizzati direttamente nella visualizzazione. Questa opzione è un'alternativa all'utilizzo del parametro LookML map_layer_name per definire un livello mappa personalizzato.
Se attivi Livello personalizzato, vengono visualizzate le seguenti opzioni:
- URL TopoJSON: l'URL del file TopoJSON. Puoi inserire un URL completo per
un file ospitato esternamente (ad esempio,
https://example.com/map.json) o un percorso relativo a un file caricato nel tuo progetto Looker.- Per i file di progetto, il percorso deve seguire rigorosamente il pattern
/projects/{project_id}/raw/{file_path}(ad esempio,/projects/my_project/raw/my_map.json). Se ometti la directory/raw/, la richiesta viene bloccata. - I file di progetto devono utilizzare un'estensione
.json(ad esempio,my_map.jsonomy_map.topojson.json). Looker non indicizza i file con estensione.topojson.
- Per i file di progetto, il percorso deve seguire rigorosamente il pattern
- Chiave oggetto TopoJSON: il nome dell'oggetto all'interno del file TopoJSON da visualizzare.
- Chiave proprietà TopoJSON: la proprietà nel file TopoJSON che corrisponde ai valori nella dimensione della query. Looker utilizza questa proprietà per mappare i dati nelle regioni personalizzate.
- Chiave etichetta proprietà TopoJSON: la proprietà nel file TopoJSON da utilizzare come etichetta di visualizzazione per ogni regione (ad esempio, nei suggerimenti).
- Mostra corrispondenze: attiva/disattiva per visualizzare le regioni del livello TopoJSON personalizzato che non hanno dati corrispondenti nella query.
- Colore/opacità regioni non corrispondenti: seleziona il colore e l'opacità del colore utilizzato per il rendering delle regioni non corrispondenti.
Livello trasporto pubblico
Se questa opzione è attiva, viene aggiunto un livello di trasporto pubblico di Google Maps che sovrappone linee e stazioni del trasporto pubblico. Le linee sulla mappa mostrano i percorsi in autobus, metropolitana e treno. Per ulteriori informazioni e per visualizzare i prossimi treni o autobus, scegli l'icona di una fermata.
Livello percorsi ciclabili
Se attivato, aggiunge un livello di Google Maps per le biciclette che evidenzia le piste ciclabili e le strade adatte alle biciclette. I colori indicano il tipo di percorsi ciclabili.
- Verde scuro: mostra i sentieri privi di traffico automobilistico.
- Verde: indica le corsie ciclabili, ovvero corsie riservate alle biciclette su una strada percorribile dagli autoveicoli.
- Linea verde punteggiata: indica le strade adatte a ciclisti, ovvero strade senza una corsia ciclabile, ma consigliate per i ciclisti.
- Linee verde scuro tratteggiate: indicano percorsi sterrati o non asfaltati.
Livello traffico
Se questa opzione è attivata, viene aggiunto un livello di traffico di Google Maps che mostra le condizioni del traffico in tempo reale. Colori del traffico Il colore indica la velocità del traffico sulla strada.
- Verde: nessun ritardo dovuto al traffico.
- Arancione: volume di traffico medio.
- Rosso: ritardi dovuti al traffico. Più scuro è il rosso, più ridotta è la velocità del traffico sulla strada.
Le linee grigie o blu sulla mappa mostrano i percorsi.
I problemi di traffico includono i seguenti tipi di ritardi:
- Incidenti
- Edilizia
- Chiusure stradali
- Altri incidenti
Opzioni del menu della mappa termica
Le opzioni del menu Mappa termica ti consentono di configurare le opzioni Mappa termica Automagic, Mappa termica di densità e Mappa termica 3D.
Linee della griglia della mappa termica
Questa opzione è disponibile quando è selezionata l'opzione Mappa termica automatica dal menu Tracciato o quando viene utilizzato un livello della mappa nel grafico. Se attivi questa opzione, viene aggiunto un bordo intorno a ciascuna delle griglie utilizzate per la mappa termica automatica.
Linee della griglia su regioni vuote
Se l'opzione Linee della griglia della mappa termica è attivata e stai tracciando una dimensione con un livello della mappa definito, puoi attivare/disattivare l'opzione Linee della griglia nelle regioni vuote per visualizzare un contorno intorno alle regioni della mappa che non hanno dati associati.

Opacità mappa termica
Questa opzione è disponibile quando è selezionata l'opzione Mappa termica automatica o quando nel grafico viene utilizzato un livello della mappa. Questa opzione ti consente di specificare l'opacità dei colori utilizzati nella mappa termica. Inserisci un numero decimale a una sola cifra compreso tra 0 e 1, dove 0 indica nessun colore e 1 indica un colore totalmente opaco.
Intensità
Questa opzione è disponibile quando è selezionata l'opzione Mappa termica di densità dal menu Tracciamento.
Questo cursore controlla il moltiplicatore di ponderazione per i punti dati.
L'aumento dell'intensità rende la mappa termica più "calda" nel complesso. Tende a spostare il colore di output verso la parte superiore dello spettro cromatico (ad esempio, passando dal blu/verde al rosso/giallo), facendo apparire come punti caldi le aree con una concentrazione anche moderata. La diminuzione dell'intensità richiede una maggiore concentrazione di punti per raggiungere il colore massimo nel gradiente.
Soglia
Questa opzione è disponibile quando è selezionata l'opzione Mappa termica di densità dal menu Tracciamento.
Questo cursore definisce il rapporto tra il "peso di dissolvenza" e il peso massimo. Controlla il taglio o la trasparenza ai bordi dei blob della mappa termica.
L'aumento della soglia rende i bordi della mappa di calore più nitidi e definiti. I pixel con densità relativamente bassa (inferiore al rapporto di soglia) sbiadiranno e diventeranno trasparenti più rapidamente. La diminuzione della soglia crea una dissolvenza più uniforme e graduale sui bordi, consentendo alle aree a densità inferiore di rimanere visibili.
Scala di elevazione
Questa opzione è disponibile quando Mappa termica 3D è selezionata dal menu Grafico. Questo cursore controlla l'altezza degli esagoni nella mappa di calore 3D.
Raggio esagono
Questa opzione è disponibile quando Mappa termica 3D è selezionata dal menu Grafico. Questo cursore controlla la larghezza degli esagoni nella mappa di calore 3D.
Colori
Le opzioni di colore sono disponibili quando Mappa termica 3D è selezionata dal menu Grafico. Puoi utilizzare queste opzioni per definire i colori della mappa termica.
Raccolta
Una raccolta ti consente di creare visualizzazioni e dashboard a tema che abbiano un bell'aspetto insieme. Tutte le raccolte di colori integrate di Looker sono riportate nella pagina di documentazione Raccolte di colori. L'amministratore di Looker può anche creare una raccolta di colori personalizzata per la tua organizzazione.
Puoi scegliere una raccolta di colori dal menu a discesa Raccolta. La sezione Tavolozza verrà aggiornata con una tavolozza della raccolta di colori scelta.
Tavolozza
Dopo aver selezionato una raccolta di colori, puoi scegliere una tavolozza diversa dalla raccolta o personalizzare la tavolozza facendo clic sulla tavolozza dei colori. Si apre il selettore della tavolozza e vengono visualizzate tutte le tavolozze della raccolta.
I colori vengono assegnati a ogni serie in ordine. Per una tavolozza categoriale, il primo colore della tavolozza viene assegnato alla prima serie e così via. Per una tavolozza sequenziale o divergente, il colore all'estremità sinistra della tavolozza viene assegnato alla prima serie e i colori per ogni serie rimanente si spostano verso destra sulla tavolozza. Se la query restituisce più serie di dati rispetto ai colori elencati, i colori si ripetono dall'inizio della tavolozza, prima come versione più chiara di ogni colore, poi come versione più scura.
Creare una tavolozza dei colori personalizzata
Per creare una tavolozza dei colori personalizzata, seleziona la scheda Personalizzato nel selettore tavolozza. Puoi modificare la tavolozza in diversi modi:
- Fai clic su uno dei colori presenti per modificarlo.
- Fai clic sui pulsanti + o - per aggiungere un colore alla fine della tavolozza o per rimuovere un colore selezionato.
- Fai clic su MODIFICA TUTTO in basso a destra nel menu per utilizzare un elenco separato da virgole di valori di colore.

Per modificare un colore selezionato o tutti i colori contemporaneamente, inserisci stringhe esadecimali, ad esempio #2ca6cd, o nomi di colori CSS, ad esempio mediumblue, nella casella del valore del colore nella parte inferiore del selettore.

Per visualizzare un selettore colori e selezionare un colore, fai clic sulla ruota dei colori a destra della casella del valore del colore. Il valore esadecimale corrispondente a quel colore viene visualizzato nella casella del valore del colore.

Se fai clic su MODIFICA TUTTO, la casella del valore del colore viene compilata con i codici esadecimali della tavolozza di colori che hai scelto o personalizzato. Copiare e incollare questo elenco è il modo migliore per copiare le tavolozze dei colori personalizzate da un grafico all'altro.
Inverti colori
Puoi invertire i colori utilizzati in una tavolozza. Per una tavolozza categoriale, l'ultimo colore della tavolozza viene applicato alla prima serie, il penultimo colore della tavolozza alla seconda serie e così via. Per una tavolozza sequenziale o divergente, questo applica il colore all'estremità destra della tavolozza alla prima serie e si sposta a sinistra sulla tavolozza per le serie rimanenti.
Aspetti da considerare
Comportamento delle descrizioni comando nei grafici di Google Maps
Le descrizioni comando nei grafici di Google Maps possono comportarsi in modi specifici.
Quando un intero paese è visibile in un grafico di Google Maps (e non viene ripetuto):
- La descrizione comando verrà visualizzata al centro geografico del paese in base alla larghezza.
- La visualizzazione della descrizione comando inizierà dalla latitudine più settentrionale del paese.
Se un intero paese non è visibile in un grafico di Google Maps (la mappa è ingrandita su un punto specifico di un paese), la descrizione comando viene visualizzata accanto al cursore.
Quando una mappa di Google Maps viene rimpicciolita a tal punto da mostrare due istanze dello stesso paese (vengono visualizzati entrambi i centri geografici), la descrizione comando viene visualizzata in uno dei due modi seguenti:
- Se c'è spazio sopra entrambe le istanze del paese, la descrizione comando verrà visualizzata sopra il punto medio dei due paesi.
- Se c'è spazio solo sopra un'istanza del paese, la descrizione comando verrà visualizzata solo sopra quel paese.