Benutzerdefinierte Dashboard-Filter hinzufügen und bearbeiten

Diese Seite enthält Informationen zu standardmäßigen Dashboard-Filtern. Weitere Informationen zu Dashboard-Kreuzfiltern finden Sie auf der Dokumentationsseite Dashboards kreuzfiltern.

Informationen zu Dashboard-Filtern

Mit Dashboard-Filtern können Betrachter die Ergebnisse eines Dashboards auf die Daten begrenzen, die für sie relevant sind. Dashboard-Filter können auf alle Tiles in einem Dashboard oder auf nur eine Dashboard-Tile angewendet werden.

Beim Aufrufen eines Dashboards kann ein Nutzer die Filterwerte des Dashboards vorübergehend aktualisieren, ohne dass sich dies auf andere Nutzer auswirkt. Dies unterscheidet sich von Filtern, die Teil einer Abfrage sind, die einer Dashboard-Tile zugrunde liegt. Betrachter können diese Filter nur ändern, wenn sie die Berechtigung haben, die Tile zu bearbeiten oder von hier aus zu explorieren.

Wenn Sie dauerhafte Änderungen an Filtern vornehmen möchten, die für alle Nutzer sichtbar sind, oder wenn Sie Filter hinzufügen oder löschen möchten, benötigen Sie die Zugriffsebene Zugriff verwalten, Bearbeiten für das Dashboard und müssen sich im Bearbeitungsmodus befinden.

Überschreibungsverhalten von Dashboard-Filtern

Filter in einem Dashboard können auf verschiedenen Ebenen angewendet werden. Wenn sich mehrere Filter auf dasselbe Feld auswirken, bestimmt Looker die Priorität gemäß der folgenden Hierarchie (von der höchsten zur niedrigsten Priorität):

  1. Kreuzfilter (höchste Priorität): Werden erstellt, wenn Betrachter mit Datenpunkten auf Dashboard-Tiles interagieren, für die Kreuzfilter aktiviert sind.
  2. Filter auf Visualisierungsebene: Sie werden direkt auf eine bestimmte Visualisierungskachel angewendet.
  3. Filter auf Dashboard-Ebene: werden auf Dashboard-Ebene auf eine oder mehrere Kacheln angewendet.
  4. Filter auf Abfrageebene (niedrigste Priorität): Sie werden in der zugrunde liegenden Abfrage (Explore oder Look) der Kachel konfiguriert.

Das Überschreibungsverhalten dieser Filter wird so bestimmt:

  • Überschreibung desselben Felds:
    • Wenn ein Filter auf Visualisierungsebene und ein Filter auf Dashboard-Ebene auf dasselbe Feld angewendet werden, überschreibt der Filter auf Visualisierungsebene den Filter auf Dashboard-Ebene für diese Tile. Auf diese Tile wird nur der Filterwert auf Visualisierungsebene angewendet.
    • Wenn ein Filter auf Dashboard- oder Visualisierungsebene zusammen mit einem Filter in der zugrunde liegenden Abfrage der Tile auf dasselbe Feld angewendet wird, überschreibt der Filter auf Dashboard- oder Visualisierungsebene den Abfragefilter. Es wird nur der Filterwert der höheren Ebene angezeigt und angewendet.
    • Kreuzfilter setzen Filter auf Visualisierungs-, Dashboard- und Abfrageebene für dasselbe Feld außer Kraft.
  • Benutzerdefinierte Ausdrücke: Wenn in der zugrunde liegenden Abfrage ein benutzerdefinierter Ausdruck verwendet wird, werden Felder im Filter für benutzerdefinierte Ausdrücke nicht durch Filter auf höherer Ebene überschrieben, unabhängig davon, auf welche Spalten verwiesen wird. In diesem Fall werden sowohl der Filter auf höherer Ebene als auch der Abfragefilter angezeigt und angewendet.
  • Komplexe Filter (OR-Bedingungen): Wenn die Filtergruppierung der zugrunde liegenden Abfrage mindestens eine OR-Bedingung enthält, wird der Filter als komplexer Filter behandelt. Übergeordnete Filter überschreiben dann keine Felder, auf die in diesem Abfragefilter verwiesen wird. Beide Filter werden angezeigt und angewendet.

Zusammenfassend lässt sich sagen, dass ein Filter für die zugrunde liegende Abfrage als benutzerdefinierter Filter behandelt wird, der von übergeordneten Filtern nie überschrieben wird, wenn eine der folgenden Bedingungen zutrifft:

  • Die innerste AND/OR-Gruppierung enthält mindestens eine OR-Bedingung.
  • Der Filter enthält einen benutzerdefinierten Ausdruck.

Dashboard-Filter und LookML

Wenn für ein Modell, ein Explore oder ein Feld der Parameter label (model), label (Explore) bzw. label (field) verwendet wird, um den Namen im Menü Explore oder in der Feldauswahl zu ändern, wird der im Parameter label angegebene Name im Fenster Filter hinzufügen verwendet.

Wenn Sie ein LookML-Entwickler sind und sich im Entwicklungsmodus befinden, können Sie einen Dashboard-Filter für ein Feld erstellen, das nur in der Entwicklungsmodus-Version eines Modells angezeigt wird. Der Filter funktioniert jedoch nicht wie erwartet, wenn Sie den Entwicklungsmodus verlassen oder wenn der Filter von anderen Nutzern verwendet wird. Gleichermaßen funktioniert der Filter nicht wie erwartet, wenn ein Filterfeld nach Erstellung des Filters gelöscht oder umbenannt wird.

Dashboard-Filter hinzufügen

Achten Sie darauf, dass sich das Dashboard im Bearbeitungsmodus befindet und dass Sie mindestens eine Abfrage-Tile oder eine mit einem Look verknüpfte Tile haben. Wählen Sie in der oberen Symbolleiste Filter und dann Filter hinzufügen aus.

Das Fenster Filter hinzufügen wird angezeigt.

Das Fenster „Filter hinzufügen“

Das Fenster Filter hinzufügen wird mit vorab ausgefüllten Feldern (Dimensionen oder Measures) aus allen Explores angezeigt, die beim Erstellen der Tiles dieses Dashboards verwendet wurden.

Im folgenden Fenster Filter hinzufügen sehen Sie beispielsweise die Explores, die in den Kacheln des Dashboards verwendet werden: das Explore Flights aus dem Modell E Faa und das Explore Order Items aus dem Modell MB ecommerce_demo.

Die im Fenster „Filter hinzufügen“ vorab ausgefüllten Explores werden nach der Suchleiste „Filtern nach“ angezeigt.

Wählen Sie den Pfeil neben einem Explore aus, um die Ansichten des Explores anzuzeigen. Die verschiedenen Ansichten können dann erweitert werden, um darin enthaltenen Felder anzuzeigen.

Um nach einem Feld aus einem dieser Explores zu filtern, können Sie im Dialogfeld Filtern nach nach Feldern suchen oder einen Feldnamen manuell eingeben. Sie können auch auf einen Feldnamen wie Order ID (Bestell-ID) klicken, um das Feld dem Dialogfeld Filter by (Filtern nach) hinzuzufügen.

Wenn Sie ein Feld auswählen, das bereits von einem anderen Filter verwendet wird, erhalten Sie einen Hinweis von Looker. Sie können den Filter zwar dennoch erstellen, aber nicht mehrere Filter, die dasselbe Feld verwenden, auf dieselbe Dashboard-Tile anwenden.

Wenn Sie einen Filter für ein Feld aus einem Explore erstellen möchten, das nicht im Dashboard verwendet wird, lesen Sie den Abschnitt Erweiterte Filter auf dieser Seite.

Nachdem Sie das Feld ausgewählt haben, nach dem Sie filtern möchten, klicken Sie auf Hinzufügen.

Erweiterte Filter

Über erweiterte Filter können Sie Dashboard-Filter mit Feldern erstellen, die nicht zu den Explores gehören, mit denen die Tiles des Dashboards erstellt wurden. Aktivieren Sie im Fenster Filter hinzufügen den Schalter Erweitert, um erweiterte Filter zu verwenden. Dadurch wird das Fenster Filter hinzufügen mit Optionen zum Auswählen eines Modells, eines Explores und eines Felds aktualisiert, mit denen der Filter erstellt werden soll:

Wählen Sie zuerst einen Modellnamen im Drop-down-Menü Modell aus. Das Drop-down-Menü enthält alle LookML-Modelle, auf die Sie Zugriff haben.

Nach der Auswahl eines Modells wird das Dialogfeld Explore mit einem Drop-down-Menü mit allen im ausgewählten Modell enthaltenen Explores gefüllt.

Nachdem Sie das Modell und das Explore ausgewählt haben, werden die in diesem Explore verfügbaren Felder im Fenster Filter hinzufügen angezeigt. Sie können mit der Suchleiste das Feld suchen, anhand dessen Sie filtern möchten. Alternativ können Sie auch einen Feldnamen auswählen.

Wählen Sie das Feld aus, nach dem Sie filtern möchten, und klicken Sie dann auf Hinzufügen.

Filterkonfiguration anpassen

Nachdem Sie ein Filterfeld ausgewählt und auf Hinzufügen geklickt haben, werden auf den Tabs Einstellungen und Zu aktualisierende Kacheln im Fenster Filter hinzufügen verschiedene anpassbare Einstellungen angezeigt.

Tab Einstellungen

  • Titel: Geben Sie den Titel des Filters ein, der auf dem Dashboard angezeigt werden soll. Die Titeloption ist mit dem Namen des Feldes, nach dem gefiltert werden soll, vorab ausgefüllt.
  • Steuerelement: Treffen Sie eine Auswahl aus einer Liste mit Steuerelementtypen, die je nach zu filterndem Datentyp unterschiedlich sind. Weitere Informationen zu den verschiedenen Steuerelementtypen finden Sie im Abschnitt Steuerelemente für Dashboard-Filter auf dieser Seite.
  • Anzeige: Legen Sie bei Steuerelementen, die Inline oder als Popover angezeigt werden können, fest, wie der Filter angezeigt wird. Weitere Informationen zu den verschiedenen Möglichkeiten zum Anzeigen von Filtern finden Sie im Abschnitt Dashboard-Filter anzeigen auf dieser Seite. Wenn ein Steuerelement nur auf eine Weise angezeigt werden kann, wird diese Option nicht angezeigt.
  • Werte: Wenn Sie bestimmte Werteoptionen für den Filter festlegen möchten, nehmen Sie eine Auswahl im Drop-down-Menü vor oder geben die Werteoptionen in dieses Feld ein. Nehmen Sie keine Eingabe vor, wenn Werteoptionen aus der Datenbank bis zur maximal für dieses Steuerelement verfügbaren Werteanzahl abgerufen werden sollen. Bei numerischen Daten wird dieses Feld durch die Felder Min und Max ersetzt.
  • Standardwert konfigurieren: Legen Sie optional den Standardwert für den Filter fest.
  • Filterwert erforderlich: Klicken Sie auf Zusätzliche Optionen, um die Option Filterwert erforderlich aufzurufen. Aktivieren Sie das Kontrollkästchen, um einen Wert für den Filter zu verlangen. Weitere Informationen über das Verlangen von Filterwerten finden Sie im Abschnitt Einen Filterwert verlangen auf dieser Seite.
  • Filter auswählen, die aktualisiert werden sollen, wenn sich dieser Filter ändert: Klicken Sie auf Zusätzliche Optionen, um die Option Filter auswählen, die aktualisiert werden sollen, wenn sich dieser Filter ändert aufzurufen. Klicken Sie auf das Kästchen, um andere Filter mit diesem Filter zu verknüpfen. Weitere Informationen über verknüpfte Filter finden Sie im Abschnitt Verknüpfte Filter einrichten auf dieser Seite. Sind im Dashboard keine weiteren Filter vorhanden, ist diese Option deaktiviert.
  • Hinzufügen und Abbrechen: Klicken Sie auf eine dieser Schaltflächen, um den neuen Filter zu speichern oder abzubrechen.

Auf dem Tab Zu aktualisierende Tiles können Sie festlegen, auf welche Tiles der Filter angewendet wird.

Standardverhalten des Tabs Zu aktualisierende Kacheln

Looker wendet den Filter standardmäßig automatisch auf alle Tiles an, die aus demselben Explore erstellt wurden wie der Filter, und legt für das Feld Zu filterndes Feld dasselbe Feld fest, das auch für den Filter ausgewählt wurde.

Wenn neue Tiles zum Dashboard hinzugefügt werden, nachdem der Filter erstellt wurde, und sie aus demselben Explore wie der Filter stammen, wird der Dashboard-Filter automatisch auf diese Tile angewendet.

Änderungen auf dem Tab Tiles To Update vornehmen

Wenn Sie anpassen möchten, auf welche Filter die einzelnen Tiles reagieren oder welche Felder von Filtern betroffen sind, stehen die folgenden Einstellungen zur Verfügung.

  • Wählen Sie Alle oder Keine aus, um den Filter für alle Kacheln zu aktivieren oder zu deaktivieren.

  • Wählen Sie im Abschnitt Zu filterndes Feld für jede Tile aus, welches Feld vom Filter betroffen sein soll, oder legen Sie fest, dass der Filter nicht auf eine einzelne Tile angewendet werden soll. Wenn das Feld eines neuen Filters bereits von einem vorhandenen Filter verwendet wird, sind alle Tiles, die vom vorhandenen Filter gefiltert werden, nicht für den neuen Filter verfügbar.

  • Wählen Sie Hinzufügen oder Abbrechen aus, um die neuen Filtereinstellungen zu speichern oder zu verwerfen.

Steuerelemente für Dashboard-Filter

Mit Steuerelementen für Dashboard-Filter können Sie die Darstellung von Filtern für Dashboard-Betrachter anpassen. Die Filtersteuerelementtypen, die beim Erstellen eines Dashboardfilters im Drop-down-Menü Steuerelement verfügbar sind, hängen von den LookML-Daten type ab, die dem Feld zugewiesen sind, nach dem Sie filtern.

S = Funktioniert mit dem Datentyp string

N = Funktioniert mit dem Datentyp number und numerischen Messwerten

T = Funktioniert mit dem Datentyp tier

ZC = Funktioniert mit dem Datentyp zipcode

YN = Funktioniert mit dem Datentyp yesno

DI = Funktioniert mit dem Datentyp distance

DU = Funktioniert mit dem Datentyp duration

DT = Funktioniert mit den meisten Datums- und Uhrzeitdatentypen *

L = Funktioniert mit dem Datentyp location

P = Funktioniert mit dem Parameter parameter

SteuerungBeschreibungDarstellungDatentypen
Mehrfachauswahl
Schaltflächengruppe Mit dieser Art von Filter können Sie Betrachtern eine begrenzte Auswahl an Optionen zur Verfügung stellen. In der Einstellung Werte können bis zu 30 Optionen kuratiert werden. Wenn die Einstellung Werte für die Datentypen string, tier und zipcode leer gelassen wird, werden die ersten 30 Werte aus der Datenbank angezeigt.

Eine Schaltfläche wird farbig dargestellt, sobald sie ausgewählt ist.
Steuerelemente für Buttongruppen werden als horizontale Reihe separater Buttons angezeigt, die Filterwerte darstellen. S N T ZC YN DI DU
Kästchen Diese Art von Filter ähnelt einer Schaltflächengruppe, hat aber ein etwas anderes Design. Sie ist nützlich, um Zuschauern eine begrenzte Auswahl an Optionen zu bieten. In der Einstellung Werte können bis zu 50 Optionen kuratiert werden. Wenn die Einstellung Werte für die Datentypen string, tier und zipcode leer bleibt, werden die ersten 50 Werte aus der Datenbank angezeigt. Kästchen-Steuerelemente werden als horizontale Reihe von Kästchen angezeigt, die Filterwerte darstellen. S N T ZC YN DI DU
Tag-ListeEine Kombination aus Drop-down- und Checkbox-Filtern. Die Drop-down-Optionen können in der Einstellung Werte kuratiert werden. Bei den Datentypen string, tier und zipcode können alle Werte aus der Datenbank abgerufen werden, wenn die Einstellung Werte leer gelassen wird.

Betrachter können das Wertemenü maximieren, indem sie entweder in das Filterfeld oder auf den Winkel klicken. Nutzer können einzelne Werte auswählen oder die Auswahl aufheben, indem sie auf das Kästchen eines Werts klicken. Nutzer können auch auf das X neben einem Filterwert klicken, um die Auswahl aufzuheben. Nutzer können alle verfügbaren Werte auswählen, indem sie auf das Kästchen „(Anzahl der ausgewählten Werte) von (Anzahl der Optionen)“ klicken (z. B. „0 von 200 ausgewählt“), um alle übereinstimmenden Werte zum Filter hinzuzufügen. Mit Auswahl aller aufheben können sie alle übereinstimmenden Werte entfernen. Alle Änderungen werden automatisch übernommen, es sei denn, der Nutzer klickt auf Abbrechen.

Steuerelemente für Tag-Listen können nur in der Popover-Ausrichtung oder hinter der Schaltfläche Mehr angezeigt werden. Die Option Alle auswählen ist nicht verfügbar,wenn die Dashboard-URL länger als 2.083 Zeichen ist.
Eine Tag-Liste wird als Drop-down-Menü mit Kästchen neben den Menüpunkten angezeigt. S N T ZC DI DU
BereichsschiebereglerDer Mindest- und Höchstwert des Bereichsschiebereglers kann auf dem Tab Einstellungen des Filterkonfigurationsfensters festgelegt werden.

Betrachter können den Filterwertbereich festlegen, indem sie beide Enden des Schiebereglers anpassen.
Ein Bereichsschieberegler wird als horizontale numerische Skala mit beweglichen Enden auf jeder Seite angezeigt, um einen Wertebereich anzupassen. N DI DU
Einfachauswahl
Ein/Aus-ButtonsDieser Filtertyp ist nützlich, um Betrachtern eine ausgewählte Gruppe von eingeschränkten Optionen zu bieten. In der Einstellung Werte können bis zu 30 Optionen kuratiert werden. Wenn die Einstellung Werte für die Datentypen string, tier und zipcode leer gelassen wird, werden die ersten 30 Werte aus der Datenbank angezeigt.

Ein Button wird farbig dargestellt, sobald er ausgewählt ist.
Schaltflächen-Umschalter werden als horizontale Reihe verbundener Schaltflächen angezeigt, die Filterwerte darstellen. S N T ZC YN DI DU P
OptionsfelderDieser Filtertyp ähnelt einem Button-Umschalter, hat aber ein etwas anderes Design. Er eignet sich, um Nutzern eine ausgewählte Gruppe von Optionen zu präsentieren. In der Einstellung Werte können bis zu 50 Optionen kuratiert werden. Wenn die Einstellung Werte für die Datentypen string, tier und zipcode leer bleibt, werden die ersten 50 Werte aus der Datenbank angezeigt. Optionsfelder werden als horizontale Liste von Werten mit einem runden Optionsfeld links neben jedem Wert angezeigt. S N T ZC YN DI DU P
Drop-down-MenüDie Drop-down-Optionen können in der Einstellung Werte kuratiert werden. Bei den Datentypen string, tier und zipcode können alle Werte aus der Datenbank abgerufen werden, wenn die Einstellung Werte leer gelassen wird.

Betrachter können das Drop-down-Menü maximieren, indem sie entweder in das Filterfeld oder auf den Winkel klicken. Nutzer können eine Option aus dem Drop-down-Menü auswählen oder in das Feld eingeben, um die Drop-down-Optionen einzugrenzen. Zuschauer können auch Beliebiger Wert auswählen.

Drop-down-Menüs können nur in der Inline-Ausrichtung oder hinter der Schaltfläche Mehr angezeigt werden.
Ein Drop-down-Menü wird als einzelner Wert und ein Chevron angezeigt. Wenn Sie das Chevron auswählen, wird eine Liste mit möglichen Filterwerten angezeigt. S N T ZC YN DI DU P
SchiebereglerDer Mindest- und Höchstwert des Schiebereglers kann auf dem Tab Einstellungen des Filterkonfigurationsfensters festgelegt werden.

Betrachter können den Filterwert festlegen, indem sie das rechte Ende des Schiebereglers anpassen.
Ein Schieberegler wird als horizontale numerische Skala mit einem beweglichen Ende auf der rechten Seite angezeigt, um den Höchstwert anzupassen.N DI DU
Datum und Uhrzeit
Einzelner Tag Betrachter können das Datum auswählen, um den Kalender zu maximieren und einen neuen Tag auszuwählen.

Menü-Steuerelemente für einen einzelnen Tag können nur in der Inline-Ausrichtung oder hinter der Schaltfläche Mehr angezeigt werden.
Ein Steuerelement für einen einzelnen Tag wird zuerst als einzelnes Datum angezeigt. Wenn Sie darauf klicken, wird ein Monatskalender eingeblendet. DT *Die Steuerung für einen einzelnen Tag kann mit den meisten Zeiträumen und zeitbasierten Typen verwendet werden. Betrachter können mit dieser Art von Steuerung jedoch nur einzelne Tage auswählen.
DatumsbereichBetrachter können den Zeitraum auswählen, um den Kalender zu maximieren und einen neuen Zeitraum auszuwählen.

Steuerelemente für das Menü „Zeitraum“ können nur in der Inline-Ausrichtung oder hinter der Schaltfläche Mehr angezeigt werden.
Steuerelemente für den Zeitraum werden anfangs als Zeitraum angezeigt. Wenn Sie den Zeitraum auswählen, wird ein Kalender für zwei Monate eingeblendet. Sie können im Kalender ein Datum auswählen, um den Filterwert zu aktualisieren. DT * Die Zeitraumsteuerung kann mit den meisten Zeiträumen und zeitbasierten Typen verwendet werden. Betrachter können mit dieser Art von Steuerung jedoch nur Zeiträume auswählen.
ZeiträumeZuschauer können entweder aus einer Reihe von Zeiträumen auswählen, die in Looker integriert sind, oder eigene benutzerdefinierte Zeiträume erstellen, indem sie den Tab Benutzerdefiniert auswählen. Auf der Dokumentationsseite Dashboards ansehen finden Sie alle Zeiträume, die für einen Zeitraumfilter verfügbar sind.

Zeitrahmenoptionen wie Letzte 7 Tage umfassen den aktuellen Tag. Wenn Sie einen Zeitraum ohne den aktuellen Tag festlegen möchten, wählen Sie im Drop-down-Menü der Steuerung die Option Erweitert aus und konfigurieren Sie den Wert mit vollständige Tage.

Seit Jahresbeginn umfasst den Zeitraum vom Jahresanfang bis zur aktuellen Sekunde.

Zuschauer können den Zeitraum auswählen, um die Optionen für den Zeitraum aufzurufen.

Steuerelemente für das Menü „Zeiträume“ können nur in der Inline-Ausrichtung oder hinter der Schaltfläche Mehr angezeigt werden.
Zeitraum-Steuerelemente werden anfangs als Zeitraum angezeigt. Wenn Sie den Zeitraum auswählen, wird ein Menü mit voreingestellten Zeiträumen sowie ein benutzerdefinierter Tab angezeigt. DT * Die Zeitachse kann mit den meisten Zeiträumen und zeitbasierten Typen verwendet werden. Zuschauer können jedoch keine Zeitoptionen mit dieser Art von Steuerelement auswählen.
Sonstiges
ErweitertWeitere Informationen zu erweiterten Steuerelementen finden Sie im Abschnitt Erweiterte Steuerelemente verwenden auf dieser Seite.

Erweiterte Steuerelemente können nur in der Popover-Ausrichtung oder hinter der Schaltfläche Mehr angezeigt werden.
Erweiterte Steuerelemente werden anfangs als Filterbedingung angezeigt. Wenn Sie diese Bedingung auswählen, werden eine Reihe von Drop-down-Menüs und Textfeldern angezeigt, mit denen Sie die Bedingung anpassen können. S N T ZC YN DT DI DU L P
* Hinweis zu Datums- und Zeitdaten:Einige Zeiträume und zeitbasierte Typen werden als unterschiedliche Datentypen interpretiert, wenn Looker Steuerelemente für sie auswählt. Zwei Beispiele sind der yesno-Zeitraum, der als yesno-Datentyp interpretiert wird und daher die für den Typ yesno verfügbaren Steuerungsoptionen hat, und der hour_of_day-Zeitraum, der als number-Datentyp interpretiert wird und daher die für den Typ number verfügbaren Steuerungsoptionen hat.

Erweiterte Steuerelemente verwenden

Ein erweitertes Steuerelement kann auf alle Datentypen angewendet werden und bietet zusätzliche Flexibilität für die Filterbedingungen, die Sie festlegen können. Wenn Sie ein erweitertes Steuerelement erstellen möchten, maximieren Sie im Fenster für die Filterkonfiguration das Drop-down-Menü Steuerelement und wählen Sie Erweitert aus.

Wenn Sie Erweitert auswählen, wird der Bereich Filteroptionen konfigurieren mit geeigneten Optionen für Filterbedingungen für den von Ihnen gefilterten Datentyp gefüllt. Wenn Sie beispielsweise einen Filter für ein Feld mit dem Datentyp string erstellt haben, werden die Optionen für die Filterbedingung angezeigt, z. B. ist, enthält und beginnt mit. Filter für andere Datentypen, wie zum Beispiel die Typen number oder date, zeigen andere Bedingungsoptionen an. Sie können die Bedingungsoptionen für den Filter festlegen, indem Sie auf das Kästchen für die jeweilige Bedingungsoption klicken.

Mit der Option Mehrere Filterwerte zulassen können Nutzer mehr als einen Wert für den Filter auswählen. Dies ist standardmäßig aktiviert. Ist die Option aktiviert, wird neben dem Feld Standardwert konfigurieren das Symbol + Hinzufügen angezeigt. Wählen Sie das Symbol + aus, um einen zusätzlichen Filterwert hinzuzufügen. Um Benutzer zu beschränken, so dass diese nur einen Wert auswählen können, deaktivieren Sie diese Option. Die Option Mehrere Filterwerte zulassen ist für Filter, die auf dem Datentyp location oder dem Parameter parameter basieren, nicht verfügbar.

Nachdem Sie Ihre Filterbedingungsoption ausgewählt haben, können Sie einen Wert aus dem Menü Standardwert konfigurieren auswählen, das Werte aus Ihrer Datenbank enthält. Alternativ kann ein Wert eingegeben werden, um einen Vorschlag zu erhalten.

Sie können auch selbst einen Wert eingeben und die Eingabetaste (PC) oder die Return-Taste (Mac) drücken, um einen Wert zu erstellen.

Sie können neben dem Filterwert das Symbol + auswählen, um dem Filter neue Bedingungen hinzuzufügen. Diese werden je nach Art der Bedingungen und Werte als OR- oder AND-Bedingungen hinzugefügt.

Wenn Sie eine Bedingung entfernen möchten, klicken Sie daneben auf X.

Erweiterte Steuerelemente, Datum und Uhrzeit

Es stehen verschiedene Filtersteuerelemente zur Verfügung, mit denen nach Datum gefiltert werden kann. Sie können auch erweiterte Steuerelemente mit Datumsangaben verwenden. Mit erweiterten Steuerelementen können Nutzer unter anderem „vollständige“ Zeiträume auswählen, die den aktuellen Zeitraum nicht enthalten, indem sie in den Bedingungsoptionen Bereiche wie ganze Tage oder ganze Wochen auswählen. Das unterscheidet sich vom Zeitrahmen-Filtersteuerelement, das den aktuellen Zeitraum umfasst.

Mit erweiterten Steuerelementen können Benutzer auch Zeitwerte auswählen, wie zum Beispiel Stunden, Minuten und Sekunden.

Übereinstimmung mit Benutzerattribut

Über die erweiterten Steuerelemente können Sie im Bereich Filteroptionen konfigurieren auch Übereinstimmung mit Benutzerattribut auswählen. Mit dieser Option können Sie Filter festlegen, die sich basierend auf den Nutzerattributen des Dashboard-Betrachters dynamisch ändern. Weitere Informationen finden Sie auf der Dokumentationsseite Daten filtern und begrenzen.

Übereinstimmung (für Fortgeschrittene)

Wenn Sie im Bereich Filteroptionen konfigurieren auf entspricht erweitert klicken, können Sie einen Looker-Filterausdruck eingeben, um einen Filter mit zusätzlichen Optionen anzupassen, die nicht im Optionsmenü enthalten sind.

In Filtern vom Typ „Übereinstimmung (für Fortgeschrittene)“ kann auch auf Benutzerattribute verwiesen werden. Verwenden Sie hierfür folgende Syntax:

{{ _user_attributes['name_of_your_attribute'] }}

Dashboard-Filter anzeigen

Sie können über verschiedene Optionen ändern, wie Dashboard-Filter angezeigt werden. Sie können die Darstellung von einzelnen Filtersteuerungen oder der gesamten Filterleiste anpassen.

Gestaltung eines einzelnen Filters

Wenn Sie festlegen möchten, wie ein Filter dargestellt wird, muss sich Ihr Dashboard zuerst im Bearbeitungsmodus befinden. Wählen Sie dann im Feld Anzeige des Filterkonfigurationsfensters, das angezeigt wird, wenn Sie im Filtermenü Bearbeiten auswählen, den Darstellungsstil aus. Die meisten Dashboard-Filter können folgendermaßen angezeigt werden:

  • Inline: Der Filter wird direkt in der oberen Dashboard-Leiste angezeigt.

  • Kurzinfo: In der oberen Leiste des Dashboards wird ein Zusammenfassungswert angezeigt. Wählen Sie den Wert aus, um den vollständigen Filter einzublenden.

  • Filter können auch hinter dem Button Mehr platziert werden: In der Filterleiste des Dashboards wird der Button Mehr mit einem Indikator für die Anzahl der enthaltenen Filter der Leiste angezeigt. Betrachter können auf den Button klicken, um die Filter und die dazugehörigen Werte einzublenden.

Einige Filtersteuerelemente können nur in der Inline-Ausrichtung angezeigt werden. Wenn Sie ein Dashboard mit diesen Filtersteuerelementen bearbeiten, wird das Feld Anzeige nicht im Filterkonfigurationsfenster angezeigt. Diese Filtersteuerelemente können nur in der Inline-Ausrichtung angezeigt werden:

  • Drop-down-Menü
  • Einzelner Tag
  • Zeiträume
  • Datumsbereich

Darüber hinaus können einige Filtersteuerelemente nur in der Popover-Ausrichtung angezeigt werden. Wenn Sie ein Dashboard mit diesen Filtersteuerelementen bearbeiten, wird das Feld Anzeige nicht im Filterkonfigurationsfenster angezeigt. Diese Filtersteuerelemente können nur in der Popover-Ausrichtung angezeigt werden:

  • Tag-Liste
  • Erweitert

Grundsätzlich empfehlen wir, dass wichtige oder häufig verwendete Filter als Inline- oder Popover-Filter und weniger häufig genutzte Filter als Überlauf-Filter angezeigt werden.

Gestaltung der Filterleiste

Befolgen Sie diese Schritte, um einzustellen, wie eine Filterleiste angezeigt wird:

  1. Das Dashboard muss sich im Bearbeitungsmodus befinden.
  1. Öffnen Sie das Fenster Einstellungen des Dashboards.
  2. Wählen Sie im Fenster Einstellungen den Tab Filter aus.
  3. Sie können die Option Standard-Filteransicht auf Maximiert oder Minimiert festlegen. Der Standardwert ist Erweitert.
  4. Mit der Option Filterposition können Sie die Filterleiste oben oder rechts im Dashboard platzieren. (Standardmäßig ist „oben“ eingestellt.)

Einen Filterwert verlangen

Standardmäßig verlangen Filter keine Werte. Enthält ein Filter keinen Wert, werden die Daten einfach nicht durch das Filterfeld eingegrenzt. Beispiel: Sie haben in einem Dashboard einen Filter für das Feld Bundesstaat festgelegt. Wenn dieser Filter keinen Wert erhält, übergibt das Dashboard Daten für alle Bundesstaaten.

Ist für einen Filter ein Wert erforderlich, wird das Dashboard erst ausgeführt, wenn Sie einen Filterwert auswählen. Für einen erforderlichen Filter ohne ausgewählten Wert werden Warnungen neben dem Filter und beim Bewegen des Mauszeigers auf das Symbol zum Neuladen angezeigt, bis ein Wert ausgewählt wird.

Darüber hinaus können Sie keinen Dashboard-Zeitplan erstellen, ohne einen Wert für einen erforderlichen Filter auszuwählen, und nicht den Zwischenspeicher leeren oder eine Tile aktualisieren, die mit einem erforderlichen Filter ohne Wert verknüpft ist.

Sie können jedoch festlegen, dass ein Benutzer einen Wert für einen Filter eingeben muss, um das Dashboard ausführen zu können:

  1. Das Dashboard muss sich im Bearbeitungsmodus befinden.
  1. Öffnen Sie das Fenster für die Filterkonfiguration, indem Sie entweder einen neuen Dashboard-Filter hinzufügen oder einen vorhandenen Dashboard-Filter bearbeiten.
  2. Klicken Sie auf den Pfeil neben der Überschrift Zusätzliche Optionen, um die zusätzlichen Optionen einzublenden.
  3. Aktivieren Sie das Kästchen Filterwert verlangen.
  4. Wählen Sie Aktualisieren aus, um die Änderung zu speichern.

Bei Auswahl des Kontrollkästchens Filterwert verlangen müssen Betrachter einfach einen beliebigen Wert auswählen. Um die für einen Betrachter sichtbaren Werte einzuschränken, legen Sie die zulässigen Werte im Feld Werte des Filterkonfigurationsfensters fest.

Mit erforderlichen Filtern können Sie die Größe von Abfragen, die an die Datenbank gesendet werden, verringern. Um den Datenzugriff von Dashboard-Betrachtern einzuschränken, verwenden Sie stattdessen den LookML-Parameter access_filter.

Verknüpfte Filter einrichten

Dashboard-Filter können jetzt verknüpft werden, sodass die Filterwertoptionen für einen Filter basierend auf den Filterwerten eingeschränkt werden, die für einen anderen Filter im gleichen Dashboard ausgewählt wurden.

So können Sie beispielsweise einen Dashboard-Folter für „Ort“ mit einem eigenen Filter für „Bundesstaat“ verknüpfen. Die Filterwertoptionen für „Stadt“ ändern sich in Abhängigkeit von dem im Filter „Bundesstaat“ ausgewählten Bundesstaat beziehungsweise den ausgewählten Bundesstaaten.

Nachdem Sie einen Filterwert für „Bundesstaat“ ausgewählt haben, wird beim Filter „Ort“ ein Verknüpfungssymbol angezeigt. Wenn Sie den Mauszeiger auf das Verknüpfungssymbol bewegen, erscheint ein Feld mit der Erläuterung, dass die Werteoptionen für diesen Filter durch den Filter „Bundesstaat“ eingeschränkt wurden.

Sie können noch weitergehen und einen Filter „Postleitzahl“ zu den Filtern „Ort“ und „Bundesstaat“ hinzufügen und somit die Werteoptionen für „Postleitzahl“ in Abhängigkeit vom ausgewählten „Ort“ und „Bundesstaat“ einschränken. Wenn beispielweise für den Filter „Bundesstaat“ „New Jersey“ angegeben ist und für den Filter „Ort“ „Asbury Park“, wird in der Dropdownliste „Postleitzahl“ nur der Wert für die Postleitzahl in Asbury Park angezeigt.

Wenn Sie Filter verknüpfen und Ihre Daten keine Werte für einen „untergeordneten“ Filter (den Filter, der eingeschränkt werden soll) enthalten, sehen Betrachter für den untergeordneten Filter die Meldung Keine Übereinstimmungen gefunden. Dies gilt für die Werte, die im „übergeordneten“ Filter (dem Filter, der die Optionen des untergeordneten Filters einschränkt) ausgewählt sind.

Verknüpfte Filter funktionieren in eine Richtung, nämlich von Übergeordnet zu untergeordnet. Wenn Sie in einem untergeordneten Filter eine Auswahl treffen, wirkt sich diese nicht auf die Filterwerteoptionen aus, die Ihnen für den übergeordneten Filter angezeigt werden.

Wenn Sie Filter verknüpfen, kann jeder Filter als „übergeordneter“ Filter verwendet werden (der Filter, der die Optionen eines anderen Filters einschränkt). Der „untergeordnete“ Filter (der Filter, der eingeschränkt werden soll) kann jedoch nur ein Feld vom Typ string (wird häufig für Wörter oder Wortgruppen verwendet) oder vom Typ zipcode (wird häufig für Postleitzahlen verwendet) verwenden.

Enthält das Dashboard nur einen Filter, können keine Filter verknüpft werden.

So verknüpfen Sie Filter miteinander:

  1. Das Dashboard muss sich im Bearbeitungsmodus befinden.
  1. Öffnen Sie das Fenster für die Filterkonfiguration für den übergeordneten Filter, indem Sie entweder einen neuen Dashboard-Filter hinzufügen oder einen vorhandenen Dashboard-Filter bearbeiten.
  2. Wählen Sie den Pfeil neben der Überschrift Zusätzliche Optionen aus, um die zusätzlichen Optionen einzublenden.
  3. Aktivieren Sie das Kontrollkästchen Select filters to update when this filter changes.
  4. Wählen Sie das Feld aus, um ein Drop-down-Menü mit den anderen string- und zipcode-Filtern im Dashboard aufzurufen.
  5. Wählen Sie den oder die string- oder zipcode-Filter aus, die Sie mit diesem Filter verknüpfen möchten.
  6. Wählen Sie Aktualisieren aus, um die Änderung zu speichern.

Dashboard-Filter verschieben und neu positionieren

Nachdem Sie Filter auf einem Dashboard abgelegt haben, können Sie diese wie folgt verschieben oder neu positionieren:

  1. Bearbeitungsmodus für das Dashboard aufrufen
  1. Bewegen Sie den Mauszeiger auf den Filter, um das Sechs-Punkte-Symbol des Filters anzuzeigen. Das Sechs-Punkte-Symbol wird oben links im Filter angezeigt.
  2. Halten Sie das Sechs-Punkte-Symbol gedrückt und ziehen Sie den Filter an die gewünschte Position.

    Mit dieser Drag-and-Drop-Methode können Sie Inline- und Popover-Filter neu positionieren, neu konfigurieren, welche Filter hinter dem Button Mehr platziert werden, und Filter im Drop-down-Menü des Buttons Mehr neu positionieren.

    Werden aktuell keine Filter hinter dem Button Mehr angezeigt, wird vorübergehend ein leerer Button Mehr angezeigt, während Sie einen Filter ziehen. Sie können den Filter auf den Button Mehr verschieben, um ihn in den Button Mehr zu verschieben. Wenn Sie den Filter nicht im Button Mehr platzieren, wird er ausgeblendet, sobald Sie ihn loslassen.

Wenn die Kreuzfilterung für ein Dashboard aktiviert ist, können Sie Kreuzfilter nicht per Drag-and-Drop neu positionieren. Wenn Sie den Bearbeitungsmodus aufrufen, werden alle im Dashboard festgelegten Kreuzfilter gelöscht.

Filter als Kacheln

Mit der Funktion Filter als Kacheln können Sie Dashboard-Filter direkt als Kacheln auf der Dashboard-Arbeitsfläche platzieren, anstatt sie auf die Filterleiste oben im Dashboard zu beschränken. Mit dieser Funktion können Dashboard-Ersteller Filtersteuerelemente neben den Visualisierungskacheln platzieren, auf die sie sich auswirken.

Mit Filter als Kacheln können Nutzer außerdem die Liste der Filter aufrufen, die auf eine bestimmte Visualisierungskachel angewendet werden.

Filter als Dashboard-Tiles platzieren

Wenn die Vorschau-Umschaltfläche Filter als Kacheln und Filterkontext auf Kachelebene aktiviert ist, können Dashboard-Bearbeiter Filter auf folgende Weise in ziehbare Kacheln auf dem Dashboard-Canvas umwandeln:

  • So senden Sie einen Filter von der Filterleiste an den Dashboard-Canvas:

    • Ziehen Sie den Filter in der Filterleiste in den Bereich Filter hierher ziehen, um sie dem Dashboard hinzuzufügen.
    • Alternativ können Sie neben dem Filter auf das Dreipunkt-Menü Filtermenü und dann auf An Dashboard senden klicken.
  • So senden Sie einen Filter vom Dashboard-Canvas zurück an die Filterleiste:

    • Klicken Sie auf der Filterkachel auf das Dreipunkt-Symbol Filtermenü und wählen Sie An Filterleiste senden aus.

Ein Bearbeiter kann Filter-Tiles auf dem Dashboard-Canvas genauso wie andere Dashboard-Tiles ziehen und anordnen. Ein Filter kann sich in der oberen Filterleiste oder im Dashboard-Arbeitsbereich befinden. Seine Position hat keinen Einfluss darauf, auf welche Kacheln er angewendet wird.

Ein Filter kann nur einmal im Dashboard angezeigt werden, entweder in der oberen Filterleiste oder im Canvas. Wenn Sie eine Filter-Tile auf einem Dashboard-Canvas duplizieren, wird ein neuer Filter mit einer anderen Filter-ID erstellt.

Beim Duplizieren eines Dashboard-Tabs

Wenn ein Tab einen Filter enthält, der als Kachel platziert ist, wird beim Duplizieren dieses Tabs auch die Filterkachel auf dem neuen Tab dupliziert. Die duplizierte Kachel bleibt dieselbe Filterinstanz und hat dieselbe Filter-ID wie das Original. Wenn Sie also einen Wert in einer Kachel ändern, wird er auch in der anderen aktualisiert.

Deaktivieren des Ein-/Aus-Buttons für die Vorabversion Filter als Kacheln und Filterkontext auf Kachelebene

Wenn Sie die Vorschaltfläche für die Vorschau deaktivieren, werden die folgenden Änderungen vorgenommen:

  • Alle Filter, die zuvor als Kacheln zum Dashboard-Canvas hinzugefügt wurden, werden in der Filterleiste oben im Dashboard angezeigt.
  • Die Filter-Tiles im Dashboard-Canvas werden als leere Tiles angezeigt.
  • Im Bearbeitungsmodus wird auf den leeren Dashboardkacheln ein Hinweis angezeigt, dass es sich um Filterkacheln handelte.

Angewendete Filter für eine Visualisierungskachel anzeigen

Wenn die Vorabversion Filter als Kacheln und Filterkontext auf Tile-Ebene oder Filter für Visualisierungskacheln aktiviert ist, können Betrachter sehen, welche Filter auf eine bestimmte Visualisierungskachel angewendet werden.

So rufen Sie die angewendeten Filter für eine Visualisierungs-Tile auf:

  • Wählen Sie rechts oben in der Kopfzeile des Visualisierungskachels das Filtersymbol Filter einblenden aus.
  • Bewegen Sie den Mauszeiger auf die Visualisierungskachel, wählen Sie das Dreipunkt-Menü Kachelaktionen und dann Filter einblenden aus.

In einem seitlichen Menü werden alle angewendeten Filter und die ausgewählten Werte angezeigt, die in die folgenden Kategorien unterteilt sind:

  • Vis-Filter: Zeigt die Filter an, die direkt auf die Visualisierungskachel angewendet werden (wenn die Funktion Filter auf Visualisierungskacheln in der Vorabversion aktiviert ist).
  • Dashboard-Filter: Hier werden Filter auf Dashboard-Ebene angezeigt, die auf die Kachel angewendet werden. Dazu gehören auch Kreuzfilter.
  • Abfragefilter: Hier werden die Filter angezeigt, die in der zugrunde liegenden Abfrage der Kachel (im Explore oder Look) konfiguriert sind.

Wenn keine relevanten Filter auf die Tile angewendet werden, wird im Menü Keine Filter angezeigt.

Ersteller und Bearbeiter von Dashboards können über die Einstellung für Tile-Filterinformationen auf dem Tab Filter im Fenster Einstellungen des Dashboards konfigurieren, ob und welche Filter auf Visualisierungs-Tiles angezeigt werden:

  • Alle anzeigen: Es werden Filter auf Dashboard-Ebene, Filter auf Abfrageebene (im zugrunde liegenden Explore konfiguriert) und Filter auf Visualisierungsebene angezeigt (wenn die Vorabversion der Funktion Filter auf Visualisierungs-Tiles aktiviert ist).
  • Abfragefilter ausblenden (Standard): Es werden nur Filter auf Dashboard-Ebene und Filter auf Visualisierungsebene angezeigt (wenn die Vorabversion Filter für Visualisierungskacheln aktiviert ist).
  • Nicht anzeigen: Die Option Filter einblenden und das entsprechende Symbol werden nicht in Visualisierungskacheln angezeigt.

Wenn Filter auf Abfrageebene angezeigt werden, verhalten sie sich so:

  • Sie werden mit einem Infosymbol daneben angezeigt, um sie von Filtern auf Dashboard-Ebene zu unterscheiden.
  • Wenn in den Abfragen des zugrunde liegenden Explores komplexe Logik (z. B. AND/OR-Logik) implementiert wurde, wird der Filterkontext unter dem Label Benutzerdefinierter Filter zusammengefasst.

Filter als Kacheln in LookML-Dashboards

Filter als Tiles werden von LookML-Dashboards unterstützt. Filterelemente können im Abschnitt elements des LookML-Dashboard-Codes konfiguriert werden, um sie als Kacheln im Dashboard-Arbeitsbereich zu platzieren. Außerdem steuert ein Konfigurationsparameter für den Filterkontext die Anzeige angewendeter Filter auf Visualisierungskacheln. Wenn dieser Parameter weggelassen wird, werden Abfragefilter standardmäßig ausgeblendet.

Filter für Visualisierungskacheln

Mit der Funktion Filter für Visualisierungskacheln können Dashboard-Ersteller Filter direkt auf einzelnen Visualisierungskacheln platzieren und verwalten, anstatt nur in der Filterleiste oben im Dashboard. Diese Funktion bietet kontextbezogene, lokalisierte Filtersteuerelemente, die ausschließlich für die Kachel gelten, auf der sie konfiguriert werden.

Damit Sie diese Funktion verwenden können, muss ein Looker-Administrator im Admin-Bereich auf der Seite Vorschaufunktionen den Ein/Aus-Schalter Filter für Visualisierungskacheln aktivieren.

Visualisierungskachel einen Filter hinzufügen

Wenn Sie einer Visualisierungskachel Filter hinzufügen möchten, benötigen Sie die Berechtigung zum Bearbeiten des Dashboards. So fügen Sie einer einzelnen Visualisierungskachel direkt einen Filter hinzu:

  1. Das Dashboard muss sich im Bearbeitungsmodus befinden.
  2. Wählen Sie auf der Visualisierungskachel, der Sie einen Filter hinzufügen möchten, in der Kopfzeile der Kachel das Symbol Visualisierungsfilter hinzufügen aus.
  3. Wählen Sie im angezeigten Dialogfeld die Option Filter hinzufügen aus.
  4. Das Fenster Filter hinzufügen wird mit vorab ausgefüllten Feldern aus dem Explore angezeigt, das zum Erstellen der Kachel verwendet wurde. Wählen Sie das Feld aus, nach dem Sie filtern möchten.
  5. Konfigurieren Sie die Filtereinstellungen, z. B. den Filtertitel, den Steuerungstyp und den Standardwert.
  6. Wählen Sie Hinzufügen aus.
  7. Wenn Sie mit der Bearbeitung des Dashboards fertig sind, wählen Sie in der Symbolleiste zum Bearbeiten des Dashboards Speichern aus, um Ihre Änderungen zu speichern und den Bearbeitungsmodus zu beenden.

Das Filter-Steuerelement wird in einer Filterleiste direkt oben auf der Visualisierungskachel angezeigt. Die Filterleiste für Kacheln wird nur angezeigt, wenn Filter für diese Kachel konfiguriert sind.

Mit Filtern auf Visualisierungsebene interagieren und sie organisieren

Dashboard-Betrachter und -Bearbeiter können direkt auf der Tile mit Filtern auf Visualisierungsebene interagieren:

  • Filterwerte vorübergehend aktualisieren: Betrachter können Filterwerte direkt über die Filterleiste der Kachel ändern, ohne die zugrunde liegende Visualisierung zu verdecken.
  • Filter neu anordnen: Wenn sich das Dashboard im Bearbeitungsmodus befindet, können Bearbeiter in der Filterleiste der Kachel auf das Symbol Halten und ziehen, um die Reihenfolge zu ändern klicken und die Maustaste gedrückt halten, um die Anzeigereihenfolge zu ändern.
  • Horizontales Scrollen: Filter auf Visualisierungsebene befinden sich oben auf der Kachel und werden nicht in mehrere Zeilen umgebrochen. Wenn die Anzahl der Filter die Breite der Tile überschreitet, wird in der Filterleiste der Tile eine horizontale Bildlaufleiste angezeigt.

Filter auf Visualisierungsebene bearbeiten oder löschen

Sie benötigen Bearbeitungsberechtigungen für das Dashboard, um Filter in einer Visualisierungskachel zu bearbeiten oder zu löschen. So bearbeiten oder löschen Sie einen Filter in einem Visualisierungskachel:

  1. Das Dashboard muss sich im Bearbeitungsmodus befinden.
  2. Klicken Sie neben dem Filter auf das Dreipunkt-Menü Filter.
  3. Wenn Sie den Filter bearbeiten möchten, wählen Sie Bearbeiten aus. Aktualisieren Sie die Filterkonfiguration im Fenster „Filterkonfiguration“ und wählen Sie dann Aktualisieren aus.
  4. Wenn Sie den Filter löschen möchten, wählen Sie Löschen aus.
  5. Wenn Sie mit der Bearbeitung des Dashboards fertig sind, wählen Sie in der Symbolleiste zum Bearbeiten des Dashboards Speichern aus, um Ihre Änderungen zu speichern und den Bearbeitungsmodus zu beenden.

Überlegungen und Einschränkungen

Beachten Sie bei der Verwendung von Filtern für Visualisierungs-Tiles die folgenden Überlegungen und Einschränkungen:

  • Kachelspezifischer Bereich: Ein Filter auf Visualisierungsebene gilt nur für die spezifische Kachel, auf der er platziert ist. Andere Kacheln im Dashboard sind davon nicht betroffen.
  • Ein Filter pro Feld und Tile: Sie können pro Feld auf jeder Tile nur einen Filter auf Visualisierungsebene hinzufügen. Wenn Sie versuchen, einen weiteren Filter für ein Feld hinzuzufügen, für das auf dieser Kachel bereits ein Filter vorhanden ist, wird in Looker ein Fehler angezeigt.
  • Unterschied zu Filtern auf Dashboard-Ebene: Filter auf Visualisierungsebene können nicht in Filter auf Dashboard-Ebene umgewandelt werden und Filter auf Dashboard-Ebene können nicht direkt auf eine Tile verschoben werden.
  • Von hier aus analysieren: Wenn ein Nutzer im Dreipunkt-Menü Tile-Aktionen der Kachel die Option Von hier aus analysieren auswählt, werden Filter auf Visualisierungsebene nicht in das Explore übernommen (entsprechend Filtern auf Dashboard-Ebene).
  • Exportieren und herunterladen: Wenn Sie ein Dashboard als PDF oder Bild herunterladen oder drucken, werden Filter auf Visualisierungsebene in einem Format erfasst, das auf dem sichtbaren Frame basiert. Wenn eine Filterleiste für Tiles Filter enthält, die über den Bildschirmrand hinausgehen und gescrollt werden müssen, werden nur die auf dem Bildschirm sichtbaren Filter in den Export einbezogen. Die anderen Filter werden abgeschnitten.
  • Dashboard-URLs: Aktive Filterwerte auf Visualisierungsebene werden in der Dashboard-URL erfasst (z. B. mit einer Parametersyntax wie vis_id<id>.<field_name>=<value>). So können Nutzer bestimmte gefilterte Ansichten eines Dashboards freigeben.
  • LookML-Dashboards: In LookML-Dashboards werden Filter auf Visualisierungsebene mit dem Unterparameter vis_filter: true unter dem Parameter filters: angegeben. Bei Standardfiltern auf Dashboard-Ebene ist die Einstellung vis_filter: false nicht erforderlich.

Dashboard-Filter ausblenden

Sie können Dashboard-Filter ausblenden, indem Sie die URL eines Dashboards so ändern, dass sie für jeden Filter, den Sie ausblenden möchten, einen hide_filter-Parameter enthält. Wenn Nutzer über diese URL auf das Dashboard zugreifen, sehen sie eine Version des Dashboards, in der diese Filter ausgeblendet sind. Wenn Nutzer jedoch auf andere Weise zum Dashboard navigieren oder mit einer URL darauf zugreifen, die den Parameter hide_filter nicht enthält, werden Filter nicht ausgeblendet.

Hier ist ein Beispiel für die URL eines Dashboards mit zwei Filtern, die nicht ausgeblendet sind: User State (Bundesstaat des Nutzers) mit dem Filterwert „New Jersey“ und Date (Datum) ohne festgelegten Filterwert.

https://mycompany.looker.com/dashboards/390?User+State=New+Jersey&Date=

Wenn Sie einen Filter ausblenden möchten, fügen Sie der URL den Parameter hide_filter hinzu, dem ein kaufmännisches Und-Zeichen (&) vorangestellt ist und auf den ein Gleichheitszeichen (=) folgt. Geben Sie dem Parameter den Wert des Filternamens, wobei alle Leerzeichen im Namen durch Pluszeichen (+) ersetzt werden. Sie müssen den Filterwert (falls vorhanden) nicht in den Parameter hide_filter aufnehmen.

Wenn Sie nur den Filter Nutzerstatus ausblenden möchten, ändern Sie die URL so:

https://mycompany.looker.com/dashboards/390?User+State=New+Jersey&Date=&hide_filter=User+State

Wenn Sie sowohl den Filter Nutzerstatus als auch den Filter Datum ausblenden möchten, fügen Sie einen weiteren hide_filter-Parameter für den Filter Datum hinzu:

https://mycompany.looker.com/dashboards/390?User+State=New+Jersey&Date=&hide_filter=User+State&hide_filter=Date

Bei Filternamen mit Sonderzeichen wie den Klammern und dem Schrägstrich in First Purchase (Yes / No) (Erster Kauf (Ja/Nein)) werden die Sonderzeichen in der URL codiert:

https://mycompany.looker.com/dashboards/390?First+Purchase+%28Yes+%2F+No%29=

Wenn Sie diesen Filter ausblenden möchten, können Sie den codierten Filternamen, der bereits in der URL vorhanden ist (First+Purchase+%28Yes+%2F+No%29), kopieren und als Wert des Parameters hide_filter verwenden.

Es gibt einige zusätzliche Aspekte, die Sie beim Ausblenden von Dashboard-Filtern beachten sollten:

  • Alle Nutzer mit Lesezugriff auf ein Dashboard können Dashboard-Filter über die URL ausblenden. Der Nutzer benötigt keinen Bearbeitungszugriff auf das Dashboard.
  • Ausgeblendete Dashboard-Filter werden weiterhin auf Dashboard-Ergebnisse angewendet, auch wenn die Filtersteuerelemente im Dashboard nicht sichtbar sind.
  • Die Werte der ausgeblendeten Filter können weiterhin geändert und auf das Dashboard angewendet werden, indem Sie die Werte in der URL ändern.
  • Ausgeblendete Filter können eingeblendet werden, indem die hide_filter-Parameter aus der URL entfernt werden.
  • Im Bearbeitungsmodus werden keine ausgeblendeten Filter angezeigt.
  • Wenn Sie einen erforderlichen Filter ohne Wert ausblenden, werden auf den Dashboard-Tiles Ungültige Filter-Fehler angezeigt. Um einen dieser Fehler zu beheben, weisen Sie dem erforderlichen Filter einen Wert zu.
  • Wenn Dashboards geplant oder gesendet werden, enthalten die in der Lieferung enthaltenen Dashboard-Links nicht den Parameter hide_filter.
  • Wenn Dashboards Benachrichtigungen enthalten, enthalten die in der Benachrichtigungszustellung enthaltenen Dashboard-Links nicht den Parameter hide_filter.

Dashboard-Filter für Warnungen anwenden

Mit dem Menü Filter können Sie Filterbearbeitungen auch auf die auf den Dashboard-Kacheln angezeigten Warnungen anwenden. Weitere Informationen finden Sie in der Dokumentation auf der Seite Auswirkungen von Dashboard-Änderungen auf Benachrichtigungen.

Dashboard-Filter bearbeiten

Im Bearbeitungsmodus wird neben jedem Filter ein Dreipunkt-Symbol für das Filtermenü angezeigt. Klicken Sie zum Bearbeiten eines Filters auf das Symbol. Hierdurch wird das Filtermenü mit Optionen zum Bearbeiten oder Löschen eines Filters geöffnet.

Wählen Sie die Menüoption Bearbeiten aus, um ein Filterkonfigurationsfenster zu öffnen. Dieses weist Ähnlichkeit mit dem Fenster auf, das zum Hinzufügen eines Filters verwendet wird, und enthält die vorhandene Konfiguration für den Filter. Hier können Sie das Feld, nach dem gefiltert wird, die Filtereinstellungen oder die zu aktualisierenden Kacheln aktualisieren. Wählen Sie im Filterkonfigurationsfenster Aktualisieren oder Abbrechen aus, um Ihre Änderungen zu speichern oder zu verwerfen.

Nachdem Sie die Filter bearbeitet haben, klicken Sie auf die Schaltfläche „Aktualisieren“ des Dashboards, um die neuen Filtereinstellungen auf die Kacheln anzuwenden.

Wählen Sie in der Symbolleiste zum Bearbeiten des Dashboards Speichern aus, um die Änderungen zu speichern und den Bearbeitungsmodus zu beenden.

Dashboard-Filter löschen

Im Bearbeitungsmodus wird neben jedem Filter das Dreipunkt-Symbol Filtermenü angezeigt.

So löschen Sie einen Filter:

  1. Wählen Sie das Dreipunkt-Menü Filter aus.
  2. Das Filtermenü wird geöffnet. In diesem Menü werden Optionen zum Bearbeiten oder Löschen eines Filters angezeigt.
  3. Wählen Sie die Menüoption Löschen aus, um den Filter zu löschen.
  4. Wählen Sie in der blauen Symbolleiste Speichern aus, um die Änderungen zu speichern und den Bearbeitungsmodus zu beenden.
  5. Nachdem Sie die Filter gelöscht haben, klicken Sie auf die Schaltfläche „Aktualisieren“ des Dashboards, um die neuen Filtereinstellungen auf die Kacheln anzuwenden.

Alternativ können Sie die Menüoption Bearbeiten wählen, wodurch das Filterkonfigurationsfenster geöffnet wird. Klicken Sie im Filterkonfigurationsfenster auf den Button Löschen, um den Filter zu löschen.

Dieser Löschvorgang kann nicht rückgängig gemacht werden.