Change log for SYNOLOGY
| Date | Changes |
|---|---|
| 2026-09-24 |
Enhancement: - Added a grok pattern on message1 to extract connection_status, client_userid, srcip, bytes_uploaded, bytes_downloaded.- event.idm.read_only_udm.security_result.summary: Newly mapped connection_status raw log field with event.idm.read_only_udm.security_result.summary UDM field.- event.idm.read_only_udm.target.user.userid: Newly mapped client_userid raw log field with event.idm.read_only_udm.target.user.userid UDM field.- event.idm.read_only_udm.principal.ip and event.idm.read_only_udm.principal.asset.ip: Newly mapped srcip raw log field with event.idm.read_only_udm.principal.ip and event.idm.read_only_udm.principal.asset.ip UDM fields.- event.idm.read_only_udm.network.sent_bytes: Newly mapped bytes_uploaded raw log field with event.idm.read_only_udm.network.sent_bytes UDM field.- event.idm.read_only_udm.network.received_bytes: Newly mapped bytes_downloaded raw log field with event.idm.read_only_udm.network.received_bytes UDM field.
|
| 2026-09-03 |
Enhancement: - Added support for JSON format logs. - Added grok patterns to parse new format SYSLOG. - event.idm.read_only_udm.principal.hostname and event.idm.read_only_udm.principal.asset.hostname: Newly mapped hostname raw log field with event.idm.read_only_udm.principal.hostname and event.idm.read_only_udm.principal.asset.hostname UDM fields.- event.idm.read_only_udm.metadata.description: Newly mapped message raw log field with event.idm.read_only_udm.metadata.description UDM field.- event.idm.read_only_udm.principal.application: Newly mapped appname raw log field with event.idm.read_only_udm.principal.application UDM field.- event.idm.read_only_udm.network.received_bytes: Newly mapped downloaded_bytes raw log field with event.idm.read_only_udm.network.received_bytes UDM field.- event.idm.read_only_udm.network.sent_bytes: Newly mapped uploaded_bytes raw log field with event.idm.read_only_udm.network.sent_bytes UDM field.- event.idm.read_only_udm.additional.fields: Newly mapped facility, syslog_priority and priority raw log fields with event.idm.read_only_udm.additional.fields UDM field.- event.idm.read_only_udm.metadata.event_type:- Updated to USER_LOGIN when principal machine data and target user data are present.- Updated to USER_LOGOUT when principal machine data and target user data are present, and the message contains logged out.- Updated to STATUS_UPDATE when principal machine data is present.
|
| 2024-01-16 | - Newly created parser. |