- [Resource: ImageViewsGetResponse](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#ImageViewsGetResponse)
  - [JSON representation](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#ImageViewsGetResponse.SCHEMA_REPRESENTATION)
    - [JSON representation](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#ImageViewsGetResponse.SCHEMA_REPRESENTATION.resource.SCHEMA_REPRESENTATION)
      - [JSON representation](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#ImageViewsGetResponse.SCHEMA_REPRESENTATION.resource.SCHEMA_REPRESENTATION.shielded_instance_initial_state.SCHEMA_REPRESENTATION)
      - [JSON representation](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#ImageViewsGetResponse.SCHEMA_REPRESENTATION.resource.SCHEMA_REPRESENTATION.shielded_instance_initial_state.SCHEMA_REPRESENTATION_1)
      - [JSON representation](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#ImageViewsGetResponse.SCHEMA_REPRESENTATION.resource.SCHEMA_REPRESENTATION.shielded_instance_initial_state.SCHEMA_REPRESENTATION_2)
      - [JSON representation](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#ImageViewsGetResponse.SCHEMA_REPRESENTATION.resource.SCHEMA_REPRESENTATION.shielded_instance_initial_state.SCHEMA_REPRESENTATION_3)
- [Methods](https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews#METHODS_SUMMARY)

## Resource: ImageViewsGetResponse

Response message for ImageViewsService.Get

| JSON representation |
|---|
| ``` { "resource": { "image": { "kind": string, "id": string, "creationTimestamp": string, "name": string, "description": string, "sourceType": enum, "rawDisk": { "source": string, "sha1Checksum": string, "containerType": enum }, "deprecated": { "state": enum, "replacement": string, "deprecated": string, "obsolete": string, "deleted": string }, "status": enum, "archiveSizeBytes": string, "diskSizeGb": string, "sourceDisk": string, "sourceDiskId": string, "licenses": [ string ], "family": string, "imageEncryptionKey": { "rawKey": string, "rsaEncryptedKey": string, "kmsKeyName": string, "sha256": string, "kmsKeyServiceAccount": string }, "sourceDiskEncryptionKey": { "rawKey": string, "rsaEncryptedKey": string, "kmsKeyName": string, "sha256": string, "kmsKeyServiceAccount": string }, "selfLink": string, "labels": { string: string, ... }, "labelFingerprint": string, "guestOsFeatures": [ { "type": enum } ], "licenseCodes": [ string ], "sourceImage": string, "sourceImageId": string, "sourceImageEncryptionKey": { "rawKey": string, "rsaEncryptedKey": string, "kmsKeyName": string, "sha256": string, "kmsKeyServiceAccount": string }, "sourceSnapshot": string, "sourceSnapshotId": string, "sourceSnapshotEncryptionKey": { "rawKey": string, "rsaEncryptedKey": string, "kmsKeyName": string, "sha256": string, "kmsKeyServiceAccount": string }, "storageLocations": [ string ], "shieldedInstanceInitialState": { "pk": { "content": string, "fileType": enum }, "keks": [ { "content": string, "fileType": enum } ], "dbs": [ { "content": string, "fileType": enum } ], "dbxs": [ { "content": string, "fileType": enum } ] }, "satisfiesPzs": boolean, "architecture": enum, "enableConfidentialCompute": boolean, "satisfiesPzi": boolean, "params": { "resourceManagerTags": { string: string, ... } } } }, "etag": string } ``` |

| Fields ||
|---|---|
| `resource` | `object` The Image resource. |
| `resource.image` | `object` The Image resource. |
| `resource.image.kind` | `string` Output only. Type of the resource. Always `compute#image` for images. |
| `resource.image.id` | `string (https://developers.google.com/discovery/v1/type-format format)` Output only. The unique identifier for the resource. This identifier is defined by the server. |
| `resource.image.creationTimestamp` | `string` Output only. Creation timestamp in [RFC3339](https://www.ietf.org/rfc/rfc3339.txt) text format. |
| `resource.image.name` | `string` Name of the resource; provided by the client when the resource is created. The name must be 1-63 characters long, and comply with [RFC1035](https://www.ietf.org/rfc/rfc1035.txt). Specifically, the name must be 1-63 characters long and match the regular expression `[a-z]([-a-z0-9]*[a-z0-9])?` which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash. |
| `resource.image.description` | `string` An optional description of this resource. Provide this property when you create the resource. |
| `resource.image.sourceType` | `enum` The type of the image used to create this disk. The default and only valid value is `RAW`. |
| `resource.image.rawDisk` | `object` The parameters of the raw disk image. |
| `resource.image.rawDisk.source` | `string` The full Google Cloud Storage URL or Artifact Registry path where the raw disk image archive is stored. The following are valid formats: - `https://storage.googleapis.com/bucketName/image_archive_name` - `https://storage.googleapis.com/bucketName/folder_name/image_archive_name` - `projects/project/locations/location/repositories/repo/packages/package/versions/version_id` - `projects/project/locations/location/repositories/repo/packages/package/versions/version_id@dirsum_sha256:hex_value` <br /> In order to create an image, you must provide the full or partial URL of one of the following: - The `rawDisk.source` URL - The `sourceDisk` URL - The `sourceImage` URL - The `sourceSnapshot` URL <br /> |
| `resource.image.rawDisk.sha1Checksum (deprecated)` | `string` \[Deprecated\] This field is deprecated. An optional SHA1 checksum of the disk image before unpackaging provided by the client when the disk image is created. |
| `resource.image.rawDisk.containerType` | `enum` The format used to encode and transmit the block device, which should be `TAR`. This is just a container and transmission format and not a runtime format. Provided by the client when the disk image is created. |
| `resource.image.deprecated` | `object` Output only. The deprecation status associated with this image. |
| `resource.image.deprecated.state` | `enum` The deprecation state of this resource. This can be `ACTIVE`, `DEPRECATED`, `OBSOLETE`, or `DELETED`. Operations which communicate the end of life date for an image, can use `ACTIVE`. Operations which create a new resource using a `DEPRECATED` resource will return successfully, but with a warning indicating the deprecated resource and recommending its replacement. Operations which use `OBSOLETE` or `DELETED` resources will be rejected and result in an error. |
| `resource.image.deprecated.replacement` | `string` The URL of the suggested replacement for a deprecated resource. The suggested replacement resource must be the same kind of resource as the deprecated resource. |
| `resource.image.deprecated.deprecated` | `string` An optional [RFC3339](https://www.ietf.org/rfc/rfc3339.txt) timestamp on or after which the state of this resource is intended to change to `DEPRECATED`. This is only informational and the status will not change unless the client explicitly changes it. |
| `resource.image.deprecated.obsolete` | `string` An optional [RFC3339](https://www.ietf.org/rfc/rfc3339.txt) timestamp on or after which the state of this resource is intended to change to `OBSOLETE`. This is only informational and the status will not change unless the client explicitly changes it. |
| `resource.image.deprecated.deleted` | `string` An optional [RFC3339](https://www.ietf.org/rfc/rfc3339.txt) timestamp on or after which the state of this resource is intended to change to `DELETED`. This is only informational and the status will not change unless the client explicitly changes it. |
| `resource.image.status` | `enum` Output only. The status of the image. An image can be used to create other resources, such as instances, only after the image has been successfully created and the `status` is set to `READY`. Possible values are `FAILED`, `PENDING`, or `READY`. |
| `resource.image.archiveSizeBytes` | `string (https://developers.google.com/discovery/v1/type-format format)` Size of the image `tar.gz` archive stored in Google Cloud Storage (in bytes). |
| `resource.image.diskSizeGb` | `string (https://developers.google.com/discovery/v1/type-format format)` Size of the image when restored onto a persistent disk (in GB). |
| `resource.image.sourceDisk` | `string` URL of the source disk used to create this image. For example, the following are valid values: - `https://www.googleapis.com/compute/v1/projects/project/zones/zone/disks/disk` - `projects/project/zones/zone/disks/disk` - `zones/zone/disks/disk` <br /> In order to create an image, you must provide the full or partial URL of one of the following: - The `rawDisk.source` URL - The `sourceDisk` URL - The `sourceImage` URL - The `sourceSnapshot` URL <br /> |
| `resource.image.sourceDiskId` | `string` Output only. The ID value of the disk used to create this image. This value may be used to determine whether the image was taken from the current or a previous instance of a given disk name. |
| `resource.image.licenses[]` | `string` Any applicable license URI. |
| `resource.image.family` | `string` The name of the image family to which this image belongs. The image family name can be from a publicly managed image family provided by Compute Engine, or from a custom image family you create. For example, `centos-stream-9` is a publicly available image family. For more information, see [Image family best practices](https://cloud.google.com/compute/docs/images/image-families-best-practices). When creating disks, you can specify an image family instead of a specific image name. The image family always returns its latest image that is not deprecated. The name of the image family must comply with [RFC1035](https://www.ietf.org/rfc/rfc1035.txt). |
| `resource.image.imageEncryptionKey` | `object` Encrypts the image using a [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption). After you encrypt an image with a customer-supplied key, you must provide the same key if you use the image later (e.g. to create a disk from the image). Customer-supplied encryption keys do not protect access to metadata of the disk. If you do not provide an encryption key when creating the image, then the disk will be encrypted using an automatically generated key and you do not need to provide a key to use the image later. |
| `resource.image.imageEncryptionKey.rawKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies a 256-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption), encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rawKey": "SGVsbG8gZnJvbSBHb29nbGUgQ2xvdWQgUGxhdGZvcm0=" ``` <br /> |
| `resource.image.imageEncryptionKey.rsaEncryptedKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies an RFC 4648 base64 encoded, RSA-wrapped 2048-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption#rsa-encryption) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rsaEncryptedKey": "ieCx/NcW06PcT7Ep1X6LUTc/hLvUDYyzSZPPVCVPTVEohpeHASqC8uw5TzyO9U+Fka9JFH z0mBibXUInrC/jEk014kCK/NPjYgEMOyssZ4ZINPKxlUh2zn1bV+MCaTICrdmuSBTWlUUiFoD D6PYznLwh8ZNdaheCeZ8ewEXgFQ8V+sDroLaN3Xs3MDTXQEMMoNUXMCZEIpg9Vtp9x2oe==" ``` The key must meet the following requirements before you can provide it to Compute Engine: 1. The key is wrapped using a RSA public key certificate provided by Google. 2. After being wrapped, the key must be encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoding. Gets the RSA public key certificate provided by Google at: ```html https://cloud-certs.storage.googleapis.com/google-cloud-csek-ingress.pem ``` <br /> |
| `resource.image.imageEncryptionKey.kmsKeyName` | `string` The name of the encryption key that is stored in Google Cloud KMS. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key ``` The fully-qualifed key name may be returned for resource GET requests. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key /cryptoKeyVersions/1 ``` <br /> |
| `resource.image.imageEncryptionKey.sha256 (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Output only. The [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoded SHA-256 hash of the [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption) that protects this resource. |
| `resource.image.imageEncryptionKey.kmsKeyServiceAccount` | `string` The service account being used for the encryption request for the given KMS key. If absent, the Compute Engine default service account is used. For example: ```html "kmsKeyServiceAccount": "name@ projectId.iam.gserviceaccount.com/ ``` <br /> |
| `resource.image.sourceDiskEncryptionKey` | `object` The [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption) of the source disk. Required if the source disk is protected by a customer-supplied encryption key. |
| `resource.image.sourceDiskEncryptionKey.rawKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies a 256-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption), encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rawKey": "SGVsbG8gZnJvbSBHb29nbGUgQ2xvdWQgUGxhdGZvcm0=" ``` <br /> |
| `resource.image.sourceDiskEncryptionKey.rsaEncryptedKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies an RFC 4648 base64 encoded, RSA-wrapped 2048-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption#rsa-encryption) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rsaEncryptedKey": "ieCx/NcW06PcT7Ep1X6LUTc/hLvUDYyzSZPPVCVPTVEohpeHASqC8uw5TzyO9U+Fka9JFH z0mBibXUInrC/jEk014kCK/NPjYgEMOyssZ4ZINPKxlUh2zn1bV+MCaTICrdmuSBTWlUUiFoD D6PYznLwh8ZNdaheCeZ8ewEXgFQ8V+sDroLaN3Xs3MDTXQEMMoNUXMCZEIpg9Vtp9x2oe==" ``` The key must meet the following requirements before you can provide it to Compute Engine: 1. The key is wrapped using a RSA public key certificate provided by Google. 2. After being wrapped, the key must be encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoding. Gets the RSA public key certificate provided by Google at: ```html https://cloud-certs.storage.googleapis.com/google-cloud-csek-ingress.pem ``` <br /> |
| `resource.image.sourceDiskEncryptionKey.kmsKeyName` | `string` The name of the encryption key that is stored in Google Cloud KMS. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key ``` The fully-qualifed key name may be returned for resource GET requests. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key /cryptoKeyVersions/1 ``` <br /> |
| `resource.image.sourceDiskEncryptionKey.sha256 (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Output only. The [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoded SHA-256 hash of the [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption) that protects this resource. |
| `resource.image.sourceDiskEncryptionKey.kmsKeyServiceAccount` | `string` The service account being used for the encryption request for the given KMS key. If absent, the Compute Engine default service account is used. For example: ```html "kmsKeyServiceAccount": "name@ projectId.iam.gserviceaccount.com/ ``` <br /> |
| `resource.image.selfLink` | `string` Output only. Server-defined URL for the resource. |
| `resource.image.labels` | `map (key: string, value: string)` Labels to apply to this image. These can be later modified by the `setLabels` method. |
| `resource.image.labelFingerprint` | `string (https://developers.google.com/discovery/v1/type-format format)` A fingerprint for the labels being applied to this image, which is essentially a hash of the labels used for optimistic locking. The fingerprint is initially generated by Compute Engine and changes after every request to modify or update labels. You must always provide an up-to-date fingerprint hash in order to update or change labels, otherwise the request will fail with error `412 conditionNotMet`. To see the latest fingerprint, make a `get()` request to retrieve an image. A base64-encoded string. |
| `resource.image.guestOsFeatures[]` | `object` A list of features to enable on the guest operating system. Applicable only for bootable images. To see a list of available options, see the `guestOSfeatures[].type` parameter. |
| `resource.image.guestOsFeatures[].type` | `enum` The ID of a supported feature. To add multiple values, use commas to separate values. Set to one or more of the following values: - `VIRTIO_SCSI_MULTIQUEUE` - `WINDOWS` - `MULTI_IP_SUBNET` - `UEFI_COMPATIBLE` - `GVNIC` - `SEV_CAPABLE` - `SUSPEND_RESUME_COMPATIBLE` - `SEV_LIVE_MIGRATABLE_V2` - `SEV_SNP_CAPABLE` - `TDX_CAPABLE` - `IDPF` - `SNP_SVSM_CAPABLE` - `CCA_CAPABLE` - `SUSPEND_SAFE_FPR` For more information, see [Enabling guest operating system features](https://docs.cloud.google.com/compute/docs/images/create-delete-deprecate-private-images#guest-os-features). <br /> |
| `resource.image.licenseCodes[]` | `string (https://developers.google.com/discovery/v1/type-format format)` Integer license codes indicating which licenses are attached to this image. |
| `resource.image.sourceImage` | `string` URL of the source image used to create this image. The following are valid formats for the URL: - `https://www.googleapis.com/compute/v1/projects/projectId/global/ images/image_name` - `projects/projectId/global/images/image_name` <br /> In order to create an image, you must provide the full or partial URL of one of the following: - The `rawDisk.source` URL - The `sourceDisk` URL - The `sourceImage` URL - The `sourceSnapshot` URL <br /> |
| `resource.image.sourceImageId` | `string` Output only. The ID value of the image used to create this image. This value may be used to determine whether the image was taken from the current or a previous instance of a given image name. |
| `resource.image.sourceImageEncryptionKey` | `object` The customer-supplied encryption key of the source image. Required if the source image is protected by a customer-supplied encryption key. |
| `resource.image.sourceImageEncryptionKey.rawKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies a 256-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption), encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rawKey": "SGVsbG8gZnJvbSBHb29nbGUgQ2xvdWQgUGxhdGZvcm0=" ``` <br /> |
| `resource.image.sourceImageEncryptionKey.rsaEncryptedKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies an RFC 4648 base64 encoded, RSA-wrapped 2048-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption#rsa-encryption) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rsaEncryptedKey": "ieCx/NcW06PcT7Ep1X6LUTc/hLvUDYyzSZPPVCVPTVEohpeHASqC8uw5TzyO9U+Fka9JFH z0mBibXUInrC/jEk014kCK/NPjYgEMOyssZ4ZINPKxlUh2zn1bV+MCaTICrdmuSBTWlUUiFoD D6PYznLwh8ZNdaheCeZ8ewEXgFQ8V+sDroLaN3Xs3MDTXQEMMoNUXMCZEIpg9Vtp9x2oe==" ``` The key must meet the following requirements before you can provide it to Compute Engine: 1. The key is wrapped using a RSA public key certificate provided by Google. 2. After being wrapped, the key must be encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoding. Gets the RSA public key certificate provided by Google at: ```html https://cloud-certs.storage.googleapis.com/google-cloud-csek-ingress.pem ``` <br /> |
| `resource.image.sourceImageEncryptionKey.kmsKeyName` | `string` The name of the encryption key that is stored in Google Cloud KMS. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key ``` The fully-qualifed key name may be returned for resource GET requests. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key /cryptoKeyVersions/1 ``` <br /> |
| `resource.image.sourceImageEncryptionKey.sha256 (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Output only. The [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoded SHA-256 hash of the [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption) that protects this resource. |
| `resource.image.sourceImageEncryptionKey.kmsKeyServiceAccount` | `string` The service account being used for the encryption request for the given KMS key. If absent, the Compute Engine default service account is used. For example: ```html "kmsKeyServiceAccount": "name@ projectId.iam.gserviceaccount.com/ ``` <br /> |
| `resource.image.sourceSnapshot` | `string` URL of the source snapshot used to create this image. The following are valid formats for the URL: - `https://www.googleapis.com/compute/v1/projects/projectId/global/ snapshots/snapshotName` - `projects/projectId/global/snapshots/snapshotName` <br /> In order to create an image, you must provide the full or partial URL of one of the following: - The `rawDisk.source` URL - The `sourceDisk` URL - The `sourceImage` URL - The `sourceSnapshot` URL <br /> |
| `resource.image.sourceSnapshotId` | `string` Output only. The ID value of the snapshot used to create this image. This value may be used to determine whether the snapshot was taken from the current or a previous instance of a given snapshot name. |
| `resource.image.sourceSnapshotEncryptionKey` | `object` The customer-supplied encryption key of the source snapshot. Required if the source snapshot is protected by a customer-supplied encryption key. |
| `resource.image.sourceSnapshotEncryptionKey.rawKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies a 256-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption), encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rawKey": "SGVsbG8gZnJvbSBHb29nbGUgQ2xvdWQgUGxhdGZvcm0=" ``` <br /> |
| `resource.image.sourceSnapshotEncryptionKey.rsaEncryptedKey (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Specifies an RFC 4648 base64 encoded, RSA-wrapped 2048-bit [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption#rsa-encryption) to either encrypt or decrypt this resource. You can provide either the `rawKey` or the `rsaEncryptedKey`. For example: ```html "rsaEncryptedKey": "ieCx/NcW06PcT7Ep1X6LUTc/hLvUDYyzSZPPVCVPTVEohpeHASqC8uw5TzyO9U+Fka9JFH z0mBibXUInrC/jEk014kCK/NPjYgEMOyssZ4ZINPKxlUh2zn1bV+MCaTICrdmuSBTWlUUiFoD D6PYznLwh8ZNdaheCeZ8ewEXgFQ8V+sDroLaN3Xs3MDTXQEMMoNUXMCZEIpg9Vtp9x2oe==" ``` The key must meet the following requirements before you can provide it to Compute Engine: 1. The key is wrapped using a RSA public key certificate provided by Google. 2. After being wrapped, the key must be encoded in [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoding. Gets the RSA public key certificate provided by Google at: ```html https://cloud-certs.storage.googleapis.com/google-cloud-csek-ingress.pem ``` <br /> |
| `resource.image.sourceSnapshotEncryptionKey.kmsKeyName` | `string` The name of the encryption key that is stored in Google Cloud KMS. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key ``` The fully-qualifed key name may be returned for resource GET requests. For example: ```html "kmsKeyName": "projects/ kms_project_id/locations/ region/keyRings/ key_region/cryptoKeys/key /cryptoKeyVersions/1 ``` <br /> |
| `resource.image.sourceSnapshotEncryptionKey.sha256 (deprecated)` | `string` \[DEPRECATED\] CSEK is no longer supported. Use CMEK instead. Output only. The [RFC 4648 base64](https://tools.ietf.org/html/rfc4648#section-4) encoded SHA-256 hash of the [customer-supplied encryption key](https://docs.cloud.google.com/compute/docs/disks/customer-supplied-encryption) that protects this resource. |
| `resource.image.sourceSnapshotEncryptionKey.kmsKeyServiceAccount` | `string` The service account being used for the encryption request for the given KMS key. If absent, the Compute Engine default service account is used. For example: ```html "kmsKeyServiceAccount": "name@ projectId.iam.gserviceaccount.com/ ``` <br /> |
| `resource.image.storageLocations[]` | `string` Cloud Storage bucket storage location of the image (regional or multi-regional). |
| `resource.image.shieldedInstanceInitialState` | `object` Set the secure boot keys of shielded instance. |
| `resource.image.shieldedInstanceInitialState.pk` | `object` The Platform Key (PK). |
| `resource.image.shieldedInstanceInitialState.pk.content` | `string (https://developers.google.com/discovery/v1/type-format format)` The raw content in the secure keys file. A base64-encoded string. |
| `resource.image.shieldedInstanceInitialState.pk.fileType` | `enum` The file type of source file. |
| `resource.image.shieldedInstanceInitialState.keks[]` | `object` The Key Exchange Key (KEK). |
| `resource.image.shieldedInstanceInitialState.keks[].content` | `string (https://developers.google.com/discovery/v1/type-format format)` The raw content in the secure keys file. A base64-encoded string. |
| `resource.image.shieldedInstanceInitialState.keks[].fileType` | `enum` The file type of source file. |
| `resource.image.shieldedInstanceInitialState.dbs[]` | `object` The Key Database (db). |
| `resource.image.shieldedInstanceInitialState.dbs[].content` | `string (https://developers.google.com/discovery/v1/type-format format)` The raw content in the secure keys file. A base64-encoded string. |
| `resource.image.shieldedInstanceInitialState.dbs[].fileType` | `enum` The file type of source file. |
| `resource.image.shieldedInstanceInitialState.dbxs[]` | `object` The forbidden key database (dbx). |
| `resource.image.shieldedInstanceInitialState.dbxs[].content` | `string (https://developers.google.com/discovery/v1/type-format format)` The raw content in the secure keys file. A base64-encoded string. |
| `resource.image.shieldedInstanceInitialState.dbxs[].fileType` | `enum` The file type of source file. |
| `resource.image.satisfiesPzs` | `boolean` Output only. Reserved for future use. |
| `resource.image.architecture` | `enum` The architecture of the image. Valid values are ARM64 or X86_64. |
| `resource.image.enableConfidentialCompute` | `boolean` Output only. Whether this image is created from a confidential compute mode disk. Output only.: This field is not set by user, but from source disk. |
| `resource.image.satisfiesPzi` | `boolean` Output only. Reserved for future use. |
| `resource.image.params` | `object` Input only. \[Input Only\] Additional params passed with the request, but not persisted as part of resource payload. |
| `resource.image.params.resourceManagerTags` | `map (key: string, value: string)` Input only. Resource manager tags to be bound to the image. Tag keys and values have the same definition as [resource manager tags](https://cloud.google.com/resource-manager/docs/tags/tags-overview). Keys and values can be either in numeric format, such as `tagKeys/{tag_key_id}` and `tagValues/{tag_value_id}` or in namespaced format such as `{org_id|projectId}/{tag_key_short_name}` and `{tag_value_short_name}`. The field is ignored (both PUT \& PATCH) when empty. |
| `etag` | `string` Etag of the resource. |

| ## Methods ||
|---|---|
| ### `https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews/get` | Returns the specified global ImageView resource, with a regional context. |
| ### `https://docs.cloud.google.com/compute/docs/reference/rest/v1/imageViews/list` | Returns a list of global ImageView resources, with a regional context. |