Cloud Code for IntelliJ-Plug-in installieren

Das Cloud Code for IntelliJ-Plug-in fügt der JetBrains-Familie von IDEs, einschließlich IntelliJ (sowohl Community- als auch Ultimate Editionen), GoLand, PyCharm, WebStorm (und anderen), Unterstützung für die Google Cloud Entwicklung hinzu.

Vorbereitung

Die folgenden Tools müssen auf Ihrem System bereits installiert, eingerichtet und in der PATH-Variablen auf Ihrem Computer verfügbar sein:

  • JetBrains-IDE ab Version 2022.3

    Ihre IDE sollte eine JetBrains-IDE sein, zum Beispiel:

    • IntelliJ Ultimate oder Community
    • PyCharm Professional oder Community
    • WebStorm
    • GoLand
  • Git, damit Cloud Code Git-Vorgänge wie das Klonen eines Beispiels ausführen kann.

  • Docker zum Erstellen der Container-Images und Übertragen per Push.

  • Konfigurierter Kubernetes-Cluster, entweder ein Cluster für die lokale Entwicklung, z. B. ein Minikube- oder Docker-Kubernetes-Cluster, oder ein Remotecluster, z. B. ein Google Kubernetes Engine-Cluster. Für die lokale Entwicklung wird ein Minikube-Cluster empfohlen. Minikube kann von Cloud Code automatisch verwaltet werden.

  • Google Cloud **-Projekt** mit aktivierter Abrechnung wenn Sie verwenden Google Cloud. Mit Projekten können Sie alle zugehörigen Ressourcen für eine einzelne Anwendung an einem Ort erfassen sowie APIs verwalten, Dienste aktivieren Google Cloud , Mitbearbeiter hinzufügen und entfernen sowie Berechtigungen für Google Cloud Ressourcen verwalten.

Cloud Code-Plug-in installieren

Installieren Sie das Cloud Code-Plug-in aus dem JetBrains Marketplace.

Alternativ können Sie das Plug-in direkt über Ihre IDE installieren:

  1. Starten Sie Ihre IDE.

  2. Öffnen Sie den Marketplace für Plug-ins Ihrer IDE:

    • Klicken Sie unter Windows auf Datei > Einstellungen > Plug-ins.
    • Klicken Sie unter macOS auf IntelliJ IDEA > Einstellungen > Plug-ins.
  3. Geben Sie im Suchfeld Google Cloud Code ein und installieren Sie dann das Cloud Code-Plug-in.

    Cloud Code-Plug-in im IntelliJ Marketplace

  4. Wenn Sie dazu aufgefordert werden, starten Sie Ihre IDE neu, um das Plug-in zu aktivieren.

  5. Um Konflikte zu vermeiden, wenn Sie Android Studio als IDE verwenden, deaktivieren Sie das Google Cloud Plug-in „Tools for Android Studio“, nachdem Sie Cloud Code installiert haben. Das Google Cloud Plug-in „Tools for Android Studio“ wird bald eingestellt und in einer zukünftigen Version von Android Studio vollständig entfernt.

Verwaltete Abhängigkeiten

Standardmäßig installiert Cloud Code einige erforderliche Befehlszeilenabhängigkeiten automatisch, z. B.:

  • kubectl für die Arbeit mit Kubernetes-Clustern und die Verwaltung von Kubernetes-Deployments.
  • Skaffold zur Unterstützung der kontinuierlichen Entwicklung für einen Kubernetes-Cluster, zum Erstellen und Taggen intelligenter Images sowie für verschiedene unterstützte Deployment- und Build-Typen.
  • **minikube** , für die lokale Entwicklung.
  • gcloud CLI zur Verwaltung von Ressourcen in Google Cloud.

Benutzerdefinierte Versionen von Abhängigkeiten

Wenn Sie benutzerdefinierte Versionen von Abhängigkeiten verwenden möchten, deaktivieren Sie die Abhängigkeitsverwaltung so:

  1. Prüfen Sie, ob Sie benutzerdefinierte Versionen der Abhängigkeiten installiert haben:

  2. Geben Sie die relevanten Cloud Code-Einstellungen in Ihrer IDE an, indem Sie Datei > Einstellungen > Tools > Cloud Code > Abhängigkeiten oder für Mac OS X IntelliJ IDEA > Einstellungen > Tools > Cloud Code > Abhängigkeiten öffnen.

  3. Wenn Sie die gcloud CLI verwalten möchten, wählen Sie im Abschnitt Cloud SDK die Option Benutzerdefinierte lokale Installation verwenden aus, klicken Sie neben dem Feld auf das Ordnersymbol Durchsuchen , wechseln Sie zur gewünschten gcloud CLI-Installation und klicken Sie auf OK.

  4. Wenn Sie andere Abhängigkeiten verwalten möchten, wählen Sie im Abschnitt Bereitstellungstools die Option Benutzerdefinierte Abhängigkeiten verwenden aus, klicken Sie für jede Abhängigkeit auf das Ordnersymbol Durchsuchen, geben Sie einen Pfad zur benutzerdefinierten Version an, die Sie für jede Abhängigkeit verwenden möchten, und klicken Sie auf OK.

Optional: Cloud Code-Binärdatei herunterladen und prüfen

Durch die Überprüfung der Cloud Code-Binärdatei können Sie sicherstellen, dass das Cloud Code-Plug-in im Laufe der Veröffentlichungs- und Bereitstellungspipeline nicht manipuliert wurde.

So laden Sie die stabile oder Insiders-Binärdatei von Cloud Code auf Ihren Computer herunter:

  1. Wählen Sie auf der Seite Plug-in-Versionen von Cloud Code entweder den Kanal Stabil oder Insiders aus.

    Weitere Informationen zum Insiders-Build finden Sie unter Vorabversionen verwenden.

  2. Laden Sie die neueste Version von Cloud Code oder eine Version herunter, die Sie prüfen möchten und die zu den aktuellen Versionen gehört, die die Überprüfung unterstützen:

    • Stabil: Jede Version nach 23.1.1-221/23.1.1-222 (einschließlich 23.1.1-221/23.1.1-222)

    • Insiders: Jede Version nach 23.1.1-221-IB.1/23.1.1-222-IB.1 (einschließlich 23.1.1-221-IB.1/23.1.1-222-IB.1)

  3. Notieren Sie sich den Pfad zu Ihrer Cloud Code-Binärdatei (die Datei google-cloud-code.zip).

So prüfen Sie die Cloud Code-Binärdatei:

  1. Laden Sie die neueste Version der marketplace-zip-signer-cli.jar Datei auf Ihren Computer herunter. Notieren Sie sich den Pfad zu Ihrer jar-Datei.

  2. Laden Sie DigiCert Trusted Root G4 herunter. Notieren Sie sich den Pfad zu Ihrer Zertifikatsdatei.

  3. Prüfen Sie, ob das JDK installiert ist. Dies ist erforderlich, um Java-Befehle auszuführen.

  4. Führen Sie Folgendes in der Befehlszeile aus, um die zip-Datei (die Cloud Code-Binärdatei) zu prüfen:

    java -jar PATH_TO_ZIP_SIGNER_JAR verify -in PATH_TO_ZIP_FILE -cert PATH_TO_CERTIFICATE_FILE
    

    Wenn die Überprüfung fehlschlägt, wird eine der folgenden Meldungen in der Befehlszeilenausgabe angezeigt:

    • Zip archive is not signed by provided certificate authority.
    • Provided zip archive is not signed.
    • Signature of zip archive is invalid.

    Wenn in der Befehlszeilenausgabe keine Meldung angezeigt wird, war die Überprüfung erfolgreich.

Support kontaktieren

So senden Sie Feedback oder melden ein Problem in Ihrer IntelliJ-IDE: Klicken Sie auf Tools > Cloud Code > Hilfe / Info > Feedback geben oder ein Problem melden, um ein Problem auf GitHub zu melden.