Le plug-in Cloud Code pour IntelliJ rend compatible le développement Google Cloud vers les IDE de la famille JetBrains, y compris IntelliJ (éditions Community et Ultimate), GoLand, PyCharm, WebStorm (et autres).
Prérequis
Les outils suivants doivent être installés et configurés sur votre système, et être disponibles sur le PATH de votre ordinateur :
IDE JetBrains version 2022.3+
Votre IDE doit être l'un des IDE JetBrains suivants :
- IntelliJ Ultimate ou Community
- PyCharm Professional ou Community
- WebStorm
- GoLand
Git pour que Cloud Code puisse effectuer des opérations Git, comme cloner un exemple.
Docker pour créer et transmettre vos images de conteneurs.
Cluster Kubernetes configuré, qui peut être un cluster de développement local, tel qu'un cluster Minikube ou Docker Kubernetes, ou un cluster distant, tel qu'un cluster Google Kubernetes Engine. Un cluster Minikube est recommandé pour le développement local. Minikube peut être géré automatiquement par Cloud Code.
Un Google Cloud projet avec facturation activée si vous utilisez Google Cloud. Les projets vous permettent de collecter toutes les ressources associées à une seule application au même endroit, de gérer les API, d'activer les services Google Cloud, d'ajouter et de supprimer des collaborateurs, et de gérer les autorisations pour les ressourcesGoogle Cloud .
Installer le plug-in Cloud Code
Installez le plug-in Cloud Code depuis JetBrains Marketplace.
Vous pouvez également installer le plug-in directement depuis votre IDE :
Lancez votre IDE.
Ouvrez la place de marché des plug-ins de votre IDE :
- Pour Windows, accédez à File > Settings > Plugins (Fichier > Paramètres > Plug-ins).
- Pour macOS, accédez à IntelliJ IDEA > Preferences > Plugins (IntelliJ IDEA > Préférences > Plug-ins).
Saisissez
Google Cloud Codedans le champ de recherche, puis installez le plug-in Cloud Code.
Si vous y êtes invité, redémarrez votre IDE pour activer le plug-in.
Pour éviter tout conflit si vous utilisez Android Studio comme IDE, désactivez le plug-in Google Cloud Tools for Android Studio après avoir installé Cloud Code. Le plug-in Google Cloud Tools for Android Studio sera bientôt obsolète et sera complètement supprimé dans une prochaine version d'Android Studio.
Versions personnalisées des dépendances
Par défaut, Cloud Code installe automatiquement certaines dépendances de ligne de commande requises. Pour utiliser des versions personnalisées des dépendances, désactivez la gestion des dépendances comme suit :
Assurez-vous d'avoir installé des versions personnalisées des dépendances :
- kubectl
- Skaffold
- minikube pour le développement local
- Google Cloud CLI si vous développez avec Google Cloud
Spécifiez les paramètres Cloud Code pertinents dans votre IDE en ouvrant Fichier > Paramètres > Outils > Cloud Code > Dépendances ou, pour Mac OS X, IntelliJ IDEA > Préférences > Outils > Cloud Code > Dépendances.
Pour gérer la gcloud CLI, dans la section Cloud SDK, sélectionnez Use a custom local installation (Utiliser une installation locale personnalisée), cliquez sur l'icône de dossier Parcourir à côté du champ, accédez à l'installation de la gcloud CLI que vous souhaitez utiliser, puis cliquez sur OK.
Pour gérer d'autres dépendances, dans la section Outils de déploiement, sélectionnez Utiliser des dépendances personnalisées, cliquez sur l'icône de dossier Parcourir pour chaque dépendance, spécifiez un chemin d'accès à la version personnalisée que vous souhaitez utiliser pour chaque dépendance, puis cliquez sur OK.
Facultatif : Télécharger et valider le binaire Cloud Code
La vérification du binaire Cloud Code permet de s'assurer que le plug-in Cloud Code n'a pas été falsifié au cours du pipeline de publication et de distribution.
Pour télécharger le binaire Stable ou Insiders de Cloud Code sur votre machine, procédez comme suit :
Sur la page Versions du plug-in de Cloud Code, sélectionnez le canal Stable ou Insiders.
Pour en savoir plus sur la version Insiders, consultez Utiliser les fonctionnalités en version préliminaire.
Téléchargez la dernière version de Cloud Code ou une version que vous souhaitez vérifier et qui fait partie des versions actuelles compatibles avec la vérification :
Stable : toutes les versions après le
23.1.1-221/23.1.1-222(23.1.1-221/23.1.1-222non inclus)Insiders : toutes les versions après
23.1.1-221-IB.1/23.1.1-222-IB.1(23.1.1-221-IB.1/23.1.1-222-IB.1non inclus)
Notez le chemin d'accès à votre binaire Cloud Code (fichier
google-cloud-code.zip).
Pour valider le binaire Cloud Code, procédez comme suit :
Téléchargez la dernière version du fichier
marketplace-zip-signer-cli.jarsur votre ordinateur. Notez le chemin d'accès à votre fichierjar.Téléchargez DigiCert Trusted Root G4. Notez le chemin d'accès à votre fichier de certificat.
Assurez-vous d'avoir installé le JDK. Cette opération est requise pour exécuter les commandes Java.
Pour valider le fichier
zip(le binaire Cloud Code), exécutez la commande suivante dans votre ligne de commande :java -jar PATH_TO_ZIP_SIGNER_JAR verify -in PATH_TO_ZIP_FILE -cert PATH_TO_CERTIFICATE_FILESi la validation échoue, l'un des messages suivants s'affiche dans le résultat de la ligne de commande :
Zip archive is not signed by provided certificate authority.Provided zip archive is not signed.Signature of zip archive is invalid.
Si aucun message ne s'affiche dans le résultat de la ligne de commande, cela signifie que la validation a réussi.