收集 Trend Micro Email Security 記錄

支援的國家/地區:

本文說明如何使用 Bindplane,將 Trend Micro Email Security 記錄擷取至 Google Security Operations。Trend Micro Email Security 是一種雲端電子郵件閘道,可在垃圾郵件、惡意軟體、網路釣魚、勒索軟體和進階目標式攻擊進入使用者信箱前,保護機構免受侵擾。這項服務提供網址篩選、附件沙箱和資料遺失防護功能,可保護電子郵件的傳入和傳出流量。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體。
  • 搭載 systemd 的 Windows 2016 以上版本或 Linux 主機。
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟。
  • 具備 Trend Micro Email Security 管理控制台的特殊存取權。

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案

    • 將檔案安全地儲存在要安裝 Bindplane 的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
    

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
    

其他安裝資源

如需其他安裝選項,請參閱這份安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

  1. 存取設定檔:

    • 找出 config.yaml 檔案。通常位於 Linux 的 /etc/bindplane-agent/ 目錄,或 Windows 的安裝目錄。
    • 使用文字編輯器 (例如 nanovi 或記事本) 開啟檔案。
  2. 按照下列方式編輯 config.yaml 檔案:

    receivers:
      tcplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: YOUR_CUSTOMER_ID
        endpoint: malachiteingestion-pa.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'TRENDMICRO_EMAIL_SECURITY'
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - tcplog
          exporters:
            - chronicle/chronicle_w_labels
    
  • 視基礎架構需求,替換通訊埠和 IP 位址。
  • YOUR_CUSTOMER_ID 替換為實際的客戶 ID。
  • /path/to/ingestion-authentication-file.json 更新為您在步驟 1 中儲存驗證檔案的檔案路徑。

重新啟動 Bindplane 代理程式,以套用變更

  1. 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 如要在 Windows 中重新啟動 Bindplane 代理程式,可以使用「服務」控制台,也可以輸入下列指令:

    net stop observiq-otel-collector && net start observiq-otel-collector
    

設定 Trend Micro Email Security 系統記錄轉送

如要設定 Trend Micro Email Security,透過 Syslog 將記錄轉送至 Bindplane 代理程式,請按照下列步驟操作:

  1. 登入 Trend Micro Email Security 管理控制台。
  2. 依序前往「管理」>「系統記錄設定」
  3. 按一下「新增」,建立新的系統記錄伺服器設定檔。

  4. 請提供下列設定詳細資料:

    • 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 通訊埠:輸入 514 (或在 Bindplane 代理程式中設定的通訊埠)。
    • 「通訊協定」:選取「TCP」
    • 格式:選取「CEF」(通用事件格式)
  5. 在「記錄類型」部分,選取要轉送的記錄類別:

    • 政策事件 - 電子郵件篩選政策動作。
    • 垃圾內容偵測 - 垃圾郵件和灰色郵件事件。
    • 惡意軟體偵測 - 病毒和惡意軟體偵測事件。
    • 勒索軟體偵測 - 勒索軟體偵測事件。
    • 網址分析 - 網址點擊和點擊時間保護事件。
    • 進階威脅防護 - 沙盒分析事件。
    • 資料遺失防護 - 違反 DLP 政策的事件。
    • 內容篩選 - 內容篩選規則事件。
  6. 按一下 [儲存]

  7. 按一下「測試連線」,確認記錄是否已傳送至 Bindplane 代理程式。

  8. 查看 Bindplane 代理程式記錄,確認記錄是否已送達。

詳情請參閱 Trend Micro Email Security 說明文件

UDM 對應表

記錄欄位 UDM 對應 邏輯
additional_cn1 additional.fields 已合併
additional_cs1 additional.fields 已合併
additional_cs2 additional.fields 已合併
additional_cs3 additional.fields 已合併
additional_cs4 additional.fields 已合併
additional_cs5 additional.fields 已合併
additional_cs6 additional.fields 已合併
message extensions.auth.type 已對應:loginAUTHTYPE_UNSPECIFIED
msg metadata.description 直接對應
rt metadata.event_timestamp 剖析為 ISO8601
cs1 metadata.event_type 已對應:phishingSCAN_UNCATEGORIZED
message metadata.event_type 對應:CEF:0GENERIC_EVENTloginUSER_LOGIN
cs1 metadata.product_event_type 直接對應
network_direction network.direction 對應:INCOMINGINBOUNDOUTGOINGOUTBOUND
cs2 principal.hostname 直接對應
principal_ip principal.hostname 直接對應
principal_ip principal.ip 已合併
message principal.user.userid 已對應:logintarget.user.userid
suser principal.user.userid 直接對應
act security_result.action 對應:ALLOWactDENYsecurity_result_actionQUARANTINEact
security_result_action security_result.action 已合併
act security_result.action_details 直接對應
cs5 security_result.rule_name 直接對應
severity security_result.severity 對應:"0", "1", "2", "3", "LOW"LOW、`"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"...
cs6 target.url 直接對應
duser target.user.email_addresses 已對應:;emailId
emailId target.user.email_addresses 已合併
duser target.user.userid 直接對應
principal.user.userid target.user.userid 已重新命名/對應
不適用 extensions.auth.type 常數:AUTHTYPE_UNSPECIFIED
不適用 metadata.event_type 常數:GENERIC_EVENT
不適用 network.direction 常數:INBOUND
不適用 principal.user.userid 常數:target.user.userid
不適用 security_result.severity 常數:LOW

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。