收集 Semperis DSP 記錄

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 Semperis Directory Services Protector (DSP) 記錄檔擷取至 Google Security Operations。

Semperis Directory Services Protector (DSP) 是 Active Directory 威脅偵測和應變平台,可監控 AD 變化和攻擊,提供即時警示和自動修復功能。剖析器會從 DSP 記錄檔項目中擷取欄位,並對應至 Unified Data Model (UDM),擷取 AD 物件修改、驗證事件、DNS 變更和安全性結果。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Semperis DSP 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備管理員權限,可存取 Semperis DSP 管理主控台

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案
  4. 將檔案安全地儲存在要安裝 Bindplane 的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        tcplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/semperis_dsp:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: SEMPERIS_DSP
            raw_log_field: body
    
    service:
        pipelines:
            logs/semperis_dsp:
                receivers:
                    - tcplog
                exporters:
                    - chronicle/semperis_dsp
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • tcplog:根據通訊協定的接收器類型:
      • udplog (適用於 UDP 系統記錄檔)
      • tcplog 適用於 TCP Syslog
      • syslog 適用於 RFC 3164/5424 syslog
    • 0.0.0.0:要接聽的 IP 位址:
      • 0.0.0.0,監聽所有介面 (建議)
      • 在一個介面上接聽的特定 IP 位址
    • 514:要接聽的通訊埠號碼 (例如 51415146514)
  • 匯出工具設定:

    • <customer_id>:先前步驟中的客戶 ID
    • malachiteingestion-pa.googleapis.com:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點
    • 根據平台調整 creds_file_path
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄中是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄中是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Semperis DSP 系統記錄檔轉送功能

  1. 登入 Semperis DSP 管理控制台。
  2. 依序前往「設定」> SIEM 整合
  3. 啟用 Syslog 轉送功能。
  4. 請提供下列設定詳細資料:
    • 主機:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 「Port」(通訊埠):輸入 514 (必須與 Bindplane 接收器通訊埠相符)。
    • 通訊協定:選取「TCP」 (必須與 Bindplane 接收器類型相符)。
  5. 按一下 [儲存]

UDM 對應表

記錄欄位 UDM 對應 邏輯
event_type extensions.auth.type 如果 ObjectModificationType ==「LoginADSM」,則設為「SSO」
主機 intermediary.hostname 直接複製值
ObjectModificationType metadata.description 直接複製值
event_type metadata.event_type 如果 ObjectModificationType ==「CreateObject」且 OriginatingUsers !=「」,則設為 RESOURCE_CREATION;如果 ObjectModificationType ==「ModifyObject」且 OriginatingUsers !=「」且 AttributeName 包含「Password」,則設為 RESOURCE_WRITTEN;如果 ObjectModificationType ==「ModifyObject」且 OriginatingUsers !=「」,則設為 RESOURCE_WRITTEN;如果 ObjectModificationType ==「DeleteObject」且 OriginatingUsers !=「」,則設為 RESOURCE_DELETION;如果 ObjectModificationType ==「LoginADSM」且 OriginatingUsers !=「」,則設為 USER_LOGIN;如果 ObjectModificationType ==「OperationRequest」且 OriginatingUsers !=「」,則設為 RESOURCE_WRITTEN;如果 principal_present ==「true」,則設為 STATUS_UPDATE;如果 principal_user_present ==「true」,則設為 USER_UNCATEGORIZED;否則設為 GENERIC_EVENT
metadata.product_name 設為「SEMPERIS_DSP」
metadata.vendor_name 設為「SEMPERIS」
StringValueFrom network.dns.answers.data 清除後直接複製值
NameNode network.dns.answers.name 直接複製值
Ttl network.dns.answers.ttl 直接複製值,並轉換為 uinteger
類型 network.dns.answers.type 如果 Type =~ "DNS_TYPE_A",則設為「1」;如果 Type =~ "DNS_TYPE_PTR",則設為「12」,並轉換為 uinteger
OriginatingServer principal.asset.hostname 直接複製值
ip principal.asset.ip 驗證及清理後直接複製值
OriginatingServer principal.hostname 直接複製值
ip principal.ip 驗證及清理後直接複製值
DistinguishedName principal.user.group_identifiers 直接合併值
ForestId principal.user.product_object_id 直接複製值
OriginatingUsers principal.user.userid 如果 OperationType !=「LoginADSM」,則直接複製值
security_action security_result.action 直接複製值
RequestedAction security_result.summary 如果 OperationResult =~「Granted」或「Denied」,則直接複製值
AttributeName target.resource.name 如果 AttributeName != "" 且 AttributeName != "isDeleted",則直接複製值
ClassName target.resource.resource_subtype 直接複製值
OriginatingUsers target.user.userid 如果 OperationType ==「LoginADSM」,則直接複製值

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。