收集 F5 VPN 日志
本文档介绍了如何使用 Bindplane 代理将 F5 VPN 日志注入到 Google Security Operations。
F5 BIG-IP Access Policy Manager (APM) 是一种 VPN 和访问管理解决方案,可针对用户身份验证、会话管理、政策评估、隧道建立和网络访问事件生成 syslog 消息。解析器会从 syslog 格式的日志中提取字段,并将其映射到统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 F5 BIG-IP 设备之间的网络连接
- 如果通过代理运行,请确保防火墙端口已根据 Bindplane 代理要求打开
- 对 F5 BIG-IP tmsh(版本 11.x 或更高版本)的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件。
将文件安全地保存在将要安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 RUNNING。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为有效(正在运行)。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/f5_vpn: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: F5_VPN raw_log_field: body service: pipelines: logs/f5_vpn_to_chronicle: receivers: - udplog exporters: - chronicle/f5_vpn
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0侦听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:提取身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDendpoint:区域端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重新启动。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
在 F5 BIG-IP APM 上配置 syslog 转发
- 连接到 F5 BIG-IP 命令行。
打开 tmsh shell:
tmsh运行以下命令,配置远程 Syslog 服务器:
modify sys syslog remote-servers add { <Name> { host <bindplane-ip> remote-port <bindplane-port> } }替换以下内容:
<Name>:此 syslog 目的地的唯一名称(例如bindplane_server)。<bindplane-ip>:Bindplane 代理主机 IP 地址。<bindplane-port>:在 Bindplane 代理接收器中配置的端口(默认值:514)。
保存配置:
save sys config partitions all
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
cmd_data |
principal.process.command_line |
该值提取自 msg 字段 |
errdefs_msgno |
additional.fields.errdefs_msgno.string_value |
该值提取自 msg 字段 |
event_time |
metadata.event_timestamp |
系统会解析该值并将其转换为时间戳 |
hostname |
principal.hostname,、observer.hostname,、principal.asset.hostname,、observer.asset.hostname, |
该值从消息字段中提取,用于填充 UDM 中的主机名字段。还用于填充 hostip 字段 |
msg |
security_result.description |
该值从消息字段中提取,并用于填充 security_result 对象中的说明字段 |
prin_ip |
principal.ip,,principal.asset.ip |
该值从消息字段中提取,用于填充 UDM 中的 IP 地址字段 |
additional.fields.Canonical_Info.string_value |
该值派生自日志消息 | |
additional.fields.IDP.string_value |
该值派生自日志消息 | |
additional.fields.Plugin_Support.string_value |
该值派生自日志消息 | |
additional.fields.SMB,Stage.string_value |
该值派生自日志消息 | |
additional.fields.SP.string_value |
该值派生自日志消息 | |
additional.fields.Timezone.string_value |
该值派生自日志消息 | |
additional.fields.Tunnel,Type.string_value |
该值派生自日志消息 | |
additional.fields.UI_Mode.string_value |
该值派生自日志消息 | |
additional.fields.Version.string_value |
该值派生自日志消息 | |
additional.fields.from_rule_item.string_value |
该值派生自日志消息 | |
additional.fields.policy_result.string_value |
该值派生自日志消息 | |
additional.fields.ppp_id.string_value |
该值派生自日志消息 | |
additional.fields.resource.string_value |
该值派生自日志消息 | |
additional.fields.rule.string_value |
该值派生自日志消息 | |
additional.fields.server_vip_ip.string_value |
该值派生自日志消息 | |
additional.fields.server_vip_name.string_value |
该值派生自日志消息 | |
additional.fields.to_rule_item.string_value |
该值派生自日志消息 | |
additional.fields.tunnel_resource.string_value |
该值派生自日志消息 | |
metadata.description |
该值派生自日志消息 | |
metadata.event_type |
对于某些事件,该值在解析器代码中是硬编码的,而对于其他事件,该值则派生自日志消息 | |
metadata.log_type |
该值设置为批处理类型 | |
metadata.product_event_type |
该值派生自日志消息 | |
metadata.product_name |
该值在解析器代码中是硬编码的 | |
metadata.vendor_name |
该值在解析器代码中是硬编码的 | |
network.application_protocol |
该值派生自日志消息 | |
network.direction |
该值派生自日志消息 | |
network.http.method |
该值派生自日志消息 | |
network.http.parsed_user_agent |
该值派生自 network.http.user_agent 字段 | |
network.http.referral_url |
该值派生自日志消息 | |
network.http.response_code |
该值派生自日志消息 | |
network.http.user_agent |
该值派生自日志消息 | |
network.ip_protocol |
该值派生自日志消息 | |
network.received_bytes |
该值派生自日志消息 | |
network.sent_bytes |
该值派生自日志消息 | |
network.session_id |
该值派生自日志消息 | |
network.tls.cipher |
该值派生自日志消息 | |
network.tls.version |
该值派生自日志消息 | |
observer.asset.hostname |
该值设置为主机名字段 | |
observer.asset.ip |
该值会设为 hostip 字段 | |
observer.hostname |
该值设置为主机名字段 | |
observer.ip |
该值会设为 hostip 字段 | |
principal.application |
该值派生自日志消息 | |
principal.asset.hostname |
该值设置为主机名字段 | |
principal.asset.ip |
如果存在,则将该值设置为 hostip 字段或 prin_ip 字段 | |
principal.asset.product_object_id |
该值派生自日志消息 | |
principal.hostname |
该值设置为主机名字段 | |
principal.ip |
如果存在,则将该值设置为 hostip 字段或 prin_ip 字段 | |
principal.location.country_or_region |
该值派生自日志消息 | |
principal.platform |
该值派生自日志消息 | |
principal.port |
该值派生自日志消息 | |
principal.process.command_line |
该值派生自日志消息 | |
principal.process.pid |
该值派生自日志消息 | |
principal.resource.name |
该值派生自日志消息 | |
principal.resource.type |
对于某些事件,该值在解析器代码中是硬编码的,而对于其他事件,该值则派生自日志消息 | |
principal.user.email_addresses |
该值派生自日志消息 | |
principal.user.userid |
该值派生自日志消息 | |
security_result.action |
该值派生自日志消息 | |
security_result.description |
该值派生自日志消息 | |
security_result.rule_name |
该值派生自日志消息 | |
security_result.severity |
该值派生自日志消息 | |
security_result.severity_details |
该值派生自日志消息 | |
security_result.summary |
该值派生自日志消息 | |
src.ip |
该值派生自日志消息 | |
src.location.country_or_region |
该值派生自日志消息 | |
src.port |
该值派生自日志消息 | |
target.asset.hostname |
该值派生自日志消息 | |
target.asset.ip |
该值派生自日志消息 | |
target.hostname |
该值派生自日志消息 | |
target.ip |
该值派生自日志消息 | |
target.port |
该值派生自日志消息 | |
target.process.command_line |
该值派生自日志消息 | |
target.process.pid |
该值派生自日志消息 | |
target.resource.id |
该值派生自日志消息 | |
target.url |
该值派生自日志消息 | |
target.user.userid |
该值派生自日志消息 |
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。