收集 Aruba Central 記錄
支援的國家/地區:
Google SecOps
SIEM
本文說明如何使用 Bindplane 代理程式,將 HPE Aruba Networking Central 記錄檔擷取至 Google SecOps。剖析器會從 Aruba Central syslog 格式的記錄檔中擷取欄位。它會使用 grok 和/或 kv 剖析記錄訊息,然後將這些值對應至統合式資料模型 (UDM)。並為事件來源和類型設定預設中繼資料值。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- 搭載
systemd的 Windows 2016 以上版本或 Linux 主機 - 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- Aruba Central Management 管理控制台的特殊存取權
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
- 複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安裝資源
如需其他安裝選項,請參閱這份安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
存取設定檔:
- 找出
config.yaml檔案。通常位於 Linux 的/etc/bindplane-agent/目錄,或 Windows 的安裝目錄。 - 使用文字編輯器 (例如
nano、vi或記事本) 開啟檔案。
- 找出
按照下列方式編輯
config.yaml檔案:receivers: udplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <customer_id> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'ARUBA_CENTRAL' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labels- 視基礎架構需求,替換通訊埠和 IP 位址。
- 將
<customer_id>替換為實際的客戶 ID。 - 將
/path/to/ingestion-authentication-file.json更新為您在步驟 1 中儲存驗證檔案的檔案路徑。
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector如要在 Windows 中重新啟動 Bindplane 代理程式,可以使用「服務」主控台,或輸入下列指令:
net stop observiq-otel-collector && net start observiq-otel-collector
在 Aruba Central 上設定 Syslog
- 登入 Aruba Central 網頁 UI。
- 在資訊主頁中,找出包含要設定裝置的群組,或將篩選器設為「所有裝置」,以進行全域設定。
- 按一下要設定的裝置或群組。
- 依序前往「Configuration」>「System」>「Logging」。
- 找到「系統記錄伺服器」部分,然後按一下「+」按鈕。
- 伺服器名稱:輸入不重複的描述性名稱。
- 伺服器 IP:輸入 Bindplane 代理程式 IP 位址。
- 伺服器通訊埠:輸入 Bindplane 代理程式通訊埠號碼。
- 記錄格式:選取 Syslog。
- 類別和設施:選取要傳送記錄的類別和設施。
- 「記錄層級」:選取「資訊」。
- 按一下「儲存設定」。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
additional_amm |
additional.fields |
已合併 |
additional_nid |
additional.fields |
已合併 |
additional_setting_id |
additional.fields |
已合併 |
additional_webhook |
additional.fields |
已合併 |
dev_type_label |
additional.fields |
已合併 |
operation_label |
additional.fields |
已合併 |
datetime |
metadata.event_timestamp |
已剖析為 RFC 3339 |
timestamp |
metadata.event_timestamp |
已剖析為 RFC 3339 |
event_type |
metadata.event_type |
直接對應 |
alert_type |
metadata.product_event_type |
直接對應 |
event_data |
metadata.product_event_type |
直接對應 |
id |
metadata.product_log_id |
直接對應 |
details.__base_url |
metadata.url_back_to_product |
直接對應 |
network_ssid |
network.session_id |
直接對應 |
app |
principal.application |
直接對應 |
cluster_hostname |
principal.asset.hostname |
直接對應 |
host |
principal.asset.hostname |
直接對應 |
princ_mac |
principal.asset.mac |
已合併 |
details.group_name |
principal.group.group_display_name |
直接對應 |
details.group |
principal.group.product_object_id |
直接對應 |
cluster_hostname |
principal.hostname |
直接對應 |
host |
principal.hostname |
直接對應 |
princ_mac |
principal.mac |
已合併 |
pid |
principal.process.pid |
直接對應 |
cid |
principal.user.product_object_id |
直接對應 |
details.user |
principal.user.userid |
直接對應 |
device_id |
principal.user.userid |
直接對應 |
labels |
security_result.about.labels |
已合併 |
description |
security_result.description |
直接對應 |
state_label |
security_result.detection_fields |
已合併 |
severity |
security_result.severity |
對應值 (共 5 個,例如 "LOG_INFO", "LOG_DEBUG" → LOW、LOG_WARN → MEDIUM、`LOG_... |
details.config_change |
security_result.summary |
直接對應 |
target_mac |
target.asset.mac |
已合併 |
target_mac |
target.mac |
已合併 |
alert_type |
target.resource.type |
已對應:DEVICE_CONFIG_CHANGE_DETECTED → DEVICE |
target_userid |
target.user.userid |
直接對應 |
userid |
target.user.userid |
直接對應 |
| 不適用 | metadata.product_name |
常數:ARUBA_CENTRAL |
| 不適用 | metadata.vendor_name |
常數:ARUBA CENTRAL |
| 不適用 | security_result.severity |
常數:LOW |
| 不適用 | target.resource.type |
常數:DEVICE |
nid" , "setting_id" , "details.dev_type" , "webhook" and "operation |
additional.fields |
從變更記錄對應 |
details.labels |
security_result.about.labels |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。