收集 Aruba Central 日志
支持:
Google SecOps
SIEM
本文档介绍了如何使用 Bindplane 代理将 HPE Aruba Networking Central 日志注入到 Google SecOps 中。解析器会从 Aruba Central syslog 格式的日志中提取字段。它使用 grok 和/或 kv 解析日志消息,然后将这些值映射到统一数据模型 (UDM)。它会为事件来源和类型设置默认元数据值。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- 搭载
systemd的 Windows 2016 或更高版本或 Linux 主机 - 如果通过代理运行,请确保防火墙端口按照 Bindplane 代理要求处于开放状态
- 对 Aruba Central Management 控制台的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
- 从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安装
- 打开具有根权限或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安装资源
如需了解其他安装选项,请参阅此安装指南。
配置 Bindplane 代理以注入 Syslog 并发送到 Google SecOps
访问配置文件:
- 找到
config.yaml文件。通常,该文件位于 Linux 上的/etc/bindplane-agent/目录或 Windows 上的安装目录中。 - 使用文本编辑器(例如
nano、vi或记事本)打开该文件。
- 找到
按如下方式修改
config.yaml文件:receivers: udplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <customer_id> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'ARUBA_CENTRAL' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labels- 根据基础架构的需要替换端口和 IP 地址。
- 将
<customer_id>替换为实际的客户 ID。 - 将
/path/to/ingestion-authentication-file.json更新为在第 1 步中保存身份验证文件的文件路径。
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector如需在 Windows 中重启 Bindplane 代理,您可以使用服务 控制台,也可以输入以下命令:
net stop observiq-otel-collector && net start observiq-otel-collector
在 Aruba Central 上配置 Syslog
- 登录 Aruba Central Web 界面。
- 在信息中心内,找到包含要配置的设备 的群组 ,或者将过滤器设置为所有设备 以进行全局设置。
- 点击要配置的设备或群组。
- 依次前往配置 > 系统 > 日志记录。
- 找到 Syslog 服务器 部分,然后点击 + 按钮。
- 服务器名称:输入一个唯一且具有描述性的名称。
- 服务器 IP:输入 Bindplane 代理 IP 地址。
- 服务器端口:输入 Bindplane 代理端口号。
- 日志记录格式:选择 Syslog。
- 类别和设施:选择要发送日志的类别和设施。
- 日志记录级别:选择信息。
- 点击 Save Settings (保存设置)。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
additional_amm |
additional.fields |
已合并 |
additional_nid |
additional.fields |
已合并 |
additional_setting_id |
additional.fields |
已合并 |
additional_webhook |
additional.fields |
已合并 |
dev_type_label |
additional.fields |
已合并 |
operation_label |
additional.fields |
已合并 |
datetime |
metadata.event_timestamp |
解析为 RFC 3339 |
timestamp |
metadata.event_timestamp |
解析为 RFC 3339 |
event_type |
metadata.event_type |
直接映射 |
alert_type |
metadata.product_event_type |
直接映射 |
event_data |
metadata.product_event_type |
直接映射 |
id |
metadata.product_log_id |
直接映射 |
details.__base_url |
metadata.url_back_to_product |
直接映射 |
network_ssid |
network.session_id |
直接映射 |
app |
principal.application |
直接映射 |
cluster_hostname |
principal.asset.hostname |
直接映射 |
host |
principal.asset.hostname |
直接映射 |
princ_mac |
principal.asset.mac |
已合并 |
details.group_name |
principal.group.group_display_name |
直接映射 |
details.group |
principal.group.product_object_id |
直接映射 |
cluster_hostname |
principal.hostname |
直接映射 |
host |
principal.hostname |
直接映射 |
princ_mac |
principal.mac |
已合并 |
pid |
principal.process.pid |
直接映射 |
cid |
principal.user.product_object_id |
直接映射 |
details.user |
principal.user.userid |
直接映射 |
device_id |
principal.user.userid |
直接映射 |
labels |
security_result.about.labels |
已合并 |
description |
security_result.description |
直接映射 |
state_label |
security_result.detection_fields |
已合并 |
severity |
security_result.severity |
映射的值(共 5 个,例如 "LOG_INFO", "LOG_DEBUG" → LOW,LOG_WARN → MEDIUM,`LOG_... |
details.config_change |
security_result.summary |
直接映射 |
target_mac |
target.asset.mac |
已合并 |
target_mac |
target.mac |
已合并 |
alert_type |
target.resource.type |
已映射:DEVICE_CONFIG_CHANGE_DETECTED → DEVICE |
target_userid |
target.user.userid |
直接映射 |
userid |
target.user.userid |
直接映射 |
| 不适用 | metadata.product_name |
常量:ARUBA_CENTRAL |
| 不适用 | metadata.vendor_name |
常量:ARUBA CENTRAL |
| 不适用 | security_result.severity |
常量:LOW |
| 不适用 | target.resource.type |
常量:DEVICE |
nid" , "setting_id" , "details.dev_type" , "webhook" and "operation |
additional.fields |
从更改日志映射 |
details.labels |
security_result.about.labels |
从更改日志映射 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。