window.first
支援的國家/地區:
window.first(values_to_sort_by, values_to_return)
說明
這項彙整函式會傳回字串值,該值衍生自比對時間範圍內相關聯 int 值最低的事件。舉例來說,您可以在比對視窗中,從時間戳記最低的事件 (最早的事件) 取得使用者 ID。
參數資料類型
INT、STRING
傳回類型
STRING
程式碼範例
在比對視窗中,從相關性最低的 int 值事件衍生字串值。
// This rule sets the outcome $first_event to the lowest correlated int value
// in the 5 minute match window.
events:
$e.user.userid = $userid
match:
$userid over 5m
outcome:
$first_event = window.first($e.metadata.timestamp.seconds, $e.metadata.event_type) // yields v1 if the events in the match window are 1, 2 and 3 and corresponding values v1, v2, and v3.