sample_rate

支援的國家/地區:
optimization.sample_rate(byteOrString, rateNumerator, rateDenominator)

說明

這個函式會根據確定性取樣策略,判斷是否要納入事件。這個函式會傳回:

  • 輸入值的分數,相當於 (rateNumerator / rateDenominator),表示事件應納入樣本。true
  • false,表示不應將事件納入樣本。

這項函式適用於只想處理部分事件的優化情境。等同於:

hash.fingerprint2011(byteOrString) % rateDenominator < rateNumerator

參數資料類型

  • byteOrString:評估結果為 BYTESTRING 的運算式。
  • rateNumerator: 'INT'
  • rateDenominator: 'INT'

傳回類型

BOOL

程式碼範例

events:
    $e.metadata.event_type = "NETWORK_CONNECTION"
    $asset_id = $e.principal.asset.asset_id
    optimization.sample_rate($e.metadata.id, 1, 5) // Only 1 out of every 5 events

  match:
    $asset_id over 1h

  outcome:
    $event_count = count_distinct($e.metadata.id)
  // estimate the usage by multiplying by the inverse of the sample rate
    $usage_past_hour = sum(5.0 * $e.network.sent_bytes)

 condition:
  // Requiring a certain number of events after sampling avoids bias (e.g. a
  // device with just 1 connection will still show up 20% of the time and
  // if we multiply that traffic by 5, we'll get an incorrect estimate)
  $e and ($usage_past_hour > 1000000000) and $event_count >= 100