sample_rate

נתמך ב:
optimization.sample_rate(byteOrString, rateNumerator, rateDenominator)

תיאור

הפונקציה הזו קובעת אם לכלול אירוע על סמך אסטרטגיית דגימה דטרמיניסטית. הפונקציה מחזירה:

  • ‫true עבור חלק מערכי הקלט, ששווה ל- (rateNumerator / rateDenominator), מציין שהאירוע צריך להיכלל במדגם.
  • ‫false שמציין שהאירוע לא צריך להיכלל במדגם.

הפונקציה הזו שימושית בתרחישי אופטימיזציה שבהם רוצים לעבד רק קבוצת משנה של אירועים. שווה ערך ל:

hash.fingerprint2011(byteOrString) % rateDenominator < rateNumerator

סוגי נתונים של פרמטרים

  • byteOrString: ביטוי שהערך המחושב שלו הוא BYTE או STRING.
  • rateNumerator: 'INT'
  • rateDenominator: 'INT'

סוג הערך שמוחזר

BOOL

דוגמת קוד

events:
    $e.metadata.event_type = "NETWORK_CONNECTION"
    $asset_id = $e.principal.asset.asset_id
    optimization.sample_rate($e.metadata.id, 1, 5) // Only 1 out of every 5 events

  match:
    $asset_id over 1h

  outcome:
    $event_count = count_distinct($e.metadata.id)
  // estimate the usage by multiplying by the inverse of the sample rate
    $usage_past_hour = sum(5.0 * $e.network.sent_bytes)

 condition:
  // Requiring a certain number of events after sampling avoids bias (e.g. a
  // device with just 1 connection will still show up 20% of the time and
  // if we multiply that traffic by 5, we'll get an incorrect estimate)
  $e and ($usage_past_hour > 1000000000) and $event_count >= 100